コンポーネントフォルダとアイテムの操作
Altium Essentials: Workspace Folder Structure
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- コンポーネントタイプとデフォルトフォルダーによって、新しいコンポーネントの保存先がどのように決まるかを理解します。
- 列、グループ化、並べ替え、フィルターを使用してコンポーネントビューをカスタマイズする方法と、ライブラリの健全性ビューでコンポーネントの健全性に関する問題を確認する方法を学びます。
- マルチパートコンポーネントのプレビューと配置の方法、およびワークスペースのコンポーネントを配置する際にパラメーターの表示を制御する方法を確認します。
コンポーネントフォルダータイプのコントロール
Componentsタイプのフォルダーにまだコンポーネントが含まれていない場合は、フォルダーへのコンポーネントの追加を支援するコントロールがここに表示されます。
これらのコントロールを使用して、適切な操作を実行します。
- Import Library – クリックすると、Windows標準のOpenダイアログが開き、ローカルフォルダーまたはネットワークフォルダーに保存されているデータベースライブラリまたはファイルベースのライブラリを選択できます。ライブラリファイルを開くと、選択したライブラリが読み込まれた状態で、シンプルモードのLibrary Importerが起動します。
- Create Component – クリックすると、Component Editorが単一コンポーネント編集モードで開き、新しいコンポーネントを定義できます。
- Create Other Item Type – クリックすると、Create New Itemダイアログが開き、任意のタイプの新しいアイテムを作成できます。
フォルダーにコンポーネントが含まれているかどうかにかかわらず、これらの操作は、パネル右上のAdd Componentボタンに関連付けられたメニューのオプションからも実行できます。
ライブラリ健全性ビュー
接続されたAltium 365 Workspaceのコンテンツを参照する際、ExplorerパネルからLibrary Healthビューにアクセスして、健全性チェックの実行やコンポーネントの健全性に関する問題の確認ができます。パネルのServer Folder領域でLibrary Healthエントリーを選択すると、パネル内にこのビューが表示されます。

ExplorerパネルからアクセスしたLibrary Healthビュー
ビューの上部には、最後に実行した健全性チェックに基づくコンポーネントの健全性の概要が表示されます。その下には、サポートされている健全性チェックの分析項目が、さまざまなIssue Themesにまとめられて表示されます。健全性チェックの分析タイルをクリックすると、チェックの詳細な説明と解決手順(用意されている場合)、およびその健全性チェックに不合格となったすべてのコンポーネントの詳細な一覧が表示されます。
コンポーネントビュー
Componentsタイプのフォルダーは、Classic ViewとComponents Viewの2つの表示モードをサポートしています。後者は、このフォルダータイプのデフォルトビューで、現在のフォルダー内のすべてのコンポーネントに関連付けられているパラメトリックデータを参照できます。さらに、コンポーネントのフォルダーごとにビューを好みに合わせて設定でき、その設定はセッション間で保持されます。
これら2つの表示モードを切り替えるには、Explorerパネルでコンポーネントフォルダーを開き、コンポーネント一覧の右上にある
ボタンをクリックして、表示されるメニューからView » Classic ViewまたはView » Components Viewコマンドを選択します。

コンポーネントタイプのフォルダーでComponents Viewにアクセスすると、コンポーネントがパラメトリックデータに基づいて表示されます。画像にカーソルを合わせると、Classic Viewに戻した結果を確認できます。
Components Viewの操作の詳細については、以下のセクションを参照してください。
列の表示の制御
ビュー内の各列は、特定のパラメーターに対応しています。表示する列、つまり表示するパラメトリック情報は、Select Columnsダイアログで設定します。このダイアログにアクセスするには、列ヘッダー領域内を右クリックし、表示されるコンテキストメニューからSelect Columnsコマンドを選択します。

Select Columnsダイアログでは、Components Viewに表示するパラメトリックデータをまとめて設定できます。
Options and Controls of the Select Columns Dialog:
- Search - テキストボックスに文字を入力して列の一覧を絞り込み、入力した文字を名前に含む列のみを表示します。
-
Visibility column - 一番左の列では、Explorerパネルで列を表示するかどうかを制御します。目のアイコンをクリックすると、列の表示(
) と非表示(
)を切り替えられます。表示される列は、常にダイアログの上部に一覧表示されます。
- Column Name - この列には、Explorer パネルでの列名のタイトルが表示されます。
- Up / Down - これらのボタンは、現在選択されている列を一覧内で上下に移動するために使用します。その結果、 OK をクリックすると、Explorer パネル内でその列が左右に移動します。順序を変更できるのは、表示されている列のみです。
-
- クリックしてドロップダウンを開き、グリッド領域の絞り込みに使用する項目を選択します。
列の順序とサイズ
列の順序はカスタマイズできます。列のヘッダーをクリックし、目的の新しい位置まで水平方向にドラッグします。配置可能な位置は、縦向きの位置指定矢印で示されます。
並べ替え
列ヘッダーをクリックすると、その列を基準にパラメーターを並べ替えることができます。1回クリックすると、その列の内容に基づいて昇順に並べ替えられます。もう一度クリックすると、降順に並べ替えられます。
複数の列を基準に並べ替えることもできます。特定の列でパラメーターを並べ替えた状態で、別の列に対してShift+Clickすると、その列の内容に基づいてさらに並べ替えることができます。
列に基づくフィルタリング
Excelのスプレッドシートと同様に、各列の内容によってパラメーターをさらに絞り込むことができます。 これを行うには、列ヘッダーにカーソルを合わせると右側に表示される小さな漏斗(フィルター)アイコン(
)をクリックします。その列に含まれる各値のチェックボックスを備えたメニューが表示されます。必要なチェックボックスをオンにしてからOKをクリックすると、選択した値を持つパラメーターだけがリストに表示されます。
列フィルターが適用されると、フィルターアイコンが青色(
)で表示され、その列に基づくフィルタリングが適用されていることを示します。フィルタリングは複数のデータ列に適用できます。各「列フィルター」は、全体のフィルター内でAND条件として組み合わされます。現在適用されているフィルタリングの条件は、領域の下部にテキストで表示されます。
マルチパートコンポーネントのサポート
マルチパートコンポーネントのシンボルを表示すると、Previewアスペクトビュータブでは、固有のシンボルグラフィックを持つ各パートが個別のタブとして表示されます。また、Placeメニューには、そのコンポーネントで配置可能なすべてのパートを含むサブメニューが表示されます。
コンポーネント配置時のパラメーターの表示制御
Workspaceライブラリのコンポーネントを(Componentsまたは Explorerパネルから)配置する際、それらのコンポーネントに関連付けられたパラメーター、より正確にはその値の表示/非表示は、親フォルダーのプロパティダイアログで制御します。
親フォルダーを右クリックし、Propertiesコマンドを選択します。Edit Folderダイアログが表示されます。右側のConfigure Parameters Visibility on Addオプションを有効にします。フォルダー内のすべてのコンポーネントから取得されたパラメーターが、領域内に一覧表示されます。各パラメーターに対応するVisible On Addチェックボックスを使用して、そのパラメーターを持つコンポーネントを回路図シートに配置したときの表示/非表示を制御します。

コンポーネントを設計に配置したときに、どのパラメーターを表示するかをフォルダーレベルで設定します。
コンポーネントのパラメーター情報をクリップボードにコピー
コンポーネントのリビジョンのパラメーター情報をクリップボードにコピーし、設計内の別の場所で使用したり、外部アプリケーション(Microsoft Excelなど)に貼り付けたりできます。Component ItemのリビジョンのPreviewアスペクトビュータブを参照しているときに、ビューのParameters領域で必要なパラメーターを選択し、Ctrl+Cキーボードショートカットを使用するか、領域内を右クリックしてコンテキストメニューのCopyコマンドを使用します。

Component Itemのリビジョンのパラメーター情報をクリップボードにコピーし、必要に応じて別の場所で使用します。
リリース済みコンポーネントのタイプをその場で変更
リリース後でも、1つまたは複数のコンポーネントのタイプを、その場でまったく異なるタイプに変更できます。Explorerパネルで変更するコンポーネントのリビジョンを選択し、右クリックしてコンテキストメニューからOperations » Change component typeコマンドを選択します。Choose component typeダイアログが表示され、新しいコンポーネントタイプを選択できます。

リリース済みのコンポーネントアイテムの選択したリビジョンについて、コンポーネントタイプを変更する例。この機能をわかりやすく示すため、最初に誤ったタイプを設定しています。
コンポーネントの検索
Explorerパネルには、強力な検索機能が用意されています。一般的な検索に加え、保存済みの検索設定を使用した絞り込み検索も実行できます。後者では、特定のコンポーネントタイプでコンポーネントを検索できるほか、範囲検索も利用できます。範囲検索は、単位を認識するコンポーネントパラメーターのデータ型によって実現される便利な検索機能です。このデータ型は、参照先のコンポーネントテンプレートを通じてサポートされます。また、保存済みの検索にキーボードショートカットを追加すると、Explorerパネルの外からでもすばやく検索を実行できます。
検索の前提条件
Related pages: コンポーネントとライブラリの構築と管理、コンポーネントテンプレート
コンポーネントを検索する際に、Explorerパネルの検索機能を十分に理解し、すべての機能を活用するには、次の要件を満たす必要があります。
-
Altium Designerを実行し、そのインストールの一部としてComponent Template EditorおよびExplorerのソフトウェア拡張機能がインストールされていることを確認します。
-
ワークスペースコンポーネントの保存にワークスペースを使用している必要があります。
-
単位を認識するコンポーネントパラメーターのデータ型をサポートするコンポーネントテンプレートを参照してコンポーネントを作成していない場合は、コンポーネントを編集し、ワークスペースに再保存する必要があります。これは、次の手順で行えます。
- コンポーネントを編集し、一時的に開かれるコンポーネントエディターでその定義にアクセスします。
-
以下を含むコンポーネントテンプレート(CMPT)を作成してリリースします。
- シンボルおよびプライマリフットプリントのデフォルトリビジョン(そのコンポーネントですでに使用されているもの)。
-
ComponentTypeシステムパラメーターのデフォルト値を適切に設定します(汎用抵抗器を編集する場合は
Resistorsなど)。さまざまな定義済みコンポーネントタイプが用意されており、必要に応じて新しいタイプを作成することもできます。 - そのコンポーネントに現在定義されているすべてのコンポーネントパラメーターに一致するコンポーネントパラメーターを定義します。これにより、パラメーターを重複させることなく、既存の値を保持できます。
-
関連するパラメーター(
Value、Tolerance、Powerなど)について、データ型を適切に設定し、単位を認識できるようにします。単位を認識するコンポーネントパラメーターのデータ型は、複数サポートされています。
- このコンポーネントテンプレートを、編集中のコンポーネントに割り当てます。コンポーネントエディターをSingle Component Editingモードで使用している場合は、Advanced Settingsの下のTemplateフィールドから割り当てます。Batch Component Editingモードで使用している場合は、Required Models/Parameters領域に関連付けられたAdd » Templatesサブメニューから割り当てます。
- 赤色で表示されているパラメーター(値が無効、または必須に指定されているものの未定義のパラメーター)の値を調整します。
- コンポーネントの次のリビジョンとして、ワークスペースにコミットします。
検索機能へのアクセス
検索機能のインターフェースであるSearchビューには、Explorerパネルの左下にあるSearchタブをクリックしてアクセスします。このビューは、次の画像に示す3つの主要な要素で構成されています。それぞれについては、画像の後で詳しく説明します。

Searchビュー — Explorerパネル内の専用ユーザーインターフェース。
- 一般検索フィールド — 標準的な検索を行えます。検索文字列を入力し、Enterを押します。
- 保存済みの検索 — 再利用できるように保存可能な絞り込み検索を行えます。この検索では、コンポーネントをタイプ別に検索できるほか、単位を認識するパラメーターの値に基づく高度な検索も行えます。
- 検索結果。
保存済み検索の作成
新しい保存済み検索を作成するには、Saved Searches領域内を右クリックし、コンテキストメニューからNewを選択します。検索を定義するためのNew Searchダイアログが表示されます。
このダイアログで、次のようにコンポーネント検索を設定します。
-
Saved Search Nameを使用して、検索にわかりやすい名前(
Resistorsなど)を付けます。 -
検索にすばやくアクセスするため、必要に応じてキーボードShortcutを定義します(フィールド内をクリックしてから、目的のショートカットキーをキーボードで押して入力します)。
-
Content Typeフィールドを
Componentに設定します。ドロップダウンリストには、ワークスペースでサポートされるすべてのコンテンツタイプが表示されます(ほかのコンテンツタイプに基づく検索も作成できます)。
ワークスペース内のコンポーネントを検索するには、Content Typeフィールドのドロップダウンから「コンポーネント」を選択します。 -
Parameters領域で、必要に応じて検索パラメーターを設定します。
Componentコンテンツタイプで検出されたすべてのパラメーターが一覧表示されます。各パラメーターについて、次の3つのオプションを定義できます。-
Show Filter – 有効にすると、Search タブのSearch Results 領域の上に、そのパラメーターに対応するフィルターフィールドが表示されます。このフィールドでパラメーターの値の条件を指定することで、検索を細かく調整できます。
-
Default Visibility – 有効にすると、Search タブのSearch Results 領域に、そのパラメーターの列がデフォルトで表示されます。パラメーターデータの列は、ビューから直接、いつでも表示または非表示に切り替えられます。
-
Parameter - パラメーターの名前です。システムパラメーターまたはユーザーパラメーターを指定できます。範囲検索を使用するには、割り当てられたコンポーネントテンプレートでパラメーターを定義し、単位を認識する特定のデータ型に設定する必要があります。
-
Type - パラメーターのデータ型です。範囲検索を行う場合は、パラメーターを単位対応のデータ型に設定する必要があります。この設定はコンポーネントテンプレートでのみ行うことができ、コンポーネント定義をリリースする前に、そのテンプレートをコンポーネントライブラリに割り当てる必要があります。
-
Default Value – このフィールドを使用して、パラメーターの値を特定の値または範囲に制限します。フィールドの内容に対して文字列検索が実行され、1文字(
?)および複数文字(*)のワイルドカード(
)を使用できます。

検索パラメーターの定義例。
-
-
Workspaceのすべてのユーザーが保存済み検索を表示して使用できるようにするには、Publicオプションを有効にしておきます。自分だけが使用できる非公開の検索にするには、このオプションを無効にします。
必要に応じて検索を定義したら、Addボタンをクリックします。検索は、ビューのSaved Searches領域にあるGeneric Searchの下にエントリーとして保存されます。
保存済み検索の適用
保存済み検索は、次の方法で適用できます。
- 新しく定義した検索でAddをクリックするか、既存の検索を変更した後にSaveをクリックすると、検索が自動的に適用されます。
- Saved Searches領域で検索を選択し、Enterを押します。
- 割り当てられたショートカットを使用して目的の保存済み検索に切り替え、Enterを押します。
- 保存済み検索のエントリーをダブルクリックします。
定義された検索条件に基づいてコンポーネントがフィルタリングされ、対応する検索結果領域に結果が表示されます。適用した保存済み検索に、Show Filterオプションが有効なパラメーターが含まれている場合、結果リストの上に、そのパラメーター専用のフィールドが表示されます。

定義した保存済み検索(Resistors)を適用した後の結果の例。この検索にはShow Filterオプションが有効なパラメーターが4つあるため、それらのフィールドが検索インターフェースの一部として表示されています。
フィルターフィールドが表示されているパラメーターについては、次の操作が可能です。
-
検索の定義でパラメーターのデフォルト値が指定されている場合、そのフィールドには最初からその値が入力され、検索の適用時にその値が使用されます。
-
フィールドに直接入力することで、パラメーターに新しい値(特定の値または範囲)を指定できます。
必要に応じて調整し、Enterを押して変更後のフィルタリングを適用します。
保存済み検索の編集
既存の保存済み検索を変更するには、Saved Searches領域で検索を選択し、右クリックしてコンテキストメニューからEditを選択します。Edit: [<SavedSearchName>]ダイアログが表示され、必要に応じて検索を変更できます。
変更後、Saveボタンをクリックすると、新しい設定に従って検索が適用されます。
保存済み検索の削除
既存の保存済み検索を削除するには、Saved Searches領域で検索を選択し、右クリックしてコンテキストメニューからDeleteを選択します。続いて表示される確認ダイアログでYesをクリックすると、保存済み検索の一覧からその検索が削除されます。








)。