Cross-probing & Selecting Objects between the Schematics and PCB in Altium Designer

 

Altium provides various powerful cross-probing and cross-selecting capabilities enabling fast, efficient navigation between schematic and PCB design domains. The Cross-Probing and Cross Selecting features are powerful search tools to help locate objects in other editors by selecting the object in the current editor.

Cross-probing is used to point to a chosen object on the current document then "jump to" its corresponding counterpart in the target document. Between the PCB and schematic editors, full cross-probing support is provided for documents, components, buses, nets, and pins/pads(s). Literally, with a single click, you can select a supported object in either domain and see it highlighted in both. 

Cross selecting enables you to select an object(s) on the source document and by enabling the cross select command, the same object(s) will be selected on the target document. 

Unified Data Model And Project Compilation

A Unified Data Model (UDM) is automatically created in the computer’s memory. The UDM models every aspect of the design, including the components, the connectivity, the component footprints, the relationships between the PCB project and a connected FPGA project, etc. It is this Unified Data Model that enables cross-probing functionality between different design domains. Cross-probing features use auto-compilation, ensuring the very latest model of the data is being used. Dynamic compilation also can be performed manually at any time by clicking Project » Validate PCB Project. This function checks for logical, electrical, and drafting errors between the UDM and compiler settings.

In versions of the software prior to Altium Designer 20.0, the project had to be manually compiled to build the Unified Data Model. Since then, the design data model is incrementally updated after each user operation through dynamic compilation - creating what is referred to as the Dynamic Data Model (DDM). There is no manual compilation of the project involved, it is all done automatically. The design connectivity model is incrementally updated after each user operation, courtesy of dynamic compilation.

Document Setup

Many of the features of Cross-Probing and Cross Selecting either require, or are more easily utilized, viewing both the schematic and PCB documents at the same time. You can view both documents at the same time by performing one of the following:

  • Right-click on the document tab then select Split Vertical or Split Horizontal depending on your viewing preference.
To close the split screen view, right-click on the document tab then select Merge All.
  • If you are using more than one screen, you can drag the document tab onto another monitor. 

Cross-Probing

Cross-probing is a powerful searching tool to help locate objects in other editors by selecting the object in the current editor. There are numerous places you can cross probe in Altium Designer. For example, once you have launched cross probing from the PCB editor, you can click on a component on the PCB to display the same component on the schematic. Between the schematic and PCB editors, full cross-probing support is provided for documents, components, buses, nets, and pins/pads.

The cross-probing feature is accessed from either the schematic or PCB editor using the Tools » Cross Probe command or by clicking the  button from an editor's Standard toolbar. 

The cross-probed objects on the target document will be displayed in accordance with the Highlight Methods defined on the System - Navigation page of the Preferences dialog. Highlighting will not be applied to the originating document.
In order to perform cross-probing, ensure that the source schematic and PCB documents for the project are open as tabbed documents in the main design window. 

There are two cross-probing modes, Continuous Mode and Jump-To Mode, which are both described in the following sections.

Continuous Cross-Probing Mode

The Continuous Mode allows you to stay in the source document while cross-probing to different objects on the target document. For this mode, ensure that the schematic and PCB documents are open side-by-side in the main design window.

After launching the cross-probe command by clicking Tools » Cross Probe, the cursor will change to a cross-hair and you will be prompted to choose the object that you wish to navigate. Position the cursor over the required object within the design space and click or press Enter. The corresponding object will be highlighted on the target document.

Cross-probing from the source (e.g., schematic) with corresponding object highlighted on the PCB.Cross-probing from the source (e.g., schematic) with corresponding object highlighted on the PCB.

You can continue to cross-probe additional objects or right-click or press Esc to exit.

  • When using Continuous Mode, if you have not opened the schematic and PCB documents side-by-side, you will have to make the PCB document active to view the results of the cross-probe.
  • When using Continuous Mode repeatedly, the last object you choose is the one displayed/highlighted. Cross-probe filtering is not cumulative.

Jump To Cross-Probing Mode

The Jump To Mode allows you to cross-probe to a single object and make the target document the active document. 

After launching the cross-probe command by clicking Tools » Cross Probe, the cursor will change to a cross-hair and you will be prompted to choose the object that you wish to navigate. Position the cursor over the required object within the workspace then Ctrl+click or press Ctrl+Enter. The corresponding object will be highlighted on the target document which will be made the active document.

Cross-Probing from Additional Locations in Altium Designer

Cross-probing also can be accomplished in various additional places in Altium Designer. These additional locations enable you to use the cross-probe function even as you are building your design without the need to use the Tools » Cross Probe command.

Probing Within the Engineering Change Order Dialog

You can cross probe from the Engineering Change Order dialog by right-clicking to access cross probe commands to locate the Reference component in the schematic or the target component in the PCB as shown in the image below:

Probing Within the Differences Between Dialog

The Differences between dialog can be used to cross-probe to a selected component on the schematic or PCB. Double-click on an entry to cross probe to that component on the schematic or PCB.  

The Differences between dialog is accessed from the Choose Documents To Compare dialog (itself accessed by running the Project » Show Differences command). This dialog is used to select which two documents/document-sets you will be comparing, typically it is the schematic project against the PCB. You can also use this dialog to compare any document to any document by ticking the Advanced Mode option. For example, you might be comparing a netlist to a PCB, or a PCB to a PCB. With documents selected, click OK. If differences exist, the Differences between dialog will be presented, with which to investigate those differences further.

Cross-Probing From the Variant Manager or Variant Management Dialog

You can use the Variant Manager or Variant Management dialog to cross probe to a chosen component on the schematic. Double-click on the component in the Variant Manager or Variant Management dialog or right-click, then select Cross Probe from the menu.

Probing Within the Differences Panel

To cross probe to the schematic or PCB from the Differences panel (click the Explore Differences button in the Differences between dialog to access this panel), double-click on an entry in the panel.

Probing Within the BomDoc

Cross-Probing also can be done within the BomDoc. In the BomDoc, right-click, choose Cross Probe then select to which item you wish to navigate from the sub-menu.

Cross-Probing From the Projects Panel

To cross probe to a chosen component or net on the schematic or the PCB from the Projects panel, right-click on an entry in the Components or Nets sub-folder and then select the Cross Probe to Schematic or Cross Probe to PCB command.

Cross-Probing from the Messages Panel

After validating the schematic project, you can right-click then choose Cross Probe or double-click on an error message in the Messages panel to jump to that error condition on the schematic.

Cross-Probing from the Constraint Manager

To cross probe to an object from the Constraint Manager, right-click on its entry, then choose the Cross Probe option from the context menu or select Cross Probe from a custom rule's  menu.

Cross Selecting

This feature facilitates dynamic, bi-directional component cross-selection. It is used to select corresponding objects between PCB and schematic documents. In other words, when you select an object on the PCB document, the same object on the source schematic document is also selected, and vice-versa. It is an ideal tool for building a set of selected objects ready for a design action. For example, you might be looking at a number of components on the schematic and would like to locate them in the PCB editor space so you can position them on the board.

There are many uses for cross-selecting from the schematic to build up a selection of PCB components, three of which include:

  • The ability to quickly create a PCB Component Class (Design » Classes; there is a button to take over selected components when defining a component class).
  • The ability to cluster selected components into a user-defined rectangle using the Tools » Component Placement » Arrange Within Rectangle command, ideal for pulling a set of components out when the design is first transferred from schematic to PCB.
  • The ability to select the schematic components in a specific order, then switch to the PCB Editor and run the Tools » Component Placement » Reposition Selected Components command - each PCB component can then be placed one-by-one, in the same order they were selected on the schematic.

This feature is accessed by:

  • Clicking Tools » Cross Select Mode from the main menus. This command toggles the feature on and off and the status of the command is displayed in the Tools menu. Cross Select Mode is enabled when a blue box appears around the Cross Select Mode icon in the Tools menu as shown in the image below.

    Cross Select Mode in the Tools menu shown disabled (left) and enabled (right).
    Cross Select Mode in the Tools menu shown disabled (left) and enabled (right).

  • Checking or un-checking the Cross Selection option in the System - Navigation page of the Preferences dialog.
  • Clicking Shift+Ctrl+X.
Enabling Cross Select Mode from the Tools menu in either the Schematic or PCB editor will enable it for both editors.

With Cross Select Mode enabled, click to select one or more objects within the design space. Those same objects will become selected on the corresponding document.

How the selected objects are displayed (zoomed, dimmed, etc) and which document has the focus after selecting, are configured by the Cross Select Mode settings in the System - Navigation page of the Preferences dialog.

Selecting PCB Components from the Schematic

It is possible to cross-select between selected parts on one or more schematic source documents and the corresponding component footprints on the PCB document for the active project. As an example, this can be useful when selecting a set of parts on the source documents to create a new component class quickly on the PCB document.

To use this feature:

  • Ensure the target PCB document is open.
  • Select the required part(s) on the source schematic document(s).
  • Choose the Tools » Select PCB Components command.
This feature can also be accessed by clicking Part Actions » Select PCB Components from the right-click menu when the cursor is over the selected part (or one part in a selection of parts). If cross-selecting a single part using this method, the part need not be selected.

After launching the command the PCB document for the project will then be made the active document. All corresponding component footprints for the selection will become selected and zoomed (but not masked) in the design space.

Since the target PCB will become the active document, it is highly recommended to have the source schematic(s) and PCB document open side-by-side.
If the active project contains multiple PCB documents, you should open only the document upon which you wish to work/have the components selected. If more than one PCB document is opened, the command will interrogate all documents for a corresponding match to the components selected on the schematic document(s).

To create the new component class once the part or set of parts has been selected on the PCB using the Select PCB Components command:

  1. Click Design » Classes to open the Object Class Explorer dialog.
  2. Right-click Component Classes then select Add Class by right-clicking in the left column. Enter the desired name of the new class.
  3. Click the button between the Non-Members and Members region of the dialog to add the desired and selected part(s) to the right-hand column.
  4. Click Cancel to close the Object Class Explorer dialog and return to the workspace.
注記

利用できる機能は、Altium Designer ソフトウェア サブスクリプション のレベルによって異なります。

Content