ナビゲーターパネル
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- Navigatorパネルで個々の回路図シート、プロジェクト全体、設計階層を参照し、接続されたオブジェクトをすばやく見つける方法を学びます。
- パネルから回路図へ、回路図からパネルへと双方向にナビゲートする方法を紹介します。また、Altキーを押しながらクリックすることで、関連するPCB上のアイテムを特定できる場面についても説明します。
- ハイライト、ズーム、ディミング、検証がナビゲーション中の表示にどう影響するかを理解し、複雑な設計の接続関係をより把握しやすくします。
設計の規模が大きく、多数のシートにまたがっている場合、回路図を見るだけでネットをたどり、設計内の接続を確認するのは難しくなります。PCB上で同じオブジェクトを探すのは、さらに困難です。この作業を支援するために、 Navigator パネルを使用します。

Navigatorパネルを使用すると、設計全体を把握できます。Altを押しながらパネル内の項目をクリックすると、PCB上でもその項目を探すことができます。
Navigator パネルでは、アクティブなソース回路図ドキュメント、またはアクティブなプロジェクト内のすべてのソース回路図ドキュメントを参照できます。このパネルは、バックグラウンドで自動的に作成される設計の接続モデルを基盤としてナビゲーションを行います。 また、PCB上のコンポーネント、パッド、バス、ネットへのナビゲーションにも使用できます。
設計内のナビゲーション
ナビゲーションには2つの方法があります。Navigatorパネル内の項目をクリックして回路図上の該当オブジェクトを探す方法と、回路図上のオブジェクトをクリックしてNavigatorパネル内の該当オブジェクトを探す方法です。
Navigatorパネルからのナビゲーション
Navigatorパネルを表示するには、ソフトウェアの右下にあるPanelsボタンを使用するか、メニューからView » Panels » Navigatorを選択します。
回路図を開くと、コンポーネントと接続の情報がすぐにパネルに読み込まれます。Documentsセクションのアイコンをクリックすると、その情報が表示されます。ソフトウェアはプロジェクト全体の動的データモデルを自動的に構築し、編集操作に応じてモデルを維持します。すべての回路図シートのドキュメントタブがグラフィカル編集領域の上部に表示されるわけではない点に注意してください。シートはバックグラウンドで開かれ、そのシートに対してユーザーが操作を行ったときにのみタブが表示されます。
動的データモデルは、各エディターおよびNavigatorパネルで使用できます。パネルの内容が設計の現在の状態と一致しているか不明な場合は、Validate Projectコマンドを選択してモデルを強制的に更新してください(Projectメニュー、またはNavigatorパネルの右クリックコンテキストメニューから実行できます)。

Navigatorパネル内のオブジェクトをクリックすると、設計全体にわたってそのオブジェクトのすべてのインスタンスを探すことができます。
インタラクティブナビゲーション
パネルに表示されるオブジェクトのリストから、クリックしてグラフィカル領域内のオブジェクトを探すだけでなく、グラフィカル領域からリストへ戻る方向のナビゲーションも可能です。これはインタラクティブナビゲーションと呼ばれ、Navigatorパネル上部のInteractive Navigationボタンをクリックすると、このモードが開始されます。カーソルが十字に変わり、ナビゲーションモードであることを示します。このモードは、右クリックするかEsc キーを押すまで継続します。
設計内をナビゲートすると、現在のハイライト表示オプションに従ってシート表示が更新され、 Navigator パネルには、グラフィカル編集ウィンドウで現在選択されている項目に関連する情報が表示されます。

インタラクティブナビゲーションを開始し( Navigatorパネル上部のボタン)、シート上のオブジェクトをクリックすると、パネル内および設計内の他の場所にある該当オブジェクトを探すことができます。
インタラクティブナビゲーションのショートカット
Navigatorパネルからインタラクティブナビゲーションを開始するほか、回路図エディターでAltを押しながら設計オブジェクトをクリックすることで、いつでもナビゲーションを実行できます。ワイヤー、ネットラベル、ポート、シートエントリ、シートシンボル、コンポーネントなど、どのオブジェクトでもクリックできます。
Alt+クリックのショートカットを使用して、設計内をナビゲートできます。
ナビゲーション中のオブジェクトのハイライト表示
Navigatorパネル内のオブジェクトをクリックすると、そのオブジェクトがグラフィカル編集領域に表示されます。オブジェクトの表示方法は、Preferencesダイアログの System - Navigation 設定によって異なります。Navigatorパネルから設定に直接アクセスするには、パネル上部の Navigation Optionsボタン(
)をクリックしてダイアログを開きます。
PreferencesダイアログのHighlight Methods領域には、パネルから、またはドキュメント内でナビゲーションを行った際に、ドキュメントに一時的に適用されるフィルタリングの表示結果を制御するオプションがあります。 これらのオプションは自由に組み合わせて有効にできます。たとえば、フィルタリングされたすべてのオブジェクトを設計エディターウィンドウでズーム表示して選択し、その他の設計オブジェクトを淡色表示して見やすくすることができます。
Navigatorパネル
Navigatorパネルでは、設計の接続モデルを確認できます。設計の構造はパネルの4つのセクションに表示されます。各セクションについて以下で説明します。
Navigatorパネルには、設計全体が接続関係を中心としたビューで表示されます。
Documentsセクション
パネル上部にあるDocumentsセクションでは、individual sheets、flattened hierarchy(プロジェクト全体)、またはfull design hierarchyの参照という、3つの方法で設計を表示できます。この最初のセクションでアイコンを1回クリックすると、データがパネルに読み込まれます。ダブルクリックすると、グラフィカル編集領域にも結果が表示されます。
Documentsセクションの機能
Componentsセクション
パネルの2番目の領域には、最初のセクションで現在選択されているドキュメントに存在するすべてのコンポーネントが表示されます。リスト内で最上位のコンポーネントインスタンスのエントリを選択すると、そのエントリに基づいてフィルターが適用されます。その表示結果は、選択したハイライト方法によって決まります。有効なハイライトオプションにConnective Graphオプションが含まれている場合、選択したコンポーネントに接続されている他のすべてのコンポーネントも表示されます(それらを含むようにフィルターの対象が拡張されます)。接続されているコンポーネントは、緑色のグラフ接続線で視覚的にハイライトされます。
Connective Graphが有効になっているため、パネルで選択したコンポーネントに接続されている各コンポーネントに緑色の線が引かれます。
Componentsセクションの機能
Componentsセクション |
|
| Information available | 各コンポーネントのエントリには、ParametersとImplementations(モデル)のサブフォルダーがあります。ハイライトオプションでPins オプションが有効になっている場合、Pins サブフォルダーも利用できます( )。 |
| When you click | Instanceリストでピンのエントリをクリックすると、パネルのNet / Busセクションでそのピンに対応するエントリが選択され、パネルの最下部のセクションに、そのピンが属するネットのすべてのピンが表示されます。また、選択したピンのエントリに基づいてフィルターが適用され、表示結果は有効なハイライト方法によって決まります。 |
| Connective Graph | Connective Graphオプションを有効にしている場合、選択したピンが属するネットに接続されている他のすべてのピンも表示されます(それらを含むようにフィルターの対象が拡張されます)。接続されているピンが属するネットは、赤色のグラフ接続線で視覚的にハイライトされます( )。 |
ネット/バスセクション
パネルの3番目のセクションには、参照中のドキュメント(またはフラット化された階層)内の各ネットとバスが一覧表示されます。項目をクリックすると、そのネット/バスに関連付けられているすべてのオブジェクト(ピン、ネットラベル、ポート、シートエントリ、シート間コネクタ)が、有効なハイライト方法に従って設計エディタウィンドウに表示されます。
ネット/バスセクションの機能
ネット/バスセクション |
|
| Information available | 選択したネット/バスに関連付けられている各種オブジェクトは、現在有効なハイライトオプション と、選択中のネット/バスにその種類のオブジェクトが存在するかどうかに応じて、サブフォルダに一覧表示されます。 各ネット/バスには、関連するピン、ポート、ネットラベル、シートエントリ、シート間コネクタの接続に使用されているグラフィカルな線を一覧表示する、追加のサブフォルダを含めることもできます。線の項目をクリックすると、その線オブジェクトのみがフィルタリングされ、表示制御設定が適用されます。 |
| When you click | パネルでの表示が有効になっているすべてのネットオブジェクト(グラフィカルな線を除く)は、パネルの最下部のセクション( )に表示されます。ここでも、いずれかの項目をクリックすると、有効なハイライト方法に従ってフィルタリングが適用されます。 |
バスネット/ネットピンセクション
パネルの4番目のセクションに表示される内容は、移動対象のオブジェクトと、表示するように設定したオブジェクトの2つによって決まります。ネット/バスセクションでbusをクリックすると、そのバス内のネットがこのセクションに一覧表示されます。ネット/バスセクションでnetをクリックすると、そのネット内のピンが一覧表示されます。 表示が有効になっている場合は、そのネットに付加されているネット識別子も一覧表示されます。
信号セクション
Navigatorパネルでは、通常のオブジェクト中心の表示方法に加え、信号を中心に設計を表示することもできます。パネルのDocumentsセクションで回路図ドキュメントが選択されている場合、パネル上部の Show Signalsオプションを有効にすると、パネルの3番目のセクションがSignalモードに切り替わります。
信号の項目をクリックするとフィルタが適用され、その信号のノード(ピン、ポート、ネットラベル、シートエントリ、シート間コネクタ)が、有効なハイライト方法に従って設計エディタウィンドウに表示されます。 リスト内の各信号には、その信号に関連付けられているノードのピン、シートエントリ、またはシート間コネクタが一覧表示されます。これらの項目は、対応するオブジェクト種類の表示オプションが有効かどうかにかかわらず表示されます。
信号セクションの機能
信号セクション |
|
| Signal | 信号の名前(バス名またはネット名)。 |
| Width | この信号に含まれる個別のネットの数。 |
| Click on a top-level signal entry | 最上位の信号項目をクリックすると、その信号に関連付けられているすべての信号ノードがパネルの最下部のセクションに表示されます。これには、ピン、ネットラベル、ポート、シートエントリ、シート間コネクタが含まれます。各項目は、そのオブジェクト種類に対応する表示オプションが有効になっている場合にのみ表示されます。 |
| Click on a sub-entry | メインの信号リスト内のサブ項目をクリックすると、その信号の親ネットに関連付けられているすべてのネットオブジェクトがパネルの最下部のセクションに表示されます。 |
| SignalName Driven By Pin X | 信号に関連付けられているノードのピンが出力ピンまたはI/Oピンの場合に表示されます。 Xは、その信号を駆動しているコンポーネントとピンのデジグネータを表します。 |
| Driving Node Pin X | 信号に関連付けられているノードのピンが入力ピンの場合に表示されます。 Xは、その信号によって駆動されるコンポーネントとピンのデジグネータを表します。 |
| Driven By Node Sheet Entry SignalName | シートエントリノードの電気的タイプが出力またはI/Oの場合に表示され、そのエントリが信号を駆動していることを示します。 |
| Driving Node Sheet Entry X | シートエントリの電気的タイプが入力の場合に表示され、そのエントリが信号によって駆動されていることを示します。 |
PCB上のオブジェクトへの移動
Navigatorパネル内をクリックして回路図内のオブジェクトに移動する際、PCB上の同じオブジェクトにも同時に移動できます。 Altキーを押しながらNavigatorパネル内のオブジェクトをクリックすると、対象のオブジェクトが回路図とPCBの両方でハイライトされます。
移動操作は常に回路図上で行われるため、PCB上のオブジェクトに移動するには、回路図とPCBを同時に表示する必要があります。これには、PCBを別のウィンドウに表示するか、Split VerticalまたはSplit Horizonal機能を使用して表示領域を分割します(下図は縦分割の例)。これらのコマンドは、ドキュメントタブを右クリックすると表示されるコンテキストメニューから使用できます。
Altキーを押しながら設計内を移動すると、PCB上でも該当するオブジェクトを見つけることができます。
Altium Designerには、回路図とPCBを連携させて作業するための次のような機能があります。
| Cross probe | クロスプローブ - 右クリックして起動し、一方のエディタでオブジェクト(コンポーネント、ピン、ネット)をクリックすると、もう一方のエディタ内の同じオブジェクトにジャンプします。モードには、continuous(元のエディタにとどまる)とjump-to(移動先のエディタ/ドキュメントをアクティブにする)の2つがあります。クロスプローブ時にCtrlを押し続けると、jump-toモードが適用されます。 クロスプローブは、回路図、PCB、BOMの各エディタ、Constraint Manager、およびProject、Navigator、Messagesパネルから実行できます。 |
| Cross select | 一方のエディタでコンポーネントをクリックして選択すると、もう一方のエディタでもそのコンポーネントが選択されます。この機能は回路図エディタとPCBエディタの間で使用でき、Viewメニューで有効にします。 |
詳細については、クロスプローブとクロス選択をご覧ください
Navigatorパネルのコンテキストメニュー
Navigatorパネルの右クリックコンテキストメニューには、次のコマンドがあります。
)を使用すると、履歴を前後に移動できます。
)
)からも利用できます。



)。
)。
)。

)に表示されます。ここでも、いずれかの項目をクリックすると、有効なハイライト方法に従ってフィルタリングが適用されます。
