PDN Analyzer (by CST) Example Guide

W skrócie

Ten przewodnik pokazuje, jak korzystać z narzędzia PDN Analyzer (by CST) w Altium Designer — od konfiguracji parametrów sieci na potrzeby symulacji PI-DC, przez przeprowadzenie analizy, aż po interpretację wyników, która pozwala stopniowo poprawiać integralność zasilania w projekcie PCB. Omawia również układ interfejsu, dostępne projekty przykładowe, proces identyfikacji sieci, elementy sterujące symulacją oraz najważniejsze opcje panelu służące do tworzenia struktur sieci zasilających i zarządzania nimi bezpośrednio na podstawie danych wczytanego projektu. Jeśli szukasz praktycznego omówienia roli PDN Analyzer w procesie projektowania i chcesz wiedzieć, gdzie znaleźć potrzebne narzędzia, ten artykuł pomoże Ci poznać podstawy i przygotować się do dalszej pracy.

- Poznasz podstawowy sposób pracy z PDN Analyzer, w tym konfigurowanie i uruchamianie symulacji oraz ich ponowne wykorzystywanie w miarę wprowadzania zmian w projekcie PCB.
- Zobaczysz, jak zorganizowany jest interfejs PDN Analyzer, w tym tryby układu, opcje dokowania, widoki sieci oraz miejsca, w których można uzyskać dostęp do konfiguracji i wyników.
- Dowiesz się, jakie projekty przykładowe i wbudowane opcje pomagają identyfikować sieci prądu stałego, zarządzać plikami symulacji oraz pracować ze strukturami sieci zasilających.
Zagłęb się w temat dzięki AI:

Aby poznać najnowsze funkcje analizy integralności zasilania DC, zapoznaj się z oferowanym przez Altium narzędziem Power Analyzer by Keysight.

Aplikacja PDN Analyzer (PDNA) jest stosunkowo prosta w obsłudze. Praca z nią polega zasadniczo na skonfigurowaniu parametrów sieci do symulacji PI-DC, uruchomieniu symulacji, a następnie interpretacji wyników. Dane wykorzystywane w symulacji sieci zasilania w PDN Analyzer są pobierane bezpośrednio z aktualnie wczytanego projektu PCB. Projekt można modyfikować iteracyjnie, aby poprawić integralność zasilania w torach zasilających, a następnie ponownie uruchamiać symulację PDN w celu sprawdzenia efektów.

W tym przewodniku przedstawiającym pracę z PDN Analyzer wykorzystano dwa projekty referencyjne dostępne w Altium:

Ponadto instalacja PDN Analyzer zawiera projekt PCB SpiritLevel wraz z kilkoma przykładowymi plikami konfiguracji analizy. Aby uzyskać dostęp do projektu i przykładów, skorzystaj z opcji menu PDNA File » Explore Samples, a następnie rozpakuj archiwum.

W tym przewodniku przyjęto, że PDN Analyzer jest dostępny w używanej instalacji Altium Designer oraz że użytkownik zna podstawowe zasady PI-DC (integralności zasilania DC).

Informacje o dostępie do funkcji PDN Analyzer oraz podstawach symulacji PI-DC można znaleźć na stronie PDN Analyzer.

Interfejs PDN Analyzer

Interfejs rozszerzenia PDN Analyzer jest otwierany jako niemodalne okno Altium Designer, które można umieścić w dowolnym dogodnym miejscu obszaru roboczego lub na innym ekranie, jeśli jest dostępny. Aby otworzyć główne okno PDN Analyzer, otwórz dokument schematu lub PCB projektu i wybierz aplikację z menu Tools (Tools » PDN Analyzer).

Interfejs graficzny PDN Analyzer z wybraną pojedynczą siecią zasilania. Ustawienia wyświetlania i wyników są dostępne w dolnej części panelu.Interfejs graficzny PDN Analyzer z wybraną pojedynczą siecią zasilania. Ustawienia wyświetlania i wyników są dostępne w dolnej części panelu.

Górna część interfejsu okna PDNA służy do zarządzania plikami i sieciami oraz zawiera interaktywną reprezentację aktualnie wybranych sieci zasilania. Dolna część panelu zapewnia dostęp do opcji analizy, ustawień wyświetlania i danych wynikowych. PDNA w wersji 2 obsługuje wiele połączonych ze sobą sieci, co umożliwia analizę integralności zasilania DC całego projektu PCB w postaci struktury hierarchicznej lub jako pojedynczych sieci zasilania.

Interfejs graficzny PDN Analyzer z wybraną pełną hierarchią sieci zasilania. Wyświetlaniem uwzględnionych sieci i warstw steruje się w dolnej części panelu.Interfejs graficzny PDN Analyzer z wybraną pełną hierarchią sieci zasilania. Wyświetlaniem uwzględnionych sieci i warstw steruje się w dolnej części panelu.

Interfejs PDN oferuje również tryb kompaktowy (File » Compact Layout), który nie obejmuje dolnej części panelu i doskonale nadaje się do dokowania w poziomie lub pionie w głównym oknie Altium Designer. Aby włączyć dokowanie w trybie kompaktowym lub standardowym, kliknij prawym przyciskiem myszy pasek tytułu interfejsu PDNA, wybierz Allow Dock z menu kontekstowego, a następnie wybierz opcję Horizontally lub Vertically.

Szczegółowe informacje o interfejsie użytkownika panelu PDN Analyzer znajdują się w poniższej rozwijanej sekcji. 

Identyfikacja sieci DC

Przy pierwszym otwarciu narzędzia PDN Analyzer dla projektu PCB podejmowana jest próba zidentyfikowania wszystkich układów zasilania prądem stałym na podstawie danych sieci projektu i typowego nazewnictwa układów zasilania.  Jeśli nie zidentyfikowano wszystkich potencjalnych sieci zasilających, usuń zaznaczenie odpowiednich opcji filtrowania Qualifiers lub wybierz opcję Enable all nets for filtering, aby zobaczyć wszystkie sieci.

Użyj pól wyboru Select, aby wskazać sieci zasilające, które będą dostępne dla analizatora PDNA, i wprowadź odpowiednie poziomy napięcia w odpowiadających im polach Nominal Voltage. Kliknij przycisk Add Selected, aby wypełnić listę Currently Identified DC Nets i zatwierdzić te sieci jako zidentyfikowane układy zasilania.

Pamiętaj, że dwukrotne kliknięcie pozycji sieci na liście w oknie dialogowym spowoduje wskazanie tej sieci w układzie PCB.

Dodatkowe sieci można zidentyfikować i uwzględnić podczas konfiguracji analizy PDN, wybierając przycisk DC Nets w interfejsie graficznym analizatora.

Poniższe przykłady analizy przedstawiają najważniejsze możliwości i funkcje PDN Analyzer. Każdy przykład pokazuje tylko jedną z wielu możliwych konfiguracji parametrów, które można wykorzystać do oceny integralności zasilania sieci na różne sposoby, zależnie od badanego zagadnienia. Pomyślnie zakończoną analizę można zapisać jako plik konfiguracji PDNA (*.pdna) i ponownie wczytać w dowolnym momencie – File » Save As i File » Open (domyślnie w folderze PDNAnalyzer_Config projektu)

Przykład 1

Ten przykład przedstawia podstawy konfigurowania symulacji integralności zasilania z prostą siecią zasilającą i jej obciążeniami prądowymi. Konfiguracja służy do oceny rozprowadzania zasilania szyną 5 V oraz ścieżki powrotnej przez masę w projekcie referencyjnym SpiritLevel-SL1, przy obciążeniu wyświetlaczem LCD zastosowanym w projekcie. W tym przypadku szyna zasilająca 5V jest traktowana jako proste źródło napięcia, a podłączone do niej sieci (np. przez przełącznik S1) nie są uwzględniane.

Warunki wstępne dla tego przykładu symulacji PDN:

  • projekt PCB Spirit Level jest otwarty w Altium Designer
  • aplikacja PDN Analyzer jest aktywna (Tools » PDN Analyzer)
  • sieci prądu stałego w projekcie PCB zostały zidentyfikowane w oknie dialogowym PDN Analyzer DC Net Identification, zgodnie z opisem powyżej.

Rozpocznij analizę od określenia sieci zasilania i masy. Kliknij dwukrotnie elementy <Power Net> i <Ground Net> na schemacie sieci w interfejsie graficznym, aby otworzyć okno dialogowe Choose Net, w którym można wybrać zidentyfikowane sieci zasilające.

W razie potrzeby użyj opcji kwalifikowania/filtrowania w tym oknie, aby ograniczyć lub rozszerzyć listę sieci, albo wróć do ekranu głównego i wybierz przycisk , aby ponownie zidentyfikować sieci zasilania prądem stałym.

Teraz można dodać element źródła lub obciążenia między określonymi sieciami zasilania i masy – zwróć uwagę, że wskaźniki stanu masy i zasilania zmieniają się na zaznaczone (✔). Kliknij prawym przyciskiem myszy w obszarze roboczym schematu sieci i wybierz Add Source (lub Add Load) z menu kontekstowego, aby otworzyć okno dialogowe Device Properties. Kroki wskazane w tym oknie są następujące:

  1. Aby dodać źródło zasilania sieci, w tym przypadku proste źródło napięcia, wybierz opcję Voltage Source z listy rozwijanej Device Type w oknie dialogowym.
  2. Na liście połączeń źródła PDNA spróbuje wybrać prawidłowe opcje połączenia sieci na podstawie parametrów sieci zasilającej – w tym przypadku jest to połączenie między sieciami 5V i GND. Użyj opcji listy rozwijanej Refdes, aby określić punkty połączenia źródła napięcia z komponentami. W tym przykładzie jako punkt napięcia źródłowego wskazano TP1, a jako połączenie powrotne do masy – gniazdo wejściowe zasilania DC J1 w projekcie (wyprowadzenia 2 i 3).
  3. W dolnej części okna dialogowego parametry źródła określają właściwości modelu symulacyjnego źródła napięcia. Tutaj napięcie źródła (Vout) ustawiono na 5V, a rezystancję wewnętrzną modelu (Rout) pozostawiono na domyślnej wartości 0Ω.
  4. Na koniec maksymalny prąd źródła i prąd wyprowadzenia (dla źródeł z wieloma wyprowadzeniami wyjściowymi) pozostawiono na ustawieniach domyślnych (0A: Don't Care). Gdy dla Limits zostaną ustawione konkretne wartości prądu, analiza PDN zasygnalizuje naruszenie, jeśli wyniki symulacji przekroczą te wartości.

W taki sam sposób jak przy dodawaniu źródła do sieci dodaj obciążenie i określ jego parametry w oknie dialogowym Device Properties.

W tym przypadku dodawane jest obciążenie w postaci źródła pochłaniającego prąd (Device Type: IC (Current)), aby odwzorować prąd pobierany z szyny 5 V przez wyświetlacz LCD w projekcie. Dostępna jest również opcja obciążenia czysto rezystancyjnego – w tym celu wybierz  Resistor jako Device Type.

Ustaw połączenie obciążenia na LCD1 i określ Load Current pobierany z zasilania 5 V – obsługiwane są przedrostki jednostek (np. 500m oznaczające 0.5A). Choć ustawienia napięcia Limits są opcjonalne, ustawiono je na  +/-10% (za pomocą odpowiedniego przycisku), co spowoduje zgłoszenie naruszenia w symulacji, jeśli napięcie na samym obciążeniu spadnie poniżej 4,5 V (lub przekroczy 5,5 V).

Po zdefiniowaniu sieci zasilającej i określeniu wszystkich parametrów (wszystkie elementy sieci mają przypisany stan ✔) można uruchomić analizę PDN, wybierając przycisk . Postęp symulacji jest wyświetlany na karcie Messages w postaci strumienia zdarzeń, który wskaże również przyczynę niepowodzenia symulacji, jeśli proces nie będzie mógł zostać ukończony.

Po uruchomieniu analizy bieżąca konfiguracja symulacji – określone sieci, źródła/obciążenia itp. oraz powiązane z nimi parametry – jest zapisywana wraz z danymi wynikowymi analizy (File » Explore; patrz folder PDNAnalyzer_Ouput). Konfigurację tę można w dowolnym momencie przywrócić dla bieżącej symulacji, klikając prawym przyciskiem myszy nazwę symulacji i wybierając Revert z menu kontekstowego.

Bezpośrednie wyniki analizy PDN są widoczne na schemacie sieci, który zawiera obliczone wartości napięcia i prądu obciążenia/źródła (tam, gdzie ma to zastosowanie) oraz wyróżnienia wszystkich fragmentów sieci, w których wystąpiło naruszenie parametrów. Zwróć uwagę, że karta Visual jest teraz wybrana i aktywna.

Najedź kursorem na dowolny element sieci (obciążenie, źródło lub element szeregowy), aby zobaczyć dodatkowe informacje, takie jak określone parametry i wyniki analizy.

Wizualizacja w edytorze PCB

Wyniki symulacji można teraz wyświetlić graficznie w edytorze PCB Altium Designer, korzystając z ustawień dostępnych na karcie Visual w PDNA.  Ustaw opcje wizualizacji tak, aby wyświetlać Voltage dla obu Layers (Top i Bottom) dla 5V Net – są to początkowe domyślne ustawienia wyświetlania. Wyniki analizatora są wyświetlane w edytorze PCB zamiast dotychczasowej nakładki graficznej PCB.

Widok spadku napięcia wzdłuż wybranej ścieżki sieci, w tym przypadku od źródła 5 V w punkcie TP1 do komponentu LCD1, jest przedstawiony za pomocą gradientu kolorów odpowiadającego skali napięcia widocznej u dołu widoku. Wartości są prezentowane jako procent napięcia (opcja Per Rail w sekcji Color Scale) lub jako rzeczywisty zakres napięcia (opcja Displayed).

Na poniższym obrazie zmiana koloru wzdłuż ścieżki sieci na płytce przedstawia całkowity spadek napięcia. Minimalny poziom (0%:, kolor niebieski), wynikający ze strat IR, występuje na komponencie LCD1, a maksymalny (100%: kolor czerwony) – w określonym punkcie źródła napięcia (TP1).

Aby wyświetlić odpowiednią analizę prądu dla sieci, wybierz opcję Current Density na karcie Visual. Tutaj kolory wzdłuż ścieżki sieci na płytce odpowiadają procentowym zmianom gęstości prądu, gdzie 100% (kolor czerwony) oznacza maksymalną obliczoną gęstość prądu w układzie ścieżek sieci, a 0% (kolor niebieski) – minimalną, najprawdopodobniej 0A/mm2.

Należy pamiętać, że choć alternatywna skala napięcia/prądu (Displayed) jest bardziej intuicyjna przy wyświetlaniu pojedynczych sieci, dostarcza niewiele przydatnych informacji podczas jednoczesnego wyświetlania wielu sieci napięciowych — takich jak 5V and GND w tym przykładzie lub kilku przeanalizowanych sieci zasilania w projekcie.

Aby wyświetlić i przeanalizować wyniki analizy integralności zasilania w torze powrotnym GND w tym przykładzie, usuń zaznaczenie sieci 5V na liście Net na karcie Visual panelu PDNA, a następnie wybierz sieć GND. Tor powrotny masy przebiega zarówno przez warstwę Top, jak i Bottom projektu. Można je wyświetlać osobno w edytorze PCB, wybierając odpowiednią pozycję na liście Layer panelu PDNA.

Poniższy obraz przedstawia rozkład napięcia w warstwie Bottom sieci GND, ze skalą Color Scale ustawioną na Displayed. Największy spadek napięcia (kolor czerwony: około 0,5 mV) występuje na wyprowadzeniu GND wyświetlacza LCD, natomiast najmniejszy (kolor niebieski: około 0 V) — w punkcie powrotnym źródła napięcia (J1).

Przełączenie na opcję Current Density panelu PDNA powoduje wyświetlenie na czerwono miejsc o największej gęstości prądu. Sama maksymalna wartość gęstości prądu (1.74 A/mm2) jest bardzo niska i mieści się z dużym zapasem w dopuszczalnych granicach.

Sterowanie wyświetlaniem i opcje

PDN Analyzer oferuje kilka interaktywnych opcji wyświetlania, które określają sposób graficznej prezentacji wyników analizy w edytorze PCB programu Altium Designer. Oprócz opcji wyświetlania Color Scale dostępne jest przełączanie między renderowaniem 2D i 3D. Ten drugi tryb zapewnia cenny wgląd w wyniki analizy w przelotkach i pomiędzy warstwami.

Dostępna jest również opcja Clear wyników analizy z widoku edytora, która automatycznie przywraca standardowy widok układu płytki. Z kolei opcja Overlay włącza widok układu płytki, który będzie renderowany wraz z aktualnie wyświetlanymi wynikami analizy. Ta opcja jest szczególnie przydatna do sprawdzania, gdzie w układzie płytki znajduje się interesujący punkt wyników analizy.

Praca z obciążeniami

W razie potrzeby można dodawać kolejne obciążenia do sieci i ponownie uruchamiać analizę zasilania, aby ocenić wyniki. Aby na przykład dodać niewielki prąd obciążenia (np. 15mA) pobierany przez diodę LED sygnalizującą zasilanie w projekcie, wybierz jej rezystor szeregowy (R15) jako połączenie z szyną 5V, a wyprowadzenie diody LED jako połączenie z GND.

PDN Analyzer umożliwia również określenie wyprowadzeń elementu podłączonych do obciążenia. Pozwala to tworzyć wiele modeli obciążenia dla pojedynczego elementu, który pobiera różne prądy przez różne wyprowadzenia.

Taką sytuację ilustruje wyświetlacz LCD w przykładowym projekcie: jego połączenie 5V na wyprowadzeniu 15 (LED+) zasila podświetlenie, natomiast połączenie 5V na wyprowadzeniu 2 (VDD) zasila wewnętrzne układy logiczne — w praktyce wyprowadzenie 15 pobiera znacznie większy prąd niż wyprowadzenie 2.

Gdy element LCD1 został wcześniej dodany jako pojedynczy model obciążenia PDNA, oba jego wyprowadzenia zostały domyślnie wskazane jako połączenie obciążenia z siecią 5V, a analiza PDN rozdzieliła prąd obciążenia LCD1 równomiernie między te wyprowadzenia. Aby zwiększyć dokładność analizy zasilania, element LCD1 można przedstawić jako two modele obciążenia: po jednym dla każdego wyprowadzenia 5V i związanego z nim prądu obciążenia. W tym celu należy zmodyfikować parametry wyprowadzeń istniejącego modelu obciążenia LCD1, a następnie dodać kolejne obciążenie dla wydzielonego wyprowadzenia.

Otwórz istniejący model obciążenia LCD1, klikając dwukrotnie jego ikonę na schemacie sieci, aby otworzyć okno dialogowe Device Properties, a następnie kliknij dwukrotnie pole Pins(s) w pozycji sieci zasilania 5V. Włączony w ten sposób tryb edycji wyprowadzeń umożliwia wybór poszczególnych wyprowadzeń elementu dla danego obciążenia. Usuń zaznaczenie wyprowadzenia 2, aby skonfigurować obciążenie tylko dla wyprowadzenia 15 (LED+), i ustaw parametr Load Current na przykład na 75mA, aby odwzorować prąd podświetlenia LCD.

Następnie utwórz kolejne obciążenie sieci 5V dla LCD1 i ustaw wyprowadzenie 2 jako aktywne (przy wyłączonym wyprowadzeniu 15), aby odwzorować obciążenie VDD. Można dla niego ustawić odpowiednio niższą wartość Load Current — na przykład 20mA.

Następnie można ponownie przeanalizować sieć zasilania 5V, aby uzyskać dokładniejsze odwzorowanie obciążenia LCD1 w ścieżkach sieci.

Różnicę w rozkładzie prądu obciążenia można zauważyć, porównując gęstość prądu w ścieżkach sieci zasilania LCD1 dla pierwotnej i zaktualizowanej konfiguracji obciążeń. Poniższe obrazy analizy gęstości prądu przedstawiają po lewej wynik dla pierwotnego modelu LCD1 z pojedynczym obciążeniem, a po prawej — wynik dla zaktualizowanego modelu z wieloma obciążeniami.

Zwróć uwagę na gęstość prądu w ścieżkach zasilających wyprowadzenia 2 (pole lutownicze LCD po lewej) i 15. Zaktualizowana wersja prawidłowo pokazuje, że większość prądu LCD płynie do wyprowadzenia 15 (pole lutownicze LCD po prawej), zamiast rozdzielać się równomiernie między oba wyprowadzenia, jak miało to miejsce wcześniej (obraz po lewej).

 

Ustawienia symulacji

Wyniki analizy, a w szczególności wielkość spadków napięcia IR w obszarach miedzi na płytce, zależą również od przyjętej przewodności miedzi na płytce oraz grubości metalizacji ścianek przelotek. Aby wyświetlić i edytować te ustawienia, wybierz kartę Simulation w oknie dialogowym Settings. Aby otworzyć to okno, kliknij prawym przyciskiem myszy nazwę bieżącej analizy i wybierz Settings z menu kontekstowego.

Przewodność metalu

Sekcja Metal Conductivity okna dialogowego zawiera informacje i ustawienia dotyczące przewodności (odwrotności rezystywności; 1/R) metalu użytego w projekcie. W oknie można wybrać lub zmodyfikować przewodność bazową (lub rezystywność), współczynnik temperaturowy i/lub temperaturę, aby odzwierciedlić właściwości konstrukcyjne płytki:

  • Pure Copper — zazwyczaj przyjmuje się, że miedź ma przewodność 5.88e7S/m w temperaturze 25°C oraz współczynnik temperaturowy przewodności 0.4%/°C. Ten dodatni współczynnik temperaturowy oznacza na przykład, że zwiększenie wartości ustawienia Temp. Compensation w oknie dialogowym z 25°C do 125°C (różnica 100°C) obniży przewodność przyjętą w symulacji o 40%, do 3.53e7S/m.
  • PCB Copper — jest to domyślne ustawienie symulacji, odpowiadające wartościom przewodności podawanym w literaturze branżowej jako reprezentatywne dla miedzi osadzanej elektrolitycznie (ED) na płytkach PCB. Jej zmierzona przewodność wynosi 4.7e7S/m w temperaturze 25°C, a współczynnik temperaturowy — 0.4%/°C.
  • Custom — wybierz tę opcję, aby wprowadzić konkretne wartości przewodności lub rezystywności na potrzeby symulacji.

Należy pamiętać, że wyświetlana wartość Sim Conductivity reprezentuje końcową przewodność po uwzględnieniu wszystkich parametrów — wartość Sim Resistivity jest jej odwrotnością.

Przelotka

Ustaw wartość Via Wall Thickness w oknie dialogowym, aby określić gramaturę metalu ścianek wszystkich przelotek w analizie symulacyjnej projektu.

To ustawienie może zauważalnie wpływać na straty stałoprądowe w sieci zasilania ze względu na rezystancję cienkościennej przelotki (z cienką metalizacją). Przy odpowiednich wymiarach i gramaturze metalu przelotka nie pogarsza jednak parametrów stałoprądowych projektu i wykazuje taką samą gęstość prądu jak łączone przez nią ścieżki zasilania — bez istotnego spadku napięcia między punktami połączenia. Przykład analizy stałoprądowej strat w przelotkach przedstawiono w sekcji poniżej.

Z punktu widzenia symulacji rozmiar przelotki i grubość jej ścianki określają ilość materiału przewodzącego reprezentowanego przez przelotkę, a tym samym jej rezystancję i przewodność. W symulacji przyjmuje się, że średnica przelotki oznacza końcową średnicę otworu, a grubość ścianki przelotki zwiększa jej średnicę zewnętrzną. Zatem: Finished Hole Diameter + (2 x Wall_Thickness) = Drill Diameter.

Przykład 2

Ten przykład pokazuje, jak utworzyć szereg połączonych sieci, które można analizować jako całość, uwzględniając parametry łączących je elementów szeregowych. Przedstawia również sposób dodawania źródeł w postaci modeli regulatorów napięcia (VRM), które także łączą sieci, oraz sposób tworzenia pełnej hierarchii sieci zasilania projektu.

W przykładzie modelowana jest sieć od PWR_IN do 5V z projektu referencyjnego SpiritLevel-SL1. Uwzględniono w nim modele VRM zarówno dla napięcia 3,3 V (VCCO), jak i 1,8 V (VCCINT), aby utworzyć kompletną strukturę sieci zasilania.

Warunki wstępne dla tego przykładu symulacji PDN są następujące:

  • projekt PCB Spirit Level jest otwarty w Altium Designer
  • aplikacja PDN Analyzer jest aktywna (Tools » PDN Analyzer)
  • sieci prądu stałego projektu PCB zostały zidentyfikowane w oknie dialogowym PDN Analyzer DC Net Identification, jak opisano powyżej.

Rozpocznij tworzenie przykładowej sieci zasilania od wskazania wejściowej sieci zasilającej (PWR_IN) w nowej symulacji (w razie potrzeby wybierz File » New Simulation). Zgodnie ze schematem projektu parametr <Power Net> sieci PDN ma wartość PWR_IN, <Ground Net> ma wartość GND, a Source ma wartość J1.

Rozszerzanie sieci przez elementy szeregowe

Aby zamodelować pełną ścieżkę zasilania od sieci PWR_IN do sieci 5V, należy dodać połączone szeregowo elementy: bezpiecznik (F1) i przełącznik (S1), a także łączącą je sieć. W interfejsie PDNA dodaje się je przez kolejne rozszerzenia sieci zasilania. Każde takie rozszerzenie jest połączone za pomocą uniwersalnego modelu elementu szeregowego.

Aby rozszerzyć sieć, najpierw kliknij prawym przyciskiem myszy w obszarze sieci, którą chcesz rozszerzyć, i wybierz opcję Extend Network z menu kontekstowego. W oknie dialogowym Choose Net wybierz sieć połączoną z PWR_IN przez element szeregowy. W tym przypadku jest to NetD1_2 — sieć łącząca F1 z wyprowadzeniem 3 elementu S1, identyfikowana jako wyprowadzenie 2 diody D1.

Ponieważ ta sieć najprawdopodobniej nie została zarejestrowana na początkowym etapie identyfikacji sieci prądu stałego, usuń zaznaczenie opcji List DC nets only w oknie dialogowym Choose Net, aby udostępnić ją do wyboru.

Proces rozszerzania sieci automatycznie doda element szeregowy między obiema sieciami. Kliknij dwukrotnie ten element, aby określić jego połączenia i parametry w oknie dialogowym Device Properties. Model elementu szeregowego składa się ze źródła napięcia połączonego szeregowo z rezystorem, co umożliwia podstawowe modelowanie takich elementów jak rezystory, cewki, diody, przełączniki itp.

W tym przypadku elementem szeregowym jest bezpiecznik F1, wybrany w opcjach połączeń RefDes, któremu przypisano nominalną wartość wewnętrznego parametru Resistance równą 0.1Ω. Gdyby element szeregowy był elementem półprzewodnikowym, takim jak dioda, należałoby określić parametr Voltage Drop oraz wartość wewnętrznego parametru Resistance tego elementu.

Zgodnie ze schematem kolejnym krokiem jest rozszerzenie sieci D1_2 do sieci zasilającej 5V przez przełącznik S1. Podobnie jak powyżej, wybierz Extend Net z menu kontekstowego otwieranego prawym przyciskiem myszy, a następnie w oknie dialogowym Choose Net wybierz sieć, do której chcesz rozszerzyć połączenie.

Dodanym elementem szeregowym jest w tym przypadku S1, który łączy sieć D1_2 z siecią wyjściową 5V przez wyprowadzenia 3 i 2 (patrz schemat). Ponieważ nieużywane wejście przełącznika S1 (wyprowadzenie 1) jest połączone z jego wyjściem (wyprowadzeniem 2) i nie przewodzi prądu obciążenia, można przykładowo usunąć wyprowadzenie 1 z analizy sieci za pomocą opcji wyboru wyprowadzeń w oknie dialogowym Device Properties — kliknij dwukrotnie pole Pin(s) we wpisie zacisku OUT.

Teraz można dodać obciążenie do sekcji 5 V połączonych sieci zasilania — w tym przypadku jest to obciążenie modułu wyświetlacza LCD1.

Po ponownym uruchomieniu analizy zarówno dane, jak i reprezentacja graficzna w edytorze PCB będą obejmować wszystkie trzy połączone sieci zasilania oraz przedstawiać obliczony prąd i spadek napięcia na łączących je elementach szeregowych.

Uwzględnianie modeli regulatorów napięcia

PDN Analyzer oferuje aktywne modele regulatorów napięcia (VRM), które można wstawiać między sieciami napięcia wejściowego i wyjściowego. Po dodaniu do sieci zasilania PDNA działają one jednocześnie jako obciążenie sieci napięcia wejściowego i źródło dla sieci napięcia wyjściowego. Dostępne modele VRM obejmują regulatory liniowe, impulsowe oraz impulsowe ze zdalnym pomiarem napięcia.

W projekcie referencyjnym SpiritLevel-SL1 zastosowano liniowe regulatory napięcia do uzyskania szyn zasilających 3,3 V (VCCO) i 1,8 V (VCCINT). Po dodaniu regulatora VCCO (U3) do sieci symulacyjnej PDNA jest on przedstawiany jako obciążenie sieci wejściowej 5 V i jako źródło dla sieci 3,3 V. 

Aby umieścić regulator liniowy U3 jako obciążenie sieci 5 V (utworzonej zgodnie z powyższą procedurą), dodaj obciążenie do sieci 5 V i wybierz opcję VRM (Linear) jako Device Type w oknie dialogowym Device Properties. Ustaw połączenia modelu zgodnie ze schematem i wskaż wyprowadzenie Ref jako połączenie GND elementu R14. Ten punkt odniesienia może znajdować się w innym, być może bardziej odpowiednim miejscu w bezpośrednim sąsiedztwie na PCB, zależnie od układu sieci GND.

Aby zakończyć konfigurację modelu VRM, ustaw parametr napięcia wyjściowego (Vout: 3.3V) oraz opcjonalnie jego rezystancję wyjściową (wewnętrzną), prąd spoczynkowy i wszelkie Limits, które mają być wykrywane podczas analizy.

PDNA umożliwia automatyczne dodanie modelu strony wyjściowej VRM jako źródła do docelowej sieci napięcia wyjściowego oraz, w razie potrzeby, utworzenie tej sieci.

W omawianym przykładzie kliknij prawym przyciskiem myszy właśnie utworzony model obciążenia VRM (Load2: U3) i wybierz opcję Add VRM To New Network. Spowoduje to automatyczne utworzenie sieci VCCO z modelem strony wyjściowej VRM (Source 1: U3) jako źródłem napięcia (3,3 V).

Pamiętaj, że obie reprezentacje modelu VRM 3,3 V — model wejściowy jako obciążenie sieci 5 V i model wyjściowy jako źródło dla sieci 3,3 V — są ze sobą powiązane i w istocie stanowią ten sam model. Dlatego dostęp do modelu VRM i jego edycja są możliwe z poziomu dowolnej z tych sieci w interfejsie PDNA.

Teraz można wybrać nową sieć VCCO i dodać odpowiednie obciążenie. W tym przykładzie jest to prąd obciążenia 0,2 A pobierany przez wiele wyprowadzeń elementu U1.

Utworzony układ sieci zasilania obejmuje teraz dwie sieci (PWR_IN i VCCO) połączone liniowym modelem VRM 3,3 V. Po wybraniu najwyższego poziomu hierarchii sieci w bieżącej strukturze pliku PDNA widok graficzny sieci przedstawia schemat blokowy połączeń między sieciami zasilającymi.

W tym przykładzie moduł VRM został dodany jako obciążenie do sieci 5 V (napięcie wejściowe), a następnie wykorzystany do automatycznego utworzenia sieci napięcia wyjściowego 3,3 V (VCCO), w której pełni rolę źródła. Możliwa jest również odwrotna kolejność, która w niektórych przypadkach może być wygodniejsza. Wówczas moduł VRM dodaje się do sieci napięcia wyjściowego jako źródło, a następnie ten model dodaje się do sieci napięcia „wejściowego” jako obciążenie (Add VRM To New Network lub Add VRM To Existing Network).

Analiza PDN dostarczy wyników dla całej połączonej sieci, z uwzględnieniem modułu VRM. Edytor PCB wyświetli graficznie wszystkie sieci po wybraniu najwyższego poziomu hierarchii sieci w interfejsie PDNA. Wybierz pojedynczą sieć na liście, aby ograniczyć wizualizację do tej sieci, a następnie przełączaj opcje Net i Layer w dolnym panelu, aby dodatkowo dostosować widok.

Należy pamiętać, że ścieżka sieci GND w tym przykładzie będzie teraz uwzględniać prądy powrotne z obu sieci: PWR_IN i VCCO.

Sieć dystrybucji zasilania w przykładowym projekcie można uzupełnić, dodając pozostały moduł VRM (U4) oraz jego sieć wyjściową zasilania 1,8 V (VCCINT).

Dodaj liniowy moduł VRM do sieci 5 V w sposób opisany wcześniej i ustaw jego parametr Vout na 1.8V.

Dodaj moduł VRM (tutaj Load 3) do nowej sieci, aby utworzyć sieć zasilania 1,8 V (VCCINT).

Dodaj odpowiednie obciążenie do sieci VCCINT — w tym przypadku wyprowadzenia zasilania 1,8 V elementu U1.

Hierarchia sieci w interfejsie PDNA będzie teraz przedstawiać wszystkie trzy połączone sieci.

Analiza PDN dostarczy wyników dla całej połączonej sieci, z uwzględnieniem modułów VRM.

Ponownie należy zwrócić uwagę, że sieć GND obejmuje teraz prąd powrotny wszystkich trzech sieci, które korzystają ze wspólnych obszarów miedzi na warstwie GND. Maksymalna gęstość prądu (65.8 A/mm2) jest teraz wysoka i prawdopodobnie przekracza dopuszczalne wartości.

Lokalizowanie problemów z integralnością zasilania

PDN Analyzer udostępnia szeroki zakres informacji graficznych i danych, które można wykorzystać do oceny integralności zasilania analizowanego projektu PCB oraz rozwiązywania związanych z nią problemów.

W przedstawionym powyżej przykładzie analiza ścieżki sieci GND Top Layer wskazuje na występowanie niedopuszczalnie wysokiej gęstości prądu, o czym świadczy maksymalna wartość na skali wynosząca 65.8A/mm2. Lokalizacja problematycznego obszaru nie jest od razu oczywista, ale można ją ujawnić za pomocą funkcji Highlight Peak Values narzędzia PDNA.

Po jej wybraniu i ustawieniu opcji Filter na Maxima obszar o szczytowej gęstości prądu zostanie podświetlony i oznaczony na wizualizacji wyników analizy w edytorze PCB.

Kliknij przycisk , aby ponownie podświetlić ten obszar, lub użyj powiązanych przycisków (), aby kolejno przechodzić przez lokalizacje o najwyższych wartościach szczytowych. Ustaw opcje Scope tak, aby podświetlać wartości szczytowe w aktualnie widocznym obszarze PCB (In View)) lub na całej płytce (Design) — w tym drugim przypadku widok będzie przesuwany i przybliżany do każdej kolejnej lokalizacji.

Dodatkowe informacje o problematycznym obszarze można uzyskać, włączając funkcję Show Arrows narzędzia PDNA. Nakłada ona na widok liczne strzałki wskazujące kierunek przepływu prądu (kąt strzałki) oraz jego względne natężenie (rozmiar strzałki) w danym miejscu. W tym przykładzie potwierdza to, że obszar o wysokiej gęstości prądu jest ścieżką powrotną prądu od U1 (u góry) do obszaru GND przy dolnej krawędzi płytki.

Jednym ze sposobów rozwiązania tego problemu jest zwiększenie szerokości ścieżki w problematycznym obszarze.

Edycję PCB można przeprowadzić przy aktywnym narzędziu PDN Analyzer, co pozwala iteracyjnie ulepszać projekt płytki, a następnie ponownie go analizować. Kliknij przycisk Clear w obszarze Views, aby wyłączyć wyświetlanie wyników PDNA w edytorze PCB i wprowadzić wymagane zmiany na płytce.

Następnie można powtórzyć analizę PDN (kliknij ), aby sprawdzić wyniki dotyczące integralności zasilania. Poniższe dwa obrazy przedstawiają zmianę gęstości prądu w sieci GND (na Top Layer) wynikającą ze zwiększenia szerokości ścieżki w tym krytycznym miejscu — górny obraz przedstawia początkowy wynik analizy gęstości prądu, a dolny wizualizację gęstości prądu po modyfikacji PCB.

W porównaniu stanu przed zmianą (górny obraz) i po zmianie (dolny obraz) warto zwrócić uwagę na następujące kwestie:

  • Maksymalna gęstość prądu w warstwie GND spadła do akceptowalnego poziomu, wynoszącego około jednej dziesiątej poprzedniej wartości — z 65.8A/mm2  do 7.1A/mm2.
  • Obszary o największej gęstości prądu, której wartości są teraz znacznie niższe, są bardziej równomiernie rozłożone wzdłuż ścieżek powrotnych GND, zamiast skupiać się w jednym problematycznym miejscu.
  • Aby uzyskać bardziej miarodajne porównanie graficzne, ręcznie ustaw skalę gęstości prądu na poprzednią wartość — wybierz opcję skali Manual, wpisz 65.8 w polu Max i kliknij przycisk , aby odświeżyć widok.

Przekroczenia dopuszczalnej gęstości prądu

Bardziej obiektywnym sposobem lokalizowania i rozwiązywania problemów z integralnością zasilania w ścieżkach przepływu prądu w projekcie PCB jest zdefiniowanie konkretnych limitów gęstości prądu, których przekroczenie będzie zgłaszane jako naruszenie. Poniżej opisano inne rodzaje naruszeń.

Limity gęstości prądu dla warstw zewnętrznych i wewnętrznych oraz przelotek określa się na karcie Limits w oknie dialogowym Settings, które otwiera się przez kliknięcie prawym przyciskiem myszy nazwy bieżącej symulacji PDN i wybranie Settings z menu kontekstowego. Ustawione limity będą obowiązywać dla wszystkich warstw zewnętrznych i wewnętrznych oraz przelotek w projekcie płytki.

Określone limity gęstości prądu mają zastosowanie do wyników bieżącej analizy. Można je zmieniać i ponownie sprawdzać bez konieczności ponownego uruchamiania symulacji — wykrywanie przekroczeń limitów odbywa się po zakończeniu analizy. Wszystkie sieci zawierające naruszenia są oznaczane czerwonym przerywanym obrysem.

W przedstawionym tutaj przykładzie sieć zasilania VCCO zawiera przekroczenia dopuszczalnej gęstości prądu. Po wybraniu samej sieci VCCO ścieżka zasilania VCCO zostaje oznaczona podświetlonym obrysem wskazującym naruszenie.

Najedź kursorem na sieć z naruszeniami, aby wyświetlić wyskakującą listę aktualnych naruszeń wraz ze szczegółami. Jedyny wpis w tym przypadku wskazuje, że gęstość prądu w przelotce (około 34.5A/mm2) przekracza zdefiniowany limit (30A/mm2).

Kliknij dwukrotnie wpis naruszenia, aby przejść do jego lokalizacji na płytce (przesunąć i przybliżyć widok). Na poniższym obrazie widok graficzny PDNA jest ustawiony w trybie 3D, który wyraźniej przedstawia problematyczną przelotkę i jej połączenia z warstwami górną i dolną.

Należy pamiętać, że w celu zademonstrowania pojedynczego naruszenia zmniejszono rozmiar przelotki w projekcie płytki projektu Spirit Level.

Dane dotyczące tej przelotki, w tym informacja o przekroczeniu dopuszczalnej gęstości prądu, są dostępne na karcie Via interfejsu PDNA.

Lista informacji o przelotkach obejmuje wszystkie sieci uwzględnione w bieżącym projekcie. Klikaj nagłówki kolumn Net i Current Density, aby uporządkować listę tak, by przedstawiała przelotki sieci VCCO posortowane według gęstości prądu. Wszystkie wartości gęstości prądu przekraczające zdefiniowany limit zostaną wyróżnione na czerwono.

Kliknij dwukrotnie dowolny wpis na liście przelotek, aby przejść do jego lokalizacji w widoku graficznym płytki w PDNA.

Inne naruszenia

Oprócz wykrywania przekroczeń określonych limitów gęstości prądu PDN Analyzer wykrywa również naruszenia zadanych parametrów pracy sieci, takich jak parametry graniczne określone w konfiguracji symulacji podczas dodawania obciążenia, źródła lub elementu szeregowego.

Te parametry graniczne symulacji obejmują:

  • Dopuszczalny zakres napięcia na obciążeniu
  • Maksymalny prąd wyjściowy źródła
  • Dopuszczalną moc strat w źródle typu stabilizator liniowy oraz jego maksymalny prąd wyjściowy.
  • Maksymalny prąd wyjściowy źródła typu stabilizator impulsowy.
  • Maksymalny prąd płynący przez element szeregowy.
W odróżnieniu od parametrów symulacyjnych elementów sieci (takich jak ustawienia napięcia źródła lub prądu obciążenia), które są przetwarzane podczas analizy, wykrywanie naruszeń parametrów granicznych (takich jak określone minimalne napięcie na obciążeniu) odbywa się po jej zakończeniu. Oznacza to, że zmiana wartości parametru granicznego zostanie wykryta natychmiast, bez konieczności ponownego uruchamiania analizy symulacyjnej.

Jeśli określono parametr graniczny (ma on wartość niezerową), jego naruszenie spowoduje wyróżnienie odpowiedniego elementu sieci na schemacie sieci w interfejsie PDNA. Najedź kursorem na element, aby zobaczyć jego parametry i wyniki analizy.

W poniższym przykładzie obliczona moc strat w Source 1 (stabilizator napięcia U1) przekroczyła zdefiniowaną maksymalną wartość parametru mocy strat, wynoszącą 2W.

Bardziej szczegółowe informacje o działaniu sieci zasilającej są dostępne na jej karcie, która przedstawia wyniki analizy w formie tabeli i zawiera obliczone wartości poboru mocy sieci.

Przykład 3

Ten przykład przedstawia zastosowanie modeli symulacyjnych zasilaczy impulsowych (SMPS), czyli modułów regulacji napięcia (VRM), dostępnych w PDN Analyzer, w sieci zasilającej oraz pokazuje, jak zaktualizowany model sieci może zapewnić dokładniejsze wyniki analizy zasilania. Przykład zawiera również omówienie funkcji sondy napięciowej i konturów w PDNA, służących do wyświetlania danych napięcia w określonych punktach lub obszarach płytki.

Przykład opiera się na projekcie referencyjnym Altium DB46 Xilinx Daughter Board i koncentruje się na sekcji SMPS (U5) używanej w sieci zasilającej 1,2 V tego projektu (1V2).

Także w tym przykładzie symulacji PDN warunki początkowe są następujące:

  • projekt DB46 Xilinx Daughter Board jest otwarty w Altium Designer
  • aplikacja PDN Analyzer jest aktywna (Tools » PDN Analyzer)
  • sieci prądu stałego projektu PCB zostały zidentyfikowane w oknie dialogowym PDN Analyzer DC Net Identification, zgodnie z opisem powyżej. Pamiętaj, że w tym przykładzie wymagane są również sieci LX i AGND.

Rozpocznij tworzenie przykładowej sieci zasilającej od określenia wejściowej sieci zasilania w nowej symulacji (w razie potrzeby wybierz File » New Simulation). Jak pokazano na powyższym schemacie, w PDN <Power Net> to 5V, a <Ground Net> to GND. Source dla sieci 5 V to złącze pinowe HDR_T1 lub HDR_B1.

Impulsowy VRM

Model układu SMPS zastosowanego w projekcie dodaje się do sieci zasilającej 5 V, wybierając VRM(SMPS) jako Device Type obciążenia w oknie dialogowym Device Properties. Jak pokazuje schemat modelu w tym oknie, zestawy pinów IN i OUT są definiowane oddzielnie.

Aby poprawnie zdefiniować ten model dla układu, określ LX jako wyjście, U5 dla opcji RefDes oraz 1.2V jako parametr Vout — zgodnie z powyższym schematem. Opcjonalnie ustaw Rout oraz parametry sprawności/prądu tak, aby odpowiadały zastosowanemu układowi SMPS.

Zakończ implementację modelu SMPS, dodając VRM do jego sieci wyjściowej (Add VRM To New Network), która zostanie automatycznie wybrana jako sieć LX. Sieć LX można następnie rozszerzyć o sieć zasilającą 1,2 V, zgodnie ze schematem.

Sieci LX i 1V2 są połączone elementem szeregowym L1 (dławikiem przetwornicy obniżającej SMPS), dla którego należy ustawić odpowiednią rezystancję szeregową. Na potrzeby tego przykładu ustawiono ją na dość wysoką wartość 0.2Ω.

Na koniec dodaj U4 jako obciążenie typu 0.3A w sieci 1V2 i określ dopuszczalną odchyłkę napięcia obciążenia równą +/-5%. Pamiętaj, że w tym przykładzie opcje limitu gęstości prądu na karcie Limits okna dialogowego Settings powinny być ustawione na 0 (domyślny stan bez limitu).

Uruchom analizę i zauważ, że obciążenie w sieci złożonej LX sygnalizuje naruszenie, ponieważ napięcie sieci 1V2 na obciążeniu (U4) jest niedopuszczalnie niskie (około 1.14V).

Sonda danych

Oprócz wizualnej interpretacji grafiki PDNA i skali w edytorze PCB, PDN Analyzer oferuje szereg narzędzi do interpretacji wyników analizy w określonych obszarach lub punktach projektu płytki, takich jak aktywna Probe.

Narzędzie sondy umożliwia rejestrowanie i porównywanie danych napięcia lub gęstości prądu w wybranych punktach projektu płytki. Jego wszechstronność pozwala dokładnie oceniać wyniki analizy dla dowolnej sieci lub warstwy. W tym przykładzie można go jednak użyć do potwierdzenia przyczyny niedopuszczalnego spadku napięcia na obciążeniu sieci 1V2 — którym wyraźnie jest rezystancja elementu szeregowego L1.

Aby wykonać sondą pomiar różnicowy napięcia w sieci 1V2, najpierw ustaw PDNA tak, aby wyświetlał tylko Layer MidLayer 1 (czyli główną ścieżkę zasilania 1,2 V do U4) oraz Net 1V2. Wybierz przycisk , aby otworzyć okno dialogowe Probe, i włącz pierwszą lokalizację sondy (). Za pomocą kursora krzyżowego wskaż punkt o najwyższym napięciu (źródło sieci 1V2 na tej warstwie), a następnie zaznacz opcję  Difference sondy i wskaż drugą lokalizację () — punkt o najniższym napięciu, przy obciążeniu U4.

Zauważ, że odczyt Difference sondy wskazuje spadek napięcia na ścieżce sieci wynoszący zaledwie około 3mV. Podobnie sprawdź ścieżkę sieci LX (przy aktywnych Top i Bottom Layer), dla której spadek napięcia wynosi zaledwie około 0.5mV.

Pomiar różnicy napięć sondą between dwiema sieciami (przy włączonych Net LX i 1V2, Top i Bottom Layer) wykazuje spadek 60mV na dławiku L1. Jest to główna strata napięcia powodująca to konkretne naruszenie wykryte podczas analizy.

Choć przedstawione tutaj badanie sondą napięciową pozwoliło ustalić główną przyczynę strat IR w sieci zasilającej, można ją było zidentyfikować bardziej bezpośrednio, sprawdzając dane napięć na pinach elementów na karcie Pins w PDNA. Funkcja sondy najlepiej sprawdza się w bardziej szczegółowych badaniach, w których można w pełni wykorzystać precyzję wskazywania lokalizacji.

VRM z pomiarem napięcia SMPS

Układ zasilacza impulsowego użyty w tym przykładzie normalnie zawierałby cewkę indukcyjną (L1) o znacznie mniejszej rezystancji, jednak przedstawione tu wyniki analizy wskazują, że podstawowy model SMPS nie uwzględnia strat na L1 – na ogół nie stanowiłoby to jednak problemu w rzeczywistym układzie.

W układzie SMPS przykładowego projektu napięcie sprzężenia zwrotnego mierzone przez U5 (na wyprowadzeniu 8) jest pobierane z łańcucha rezystorów R25–R26, znajdującego się między siecią wyjściową 1V2 a siecią masy analogowej AGND. Ta ostatnia jest połączona z siecią GND za pośrednictwem rezystora łączącego sieci 0Ω R118.

Należy pamiętać, że na potrzeby tego przykładu źródłowy projekt referencyjny DB46 Xilinx Daughter Board został zmodyfikowany: bezpośrednie połączenie miedziane między sieciami GND i AGND zastąpiono połączeniem przez rezystor (R118).

Aby dokładniej odwzorować zachowanie układu w otoczeniu U5, zamiast standardowego elementu SMPS można zastosować dostępny w PDNA model zasilacza impulsowego ze zdalnym pomiarem napięcia. Model ten udostępnia osobne zaciski pomiaru napięcia (S+ i S-), które można „podłączyć” do dowolnych wyprowadzeń w określonych sieciach wyjściowych – na przykład do wyprowadzeń łańcucha rezystorów pomiarowych w tym układzie.

Pierwszym krokiem do utworzenia pełniejszego modelu sieci dla układu SMPS U5 jest dodanie sieci AGND do istniejącej sieci GND. Użyj opcji Extend Network i wybierz sieć AGND.

Sieć AGND jest połączona z siecią GND przez rezystor R118, jak pokazano na powyższym schemacie. Dla tego rezystora należy ustawić parametr Resistance na wartość 0Ω.

Aby zaktualizować model SMPS w sieci LX, usuń istniejący element źródłowy U5 (Source 1), a następnie dodaj w jego miejsce alternatywny model SMPS Sense. Ustaw połączenia zacisków IN i OUT modelu tak jak poprzednio. Zaciski pomiarowe (S+/S-) podłącz do obu końców łańcucha rezystorów sprzężenia zwrotnego układu, zgodnie ze schematem.

Przenieś zastępczy model SMPS z sieci LX do sieci źródłowej 5V, aby zapewnić zgodność sieci. W tym celu usuń z niej obciążenie U5, a następnie zastosuj opcję źródła Add VRM To Existing Network » 5V w sieci LX.

Następnie można ponownie przeanalizować zaktualizowany układ i ocenić wyniki.  Jak pokazano na poniższym rysunku, napięcie obciążenia spełnia teraz wymaganie +/-5% z dużym zapasem i nie jest sygnalizowane naruszenie. Na podstawie pomiaru napięcia wyjściowego w sieci 1V2 zasilacz SMPS skompensował spadek napięcia na elemencie szeregowym L1 – w rezultacie napięcie w sieci LX jest wyższe o 60mV.

Choć zastosowanie zaawansowanego modelu SMPS-sense w tym konkretnym układzie daje dokładniejsze wyniki analizy, w praktyce zasilacze SMPS z funkcją zdalnego pomiaru napięcia mogą wymagać bezpośrednich połączeń na PCB od zacisków pomiarowych do samego obciążenia, a nie do pobliskiej sieci sprzężenia zwrotnego. W takim przypadku obie linie pomiarowe (S+ i S-)) byłyby prowadzone oddzielnymi ścieżkami PCB do odpowiednich końców obciążenia lub w ich pobliże.

Izolinie napięcia

Wybór najlepszego miejsca podłączenia linii zdalnego pomiaru napięcia zasilacza SMPS (opisany powyżej) to jedno z wielu możliwych zastosowań funkcji Voltage Contour programu PDN Analyzer, która graficznie wskazuje kluczowe miejsca zmian napięcia w projekcie płytki.

Funkcja ta umożliwia nałożenie przerywanych izolinii napięcia na widok wyświetlanych warstw w edytorze PCB. Można zdefiniować wiele izolinii i wyświetlać je jako procent spadku napięcia w sieci lub jako bezwzględne wartości napięcia – zobacz opcje Indicate.

Oprócz zestawu izolinii odpowiadających określonym wartościom procentowym można dodać kolejną linię za pomocą opcji Slider, która umożliwia płynną regulację wartości wyznaczającej jej położenie.

Na przykład podczas wyznaczania odpowiedniego punktu pomiaru dodatniego napięcia obciążenia dla zasilacza SMPS warto podłączyć linię pomiarową w miejscu, w którym różnica napięcia względem obciążenia wynosi mniej niż, powiedzmy, 20% spadku napięcia. W pokazanym powyżej przykładzie SMPS-sense ścieżkę linii pomiarowej z U5 (S+) można podłączyć do obszaru miedzi zasilania sieci 1V2 w dowolnym dogodnym punkcie między wyprowadzeniami obciążenia U4 (po lewej stronie) a izolinią napięcia 20%.

Podobnie, aby wyznaczyć odpowiednie punkty podłączenia ujemnej linii pomiarowej (S-) zasilacza SMPS (U5), można ustawić izolinię napięcia o wartości na przykład 80% dla ścieżki powrotnej prądu obciążenia (U4) na warstwie GND. W tym przypadku, ponieważ chodzi o ujemny prąd powrotny obciążenia, odpowiednie miejsce podłączenia ujemnej linii pomiarowej do obszaru miedzi masy powinno znajdować się wewnątrz obwodu wyznaczonego przez izolinię 80%.

Raport z analizy

Aby zapisać wyniki analizy integralności zasilania do dalszego przeglądu lub udostępnienia zainteresowanym osobom, PDN Analyzer oferuje funkcję Report dotyczącą danych i dokumentacji. Funkcja raportowania generuje bardzo szczegółowy dokument HTML zawierający grafiki i dane dotyczące zarówno bieżących wyników analizy, jak i samego projektu płytki.

Wybierz przycisk , aby skonfigurować opcje raportu w oknie dialogowym HTML Report. Zaznacz pola Results, aby określić poziom szczegółowości raportu, i przejrzyj zapisane obrazy, które mają zostać dołączone do folderu raportu () – do zapisywania obrazów wyników analizy służy przycisk w głównym interfejsie.

Kliknij przycisk , aby wygenerować interaktywny raport HTML i otworzyć zawierający go folder, w którym znajdą się wszystkie obrazy (w tym zapisane zrzuty) oraz powiązany plik konfiguracji analizy (*.pdna).

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents