Ansys CoDesigner
Devido à complexidade dos produtos eletrônicos modernos que incorporam circuitos de alta velocidade e RF, é necessária uma comunicação intensa entre os engenheiros de PCB e de simulação durante o processo de projeto de PCB, e essa comunicação deve ser o mais clara e simples possível para ambos os lados. Não basta exportar um projeto alterado pelo engenheiro de PCB ou otimizado pelo engenheiro de simulação e repassá-lo para a outra parte — também é preciso comunicar o que foi alterado, o que normalmente é feito por e-mail ou verbalmente. Essa abordagem é imperfeita devido à necessidade de acompanhar todas as solicitações e comparar os dados manualmente para decidir sobre alterações no projeto ou iniciar uma nova análise. Esses e outros desafios relacionados podem ser superados por Ansys CoDesigner, uma interface para transferir projetos de placas de circuito impresso entre os domínios de projeto de PCB e simulação.
Software compatível
A seguinte plataforma de simulação e suas versões são atualmente compatíveis:
Ansys Electronics Desktop (AEDT) – versão 2023 R1, 2023 R2, 2024 R1, 2024 R2, 2025 R1, 2025 R2, 2026 R1
Instalação e configuração
Para acessar o Ansys CoDesigner no Altium Designer, a extensão de software Ansys CoDesigner deve ser instalada. Essa extensão pode ser instalada ou removida manualmente.
Para mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).
Para acessar o Ansys CoDesigner no Ansys Electronics Desktop, a extensão Altium Link deve ser instalada. O processo é o seguinte:
-
Baixe e descompacte o arquivo da extensão Altium Link. Ele pode ser obtido entrando em contato com ansyscollaboration@altium.com (informe a versão do AEDT utilizada).
-
Certifique-se de que o aplicativo AEDT esteja fechado.
-
Na pasta descompactada, localize o arquivo
install_altiumlink.bat, clique com o botão direito nele e selecione Run as administrator. -
Abra o AEDT e selecione o comando Tools » Layout Links nos menus principais.
-
Na guia Config da caixa de diálogo Layout Links que se abrir, clique no botão Add Link, navegue até a pasta
\AnsysEM\<version>\Win64dos arquivos de programa do AEDT e abra o arquivoaltiumlink.dll. -
Na guia Layout Links da caixa de diálogo Layout Links, certifique-se de que o link Altium esteja listado e feche a caixa de diálogo.
Como funciona
Depois que a funcionalidade do Ansys CoDesigner tiver sido adicionada ao software de projeto de PCB e de simulação, ela poderá transferir alterações de projeto entre ambos os lados. As alterações de projeto são transferidas por meio de um Altium 365 Workspace, que atua como uma ponte entre os dois domínios. A vantagem de transferir alterações de projeto por meio de um Workspace é que o processo de atualização se torna stateless. Isso significa que cada lado pode continuar trabalhando de forma independente; não há necessidade de se preocupar com o estágio em que a outra equipe se encontra no processo de projeto/simulação.
O Ansys CoDesigner facilita o push/pull bidirecional de alterações de projeto entre os dois domínios. No Altium Designer, alterações no empilhamento de camadas e materiais, componentes e primitivas são detectadas e podem ser aplicadas no AEDT. No AEDT, alterações propostas no empilhamento de camadas e materiais podem ser enviadas por meio do arquivo EDB e detectadas/aplicadas no Altium Designer. Engenheiros de ECAD e de simulação podem se comunicar por meio do sistema de comentários, com cada thread de comentários anexada a um componente específico em um projeto. Os resultados de simulação podem ser enviados do AEDT para o Altium 365 Workspace e associados a uma revisão do projeto, com a possibilidade de visualização pela interface do navegador do Workspace e de pré-visualização dentro do Altium Designer.
A interface de colaboração
-
No Altium Designer, o painel Ansys CoDesigner é usado para fazer Push e Pull de alterações de projeto em ambos os sentidos e exibir mensagens.
O painel Ansys CoDesigner é acessado a partir do editor de PCB no Altium Designer clicando no botão Panels no canto inferior direito da área de projeto e selecionando a opção Ansys CoDesigner no menu exibido. Observe que você deve estar conectado a um Workspace para acessar o painel, e o documento PCB deve fazer parte de um projeto PCB armazenado nesse Workspace para que seja possível usar a funcionalidade.
-
No AEDT, caixas de diálogo acessadas a partir da caixa de diálogo Layout Links (Tools » Layout Links) ou da guia Desktop da faixa de opções quando um projeto está aberto são usadas para:
- Conectar-se ao seu Altium 365 Workspace e importar dele um projeto de PCB.
- Enviar o projeto para o Workspace e obtê-lo dele.
- Explorar o histórico de troca de dados entre o Altium Designer e o AEDT.
- Adicionar comentários aos componentes no projeto.
Enviando alterações do Altium Designer
Para enviar o projeto a partir do Altium Designer, clique no botão Push no painel Ansys CoDesigner . Uma janela de edição será exibida na parte superior do painel. Digite uma mensagem sobre a alteração de projeto e clique em Send. A região Latest from Altium Designer do painel Ansys CoDesigner será atualizada com os detalhes desse envio.
O projeto poderá então ser importado para o AEDT. Para um projeto que já tenha sido importado, as alterações podem ser obtidas no AEDT.
Enviar e compartilhar para convidar um engenheiro de simulação
Ao clicar em Push no painel Ansys CoDesigner , você também pode ativar a opção Share abaixo do campo Comment para enviar por e-mail um convite ao engenheiro de simulação usando a caixa de diálogo Share with a Simulation Engineer que se abre após clicar no botão Send.
Digite o endereço de e-mail do engenheiro de simulação e uma observação opcional (se necessário), depois clique no botão Share . Você pode compartilhar com uma pessoa que já seja membro da equipe do seu Workspace, outro usuário Altium registrado dentro ou fora da sua organização, ou um usuário que não tenha uma conta Altium. Uma caixa de diálogo de notificação pode aparecer para alertá-lo de que o usuário cujo e-mail você inseriu pode estar fora da sua organização — clique em OK para convidá-lo mesmo assim.
Após um breve intervalo, outra caixa de diálogo aparecerá para indicar que o convite foi enviado com sucesso.
Como parte do processo de convite:
- Um usuário que já seja membro da equipe do seu Workspace terá o projeto compartilhado com ele com direitos de Visualização e receberá um e-mail de convite por meio do qual poderá obter acesso ao projeto dentro do Workspace.
- Um usuário que não seja membro da equipe do seu Workspace, mas tenha uma conta Altium (independentemente de estar dentro ou fora da sua organização), será adicionado como membro da equipe do Workspace, e o projeto será compartilhado com ele com direitos de Visualização. Ele receberá um e-mail de convite por meio do qual poderá obter acesso ao projeto dentro do Workspace.
- Um usuário sem conta Altium receberá um e-mail direcionando-o para um formulário intermediário para criar/registrar uma conta Altium. Ele será adicionado como membro da equipe do Workspace ao se registrar, e o projeto será compartilhado com ele com direitos de Visualização.
Obtendo alterações no Altium Designer
Quando novas alterações são enviadas do AEDT, o banner New changes have been detected aparece automaticamente no painel Ansys CoDesigner . O painel detalhará o nome do engenheiro de simulação que realizou o Push e o comentário opcional inserido por ele ao fazer o Push.
Quando o botão Pull é clicado e se o arquivo EDB tiver sido incluído no Push a partir do AEDT, cada alteração que precisa ser feita no arquivo de trabalho para sincronizá-lo com o snapshot no seu Workspace é listada. Cada diferença detectada é listada na lista Changes no painel. Desmarque a caixa de seleção de cada alteração que você não deseja aplicar. Quando estiver pronto, clique no botão Apply para aplicar todas as alterações habilitadas ao projeto.
Se os resultados da simulação tiverem sido incluídos no Push a partir do AEDT, o controle Design Summary será apresentado no painel. Clique no controle para apresentar os resultados da simulação na caixa de diálogo Design Summary.
Importando um projeto para o AEDT
Para começar a trabalhar em um projeto de PCB no AEDT, ele deve primeiro ser importado para o AEDT. Para isso:
- Na caixa de diálogo Layout Links (Tools » Layout Links), clique na célula [Action] do link Altium na guia Layout Links e selecione Projects. Como alternativa, clique no botão Projects na guia Desktop da faixa de opções quando um projeto estiver aberto. A caixa de diálogo Altium será aberta.
-
Entre na sua conta Altium. Certifique-se de que a entrada Altium Account esteja selecionada na lista suspensa na parte superior da caixa de diálogo e clique no botão Sign In. Uma página será aberta no seu navegador padrão, onde você poderá inserir as credenciais da sua conta Altium ou usar SSO para entrar na sua conta Altium – show example.
- Selecione o Workspace onde o projeto necessário está localizado na lista suspensa Workspace.
-
Selecione o projeto na lista Projects e clique no botão Import.
- Salve o arquivo de projeto AEDT usando a caixa de diálogo Save As que se abre e, em seguida, feche a caixa de diálogo Altium.
Enviando alterações do AEDT
Para enviar o projeto a partir do AEDT:
- Na caixa de diálogo Layout Links (Tools » Layout Links), clique na célula [Action] do link Altium na guia Layout Links e selecione Push/Pull. Como alternativa, clique no botão Push/Pull na guia Desktop da faixa de opções quando o projeto estiver aberto.
- Use o campo Comment na parte superior da caixa de diálogo que se abre para adicionar um comentário que descreva o que está incluído no Push.
- Ative as opções Include EDB file (para enviar as alterações de projeto) e/ou Include the Simulation Result (para enviar os resultados da simulação).
- Clique no botão Push to Altium 365. A região Latest from Ansys da caixa de diálogo será atualizada com os detalhes desse envio.
O envio será detectado no Altium Designer, e poderá ser obtido no Altium Designer conforme descrito acima.
Obtendo alterações no AEDT
Quando alterações de projeto tiverem sido enviadas do Altium Designer, elas poderão ser obtidas no AEDT.
- Na caixa de diálogo Layout Links (Tools » Layout Links), clique na célula [Action] do link Altium na guia Layout Links e selecione Push/Pull. Como alternativa, clique no botão Push/Pull na guia Desktop da faixa de opções quando o projeto estiver aberto.
-
Verifique a região Latest From Altium da caixa de diálogo que se abre para obter informações sobre o envio mais recente do Altium Designer e clique no botão Show Changes para abrir a caixa de diálogo onde as diferenças entre o projeto no Workspace e o projeto atual no AEDT são descritas. Use as caixas de seleção fornecidas nas guias da caixa de diálogo para selecionar as alterações que você deseja aplicar ao projeto no AEDT.
- Depois que as alterações forem revisadas, clique no botão Apply changes para aplicá-las ao projeto no AEDT.
Explorando o histórico de trocas
O histórico de Pushes e Pulls do projeto é mantido.
Para examinar o histórico no Altium Designer, clique no controle History à direita do título da região Latest from the Ansys no painel Ansys Codesigner . Será aberta a lista de Pushes e Pulls do Altium Designer e do Ansys . Use o botão
na parte superior do painel para retornar às alterações mais recentes.
Para examinar o histórico no AEDT, clique na célula [Action] do link Altium na guia Layout Links da caixa de diálogo Layout Links (Tools » Layout Links) e selecione Push/Pull ou Comment ou clique no botão Push/Pull ou Comment na guia Desktop da faixa de opções. Selecione a guia History da caixa de diálogo que se abre. Expanda uma entrada de push/pull para ver seus detalhes. Use o botão Refresh para atualizar a guia com os dados mais recentes.
Adicionando comentários no Altium Designer e no AEDT
Tanto os engenheiros elétricos quanto os de simulação também podem se beneficiar do suporte do Workspace a comentários, criando threads de comentários anexadas a componentes específicos.
No Altium Designer, os comentários existentes estão disponíveis por meio do painel Comments and Tasks.
-
Para adicionar um novo comentário a um componente na PCB, clique no botão Comments na parte superior do painel, passe o cursor sobre um componente na área de projeto para que ele seja destacado com uma borda azul e clique. Na caixa de diálogo de inserção de comentário que se abre, digite o comentário e clique em Post.
-
Para responder a um comentário, selecione a entrada do comentário no painel Comments and Tasks, digite a resposta no campo de texto fornecido na caixa de diálogo de inserção de comentário e clique em Reply. A resposta será adicionada à thread de comentários.
Consulte a página Document Commenting para saber mais.
No AEDT, as threads de comentários são gerenciadas por meio da guia Comments da caixa de diálogo Altium, acessada clicando na célula [Action] do link Altium na guia Layout Links da caixa de diálogo Layout Links (Tools » Layout Links) e selecionando Comment. A lista na parte superior da caixa de diálogo apresenta as threads de comentários existentes para o projeto.
Para adicionar um comentário a um componente no AEDT:
- Selecione um componente específico no painel Components (View » Components) ou na área de projeto.
- Na caixa de diálogo Layout Links (Tools » Layout Links), clique na célula [Action] do link Altium na guia Layout Links e selecione Comment.
- Digite o comentário no campo Comment na parte inferior da caixa de diálogo que se abre.
- Clique no botão Create Thread . Uma nova thread será adicionada à lista.
Para responder a uma thread existente no AEDT:
- Selecione uma entrada de comentário numerada na lista da guia Comments da caixa de diálogo Altium.
- Digite a resposta no campo Comment na parte inferior da caixa de diálogo.
- Clique no botão Reply Thread . Uma nova resposta será adicionada sob a entrada da thread de comentários relacionada na lista.












