Mantendo o Esquemático e a PCB Sincronizados
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Num relance
- Conheça a diferença entre os fluxos de trabalho de comparação bidirecional e de atualização direta e saiba quando cada abordagem é usada.
- Entenda o que o Altium Designer pode sincronizar entre o esquemático e a PCB, incluindo componentes, conectividade, classes e determinadas regras de projeto.
- Veja como as opções do projeto, como as configurações do Comparador e de Geração de ECO, influenciam o processo de sincronização e as alterações que podem ser aplicadas.
A tarefa mais comum no projeto de esquemático para PCB é manter o esquemático e a PCB correspondentes ou sincronizados. Seja ao transferir pela primeira vez um projeto capturado para uma nova PCB, seja ao fazer alterações em um projeto existente no esquemático ou na PCB, você precisa de uma forma de manter os dois lados sincronizados. O Altium Designer inclui recursos avançados de sincronização de projeto que simplificam essa tarefa, permitindo que o projetista mantenha o foco nos aspectos criativos do processo de projeto.
O processo de sincronização detecta e resolve as diferenças entre o esquemático e a PCB.
A sincronização do projeto é realizada diretamente entre os editores de esquemático e de PCB; não é utilizado nenhum documento intermediário, como uma netlist. O software usa um mecanismo de comparação para comparar todos os aspectos do projeto, apresentando o resultado como uma lista de diferenças. O projetista decide qual lado deve ser alterado para resolver as diferenças, e um conjunto de ordens de alteração de engenharia (ECOs) é criado. Quando essas ordens são aplicadas, os dois lados do projeto voltam a ficar sincronizados.
O que pode ser sincronizado?
O processo de sincronização garante que os dados de componentes e de conectividade no esquemático correspondam aos dados de componentes e de conectividade na PCB. Além desses dados, o processo de sincronização também garante que outras restrições de projeto, como classes de nets, classes de componentes e regras de projeto, estejam sincronizadas.
Configuração das opções do comparador
Dialog page: Opções do projeto de PCB, aba Comparador
Exatamente what dados do esquemático e da PCB são comparados é configurado na aba Comparador da caixa de diálogo Options for PCB Project. Selecione Project » Project Options para abrir a caixa de diálogo.

O mecanismo de comparação segue as configurações definidas na aba Comparator da caixa de diálogo Options for Project.
A área principal da caixa de diálogo inclui uma extensa lista de tipos de comparação, como Different Designators e Changed Net Name, agrupados em 5 categorias. A coluna Mode à direita inclui uma lista suspensa para cada tipo, na qual você seleciona o modo de comparação, como Find Differences ou Ignore Differences. As comparações de texto têm uma terceira opção, que permite comparar sem diferenciar maiúsculas de minúsculas.
O padrão para um novo projeto é localizar diferenças para todos os tipos de comparação. Defina as opções conforme necessário para o seu projeto.
Na parte inferior da caixa de diálogo, há opções para configurar Object Matching Criteria. A correspondência é um processo sofisticado, realizado em várias etapas, que não depende de uma simples correspondência exata de strings. Para saber mais, consulte a seção Correspondência de nets e classes.
Observe a opção Ignore Rules Defined in the PCB Only na parte inferior da caixa de diálogo. Ative-a para excluir do processo de comparação as regras que você definiu na PCB.
Sincronização de classes de nets e de componentes
Dialog page: Opções do projeto de PCB, aba Geração de classes
Além dos dados de componentes e de conectividade, você também pode gerar e sincronizar classes e regras de projeto ao realizar um Design » Update PCB.
Sincronização de regras de projeto
As regras de projeto podem ser definidas no esquemático usando um objeto Conjunto de parâmetros. Quando um objeto Conjunto de parâmetros é selecionado, o painel ou a caixa de diálogo modal Properties inclui uma área Rules. Clique na lista suspensa Add para adicionar uma regra de projeto. A regra será aplicada à net / ao barramento / ao chicote / aos objetos sob a cobertura com os quais o objeto Conjunto de parâmetros está em contato.
Na imagem abaixo, uma regra de projeto de restrição de largura está sendo aplicada à classe de nets USB_data (a classe de nets também é definida como parte desse Conjunto de parâmetros, na área Classes da lista suspensa Parameters ).

O Conjunto de parâmetros é usado para definir uma classe de nets e uma regra de projeto para as nets sob o objeto de cobertura do esquemático. Observe que as unidades de medida necessárias são configuradas na parte inferior da caixa de diálogo Editar regra de PCB.
Adição de uma regra de projeto no esquemático
- Anexe um Conjunto de parâmetros à net / ao barramento / ao chicote / à cobertura (adicione uma definição de classe de nets ao Conjunto de parâmetros, se necessário).
- Add uma definição de regra no Conjunto de parâmetros. Isso abrirá a caixa de diálogo Choose Design Rule Type, conforme mostrado acima.
- Selecione o Rule Type necessário.
- Clique no botão OK para abrir a caixa de diálogo Edit PCB Rule.
- Configure os requisitos da regra de PCB conforme necessário. Observe que as unidades de medida necessárias para essa regra de PCB são selecionadas na parte inferior da caixa de diálogo.
Tanto na imagem acima quanto na imagem abaixo, a regra de projeto é definida em um objeto Conjunto de parâmetros anexado a uma cobertura. Ao incluir uma definição de classe no objeto Conjunto de parâmetros, uma classe de nets de PCB também será criada e, como a definição de classe está presente, a regra de PCB terá o escopo InNetClass('<PCB_NetClassName >').
Na imagem abaixo, você perceberá que o objeto Conjunto de parâmetros é exibido como uma diretiva de par diferencial. Esse é um tipo especial de objeto Conjunto de parâmetros, inserido usando o comando Place » Directives » Differential Pair.

A diretiva de par diferencial é usada para definir uma classe de nets e uma regra de projeto, que é então aplicada aos pares diferenciais especificados.
Configuração das opções de geração de ECO
A caixa de diálogo Options for Project também inclui uma aba Geração de ECO. Essa aba define quais modificações de projeto podem gerar ECOs. Normalmente, todas essas opções ficam habilitadas, e as opções da aba Comparador da caixa de diálogo são usadas para configurar quais alterações de projeto devem ser sincronizadas entre o esquemático e a PCB.

A aba Geração de ECO define quais tipos de modificações podem gerar ECOs.
Identificação de diferenças
O recurso de sincronização de projeto é capaz de detectar e resolver diferenças em ambas as direções, ou seja, do esquemático para a PCB ou da PCB de volta para o esquemático.
O software é capaz de resolver essas diferenças aplicando alterações aos dois lados ao mesmo tempo. Por exemplo, imagine um cenário em que o projetista eletrônico alterou o valor de um capacitor, enquanto o projetista da PCB alterou o footprint desse mesmo capacitor. Essas duas diferenças podem ser resolvidas em um único processo de atualização, aplicando a alteração do comentário como uma atualização do esquemático para a PCB e a alteração do footprint como uma atualização da PCB para o esquemático.
Quando o mecanismo do comparador compara o projeto esquemático com a PCB, é criada uma lista completa de diferenças - nessa etapa, não se presume qual lado deve ser alterado para que ambos voltem a ficar sincronizados.
A lista de diferenças pode ser visualizada na caixa de diálogo Differences between.
Opções e controles da caixa de diálogo Diferenças entre
A caixa de diálogo é dividida basicamente em três regiões principais - Differences, Update e Change Order.
Diferenças
Essa região da caixa de diálogo lista todas as diferenças que o Comparador encontrou entre os documentos escolhidos. Cada diferença é listada na coluna correspondente ao documento em que ela se encontra. As diferenças são agrupadas por tipo de comparação, conforme listado e habilitado na aba Comparador da caixa de diálogo Project Options . A entrada nesse nível de agrupamento indica o número de diferenças desse tipo.
Clique duas vezes em uma entrada para localizar o objeto no documento de origem correspondente por meio de sondagem cruzada.
Atualização
Use essa região da caixa de diálogo para especificar qual documento deve ser atualizado para corrigir a diferença. Por padrão, todas as entradas Decision têm inicialmente a decisão No Change aplicada a elas.
A decisão de atualização para cada diferença pode ser definida individualmente clicando na entrada associada na coluna Decision e, em seguida, selecionando a ação de atualização desejada na caixa de diálogo Decisão de ECO exibida a seguir. Basta escolher a direção da atualização (qual dos documentos comparados será atualizado) ou No Updates.
Ordem de alteração
Essa região da caixa de diálogo lista (para cada diferença sobre a qual você decidir agir) a ação a ser executada, o objeto afetado pela ação e o documento no qual a ação será realizada. Essas informações são usadas para compilar a ECO subsequente, que será usada para realizar as atualizações. As ações comuns listadas nessa área são:
- Remove - quando a atualização é feita na direção do documento que contém o objeto que causa a diferença; o objeto será removido.
- Add - quando a atualização é feita na direção do documento que não contém o objeto que causa a diferença; o objeto será adicionado.
- Update - quando ambos os documentos contêm o mesmo objeto, mas ele apresenta alguma diferença; o objeto alterado depende da direção escolhida.
Menu de contexto
- Create Change Order - use para criar uma ordem de alteração de engenharia (ECO).
- Generate Report - use para gerar um relatório das diferenças encontradas pelo Comparador. As decisões de atualização que você definiu e as ações serão incluídas na ECO gerada. O relatório será carregado na caixa de diálogo Report Preview. Use essa caixa de diálogo para examinar o relatório antes de exportá-lo para um dos vários formatos suportados ou imprimi-lo diretamente.
- << Update All in - use para definir a direção da atualização de todas as diferenças para o documento à esquerda (quando aplicável).
- Update All in >> - use para definir a direção da atualização de todas as diferenças para o documento à direita (quando aplicável).
- Reverse Direction For All - use para inverter rapidamente a direção da atualização de todas as diferenças (quando aplicável). Se não for válido alterar a direção de uma diferença, a entrada será definida como No Change.
- Set No Action For All - use para definir rapidamente a decisão de atualização de todas as diferenças como No Change.
- << Update Same Kind in - use para definir a direção da atualização de todas as diferenças do mesmo tipo de comparação da diferença atualmente selecionada para o documento à esquerda (quando aplicável).
- Update Same Kind in >> - use para definir a direção da atualização para todas as diferenças do mesmo tipo de comparação que a diferença atualmente em foco para o documento à direita (quando aplicável).
- Reverse Direction For Same Kind - use para inverter rapidamente a direção da atualização para todas as diferenças do mesmo tipo de comparação que a diferença atualmente em foco, quando aplicável. Se não for válido alterar a direção de uma diferença, a entrada será definida como No Change.
- Set No Action For Same Kind - use para definir rapidamente a direção da atualização para todas as diferenças do mesmo tipo de comparação que a diferença atualmente em foco como No Change.
- << Update Selected in - use para definir a direção da atualização de todas as diferenças selecionadas para o documento à esquerda (quando aplicável).
- Update Selected in >> - use para definir a direção da atualização de todas as diferenças selecionadas para o documento à direita (quando aplicável).
- Reverse Direction For Selected - use para inverter rapidamente a direção da atualização de todas as diferenças selecionadas (quando aplicável). Se não for válido alterar a direção de uma diferença, a entrada será definida como No Change.
- Set No Action For Selected - use para definir rapidamente a decisão de atualização de todas as diferenças selecionadas como No Change.
- Invert Selection - use para selecionar todas as diferenças que não estão atualmente selecionadas na lista ou desmarcar as que estão.
Controles adicionais
Os seguintes botões estão disponíveis na parte inferior da caixa de diálogo:
- Create Engineering Change Order - clique neste botão para gerar uma ECO. A caixa de diálogo Engineering Change Order será exibida, permitindo validar e executar as atualizações para sincronizar os documentos.
- Report Differences - clique neste botão para gerar um relatório das diferenças encontradas pelo Comparador. As decisões de atualização que você definiu e as ações serão incluídas na ECO gerada. O relatório será carregado na caixa de diálogo Report Preview. Use essa caixa de diálogo para examinar o relatório antes de exportá-lo para um dos vários formatos compatíveis ou imprimi-lo diretamente.
- Explore Differences - clique neste botão para investigar mais detalhadamente as diferenças encontradas pelo Comparador antes de gerar uma ECO. A caixa de diálogo Differences between será fechada e você retornará ao espaço de trabalho principal com o painel Diferenças aberto. O painel conterá todas as diferenças listadas pelo Comparador, nas mesmas categorias. Use o painel para localizar, por referência cruzada, um objeto responsável por uma diferença no documento ao qual ele pertence.
Para abrir a caixa de diálogo Difference between e visualizar uma lista de diferenças:
-
Para abrir a caixa de diálogo Choose Documents to Compare, conforme mostrado na imagem abaixo, execute o comando Project » Show Differences ou clique com o botão direito na entrada do projeto desejado (ou de um de seus documentos de origem) no painel Projects e escolha o comando Show Differences no menu de contexto. A caixa de diálogo Choose Documents to Compare é usada para selecionar quais dois documentos ou conjuntos de documentos serão comparados; normalmente, compara-se o projeto esquemático com a PCB. Você também pode usar essa caixa de diálogo para comparar qualquer documento com qualquer outro, marcando a opção Advanced Mode. Por exemplo, você pode comparar uma netlist com uma PCB ou uma PCB com outra PCB.
Em geral, a configuração padrão da caixa de diálogo — tanto no modo básico quanto no avançado — atende à maioria das necessidades de comparação de projetos, quando é necessário comparar os documentos de origem e o projeto da PCB de destino para sincronizá-los. No entanto, a caixa de diálogo também permite comparar outros documentos, o que pode ser útil se você precisar carregar versões de um projeto e comparar as diferenças entre os documentos de origem correspondentes.

Selecione a PCB com a qual o projeto esquemático será comparado. - Selecione a PCB na parte principal da caixa de diálogo e clique em OK para abrir a caixa de diálogo Difference between, conforme mostrado abaixo. Se o documento da PCB estiver atualmente sincronizado com os documentos de origem, será exibida uma caixa de diálogo informando que nenhuma diferença foi detectada.
A caixa de diálogo Differences between será aberta. O Sincronizador é bidirecional. Isso significa que você pode especificar atualizações para ambos os documentos na mesma ECO. Para sincronizar os documentos comparados, o objetivo é determinar, para cada diferença, se uma ação deve ser realizada e em qual direção a alteração deve ocorrer — especificando qual documento deve ser atualizado para corrigir a diferença. Portanto, a próxima etapa é atribuir uma direção de atualização a cada diferença:
- Para uma diferença individual, clique na coluna Update para exibir um seletor de direção, conforme mostrado na imagem abaixo.
- Para várias diferenças do mesmo tipo, clique com o botão direito em um cabeçalho, como Footprints diferentes, e selecione o comando Update Same Kind desejado.
- Para todas as diferenças, clique com o botão direito em qualquer lugar da caixa de diálogo e selecione o comando Update All desejado.

Para cada diferença, é necessário definir a direção da atualização para que uma ECO seja criada para resolvê-la.
Clique no botão Explore Differences para acessar o painel Differences e explorar as diferenças conforme descrito na seção Explorando alterações de projeto com o painel Diferenças abaixo.
Clique em Report Differences para configurar e imprimir/exportar um relatório das diferenças encontradas pelo Comparador, das decisões de atualização especificadas e das ações que serão incluídas na ECO gerada.
Depois de atribuir a direção da atualização, clique no botão Create Engineering Change Order para abrir a caixa de diálogo Engineering Change Order, descrita na seção Resolvendo diferenças — Aplicando as ECOs abaixo.
Explorando alterações de projeto com o painel Diferenças

O painel Differences exibe uma visualização hierárquica das diferenças entre documentos.
Resumo
O painel Differences é usado para exibir as diferenças lógicas ou físicas encontradas pelo Comparador de Diferenças integrado ao software ao comparar documentos de projeto (por exemplo, ao comparar a hierarquia de documentos-fonte (esquemáticos) de um projeto com o documento de projeto da PCB). O painel permite explorar interativamente as diferenças antes de decidir criar uma Ordem de Alteração de Engenharia (ECO), que será usada para sincronizar os documentos do projeto.
Acesso ao painel
Para abrir o painel Differences :
- Escolha View » Panels » Differences nos menus principais.
- Clique no botão Panels no canto inferior direito da área de trabalho de projeto e, em seguida, clique em Differences.
Exibição de diferenças
A forma como o painel Differences é utilizado depende de o objetivo ser:
- Analisar a integridade do projeto completo em termos de conteúdo e estrutura detectando diferenças lógicas na hierarquia do projeto.
- Comparar duas versões do mesmo documento esquemático ou de PCB detectando suas diferenças gráficas (físicas).
Exibição de diferenças lógicas
A comparação de documentos de projeto para identificar diferenças lógicas é realizada na caixa de diálogo Choose Documents To Compare, acessada clicando com o botão direito em um projeto (ou documento de projeto) no painel Projects e selecionando Show Differences no menu de contexto correspondente.

Clique com o botão direito no nome de um projeto e selecione Show Differences para abrir a caixa de diálogo Choose Documents To Compare.
Normalmente, o documento de PCB é comparado com a hierarquia de documentos-fonte do projeto ao qual pertence para detectar diferenças lógicas entre o conteúdo do projeto esquemático e o conteúdo do projeto da PCB.
Após clicar em OK, se houver diferenças entre os documentos selecionados, a caixa de diálogo Diferenças entre será aberta. As informações só aparecerão no painel Differences após clicar no botão Explore Differences na caixa de diálogo Differences between.
O painel Differences exibirá apenas as diferenças listadas na caixa de diálogo Differences between. Essas diferenças, por sua vez, são determinadas pelas seleções feitas na aba Comparador da caixa de diálogo Project Options (Project » Options). Essa aba lista todos os tipos de comparação, como diferenças associadas a componentes, redes e parâmetros. Definir Mode para cada categoria de comparação como Find Differences ou Ignore Differences determinará se o Comparador de Diferenças transfere seus resultados para a caixa de diálogo Differences between .

Configure como as diferenças são detectadas e relatadas na caixa de diálogo Project Options .
O painel Differences exibe as diferenças encontradas entre os documentos-fonte em uma estrutura em árvore, na qual a pasta de nível superior exibe o número total de diferenças detectadas. Em seguida, são criadas subpastas para cada tipo específico de comparação que aparece na caixa de diálogo Diferenças entre. Cada subpasta lista as diferenças específicas encontradas, que, por sua vez, são detalhadas pelos objetos nos documentos responsáveis por essas diferenças.
Se o documento associado estiver aberto (ou aberto e oculto), clicar em uma entrada de objeto no painel localizará o objeto no documento por meio de navegação cruzada.
A exibição visual do objeto usa o efeito de zoom e esmaecimento, no qual o objeto é destacado pelo esmaecimento de todos os outros objetos. O contraste do esmaecimento pode ser ajustado com o controle deslizante Dimming localizado na região Highlight Methods da página Sistema - Navegação da caixa de diálogo Preferences .
Exibição de diferenças físicas
A comparação gráfica (física) de duas versões do mesmo documento esquemático ou de PCB é realizada basicamente da mesma forma que a comparação lógica descrita acima, mas também utiliza Advanced Mode na caixa de diálogo Choose Documents To Compare.
Realize uma comparação física de documentos usando o comando Show Differences (menu do botão direito do painel Projects) para abrir a caixa de diálogo Choose Documents To Compare e, em seguida, marque a caixa Advanced Mode. Com todos os arquivos do projeto agora exibidos na caixa de diálogo, selecione as duas versões de um documento para comparação.

Seleção de documentos para comparação física na caixa de diálogo Choose Documents To Compare em Advanced Mode.
Clicar em OK iniciará a comparação gráfica e abrirá a caixa de diálogo Diferenças entre conforme descrito anteriormente. Clique em Explore Differences para abrir a lista interativa de diferenças no painel Differences.
O painel exibe as diferenças encontradas entre os documentos em uma estrutura em árvore. A pasta de nível superior exibe o número total de diferenças detectadas. São criadas entradas para cada tipo de diferença, que, por sua vez, contêm as referências específicas e o objeto (porta, componente etc.) envolvido em cada uma.
Selecionar a entrada de objeto de uma diferença detectada destacará o objeto e aplicará zoom sobre ele na área de projeto do editor.
Notas
- Se um objeto no painel estiver em um documento atualmente oculto, o documento será aberto automaticamente e se tornará o documento ativo na janela do editor de projeto quando você clicar na entrada associada.
- A filtragem aplicada ao realizar a navegação cruzada a partir do painel Differences é temporária. Portanto, você ainda pode selecionar ou editar objetos de projeto que estejam fora do escopo do filtro.
- As informações no painel Differences serão apagadas ao realizar uma nova comparação de documentos ou compilar o projeto ao qual pertencem.
- Use o comando Project » Show Physical Differences nos menus principais para detectar as diferenças físicas existentes entre duas versões de um documento esquemático ou de PCB e apresentar essas diferenças graficamente ao visualizar os dois documentos lado a lado na área de projeto. Esse recurso de exibição de diferenças físicas oferece uma comparação puramente visual — nenhum dos documentos comparados pode ser atualizado pela geração de ECOs. Ele se destina à comparação de duas versões do mesmo documento, mas, se for executado para comparar documentos diferentes, como a hierarquia de documentos-fonte do projeto e a PCB, o painel Differences aparecerá listando as diferenças lógicas detectadas.
Execução de uma atualização direta
Como o projetista geralmente sabe em qual direção deseja aplicar as atualizações, e todas essas atualizações seguem a mesma direção, você pode optar por ignorar o processo de detecção de diferenças e definição de direção que acabou de ser descrito.
Em vez de selecionar o comando Show Differences no menu Project, você escolhe o comando Update no menu Design, no editor de esquemáticos ou no editor de PCB. A escolha do editor a partir do qual você executa o comando indica a direção em que deseja aplicar as alterações — do editor this para o editor that. Por exemplo, você escolheria Design » Update no editor de esquemáticos para transferir todas as alterações do esquemático para a PCB.
A caixa de diálogo Differences between será ignorada, e você irá diretamente para a caixa de diálogo Engineering Change Order.
Se todas as atualizações forem aplicadas na mesma direção, use o comando Design » Update.
Resolução de diferenças — Aplicação das ECOs
Cada diferença é resolvida pela aplicação de uma Ordem de Alteração de Engenharia (ECO). As ECOs são listadas na caixa de diálogo Engineering Change Order, com uma ECO por linha, cada uma com sua própria caixa de seleção Enable.
Ao usar a caixa de diálogo Engineering Change Order:
- A caixa de diálogo é aberta com todas as alterações habilitadas; desabilite as alterações que deseja adiar por enquanto. A caixa de diálogo permite seleção múltipla — use o menu de contexto acessado com o botão direito do mouse para alternar o estado de habilitação das ECOs selecionadas.
- Use o comando Cross Probe do menu acessado com o botão direito do mouse para examinar os objetos afetados por essa ECO.
- Use o botão Validate Changes para verificar se as alterações podem ser executadas. As ECOs normalmente falham porque um objeto não está disponível — por exemplo, o footprint de PCB especificado não existe nas Bibliotecas disponíveis baseadas em arquivos, ou o pad especificado não existe no footprint.
- Uma ECO também pode falhar porque um objeto necessário para determinada ECO não estava presente, mas foi adicionado durante o processamento das ECOs atuais. Nessa situação, execute novamente o comando Update para concluir essa ECO.

Cada alteração de projeto é apresentada como uma ECO; habilite as que forem necessárias.
Opções e controles da caixa de diálogo de Ordem de Alteração de Engenharia
A caixa de diálogo é dividida em duas regiões principais: Modifications e Status.
Modificações
Esta região da caixa de diálogo lista todas as modificações necessárias para implementar as alterações exigidas para obter a sincronização. As modificações são agrupadas por tipo de modificação, conforme listado e habilitado na caixa de diálogo Opções do projeto — Geração de ECO. A entrada nesse nível de grupo indica o número de modificações desse tipo. Cada modificação específica nesta região é listada de acordo com o seguinte:
- Enable - esta opção determina se a modificação será incluída ou não quando a ECO for executada. Clique diretamente na caixa de seleção para alternar seu estado entre habilitada/incluída (marcada) e desabilitada/excluída (desmarcada). Você pode marcar e desmarcar a caixa de seleção Enable usando a barra de espaço.
- Action - a ação específica a ser executada. Os tipos de ação dependem do tipo de ECO que precisa ser realizada.
- Affected Object - o objeto afetado pela ação.
- Affected Document - o documento no qual a ação será executada.
Menu do botão direito do mouse
Por padrão, todas as modificações são habilitadas para inclusão quando a ECO é executada. Habilite ou desabilite cada entrada de modificação conforme necessário, individualmente ou usando os seguintes comandos disponíveis no menu do botão direito do mouse para alterar o estado de habilitação de várias modificações:
- Validate Changes - clique para executar uma verificação de validação das modificações habilitadas para inclusão na ECO. Os resultados da validação aparecerão na coluna Check , na região Status da caixa de diálogo.
- Execute Changes - clique para executar a ECO. Os resultados da execução aparecerão na coluna Done , na região Status da caixa de diálogo. Lembre-se: somente as alterações aprovadas na etapa de validação serão executadas.
- Create Report - clique para gerar um relatório das modificações contidas na ECO. O relatório será carregado na caixa de diálogo Report Preview.
- Cross Probe - clique para realizar a sondagem cruzada dos objetos de destino e de referência envolvidos em uma ação de modificação nos documentos esquemáticos e de PCB associados.
- Expand All - clique para expandir a visualização de todas as modificações na lista.
- Contract All - clique para recolher a visualização de todas as modificações na lista.
- Enable All - use para habilitar todas as modificações.
- Disable All - use para desabilitar todas as modificações.
- Enable Selected - use para habilitar todas as modificações selecionadas.
- Disable Selected - use para desabilitar todas as modificações selecionadas.
- Enable all of same Kind - use para habilitar todas as modificações do mesmo tipo da modificação atualmente em foco.
- Disable all of same Kind - use para desabilitar todas as modificações do mesmo tipo da modificação atualmente em foco.
- Invert Selection - use para selecionar rapidamente todas as modificações que não estão selecionadas na lista e desmarcar as que estão.
Status
Esta região da caixa de diálogo apresenta as seguintes informações de status para cada modificação habilitada:
- Check - este campo mostra o resultado da verificação de validação da modificação. Uma marca de verificação verde significa que a alteração proposta é compatível e será realizada na execução da ECO. Uma cruz vermelha significa que a alteração proposta é inválida e não será realizada quando a ECO for executada.
- Done - este campo mostra o resultado da execução da modificação. Uma marca de verificação verde significa que a modificação válida foi executada com sucesso.
- Message - se a modificação falhar na etapa de validação, uma entrada aparecerá neste campo (e também no painel Messages), indicando o motivo da falha.
Controles adicionais
Os seguintes controles estão disponíveis na parte inferior da caixa de diálogo e no menu de contexto:
- Validate Changes - clique para executar uma verificação de validação das modificações habilitadas para inclusão na ECO. Os resultados da validação aparecerão na coluna Check na região Status da caixa de diálogo.
- Execute Changes - clique para executar a ECO e aplicar as alterações válidas contidas nela. Os resultados da execução aparecerão na coluna Done na região Status da caixa de diálogo. Lembre-se de que somente as alterações aprovadas na etapa de validação serão executadas.
- Report Changes - clique para gerar um relatório das modificações contidas na ECO. O relatório será carregado na caixa de diálogo Report Preview.
- Only Show Errors - marque esta opção para mostrar apenas os erros da Ordem de Alteração de Engenharia. As alterações validadas não serão exibidas. Exibir apenas a lista de erros permitirá que você revise rapidamente o projeto e faça as alterações necessárias para que a ECO resultante seja validada por completo.
Entendendo a vinculação entre o esquemático e a PCB
Correspondência de componentes por identificadores únicos
Cada componente do esquemático é vinculado ao seu componente na PCB por meio de um identificador único (UID). O UID é atribuído quando o componente do esquemático é colocado na folha, e esse valor é transferido para o componente da PCB quando o projeto é transferido para o editor de PCB. Quando as informações dos componentes são transferidas pela primeira vez entre os documentos de origem do esquemático e o documento de projeto de PCB em branco, usando o Synchronizer, todos os componentes serão automaticamente vinculados pelo ID único — as informações de ID de cada componente do esquemático serão atribuídas ao footprint do componente correspondente.
Esse esquema seria adequado para um projeto simples, mas não é capaz de oferecer suporte a um projeto multicanal. Em um projeto multicanal, o mesmo componente do esquemático é repetido em cada canal físico, o que significaria que os componentes repetidos na PCB teriam o mesmo UID. Para lidar com isso, o UID do componente da PCB é criado combinando o UID do símbolo de folha pai com o UID do componente do esquemático. A sintaxe do UID da PCB muda ligeiramente, dependendo de como o projeto multicanal foi criado.
Para um projeto multicanal criado pela colocação de vários símbolos de folha que fazem referência à mesma folha de esquemático, cada símbolo de folha pode fornecer um ID único, de modo que o UID da PCB tem o formato:
\SheetSymbolUID\SchComponentUID
Para um projeto multicanal criado usando a palavra-chave Repeat, há apenas 1 UID de símbolo de folha disponível, de modo que o UID da PCB também inclui o valor ChannelIndex, no formato:
\ChannelIndex+SheetSymbolUID\SchComponentUID
Quando os componentes não estão vinculados
A vantagem de usar um UID para estabelecer a correspondência entre os componentes do esquemático e da PCB é que isso permite que os designadores fiquem fora de sincronia (talvez após várias reanotações da PCB), sem qualquer risco de impedir uma nova sincronização entre o esquemático e a PCB.
Se houver um componente no esquemático ou na PCB que não tenha um componente correspondente (com o mesmo UID) no outro editor, ocorrerá o seguinte:
- Se o componente extra estiver presente apenas no editor de origem, será gerada uma ECO para adicionar o componente ao editor de destino.
- Se o componente extra estiver presente apenas no editor de destino, será gerada uma ECO para remover o componente extra.
- Quando houver componentes sem correspondência em ambos os editores, o software precisará de instruções sobre como lidar com eles, e a caixa de diálogo Failed to Match Unique Identifiers será aberta.
A caixa de diálogo e Failed to Match Unique Identifiers
Os botões da caixa de diálogo oferecem as seguintes opções:
- Automatically Create Component Links - clique neste botão se você souber que os componentes sem correspondência já têm designadores correspondentes. Usando os designadores dos componentes, o software atribuirá UIDs correspondentes a esses componentes extras. Para os componentes cuja correspondência puder ser estabelecida pelo designador, quaisquer outras diferenças de propriedades (como parâmetros sem correspondência) resultarão na geração de ECOs. Se houver componentes cuja correspondência não puder ser estabelecida pelo designador, serão geradas ECOs para adicioná-los ou removê-los (os componentes extras presentes no editor de origem serão adicionados, e os componentes extras no editor de destino serão removidos).
-
Manual Component Links - clique neste botão se você souber que há componentes correspondentes, mas não souber o estado dos seus designadores. A caixa de diálogo Edit Component Links será aberta (descrita abaixo), permitindo selecionar manualmente cada componente de origem e de destino e transferi-los para a lista de componentes correspondentes, atribuindo-lhes UIDs correspondentes. Em seguida, serão geradas ECOs para sincronizar os designadores (e quaisquer outras propriedades de componentes sem correspondência).
- Cancel - clique neste botão para gerar ECOs que adicionem componentes extras presentes no editor de origem e removam componentes extras do editor de destino.
Vinculação manual de componentes
O estado dos vínculos entre os componentes do esquemático e os footprints dos componentes correspondentes na PCB pode ser verificado e gerenciado a qualquer momento na caixa de diálogo Edit Component Links (editor de PCB, comando Projects » Component Links).

A caixa de diálogo Editar vínculos de componentes é usada para detectar e resolver divergências de UID e é aberta a partir do editor de PCB.
Resumo dos recursos da caixa de diálogo:
- Os componentes sem correspondência são apresentados nas duas colunas Un-Matched Components à esquerda; os componentes que compartilham um UID correspondente são apresentados na região Matched Components à direita da caixa de diálogo.
- Os botões de seta no meio da caixa de diálogo são usados para estabelecer (ou desfazer) manualmente a correspondência entre os componentes selecionados, ou para desfazer a correspondência de todos os componentes atualmente correspondentes.
- O botão Add Pairs Matched By e as opções na parte inferior da caixa de diálogo são usados para examinar a lista de componentes atualmente sem correspondência e tentar estabelecer a correspondência entre eles pelas propriedades habilitadas (Designador, Comentário, Footprint).
- Quando o botão Perform Update é clicado, cada componente da PCB cuja correspondência foi recém-estabelecida recebe o UID de seu equivalente no esquemático. Se você tiver movido alguma entrada na Matched seção da caixa de diálogo de volta para as Unmatched seções, será exibida uma caixa de diálogo de confirmação avisando que as associações existentes entre componentes serão desfeitas se você prosseguir. Clicar em Yes prosseguirá com a atualização, e uma caixa de diálogo de informações será exibida com um resumo dos vínculos de componentes modificados no documento PCB. Uma nova entrada na seção Matched é resumida como um Link Modified, enquanto uma entrada anteriormente vinculada cuja correspondência você desfez agora é resumida como um Link Removed.
- Depois de usar esta caixa de diálogo para vincular componentes manualmente, é uma boa prática verificar o estado de sincronização (executar o comando Design » Update).
Correspondência de nets e classes
Tanto as nets quanto as classes têm um elemento pai (a net ou classe) e elementos filhos (os membros dessa net ou classe). Estabelecer a correspondência entre esses elementos exige uma abordagem diferente do mecanismo de UID usado para vincular componentes, para permitir alterações no elemento pai, nos elementos filhos ou em ambos. Por exemplo, algo tão simples quanto alterar o nome de uma net no esquemático não deve exigir que essa net e todos os seus pinos filhos sejam removidos da PCB, que a net com o novo nome seja adicionada e, por fim, que todos os pinos filhos sejam adicionados a essa nova net.
Para permitir isso, o software inclui algoritmos de correspondência separados para associar nets e classes pelos seus membros e também pelo nome. O processo de correspondência é configurado na seção Object Matching Criteria da aba Comparator da caixa de diálogo Options for Project.

A configuração padrão é estabelecer a correspondência primeiro pelos membros e, em seguida, pelo nome do tipo de objeto.
A correspondência desses tipos de objetos é tratada da seguinte maneira:
- Durante a sincronização do projeto, o comportamento padrão é primeiro tentar estabelecer a correspondência pelos membros, de acordo com as configurações Min Match % e Min Match Member.
- Se a correspondência pelos membros falhar, o software tentará estabelecer a correspondência pelo nome (se a opção Use Name Matching estiver habilitada).
- Se qualquer um desses processos de correspondência for bem-sucedido, você avançará para a caixa de diálogo Engineering Change Order.
-
Se ambas as técnicas de correspondência falharem (ou se a opção Use Name Matching estiver definida como
Never), a caixa de diálogo Match Manually será aberta.
- Clicar em No na caixa de diálogo Match Manually ignorará o processo de correspondência manual e avançará diretamente para a caixa de diálogo Engineering Change Order. Como você não tentou associar nenhum objeto sem correspondência, o software presume que os objetos de referência e de destino não estão relacionados; portanto, serão geradas ECOs que removerão os Unmatched Reference Objects da placa e adicionarão os Unmatched Target Objects como novos objetos.
- Se você clicar em Yes na caixa de diálogo para estabelecer a correspondência manualmente, a caixa de diálogo Match será aberta, conforme mostrado abaixo (o título da caixa de diálogo mudará de acordo com o tipo de objeto sem correspondência).
A caixa de diálogo Match é usada para associar manualmente objetos que você sabe que são correspondentes. Deixe o lado direito vazio e clique em Continue se não tiver certeza.
Opções e controles da caixa de diálogo de correspondência
-
Unmatched <Object>
- Unmatched Reference Objects - lista os objetos sem correspondência. Use os controles de expandir/recolher para abrir/fechar a lista.
- Unmatched Target Objects - lista os objetos de destino. Use os controles de expandir/recolher para abrir/fechar a lista.
-
- clique para associar os objetos de referência e de destino selecionados e mover os objetos selecionados da região Unmatched para a região Matched Pairs.
-
- clique para mover os objetos selecionados da região Matched Pairs para a região Unmatched. Essa ação desfará a correspondência dos objetos movidos.
-
- clique para mover todos os objetos da região Matched Pairs para a região Unmatched. Essa ação desfará a correspondência dos objetos movidos.
- Matched Pairs - lista os Reference Object e Target Object que agora estão associados.
- Continue - clique para aceitar as atualizações de correspondência e abrir a caixa de diálogo Engineering Change Order.
- Nesta caixa de diálogo, selecione os objetos que deseja associar em Unmatched Reference Objects e Unmatched Target Objects e, em seguida, transfira-os para a seção Matched Pairs da caixa de diálogo. Para esses objetos, o software gerará uma ECO para atualizar os nomes de modo que correspondam entre si, além de ECOs para remover/adicionar membros, para que eles também correspondam.
- Se não tiver certeza, você não precisa associar os objetos manualmente. Para qualquer objeto sem correspondência, o software presume que os objetos de referência e de destino não estão relacionados; portanto, gerará ECOs que removerão os Unmatched Reference Objects da placa e adicionarão os Unmatched Target Objects como novos objetos.
- Depois de associar os objetos que você sabe que são correspondentes, clique em Continue para abrir a caixa de diálogo Engineering Change Order.
- Se você clicar em Cancel, o processo de atualização será encerrado.
Correspondência das regras de projeto
As regras de projeto definidas no esquemático também devem ser vinculadas à regra correspondente na PCB. Se não houvesse um mecanismo de vinculação, não seria possível atualizar a regra no esquemático e transferir essas alterações para a PCB. Os UIDs são usados para vincular a regra de projeto do esquemático à regra de projeto da PCB.
O UID é atribuído automaticamente no conjunto de parâmetros que contém a definição da regra no esquemático e transferido para a PCB durante a sincronização do projeto.
As regras de projeto usam um UID para associar a definição da regra de projeto do esquemático à regra de projeto da PCB.
Normalmente, você não precisará gerenciar manualmente a correspondência entre as regras, a menos que tenha editado manualmente o UID na caixa de diálogo PCB Rules and Constraints do editor de PCB. Se os UIDs não corresponderem, o software adicionará uma nova regra à PCB para cada regra do esquemático que não tenha uma regra correspondente na PCB e removerá qualquer regra de projeto da PCB que não tenha uma regra de projeto correspondente no esquemático.
