Guia de Início Rápido do Power Analyzer da Keysight

Num relance

Este guia de início rápido apresenta como o Power Analyzer by Keysight ajuda você a avaliar a rede de distribuição de energia CC de um projeto de PCB no Altium Designer, permitindo ir além das suposições e verificar se os caminhos de cobre, planos, trilhas e vias conseguem atender às demandas de energia do seu projeto. Ele explica como a extensão se integra diretamente ao seu projeto atual, como instalá-la e iniciá-la, quais informações de configuração são necessárias antes de executar uma análise e como começar a definir e simular redes de alimentação. Se você busca um ponto de partida mais claro para usar o Power Analyzer by Keysight no seu fluxo de trabalho atual, este artigo apresenta as etapas essenciais para começar. Continue lendo para ganhar confiança no uso da ferramenta.

- Saiba o que o Power Analyzer by Keysight faz no Altium Designer e como ele auxilia na análise de integridade de energia CC usando os dados existentes do seu projeto.
- Conheça o fluxo de trabalho básico para instalar a extensão, abrir o documento do analisador e preparar as configurações da placa e das redes para a simulação.
- Entenda os principais requisitos de preparação, incluindo a sincronização entre o esquemático e a PCB, as opções de configuração, os requisitos de assinatura e a seleção das redes de alimentação.
Aprofunde-se com a IA:

Com projetos digitais modernos que apresentam circuitos de alta velocidade, placas densamente povoadas e múltiplas linhas de alimentação de baixa tensão, as exigências impostas à rede de distribuição de energia CC do projeto requerem uma abordagem analítica para seu dimensionamento. A análise CC de uma rede de distribuição de energia, ou os resultados de sua análise de integridade de energia CC (PI-DC), tem como objetivo garantir que haja cobre suficiente no caminho entre as fontes de tensão e as cargas — em outras palavras, que os planos, as trilhas e as vias da placa tenham dimensões (e características) suficientes para atender aos requisitos de consumo de energia dos dispositivos na placa.

Felizmente, é possível eliminar as suposições da avaliação da rede de distribuição de energia de uma PCB com o uso de uma ferramenta de simulação de integridade de energia CC (PI-DC), que analisa o desempenho CC do projeto da placa com base em suas propriedades elétricas e físicas. Uma ferramenta desse tipo está disponível para o Altium Designer: o Power Analyzer by Keysight.

Disponibilizado como uma extensão do Altium para download, o Power Analyzer integra-se diretamente ao Altium Designer para permitir a simulação e a análise PI-DC do projeto de PCB atual. Como o Power Analyzer funciona dentro do Altium Designer, não é necessário importar ou exportar dados manualmente, converter dados ou executar aplicativos separados — basta iniciar o Power Analyzer no editor de esquemáticos ou de PCB, definir os parâmetros de teste desejados e executar a simulação. Os resultados são apresentados principalmente por meio de modelagem 2D/3D do layout de cobre da placa de circuito, permitindo uma avaliação rápida dos resultados e a realização de testes exploratórios do tipo “e se” no projeto do layout da PCB.

Acesso às funcionalidades do Power Analyzer by Keysight

Para acessar as funcionalidades do Power Analyzer by Keysight no Altium Designer, a Power Analyzer by Keysight extensão de software deve estar instalada. Essa extensão pode ser instalada ou removida manualmente.

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Ao clicar para baixar e instalar a extensão, a End-User License Agreement é aberta (). Clicar em Accept indica sua aceitação dos termos e condições do EULA; ao fazer isso, a instalação continuará. Clicar em Close indica que você não aceita os termos e condições do EULA, e o processo de instalação será interrompido.

Quando a extensão de software Power Analyzer by Keysight está instalada, ela permite:

 
 
 
 
 
  • adicionar um novo documento de análise de energia ou abrir um existente; 

  • Button, Manage Power Nets configurar o Power Analyzer e as redes de alimentação; 

  • Button, Show Power Net in Tree examinar a estrutura em árvore das redes;

  • Button, Show the Power Net Analysis on the PCB examinar quaisquer resultados existentes de análise de energia;

  • Button, View the Power Net Analysis results as a Report visualizar relatórios existentes e gerar novos relatórios a partir de resultados existentes de análise de energia.

No entanto, para realizar uma nova análise de energia, você precisa ter uma assinatura válida do Power Analyzer by Keysight. Caso contrário, ao tentar iniciar uma análise de energia, será aberta a caixa de diálogo Analyze Your Power Nets, na qual você poderá solicitar uma avaliação gratuita ().

Inicialização do Power Analyzer

Para começar a trabalhar com o Power Analyzer, abra o documento de PCB do projeto ou um de seus esquemáticos e selecione Tools » Power Analyzer by Keysight nos menus principais.

O documento do Power Analyzer Keysight (<ProjectName>.pdnaK) será aberto e adicionado à área Source Documents do projeto (no painel Projects), conforme mostrado abaixo.

O comando Power Analyzer by Keysight não está disponível no menu? Verifique se a extensão está instalada e se você tem uma assinatura para ela (saiba mais).

O Power Analyzer pode ser iniciado pelos menus do editor de esquemáticos ou do editor de PCB. No entanto, como o Power Analyzer simula as estruturas da PCB, quaisquer alterações de projeto feitas no esquemático devem ser sincronizadas com a PCB antes que possam ser detectadas no documento do analisador (*.pdnaK). Se uma alteração de projeto não tiver sido detectada, salve, feche e reabra o documento do analisador.

Preparação para a análise

Pronto para realizar uma análise, mas, ao clicar no botão Analyze, uma caixa de diálogo é aberta oferecendo acesso a uma versão de avaliação? Verifique se a extensão está instalada e se você tem uma assinatura para ela (saiba mais).

O Power Analyzer precisa conhecer as propriedades físicas da sua placa. Elas incluem as densidades máximas de corrente para as camadas externas/internas, os diâmetros mínimo e máximo das vias, o tipo de cobre, a temperatura de operação e assim por diante. Essas propriedades são definidas na região Configuration do documento do analisador.

Opções de configuração

  • Os valores de densidade máxima de corrente e de corrente máxima nas vias são os mesmos para todas as nets, pois dependem da geometria do cobre.

  • As configurações de Max Current Density for Surface / Internal Layers especificam o valor permitido para as camadas correspondentes da PCB.

  • A corrente máxima nas vias é especificada para os tamanhos mínimo e máximo de furo usados no projeto. Os valores de diâmetro do furo são definidos nos campos Min Via Diameter e Max Via Diameter, juntamente com o valor de Max Current permitido para esse tamanho de furo.

  • O software divide o layout da PCB em malhas durante o processo de simulação. Por padrão, é usado um tamanho de malha dinâmico. Ao marcar a caixa de seleção Simulation Mesh Size, você pode definir o tamanho de malha necessário.

  • A configuração padrão exclui a net de terra dos resultados do mapa de calor. Para incluir a net de terra, desmarque a caixa de seleção Skip Ground e selecione a net GND na lista suspensa Network / Net, na parte superior do painel Power Analysis by Keysight, para explorar os resultados do mapa de calor. Observe que o mapa de calor oferece suporte a estruturas de polígonos em camadas de sinal, mas o comportamento de uma camada de plano de alimentação não pode ser simulado.

  • O campo Copper Type especifica o tipo de cobre usado, juntamente com seus parâmetros associados e os parâmetros de temperatura. 

  • O Work Temperature é usado para determinar a resistividade dos condutores, e o Temperature Compensation é uma característica do próprio material relacionada à sua condutividade térmica. Diferentes materiais têm diferentes coeficientes de condutividade térmica e, consequentemente, afetam o aquecimento do material de acordo com a carga. Esse aquecimento afeta a resistência interna do material, que, por sua vez, afeta a queda de tensão.

  • O Via Plating Thickness exibido na região Global PCB Parameters é definido no painel Properties do Layer Stack Manager – saiba mais.

Altere esses valores padrão conforme necessário para adequá-los ao seu projeto.

Além da densidade máxima de corrente e da corrente máxima nas vias, o valor da queda de tensão permitida deve ser especificado para cada net de alimentação definida. Configure o DC Drop Limit para cada net, selecionando uma porcentagem predefinida ou inserindo um valor de Custom.

Os Auto-Define Settings são usados pelo Power Analyzer ao tentar definir automaticamente as nets de alimentação do seu projeto. Para isso, ele precisa saber como identificar elementos do circuito, como reguladores de tensão, conectores e componentes em série. Além de usar indícios como os prefixos dos designadores de componentes, você também pode adicionar parâmetros a determinados componentes para aprimorar o processo de detecção automática. Para obter mais informações, consulte a seção Requisitos de reconhecimento automático.

Adição de uma net de alimentação para simulação

Para adicionar uma net de alimentação para simulação, clique no botão  no canto superior esquerdo para abrir a caixa de diálogo Manage Nets. Marque a caixa de seleção do Power Net Name desejado e configure o Reference Net correspondente. Se uma net não tiver um objeto de porta de alimentação no projeto esquemático, ela não será exibida na lista Power Net Name. Clique em Show Custom Nets para incluir todas as nets do projeto. Várias nets de alimentação podem ser habilitadas, se necessário. As relações hierárquicas entre as nets de alimentação são resolvidas automaticamente quando a net de alimentação está totalmente configurada.

Cada net de alimentação requer uma fonte de alimentação, que será configurada a seguir.

Você também pode clicar no botão  para que o software crie as nets de alimentação para você, o que ele tenta fazer reconhecendo automaticamente a topologia do projeto, com base nas configurações atuais da região Auto-Define Settings da seção Configuration no documento do analisador (*.pdnaK).

Adição de uma fonte de alimentação

Para adicionar uma fonte de alimentação, clique em + (ou no controle Gerenciar associado) na seção Sources do circuito de alimentação desejado. Se o circuito incluir mais de uma fonte de alimentação, clique em Gerenciar e selecione os componentes restantes.

Para que um componente esteja disponível como fonte, ele deve se conectar ao Power Net selecionado, mas pode se conectar ao Reference Net selecionado por meio de qualquer componente conectado a esse Reference Net.

O cartão do componente

Cada componente incluído como fonte ou carga é representado no documento do Power Analyzer por um Component Card.

  • Passe o cursor sobre o cartão do componente para exibir os botões Edit e Delete.
  • Clique duas vezes no cartão do componente para abrir a caixa de diálogo Properties desse componente.
  • Clique no valor de ID do item de projeto para localizar esse componente no esquemático por meio da sondagem cruzada. O nível de zoom da sondagem cruzada é definido na seção Highlight Methods da página System - Navigation da caixa de diálogo Preferences.
  • Edite o principal valor de análise desse componente diretamente no cartão (ou edite o componente para acessar todas as propriedades).

Extensão de uma net

As nets de alimentação da placa podem passar por elementos passivos, como fusíveis ou resistores, que terão uma net diferente do outro lado desse componente. Nessa situação, recomenda-se extend the net, incluindo um componente intermediário e sua segunda net como parte da net principal. A função Extend Nets é usada para essa finalidade.

Para estender uma net, clique no ícone +Estender nets ao lado do nome dela para abrir a caixa de diálogo <PowerNet> Extensions Manager. Clique em + para estender a net desejada. O Power Analyzer exibe apenas as nets que podem ser conectadas por meio de um único componente de extensão. Depois que você Add a net, um componente relacionado será adicionado automaticamente à caixa de diálogo <PowerNet> Extensions Manager, podendo ser alterado, se desejado.

As nets de alimentação podem ser estendidas por meio de um componente em série.As nets de alimentação podem ser estendidas por meio de um componente em série.

Você pode continuar estendendo a net clicando no símbolo + , conforme mostrado na imagem abaixo. Ao concluir, clique em Salvar na caixa de diálogo <PowerNet> Extensions Manager.

Continue adicionando componentes em série e nets.Continue adicionando componentes em série e nets.

Observações sobre a extensão de uma net

  • Para cada componente em série, você pode definir a queda de tensão, a resistência e a corrente máxima permitida, que serão consideradas durante a análise (mostrar imagem).

  • Se você definir uma net incorreta, poderá excluí-la passando o cursor sobre o nome dela e clicando no ícone de exclusão que aparece.

  • Depois que a net estendida for salva, os componentes conectados às nets estendidas aparecerão na lista de cargas, e você poderá adicioná-los.

  • Ao lado do nome da net de alimentação, você pode ver o número de extensões adicionadas. Passe o cursor sobre o número para exibir os nomes das nets de extensão (conforme mostrado na imagem acima).

  • O suporte à simulação de componentes em paralelo em uma net estendida foi adicionado na versão V1.0.6 da extensão PABK, e o suporte na interface do usuário foi adicionado na versão V1.0.9 da extensão PABK. Para definir componentes em paralelo, selecione a net na caixa de diálogo pop-up Extensions Manager e, em seguida, habilite todos os componentes em paralelo, conforme mostrado na imagem abaixo. Passe o cursor sobre a imagem para mostrar a caixa de diálogo após a conclusão da extensão da net.

    Selecione todos os componentes em paralelo na net.Selecione todos os componentes em paralelo na net.

Especificação de uma carga

Para adicionar um componente de carga, clique em + (ou no controle Gerenciar associado) na seção Loads e selecione o componente desejado. Um componente é listado na caixa de diálogo quando está conectado à net principal ou a uma net estendida.

Após adicionar um componente, você pode especificar seu consumo diretamente no Cartão do componente ou clicando no botão  para abrir a caixa de diálogo <NetName>/<LoadName> Load Properties.

Observações sobre a configuração de uma carga

  • Defina as propriedades da carga, incluindo Load Type, Total Load Current, Min e Max Voltage.
  • Confirme se a net de alimentação IN está configurada corretamente, assim como as opções Reference e Connected to reference through.
  • A corrente de carga é automaticamente dividida de forma igual entre todos os pinos de alimentação identificados; modifique esses valores se necessário.
  • Ao configurar uma carga do tipo IC (Current) , você pode ver todos os pinos do componente de carga que o conectam à fonte por meio de diferentes componentes em série, com a possibilidade de selecionar os pinos necessários.

Quando a caixa de diálogo Manage Loads (ou Add Sources) está aberta, ela inclui uma coluna Design Item Id. Clique em uma entrada dessa coluna para localizar o componente correspondente no esquemático por meio da sondagem cruzada, facilitando a verificação de que você está selecionando o componente correto.

O nível de zoom da sondagem cruzada é definido na seção Highlight Methods da página System - Navigation da caixa de diálogo Preferences.

Especificação de um VRM

Para definir um componente de módulo regulador de tensão (VRM), primeiro adicione-o como carga. Em seguida, abra a caixa de diálogo Load Properties do componente (clique no botão  ) para configurá-lo.

Depois que uma carga for configurada como VRM, ela também aparecerá como a fonte da net de alimentação especificada como sua net OUT.Depois que uma carga for configurada como VRM, ela também aparecerá como a fonte da net de alimentação especificada como sua net OUT.

Observações sobre a configuração de um VRM

  • Especifique Load Type como o VRM do tipo desejado.
  • Especifique a tensão de saída no campo Vout, juntamente com as outras propriedades do regulador.
  • Configure as nets IN e OUT na região Nets Management da caixa de diálogo.
  • Se o VRM não estiver conectado diretamente à net de referência ou usar uma referência diferente, configure as opções Reference e Connected to reference through conforme necessário.
  • Uma rede de alimentação filha é criada automaticamente na hierarquia, com esse VRM como fonte (conforme mostrado acima).
  • Se o VRM tiver mais de uma net de saída, adicione todas as nets necessárias usando o link +Adicionar net de saída na caixa de diálogo Load Properties e especifique a corrente de saída delas nos campos correspondentes que aparecerem.

A net de alimentação configurada

Cada net de alimentação configurada é apresentada como uma definição recolhível separada no documento *.pdnaK. A net PWR_IN configurada é mostrada abaixo, com suas duas nets de alimentação filhas, 3V3 e 1V8, ligeiramente recuadas para indicar sua condição de nets filhas.

Entendendo a definição da net de alimentação

  • Cada net de alimentação é apresentada como um Power Net Definition recolhível separado.
  • O cabeçalho da definição da net de alimentação inclui:
    • O nome da net de alimentação 
    • A net de referência 
    • Um indicador que mostra o número de nets adicionais (), se a net tiver sido estendida. Passe o cursor sobre ele para mostrar os nomes das nets filhas.
    • Um botão  ; clique nele para mostrar a estrutura de conexão dos componentes dessa net no contexto de toda a hierarquia de nets de alimentação.
    • Um botão  ; clique nele para excluir essa net do processo de análise, juntamente com todas as nets filhas.
    • Um botão  ; clique nele para analisar essa net, juntamente com todas as nets filhas.
  • Cada componente na net é representado por um Cartão do componente.
  • Depois que a net for analisada, os resultados de Voltage Drop, Current Density e Max Via Current dessa net serão mostrados na definição da net de alimentação, conforme mostrado na imagem acima.
    • Cada medidor mostra o valor simulado em relação ao limite especificado. Se o valor estiver totalmente dentro do limite, a linha da escala ficará verde. Se estiver próximo do limite, a linha ficará amarela e, se o limite for excedido, ficará vermelha. 
    • Clique no botão  para alternar a visualização para o editor de PCB, mostrando o cobre pertencente a essa net na PCB. No editor de PCB, use o painel Power Analyzer by Keysight para controlar o processo de análise.
    • Clique no botão  para gerar e abrir um relatório detalhado sobre essa net de alimentação. No relatório, use o  botão para salvar uma cópia em HTML.

A visualização em árvore das redes de alimentação

Alterne para a visualização da rede de alimentação configurada (e de quaisquer sub-redes definidas por meio de VRMs) em formato de árvore clicando no botão  correspondente. Toda a estrutura será exibida, com a rede de alimentação específica e os componentes associados devidamente destacados.

A visualização em árvore permite avaliar rapidamente se toda a rede de alimentação foi definida conforme necessário e está pronta para análise. Para retornar à janela principal, clique no link Power Analyzer by Keysight no canto superior esquerdo do documento .pdnaK.

Executar uma análise

Com a configuração concluída, você pode executar uma análise de uma rede específica clicando no botão  correspondente. Um resumo dos resultados da análise é apresentado na definição da rede de alimentação, conforme mostrado abaixo. Para ver os resultados na PCB, clique no botão  correspondente.

Para analisar todas as redes configuradas em uma única ação, clique no botão  (no canto superior direito do documento do analisador). Se você optar por analisar a rede de alimentação de nível superior na estrutura em árvore, todas as sub-redes (criadas por meio de componentes VRM) também serão analisadas. Se todas as redes tiverem sido analisadas, você poderá selecionar qual rede está destacada usando a lista suspensa Network/Net na parte superior do painel Power Analyzer by Keysight. 

Gerenciamento de camadas

A alternância entre as camadas da simulação pode ser feita da mesma forma que ao trabalhar com uma PCB: pelas abas de camadas na parte inferior da janela do Editor de PCB. Você também pode focar na camada atual com o atalho Shift+S; use esse atalho para percorrer as opções de visibilidade do modo de camada única.

Use as abas de camadas da PCB para alternar rapidamente a exibição dos resultados da análise. Aqui são mostrados os resultados da camada superior. Passe o cursor sobre a imagem para ver os resultados da camada inferior.Use as abas de camadas da PCB para alternar rapidamente a exibição dos resultados da análise. Aqui são mostrados os resultados da camada superior. Passe o cursor sobre a imagem para ver os resultados da camada inferior.

O painel Power Analyzer by Keysight

No editor de PCB, o processo de análise e os resultados são controlados pelo painel Power Analyzer by Keysight. Observe que o painel é adicionado à lista de painéis disponíveis (por meio do botão Panels) após a execução de uma análise de alimentação e depois que o botão  é clicado.  

Rede de alimentação / Rede

  • Network / Net - usado para selecionar a rede de alimentação () ou a rede () que você deseja exibir como um mapa de calor na área de trabalho gráfica.
  • Only nets with violations - quando esta opção está ativada (o padrão), apenas as redes que apresentam uma violação no momento ficam disponíveis na lista suspensa. Desmarque esta opção para listar todas as redes de alimentação. 
  • Use as técnicas padrão do editor de PCB para deslocar a visualização e ajustar o zoom na área de trabalho a fim de examinar os resultados da simulação.

Abaixo do seletor Network / Net, o painel tem duas abas, General e Heatmap. As opções dessas abas se aplicam à rede atualmente selecionada na lista suspensa Network / Net.

Selecione a rede a ser exibida e configure as opções gerais ou de mapa de calor para essa rede.Selecione a rede a ser exibida e configure as opções gerais ou de mapa de calor para essa rede.

Mapa de calor

A aba Heatmap do painel Power Analyzer by Keysight é usada para controlar quais dados são apresentados como um mapa de calor, seja a densidade de corrente ou a queda de tensão, e como as cores são aplicadas à densidade de corrente ou à queda de tensão.

Use a aba Heatmap  do painel Power Analyzer by Keysight para alterar os resultados da simulação apresentados na PCB. Aqui, são exibidos os resultados de densidade de corrente. Passe o cursor sobre a imagem para ver os resultados de queda de tensão.Use a aba Heatmap do painel Power Analyzer by Keysight para alterar os resultados da simulação apresentados na PCB. Aqui, são exibidos os resultados de densidade de corrente. Passe o cursor sobre a imagem para ver os resultados de queda de tensão.

As opções de cada um desses modos são descritas abaixo.

Mapa de calor da densidade de corrente
  • Toda a rede é colorida para refletir a densidade de corrente em cada ponto ao longo dela; quanto maior a densidade de corrente, mais quente (mais vermelha) será a cor. 
  • Show Heatmap - use este controle para remover rapidamente o mapa de calor e restaurar a exibição padrão da PCB. 
  • Show Arrows of Current Direction - habilite esta opção para exibir pequenas setas que indicam o sentido do fluxo de corrente em toda a rede.
  • Use Noise Suppression - À medida que a corrente calculada se aproxima de zero, as setas de sentido da corrente dão a impressão de que há corrente fluindo nessa área, quando, na prática, praticamente não há. Habilite esta opção para excluir esses valores de corrente mais baixos que podem induzir a interpretações equivocadas.
  • Scope Controller - a forma como as cores são aplicadas à rede para exibir a intensidade, ou o calor, é controlada por Scope Controller. O valor de Max corresponde, por padrão, à densidade de corrente máxima calculada nessa rede (mostrar imagem), e o de Min é, por padrão, 0 A/mm2. Essa escala é exibida como uma barra colorida abaixo da PCB, refletindo: as configurações atuais de mínimo e máximo, uma escala determinada pelo tipo de escala selecionado e as unidades. Os valores de Min e Max podem ser ajustados clicando e arrastando o controle deslizante ou inserindo um novo valor nos campos Min ou Max. Os valores calculados abaixo de Min são exibidos em azul, e os valores acima de Max são exibidos em vermelho. 
  • Use Logarithmic Scale - habilite esta opção para alterar a escala de linear para logarítmica. Uma escala logarítmica tem o efeito de concentrar os valores mais altos em direção à extremidade hot da escala de cores. Por exemplo, você pode habilitar a escala logarítmica para localizar rapidamente trechos do roteamento que conduzem correntes mais altas e, em seguida, alternar para a escala linear para examinar a distribuição das densidades de corrente nesse trecho do roteamento.

O mapa de calor logarítmico da densidade de corrente mostra uma área que requer atenção; passe o cursor sobre a imagem para exibir essa área usando a escala linear.O mapa de calor logarítmico da densidade de corrente mostra uma área que requer atenção; passe o cursor sobre a imagem para exibir essa área usando a escala linear.

Mapa de calor da queda de tensão
  • Toda a net é colorida para representar a queda de tensão em cada ponto ao longo dela: quanto maior a tensão, mais quente (mais vermelha) é a cor. Nessa abordagem, quanto mais fria a cor, menor a tensão (e maior a queda de tensão). 
  • Show Heatmap - use este controle para remover rapidamente o mapa de calor e restaurar a visualização padrão da PCB. 
  • Show Arrows of Current Direction - habilite para exibir pequenas setas que indicam o sentido do fluxo de corrente em toda a net.
  • Use Noise Suppression - À medida que a corrente calculada se aproxima de zero, as setas de sentido da corrente dão a impressão de que há corrente fluindo naquela área, quando ela é praticamente inexistente. Habilite esta opção para excluir esses valores de corrente mais baixa, que podem ser enganosos.
  • Scope Controller - a forma como as cores são aplicadas à net para exibir a intensidade, ou o calor, é controlada por Scope Controller. O valor de Max é definido por padrão como um valor ligeiramente abaixo da tensão máxima especificada para essa net, e o valor de Min é Max - calculated voltage drop (mostrar imagem). Essa escala é exibida como uma barra colorida abaixo da PCB, representando: a queda de tensão como valor absoluto ou porcentagem, as configurações atuais de mínimo e máximo e as unidades. Os valores de Min e Max podem ser ajustados clicando e arrastando os controles deslizantes ou inserindo um novo valor nos campos Min ou Max. Os valores calculados abaixo de Min são exibidos em azul, e os valores acima de Max são exibidos em vermelho. 
  • Scale Type - a escala de queda de tensão pode ser expressa em volts (clique no botão  ) ou como porcentagem (clique no botão  ).
  • Enable Visual Slider for Voltage Contour - quando habilitada, esta opção exibe os locais no mapa de calor onde a tensão é igual aos pontos de contorno de tensão especificados, permitindo identificá-los facilmente. Os valores dos pontos de contorno podem ser ajustados arrastando os controles deslizantes ou digitando valores nos campos Voltage Contour Points abaixo. É possível adicionar novos pontos e remover pontos existentes clicando no ícone correspondente.

Os pontos de contorno podem ser configurados para identificar rapidamente os locais na placa onde a tensão corresponde ao valor especificado.Os pontos de contorno podem ser configurados para identificar rapidamente os locais na placa onde a tensão corresponde ao valor especificado.

Detecção de violações

Se a simulação detectar uma violação de Voltage Drop, Current Density ou Max Via Current, ela será listada na seção Violations do painel Power Analyzer by Keysight. Clique em uma violação no painel para navegar até o local específico na PCB onde o erro ocorreu. Se não conseguir ler toda a descrição da violação, passe o cursor sobre a seção de descrição da violação para exibir uma dica de ferramenta com todos os detalhes.

As violações são detalhadas automaticamente na seção Violations do painel Power Analyzer by Keysight. Passe o cursor sobre a imagem para mostrar uma violação de corrente em via.As violações são detalhadas automaticamente na seção Violations do painel Power Analyzer by Keysight. Passe o cursor sobre a imagem para mostrar uma violação de corrente em via.

Observe que o modo do mapa de calor (Densidade de corrente ou Queda de tensão) é selecionado automaticamente com base no tipo de violação em que você clicar. 

Sondas

A seção de sondas do painel Power Analyzer by Keysight é usada para posicionar sondas de medição diretamente na PCB. As sondas podem medir a densidade de corrente ou a queda de tensão; o tipo de medição é determinado pelo modo atual do mapa de calor da placa.

As sondas podem ser:

  1. Uma sonda simples, para medir um valor absoluto no local da sonda, ou
  2. Uma sonda diferencial, para medir a diferença entre os dois locais de medição. 

Ambos os tipos de sondas são posicionados clicando no botão  na região Probes do painel. Para posicionar uma sonda simples, clique no local desejado e depois clique com o botão direito do mouse (ou pressione Esc). Para posicionar uma sonda diferencial, clique uma vez para definir o primeiro local de medição e, em seguida, clique novamente para definir o segundo local. Após definir uma sonda, os resultados da medição serão exibidos no painel.

Ao posicionar uma sonda, aplicam-se os mesmos recursos de ajuste do cursor usados ao posicionar outros objetos de projeto no editor de PCB. Para obter mais informações sobre o sistema unificado de ajuste do cursor, consulte a página Trabalhando com o sistema de ajuste do cursor.

Clique no botão  para criar uma imagem da PCB no local da última sonda clicada. A imagem será exibida na região Image Captures do painel, identificada por um marcador Probe. Passe o cursor sobre a captura de tela para exibir os detalhes da sonda (mostrar imagem). 

As sondas podem medir tensão ou corrente, como valor absoluto ou como diferença entre dois locais. Passe o cursor sobre a imagem para mostrar uma sonda de corrente.As sondas podem medir tensão ou corrente, como valor absoluto ou como diferença entre dois locais. Passe o cursor sobre a imagem para mostrar uma sonda de corrente.

Se o projeto for alterado de qualquer forma, as sondas existentes deverão ser removidas () e novas sondas deverão ser posicionadas.

Capturas de imagem

O recurso de captura de imagem do painel Power Analyzer by Keysight pode ser usado para capturar uma imagem específica do projeto com a net selecionada, que poderá ser incluída em um relatório.

Para capturar uma imagem de uma área específica da placa, primeiro ajuste a visualização da placa na área principal de projeto para que os elementos que deseja incluir na captura fiquem visíveis. Quando estiver pronto, clique no botão   na região Image Captures do painel para fazer a captura de tela. Você pode continuar alterando a visualização da placa e Add mais imagens. Para excluir uma imagem, passe o cursor sobre ela para revelar o botão  e clique uma vez para excluí-la.

As capturas de imagem não são mantidas no projeto. Para salvar as imagens, gere um relatório de análise.

Relatório de análise

Para gerar um relatório de análise completo, clique no botão  na parte superior do documento do analisador. O relatório completo inclui uma seção para cada net de alimentação da rede, conforme mostrado na imagem abaixo. 

No relatório, clique em uma net de alimentação para ver um relatório detalhado sobre ela, incluindo:

  • Configurações globais
  • Empilhamento de camadas da placa
  • Mapas de calor de densidade de corrente para cada camada de sinal
  • Mapas de calor de queda de tensão para cada camada de sinal
  • A visualização em árvore da rede de alimentação, destacando a net escolhida.
  • Detalhes da análise da net escolhida, incluindo: consumo de potência; detalhes das margens e dos resultados de aprovação/reprovação; um resumo detalhado do desempenho de todas as vias dessa net; todas as capturas de tela definidas pelo usuário.

  • Clique no botão  para salvar o relatório em formato HTML. Use a caixa de diálogo Save Report Settings exibida em seguida para configurar quais redes e dados específicos serão incluídos no relatório.
  • O relatório é armazenado em uma subpasta na pasta do projeto, chamada \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime>.
  • Todas as imagens do relatório são armazenadas em uma subpasta \Images.
  • Vários arquivos de log também são gerados durante a análise e armazenados em uma subpasta na pasta do projeto, chamada \PowerAnalyzerByKeysight_Output\<BoardName>\.

Requisitos de reconhecimento automático

Além de adicionar redes de alimentação manualmente, o Power Analyzer by Keysight pode reconhecer e adicionar redes de alimentação automaticamente, incluindo fontes e cargas, reduzindo o tempo necessário para definir uma estrutura de alimentação.

Configurações de definição automática

Antes de iniciar o reconhecimento automático, você deve configurar os parâmetros do algoritmo de acordo com seu projeto. Esses parâmetros são configurados na seção Auto-Define Settings da seção Configuration da janela do documento do Power Analyzer by Keysight.

Os componentes que não atendem a esses critérios de definição automática são tratados como cargas normais. Você também pode adicionar parâmetros nomeados a componentes individuais do esquemático, definindo o tipo e as propriedades de cada componente no sistema de alimentação. Esses parâmetros podem ser especificados como parte do componente durante sua criação ou adicionados posteriormente no esquemático.

Parâmetros dos componentes

Para o reconhecimento correto, todos os componentes relacionados à alimentação devem atender aos seguintes critérios:

  • Para detectar automaticamente um componente de fonte, o componente deve ter um parâmetro chamado Component Type, com o valor Source.

  • Se o parâmetro não for encontrado, a busca será baseada em Default Connectors Designators, definidos na região Auto-Define Settings da seção Configuration no documento do analisador (*.pdnaK). Observe que apenas conectores com conexões de alimentação serão definidos, a menos que sejam referenciados como parte de uma rede estendida.
  • Módulos reguladores de tensão (VRMs):
    • Os reguladores lineares devem ter um parâmetro chamado Component Type, com o valor VRM.
    • Para um regulador VRM do tipo SMPS, o parâmetro Component Type deve ter o valor SMPS.
    • Se o VRM incluir uma função de sensoriamento, o parâmetro Component Type deve ter o valor Sense.

  • Se o parâmetro não estiver definido, a busca será baseada em VRM Keywords definidos na região Auto-Define Settings da seção Configuration no documento do analisador. Por padrão, essas palavras-chave são: PWR, REG, Regulator, Voltage, Switch.

  • O valor de consumo do componente (carga) deve ser definido por um parâmetro chamado Current Consumption. Preste atenção ao símbolo separador decimal usado no valor, que pode ser . ou , dependendo das preferências do sistema.

Se um componente tiver o parâmetro de consumo de corrente, o valor especificado será dividido entre todos os pinos conectados ao mesmo circuito.

Sincronização de parâmetros

Todos os parâmetros devem estar sincronizados entre a PCB e o esquemático. Isso pode ser verificado selecionando um componente na PCB e confirmando que os parâmetros de análise de alimentação estão presentes na aba Parameters do painel Properties.

Requisitos do projeto

  • Todas as redes de alimentação devem ser definidas:
    • usando um objeto Power Port,
    • com a propriedade de rede de alimentação configurada para que a rede inclua Supply Net Parameter (conforme descrito abaixo),
    • ou com nomes que sejam detectados por Name Mask (definidos na região Auto-Define Settings da seção Configuration no documento do analisador).
  • Para obter um valor de tensão usando Name Mask, o nome da rede de alimentação deve seguir o formato *V* ou *.*V, em que * é um valor numérico, conforme mostrado na imagem abaixo.

  • Uma forma alternativa de definir o valor de tensão da rede de alimentação é configurar a propriedade Power Net, definida no painel Properties para qualquer fio da rede. Para habilitar a propriedade, primeiro posicione uma diretiva de conjunto de parâmetros (Place » Directives » Parameter Set) na rede (passe o cursor sobre a imagem abaixo para exibir uma imagem desse processo). O tamanho, a cor e o rótulo são definidos pelo usuário; é a presença da diretiva que habilita a propriedade Power Net dessa rede. Após adicionar a diretiva, selecione um fio dessa rede, habilite a propriedade Power Net e configure Voltage da rede, conforme mostrado abaixo. 

  • Os componentes em série devem seguir os designadores definidos para resistores, indutores e componentes em série personalizados (conforme definido na região Auto-Define Settings da seção Configuration no documento do analisador).

  • Os VRMs devem estar conectados a pelo menos duas redes de alimentação.

Comandos do Power Analyzer

Os comandos a seguir estão disponíveis nos menus principais do editor do Power Analyzer.

Comando

Resumo e uso

Tools » Define Automatically

Tenta reconhecer automaticamente a topologia do projeto com base nas configurações atuais da região Auto-Define Settings da seção Configuration no documento do analisador (*.pdnaK). Esse comando também pode ser acessado clicando no botão Define Automatically no canto superior esquerdo do editor.

File » Load from File

Carrega um documento salvo do Power Analyzer by Keysight (*.pdnaK) no editor do Power Analyzer.

Edit » Manage Nets

Abre a caixa de diálogo Manage Nets, na qual você seleciona as redes de alimentação a serem analisadas. Marcar uma rede adiciona essa rede ao documento do analisador (*.pdnaK). Desmarcar uma rede a remove do documento (junto com todas as redes de alimentação filhas). Esse comando também pode ser acessado clicando no botão Manage Nets no canto superior esquerdo do editor. Saiba mais sobre Gerenciamento de redes.

File » Save

Salva a configuração atual do Power Analyzer em um documento do Power Analyzer by Keysight (*.pdnaK)

File » Save As

Salva a configuração atual do Power Analyzer em um documento do Power Analyzer by Keysight (*.pdnaK) com um novo nome definido pelo usuário.

Tools » Measurement Units » mil

Configura o Power Analyzer para usar unidades de medida imperiais (mils).

Tools » Measurement Units » mm

Configura o Power Analyzer para usar unidades de medida métricas (mm).

Limitações do Power Analyzer

No momento, o Power Analyzer by Keysight não oferece suporte a:

  1. Tensões negativas.
  2. Componentes embutidos (componentes posicionados em uma camada interna). Saiba mais sobre Como projetar uma PCB com componentes embutidos.

 

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents