Capturando o projeto lógico do sistema
Num relance
- Entenda as etapas para criar um esquemático multiplaca e vincular módulos a projetos de PCB filhos.
- Saiba como o parâmetro `System:Connector` identifica os conectores que serão incluídos no projeto no nível do sistema.
- Descubra como validar projetos de PCB filhos e importar seus dados de conectividade para as entradas dos módulos.
As etapas essenciais para criar um projeto esquemático de sistema multiplacas a partir de projetos de PCB subordinados são:
-
Crie um projeto multiplacas e adicione um documento esquemático multiplacas ao projeto.
-
Posicione blocos gráficos (módulos) no esquemático multiplacas para representar logicamente os projetos de PCB subordinados.
-
Vincule cada módulo ao projeto subordinado correspondente.
-
Importe os dados de conectividade dos projetos subordinados para o projeto multiplacas.
-
Adicione conexões entre os módulos para criar o projeto lógico do sistema.
Para adicionar um documento esquemático multiplacas (*.MbsDoc) ao projeto multiplacas, clique com o botão direito do mouse na entrada do projeto no painel Projects e selecione Add New to Project » Multi-board Schematic no menu de contexto.
Habilitação de projetos de PCB para projetos multiplacas
Os projetos de PCB do Altium Designer que representam os projetos de placas subordinadas em um projeto multiplacas contêm conexões específicas, como conectores de borda ou conectores macho/fêmea de pinos, que constituem a interface elétrica e física com outras PCBs no projeto do sistema.
Essas conexões e suas redes elétricas associadas precisam ser detectadas e processadas por um documento de projeto esquemático (lógico) multiplacas para estabelecer a conectividade entre as placas no projeto em nível de sistema. Essa funcionalidade é habilitada pela presença de um parâmetro de componente específico nos conectores do projeto de PCB — um parâmetro chamado System, com Connector como valor do parâmetro.
Para cada conector em um projeto de PCB destinado a uma interconexão em nível de sistema, selecione o componente do conector e adicione o parâmetro de componente especial à lista na região Parameters, na aba General do painel Properties, com o componente selecionado.
Para saber mais sobre as propriedades dos componentes, consulte a página Trabalho com componentes posicionados.

A presença do parâmetro chamado System, com o valor Connector, vincula esse conector de PCB ao esquemático multiplacas.
Representação de projetos subordinados no esquemático multiplacas
A conectividade entre os projetos de PCB que compõem um projeto multiplacas é estabelecida posicionando blocos representativos (módulos) no esquemático e interligando seus conectores expostos (entradas de módulo) por meio de conexões.
Os módulos, que representam projetos de PCB subordinados e PCBs específicas contidas neles, são posicionados na área de projeto a partir do menu Place » Module.
Para definir a origem de um módulo posicionado, selecione-o na área de projeto e, no painel Properties, use o botão
associado ao campo Project na região Source da aba General para abrir a caixa de diálogo Choose Project (uma variante da caixa de diálogo Abrir projeto), na qual você pode procurar e selecionar um projeto de PCB ou multiplacas como origem do módulo. Após escolher o projeto necessário, selecione o projeto de placa de PCB ou a montagem multiplacas desejada dentro desse projeto usando a lista suspensa Assembly/Board.
Um projeto multiplacas estabelecido apresenta uma estrutura hierárquica de documentos que inclui os documentos de origem e os subprojetos subordinados vinculados aos módulos no projeto esquemático do sistema. A estrutura de um projeto subordinado é adicionada imediatamente ao projeto multiplacas quando um módulo do projeto do sistema é vinculado a esse projeto externo. Expanda a estrutura do projeto no painel Projects para exibir os arquivos que compõem o projeto multiplacas e seus projetos subordinados.
Para garantir que o projeto multiplacas extraia e processe os dados corretos de seus subprojetos, a PCB de cada projeto deve estar sincronizada com seu esquemático e livre de erros de projeto ou de desenho. Para validar um subprojeto de PCB, clique com o botão direito do mouse em seu nome no painel e selecione o comando Validate PCB Project <ProjectName>.PrjPcb — quaisquer problemas serão listados no painel Messages.
Use o painel Properties com um módulo posicionado selecionado para definir outras propriedades do módulo:
-
Use as propriedades Designator e Title na região Properties, na aba General do painel, para especificar o identificador esquemático e o texto do título do módulo, respectivamente. Use o botão
à direita do campo correspondente para alternar sua visibilidade no esquemático multiplaca e o botão
para permitir ou impedir a edição do valor. Use os controles de fonte e Other para configurar a fonte do texto, sua posição no documento e, no caso do texto do título, a visibilidade do nome do parâmetro.
-
A tabela na região Entries da aba General do painel Properties, quando o módulo estiver selecionado, será preenchida quando entradas de módulo forem adicionadas ao módulo – veja abaixo.
-
Use os controles na região Graphical, na aba General do painel, para configurar a aparência do módulo: seu tamanho (largura e altura), a espessura, o estilo e a cor da linha do contorno do módulo e a cor de preenchimento. As opções disponíveis de espessura e estilo de linha são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado na área de projeto. Para obter mais informações, consulte a página Configurando um documento esquemático multiplaca.
-
Use os controles na aba Parameters do painel para adicionar, modificar e remover parâmetros do módulo e configurar sua visibilidade na área de projeto.
Adicione outros módulos e seus vínculos com projetos filhos ao projeto esquemático multiplaca, conforme necessário para o projeto completo do sistema.
Os módulos são preenchidos com dados dos projetos vinculados a eles por meio da importação dos dados do projeto usando os seguintes comandos dos menus principais ou do menu de contexto da área de projeto:
-
Design » Import From Child Projects – propaga os dados de projeto de todos os projetos de origem (filhos) para os módulos especificados.
-
Design » Import From Selected Child Projects – propaga os dados de projeto dos projetos de origem (filhos) correspondentes aos módulos atualmente selecionados.
O mais importante é que isso processa os dados de pinos e redes de cada conector nos projetos filhos que tenham o parâmetro especial System:Connector associado (veja os detalhes acima). Após a conclusão da importação, uma entrada de módulo é criada automaticamente para cada um desses conectores na representação gráfica do respectivo bloco de módulo. A entrada do conector fica ativamente associada aos pinos e às redes do conector no projeto filho. Selecione a representação gráfica de uma entrada de módulo na área de projeto para ver seus detalhes, como os pinos/redes do conector, no painel Properties. Até que seja conectada à entrada de outro módulo, a listagem de componentes/pinos da entrada no painel mostrará o conector e os pinos como não acoplados.
Use o painel Properties com uma entrada selecionada para definir suas propriedades:
-
Use os controles na região Properties, na aba General do painel, para alterar o valor, a visibilidade e o estilo de Designator da entrada e escolher Type da entrada (Male/Female). Nessa região do painel, também são informados o número de pinos no conector da entrada (Number of Pins) e o número identificador atribuído a essa entrada no módulo pai (Entry Number).
-
Habilite a opção System Entry para indicar que a entrada é uma conexão no nível do sistema que não está ligada a outro módulo, por exemplo, uma entrada que representa um conector de entrada de alimentação.
-
Quando a entrada é conectada por meio de uma conexão por chicote elétrico ou cabo (saiba mais), a região Mated Component do painel é preenchida com os dados do componente acoplado.
-
Na Mated Pins região do painel, a coluna Pin lista os pinos individuais do conector e suas respectivas redes. Depois que esta entrada é conectada, a coluna Mated Pin é preenchida com uma lista dos pinos acoplados. Além disso, depois que esta entrada é conectada, a aba Addresses do painel Properties é preenchida com uma listagem tabular dos caminhos de conexão e das redes da entrada (saiba mais).
-
Use os controles na aba Parameters do painel para adicionar, modificar e remover parâmetros da entrada e configurar sua visibilidade na área de projeto.
Quando entradas de módulo são adicionadas a um módulo, a tabela na região Entries da aba General do painel Properties, quando o módulo está selecionado, é preenchida com as entradas. A coluna Part(s) lista cada entrada de módulo pelo designador e pelo nome do conector de entrada no projeto de origem. Isso pode ser editado por conveniência — a nomenclatura é local ao projeto multiplacas e não afeta os projetos filhos de origem.
Suporte a periféricos/componentes externos
O documento esquemático multiplacas oferece suporte a periféricos/componentes externos que não fazem parte das montagens de placas PCB filhas convencionais (ou seja, componentes que não pertencem a uma PCB). Isso pode incluir, por exemplo, interruptores externos, sensores e quaisquer outros módulos eletrônicos comerciais de terceiros. Essa funcionalidade é viabilizada pelo suporte a dois tipos de objetos:
-
Custom Part – uma entidade semelhante a um módulo que permite vincular um ou mais componentes de biblioteca e que é adicionada ao documento esquemático multiplacas usando o comando Place » Custom Part dos menus principais. Use a região Linked Components do painel Properties, quando a peça personalizada posicionada estiver selecionada na área de projeto, para adicionar componentes à peça personalizada e removê-los usando os botões
e
, respectivamente. Se a lista de componentes vinculados incluir componentes desatualizados do Workspace, clique no botão
para atualizar os componentes para suas revisões mais recentes. Uma entrada é adicionada automaticamente para cada componente vinculado.
-
Custom Connection – permite adicionar um único componente de biblioteca ao documento esquemático multiplacas arrastando o componente desejado do painel Components e soltando-o em um espaço livre da folha. Uma entrada é adicionada automaticamente para cada pino do componente.
Os componentes de biblioteca são aqueles disponíveis no Workspace ao qual você está conectado e nas bibliotecas locais disponíveis. Depois de posicionados/definidos, você pode conectar os componentes ao restante do projeto, por exemplo, usando conexões de cabos e chicotes.
Navegação cruzada
Os comandos de navegação cruzada disponíveis no menu principal Design e no menu de contexto da área de projeto permitem navegar rapidamente do documento esquemático multiplacas para elementos relacionados nos projetos filhos.
-
Para navegar do módulo ou da entrada atualmente selecionados até o documento PCB ou o conector nesse documento, dentro do projeto de PCB referenciado por esse módulo, use o comando Design » Crossprobe to PCB/Multi-board. Se o módulo fizer referência a um documento de montagem multiplacas (
*.MbaDoc) dentro de um projeto multiplacas de origem (*.PrjMbd), a navegação cruzada levará ao documento de montagem multiplacas. -
Para navegar do módulo ou da entrada atualmente selecionados até o esquemático de nível superior ou o conector no esquemático correspondente, dentro do projeto de PCB referenciado por esse módulo, use o comando Design » Crossprobe to Schematic.
-
Para navegar do módulo ou da entrada atualmente selecionados até a placa, ou o conector nessa placa, no documento de montagem multiplacas (
*.MbaDoc) dentro do projeto multiplacas (*.PrjMbd), use o comando Design » Crossprobe to MBA. -
Para navegar da conexão de chicote atualmente selecionada no documento esquemático multiplacas (
*.MbsDoc) até um projeto de chicote vinculado (*.PrjHar), use o comando Design » Crossprobe to Harness. O documento de diagrama de fiação do projeto de chicote associado será aberto.
Imprimir ou exportar para PDF
Para imprimir o documento esquemático multi-board ativo, selecione File » Print no menu principal (atalho: Ctrl+P). A caixa de diálogo Print será aberta. O lado esquerdo da caixa de diálogo apresenta uma pré-visualização de impressão com escala ajustável. As opções padrão de impressão estão disponíveis no lado direito da caixa de diálogo. Elas permitem selecionar uma impressora específica, confirmar a localização da impressora, verificar quantos documentos estão na fila de impressão, ajustar o número de cópias a imprimir, o tamanho da página e a orientação. Após clicar em
, o conjunto de impressão será enviado ao dispositivo de impressão escolhido, de acordo com as opções definidas.
Para exportar um documento esquemático multi-board para um arquivo PDF, selecione File » Export to PDF no menu principal.



).
).









