Trabalhando com Componentes Posicionados
Num relance
- Saiba de onde vêm os componentes, como as partes e os componentes com múltiplas partes são tratados e quais são as principais maneiras de posicioná-los em um esquema.
- Veja como buscar componentes com mais eficiência e fazer edições gráficas rápidas durante ou após o posicionamento.
- Entenda como os componentes do esquema se relacionam com os componentes da PCB e quais propriedades principais você pode consultar ou editar após o posicionamento.
Um componente em uma biblioteca representa o dispositivo físico que é colocado na placa de circuito impresso real. Em uma folha de esquemático, um componente é representado pelo seu modelo de símbolo esquemático. Cada componente pode conter uma ou mais partes.
Parte

A parte representa o componente eletrônico físico real.
Resumo
Uma parte é uma primitiva de projeto elétrico. É um símbolo esquemático que representa um dispositivo eletrônico, como um resistor, uma chave, um amplificador operacional, um regulador de tensão etc. As partes são armazenadas dentro de componentes em bibliotecas de componentes esquemáticos. Observe que cada componente pode conter uma ou mais partes. Além de uma representação simbólica do componente, a parte também inclui vínculos com modelos, como o footprint de PCB, e parâmetros usados para documentar detalhes, como parâmetros do componente e informações do fornecedor. A maneira como os vínculos com modelos e os parâmetros são adicionados à parte depende do tipo de armazenamento de biblioteca utilizado.
Disponibilidade
As partes estão disponíveis para posicionamento tanto no editor de esquemáticos quanto no editor de bibliotecas de esquemáticos.
- No editor de esquemáticos, clique em Place » Part.
- Clique com o botão direito na área de projeto e escolha Place » Part no menu de contexto.
- No painel Components, clique com o botão direito em um componente e selecione Place <ComponentName>.
- No painel Components, selecione um componente genérico como elemento provisório.
- Arraste e solte um componente do painel Components.
- Selecione o botão Place na seção Details do painel Components, ou use a tecla de atalho Enter.
- No painel SCH Library, quando estiver no editor de bibliotecas de esquemáticos, selecione um componente e clique em Place.
Posicionamento pelo painel Components
No editor de esquemáticos, o processo de seleção e posicionamento de partes pode ser realizado pelo painel Components.
- O painel exibe o conteúdo da biblioteca selecionada no momento. Use a lista suspensa ao lado do nome da biblioteca para escolher outra biblioteca.
- Use o campo de máscara abaixo do campo da biblioteca selecionada no momento para filtrar a lista e agilizar a busca, ou percorra a lista e selecione a parte desejada.
- Clique em Place, dê um clique duplo ou clique e arraste para posicionar o componente selecionado na folha de esquemático ativa. Enquanto a parte estiver presa ao cursor, ela poderá ser girada (pressione Spacebar), espelhada ao longo de um eixo (pressione X ou Y) ou editada (pressione Tab) antes do posicionamento.
- As colunas exibidas na lista de componentes da biblioteca selecionada no momento podem ser reorganizadas (clique e arraste) ou reconfiguradas (clique com o botão direito e escolha Select Columns).
-
Clique no botão
em um bloco de componente genérico para prender o componente ao cursor e posicioná-lo no documento de esquemático ativo. Selecionar o próprio bloco abrirá a categoria desse tipo de componente no painel Components.
Busca de um componente
As opções do menu de bibliotecas que não pertencem a um Workspace permitem definir preferências, realizar buscas e migrar o conteúdo de bibliotecas baseadas em bancos de dados e arquivos. Para acessar essas opções, selecione o botão do menu de bibliotecas
no canto superior direito do painel Components.
Selecione File-based Libraries Preferences para abrir a caixa de diálogo Bibliotecas baseadas em arquivos disponíveis, onde você encontrará controles para adicionar ou remover bibliotecas, instalar bibliotecas e especificar caminhos de busca de bibliotecas.
A lista atual de componentes de bibliotecas baseadas em bancos de dados e arquivos pode ser filtrada inserindo uma expressão de busca no campo Search do painel Components. Para acessar recursos de busca mais avançados para bibliotecas de componentes, selecione a opção File-based Libraries Search no menu
do painel (no canto superior direito), que abre a caixa de diálogo Busca em bibliotecas baseadas em arquivos. A caixa de diálogo oferece opções de busca flexíveis, incluindo restrições de filtro baseadas em consultas, e a possibilidade de pesquisar em todas as bibliotecas disponíveis baseadas em bancos de dados e arquivos ou naquelas localizadas em um caminho especificado.
- O Scope padrão de busca consiste em procurar Components em Available File-based Libraries.
- Como alternativa, a caixa de diálogo também permite pesquisar em Libraries on path armazenados em pastas de uma unidade. Para isso, habilite a opção Libraries on path e configure as opções Path conforme necessário.
- Os Filters usam "AND" e, portanto, é melhor começar com um filtro simples e, se houver muitos resultados, usar o modo Refine last search para pesquisar nos resultados.
- Os resultados da busca por consulta são apresentados na caixa de diálogo File-based Libraries Search ao selecionar Helper.
Posicionamento pelo editor de bibliotecas de esquemáticos
Uma parte também pode ser posicionada diretamente a partir de uma biblioteca aberta no editor de bibliotecas de esquemáticos, pelo painel SCH Library. Observe que:
- Clicar no botão Place do painel posicionará a parte (componente) selecionada na última folha de esquemático ativa.
- Enquanto a parte estiver presa ao cursor, ela poderá ser girada (pressione Spacebar), espelhada ao longo de um eixo (pressione X ou Y) ou editada (pressione Tab) antes do posicionamento. A ação também pode ser realizada enquanto o objeto é arrastado. A rotação ocorre em incrementos de 90°.
-
Se uma parte for posicionada diretamente a partir de uma biblioteca, essa biblioteca não precisará ser adicionada primeiro à caixa de diálogo Bibliotecas baseadas em arquivos disponíveis.
Edição gráfica
A edição gráfica de uma parte se limita a mover, girar e espelhar. Quando uma parte é selecionada na área de projeto, uma caixa de seleção tracejada aparece ao seu redor. Para manipular graficamente um componente selecionado:
- Pressione Delete para remover a parte selecionada do projeto.
- Clique e mantenha o botão pressionado para mover a parte selecionada. O cursor saltará para o ponto de conexão elétrica mais próximo (a extremidade de conexão do pino mais próximo).
- Pressione Spacebar para girar o arco no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. A ação também pode ser realizada enquanto o objeto é arrastado. A rotação ocorre em incrementos de 90°.
- Enquanto uma parte estiver sendo movida com o cursor, pressione a tecla X ou Y para espelhá-la ao longo desse eixo.
Trabalhando entre o componente do esquemático e o componente da PCB
O software inclui ferramentas para facilitar o trabalho entre o componente no esquemático e esse mesmo componente na PCB. Essas ferramentas incluem a Localização cruzada, a Seleção cruzada e a Seleção de componentes da PCB a partir do esquemático.
Localização cruzada
Como o nome sugere, a Localização cruzada permite clicar em um componente em um editor e ir até esse componente no outro editor. Para usar a Localização cruzada:
- Clique em Cross Probe no menu Tools do editor de esquemático ou de PCB.
- Ao clicar no componente no editor de esquemático, ele será centralizado e ampliado no editor de PCB. O nível de zoom é definido na página Sistema – Navegação da caixa de diálogo Preferences.
- O comportamento padrão é permanecer no mesmo editor, pronto para localizar outro componente. Para alternar para o outro editor ao usar a Localização cruzada, mantenha pressionada a tecla Ctrl.
Modo de seleção cruzada
O Modo de seleção cruzada seleciona o mesmo componente no outro editor. Observe que ele não amplia nem centraliza o componente. A Seleção cruzada fica ativada ou desativada. Clique em Tools » Cross Select Mode para ativar/desativar o modo. Selecione vários componentes mantendo pressionada a tecla Shift enquanto clica para selecioná-los.
Selecionando os componentes da PCB
Esse recurso permite selecionar vários componentes do esquemático em uma ordem específica e, em seguida, posicionar esses mesmos componentes no editor de PCB na mesma ordem. Para usar esse recurso:
- Selecione os componentes no esquemático um por um (mantenha Shift pressionada enquanto clica para selecionar vários componentes).
- Alterne para o editor de PCB e pressione o atalho I, C para executar o comando Reposition Selected Components. O comando Reposition Selected Components também está disponível no menu de contexto após pressionar o atalho I.
Propriedades da parte
Guia Geral
Geral
-
Reuse Block – quando o componente faz parte de um bloco de reutilização, este campo mostra o nome do bloco de reutilização pai. Clique no hiperlink Reuse Block para ver as propriedades desse bloco de reutilização.
-
Designator – insira o designador. Alterne o ícone de olho para mostrar/ocultar o designador. Use o ícone de cadeado para bloquear/desbloquear o designador. Saiba mais sobre o Designador.
-
Comment – insira um nome ou comentário. Alterne o ícone de olho para mostrar/ocultar o nome. Use o ícone de cadeado para bloquear/desbloquear o nome. O campo Comentário também pode ser usado para exibir o valor de um parâmetro definido pelo usuário ou de um parâmetro do sistema. Saiba mais sobre o Comentário.
-
Part <x> of Parts – exibe o número da parte selecionada e o número total de partes. Clique em
para bloquear/desbloquear os campos e use a lista suspensa para selecionar o número da parte associada.
-
Description – a descrição do componente/da parte.
-
Type – selecione aqui um dos seguintes tipos de componente para o footprint do componente. Os tipos disponíveis são:
-
Standard– componentes que possuem propriedades elétricas padrão, são sempre sincronizados entre o esquemático e a PCB (o footprint, os pinos/pads e as atribuições de redes devem corresponder) e são incluídos na BOM. Um exemplo é um componente elétrico padrão, como um resistor. -
Mechanical– componentes que não possuem propriedades elétricas, não são sincronizados (você deve posicioná-los manualmente em ambos os editores) e são incluídos na BOM. Um exemplo é um dissipador de calor. -
Graphical– componentes que não possuem propriedades elétricas, não são sincronizados (você deve posicioná-los manualmente em ambos os editores) e not são incluídos na BOM. Um exemplo é um logotipo de empresa. -
Net Tie (In BOM)– componentes usados para curto-circuitar duas ou mais redes diferentes entre si, são sempre sincronizados entre o esquemático e a PCB (o footprint, os pinos/pads e as atribuições de redes devem corresponder) e são incluídos na BOM. Eles diferem de um componente padrão porque a conectividade criada pelo cobre dentro do footprint não é verificada; é esse cobre que permite curto-circuitar as redes. Observação: ative a opção Verify Shorting Copper na caixa de diálogo Verificador de regras de projeto para verificar se não há cobre desconectado dentro do componente. -
Net Tie (No BOM)– componentes usados para curto-circuitar duas ou mais redes diferentes entre si, são sempre sincronizados entre o esquemático e a PCB (o footprint, os pinos/pads e as atribuições de redes devem corresponder) e not são incluídos na BOM. Eles diferem de um componente padrão porque a conectividade criada pelo cobre dentro do footprint não é verificada; é esse cobre que permite curto-circuitar as redes. Observação: ative a opção Verify Shorting Copper na caixa de diálogo Verificador de regras de projeto para verificar se não há cobre desconectado no componente. -
Standard (No BOM)– componentes que possuem propriedades elétricas padrão, são sempre sincronizados entre o esquemático e a PCB (o footprint, os pinos/pads e as atribuições de redes devem corresponder) e not são incluídos na BOM. Um exemplo é um componente de ponto de teste que você deseja excluir da BOM. -
Jumper– componentes usados para incluir jumpers de fio em um projeto de PCB, por exemplo, em uma PCB de face única que não pode ser totalmente roteada em uma camada. Para esse tipo de componente, o footprint e os pinos do componente são sincronizados entre o esquemático e a PCB, mas as atribuições de redes não são, e o componente é incluído na BOM. Além de selecionar essa opção no nível do componente, ambos os pads do componente devem ter o JumperID definido com o mesmo valor diferente de zero. Componentes do tipo Jumper não precisam ser conectados no esquemático; só precisam ser incluídos no esquemático se forem necessários na BOM. Se não forem necessários na BOM, poderão ser posicionados diretamente na PCB, onde Component Type é definido, JumperIDs são definidos e Nets é atribuído manualmente aos pads.
-
-
Design Item ID – este campo lista o nome do componente selecionado (para um componente do Workspace), o campo-chave escolhido definido em Field Settings região do arquivo DbLib/SVNDbLib (para um componente de biblioteca de banco de dados), ou o parâmetro Design Item ID definido para o símbolo do componente (para um componente de biblioteca baseada em arquivos). Clique em
para abrir a caixa de diálogo Substituir componente. Essa caixa de diálogo permite acessar todos os detalhes do componente selecionado (Parâmetros, Modelos, Opções de peças, Dados de fornecedores etc.), comparar componentes e substituir o componente atual por outro, entre outras possibilidades. Se outro componente for selecionado como substituto, este campo passará a exibir o Design Item ID completo do componente recém-selecionado. Clique no botão Validate para exibir informações sobre onde o componente está localizado. Se não for um componente do Workspace, será exibido o caminho do arquivo no qual ele está salvo no seu computador. Se for um componente do Workspace, as informações indicarão apenas que o componente foi encontrado.
-
Source – exibe o nome da biblioteca de origem do componente. Clique em
para pesquisar e selecionar a biblioteca desejada.
-
Revision state – este campo exibe o estado atual do ciclo de vida da revisão do componente selecionado, com o ícone colorido e o nome do estado da revisão.
-
Revision status – se a revisão do componente selecionado estiver em um estado aplicável (permitido para uso em projetos), a entrada indicará se a revisão é a mais recente (
Up to date) ou não (Out of date). Se a revisão estiver em um estado não aplicável (não permitido para uso em projetos), a entrada exibiráNot applicable. Clique no botão
para atualizar o componente para a revisão mais recente.
-
Component issues (somente no painel Properties) – se um componente selecionado proveniente do Altium 365 Workspace conectado apresentar algum problema de integridade, isso será indicado pelo ícone
(para erros) ou
(para erros fatais). O número à direita do ícone indica a quantidade de problemas encontrados. Clique na seta para baixo à direita do número para ver as descrições resumidas dos problemas.

Um exemplo de problemas de integridade da biblioteca encontrados. -
Supply Chain Data (somente no painel Properties) – exibe as informações da cadeia de suprimentos da Opção de peça relacionada:
- Preço unitário mediano. Esta entrada será exibida em vermelho se não houver preços ou se o preço = 0.
- Estoque. Esta entrada exibe a soma total do estoque disponível nos fornecedores habilitados como parte da fonte Altium Parts Provider do seu Workspace.
-
Barra do ciclo de vida do fabricante. Passe o cursor sobre a barra para ver uma dica informativa. Ela pode aparecer em um de quatro estados:
- Branco/Cinza = Padrão, desconhecido ou sem informações
- Verde = Estados Novo ou Produção em volume
- Laranja = Não recomendado para novos projetos
- Vermelho = Obsoleto ou EOL
Localização
-
(X/Y)
- X (primeiro campo) – a coordenada X (horizontal) atual do ponto de referência do objeto, em relação à origem atual do espaço de projeto. Edite para alterar a posição X do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Y (segundo campo) – a coordenada Y (vertical) atual do ponto de referência do objeto, em relação à origem atual. Edite para alterar a posição Y do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
-
Rotation – use a lista suspensa para selecionar a rotação. As opções são
0 Degrees,90 Degrees,180 Degreese270 Degrees.
Parâmetros
-
Grid – lista os Name e Value dos parâmetros associados ao componente atualmente selecionado. Use
para bloquear/desbloquear um parâmetro listado e impedir que ele seja atualizado. Os valores dos parâmetros podem ser inseridos manualmente ou selecionados em uma lista suspensa que oferece valores provenientes de todos os componentes disponíveis desse tipo. Você pode alternar o ícone de olho para mostrar/ocultar o parâmetro.
-
Favorites – os parâmetros marcados como Favoritos serão exibidos na lista de Parâmetros, enquanto os não marcados ficarão ocultos. Passe o cursor à direita do nome de um filtro de parâmetros e clique no ícone
para definir o filtro como Favorito. Para remover um parâmetro dos Favoritos, clique no ícone novamente.
Para ver todos os parâmetros ocultos, clique no controle Show More na parte inferior da lista. Clique no controle Show Less para visualizar apenas os parâmetros Favoritos.
-
Font – clique na fonte exibida para alterar o estilo da fonte.
-
Other – clique para abrir uma lista suspensa e alterar opções adicionais:
- Show Parameter Name – habilite para mostrar o nome do parâmetro.
- Allow Synchronization with Database – habilite para sincronizar com o banco de dados. Essa opção é usada para controlar se o comentário pode ser atualizado. Por padrão, essas opções estão habilitadas para sempre permitir a sincronização com a biblioteca/banco de dados de origem. Você pode desabilitar essa opção para impedir que esse comentário seja incluído em um processo de atualização.
- (X/Y) – insira as coordenadas X e Y.
-
Rotation – use a lista suspensa para selecionar a rotação. As opções são:
0°,90°,180°e270°. - Autoposition – marque para habilitar o posicionamento automático, o que significa que o parâmetro é posicionado automaticamente sempre que o componente associado é girado. Desabilite essa opção para manter a posição do parâmetro em relação ao componente associado quando ele for girado.
-
Add – clique para adicionar um parâmetro, como um footprint, modelo ou regra, entre outros. Clique em
para excluir uma entrada selecionada da grade. Clique em
para editar o parâmetro na respectiva caixa de diálogo.
Gráfico
-
Mode – use a lista suspensa para selecionar o modo desejado. Se não houver outros modos disponíveis além de Normal, essa lista suspensa ficará desabilitada.
- Mirrored – habilite para espelhar a parte.
- Local Colors – habilite a opção de cor local para substituir as cores de preenchimento, linha e pinos do componente do esquemático pelas cores das caixas de cores Fill, Lines e Pins, respectivamente. Desabilite essa opção para usar as cores predefinidas da biblioteca.
Opções de peças
Esta região fornece informações sobre as opções de peças e os links de fornecedores atribuídos ao componente selecionado. Consulte a página Adicionar informações da cadeia de suprimentos a um componente para saber mais sobre as informações fornecidas pelas entradas desta seção.
Aba Pinos
-
Grid – esta região lista os Pins e Names de todos os pinos do componente selecionado. Use o ícone de olho para mostrar/ocultar o pino. Use o ícone de cadeado para bloquear/desbloquear os pinos.
Para um pino multifuncional (um pino com funções especificadas no campo Functions do modo Pinos do painel Propriedades), clique na célula do pino na coluna Name e selecione a função do pino na lista suspensa exibida. A função selecionada será mostrada como o nome do pino na folha de esquemático.
- Show Full/Show Short - em Show Full são exibidos os nomes estendidos completos de todos os pinos listados; no modo Show Short, é exibido o nome atual do pino.
-
– quando o botão está ativado (ícone de cadeado fechado), os pinos do componente não podem ser editados no editor de esquemáticos (mas podem ser editados no editor de bibliotecas de esquemáticos). Desative esta opção para editar um pino de componente na folha de esquemático.
-
– clique para exibir todos os pinos ocultos e suas propriedades (nomes e números), incluindo os pinos com a propriedade Show desativada no Editor de Pinos do Componente. Observe que, se estiver trabalhando no editor de bibliotecas de esquemáticos, a opção View » Show Hidden Pins também deverá estar ativada para exibir os pinos ocultos no editor de bibliotecas.
-
– clique para adicionar um pino ao componente. Configure o pino no painel Properties, clique e arraste para posicioná-lo.
-
– clique para excluir os pinos selecionados do componente.
-
– clique para abrir a caixa de diálogo Editor de Pinos do Componente. Essa caixa de diálogo oferece uma maneira prática de visualizar/editar todos os pinos do componente atualmente aberto no editor de bibliotecas de esquemáticos ou do componente selecionado (ou de uma parte dele) no editor de esquemáticos.
Propriedades do Componente Genérico
Componentes Genéricos

Inserção de um Componente Genérico a partir do painel Components
Quando o Altium Designer está conectado a um Workspace, os Componentes Genéricos disponíveis podem ser acessados no painel Componentes, onde são exibidos quando a opção All é selecionada na área Categories – ou no menu suspenso superior, quando o painel está no modo compacto. Clique no botão
dentro do bloco de um Componente Genérico para anexar o componente ao cursor e inseri-lo no esquemático ativo. Selecionar o próprio bloco abrirá a categoria desse tipo de componente no painel Components.
Propriedades do Componente Genérico
Geral
- Designator – insira o designador. Alterne o ícone de olho para mostrar/ocultar o designador. Clique no ícone de cadeado para bloquear/desbloquear o designador.
- Comment – insira o nome. Alterne o ícone de olho para mostrar/ocultar o nome.
-
Description – a descrição do componente/parte genérico.
- Replace – selecione o botão Replace quando o projeto tiver avançado até o ponto em que um Componente Genérico possa ser substituído por um componente físico específico usando a caixa de diálogo Substituir Componente.
Localização
-
(X/Y)
- X (primeiro campo) – a coordenada X (horizontal) atual do ponto de referência do objeto, em relação à origem atual do espaço de projeto. Edite para alterar a posição X do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Y (segundo campo) – a coordenada Y (vertical) atual do ponto de referência do objeto, em relação à origem atual. Edite para alterar a posição Y do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Rotation – use a lista suspensa para selecionar a rotação.
Parâmetros
- Grid – lista o Name e o Value dos parâmetros associados ao componente atualmente selecionado. Use o ícone de cadeado para bloquear/desbloquear um parâmetro listado. Os valores dos parâmetros podem ser inseridos manualmente ou selecionados em uma lista de menu suspenso que oferece valores provenientes de todos os componentes disponíveis desse tipo. Use o ícone de olho para mostrar/ocultar o parâmetro.
- Font – clique na fonte exibida para alterar o estilo da fonte.
-
Other – clique para abrir uma lista suspensa e alterar opções adicionais:
- Show Parameter Name – ative para mostrar o nome do parâmetro.
- Allow Synchronization with Database – ative para sincronizar com o banco de dados. Esta opção é usada para controlar se o comentário pode ser atualizado. Por padrão, essas opções estão ativadas para sempre permitir a sincronização com a biblioteca/banco de dados de origem. Você pode desativar esta opção para impedir que esse comentário seja incluído em um processo de atualização.
- (X/Y) – insira as coordenadas X e Y.
- Rotation – use a lista suspensa para selecionar a rotação.
- Autoposition – marque para ativar o posicionamento automático, o que significa que o parâmetro será posicionado automaticamente sempre que o componente associado for girado. Desative esta opção para manter a posição do parâmetro em relação ao componente associado quando ele for girado.
Designador
O Designador identifica de forma exclusiva cada componente no projeto.
Resumo
O campo de designador é um objeto de parâmetro filho de um componente esquemático (parte). Ele é usado para identificar de forma exclusiva cada parte inserida, distinguindo-a de todas as outras partes inseridas em todas as folhas de esquemático do projeto.
Disponibilidade e Inserção
O designador é inserido automaticamente quando o objeto da parte do componente pai é inserido. Ele não é um objeto de projeto que você possa inserir diretamente.
Edição Gráfica
O texto do designador pode ser editado graficamente usando o que se conhece como edição in-place. Para editar o texto de um designador no local, selecione o designador arrastando o cursor ao redor dele e pressione Enter.

Um exemplo de edição no local
Quando a edição estiver concluída, pressione Enter ou clique fora do texto para sair do modo de edição no local.
Edição Não Gráfica
Há dois aspectos a considerar em relação à edição do designador: a edição do valor do designador e a edição de suas propriedades de exibição.
As strings do designador (e do comentário) podem ser exibidas no editor de bibliotecas de esquemáticos; em seguida, basta clicar duas vezes nelas para editar suas propriedades. O ícone
associado ao campo no painel Properties é usado para mostrar ou ocultar o designador.
Edição do valor do designador no Editor de Esquemáticos
O designador pode ser definido no editor de esquemáticos durante o posicionamento do componente ou depois que o componente tiver sido posicionado em uma folha de esquemático no Properties panel.
- Para editar o designador durante o posicionamento do componente, pressione a tecla Tab enquanto o componente estiver flutuando no cursor. O painel Properties será aberto; insira a string desejada para o designador. Clique no botão de pausa sobreposto à área de projeto para retomar o posicionamento.
- Continue posicionando componentes ou pressione Esc para encerrar o posicionamento.
- Pressione Spacebar para girar o arco no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. Essa ação também pode ser realizada ao arrastar o objeto. A rotação ocorre em incrementos de 90°.
- Para editar o designador após o posicionamento, clique duas vezes no componente posicionado para abrir o painel Propriedades , no qual o designador pode ser editado.
Edição das propriedades de exibição do designador
A aparência da string do designador, que inclui o tipo, o tamanho e a cor da fonte, pode ser configurada na página Esquemático - Padrões da caixa de diálogo Preferences. Essas configurações serão aplicadas, a menos que sejam substituídas pelas configurações definidas no símbolo do componente no Editor de Bibliotecas de Esquemáticos.
Fixação da posição da string do designador
O comportamento padrão do designador é posicioná-lo automaticamente quando um componente é girado durante o posicionamento. Se esse comportamento não for necessário, desative a opção Autoposition na caixa de diálogo Preferences (consulte a imagem anterior), durante a criação do símbolo ou depois que o componente tiver sido posicionado em uma folha de esquemático. Observe que isso faz com que esse parâmetro seja classificado como manual parameter (ou seja, um parâmetro posicionado manualmente). Os parâmetros manuais são identificados por um ponto no canto inferior esquerdo de sua caixa de seleção.
Notas
-
O Editor de Esquemáticos inclui um recurso simples de incremento automático do designador que pode ser usado durante o posicionamento de várias instâncias da mesma peça. Para usá-lo, pressione Tab enquanto o primeiro componente estiver flutuando no cursor e insira um designador adequado, por exemplo,
R1. Os componentes subsequentes serão então designados comoR2,R3etc. Observe que, ao passar a posicionar um tipo diferente de componente, você deve pressionar Tab novamente e inserir um prefixo de designador adequado. -
Ao posicionar componentes com múltiplas partes, se o designador inicial for atribuído conforme descrito acima, um sufixo de parte será atribuído automaticamente, por exemplo,
U3A,U3Betc. Se o designador inicial não for atribuído, todas as partes terão o mesmo sufixo. Isso é resolvido pelo comando Annotation do Editor de Esquemáticos. O sufixo da parte pode ser alfabético ou numérico. Use a opção Alpha Numeric Suffix na página Esquemático - Geral da caixa de diálogo Preferences para configurá-lo.
Propriedades do designador
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência do objeto, em relação à origem atual da área de trabalho. Edite para alterar a posição X do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades sejam diferentes do padrão atual.
- Y (segundo campo) - A coordenada Y (vertical) atual do ponto de referência do objeto, em relação à origem atual. Edite para alterar a posição Y do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades sejam diferentes do padrão atual.
- Rotation - use a lista suspensa para selecionar a rotação.
Propriedades
- Object - exibe o objeto associado.
- Nome - habilite este campo clicando no ícone de visibilidade para adicionar o prefixo "Designador:" ao próprio valor do designador. Isso distingue visualmente o valor do texto e confirma que ele é um designador no documento esquemático.
-
Value - exibe o próprio nome do designador. Clique no ícone de olho
para mostrar/ocultar o valor.
- Posicionamento automático - marque para habilitar o posicionamento automático, de modo que o texto permaneça na posição escolhida quando o componente for movido e girado.
- Bloquear parâmetro - marque para bloquear o parâmetro, impedindo que o valor seja editado no painel Properties ou no documento esquemático.
- Permitir sincronização com o banco de dados - habilite para sincronizar com o banco de dados. Esta opção é usada para controlar se o comentário pode ser atualizado. Por padrão, essas opções estão habilitadas para sempre permitir a sincronização com a biblioteca/banco de dados de origem. Você pode desabilitar esta opção para impedir que esse comentário seja incluído em um processo de atualização.
- Fonte - use os controles para selecionar a fonte, o tamanho e a cor da fonte, além de adicionar características especiais desejadas, como negrito, itálico e sublinhado.
- Alinhamento - clique nas setas para configurar o alinhamento do texto ou no círculo para centralizá-lo.
- Override Library Primitive (somente na caixa de diálogo Preferences ) - marque esta caixa de seleção para substituir as configurações da primitiva definidas para o objeto designador em uma biblioteca. Assim, quando um componente for posicionado, ele adotará as configurações da primitiva que você definiu na caixa de diálogo Preferências, em vez daquelas definidas para o componente na biblioteca.
Comentário
Um comentário permite exibir informações adicionais sobre um componente.
Resumo
O campo Comentário é um objeto de parâmetro filho de um componente esquemático (peça). Ele exibe informações adicionais sobre o componente.
Disponibilidade e posicionamento
O comentário é configurado quando o objeto da parte do componente pai é posicionado. Ele não é um objeto de projeto que você pode posicionar diretamente.
Edição gráfica
O Comentário pode ser editado graficamente usando o que é conhecido como edição in-place. Para editar um Comentário no local, clique uma vez para selecioná-lo, aguarde um segundo e clique novamente para entrar no modo de edição.
Clique uma vez para selecionar a string.
Quando a edição estiver concluída, pressione Enter ou clique fora da string para sair do modo de edição no local.
Edição não gráfica
Há dois aspectos a considerar em relação à edição do Comentário: a edição do valor do Comentário e a edição de suas propriedades de exibição.
Edição do Comentário no Editor de Esquemáticos
O Comentário pode ser definido no editor de esquemáticos durante o posicionamento do componente ou depois que o componente tiver sido posicionado em uma folha de esquemático, no campo Comment do painel Properties.
- Para editar o comentário durante o posicionamento do componente, pressione a tecla Tab enquanto o componente estiver preso ao cursor. O painel Properties será aberto; insira o Comentário desejado. Clique no botão de pausa sobreposto à área de projeto para retomar o posicionamento do componente.
- Continue posicionando componentes ou pressione Esc para encerrar o posicionamento.
- Para editar o Comentário após o posicionamento, clique duas vezes no componente posicionado para abrir o painel Propriedades , onde o Comentário pode ser editado.
Edição das propriedades de exibição do Comentário
A aparência dos comentários, incluindo o tipo, o tamanho e a cor da fonte, pode ser configurada na página Esquemático - Padrões da caixa de diálogo Preferences .
Fixação da posição do Comentário
O comportamento padrão do Comentário é posicioná-lo automaticamente conforme o componente é girado durante o posicionamento. Se esse comportamento não for necessário, desative a opção Autoposition na caixa de diálogo Preferences (consulte a imagem anterior), durante a criação do símbolo ou depois que o componente tiver sido posicionado em uma folha de esquemático. Observe que isso faz com que esse parâmetro seja classificado como manual parameter (ou seja, um parâmetro posicionado manualmente). Os parâmetros manuais são identificados por um ponto no canto inferior esquerdo de sua caixa de seleção.
Propriedades do Comentário
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência do objeto, em relação à origem atual da área de projeto. Edite para alterar a posição X do objeto. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Y (segundo campo) - a coordenada Y (vertical) atual do ponto de referência do objeto, em relação à origem atual. Edite para alterar a posição Y do objeto. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Rotation - use a lista suspensa para selecionar a rotação. As opções são: 0 Degrees, 90 Degrees, 180 Degrees e 270 Degrees.
Propriedades
- Componente - exibe o nome do componente associado. Clique no link Component para abrir o painel Propriedades da peça, onde você pode editar as opções do componente, bem como o próprio comentário, que será definido no campo Comment desse painel.
- Nome - habilite este campo clicando no ícone de visibilidade para adicionar o prefixo "Comentário:" ao próprio valor do comentário. Isso distingue visualmente e confirma que o valor de texto é um comentário no documento esquemático.
-
Valor - exibe o próprio nome do comentário. Alterne para mostrar/ocultar o valor.
- Posicionamento automático - marque para habilitar o posicionamento automático, o que significa que o texto permanecerá na posição escolhida conforme o componente for movido e girado.
- Bloquear parâmetro - marque para bloquear o parâmetro, impedindo que o valor seja editado no painel Properties ou no documento esquemático.
- Permitir sincronização com o banco de dados - habilite para sincronizar com o banco de dados. Esta opção é usada para controlar se o comentário pode ser atualizado. Por padrão, esta opção é habilitada para sempre permitir a sincronização com a biblioteca/banco de dados de origem. Você pode desativar esta opção para impedir que o comentário seja incluído em um processo de atualização.
- Fonte - use os controles para selecionar a fonte, o tamanho e a cor da fonte, e adicionar quaisquer características especiais desejadas, como negrito, itálico e sublinhado.
- Alinhamento - clique nas setas para configurar o alinhamento do texto ou no círculo para centralizá-lo.
- Override Library Primitive (somente na caixa de diálogo Preferences ) - marque esta caixa de seleção para substituir as configurações de primitivas definidas para o objeto de comentário em uma biblioteca. Assim, quando um componente for posicionado, ele adotará as configurações de primitivas que você definiu na caixa de diálogo Preferences, em vez das configurações definidas para o componente na biblioteca.
Atualização e substituição de componentes a partir de uma biblioteca
Após o posicionamento inicial dos componentes nas folhas de esquemático de um projeto de placa, é necessário ter uma forma de atualizar essas instâncias de componentes com quaisquer alterações feitas em seus componentes de origem vinculados no Workspace correspondente. Em outras palavras, uma maneira de manter o projeto sincronizado com as entidades do Workspace que ele utiliza.
Por exemplo, um componente pode ter sido salvo novamente no Workspace, talvez refletindo uma alteração em um modelo filho. Isso resulta em uma nova revisão desse componente. A instância posicionada desse componente está agora usando uma revisão mais antiga, e você pode querer atualizá-la para usar a revisão mais recente. Como alternativa, você pode ter decidido usar um componente completamente diferente e precisar apenas substituir o componente existente no projeto por outro.
Há vários métodos disponíveis para gerenciar os componentes após sua inserção inicial em um projeto.
Alteração de uma única instância de componente
Cada componente inserido tem um vínculo com a revisão do componente no Workspace. Essas informações podem ser encontradas no painel Properties, ao consultar as propriedades do componente selecionado.
Cada instância inserida de um componente tem um vínculo com a revisão específica desse componente no Workspace.
Nesse nível mais básico, de componente individual, a instância inserida pode ser:
-
Atualizada para a revisão mais recente do componente existente, clicando no botão
.
Exemplo de atualização do mesmo componente para sua revisão mais recente — passe o cursor sobre a imagem para ver o resultado.
-
Substituída pela revisão mais recente de outro componente do Workspace (um substituto) ou por um componente de biblioteca baseada em arquivo, clicando no botão
à direita do campo Design Item ID. A caixa de diálogo Replace Component será aberta, apresentando os componentes do Workspace conectado e das bibliotecas baseadas em arquivo disponíveis. O componente atual é mostrado no topo da lista. Pesquise o componente substituto desejado, selecione-o e clique em OK.
Exemplo de substituição do componente existente por outro diferente (uma alternativa)
A caixa de diálogo Replace Component oferece acesso direto a todos os componentes de biblioteca do Workspace e de bibliotecas baseadas em arquivo disponíveis. A caixa de diálogo oferece detalhes completos do componente selecionado (parâmetros, modelos, opções de peças, dados de fornecedores etc.), comparação de componentes e, para componentes de biblioteca do Workspace, um recurso de pesquisa paramétrica baseada em filtros para especificar os parâmetros desejados do componente.
Opções e controles da caixa de diálogo Replace Component
- Search - use a caixa de texto de pesquisa para pesquisar manualmente um componente específico.
-
- clique para expandir ou recolher o painel Categories — para mostrar determinados tipos de componentes ou exibir todos os componentes disponíveis. Use a barra de pesquisa abaixo do painel Categories para pesquisar manualmente uma categoria específica de componentes ou uma biblioteca de componentes baseada em arquivo disponível.
-
- clique para acessar um menu e selecionar entre:
- File-based Libraries Preferences - clique para abrir a caixa de diálogo Available File-based Libraries e adicionar ou remover bibliotecas.
- File-based Libraries Search - clique para abrir a caixa de diálogo File-based Libraries Search e pesquisar bibliotecas.
- Refresh - clique para atualizar a caixa de diálogo.
-
- clique para abrir/fechar a Details região da caixa de diálogo (descrita abaixo).
Filtros
Quando uma categoria de componentes do Workspace estiver selecionada, clique no ícone Filters para abrir a região Filters, onde você pode filtrar ainda mais as categorias selecionadas na lista Components . As opções Filters do painel podem ser adaptadas às suas necessidades selecionando tipos específicos de parâmetros como Favorites, que passam então para o topo da lista da categoria atual de componentes. Passe o cursor à direita do nome de um filtro de parâmetro e clique no ícone para definir o filtro como favorito. As configurações de filtros favoritos são aplicadas e salvas individualmente para cada Categories de componentes.
Componentes
- Name - o nome do componente.
- Description - a descrição de cada componente.
- Footprint - o footprint do componente.
- Results - lista o número total de componentes encontrados/listados na pesquisa.
Detalhes
- Component Revision ID - lista o ID da revisão e o preço de um determinado componente. Clique no ID da revisão para abrir o painel Explorer e obter mais informações sobre um componente.
- References - clique para abrir informações de referência do componente em um navegador da Web. Use a lista suspensa para acessar Manufacturer URL ou Datasheet.
- Place - clique para inserir o componente selecionado em um documento esquemático.
- Component information - lista informações relevantes sobre o componente, incluindo fabricante, data de lançamento e informações descritivas. Clique no link Show More para visualizar todas as informações; clique em Show Less para recolher as informações.
- Models - expanda para visualizar os modelos fornecidos. Use os links disponíveis para exibir várias partes de um único modelo.
- References - expanda para acessar Manufacturer URL, Datasheet e Package Specification.
- Part Choices - expanda para visualizar as opções de peças. São fornecidos nome, preço e descrição. A folha de dados do componente também será listada.
- Where Used - expanda para visualizar os projetos que utilizam o componente.
Menu do botão direito
- Find Similar Components - clique para abrir a caixa de diálogo Find Similar Components, onde você pode pesquisar vários outros componentes com características semelhantes.
- Place <component> - clique para inserir o componente no documento apropriado.
- Edit - clique para abrir os documentos de biblioteca do componente selecionado.
- Navigate to <revision> - clique para abrir o componente selecionado no painel Explorer.
- Operations - passe o cursor para acessar as opções de Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL e Full Item History.
- Refresh- clique para atualizar e visualizar atualizações ou edições recentes. Você também pode atualizar usando o atalho F5.
- Library Report - quando uma biblioteca baseada em arquivo estiver selecionada no painel Categories, clique para acessar a caixa de diálogo Library Report Settings, na qual você pode usar os controles fornecidos para configurar um relatório de biblioteca.
Realização de alterações de componentes em lote — o Item Manager
Related page: Gerenciamento de conteúdo com o Item Manager
A alteração individual de componentes é útil, mas logo se torna cansativa ao lidar com um número maior de componentes. Para isso, você precisa de um local único e centralizado para realizar várias alterações em lote. É aí que entra o Item Manager (Tools » Item Manager).
O Item Manager é a “central de comando” para sincronizar as entidades de projeto do Workspace — posicionadas nas folhas de esquemático — com o conteúdo de origem ao qual estão vinculadas em um Workspace. Ele detecta e lista automaticamente todos os componentes, indicando se são ou não entidades do Workspace, e compara a revisão do Item de cada componente do Workspace nos esquemáticos com as revisões disponíveis desse componente no Workspace. Para cada entidade, são fornecidas informações sobre o Item atualmente vinculado, incluindo a revisão, o estado do ciclo de vida e o Workspace de origem em que ele se encontra.
Você tem controle total sobre quais dessas entidades do Workspace atualizar e como. Por exemplo:
- Selecione uma entrada individual e atualize-a para usar a revisão mais recente do Item vinculado, ou opte por usar a revisão mais recente de um Item completamente diferente.
- Selecione um grupo de entradas que utilizam o mesmo Item vinculado e atualize-as para a revisão mais recente desse Item, ou opte por usar a revisão mais recente de um Item completamente diferente.
Todas as alterações propostas são refletidas no gerenciador.
Depois de configurar as alterações conforme necessário, gere uma Ordem de Alteração de Engenharia (ECO) e examine as ações que serão realizadas para implementar essas alterações. Desative quaisquer ações, se necessário — você está sempre no controle! Quando estiver pronto, execute a ECO e as alterações serão aplicadas. De forma rápida e eficiente, o conteúdo do Workspace posicionado no projeto é gerenciado com facilidade.
Os exemplos a seguir ilustram o uso do Item Manager:
- Para atualizar vários componentes para usar a revisão mais recente do componente existente no Workspace.

Atualize um grupo de componentes desatualizados para suas revisões mais recentes.
- Para trocar alguns componentes pela revisão mais recente de um componente diferente do Workspace — escolhido por meio da caixa de diálogo Substituir componente.

Substitua um ou mais componentes por um componente diferente do Workspace.
O Item Manager não apenas pode ser usado para manter os componentes dos seus projetos sincronizados com as alterações no conteúdo de origem dos Workspaces conectados, como também é uma ferramenta poderosa para ajudar na migração dos seus projetos de placa existentes — do uso de itens de projeto locais para o uso de conteúdo de projeto do Workspace. Depois de migrar os componentes do projeto e quaisquer folhas de esquemático (folhas de dispositivo) para um Workspace, você usa o Item Manager para “substituir” os componentes e símbolos de folha existentes por suas versões recém-migradas para o Workspace. Em outras palavras, os componentes permanecem os mesmos do ponto de vista do projeto, mas a origem desses componentes muda.
Alterar um componente a partir de um BomDoc
Não é incomum identificar um problema com um componente quando o BomDoc está sendo verificado e preparado para a compra das peças. Por exemplo, o projetista pode ter esquecido de finalizar a seleção de um componente, ou um componente pode ter chegado ao fim de vida (EOL) e o projetista deseja avaliar o preço e a disponibilidade de possíveis substitutos. Embora seja possível resolver isso retornando ao esquemático e editando o componente, selecionando uma peça adequada e depois atualizando o BomDoc, o ActiveBOM permite realizar essa operação diretamente no BomDoc — e então transferir essa alteração de volta para o esquemático por meio de uma Ordem de Alteração de Engenharia.
No BomDoc, clique com o botão direito nos componentes selecionados e selecione o comando Operations » Change <ComponentName>. A caixa de diálogo Substituir componente será aberta, permitindo pesquisar o componente substituto. Após encontrar o componente substituto desejado, selecione-o e clique em OK. A caixa de diálogo Engineering Change Order será aberta, detalhando as alterações necessárias para sincronizar o esquemático com o BomDoc.

Exemplo de substituição de componente diretamente em um BomDoc.
Substituir um componente genérico
Quando um projeto avançar até o ponto em que um componente genérico possa ser substituído por um componente físico específico, abra a caixa de diálogo Substituir componente selecionando o botão
no painel Properties. Observe que isso também pode ser feito pelo Gerenciador de Itens ou pelo documento ActiveBOM do projeto.
Os valores dos parâmetros aplicados ao componente genérico (neste caso, valores de potência e resistência) são usados automaticamente como termos de pesquisa na caixa de diálogo Replace Generic Component, permitindo escolher um componente substituto adequado nos resultados filtrados — no exemplo apresentado, duas entradas de componentes atendem aos critérios de pesquisa.
|
Substituição de um componente genérico pelo painel Properties. Substituição de um componente genérico pelo painel Properties. |
Gerenciar footprints em todo o projeto
O Editor de Esquemáticos do Altium Designer inclui um poderoso Footprint Manager. Acessado pelo menu Ferramentas do Editor de Esquemáticos (Tools » Footprint Manager), o Footprint Manager permite revisar todos os footprints associados a cada componente do projeto inteiro. O suporte à seleção múltipla facilita editar a atribuição de footprints para vários componentes, alterar a forma como o footprint é vinculado ou alterar a atribuição atual de footprint para componentes que possuem vários footprints atribuídos. O Footprint Manager facilita a revisão e a detecção de problemas nas atribuições de footprints em todo o projeto, sendo particularmente útil quando você está trabalhando em um projeto legado ou em um projeto de outra organização. As alterações do projeto são aplicadas por meio do sistema ECO, atualizando tanto o esquemático quanto a PCB, se necessário.
A caixa de diálogo Footprint Manager apresenta uma lista de todos os componentes em todos os esquemáticos de origem do projeto ativo. Use os controles disponíveis no lado direito da caixa de diálogo para gerenciar os footprints disponíveis para os componentes do projeto e aqueles atualmente utilizados por eles. Os recursos incluem:
- Capacidade de adicionar, editar e remover modelos de footprint para um ou mais componentes selecionados.
- Copiar footprints entre componentes.
- Alterar a atribuição atual de footprint (o footprint que será usado no momento para representar um componente na PCB, dentre os vários que podem estar disponíveis para esse componente).
- Validação de footprints — para garantir que os modelos de footprint estejam realmente disponíveis, especialmente aqueles definidos como o modelo atual.
Depois que todas as alterações nas atribuições de modelos de footprint forem feitas conforme necessário, elas serão implementadas por meio de uma Ordem de Alteração de Engenharia (ECO) padrão. Para isso, basta clicar no botão Accept Changes (Create ECO) , no canto inferior direito da caixa de diálogo Footprint Manager .
Opções e controles da caixa de diálogo Gerenciador de footprints
Lista de componentes
Esta é uma lista de todos os componentes das folhas de esquemático do projeto de PCB atualmente em foco. As informações incluem:
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
Visualizar e editar footprints
Esta é uma lista dos footprints associados ao componente selecionado na Component List. Use os controles na parte inferior da região ou os comandos do menu de contexto para manipular os footprints da lista.
Menu de contexto
-
Add - clique para abrir a caixa de diálogo Modelo de PCB e escolher um novo modelo de footprint para adicionar ao componente de esquemático destacado. Não disponível quando um componente gerenciado está selecionado.
-
Remove - clique para remover o footprint selecionado. Não disponível quando um componente gerenciado está selecionado.
-
Edit Footprint - clique para abrir a caixa de diálogo Modelo de PCB. A caixa de diálogo PCB Model define qual modelo de footprint está vinculado ao componente de esquemático e em quais bibliotecas o editor de esquemáticos pode procurar o footprint. Não disponível quando um componente gerenciado está selecionado.
-
Validate Footprint Paths - clique para confirmar que o footprint destacado pode ser encontrado no local permitido. Se o footprint não puder ser encontrado, Not Validated aparecerá no campo Found In. Se o footprint for validado, será exibido o caminho completo para ele.
-
Change PCB Library - clique para abrir a caixa de diálogo Edit PCB Library e alterar a biblioteca de PCB do footprint selecionado. Esta caixa de diálogo é uma versão simplificada da caixa de diálogo PCB Model, que dá acesso às opções PCB Library para definir onde o software pode procurar modelos de footprint.

A caixa de diálogo Edit PCB Library- Any - pesquisa um modelo correspondente em todas as bibliotecas disponíveis.
- Library name - pesquisa um modelo correspondente apenas nas bibliotecas disponíveis com este nome.
- Library path - pesquisa um modelo correspondente apenas em uma biblioteca com este nome, neste local. Digite o caminho e o nome da biblioteca manualmente ou clique no botão Choose para abrir a caixa de diálogo Open do Windows, que permite navegar até a biblioteca desejada.
- Use footprint from source integrated library, database library, or server - pesquisa o modelo apenas na biblioteca integrada, na biblioteca de banco de dados ou no servidor de onde o componente foi inserido. A biblioteca integrada ou a biblioteca de banco de dados deve estar disponível ou, no caso de um servidor, você deve estar conectado a ele.
-
Copy - clique para copiar os detalhes do footprint atualmente selecionado.
-
Paste - clique para colar (adicionar) os detalhes copiados do footprint no componente de esquemático atualmente selecionado.
-
Select All - clique para selecionar todos os footprints atualmente visíveis na lista View and Edit Footprints.
-
Set As Current - clique para definir o footprint selecionado como o footprint atual (indicado por um
na coluna Current ).
-
Add to All Parts - clique para adicionar o footprint selecionado a todas as outras partes do mesmo componente de esquemático (comando disponível apenas se o componente selecionado tiver várias partes e uma ou mais delas não tiverem este footprint especificado).
Controles adicionais
-
Menu - clique para visualizar um menu com os mesmos controles do menu de contexto acima.
-
Add, Remove, Edit, Validate - estes botões executam as mesmas funções que as opções de menu descritas acima.
-
Accept Changes (Create ECO) - clique para aceitar as alterações nos componentes de esquemático e em seus modelos de footprint vinculados e abrir a caixa de diálogo Engineering Change Order. Na caixa de diálogo ECO, você pode validar e executar as alterações depois de revisar as modificações feitas nos valores de footprint dos componentes de esquemático correspondentes.












