Definindo o Diagrama de Fiação

Num relance

Este artigo explica como os diagramas de fiação de chicotes no Altium Designer são criados, configurados e usados para definir as conexões individuais por fios em um projeto de chicote. Ele apresenta as etapas para adicionar um documento de diagrama de fiação e configurar as principais opções do documento, como unidades, grades, configurações de página e modelos, além de destacar recursos relacionados, como validação, objetos de texto e desenho e salvamento em formato ASCII. Também descreve como os diagramas de fiação podem ser sincronizados com projetos multiplaca e como os componentes podem ser importados ou posicionados manualmente, oferecendo uma visão geral prática do fluxo de trabalho principal antes de você começar a desenvolver seu projeto. Continue lendo para entender as etapas essenciais de configuração e sincronização que facilitam o trabalho com diagramas de fiação de chicotes.

- Como adicionar e configurar um documento de diagrama de fiação de chicote, incluindo unidades, grades, opções de página e configurações padrão.
- Como a sincronização com um projeto multiplaca importa os componentes de conectores e a conectividade lógica para o diagrama de fiação.
- Como os componentes podem ser posicionados e gerenciados no diagrama de fiação, sejam eles importados de um projeto multiplaca ou adicionados manualmente.
Aprofunde-se com a IA:

As conexões individuais dos fios no chicote são especificadas no diagrama de fiação do chicote (*.WirDoc). Adicione este documento ao projeto de chicote pelo painel Projects, clicando com o botão direito na entrada do projeto e selecionando Add New to Project » Harness Wiring Diagram no menu de contexto (ou use o comando File » New » Harness Wiring Diagram nos menus principais).

Configurando um documento de diagrama de fiação de chicote

As opções de um documento de diagrama de fiação de chicote podem ser configuradas no painel Properties quando nenhum objeto estiver selecionado na área de projeto do documento. As principais configurações são:

  • Na região General da aba General do painel – selecione as unidades de medida que se aplicam ao documento e aos seus elementos gráficos e configure as grades para facilitar o posicionamento. O Altium Designer oferece três tipos de grade: grade visível para navegação, grade de ajuste para posicionamento e distância de ajuste para auxiliar na criação de conexões.

  • Na região Page Options da aba General do painel – configure o tamanho da folha do documento e o bloco de título ou selecione um dos modelos de diagrama de fiação de chicote disponíveis.

As abas General e Parameters do painel Properties quando nenhum objeto está selecionado no documento de diagrama de fiação de chicote 
As abas General e Parameters do painel Properties quando nenhum objeto está selecionado no documento de diagrama de fiação de chicote

  • A configuração de um documento de diagrama de fiação de chicote é semelhante à configuração de um documento esquemático (*.SchDoc) de um projeto de PCB. Consulte a página Configurando um documento esquemático para saber mais.

  • Use a lista suspensa Length Units para escolher as unidades de comprimento do documento. Os valores Strip Length e Pull Off Length das cavidades dos soquetes serão exibidos nas unidades selecionadas. As unidades compatíveis são mm, cm, m, in e ft. As unidades de comprimento padrão de novos documentos de diagrama de fiação podem ser definidas na página Projeto de chicote – Geral da caixa de diálogo Preferences.

  • Para saber mais sobre a criação de modelos de documentos de fiação de chicote, consulte a página Criando documentos de modelo de chicote.

  • As propriedades padrão dos objetos de diagrama de fiação de chicote podem ser configuradas na página Projeto de chicote – Padrões  da caixa de diálogo Preferences. Essas propriedades serão aplicadas ao posicionar os próximos objetos.

  • Ao criar um documento de diagrama de fiação de chicote, você também pode usar objetos de texto e de desenho. Trabalhar com esses objetos em um documento de diagrama de fiação de chicote é semelhante a trabalhar com eles em um documento esquemático (*.SchDoc) de um projeto de PCB. Consulte Trabalhando com objetos de texto em um esquemático e Trabalhando com objetos de desenho em um esquemático para saber mais sobre esses objetos.

    • Observe que links ativos para objetos do diagrama de fiação de chicote (por exemplo, fios e componentes) e objetos do desenho de layout de chicote (por exemplo, feixes e pontos de conexão) também são compatíveis com quadros de texto e notas. Clique em um link no quadro de texto ou na nota posicionados para localizar o objeto correspondente no documento associado.

  • Para verificar se há violações lógicas, elétricas e de desenho no seu diagrama de fiação de chicote, estão disponíveis diversas verificações de violações. Consulte a página Validando o projeto de chicote para saber mais.

  • Um documento de diagrama de fiação de chicote pode ser salvo no formato ASCII, o que pode ser útil para compartilhamento. Use o comando File » Save As e selecione Harness Wiring ascii (*.WirDoc) na lista suspensa Save as type da caixa de diálogo Save As que se abre. Ao salvar um diagrama de fiação ASCII usando o comando File » Save, a caixa de diálogo File Format será aberta, informando que o formato ASCII está sendo usado. Escolha a versão ASCII na caixa de diálogo para continuar usando esse formato.

Sincronizando projetos multiplaca e de chicote

 
 
 
 
 

Quando o projeto de chicote faz parte de um projeto multiplaca, o diagrama de fiação de chicote pode ser sincronizado com os dados do documento esquemático multiplaca (*.MbsDoc). Para isso, selecione o comando Design » Import Changes From <Multi-board Project> nos menus principais.

Para saber mais sobre como adicionar um projeto de chicote a um projeto multiplaca, consulte a página Projeto de chicote.

Se o documento esquemático multiplaca contiver mais de uma definição de conexão de chicote, a caixa de diálogo Select Harness Definition será aberta. Especifique a definição relacionada ao projeto de chicote atual.

A caixa de diálogo Select Harness Definition
A caixa de diálogo Select Harness Definition

A caixa de diálogo Engineering Change Order será aberta em seguida, mostrando os componentes de conectores e as redes do chicote que foram definidos no esquemático multiplaca e que formarão a base do diagrama de fiação de chicote.

Use a caixa de diálogo Engineering Change Order para importar dados do projeto multiplaca. 
Use a caixa de diálogo Engineering Change Order para importar dados do projeto multiplaca. 

Após executar as alterações (), os dados do documento esquemático multiplaca são importados para o diagrama de fiação de chicote. Os componentes de conectores, cada um representado por seu símbolo esquemático, aparecerão no documento de diagrama de fiação de chicote, inicialmente em posições arbitrárias.

Um exemplo de diagrama de fiação de chicote logo após a importação.
Um exemplo de diagrama de fiação de chicote logo após a importação.

Linhas de rede serão exibidas entre os pinos para representar as conexões lógicas definidas no esquemático multiplaca. Observe que, nesta etapa, não há fios físicos no projeto.

Observe que os dados de conectividade importados do projeto multiplaca para o projeto de chicote dependem dos nomes dos pinos dos componentes de conectores. Portanto, certifique-se de que nomes exclusivos e corretos sejam atribuídos aos pinos dos componentes na biblioteca de origem antes da importação dos dados.

Trabalhando com componentes

Além da sincronização a partir do documento esquemático multiplaca, os componentes também podem ser inseridos manualmente no diagrama de fiação do chicote. Isso permite inserir componentes em um projeto de chicote independente (que não faz parte de um projeto multiplaca), além de permitir a inserção de componentes adicionais em um diagrama de fiação de chicote que faz parte de um projeto multiplaca.

Use o painel Components para inserir os símbolos dos componentes necessários. O processo de inserção de componentes é semelhante ao do editor de esquemáticos — consulte a página Pesquisa e inserção de componentes para saber mais. Observe que não haverá linhas de rede para componentes adicionados manualmente, pois não há um projeto lógico de nível superior para defini-las.

  • Os componentes são inseridos a partir das bibliotecas disponíveis e representados por seus modelos de símbolos esquemáticos em um diagrama de fiação de chicote. Consulte Criação e manutenção de componentes e bibliotecas para saber mais sobre a criação de componentes.

  • Componentes com múltiplas partes também podem ser inseridos em um diagrama de fiação de chicote. Quando os dados do projeto são importados para o desenho de layout do chicote, os designadores são atribuídos corretamente aos componentes no desenho de layout do chicote. Se várias partes do mesmo componente forem inseridas no diagrama de fiação do chicote, apenas uma instância do componente será inserida no desenho de layout do chicote ().

  • Os conectores de chicote podem ser usados para estabelecer conexões entre vários projetos multiplaca organizados em uma configuração aninhada.

  • Ao colar componentes de chicote recortados ou copiados em um diagrama de fiação de chicote, os designadores dos componentes colados respeitam a opção Reset Parts Designators On Paste da página Esquemático – Edição gráfica da caixa de diálogo Preferences. Quando os componentes são colados, a parte numérica de seus designadores é redefinida para ? quando a opção está habilitada.

Para mover um componente já inserido (ou um componente que está sendo inserido a partir do painel Components) para a posição desejada, clique nele e mantenha o botão esquerdo do mouse pressionado enquanto move o mouse. Durante o arraste, use Spacebar para girar os componentes em 90 graus e as teclas X e Y para espelhá-los horizontal e verticalmente, respectivamente.

O diagrama de fiação do chicote após mover os componentes
O diagrama de fiação do chicote após mover os componentes

As propriedades de um componente inserido podem ser configuradas no painel Properties quando o componente está selecionado na área de projeto. O painel Properties de um componente inclui as seguintes abas:

 
 
 
 
 
  • General – propriedades gerais do componente, como designador e comentário, localização, parâmetros etc.

  • Pins – a lista de pinos do componente.

  • Cavities – permite atribuir cavidades de soquete ao componente (saiba mais).

  • Associated Parts – permite atribuir peças adicionais, como tubos termorretráteis, ao componente.

Abas do painel Properties quando um componente está selecionado
Abas do painel Properties quando um componente está selecionado

Atribuição de cavidades de soquete

 
 
 
 
 

Cavidades de soquete e seus tipos podem ser atribuídos a um componente de chicote. Selecione um componente na área de projeto para adicionar uma cavidade e seu tipo. Selecione um pino na aba Cavities do painel Properties e, em seguida, clique no botão  . Selecione o tipo desejado na lista suspensa. Os seguintes tipos de cavidade são compatíveis:

  • Crimp – usado para fornecer uma conexão elétrica por meio da compressão do cilindro de um contato ao redor de um condutor.

  • Seal – usado para fornecer proteção ambiental por meio da vedação do ponto de entrada do fio.

  • Plug – usado para preencher uma cavidade aberta (não utilizada) do conector para manter a integridade da vedação ambiental.

  • Other – usado para especificar outras peças ou materiais adicionais, por exemplo, solda.

Para o tipo de cavidade Crimp ou para linhas sem um tipo de cavidade adicionado, você pode especificar os seguintes valores:

  • Strip Length – o comprimento no qual a isolação é cortada do condutor.

  • Pull Off Length – o comprimento pelo qual a isolação cortada é puxada do condutor. Isso pode ser usado quando a extremidade do fio não é completamente decapada e o pedaço de isolação removido é mantido no fio para evitar danos aos filamentos.

As unidades em que esses valores são exibidos no painel Properties quando um componente está selecionado são especificadas usando a lista suspensa Length Units na aba General do painel Properties quando nenhum objeto está selecionado no documento.

Na caixa de diálogo Select Connector que se abre, procure e selecione o componente desejado. O tipo específico e as informações pertinentes serão adicionados ao pino na aba, conforme mostrado nas imagens abaixo para a adição de um terminal de crimpagem ao pino 1.

Observe que os pinos são apresentados na tabela da aba Cavities por seus nomes (a coluna Pins) e que a atribuição de cavidades se baseia nos nomes dos pinos. Portanto, certifique-se de que nomes exclusivos e corretos sejam atribuídos aos pinos do componente.

Para um terminal de crimpagem, uma vedação ou um tampão, apenas uma cavidade de um determinado tipo pode ser adicionada a um pino. Depois que uma cavidade de um determinado tipo é adicionada, a opção fica indisponível (acinzentada) na lista suspensa. Qualquer quantidade de cavidades do tipo Other pode ser adicionada a um pino.

Os pinos com terminais de crimpagem atribuídos são indicados pelo símbolo  na área de projeto, conforme mostrado na imagem abaixo.

A região da grade da aba Cavities permite seleção múltipla e operações de copiar/colar/excluir para as entradas selecionadas.

  • Várias entradas de pinos podem ser selecionadas usando os atalhos Click, Hold&Drag, Ctrl+Click, Shift+Click e Ctrl+A.

  • Quando várias entradas de pinos estiverem selecionadas, clique em  para adicionar uma cavidade a todos os pinos selecionados ou clique em  ou pressione Delete para remover as cavidades adicionadas dos pinos selecionados. 

  • Para alterar a cavidade de um pino, selecione sua entrada e clique em  para abrir a caixa de diálogo Select Connector e selecionar a nova cavidade.

  • Selecione uma ou mais entradas de pinos e use os atalhos Ctrl+X/Ctrl+C para recortar/copiar as entradas selecionadas. Em seguida, use o atalho Ctrl+V para colar o conteúdo recortado/copiado na entrada atualmente selecionada.

Criação de conectividade no diagrama de fiação do chicote

Os fios físicos são inseridos no documento de diagrama de fiação do chicote selecionando o comando Place » Harness Wire nos menus principais (atalho: Shift+W).

Após selecionar o comando, clique em um pino de um conector (uma cruz vermelha aparece no cursor quando ele está sobre o ponto de conexão de um pino) para posicionar o ponto inicial do fio do chicote. Posicione o cursor e clique para fixar uma série de vértices que definem a forma do fio do chicote. Após posicionar o vértice final no ponto de conexão de outro pino, clique com o botão direito do mouse para concluir a inserção.

Ao inserir um fio de chicote, pressione Shift+Spacebar para alternar entre os modos de inserção. O modo especifica como os cantos são criados ao inserir fios e os ângulos nos quais os fios podem ser inseridos. Nos modos 90 Degree ou 45 Degree (modos verdadeiramente ortogonais), pressione Spacebar para alternar entre os submodos de início e fim. O modo e o submodo atuais são exibidos na barra de status.

Ao inserir um fio de chicote, as linhas de conexão são acompanhadas/atualizadas em tempo real, mostrando onde conectar os fios, conforme demonstrado no vídeo abaixo. Assim que uma conexão é concluída, sua linha de conexão desaparece do documento.

Demonstração do recurso de rastreamento em tempo real

Após a inserção e seleção de um fio de chicote, seus vértices podem ser arrastados para alterar o ângulo entre dois segmentos adjacentes (Mostrar exemplo).

Selecione um fio de chicote na área de projeto para alterá-lo no painel Properties. Nesse painel, você pode renomear o fio de chicote selecionado, alterar sua largura e cor e adicionar parâmetros que podem ser exibidos ou ocultados na área de projeto.

O painel Properties quando um fio de chicote está selecionado
O painel Properties quando um fio de chicote está selecionado

  • Um fio de chicote inserido pode ser substituído por um componente de fiação de chicote que inclua um único fio. Para isso, selecione o fio de chicote a ser substituído e clique no botão  à direita do campo Design Item ID no painel Properties. Na caixa de diálogo Replace Component que se abre, localize e selecione o componente desejado. O fio inserido será atualizado com as propriedades e os parâmetros do componente escolhido, mantendo sua geometria inalterada. Consulte a seção Inserção de um componente de fiação de chicote para saber mais.

  • A cor primária de um fio é definida pelo parâmetro Color, que é exibido por padrão em um fio de chicote inserido. Para editar a cor, insira seu nome (por exemplo, Red) ou código hexadecimal (digitando o caractere # seguido do número hexadecimal, por exemplo, #9900FF) como valor do parâmetro. Como alternativa, clique no botão de cor à esquerda do valor do parâmetro e use o seletor de cores que se abre, no qual a cor do fio pode ser especificada por um valor RGB ou HEX, por seleção livre ou a partir de uma variedade de predefinições.

  • O diagrama de fiação do chicote oferece suporte a fios multicoloridos por meio da escolha das cores secundária e terciária de um fio. No painel Properties, clique no menu suspenso  na parte inferior da região Parameters e escolha Secondary e Tertiary para definir as cores desejadas; o parâmetro da cor escolhida aparecerá na região Parameters . Você também pode definir a cor da borda do fio de chicote usando o mesmo menu suspenso e selecionando Border. Observe que o parâmetro Color controla a visibilidade do valor combinado dos parâmetros Color, Secondary Color e Tertiary Color definidos para o fio. Navegue pela apresentação de slides abaixo para ver exemplos.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Um fio com apenas a cor primária definida

    Um fio com a cor secundária definida

    Um fio com a cor terciária definida

    Um fio com a cor da borda definida

    Um fio com todas as opções de cor definidas

    As tabelas nos documentos de desenho de fabricação de projetos de chicote (*.HarDwf) oferecem suporte a fios multicoloridos – saiba mais.

  • Se um fio de chicote tiver o valor No para seu parâmetro Include Cut, esse fio não será exibido em uma lista de fiação nem em uma tabela de conexões no desenho de fabricação.

  • Os parâmetros Color, Min. Bending Radius, Thickness e Units de um fio de chicote são usados ao sincronizar um projeto de chicote com uma ferramenta MCAD usando o MCAD CoDesigner. Consulte a página Sincronização de um projeto de chicote para saber mais.

Adição de emendas e derivações

Em situações de projeto nas quais um novo fio precisa ser conectado a um fio já inserido, é necessário inserir primeiro um objeto de emenda (Place » Splice) ou de derivação (Place » Tap).

  • Splice – o fio original é dividido em dois fios separados pela emenda.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Outro fio precisa ser conectado ao fio selecionado (W4).

    Uma emenda inserida no fio. Observe que a emenda divide o fio original em dois no local da emenda.

    Outro fio foi conectado à emenda.

    Quando dois fios são conectados em forma de T, uma emenda é inserida automaticamente no local da junção em T (Mostrar exemplo).

  • Tap – o fio original permanece contínuo.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Outro fio precisa ser conectado ao fio selecionado (W4).

    Uma derivação posicionada no fio. Observe que a derivação não divide o fio original.

    Outro fio foi conectado à derivação.

As propriedades de uma emenda ou derivação posicionada (sua localização e representação visual) podem ser configuradas no painel Properties quando o objeto está selecionado na área de projeto.

O painel Properties quando uma emenda/derivação está selecionada
O painel Properties quando uma emenda/derivação está selecionada

A região Associated Parts do painel Properties permite atribuir componentes à emenda/derivação selecionada, e esse componente será incluído na BOM do projeto.

Adição de cabos

Para definir um ou mais fios como integrantes de um cabo, você pode posicionar um objeto de cabo no diagrama de fiação do chicote (Place » Harness Cable).

Posicione um cabo para definir um ou mais fios como integrantes de um cabo.
Posicione um cabo para definir um ou mais fios como integrantes de um cabo.

Quando um objeto de cabo é selecionado, os fios abrangidos por esse cabo são destacados em verde-neon na área de projeto ().

As propriedades de um objeto de cabo posicionado (sua localização, representação visual e parâmetros) podem ser configuradas no painel Properties quando o objeto está selecionado na área de projeto.

O painel Properties quando um cabo está selecionado
O painel Properties quando um cabo está selecionado

Use o controle de bloqueio/desbloqueio nos campos Width/Height do painel para alternar entre dimensões bloqueadas ou desbloqueadas. Quando o objeto é arrastado por suas alças de edição, a proporção é mantida de acordo com a configuração. O padrão é bloqueado, com uma proporção de altura:largura de 2:1.  Quando desbloqueado, você pode alterar as dimensões de forma independente, conforme necessário.

  • Se um cabo estiver associado a fios em vários locais do diagrama de fiação do chicote (ou seja, quando vários objetos de cabo com o mesmo designador forem posicionados sobre fios diferentes), selecionar um objeto destacará todos os fios associados do grupo, e todos esses fios serão listados na região Cable Objects do painel Properties ().

  • Os parâmetros Color, Min. Bending Radius, Thickness e Units de um cabo são usados ao sincronizar um projeto de chicote com uma ferramenta MCAD usando o MCAD CoDesigner. Consulte a página Sincronização de um projeto de chicote para saber mais.

Blindagem e trançamento de fios

Uma blindagem (com ou sem conexão, como uma conexão de fio dreno) pode ser aplicada a um grupo de fios posicionando um objeto de blindagem (Place » Shield) ou de blindagem com conexão (Place » Shield with Connection).

No exemplo abaixo, os fios W1, W2 e W3 são blindados por uma blindagem sem conexão (SH1), e os fios W4, W8 e W9 são blindados por uma blindagem com conexão (SH2). O fio W10 é posicionado para conectar SH2 a um pino de componente.

Posicione um objeto de blindagem ou de blindagem com conexão para indicar que os fios são blindados.
Posicione um objeto de blindagem ou de blindagem com conexão para indicar que os fios são blindados.

Quando um objeto de blindagem ou de blindagem com conexão é selecionado, os fios abrangidos são destacados em verde-neon na área de projeto ().

As propriedades de um objeto de blindagem ou de blindagem com conexão posicionado (localização e representação visual) podem ser configuradas no painel Properties quando o objeto está selecionado na área de projeto. A região Shield Objects do painel lista os fios abrangidos pelo objeto selecionado.

O painel Properties quando uma blindagem está selecionada
O painel Properties quando uma blindagem está selecionada

  • Use o controle de bloqueio/desbloqueio nos campos Width/Height do painel para alternar entre dimensões bloqueadas ou desbloqueadas. Quando o objeto é arrastado por suas alças de edição, a proporção é mantida de acordo com a configuração. O padrão é bloqueado, com uma proporção de altura:largura de 2:1.  Quando desbloqueado, você pode alterar as dimensões de forma independente, conforme necessário.

  • Se uma blindagem estiver associada a fios em vários locais do diagrama de fiação do chicote (ou seja, quando vários objetos de blindagem com o mesmo designador forem posicionados sobre fios diferentes), selecionar um objeto destacará todos os fios associados do grupo, e todos esses fios serão listados na região Shield Objects do painel Properties ().

É possível indicar que fios estão trançados entre si posicionando um objeto de trançamento (Place » Twist). Um objeto de trançamento pode ser posicionado sobre dois ou mais fios.

No exemplo abaixo, os fios W1 e W2 são indicados como trançados entre si pelo objeto de trançamento Tw1.

Posicione um objeto de trançamento para indicar que os fios estão trançados entre si.
Posicione um objeto de trançamento para indicar que os fios estão trançados entre si.

Quando um objeto de trançamento é selecionado, os fios abrangidos são destacados em verde-neon na área de projeto ().

As propriedades de um objeto de trançamento posicionado (sua localização e representação visual) podem ser configuradas no painel Properties quando o objeto está selecionado na área de projeto. A região Twist Objects do painel lista os fios abrangidos pelo objeto de trançamento selecionado.

O painel Properties quando um objeto de trançamento está selecionado
O painel Properties quando um objeto de trançamento está selecionado

  • Use o controle de bloqueio/desbloqueio nos campos Width/Height do painel para alternar entre dimensões bloqueadas ou desbloqueadas. Quando o objeto é arrastado por suas alças de edição, a proporção é mantida de acordo com a configuração. O padrão é bloqueado, com uma proporção de altura:largura de 1:1.  Quando desbloqueado, você pode alterar as dimensões de forma independente, conforme necessário.

  • Se um objeto de trançamento estiver associado a fios em vários locais do diagrama de fiação do chicote (ou seja, quando vários objetos de trançamento com o mesmo designador forem posicionados sobre fios diferentes), selecionar um objeto destacará todos os fios associados do grupo, e todos esses fios serão listados na região Twist Objects do painel Properties ().

  • Os parâmetros Voltas por unidade de comprimento e Thickness de um objeto de trançamento são usados ao sincronizar um projeto de chicote com uma ferramenta MCAD usando o MCAD CoDesigner. Consulte a página Sincronização de um projeto de chicote para saber mais.

Fios não conectados

As extremidades de fios não conectadas são indicadas por um quadrado preenchido.

Um fio não conectado sinalizado
Um fio não conectado sinalizado

Uma extremidade de fio não deve ser deixada sem conexão. Se o projeto exigir uma extremidade de fio não conectada, um objeto de 'não conectar' deverá ser posicionado nessa extremidade (Place » No Connect).

Posicione um objeto de 'não conectar' na extremidade de um fio que deve permanecer sem conexão.
Posicione um objeto de 'não conectar' na extremidade de um fio que deve permanecer sem conexão.

As propriedades de um objeto de 'não conectar' posicionado (sua localização e representação visual) podem ser configuradas no painel Properties quando o objeto está selecionado na área de projeto.

O painel Properties quando um objeto de 'não conectar' está selecionado
O painel Properties quando um objeto de 'não conectar' está selecionado

Trabalho com múltiplas folhas

Um diagrama de fiação de chicote completo pode ser definido em várias folhas (em um projeto 'plano', no qual todas as folhas estão no mesmo nível), cada uma representada por seu próprio documento *.WirDoc. A conectividade é criada diretamente entre quaisquer folhas usando objetos de interrupção de fio (Place » Wire Break) com o mesmo designador de fio.

Após selecionar o comando de posicionamento de interrupção de fio, posicione o objeto de modo que seu ponto de conexão elétrica (a extremidade presa ao cursor) toque o fio ao qual você deseja conectá-lo e, em seguida, clique ou pressione Enter para efetuar o posicionamento. Uma interrupção de fio posicionada herda as propriedades (designador e cor) do fio ao qual está conectada.

Selecione uma interrupção de fio na área de projeto para alterá-la no painel Properties. No painel, você pode definir o designador do fio ao qual ela está conectada e seu estilo: direção (Left ou Right) e cor.

Sincronização de fios

Os fios do chicote conectados por uma interrupção de fio são reconhecidos mesmo que tenham IDs de item de projeto diferentes. Além disso, todos os segmentos de fio com o mesmo designador conectados pela mesma interrupção de fio são comparados (quanto ao número de peça, comentário, cor e todos os parâmetros). Se forem encontradas diferenças, a violação Mismatched parameters in connected wire segments será relatada. Um aviso também aparece no painel Properties do fio e da interrupção de fio, indicando que foi detectado um conflito entre os parâmetros. Clique em Synchronize no aviso para abrir a caixa de diálogo Conflict Wire Parameters, na qual você pode escolher quais parâmetros usar para o segmento de fio.

Propriedades e parâmetros do fio antes da sincronização

Um aviso aparece no painel Properties indicando que há um conflito entre os parâmetros. Após clicar em Synchronize no aviso, a caixa de diálogo Confirm Wire Parameters é aberta. Selecione a opção desejada e clique em OK para executar a sincronização.

A violação Mismatched parameters in connected wire segments na caixa de diálogo Project Options

Após a sincronização, as propriedades dos segmentos de fio foram sincronizadas. 

 
  • Observe que, ao alterar a cor e o designador de uma interrupção de fio, a cor e o designador do fio ao qual ela está conectada são alterados de forma correspondente. Da mesma forma, ao alterar a cor e o designador de um fio, a cor e o designador da interrupção de fio conectada a ele são alterados de forma correspondente.

  • Você também pode alterar as propriedades de uma interrupção de fio durante seu posicionamento pressionando Tab após selecionar o comando de posicionamento. Observe que, se um designador for definido para a interrupção de fio antes de seu posicionamento, o fio ao qual ela for conectada herdará o designador e a cor da interrupção de fio.

  • Se uma cor de borda for definida para um fio ao qual uma interrupção de fio está conectada, essa interrupção também será exibida com uma borda dessa cor. Além disso, o designador da interrupção de fio será exibido na cor da borda do fio conectado.

  • As interrupções de fio não têm propriedades de fonte independentes; elas usam as propriedades Document Font do documento de diagrama de fiação de chicote no qual estão posicionadas.

  • As interrupções de fio também podem ser usadas para criar conectividade dentro da mesma folha do diagrama de fiação de chicote – por exemplo, em vez de posicionar um fio de um pino de conector a outro, você pode posicionar um fio de chicote curto e uma interrupção de fio em cada um desses pinos ().

Posicionamento de um componente de fiação de chicote

Quando conectado ao seu Workspace, você pode criar componentes com estrutura e propriedades predefinidas conforme necessário no Workspace conectado e, em seguida, reutilizar esses componentes em seus projetos de chicote, posicionando-os diretamente nos documentos de diagrama de fiação de chicote.

Consulte a página Criação de um componente de fiação de chicote para saber mais.

Esses componentes (cada um com um modelo de fiação de chicote definido e atribuído) são acessados pelo painel Components . Quando o documento de diagrama de fiação de chicote desejado estiver ativo na área de projeto, posicione um componente clicando com o botão direito do mouse em sua entrada no painel e selecionando o comando Place <ComponentName> no menu de contexto. O comportamento de posicionamento de um componente difere dependendo de ele incluir um único objeto de fio ou uma estrutura de cabo (vários fios e/ou objetos adicionais: cabos, blindagens etc.).

  • Single wire – ao posicionar um componente que inclui um único objeto de fio, você entrará no modo de posicionamento de fio de chicote. O fio que está sendo posicionado herdará as propriedades definidas durante a criação do componente. Consulte a seção Criação de conectividade no diagrama de fiação de chicote acima para saber mais sobre o posicionamento de fios de chicote.

  • Cable structure – ao selecionar o comando de posicionamento de um componente que inclui uma estrutura de cabo, essa estrutura aparecerá presa ao cursor exatamente como foi definida durante a criação do componente. Clique no local desejado do documento de diagrama de fiação de chicote para posicionar o componente. Em seguida, você poderá editar individualmente os objetos do componente, por exemplo, para conectar os fios que compõem o cabo aos pinos dos conectores do chicote.

Atualização do diagrama de fiação a partir de bibliotecas

Os seguintes objetos podem ser atualizados a partir de sua biblioteca de origem no Workspace:

  • Componentes de chicote

  • Cavidades dos componentes de chicote

  • Peças associadas aos componentes de chicote

  • Fios

Quando um objeto é selecionado, as informações sobre o componente vinculado do Workspace podem ser encontradas no painel Properties (por exemplo, na guia Associated Parts para as peças associadas de um componente de chicote).

Se houver uma revisão mais recente do componente do Workspace disponível, a entrada de status da revisão indicará isso usando o texto Out of date. No nível de cada objeto, o vínculo pode ser atualizado para a revisão mais recente do componente do Workspace clicando no botão .

Exemplo de indicação de uma revisão desatualizada de um componente de chicote​
Exemplo de indicação de uma revisão desatualizada de um componente de chicote

O recurso Update from Libraries (Tools » Update from Libraries) também pode ser usado para atualizar componentes desatualizados vinculados aos objetos listados acima. Observe que, para que um objeto seja incluído na atualização usando o recurso Update from Libraries, um componente atribuído ao objeto deve incluir um vínculo para um símbolo esquemático.

Anotação de objetos do diagrama de fiação de chicote

Use os comandos do menu Tools » Annotation para anotar os seguintes objetos no documento de diagrama de fiação de chicote:

  • Componentes de chicote

  • Fios

  • Emendas e derivações

  • Cabos

  • Blindagens e blindagens com conexão

  • Trançamentos

  • Objetos de 'Não conectar'

A anotação de objetos em um documento de diagrama de fiação de chicote é semelhante à anotação de componentes em um documento esquemático (*.SchDoc) de um projeto de PCB. Use os links a seguir para saber mais sobre os comandos de anotação disponíveis para um documento de diagrama de fiação de chicote:

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents