Capturando o projeto lógico do sistema

Num relance

Aprenda a capturar o projeto lógico de um sistema multiplaca no Altium Designer vinculando projetos de PCB filhos a módulos em um esquemático multiplaca. Este artigo explica como preparar conectores para a conectividade no nível do sistema, definir as fontes e propriedades dos módulos e importar dados de pinos e redes dos conectores para preencher as entradas dos módulos. Continue lendo para começar a criar uma representação clara das conexões entre as placas do seu sistema.

- Entenda as etapas para criar um esquemático multiplaca e vincular módulos a projetos de PCB filhos.
- Saiba como o parâmetro `System:Connector` identifica os conectores que serão incluídos no projeto no nível do sistema.
- Descubra como validar projetos de PCB filhos e importar seus dados de conectividade para as entradas dos módulos.
Aprofunde-se com a IA:

As etapas essenciais para criar um projeto esquemático de sistema multiplacas a partir de projetos de PCB subordinados são:

  1. Crie um projeto multiplacas e adicione um documento esquemático multiplacas ao projeto.

  2. Posicione blocos gráficos (módulos) no esquemático multiplacas para representar logicamente os projetos de PCB subordinados.

  3. Vincule cada módulo ao projeto subordinado correspondente.

  4. Importe os dados de conectividade dos projetos subordinados para o projeto multiplacas.

  5. Adicione conexões entre os módulos para criar o projeto lógico do sistema.

Para adicionar um documento esquemático multiplacas (*.MbsDoc) ao projeto multiplacas, clique com o botão direito do mouse na entrada do projeto no painel Projects e selecione Add New to Project » Multi-board Schematic no menu de contexto.

Cada projeto multiplacas pode incluir apenas um documento esquemático multiplacas.

Habilitação de projetos de PCB para projetos multiplacas

Os projetos de PCB do Altium Designer que representam os projetos de placas subordinadas em um projeto multiplacas contêm conexões específicas, como conectores de borda ou conectores macho/fêmea de pinos, que constituem a interface elétrica e física com outras PCBs no projeto do sistema.

Essas conexões e suas redes elétricas associadas precisam ser detectadas e processadas por um documento de projeto esquemático (lógico) multiplacas para estabelecer a conectividade entre as placas no projeto em nível de sistema. Essa funcionalidade é habilitada pela presença de um parâmetro de componente específico nos conectores do projeto de PCB — um parâmetro chamado System, com Connector como valor do parâmetro.

Os conectores com o Parâmetro:Valor System:Connector são detectados quando cada módulo em nível de sistema é sincronizado com seu projeto de PCB subordinado usando o comando Import from Child Projects. Isso é explicado na seção Representação de projetos de PCB subordinados no esquemático multiplacas a seguir.

Para cada conector em um projeto de PCB destinado a uma interconexão em nível de sistema, selecione o componente do conector e adicione o parâmetro de componente especial à lista na região Parameters, na aba General do painel Properties, com o componente selecionado.

Para saber mais sobre as propriedades dos componentes, consulte a página Trabalho com componentes posicionados.

A presença do parâmetro chamado System, com o valor Connector, vincula esse conector de PCB ao esquemático multiplacas.
A presença do parâmetro chamado System, com o valor Connector, vincula esse conector de PCB ao esquemático multiplacas.

Representação de projetos subordinados no esquemático multiplacas

A conectividade entre os projetos de PCB que compõem um projeto multiplacas é estabelecida posicionando blocos representativos (módulos) no esquemático e interligando seus conectores expostos (entradas de módulo) por meio de conexões.

Os módulos, que representam projetos de PCB subordinados e PCBs específicas contidas neles, são posicionados na área de projeto a partir do menu Place » Module.

Para definir a origem de um módulo posicionado, selecione-o na área de projeto e, no painel Properties, use o botão  associado ao campo Project na região Source da aba General para abrir a caixa de diálogo Choose Project (uma variante da caixa de diálogo Abrir projeto), na qual você pode procurar e selecionar um projeto de PCB ou multiplacas como origem do módulo. Após escolher o projeto necessário, selecione o projeto de placa de PCB ou a montagem multiplacas desejada dentro desse projeto usando a lista suspensa Assembly/Board.

Um projeto multiplacas estabelecido apresenta uma estrutura hierárquica de documentos que inclui os documentos de origem e os subprojetos subordinados vinculados aos módulos no projeto esquemático do sistema. A estrutura de um projeto subordinado é adicionada imediatamente ao projeto multiplacas quando um módulo do projeto do sistema é vinculado a esse projeto externo. Expanda a estrutura do projeto no painel Projects para exibir os arquivos que compõem o projeto multiplacas e seus projetos subordinados.

Para garantir que o projeto multiplacas extraia e processe os dados corretos de seus subprojetos, a PCB de cada projeto deve estar sincronizada com seu esquemático e livre de erros de projeto ou de desenho. Para validar um subprojeto de PCB, clique com o botão direito do mouse em seu nome no painel e selecione o comando Validate PCB Project <ProjectName>.PrjPcb — quaisquer problemas serão listados no painel Messages.

Javascript ID: Pnl_Properties_MBS_Module_Source
 
 
 
 
 
  • Um projeto de PCB, outro projeto multiplacas ou um projeto de chicote elétrico pode ser adicionado à estrutura do projeto multiplacas clicando com o botão direito do mouse na entrada deste último no painel Projects, selecionando o comando Add Existing to Project e, em seguida, procurando e selecionando o arquivo local *.PrjPcb, *.PrjMbd ou *.PrjHar correspondente. Se um projeto de PCB ou de chicote elétrico a ser incluído no projeto multiplacas já estiver aberto no Altium Designer, você poderá arrastar sua entrada no painel Projects para a entrada do projeto multiplacas principal, adicionando-o à sua estrutura (). Depois disso, posicione manualmente um novo módulo no documento esquemático multiplacas (do projeto multiplacas principal) e, com o módulo selecionado, escolha o projeto de PCB subordinado (e seu documento de PCB) ou o projeto multiplacas subordinado (e seu documento de montagem multiplacas) como origem desse módulo na lista suspensa do campo Source no painel Properties (). O projeto de chicote elétrico pode ser sincronizado com o projeto multiplacas (consulte a página Definição do diagrama de fiação para saber mais).

  • Para remover um projeto de PCB ou multiplacas subordinado da estrutura do projeto multiplacas principal, remova todos os módulos que fazem referência a esse projeto subordinado do documento esquemático multiplacas do projeto principal. O projeto subordinado será então removido automaticamente da estrutura.

  • Um projeto de PCB ou de chicote elétrico subordinado também pode ser removido da estrutura do projeto multiplacas principal arrastando sua entrada para fora da estrutura do projeto multiplacas. Observe que, nesse caso (e apenas para projetos de PCB), os módulos que fazem referência ao projeto subordinado permanecerão no documento esquemático multiplacas, assim como os vínculos desses módulos com o projeto subordinado. Para eliminar completamente do projeto multiplacas principal as referências ao projeto subordinado removido, remova esses módulos manualmente.

Use o painel Properties com um módulo posicionado selecionado para definir outras propriedades do módulo:

  • Use as propriedades Designator e Title na região Properties, na aba General do painel, para especificar o identificador esquemático e o texto do título do módulo, respectivamente. Use o botão  à direita do campo correspondente para alternar sua visibilidade no esquemático multiplaca e o botão  para permitir ou impedir a edição do valor. Use os controles de fonte e Other para configurar a fonte do texto, sua posição no documento e, no caso do texto do título, a visibilidade do nome do parâmetro.

  • A tabela na região Entries da aba General do painel Properties, quando o módulo estiver selecionado, será preenchida quando entradas de módulo forem adicionadas ao módulo – veja abaixo.

  • Use os controles na região Graphical, na aba General do painel, para configurar a aparência do módulo: seu tamanho (largura e altura), a espessura, o estilo e a cor da linha do contorno do módulo e a cor de preenchimento. As opções disponíveis de espessura e estilo de linha são definidas na região Line Styles do painel Properties quando nenhum objeto está selecionado na área de projeto. Para obter mais informações, consulte a página Configurando um documento esquemático multiplaca.

  • Use os controles na aba Parameters do painel para adicionar, modificar e remover parâmetros do módulo e configurar sua visibilidade na área de projeto.  

Adicione outros módulos e seus vínculos com projetos filhos ao projeto esquemático multiplaca, conforme necessário para o projeto completo do sistema.

Os módulos são preenchidos com dados dos projetos vinculados a eles por meio da importação dos dados do projeto usando os seguintes comandos dos menus principais ou do menu de contexto da área de projeto:

  • Design » Import From Child Projects – propaga os dados de projeto de todos os projetos de origem (filhos) para os módulos especificados.

  • Design » Import From Selected Child Projects – propaga os dados de projeto dos projetos de origem (filhos) correspondentes aos módulos atualmente selecionados.

O mais importante é que isso processa os dados de pinos e redes de cada conector nos projetos filhos que tenham o parâmetro especial System:Connector associado (veja os detalhes acima). Após a conclusão da importação, uma entrada de módulo é criada automaticamente para cada um desses conectores na representação gráfica do respectivo bloco de módulo. A entrada do conector fica ativamente associada aos pinos e às redes do conector no projeto filho. Selecione a representação gráfica de uma entrada de módulo na área de projeto para ver seus detalhes, como os pinos/redes do conector, no painel Properties. Até que seja conectada à entrada de outro módulo, a listagem de componentes/pinos da entrada no painel mostrará o conector e os pinos como não acoplados.

 
  • Embora as entradas sejam posicionadas automaticamente ao importar dados de projetos filhos, você também pode posicionar uma entrada de módulo manualmente selecionando o comando Place » Entry nos menus principais.

  • Selecione uma entrada de módulo clicando em sua representação gráfica e, em seguida, arraste-a ao longo do perímetro do módulo até um local adequado. Observe que o designador da entrada pode ser arrastado de forma independente para outra posição.

  • Você também pode mover um grupo de entradas de módulo selecionando mais de uma entrada e arrastando o grupo até o local desejado.

  • A coloração da entrada ajudará a movê-la e posicioná-la corretamente. Quando estiver fora de um módulo, a entrada será exibida parcialmente e em cinza, e seu posicionamento será impedido. Quando estiver sobre um módulo, a entrada aparecerá completa e colorida, indicando que pode ser posicionada nesse local.

Use o painel Properties com uma entrada selecionada para definir suas propriedades:

  • Use os controles na região Properties, na aba General do painel, para alterar o valor, a visibilidade e o estilo de Designator da entrada e escolher Type da entrada (Male/Female). Nessa região do painel, também são informados o número de pinos no conector da entrada (Number of Pins) e o número identificador atribuído a essa entrada no módulo pai (Entry Number).

  • Habilite a opção System Entry para indicar que a entrada é uma conexão no nível do sistema que não está ligada a outro módulo, por exemplo, uma entrada que representa um conector de entrada de alimentação.

    Um projeto multiplaca filho tem um módulo cuja entrada está com a opção System Entry habilitada.

    Quando as alterações forem importadas para o projeto multiplaca pai, esse conector de entrada será adicionado como uma entrada de módulo do módulo do projeto filho.

     
  • Quando a entrada é conectada por meio de uma conexão por chicote elétrico ou cabo (saiba mais), a região Mated Component do painel é preenchida com os dados do componente acoplado.

  • Na Mated Pins região do painel, a coluna Pin lista os pinos individuais do conector e suas respectivas redes. Depois que esta entrada é conectada, a coluna Mated Pin é preenchida com uma lista dos pinos acoplados. Além disso, depois que esta entrada é conectada, a aba Addresses do painel Properties é preenchida com uma listagem tabular dos caminhos de conexão e das redes da entrada (saiba mais).

  • Use os controles na aba Parameters do painel para adicionar, modificar e remover parâmetros da entrada e configurar sua visibilidade na área de projeto.

Quando entradas de módulo são adicionadas a um módulo, a tabela na região Entries da aba General do painel Properties, quando o módulo está selecionado, é preenchida com as entradas. A coluna Part(s) lista cada entrada de módulo pelo designador e pelo nome do conector de entrada no projeto de origem. Isso pode ser editado por conveniência — a nomenclatura é local ao projeto multiplacas e não afeta os projetos filhos de origem.

  • A coluna Mated part(s) é preenchida com dados quando a entrada é conectada a outra entrada no projeto multiplacas por meio de uma conexão. Para obter mais informações, consulte a página Trabalhando com conexões.

  • Na lista, você pode alternar rapidamente a visibilidade do designador da entrada (  /  ) e seu tipo (  /  ). Use os botões  e  para adicionar uma nova entrada indefinida ao módulo e à lista e para remover do módulo a entrada selecionada na lista, respectivamente.

  • Use os botões  e  para dividir a conexão selecionada na lista em duas entradas de módulo relacionadas e para reunir entradas anteriormente divididas em uma única entrada, respectivamente. Para obter mais informações, consulte a página Trabalhando com conexões.

Suporte a periféricos/componentes externos

Este recurso está disponível quando as opções MBS.PlacePart e MBS.UseGeometryMaker estão habilitadas na caixa de diálogo Configurações avançadas.

O documento esquemático multiplacas oferece suporte a periféricos/componentes externos que não fazem parte das montagens de placas PCB filhas convencionais (ou seja, componentes que não pertencem a uma PCB). Isso pode incluir, por exemplo, interruptores externos, sensores e quaisquer outros módulos eletrônicos comerciais de terceiros. Essa funcionalidade é viabilizada pelo suporte a dois tipos de objetos:

  • Custom Part – uma entidade semelhante a um módulo que permite vincular um ou mais componentes de biblioteca e que é adicionada ao documento esquemático multiplacas usando o comando Place » Custom Part dos menus principais. Use a região Linked Components do painel Properties, quando a peça personalizada posicionada estiver selecionada na área de projeto, para adicionar componentes à peça personalizada e removê-los usando os botões  e , respectivamente. Se a lista de componentes vinculados incluir componentes desatualizados do Workspace, clique no botão  para atualizar os componentes para suas revisões mais recentes. Uma entrada é adicionada automaticamente para cada componente vinculado.

  • Custom Connection – permite adicionar um único componente de biblioteca ao documento esquemático multiplacas arrastando o componente desejado do painel Components e soltando-o em um espaço livre da folha. Uma entrada é adicionada automaticamente para cada pino do componente.

    Você também pode criar um símbolo personalizado para um componente especificamente para uso em um documento esquemático multiplacas. Adicionar nomes separados por vírgulas ao campo Name das propriedades de um pino permite agrupar vários pinos em entradas, criando símbolos visualmente mais limpos, com menos entradas, e simplificando bastante a conexão desses componentes.

    Javascript ID: MBS_CustomConn_MultiplePins_AD24_5

    Ao editar um símbolo esquemático, adicione vários nomes separados por vírgulas ao campo Name de um pino.

    Quando o componente é adicionado a uma peça personalizada em um esquemático multiplacas, é criada uma entrada para cada pino do componente, em vez de uma única entrada para o componente, e são criadas entradas com vários pinos.

    Quando o componente é posicionado em um esquemático multiplacas como uma conexão personalizada, são criadas entradas com vários pinos.

Os componentes de biblioteca são aqueles disponíveis no Workspace ao qual você está conectado e nas bibliotecas locais disponíveis. Depois de posicionados/definidos, você pode conectar os componentes ao restante do projeto, por exemplo, usando conexões de cabos e chicotes.

Os componentes vinculados definidos por meio de peças personalizadas e/ou conexões personalizadas não são incluídos automaticamente na BOM geral do produto/sistema e não são apresentados na montagem multiplacas (*.MbaDoc).

Navegação cruzada

Os comandos de navegação cruzada disponíveis no menu principal Design e no menu de contexto da área de projeto permitem navegar rapidamente do documento esquemático multiplacas para elementos relacionados nos projetos filhos.

  • Para navegar do módulo ou da entrada atualmente selecionados até o documento PCB ou o conector nesse documento, dentro do projeto de PCB referenciado por esse módulo, use o comando Design » Crossprobe to PCB/Multi-board. Se o módulo fizer referência a um documento de montagem multiplacas (*.MbaDoc) dentro de um projeto multiplacas de origem (*.PrjMbd), a navegação cruzada levará ao documento de montagem multiplacas.

  • Para navegar do módulo ou da entrada atualmente selecionados até o esquemático de nível superior ou o conector no esquemático correspondente, dentro do projeto de PCB referenciado por esse módulo, use o comando Design » Crossprobe to Schematic.

  • Para navegar do módulo ou da entrada atualmente selecionados até a placa, ou o conector nessa placa, no documento de montagem multiplacas (*.MbaDoc) dentro do projeto multiplacas (*.PrjMbd), use o comando Design » Crossprobe to MBA.

  • Para navegar da conexão de chicote atualmente selecionada no documento esquemático multiplacas (*.MbsDoc) até um projeto de chicote vinculado (*.PrjHar), use o comando Design » Crossprobe to Harness. O documento de diagrama de fiação do projeto de chicote associado será aberto.

Ao realizar a navegação cruzada a partir de uma entrada de módulo, os objetos correspondentes no documento esquemático/PCB de destino serão exibidos de acordo com as opções Highlight Methods definidas na página Sistema – Navegação do Preferences caixa de diálogo. O realce não será aplicado ao documento esquemático multi-board.

Imprimir ou exportar para PDF

Para imprimir o documento esquemático multi-board ativo, selecione File » Print no menu principal (atalho: Ctrl+P). A caixa de diálogo Print será aberta. O lado esquerdo da caixa de diálogo apresenta uma pré-visualização de impressão com escala ajustável. As opções padrão de impressão estão disponíveis no lado direito da caixa de diálogo. Elas permitem selecionar uma impressora específica, confirmar a localização da impressora, verificar quantos documentos estão na fila de impressão, ajustar o número de cópias a imprimir, o tamanho da página e a orientação. Após clicar em , o conjunto de impressão será enviado ao dispositivo de impressão escolhido, de acordo com as opções definidas.

A caixa de diálogo Print
A caixa de diálogo Print

Para exportar um documento esquemático multi-board para um arquivo PDF, selecione File » Export to PDF no menu principal.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents