Liberando para um Workspace
Num relance
- Identifique quais conjuntos de dados de origem, fabricação, montagem, variantes e personalizados devem ser incluídos e como atribuir as tarefas de saída necessárias.
- Entenda as opções de destino da liberação, os esquemas de nomenclatura dos itens do Workspace e os controles das revisões de destino.
- Acompanhe as etapas de liberação e saiba como os comandos de liberação automatizados afetam a revisão, a geração de relatórios e a publicação no PLM.
Com a visualização Release em Online Mode, o processo de liberação segue um fluxo por etapas, com as entradas no lado esquerdo da visualização mostrando rapidamente em qual etapa você está:
-
Configure Server Release – nesta etapa do processo de liberação, você especifica os tipos de dados que deseja gerar: dados de origem (sempre gerados), dados de fabricação e dados de montagem (para o projeto base e cada variante detectada).
-
Validate Project – esta próxima etapa do processo de liberação é executada automaticamente quando um ou mais relatórios do tipo Validação são detectados nos arquivos OutJob atribuídos. Todos os geradores de saída de validação definidos em um arquivo Output Job atribuído ao item de dados que está sendo liberado são executados.
-
Generate Data – esta próxima etapa do processo de liberação é executada automaticamente. Aqui, todas as outras saídas — definidas nos arquivos OutJob atribuídos aos itens de dados incluídos — são executadas para gerar os dados a serem liberados nos respectivos itens de destino do Workspace.
-
Review Data – após a aprovação em todas as verificações de validação e a geração dos dados de saída, esta etapa do processo de liberação permite revisar os dados gerados.
-
Upload Data – após a confirmação da liberação na etapa anterior, esta próxima etapa é iniciada automaticamente. Ela simplesmente apresenta o progresso do upload dos dados para as revisões dos respectivos itens de dados no Workspace de destino.
-
Execution Report – esta é a etapa final do processo, que apresenta um resumo da liberação. São fornecidos links de navegação para acessar rapidamente as revisões dos itens geradas no painel Explorer. Se você acessou o Project Releaser como parte de um processo de liberação e publicação em um PLM, o botão
será apresentado. Clique nele para continuar o fluxo de trabalho subjacente ao processo e publicar no PLM.
-
Publish to PLM – esta etapa está presente apenas ao executar a liberação no processo ativado correspondente (para liberar e depois publicar em um PLM). Esta etapa é iniciada automaticamente quando o botão
é clicado na etapa anterior (ou acessada diretamente se o comando Prepare & Release & Publish to PLM, no menu associado ao botão
, tiver sido usado). A caixa de diálogo Login Credentials será exibida. Insira o Username e a Password da sua instância de PLM e selecione o modelo de PLM que deseja usar (exibido no formato <PLMInstance>:<PublishingTemplate>).
Etapa on-line 1 – Configurar a liberação no servidor
Nesta etapa do processo de liberação, você especifica os tipos de dados que deseja gerar. Os itens de dados que podem ser liberados são:
- Source Data – um instantâneo do projeto de origem.
- Fabrication Data – os dados necessários para que um fabricante produza a placa nua.
- Assembly Data for the Base Design (no variations) – os dados necessários para que uma empresa de montagem monte todos os componentes na placa nua de acordo com uma lista de materiais, para o projeto base sem variações.
-
Assembly Data for Design
Variant n– os dados necessários para que uma empresa de montagem monte os componentes na placa nua de acordo com uma lista de materiais, paraVariant ndo projeto base.
O número de conjuntos de dados de montagem corresponderá ao projeto base (sem variações) e a todas as variantes detectadas definidas para esse projeto.

Etapa 1 do processo de liberação do projeto – configuração do que será incluído na liberação (quais dados gerar).
O item Source Data é sempre incluído em uma liberação. Os demais itens de dados são opcionais.
Atribuição de Output Jobs
Para que os itens Fabrication Data e Assembly Data sejam incluídos em uma liberação, é necessário atribuir a eles pelo menos um arquivo OutputJob. Se você tiver arquivos Output Job cujos nomes comecem com as substrings 'fab' e 'ass', esses OutJobs serão atribuídos automaticamente às seções Fabrication Data e Assembly Data, respectivamente, quando a visualização Release for acessada pela primeira vez. Caso contrário, você precisará atribuir manualmente os OutJobs aplicáveis em cada caso. Isso pode ser feito na aba Release Options da caixa de diálogo Project Release Options (clique no botão
no canto inferior esquerdo da visualização para acessá-la).

Atribua OutJobs aos conjuntos de dados aplicáveis, conforme necessário.
Alteração do destino da liberação
A aba Release Options da caixa de diálogo Project Release Options também pode ser usada para alterar o destino da liberação, alternando entre os modos de operação gerenciado (Online) e não gerenciado (Offline). Há três opções disponíveis:
-
Unmanaged - Folder(Offline): selecione esta opção para liberar os dados gerados em uma pasta local. O caminho da pasta raiz é especificado na aba Output Path da caixa de diálogo. Por padrão, ele é definido como[OutputPath](usando o caminho definido no campo Output Path, na aba Options da caixa de diálogo Project Options). -
Unmanaged - Zip(Offline): selecione esta opção para liberar os dados gerados em uma pasta local. Os dados serão compactados em um único arquivo ZIP. O caminho e o nome do arquivo ZIP são especificados na aba Output Path da caixa de diálogo. Por padrão, são definidos como[OutputPath][ProjectName].zip(usando o caminho definido no campo Output Path na aba Options da caixa de diálogo Project Options). -
Managed - <WorkspaceName>(Online): selecione esta opção para liberar no Workspace (comWorkspaceName) ao qual você está conectado no momento.

Alterne o destino da liberação – para onde os dados gerados serão enviados – como parte das opções de liberação do projeto.
Definição dos esquemas de nomenclatura dos itens do Workspace
Ao liberar um projeto para o Workspace de destino pela primeira vez, você pode definir como serão nomeados os itens de dados de destino nesse Workspace (cujas revisões recebem os dados gerados). Isso é feito na guia Item Naming da caixa de diálogo Project Release Options, acessada pressionando o botão
no canto inferior esquerdo da visualização (ou clicando no link Target Revision de um conjunto de dados a ser liberado e escolhendo Edit no menu de contexto). Use essa guia para:
- Definir o nome do projeto. Por padrão, esse campo será preenchido com o nome atual do projeto.
-
Definir os esquemas de nomenclatura padrão para os vários itens de dados que podem ser gerados como parte da liberação. Clique em um campo na coluna Item ID e, em seguida, clique no botão
à direita do campo para acessar a caixa de diálogo Choose Item (uma versão do painel Explorer), que permite selecionar como destino um Item existente no Workspace conectado no momento.
Para alterar qualquer um dos esquemas de nomenclatura, clique no botão Settings para acessar a caixa de diálogo Naming Template Settings.

Defina o nome do projeto e a nomenclatura dos itens de dados gerados no Workspace de destino. Aqui, os campos são editáveis porque o projeto ainda não foi liberado.
Os seguintes formatos de macro podem ser usados em um modelo de nomenclatura:
-
Parameter-based – permite o uso de parâmetros entre colchetes (por exemplo,
[ProjectName],[VariantName],[ProjectParameter]). -
Numeric-based – permite o uso de quantificadores numéricos entre chaves (por exemplo,
{0000},{9000}).
Controle da revisão de destino
Clique no link ao lado de uma entrada Target Revision, de volta à visualização principal, para acessar um menu de comandos, ilustrado na imagem a seguir:

Acesso aos controles para especificar a revisão de destino de um conjunto de dados que será gerado como parte da liberação – passe o mouse sobre a imagem para visualizar.
Os comandos disponíveis dependerão de o item já ter sido liberado pela primeira vez ou não. A seguir, estão listados todos os comandos possíveis:
-
Auto <RevisionID> – esta entrada permite que o sistema gerencie as revisões, para que você não precise criar revisões planejadas onde elas ainda não existam. O
RevisionIDmostra a próxima revisão do Item no mesmo nível do esquema de nomenclatura de revisões atribuído (por exemplo, se a revisão atual forA.1, esse comando mostraráA.2como destino). -
Next <RevisionID> – esta entrada só fica disponível após a liberação inicial do item. Use-a para incrementar rapidamente a revisão de destino no próximo nível do esquema de nomenclatura de revisões atribuído. O
RevisionIDmostra a próxima revisão (por exemplo, se a revisão atual forA.1, esse comando alterará o destino paraB.1). -
Custom – use esta entrada para selecionar uma revisão específica de um item de destino, definindo um ID de revisão personalizado por meio da caixa de diálogo Custom Revision ID. Dependendo do esquema de nomenclatura de revisões utilizado, a caixa de diálogo pode conter até três campos de ID de nível. Observe que o ID da primeira revisão planejada do item pode ser alterado a qualquer momento após a criação do Item e antes da liberação dos dados nessa revisão inicial (ou seja, enquanto ela ainda estiver no estado
Planned). - Browse – use esta entrada para apontar para uma revisão de Item de destino existente na qual os dados serão liberados. A caixa de diálogo Choose Target Item (uma versão do painel Explorer) será exibida para essa finalidade.
- Edit – use esta entrada para acessar a guia Item Naming da caixa de diálogo Project Release Options, na qual você pode alterar o nome do Item de destino (e da revisão inicial) que será criado.
- Navigate – use esta entrada para navegar rapidamente até o Item no painel Explorer (no qual ele já foi liberado, e a próxima revisão existe em estado planejado).
A entrada na parte superior do menu refletirá a revisão de destino atualmente escolhida/definida.
Acesso aos detalhes da geração de dados
Clique no controle Details – na extremidade direita do cabeçalho de um conjunto de dados – para acessar os detalhes do que exatamente será gerado por esse conjunto de dados. Recolha essa visualização expandida clicando no controle Hide Details. Com exceção do conjunto Source Data, os dados gerados virão de um ou mais arquivos Output Job atribuídos. Você pode acessar rapidamente o OutJob de origem clicando no controle Configure.

Acesse a visualização detalhada de um conjunto de dados para ver quais dados serão gerados – passe o mouse sobre a imagem para visualizar.
Configurações adicionais
Há configurações adicionais relacionadas à liberação do projeto que podem ser definidas na página Data Management – Servers da caixa de diálogo Preferences:
-
A pasta usada para armazenar temporariamente os arquivos gerados antes do envio ao Workspace conectado no momento pode ser definida para o local automático (
\Users\<ProfileName>\AppData\Local\Temp\Releasesem uma instalação padrão) ou substituída manualmente por uma pasta de sua escolha. - Habilite a opção Delete contents after exiting release mode para que a pasta de armazenamento temporário seja esvaziada após a conclusão do processo de liberação.
- O nome de cada saída gerada pode, opcionalmente, receber como prefixo o ID do Item e o ID da Revisão (por exemplo,
[FAB-Kame_FMU-A.1] Validation.PDF). Para isso, habilite a opção Prepend revision HRID to file names.

Preferências adicionais relacionadas ao processo de liberação do projeto.
Com os itens de dados que serão criados como parte da liberação configurados conforme necessário, clique no botão
no canto inferior direito da visualização para prosseguir.
Várias verificações prévias à liberação são realizadas como parte da preparação, incluindo:
- Verificar se o projeto e todos os arquivos foram salvos.
- Verificar se o projeto e todos os arquivos relevantes foram registrados no VCS, se aplicável.
- Verificar se cada item de dados habilitado recebeu um nome.
- Garantir que o usuário tenha permissão para criar o item de destino (e sua revisão).
- Criar os Itens de destino necessários (e as revisões planejadas) no Workspace, quando ainda não existirem, e garantir que a próxima revisão seja usada para os itens que já existem.
Se algum problema for encontrado, serão oferecidas soluções para resolvê-lo (como salvar arquivos modificados localmente e registrá-los no VCS).
O Item Source Data é gerado neste momento — com uma cópia instantânea dos arquivos-fonte do projeto liberada para a revisão do item de destino.
Etapa on-line 2 – Validar o projeto
Após a conclusão da Etapa 1 sem problemas, esta próxima etapa do processo de liberação é executada automaticamente quando um ou mais relatórios do tipo Validação são detectados nos arquivos OutJob atribuídos. Todos os geradores de saída de validação definidos em um arquivo Output Job atribuído ao item de dados que está sendo liberado são executados. Isso inclui a execução de qualquer uma das seguintes verificações:
- Differences Report – usar o comparador para determinar se os documentos-fonte e os documentos de projeto da PCB estão corretamente sincronizados.
- Electrical Rules Check – verificar a validade elétrica e de representação do projeto-fonte capturado.
- Design Rules Check – verificar a validade do documento da PCB em relação às restrições de projeto especificadas para a placa.
-
BOM Checks – verificar possíveis violações associadas a Itens de Projeto ou Opções de Peças no documento BOM de origem (
*.BomDoc), quando disponível. - Footprint Comparison Report – comparar os footprints da placa com os da biblioteca de origem para garantir que estejam atualizados e sejam correspondentes.
- Component State Checking – verificar componentes que estejam em estados restritos. Como parte da configuração, você determina a ação a ser tomada para cada estado atualmente definido de cada Definição de Ciclo de Vida atualmente definida no Workspace de destino: nenhuma ação, um aviso ou a geração de um erro. A última opção impedirá a liberação do projeto. Além disso, a execução da verificação gerará um relatório prático em HTML, permitindo identificar rapidamente quais componentes do projeto não estão em estados válidos.
- Environment Configuration Compliance Check – verificar se estão sendo usados apenas itens de dados permitidos pela configuração de ambiente disponível para a função atribuída a você (se aplicável). Essa verificação também pode garantir que todos os itens de projeto sejam provenientes de um Workspace.
Se a validação for bem-sucedida, o ícone
será apresentado com o texto Passed. Caso contrário, o ícone
será exibido com o texto Failed.
Etapa on-line 3 – Gerar dados
Após a conclusão da Etapa 2 sem problemas, esta próxima etapa do processo de liberação é executada automaticamente. É aqui que todas as outras saídas — definidas nos arquivos OutJob atribuídos aos Itens de Dados incluídos — são executadas para gerar os dados que serão liberados nos respectivos itens de destino no Workspace.
Assim como nas outras etapas, mas de forma mais perceptível nesta, por levar mais tempo para ser executada, ícones são usados para apresentar o progresso da geração:
– ainda não executado/gerado.
– em execução/geração.
– gerado com sucesso.
– falha na geração.
Etapa on-line 4 – Revisar dados
Com todas as verificações de validação aprovadas e os dados de saída gerados, esta etapa do processo de liberação permite revisar os dados gerados.

Revise os dados gerados, verificando se tudo está como deveria, antes de confirmar a liberação e enviar os dados para o Workspace.
Por padrão, a página apresenta uma visualização simples (compacta) dos dados gerados. Alterne para uma visualização mais detalhada clicando no controle Details associado à seção de interesse.

Clique em um controle Details para alternar da visualização simples para a detalhada dos dados gerados da seção associada. Volte à visualização anterior clicando no controle Hide Details.
Estados de geração de saída na visualização detalhada
A tabela a seguir lista os possíveis estados das saídas quando os dados estão sendo gerados e observados na visualização detalhada:
Estado |
Descrição |
|---|---|
|
A saída ainda não foi gerada/não existe. |
|
A saída foi gerada, mas ocorreram alterações no projeto desde então, tornando esses dados desatualizados. |
|
A saída está sendo gerada no momento. |
|
A saída é baseada em validação e gerou um relatório sem erros. No caso de um relatório ERC, não há erros ou o nível desses erros está dentro do nível máximo de erro tolerado especificado para esse relatório. |
|
A saída (exceto as saídas baseadas em validação) foi gerada com sucesso. |
|
A saída não foi gerada com sucesso. Para uma saída baseada em validação, isso significa que existem erros nos documentos-fonte do projeto que estão causando a falha de determinadas verificações. Para uma saída padrão, não foi possível gerar a saída com sucesso. Talvez existam Erros Fatais ao realizar uma validação anterior à geração, ou haja algo incorreto na configuração do gerador de saída associado, no arquivo Output Job. |
Na visualização compacta dos dados gerados, clique em um link View para abrir o arquivo de dados ou conjunto de arquivos associado, no editor correspondente do Altium Designer (por exemplo, o editor CAM para arquivos Gerber ou arquivos ODB++ compactados/descompactados) ou no aplicativo externo correspondente (por exemplo, o Microsoft Excel para uma lista de materiais). Na visualização detalhada, clique duas vezes em uma entrada para visualizar apenas esse arquivo.
Um teste comum de prontidão para liberação usado por muitos projetistas é comparar os arquivos Gerber gerados na liberação atual com os arquivos Gerber da liberação anterior. Clique no link Compare Gerber ao lado de uma saída Gerber e selecione uma liberação anterior no menu suspenso para comparar os dados Gerber preparados com os da liberação escolhida. Seu navegador padrão abrirá o Workspace da sua empresa e exibirá os resultados.

Acesso ao recurso de comparação de Gerber pelo Project Releaser, antes de liberar os dados para um Workspace.
► Saiba mais sobre o recurso Gerber Comparison (Workspace do Altium 365, Workspace do Enterprise Server).
Se, após revisar os dados, você perceber que precisa fazer modificações, clique no botão
no canto inferior direito da visualização. Uma caixa de diálogo de confirmação será exibida, alertando que todos os dados gerados serão perdidos — clicar em OK cancelará a liberação e retornará você à Etapa 1 do processo.
Se todos os dados gerados estiverem corretos, prossiga com a liberação clicando no botão
(também no canto inferior direito da visualização). A caixa de diálogo Confirm Release será exibida, resumindo as configurações do projeto que serão liberadas para o Workspace. Aqui, você também pode adicionar um Name (por padrão, a entrada aqui é [ProjectName]), Description e quaisquer notas de liberação pertinentes.

Confirmação do que será liberado, em termos das revisões de itens geradas, e possibilidade de alterar o nome e a descrição e adicionar notas de liberação.
Etapa on-line 5 – Upload de dados
Após a confirmação da liberação na etapa anterior, esta próxima etapa é iniciada automaticamente. Ela apenas apresenta o andamento do upload dos dados para as revisões dos itens de dados correspondentes no Workspace.

Esta etapa apenas mostra o andamento do upload dos dados gerados para as revisões de itens vinculadas no Workspace.
Etapa on-line 6 – Relatório de execução
Esta é a etapa final do processo, que fornece um resumo da liberação.

O relatório final da liberação.
Use os links de navegação para acessar rapidamente a revisão de item associada, que contém os dados liberados (dados de fabricação, dados de montagem e quaisquer conjuntos de dados personalizados), no painel Explorer — seu portal para o Workspace.

Visualização dos dados liberados do projeto diretamente no Workspace, por meio do painel Explorer.
Visualização do projeto liberado
Para um projeto do Workspace, você tem uma funcionalidade adicional disponível após a conclusão da liberação. Ao clicar no link Project Page, o último dos links de navegação na parte superior da página Execution Report, você abrirá o painel Explorer, que apresenta o projeto no Project View — disponível apenas para projetos do Workspace.

Você pode explorar um projeto do Workspace no painel Explorer com mais detalhes, por meio do Project View.
A região Releases (no canto inferior esquerdo da visualização) exibirá uma compilação das liberações associadas ao projeto, que inclui um resumo de cada liberação e dos pacotes que a compõem. Clique no botão
nessa região para abrir a caixa de diálogo de alteração de estado em lote, que você pode usar para alterar o estado do ciclo de vida de vários itens relacionados à mesma liberação, de uma só vez, em um único processo em lote.
Também é possível acessar informações sobre as liberações do projeto no visualizador Web do Workspace de destino, aberto pelo botão
do painel Explorer. No visualizador Web de um Workspace, todas as liberações associadas ao projeto podem ser acessadas na visualização Releases — ou na visualização Manufacture para um Workspace fornecido por um servidor local. A página lista todas as liberações do projeto, com a entrada mais recente no topo, e cada liberação pode ser aberta no Manufacturing Portal do Workspace pelo respectivo botão de abertura A visualização Manufacturing Portal fornece informações mais detalhadas sobre a liberação selecionada, incluindo os arquivos dos pacotes que a compõem, o conjunto completo de documentos do projeto e detalhes dos fabricantes e fornecedores dos componentes. Observe que o recurso Send to Manufacturer está disponível apenas em um Workspace do Altium 365. ► Consulte a página Visualização de liberações do Workspace do Altium 365 para obter mais informações.
Pronto — com o projeto liberado, basta fechar a visualização Release (usando o botão
no canto inferior direito da visualização). E, quando você precisar liberar novamente o mesmo projeto no futuro, o Project Releaser facilitará esse processo de forma rápida e simples, incrementando automaticamente as revisões dos itens de destino.
Publicação em uma instância de PLM
Related pages: Integração com PLM (Altium 365 Workspace, Enterprise Server Workspace), Publicação em um PLM
Você pode publicar um projeto em uma instância de PLM como parte da execução do Project Releaser no Altium Designer. A operação de publicação usa um modelo de publicação – definido como parte da configuração de integração dessa instância de PLM – para controlar como os dados devem ser propagados para o PLM. Esse recurso está disponível por meio de um processo configurado adequadamente. Uma definição de processo de exemplo é fornecida como parte da instalação – Project Releaser with Publish – cujo fluxo de trabalho subjacente permite publicar na instância de PLM integrada como uma etapa adicional do Project Releaser. O diagrama do fluxo de trabalho é mostrado abaixo.

O diagrama do fluxo de trabalho da definição de processo de exemplo padrão Project Releaser with Publish
Após a ativação, o processo de publicação em uma instância de PLM como parte do Project Releaser pode ser acessado no Altium Designer pelo submenu Project » Project Releaser do projeto ativo ou pelo submenu de contexto Project Releaser, acessado ao clicar com o botão direito do mouse na entrada do projeto no painel Projects.

Acesso ao processo de publicação em uma instância de PLM como parte do Project Releaser
O Project Releaser será exibido com uma etapa adicional – 7. Publish to PLM. Além disso, um comando está disponível no menu associado ao botão
– Prepare & Release & Publish to PLM – caso você queira executar o Project Releaser sem parar para revisar os dados gerados e o relatório de execução.

Um comando adicional para executar o Project Releaser sem parar para revisar os dados gerados e o relatório de execução
Se você executar o Project Releaser com o comando padrão Prepare, após revisar e liberar os dados, o botão
será apresentado na etapa Execution Report. Clique nele para continuar o fluxo de trabalho subjacente do processo e publicar no PLM. A caixa de diálogo Login Credentials será exibida. Insira o Username e a Password da sua instância de PLM e selecione o modelo de PLM que deseja usar (exibido no formato <PLMInstance>:<PublishingTemplate>).

A caixa de diálogo Login Credentials acessada durante a primeira publicação na instância de PLM.
Clique na aba Diagram para ver o fluxo de trabalho subjacente do processo.

A aba Diagram da caixa de diálogo Login Credentials
Clique no botão
para prosseguir com o processo de publicação, de acordo com esse fluxo de trabalho.
).
