Lançamento do Projeto de Design
Num relance
- Entenda como os dados de origem, fabricação e montagem são organizados e preservados, incluindo as saídas de montagem para variantes de projeto.
- Saiba como o controle de versão, as liberações em uma única operação e as verificações opcionais de validação ajudam a proteger a integridade das liberações.
- Descubra como preparar e acessar o Project Releaser, revisar as saídas geradas antes de confirmar a liberação e compartilhar os dados liberados por meio das opções de publicação disponíveis.
Quando um projeto é considerado pronto para ganhar o mundo, ele precisa ser liberado — um processo que muitas vezes pode ser subestimado.
Sem um processo de liberação disciplinado e com fundamentos sólidos, acompanhar um produto em constante evolução ao longo do tempo pode envolver inúmeras armadilhas. Imagine precisar voltar e liberar uma revisão anterior do seu produto, apenas para descobrir que nem todos os arquivos-fonte necessários do projeto foram incluídos, como um instantâneo, naquela liberação específica! Tudo bem; basta obter os arquivos de saída gerados nas pastas correspondentes àquela liberação — os confiáveis Gerbers e quaisquer informações adicionais de fabricação e montagem; afinal, isso é tudo de que você realmente precisa. Mas imagine que essas saídas “confiáveis” tenham sido sobrescritas ou corrompidas de alguma forma. Se ao menos o processo de liberação fosse mais robusto.
O Altium Designer atende a essa necessidade oferecendo um gerenciamento de liberação de projetos poderoso e de alta integridade. O processo de liberação do projeto é automatizado, permitindo liberar seus projetos sem os riscos associados a procedimentos manuais de liberação. Quando um projeto específico é liberado, um instantâneo dos arquivos-fonte do projeto é capturado e arquivado junto com todas as saídas geradas — que representam um produto tangível fabricado a partir desse projeto e vendido pela empresa. Os dados da liberação são armazenados na pasta ou no arquivo ZIP especificado no seu disco rígido, ou em revisões do Item correspondente ao projeto no Workspace de destino:
- Source Data (PCB Project Design Item) — uma cópia com registro de data e hora (instantâneo) dos arquivos principais do projeto, incluindo todos os documentos-fonte. Liberada em um Item separado no Workspace, permitindo manter sua valiosa propriedade intelectual separada dos dados gerados de fabricação e montagem necessários para que terceiros produzam o produto.
- Fabrication Data (PCB Fabrication Data Item) — o conjunto de dados necessário para que o fabricante produza a placa nua (arquivos Gerber, arquivos de furação NC etc.).
- Assembly Data (PCB Assembly Data Item) — o conjunto de dados necessário para que a empresa de montagem instale os componentes especificados na placa nua, de acordo com uma lista de materiais (arquivos de posicionamento de componentes, desenhos de montagem, BOMs etc.). Um Item exclusivo é usado para o projeto base (totalmente montado) e para cada variante definida para o projeto (variantes montadas).

Os dados gerados a partir de um projeto são armazenados com segurança no Workspace, em revisões de Items relacionados ao projeto. Esses dados de alta integridade são então usados pela cadeia de suprimentos para fabricar a revisão necessária do produto.
O resultado geral é um gerenciamento de liberação de projetos com o mais alto nível de integridade possível. Não apenas o projeto em si é rigorosamente monitorado, protegido por backups e mantido sob controle de versão, como também as liberações dos seus dados recebem o mesmo tratamento no Workspace de destino — de forma robusta, segura e protegida.
Principais benefícios
- Integração com o controle de versão. Se o seu projeto estiver sob controle de versão, o sistema exigirá que todos os arquivos tenham sido submetidos ao repositório e estejam atualizados antes da liberação. Isso garante que nenhuma “cópia particular” de um documento essencial do projeto permaneça no disco rígido de um engenheiro — com o risco de se perder. Essa regra simples pode economizar horas no futuro, evitando buscas dispendiosas pelo conjunto correto de documentos de projeto usados para gerar um produto liberado.
- “Liberação única”. O sistema permite liberar apenas uma vez para cada revisão de um Item de destino. De fato, uma liberação bem-sucedida confirma o armazenamento dos dados da liberação na Revisão do Item referenciada e, em seguida, fecha essa revisão. Nenhum dado adicional pode ser gerado e liberado nessa mesma revisão.
- Processo de liberação de projetos automatizado e repetível. Liberação com um único toque — sem etapas manuais nem riscos. Da captura do instantâneo dos arquivos do projeto à validação e à geração de saídas, não há necessidade de interação. Se uma parte do processo falhar, a liberação falhará. Simples assim. E você pode revisar todos os dados gerados antes de confirmar o armazenamento definitivo dos dados da liberação na Revisão do Item no Workspace de destino.
-
Capacidade de validar o projeto como parte integrante do processo de liberação. O processo de liberação trabalha a partir de um instantâneo “bloqueado” dos arquivos-fonte do projeto (incluindo dependências), e é muito provável que uma validação prévia já tenha sido realizada antes de iniciar a liberação. Mas, para proporcionar mais tranquilidade e garantir a integridade dos dados do projeto, você pode, opcionalmente, adicionar verificações de validação ao “fluxo” do processo de liberação por meio de configurações de tarefas de saída devidamente ajustadas. Isso inclui a verificação ERC padrão dos esquemas-fonte e a verificação DRC da PCB, além da capacidade de verificar se o projeto-fonte e a PCB estão sincronizados e de comparar os footprints da placa com os da biblioteca de origem, para garantir que estejam atualizados e sejam correspondentes. A liberação falhará se alguma verificação de validação não for concluída com êxito.
- Todos os arquivos de dados gerados pelo processo de liberação do projeto podem, opcionalmente, receber como prefixo o ID do Item e o ID da Revisão do Item, garantindo que não haja ambiguidade sobre qual revisão de qual Item os dados devem ser usados para fabricar.
- Publicação. Oferece a capacidade de publicar dados de liberação diretamente de um Workspace em um espaço de armazenamento compartilhado, como Amazon S3, servidores FTP, Box.com ou uma simples pasta de rede. Isso facilita o compartilhamento seguro dos dados do Workspace, sem conceder a terceiros acesso a esse Workspace.
O recurso de liberação de projetos
O Altium Designer oferece um gerenciamento de liberação de projetos poderoso e de alta integridade, graças ao seu Project Releaser. Com uma interface de usuário intuitiva, você pode gerar simultaneamente todos os dados de manufatura do seu projeto – dados de fabricação, dados de montagem, arquivos-fonte do projeto etc. O Project Releaser também permite gerar, ao mesmo tempo, os dados de montagem para várias variantes detectadas no seu projeto de PCB. Você nem precisa se preocupar se ainda não criou arquivos Output Job – ele fará isso por você, se você solicitar!
Com o Project Releaser, você poderá gerar seus dados de manufatura de forma simples e com a mais alta integridade. Também poderá conferir os resultados dessa geração antes de concluir a liberação (visualizando dados Gerber/ODB++ no editor CAM, por exemplo), garantindo que os dados gerados sejam exatamente os necessários para que seu projeto seja fabricado no prazo e corretamente já na primeira vez.
Os pré-requisitos para liberar um projeto em um Workspace são:
- O Altium Designer está conectado ao Workspace que hospeda o repositório de destino da liberação.
- O projeto inclui Output Jobs adequados – geradores de dados de saída do projeto (para saídas como impressão, arquivo ou PDF). Se não houver OutJobs disponíveis, o Project Releaser oferecerá a criação de OutJobs adequados para conduzir o processo.
- O projeto utilizado pelo processo de liberação tem todos os elementos necessários – os dados de origem são válidos e estão atualizados, o usuário tem permissões suficientes para liberar esse projeto no Workspace etc.
Acessando o Project Releaser
O processo de liberação em si é realizado usando o Project Releaser do Altium Designer, cuja interface de usuário é disponibilizada em uma visualização dedicada – a visualização Release. Ela pode ser acessada das seguintes formas:
- Selecionando o comando Project » Project Releaser nos menus principais (com um documento-fonte do projeto desejado aberto como documento ativo).
- Clicando com o botão direito na entrada do projeto desejado, no painel Projects, e selecionando o comando Project Releaser no menu de contexto.

A visualização Release – a interface de usuário do Project Releaser.
Publicação em um PLM
Related page: Integração com PLM (Workspace do Altium 365, Workspace do Enterprise Server)
Se você tiver um processo ativado para publicação em uma instância de PLM como parte do Project Releaser, ele será apresentado no submenu Project Releaser do projeto. Iniciar esse processo adicionará uma etapa à visualização para realizar essa publicação.
A definição de processo de exemplo Publish to PLM (User selects) está disponível no seu Workspace – como parte do tema de processos Project Activities – para realizar essa publicação padrão (ou seja, não como parte do Project Releaser, conforme descrito anteriormente). Esse processo permite publicar as saídas liberadas do projeto na instância de PLM integrada, permitindo que o usuário selecione exatamente quais saídas serão publicadas. O diagrama do fluxo de trabalho é mostrado abaixo.

O diagrama do fluxo de trabalho da definição de processo de exemplo Publish to PLM (User selects) padrão
Os processos de publicação padrão em PLM podem ser acessados no Altium Designer pelo submenu Project » Project Activities do projeto ativo.

Acessando, no Altium Designer, um processo ativado para publicação padrão dos dados liberados de um projeto do Workspace em uma instância de PLM.
Modo/destino da liberação
O Project Releaser atende a todos os tipos de projetos – locais/sem controle de versão, sob controle de um VCS externo ou sob o controle de versão nativo de um Workspace conectado – oferecendo dois modos de operação:
- Managed (Online) Mode – libera todos os dados gerados em revisões de Itens em um Workspace de destino. Você nem precisa se lembrar de incrementar as revisões dos Itens, pois tudo é feito para você. E, se houver um processo definido para liberação em uma instância de PLM por meio do Project Releaser, iniciar esse processo adicionará uma etapa à visualização para realizar essa liberação.
- Unmanaged (Offline) Mode – libera todos os dados gerados em uma estrutura de pastas, que pode ser opcionalmente compactada em um único arquivo Zip.
O Project Releaser tenta detectar automaticamente qual modo de liberação usar e o destino da liberação. Quando houver mais de uma opção, normalmente quando o projeto tiver sido liberado em um Workspace e você estiver conectado a outro, o sistema apresentará as opções disponíveis.
Detectando arquivos Output Job
O método fundamental para gerar saídas de projeto no Altium Designer é usar os diversos geradores de saída de projeto disponíveis, que produzem os arquivos de dados e as artes-finais necessários para criar a versão física do projeto – em outras palavras, as impressões de esquemáticos e PCBs, os arquivos de fabricação Gerber e de furação NC, a lista de materiais (BOM), os arquivos de montagem Pick and Place, os desenhos de manufatura etc., necessários para fabricar e montar o projeto.
Os geradores de saída selecionados e os arquivos de saída específicos que eles criarão para um projeto são definidos em conjunto usando o Output Job Editor, que salva as configurações de mapeamento entre geradores e saídas em um arquivo Output Job (*.OutJob) – criado por meio do comando File » New » Output Job File.
Como mecanismo central para gerar coletivamente os arquivos de manufatura de um projeto, os Output Jobs do Altium Designer oferecem os seguintes recursos adicionais:
- Qualquer quantidade de OutJobs pode ser adicionada a um determinado projeto, disponibilizando configurações para tarefas específicas, como gerar saídas para fabricação, montagem, arquivamento, aquisição de materiais e documentação.
-
Os arquivos OutJob são, de fato, portáteis e podem ser aplicados a qualquer projeto que exija um conjunto padronizado de saídas. Por exemplo, selecione
[Project]como opção de origem do documento, em vez de um arquivo de projeto específico, para criar um Output Job genérico (e, portanto, portátil). - Os OutJobs podem incluir arquivos para verificações de validação do projeto, como verificações elétricas (ERC), de regras (DRC) e comparações entre footprints e suas origens. Dessa forma, os jobs de saída de validação são um caso “ativo” especializado, em que o projeto é verificado e a saída efetiva (como um documento PDF) representa os resultados do processo de validação.
- Os OutJobs atendem às variações de um projeto de placa montada, em que diferentes conjuntos de arquivos de saída são necessários para fabricar versões alternativas do projeto — como versões padrão ou de desempenho aprimorado do produto, que utilizam componentes adicionais ou de tipos diferentes. Consulte Variantes de projeto para obter mais informações sobre variações de projetos de placas.
Se o seu projeto não tiver nenhum arquivo Output Job associado a ele no momento, o Project Releaser detectará isso e perguntará se você deseja adicionar arquivos padrão. Se optar por fazê-lo, os seguintes arquivos serão criados:
-
Para um projeto de PCB:
-
Assembly.OutJob— com as seguintes saídas definidas:-
Documentation Outputs:
PCB 3D Print,Schematic Prints -
Assembly Outputs:
Generates pick and place files,Assembly Drawings -
Report Outputs:
Bill of Materials -
Export Outputs:
Export STEP
-
Documentation Outputs:
-
Fabrication.OutJob— com as seguintes saídas definidas:-
Documentation Outputs:
PCB Prints -
Fabrication Outputs:
Gerber Files,NC Drill FileseIPC-2581 -
Validation Outputs:
Design Rules Check,Footprint Comparison Report -
Export Outputs:
Save As/Export PCB
-
Documentation Outputs:
Esses arquivos Output Job padrão são obtidos da seguinte pasta de instalação padrão:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs. -
-
Para um projeto de chicote elétrico:
-
Assembly.OutJob— com as seguintes saídas definidas:- Documentation Outputs: Draftsman
-
Report Outputs:
Bill of Materials -
Validation Outputs:
Electrical Rules Check
Esse arquivo Output Job padrão é obtido da seguinte pasta de instalação padrão:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs\Harness. -
Detecção de variantes
Para projetos de PCB, um recurso muito poderoso do Project Releaser é a capacidade de detectar as variantes definidas para o seu projeto e criar conjuntos de dados de montagem para cada uma delas, prontos para liberação. Cada conjunto de dados de montagem aparecerá com a nomenclatura padrão do item de destino no formato:
PCBA-[ProjectName]-[VariantName]
O sufixo [VariantName] garante que a variante correta seja usada ao gerar dados a partir dos arquivos OutJob atribuídos.

Conjuntos adicionais de dados de montagem criados com base na detecção de variantes definidas para o projeto.
O processo de liberação
O processo de liberação é um fluxo dividido em etapas, com as entradas no lado esquerdo da visualização Release mostrando rapidamente em qual etapa você está.
Para saber mais sobre o processo de liberação no modo de liberação Online, consulte a página Liberação para um Workspace. Para saber mais sobre as particularidades do modo de liberação Offline, consulte a página Liberação local.
Publicação de dados liberados
Related page: Trabalhando com destinos de publicação
Para dados liberados gerados a partir de um projeto de PCB (somente dados de fabricação de PCB, dados de montagem de PCB e itens de projeto de PCB), você pode publicar esses dados diretamente do seu Workspace ou Output Job em um espaço de armazenamento, como Box.com, Amazon S3, um servidor FTP ou uma simples pasta em uma rede compartilhada. Em termos de distribuição e colaboração, isso oferece uma vantagem incomparável em um mundo em que os integrantes da “equipe de produto” como um todo — a equipe de projeto, a equipe de fabricação e todos os demais envolvidos no processo de transformar uma ideia em um produto real — costumam estar espalhados pelo mundo.
A publicação consiste em definir um Publishing Destination e, em seguida, carregar nesse destino os dados liberados da revisão do item desejada. Da fábrica na China às equipes de projeto em Kiev, Stanstead Abbotts e San Diego, passando pelo diretor do projeto em um voo em algum ponto sobre o Pacífico, todos que precisam saber da nova liberação podem ser convidados por meio de um link para a pasta publicada — acesso compartilhado (e controlado) para visualizar, discutir e utilizar os dados com os quais o item será produzido.

Publique seus dados liberados em um espaço de armazenamento e compartilhe informações entre integrantes da equipe em todo o mundo.
Compartilhamento global de dados de pacotes de fabricação
Um aspecto fundamental dos projetos armazenados em um Workspace do Altium 365 é a capacidade de criar e compartilhar um Build Package de liberação com outras pessoas. Quando compartilhado diretamente com seu fabricante, ele pode ser considerado um Manufacturing Package, pois é o pacote que o fabricante pode explorar, baixar e usar para fabricar e montar a placa.
Para permitir o compartilhamento desse pacote com outras pessoas e com seu fabricante (que normalmente está fora da sua organização), a plataforma Altium 365 oferece um Manufacturing Package Viewer dedicado — um elemento do suporte a Global Sharing da plataforma — que permite a outras pessoas visualizar um pacote de fabricação em qualquer navegador web, de qualquer lugar do mundo, mas fora do seu Workspace, para que seus projetos e outras propriedades intelectuais valiosas permaneçam protegidos contra acesso.
Cada usuário com quem o pacote for compartilhado receberá um convite por e-mail com um link para visualizar o pacote de fabricação por meio do Manufacturing Package Viewer. Os pacotes de fabricação compartilhados são apresentados na página Shared with Me da interface da plataforma Altium 365 baseada em navegador.
O próprio Manufacturing Package Viewer permite que as principais partes interessadas — especialmente o pessoal de fabricação — tenham uma visão geral resumida do projeto, com os principais dados da placa, além da possibilidade de explorar a estrutura dos dados de origem, fabricação e montagem (e baixar qualquer arquivo individual conforme necessário). O visualizador também oferece subpáginas de dados de fabricação, montagem e BOM, com a página de fabricação apresentando um visualizador Gerber e permitindo que todos os usuários com quem o pacote foi compartilhado adicionem comentários.
Por fim, o pessoal de fabricação pode baixar um pacote de produção da liberação visualizada — a partir de qualquer página do visualizador — para produzir fisicamente essa revisão da placa.
Visualizador web
Related page: Web Viewer (Workspace do Altium 365, Workspace do Enterprise Server)
A interface Web Viewer do Workspace oferece acesso universal aos documentos de projetos de PCB por meio de um navegador web padrão. Muito mais do que apenas um visualizador baseado na web, a tecnologia avançada de navegação do Web Viewer's permite que os usuários naveguem pela estrutura do projeto, interajam com os documentos de projeto, extraiam informações sobre os elementos do projeto e destaquem áreas ou objetos para adicionar comentários.
Ao visualizar documentos, a qualidade visual dos esquemáticos e das PCBs não é comprometida pelo formato web, que também oferece recursos completos de deslocamento e zoom, além da possibilidade de pesquisar, realizar sondagem cruzada, selecionar e inspecionar componentes e redes em todo o projeto.

A interface Web Viewer do Workspace oferece uma experiência imersiva e interativa para revisar, por exemplo, os documentos-fonte de esquemático e PCB do seu projeto. Aqui é mostrado um esquemático na interface Web Viewer do Altium 365 – passe o cursor sobre a imagem para ver a PCB (em 3D).
Como uma plataforma independente de visualização baseada em navegador, a interface Web Viewer oferece acesso interativo somente leitura aos documentos de projeto, sem a necessidade de abrir o projeto no ambiente de edição. Outras pessoas que estejam trabalhando no projeto, como o engenheiro responsável por ele, não serão afetadas pelas ações no espaço Web Viewer – exceto pelas notificações de comentários relacionados.
