Руководство по PDN Analyzer v2 на основе примеров

Краткий обзор

В этом руководстве описана работа с PDN Analyzer (by CST) в Altium Designer: от настройки параметров цепей для моделирования PI-DC и запуска анализа до интерпретации результатов, позволяющей последовательно улучшать целостность питания в проекте печатной платы. Также рассматриваются структура интерфейса, доступные примеры проектов, порядок определения цепей, средства управления моделированием и основные параметры панели, используемые для создания сетей питания и управления ими непосредственно на основе данных загруженного проекта. Если вам нужен практический обзор того, как встроить PDN Analyzer в процесс проектирования и где найти необходимые инструменты, эта статья поможет освоиться и подготовиться к более подробному изучению.

- Вы познакомитесь с основным рабочим процессом PDN Analyzer, включая настройку, запуск и повторное использование моделирования по мере изменения проекта печатной платы.
- Вы узнаете, как организован интерфейс PDN Analyzer: какие есть режимы компоновки, возможности закрепления панелей и представления сетей питания, а также где находятся настройки и результаты.
- Вы узнаете, какие примеры проектов и встроенные средства доступны для определения цепей постоянного тока, управления файлами моделирования и работы со структурами сетей питания.
Узнайте больше с ИИ:

Чтобы узнать о новейших возможностях анализа целостности питания постоянного тока, ознакомьтесь с Power Analyzer by Keysight от Altium.

Приложение PDN Analyzer (PDNA) довольно просто в использовании: работа с ним сводится к настройке параметров цепей для моделирования PI-DC, запуску моделирования и интерпретации результатов. Данные для моделирования цепей питания в PDN Analyzer берутся непосредственно из текущего загруженного проекта печатной платы. Проект можно последовательно дорабатывать для улучшения целостности питания в цепях подачи питания, а затем повторно запускать моделирование PDN для проверки результатов.

В этом демонстрационном руководстве по работе с PDN Analyzer используются два примера проектов, доступных от Altium:

Кроме того, в установочный комплект PDN Analyzer входит проект печатной платы SpiritLevel с несколькими примерами файлов конфигурации анализа. Чтобы открыть папку с проектом и примерами, а затем распаковать их, воспользуйтесь пунктом меню PDNA File » Explore Samples.

Это руководство предполагает, что PDN Analyzer доступен в вашей установленной копии Altium Designer и что вы обладаете базовым пониманием используемых принципов PI-DC (целостности питания постоянного тока).

Информацию о доступе к функциям PDN Analyzer, а также об основах моделирования PI-DC см. на странице PDN Analyzer.

Интерфейс PDN Analyzer

Интерфейс расширения PDN Analyzer открывается в немодальном окне Altium Designer, которое можно разместить в любом удобном месте рабочей области или на другом экране, если он доступен. Чтобы открыть главное окно PDN Analyzer, откройте документ схемы или печатной платы проекта и выберите приложение в меню Tools (Tools » PDN Analyzer).

Графический интерфейс PDN Analyzer с одной выбранной сетью питания. Настройки отображения и результатов доступны в нижней части панели.Графический интерфейс PDN Analyzer с одной выбранной сетью питания. Настройки отображения и результатов доступны в нижней части панели.

Верхняя часть окна PDNA предназначена для управления файлами и цепями и содержит интерактивное представление выбранных сетей питания, а нижняя часть панели обеспечивает доступ к параметрам анализа, настройкам отображения и результатам. PDNA версии 2 поддерживает несколько взаимосвязанных цепей, что позволяет анализировать целостность питания постоянного тока всего проекта печатной платы как в виде иерархической структуры, так и по отдельным цепям питания.

Графический интерфейс PDN Analyzer со всей выбранной иерархией цепей питания. Отображение входящих в неё сетей и слоёв настраивается в нижней части панели.Графический интерфейс PDN Analyzer со всей выбранной иерархией цепей питания. Отображение входящих в неё сетей и слоёв настраивается в нижней части панели.

Интерфейс PDN также предлагает компактный режим отображения (File » Compact Layout), в котором нижняя часть панели отсутствует. Этот режим идеально подходит для горизонтального или вертикального закрепления в главном окне Altium Designer. Чтобы разрешить закрепление панели в компактном или стандартном режиме, щёлкните правой кнопкой мыши по заголовку окна PDNA, выберите Allow Dock в контекстном меню, а затем — вариант Horizontally или Vertically.

Подробное описание пользовательского интерфейса панели PDN Analyzer приведено в раскрывающемся разделе ниже. 

Определение цепей постоянного тока

При первом открытии PDN Analyzer для проекта печатной платы выполняется попытка определить все сети питания постоянного тока по данным о цепях проекта на основе общепринятых обозначений сетей питания.  Если определены не все потенциальные цепи питания, снимите соответствующие флажки фильтра Qualifiers или выберите параметр Enable all nets for filtering, чтобы отобразить все цепи.

С помощью флажков Select выберите цепи питания, которые будут доступны анализатору PDNA, и введите соответствующие уровни напряжения в поля Nominal Voltage. Нажмите кнопку Add Selected, чтобы заполнить список Currently Identified DC Nets и подтвердить эти цепи как определенные сети питания.

Обратите внимание: двойной щелчок по записи цепи в списке диалогового окна позволяет перейти к этой цепи в топологии печатной платы.

Дополнительные цепи можно определить и включить в анализ при настройке анализа PDN, нажав кнопку DC Nets в графическом интерфейсе анализатора.

Приведенные ниже примеры анализа демонстрируют основные возможности и функции PDN Analyzer. В каждом примере показан лишь один из множества возможных вариантов настройки параметров, позволяющих по-разному оценивать целостность питания сети в зависимости от интересующих аспектов. Обратите внимание: успешно завершенный анализ можно сохранить в виде файла конфигурации PDNA (*.pdna) и загрузить в любое время — File » Save As и File » Open (по умолчанию в папке PDNAnalyzer_Config проекта).

Пример 1

Этот пример демонстрирует основы настройки моделирования целостности питания для простой цепи питания и ее токовых нагрузок. Он настроен для оценки распределения питания по шине 5 В и обратного пути тока по земле в демонстрационном проекте SpiritLevel-SL1, когда нагрузкой служит ЖК-дисплей устройства. В данном случае шина питания 5V рассматривается как простой источник напряжения, а подключенные к ней цепи (например, через переключатель S1) не учитываются.

Исходные условия для этого примера моделирования PDN:

  • проект печатной платы Spirit Level открыт в Altium Designer;
  • приложение PDN Analyzer активно (Tools » PDN Analyzer);
  • цепи постоянного тока проекта печатной платы определены в диалоговом окне PDN Analyzer DC Net Identification, как описано выше.

Начните анализ с указания цепей питания и земли. Дважды щелкните элементы <Power Net> и <Ground Net> на схеме сети в графическом интерфейсе, чтобы открыть диалоговое окно Choose Net, в котором можно выбрать определенные ранее цепи питания.

При необходимости используйте параметры отбора и фильтрации в диалоговом окне, чтобы сократить или расширить список цепей, либо вернитесь на главный экран и нажмите кнопку , чтобы повторно определить цепи питания постоянного тока.

Теперь между указанными цепями питания и земли можно добавить источник или нагрузку. Обратите внимание: индикаторы состояния земли и питания теперь отмечены галочками (✔). Щелкните правой кнопкой мыши в рабочей области схемы сети и выберите Add Source (или Add Load) в контекстном меню, чтобы открыть диалоговое окно Device Properties. Выполните следующие действия, указанные в этом окне:

  1. Чтобы добавить в сеть источник питания, в данном случае простой источник напряжения, выберите пункт Voltage Source в раскрывающемся списке Device Type.
  2. В списке подключений источника PDNA попытается выбрать подходящие варианты подключения цепей на основе параметров сети питания — в данном случае между цепями 5V и GND. Используйте раскрывающиеся списки Refdes, чтобы указать точки подключения источника напряжения к компонентам. В этом примере точкой подключения напряжения источника выбрана TP1, а точкой обратного пути тока по земле — входной разъем питания постоянного тока J1 (выводы 2 и 3).
  3. В нижней части диалогового окна параметры источника задают характеристики модели источника напряжения для моделирования. Здесь напряжение источника (Vout) задано равным 5V, а внутреннее сопротивление модели (Rout) оставлено на уровне по умолчанию 0Ω.
  4. Наконец, максимальный ток источника и ток вывода (для источников с несколькими выходными выводами) оставлены равными значениям по умолчанию (0A: Don't Care). Если для Limits заданы конкретные значения тока, анализ PDN отметит нарушение при превышении этих значений в результатах моделирования.

Аналогично добавлению источника в сеть добавьте нагрузку и задайте ее параметры в диалоговом окне Device Properties.

В данном случае добавляется нагрузка в виде потребителя тока (Device Type: IC (Current)), представляющая ток, потребляемый ЖК-дисплеем устройства от шины 5 В. Обратите внимание: также доступна чисто резистивная нагрузка — для этого выберите  Resistor в качестве Device Type.

Задайте подключение нагрузки как LCD1 и укажите Load Current, который она будет потреблять от источника питания 5 В. Обратите внимание: поддерживаются приставки единиц измерения (например, 500m для обозначения 0.5A). Хотя параметры напряжения Limits необязательны, здесь для них задано  +/-10% (с помощью соответствующей кнопки). Это приведет к регистрации нарушения при моделировании, если напряжение непосредственно на нагрузке опустится ниже 4,5 В (или превысит 5,5 В).

После определения сети питания и задания всех параметров (все элементы сети имеют статус ✔) анализ PDN можно запустить нажатием кнопки . Ход моделирования отображается на вкладке Messages в виде потока событий, в котором также будет указана причина сбоя, если процесс не удастся завершить.

При запуске анализа текущая конфигурация моделирования — указанные цепи, источники, нагрузки и т. д., а также связанные с ними параметры — сохраняется вместе с данными результатов анализа (File » Explore; см. папку PDNAnalyzer_Ouput). Эту конфигурацию можно в любое время восстановить для текущего моделирования: щелкните правой кнопкой мыши имя моделирования и выберите Revert в контекстном меню.

Непосредственные результаты анализа PDN отображаются на схеме сети: на ней показаны рассчитанные значения напряжения и тока нагрузки и источника (где применимо), а также выделены участки сети, на которых обнаружены нарушения заданных параметров. Обратите внимание: вкладка Visual теперь выбрана и активна.

Наведите указатель на любой элемент сети (нагрузку, источник или последовательный элемент), чтобы просмотреть дополнительную информацию, например заданные параметры и результаты анализа.

Визуализация в редакторе печатных плат

Теперь результаты моделирования можно просмотреть графически в редакторе печатных плат Altium Designer, управляя отображением с помощью настроек на вкладке Visual PDNA.  Настройте отображение Voltage для обоих Layers (Top и Bottom) объекта 5V Net — это исходные настройки отображения по умолчанию. Результаты анализа отображаются в редакторе печатных плат вместо существующего графического наложения платы.

Падение напряжения вдоль выбранного пути цепи, в данном случае от источника 5 В в точке TP1 до компонента LCD1, отображается цветовым градиентом, соответствующим шкале напряжения в нижней части представления. Напряжение отображается в процентах (параметр Per Rail в разделе Color Scale) или в виде диапазона абсолютных значений (параметр Displayed).

На изображении ниже изменение цвета вдоль пути цепи на плате отражает общее падение напряжения: минимальный уровень (0%:, синий цвет), обусловленный падением напряжения на сопротивлении проводников, наблюдается у компонента LCD1, а максимальный (100%, красный цвет) — в указанной точке источника напряжения (TP1).

Чтобы отобразить соответствующий анализ тока в сети, выберите параметр Current Density на вкладке Visual. Здесь цвета вдоль пути цепи на плате отражают относительное изменение плотности тока: 100% (красный цвет) соответствует максимальной расчетной плотности тока вдоль проложенного пути цепи, а 0% (синий цвет) — минимальной, скорее всего 0A/mm2.

Обратите внимание: хотя альтернативная шкала напряжения/тока (Displayed) более наглядна при отображении отдельных сетей, она дает мало полезной информации при одновременном отображении нескольких сетей питания — например, 5V and GND в этом примере или нескольких проанализированных сетей питания проекта.

Чтобы отобразить и проанализировать результаты анализа целостности питания для обратного пути тока GND в этом примере, снимите флажок сети 5V в списке Net на вкладке Visual панели PDNA, а затем выберите сеть GND. Обратный путь тока по земле проходит как по верхнему, так и по нижнему слою платы. Эти слои можно отображать по отдельности в редакторе плат, выбирая соответствующие пункты в списке Layer панели PDNA.

На изображении ниже показано распределение напряжения для нижнего слоя цепи GND, при этом для шкалы Color Scale задано значение Displayed. Наибольшее падение напряжения (красный цвет: примерно 0,5 мВ) наблюдается на выводе GND ЖК-дисплея, а наименьшее (синий цвет: примерно 0 В) — в точке возврата тока к источнику напряжения (J1).

При переключении на режим Current Density панели PDNA области с максимальным током выделяются красным. Само максимальное значение плотности тока (1.74 A/mm2) очень мало и находится в допустимых пределах с большим запасом.

Управление отображением и параметры

PDN Analyzer предлагает несколько интерактивных параметров отображения, определяющих графическое представление результатов анализа в редакторе плат Altium Designer. Помимо параметров Color Scale, можно переключаться между режимами отображения 2D и 3D. Последний позволяет наглядно оценить результаты анализа в переходных отверстиях и между слоями.

Также предусмотрена возможность Clear результатов анализа в окне редактора, при этом автоматически восстанавливается стандартное отображение топологии платы. В отличие от нее, параметр Overlay включает отображение топологии платы вместе с текущими результатами анализа. Этот параметр особенно полезен, когда нужно определить, где именно на плате находится интересующая точка результатов анализа.

Работа с нагрузками

При необходимости в сеть можно добавлять другие нагрузки и повторно запускать анализ питания для оценки результатов. Например, чтобы добавить небольшой ток нагрузки (скажем, 15mA), потребляемый светодиодным индикатором питания, выберите его последовательный резистор (R15) в качестве точки подключения к шине 5V, а вывод светодиода — в качестве точки подключения к GND.

PDN Analyzer также позволяет задавать выводы компонента, к которым подключена нагрузка. Благодаря этому для одного компонента, потребляющего разные токи через разные выводы, можно создать несколько моделей нагрузки.

Такой случай представлен ЖК-дисплеем в примере проекта: подключение 5V к выводу 15 (LED+) питает подсветку дисплея, а подключение 5V к выводу 2 (VDD) — внутреннюю логику. На практике через вывод 15 протекает значительно больший ток, чем через вывод 2.

Когда LCD1 был добавлен ранее в виде единой модели нагрузки PDNA, оба его вывода по умолчанию были назначены точками подключения нагрузки к 5V, и при анализе PDN ток нагрузки LCD1 распределялся поровну между этими выводами. Чтобы повысить точность анализа питания, компонент LCD1 можно представить в виде two моделей нагрузки: по одной для каждого вывода 5V с соответствующим током нагрузки. Для этого измените параметры выводов существующей модели нагрузки LCD1, а затем добавьте еще одну нагрузку для выделенного вывода.

Откройте существующую модель нагрузки LCD1, дважды щелкнув ее значок на графической схеме сети, чтобы вызвать диалоговое окно Device Properties. Затем дважды щелкните поле Pins(s) в строке сети питания 5V. В открывшемся режиме редактирования выводов можно выбрать отдельные выводы компонента для этой нагрузки. Снимите выбор вывода 2, чтобы оставить в составе нагрузки только вывод 15 (LED+), и задайте для параметра Load Current, например, значение 75mA, соответствующее току подсветки ЖК-дисплея.

Затем создайте еще одну нагрузку сети 5V для LCD1 и выберите вывод 2 (отключив вывод 15), чтобы представить нагрузку VDD. Для нее можно задать подходящее меньшее значение Load Current — например, 20mA.

После этого можно повторно выполнить анализ сети питания 5V, чтобы получить более точную картину распределения нагрузки LCD1 по путям сети.

Разницу в распределении тока нагрузки можно увидеть, сравнив плотность тока в дорожках сети питания LCD1 для исходного и обновленного вариантов нагрузки. На изображениях результатов анализа плотности тока ниже слева показан результат для исходной модели LCD1 с одной нагрузкой, а справа — для обновленной модели с несколькими нагрузками.

Обратите внимание на плотность тока в дорожках, питающих выводы 2 (контактная площадка ЖК-дисплея слева) и 15. Обновленный вариант правильно показывает, что основная часть тока ЖК-дисплея протекает к выводу 15 (контактная площадка ЖК-дисплея справа), а не распределяется поровну между двумя выводами, как было ранее (изображение слева).

 

Настройки моделирования

Результаты анализа, в частности величина падения напряжения из-за омического сопротивления проводящих областей платы, также зависят от заданной электропроводности меди платы и толщины стенок переходных отверстий. Для просмотра и изменения этих настроек выберите вкладку Simulation в диалоговом окне Settings. Чтобы открыть это окно, щелкните правой кнопкой мыши имя текущего анализа и выберите Settings в контекстном меню.

Электропроводность металла

В разделе Metal Conductivity диалогового окна приведены сведения и настройки электропроводности (величины, обратной удельному сопротивлению; 1/R) металла, используемого в проекте. В этом окне можно выбрать или изменить базовую электропроводность (или удельное сопротивление), температурный коэффициент и/или температуру в соответствии с конструктивными особенностями платы:

  • Pure Copper — обычно считается, что электропроводность меди составляет 5.88e7S/m при 25°C, а температурный коэффициент электропроводности равен 0.4%/°C. Этот положительный температурный коэффициент означает, например, что увеличение значения Temp. Compensation в диалоговом окне с 25°C до 125°C (разница 100°C) уменьшит электропроводность, используемую при моделировании, на 40%, до 3.53e7S/m.
  • PCB Copper — этот вариант используется по умолчанию при моделировании и соответствует значениям электропроводности, которые приводятся в отраслевой литературе как характерные для меди, электрохимически осажденной (ED) на печатных платах. Ее измеренная электропроводность составляет 4.7e7S/m при 25°C, а температурный коэффициент — 0.4%/°C.
  • Custom — выберите этот вариант, чтобы ввести конкретные значения электропроводности или удельного сопротивления для моделирования.

Обратите внимание: отображаемое значение Sim Conductivity представляет собой итоговую электропроводность с учетом всех параметров, а значение Sim Resistivity является обратной ей величиной.

Переходные отверстия

Задайте значение Via Wall Thickness в диалоговом окне, чтобы указать весовую толщину металла стенок всех переходных отверстий при моделировании проекта.

Эта настройка может заметно влиять на потери постоянного тока в сети питания из-за собственного сопротивления переходных отверстий с тонкими стенками металлизации. Однако при достаточных размерах и толщине металлизации переходное отверстие не ухудшает характеристики цепей постоянного тока: плотность тока в нем будет такой же, как в соединяемых им дорожках питания, а существенного падения напряжения между точками его подключения не возникнет. Пример анализа потерь постоянного тока в переходных отверстиях приведен в разделе ниже.

С точки зрения моделирования размер переходного отверстия и толщина его стенки фактически определяют количество проводящего материала в переходном отверстии и, следовательно, его сопротивление и проводимость. При моделировании предполагается, что диаметр переходного отверстия соответствует размеру готового отверстия, а толщина стенки увеличивает его наружный диаметр. Таким образом: Finished Hole Diameter + (2 x Wall_Thickness) = Drill Diameter.

Пример 2

В этом примере показано, как создать набор связанных сетей, которые можно анализировать как единое целое с учетом параметров соединяющих их последовательных элементов. Также рассматривается добавление источников на основе моделей стабилизаторов напряжения (VRM), которые тоже служат связями между сетями, и построение полной иерархии сети питания проекта.

В примере моделируется сеть от PWR_IN до 5V демонстрационного проекта SpiritLevel-SL1. Для создания полной структуры сети питания в нее включены модели стабилизаторов напряжения 3,3 В (VCCO) и 1,8 В (VCCINT).

Исходные условия для этого примера моделирования сети распределения питания (PDN):

  • проект печатной платы Spirit Level открыт в Altium Designer;
  • приложение PDN Analyzer активно (Tools » PDN Analyzer);
  • цепи постоянного тока проекта печатной платы определены в диалоговом окне PDN Analyzer DC Net Identification, как описано выше.

Начните построение сети питания для этого примера с указания входной цепи питания (PWR_IN) в новом моделировании (при необходимости выберите File » New Simulation). Согласно принципиальной схеме проекта, параметр PDN <Power Net> имеет значение PWR_IN, <Ground Net> — GND, а Source — J1.

Расширение сетей через последовательные элементы

Чтобы смоделировать полный путь питания от сети PWR_IN до сети 5V, необходимо добавить последовательно включенные предохранитель (F1) и переключатель (S1), а также соединяющую их цепь. В интерфейсе PDNA они добавляются путем последовательного расширения сети питания. Каждое такое расширение подключается через универсальную модель последовательного элемента.

Чтобы расширить сеть, сначала щелкните правой кнопкой мыши в сети, к которой требуется добавить участок, и выберите в контекстном меню пункт Extend Network. В диалоговом окне Choose Net выберите сеть, соединенную с PWR_IN через последовательный элемент. В данном случае это NetD1_2 — сеть, соединяющая F1 и вывод 3 компонента S1 и обозначенная по выводу 2 диода D1.

Поскольку эта сеть, скорее всего, не была зарегистрирована на начальном этапе идентификации цепей постоянного тока, снимите флажок List DC nets only в диалоговом окне Choose Net, чтобы она стала доступна для выбора.

При расширении сети между двумя цепями автоматически добавляется последовательный элемент. Дважды щелкните по нему, чтобы задать его подключения и параметры в диалоговом окне Device Properties. Модель последовательного элемента состоит из источника напряжения, последовательно соединенного с резистором, что позволяет выполнять базовое моделирование таких компонентов, как резисторы, катушки индуктивности, диоды, переключатели и т. д.

В данном случае последовательным элементом является предохранитель F1, который выбирается в параметрах подключения RefDes и которому задается номинальное внутреннее Resistance, равное 0.1Ω. Если бы последовательным элементом был полупроводниковый прибор, например диод, наряду со значением внутреннего Resistance потребовалось бы задать параметр Voltage Drop.

Далее, следуя принципиальной схеме, необходимо расширить цепь D1_2 до цепи питания 5V через переключатель S1. Как и ранее, выберите Extend Net в контекстном меню, вызываемом правой кнопкой мыши, и укажите цепь для расширения в диалоговом окне Choose Net.

В данном случае добавленный последовательный элемент — S1, который соединяет цепь D1_2 с выходной сетью 5V через выводы 3 и 2 (см. принципиальную схему). Поскольку неиспользуемый вход переключателя S1 (вывод 1) подключен к его выходу (выводу 2) и не проводит ток нагрузки, вывод 1 можно, в качестве примера, исключить из анализа сети с помощью параметров выбора выводов в диалоговом окне Device Properties. Для этого дважды щелкните поле Pin(s) в строке клеммы OUT.

Теперь к участку 5 В связанных сетей питания можно добавить нагрузку — в данном случае модуль дисплея LCD1.

После повторного запуска анализа и данные, и графическое представление в редакторе печатных плат будут включать все три связанные сети питания и показывать рассчитанные токи и падения напряжения на соединяющих их последовательных элементах.

Добавление моделей стабилизаторов напряжения

PDN Analyzer предлагает активные модели стабилизаторов напряжения (VRM), которые можно включать между сетями входного и выходного напряжения. При добавлении в сети питания PDNA они представляют собой одновременно нагрузку для сети входного напряжения и источник для сети выходного напряжения. Доступны модели линейных и импульсных стабилизаторов, а также импульсных стабилизаторов с дистанционной обратной связью по напряжению.

В демонстрационном проекте SpiritLevel-SL1 используются линейные стабилизаторы напряжения для формирования шин питания 3,3 В (VCCO) и 1,8 В (VCCINT). При добавлении стабилизатора VCCO (U3) в моделируемую сеть PDNA он представляется как нагрузка для входной сети 5 В и как источник для сети 3,3 В. 

Чтобы включить линейный стабилизатор U3 в качестве нагрузки сети 5 В, созданной по описанной выше процедуре, добавьте нагрузку к сети 5 В и выберите вариант VRM (Linear) для параметра Device Type в диалоговом окне Device Properties. Задайте подключения модели в соответствии с принципиальной схемой и укажите вывод Ref в качестве подключения GND компонента R14. В зависимости от топологии сети GND эта опорная точка может находиться в другом, более подходящем месте на соседнем участке печатной платы.

Чтобы завершить настройку VRM, задайте параметр выходного напряжения (Vout: 3.3V), а при необходимости — выходное (внутреннее) сопротивление, ток покоя и любые Limits, которые требуется выявлять при анализе.

В PDNA предусмотрена возможность автоматически добавлять модель выходной стороны VRM в качестве источника в целевую цепь выходного напряжения и при необходимости создавать эту сеть.

В данном примере щелкните правой кнопкой мыши только что созданную модель нагрузки VRM (Load2: U3) и выберите пункт Add VRM To New Network. При этом автоматически создается сеть VCCO с моделью выходной стороны VRM (Source 1: U3) в качестве источника напряжения 3,3 В.

Обратите внимание: два представления VRM на 3,3 В — входная модель в качестве нагрузки цепи 5 В и выходная модель в качестве источника для цепи 3,3 В — взаимосвязаны и фактически являются одной моделью. Поэтому открыть и отредактировать VRM в интерфейсе PDNA можно из любой из этих сетей.

Теперь можно выбрать новую сеть VCCO и добавить подходящую нагрузку. В этом примере ток нагрузки составляет 0,2 А и потребляется через несколько выводов компонента U1.

Полученная структура питания теперь включает две сети (PWR_IN и VCCO), соединенные линейным VRM на 3,3 В. При выборе верхнего уровня иерархии сетей в структуре текущего файла PDNA графическое представление сети показывает взаимосвязи цепей питания в виде блок-схемы.

В этом примере VRM был добавлен в сеть 5 В (входное напряжение) в качестве нагрузки, а затем использован для автоматического создания выходной сети напряжения 3,3 В (VCCO), в которой VRM выступает источником. Возможен и обратный порядок действий, который в некоторых случаях может оказаться удобнее. В этом случае VRM добавляется в сеть выходного напряжения в качестве источника, а затем эта модель добавляется во «входную» сеть напряжения в качестве нагрузки (Add VRM To New Network или Add VRM To Existing Network).

Анализ PDN позволяет получить результаты для составной сети, включая VRM. При выборе верхнего уровня иерархии сетей в интерфейсе PDNA редактор печатных плат отображает все сети. Выберите отдельную сеть в списке, чтобы ограничить графическое отображение этой сетью, и переключайте параметры Net и Layer на нижней панели для дополнительной настройки вида.

Обратите внимание: теперь путь сети GND в этом примере будет включать обратные токи обеих сетей — PWR_IN и VCCO.

Создание сети распределения питания в демонстрационном проекте можно завершить, добавив оставшийся VRM (U4) и его выходную сеть питания 1,8 В (VCCINT).

Добавьте линейный VRM в сеть 5 В, как описано выше, и задайте для его параметра Vout значение 1.8V.

Добавьте VRM (здесь — Load 3) в новую сеть, чтобы создать сеть питания 1,8 В (VCCINT).

Добавьте соответствующую нагрузку в сеть VCCINT — в данном случае это выводы питания 1,8 В компонента U1.

Теперь в иерархии сетей интерфейса PDNA будут отображаться все три взаимосвязанные сети.

Анализ PDN позволит получить результаты для составной сети, включая VRM.

Еще раз обратите внимание: теперь сеть GND включает обратные токи всех трех сетей, использующих общие области меди слоя GND. Ее максимальная плотность тока (65.8 A/mm2) теперь высока и, вероятно, превышает допустимые пределы.

Поиск проблем целостности питания

PDN Analyzer предоставляет широкий набор графических представлений и данных, которые можно использовать для оценки целостности питания анализируемого проекта печатной платы, а также для поиска и устранения связанных с ней проблем.

В приведенном выше примере анализ пути сети GND Top Layer указывает на наличие недопустимо высокой плотности тока, о чем свидетельствует максимальное значение шкалы 65.8A/mm2. Расположение проблемного участка не сразу очевидно, но его можно выявить с помощью функции Highlight Peak Values в PDNA.

При выборе этой функции и установке для параметра Filter значения Maxima область пиковой плотности тока будет выделена и отмечена на графическом представлении результатов анализа в редакторе печатных плат.

Нажмите кнопку , чтобы повторить графическое выделение, или используйте соответствующие кнопки () для последовательного перехода по наибольшим пиковым значениям и их расположениям. Настройте параметры Scope, чтобы выделять пики в текущей видимой области платы (In View)) или на всей плате (Design) — во втором случае при переходе к каждому участку будут автоматически изменяться положение и масштаб вида.

Дополнительную информацию о проблемном участке можно получить, включив функцию Show Arrows в PDNA. Она накладывает на изображение стрелки, которые указывают направление тока своим углом, а его относительную величину в данной точке — своим размером. В этом примере функция подтверждает, что область высокой плотности тока представляет собой путь обратного тока от U1 (вверху) к области GND у нижнего края платы.

Один из способов решения этой проблемы — увеличить ширину дорожки на проблемном участке.

Редактировать плату можно при работающем PDN Analyzer, что позволяет последовательно улучшать топологию и повторять анализ. Нажмите кнопку Clear в области Views, чтобы отключить отображение результатов PDNA в редакторе печатных плат и внести необходимые изменения в плату.

Затем можно повторить анализ PDN (нажмите ), чтобы проверить результаты оценки целостности питания. На двух изображениях ниже показано изменение плотности тока в сети GND (на Top Layer) после увеличения ширины дорожки в критической точке: на верхнем изображении представлен исходный результат, а на нижнем — графическое отображение плотности тока после изменения платы.

При сравнении результатов до изменения (верхнее изображение) и после него (нижнее изображение) следует отметить:

  • Максимальная плотность тока в слое GND снизилась до допустимого уровня, примерно в десять раз относительно предыдущего значения — с 65.8A/mm2  до 7.1A/mm2.
  • Участки максимального тока, значения которого теперь значительно ниже, более равномерно распределены по путям обратного тока GND, а не сосредоточены в одной проблемной точке.
  • Для более наглядного графического сравнения вручную установите прежнее значение шкалы плотности тока: выберите параметр шкалы Manual, введите 65.8 в поле Max и нажмите кнопку , чтобы обновить отображение.

Нарушения ограничений плотности тока

Более объективный способ поиска и устранения проблем целостности питания в токовых путях печатной платы — задать конкретные ограничения плотности тока, превышение которых будет регистрироваться как нарушение. Информацию о других типах нарушений см. ниже.

Ограничения плотности тока для наружных и внутренних слоев, а также переходных отверстий задаются на вкладке Limits диалогового окна Settings. Чтобы открыть его, щелкните правой кнопкой мыши имя текущего моделирования PDN и выберите Settings в контекстном меню. Заданные ограничения будут применяться ко всем наружным и внутренним слоям и переходным отверстиям в проекте платы.

Заданные ограничения плотности тока применяются к результатам текущего анализа. Их можно изменять и повторно проверять без повторного запуска моделирования — проверка ограничений выполняется после анализа. Все сети, содержащие нарушения, выделяются красным пунктирным контуром.

В приведенном здесь примере сеть питания VCCO содержит нарушения ограничений плотности тока. При выборе самой сети VCCO путь питания VCCO выделяется контуром, указывающим на нарушение.

Наведите курсор на сеть с нарушениями, чтобы открыть всплывающий список ее текущих нарушений и связанных с ними сведений. Единственная запись в этом примере указывает, что плотность тока в переходном отверстии (около 34.5A/mm2) превышает заданное ограничение (30A/mm2).

Дважды щелкните запись о нарушении, чтобы перейти к его расположению на плате с соответствующим панорамированием и масштабированием. На изображении ниже для графического представления PDNA выбран режим 3D, в котором проблемное переходное отверстие и его соединения на верхнем и нижнем слоях показаны более отчетливо.

Обратите внимание: для демонстрации отдельного нарушения размер переходного отверстия в проекте платы Spirit Level был уменьшен.

Данные об этом переходном отверстии, включая указание на нарушение ограничения плотности тока, доступны на вкладке Via интерфейса PDNA.

Список сведений о переходных отверстиях охватывает все сети текущего проекта. Используйте заголовки столбцов Net и Current Density, чтобы упорядочить список и отобразить переходные отверстия сети VCCO по плотности тока. Все значения плотности тока, превышающие заданное ограничение, будут выделены красным цветом.

Дважды щелкните любую запись в списке переходных отверстий, чтобы перейти к ее расположению на графическом представлении платы в PDNA.

Другие нарушения

Помимо выявления превышений заданных пределов плотности тока, PDN Analyzer также обнаруживает нарушения заданных рабочих характеристик сети, например выход за предельные значения, указанные в конфигурации моделирования при добавлении нагрузки, источника или последовательного элемента.

К таким предельным параметрам моделирования относятся:

  • Допустимый диапазон напряжения на нагрузке.
  • Максимальный выходной ток источника.
  • Допустимая рассеиваемая мощность источника на базе линейного стабилизатора и его максимальный выходной ток.
  • Максимальный выходной ток источника на базе импульсного стабилизатора.
  • Максимальный ток через последовательный элемент.
В отличие от параметров моделирования элементов сети (например, напряжения источника или тока нагрузки), которые обрабатываются во время анализа, проверка соблюдения предельных параметров (например, заданного минимального напряжения на нагрузке) выполняется после анализа. Это означает, что изменение предельного значения учитывается немедленно, без необходимости повторного запуска моделирования.

Если для параметра задано предельное значение (ненулевое), при его нарушении соответствующий элемент сети выделяется на графической схеме в интерфейсе PDNA. Наведите курсор на элемент, чтобы просмотреть его параметры и результаты анализа.

В приведенном ниже примере расчетная рассеиваемая мощность Source 1 (стабилизатор напряжения U1) превысила заданное максимальное значение рассеиваемой мощности 2W.

Более подробные сведения о рабочих характеристиках сети питания доступны на ее вкладке, где результаты анализа представлены в виде таблицы, включая расчетные значения потребляемой мощности сети.

Пример 3

В этом примере демонстрируется применение моделей импульсных источников питания (SMPS), или модулей стабилизации напряжения (VRM), в PDN Analyzer для моделирования сети питания, а также показано, как уточненная модель сети позволяет получить более точные результаты анализа питания. Кроме того, в примере кратко рассматривается использование функций измерительного зонда напряжения и контуров PDNA для отображения данных о напряжении в определенных точках или областях топологии платы.

Пример основан на эталонном проекте Altium DB46 Xilinx Daughter Board и посвящен части схемы SMPS (U5), используемой для сети питания 1,2 В (1V2).

Как и ранее, для выполнения этого примера моделирования PDN необходимо соблюсти следующие предварительные условия:

  • Проект DB46 Xilinx Daughter Board открыт в Altium Designer.
  • Приложение PDN Analyzer активно (Tools » PDN Analyzer).
  • Цепи постоянного тока проекта печатной платы определены в диалоговом окне PDN Analyzer DC Net Identification, как описано выше. Обратите внимание: для этого примера также требуются сети LX и AGND.

Начните построение сети питания для примера с указания входной цепи питания в новом моделировании (при необходимости выберите File » New Simulation). Как показано на приведенной выше принципиальной схеме, для PDN <Power Net> — это 5V, а <Ground Net> — это GND. В качестве Source для сети 5 В используется штыревой разъем HDR_T1 или HDR_B1.

Импульсный VRM

Модель схемы SMPS добавляется в сеть питания 5 В путем выбора VRM(SMPS) в качестве Device Type нагрузки в диалоговом окне Device Properties. Как показано на схеме модели в диалоговом окне, группы выводов IN и OUT задаются отдельно.

Чтобы правильно настроить эту модель для схемы, укажите LX в качестве выхода, U5 для параметров RefDes и 1.2V в качестве параметра Vout, как показано на приведенной выше принципиальной схеме. При необходимости задайте Rout и параметры КПД/тока в соответствии с используемым устройством SMPS.

Завершите настройку модели SMPS, добавив VRM в его выходную сеть (Add VRM To New Network), которая будет автоматически выбрана в качестве сети LX. Затем сеть LX можно расширить, включив в нее сеть питания 1,2 В в соответствии с принципиальной схемой.

Сети LX и 1V2 соединены последовательным элементом L1 (дросселем понижающего преобразователя SMPS), для которого следует задать соответствующее последовательное сопротивление. Для целей этого примера задано несколько завышенное значение 0.2Ω.

Наконец, добавьте U4 в качестве нагрузки 0.3A в сеть 1V2 и задайте допустимое отклонение напряжения на нагрузке +/-5%. Обратите внимание: для этого примера параметры ограничения плотности тока на вкладке Limits диалогового окна Settings должны быть установлены в 0 (состояние по умолчанию — без ограничений).

Запустите анализ и обратите внимание, что для нагрузки в составной сети LX отображается нарушение: напряжение сети 1V2 на нагрузке (U4) недопустимо низкое (около 1.14V).

Измерительный зонд

Помимо визуальной оценки графического представления PDNA и шкалы в редакторе печатных плат, PDN Analyzer предлагает ряд инструментов для интерпретации результатов анализа в определенных областях или точках топологии, например активный Probe.

Инструмент зонда позволяет фиксировать и сравнивать значения напряжения или плотности тока в выбранных точках топологии. Благодаря своей универсальности он позволяет точно оценивать результаты анализа для любой сети или слоя. В данном примере его можно использовать для подтверждения причины недопустимого падения напряжения на нагрузке сети 1V2, которое явно обусловлено сопротивлением последовательного элемента L1.

Чтобы измерить разность напряжений в сети 1V2 с помощью зонда, сначала настройте PDNA на отображение только Layer MidLayer 1 (основного пути питания 1,2 В к U4) и Net 1V2. Нажмите кнопку , чтобы открыть диалоговое окно Probe, и включите первую точку измерения (). С помощью перекрестия курсора укажите точку с наибольшим напряжением (источник сети 1V2 на этом слое), затем включите параметр  Difference зонда и укажите вторую точку () — точку с наименьшим напряжением на нагрузке U4.

Обратите внимание: показание Difference зонда указывает на падение напряжения вдоль пути сети всего около 3mV. Аналогично проверьте путь сети LX (при активных Top и Bottom Layer): падение напряжения составит всего около 0.5mV.

Измерение разности напряжений зондом between двумя сетями (при включенных Net LX и 1V2, Top и Bottom Layer) показывает падение 60mV на дросселе L1. Именно эта основная потеря напряжения вызывает данное нарушение, выявленное при анализе.

Хотя описанное исследование с помощью зонда напряжения позволило установить основную причину потерь IR в сети питания, ее можно было определить более прямым способом — просмотрев данные о напряжении на выводах устройства на вкладке Pins в PDNA. Зонд лучше всего подходит для более подробных исследований, в которых можно в полной мере использовать точность выбора точки измерения.

VRM SMPS с обратной связью по напряжению

В схеме импульсного источника питания, используемой в этом примере, обычно применяют дроссель (L1) с гораздо меньшим сопротивлением. Однако приведенные результаты анализа показывают, что базовая модель импульсного источника питания (SMPS) не учитывает потери на L1 — впрочем, в реальной схеме это, как правило, не представляет проблемы.

В схеме SMPS из примера проекта напряжение обратной связи, измеряемое U5 (на выводе 8), формируется резистивной цепочкой R25–R26, включенной между выходной цепью 1V2 и цепью аналоговой земли AGND. Последняя соединена с цепью GND через соединительный резистор 0Ω R118.

Обратите внимание: для целей этого примера исходный демонстрационный проект DB46 Xilinx Daughter Board был изменен — вместо прямого соединения медью между цепями GND и AGND добавлена резистивная перемычка (R118).

Чтобы точнее смоделировать работу схемы в области U5, вместо стандартной модели SMPS можно использовать модель импульсного источника питания с дистанционным измерением напряжения, доступную в PDNA. Эта модель имеет отдельные измерительные выводы (S+ и S-), которые можно «подключить» к любым выводам в указанных выходных цепях, например к выводам резистивной цепочки измерения напряжения в этой схеме.

Первый шаг при создании более полной модели цепей для схемы SMPS U5 — добавление цепи AGND к существующей цепи GND. Воспользуйтесь параметром Extend Network и выберите цепь AGND.

Цепь AGND соединена с цепью GND через резистор R118, как показано на приведенной выше принципиальной схеме. Для его параметра Resistance следует задать значение 0Ω.

Чтобы обновить модель SMPS в цепи LX, удалите существующий источник U5 (Source 1), а затем добавьте вместо него альтернативную модель SMPS Sense. Задайте подключения выводов IN и OUT модели так же, как прежде. Измерительные выводы (S+/S−) подключите к концам резистивной цепочки обратной связи, как показано на принципиальной схеме.

Перенесите замененную модель SMPS из цепи LX в питающую цепь 5V, чтобы модели цепей соответствовали друг другу: удалите в ней нагрузку U5, а затем примените параметр источника Add VRM To Existing Network » 5V в цепи LX.

Затем можно повторно выполнить анализ обновленной схемы и оценить результаты.  Как показано на изображении ниже, теперь напряжение на нагрузке уверенно соответствует требованию +/-5%, и нарушение не фиксируется. Измеряя выходное напряжение в цепи 1V2, SMPS компенсирует падение напряжения на последовательном элементе L1, поэтому напряжение в цепи LX становится выше на 60mV.

Хотя использование расширенной модели SMPS-sense для этой схемы дает более точные результаты анализа, на практике измерительные выводы источников SMPS с дистанционным измерением напряжения могут подключаться дорожками печатной платы непосредственно к нагрузке, а не к расположенной рядом цепи обратной связи. В этом случае обе измерительные линии (S+ и S-)) прокладываются отдельными дорожками к соответствующим выводам нагрузки или к точкам рядом с ними.

Контуры напряжения

Выбор оптимального места подключения линий дистанционного измерения напряжения SMPS, описанный выше, — один из множества вариантов применения функции Voltage Contour в PDN Analyzer, которая графически отображает ключевые границы изменения напряжения на печатной плате.

Эта функция позволяет накладывать пунктирные контуры равного напряжения на отображаемые слои в редакторе печатных плат. Можно задать несколько контуров и отображать их уровни либо в процентах от падения напряжения в цепи, либо в виде абсолютных значений напряжения — см. параметры Indicate.

Помимо набора контуров с заданными процентными уровнями, можно добавить еще один контур с помощью параметра Slider, который позволяет плавно регулировать его уровень.

Например, при выборе подходящей точки измерения напряжения на положительном выводе нагрузки для SMPS желательно подключить измерительную линию в области, где отклонение напряжения от напряжения на нагрузке составляет менее, скажем, 20% от общего падения напряжения. В приведенном выше примере SMPS-sense измерительная дорожка от U5 (S+) подключается к медной области питания цепи 1V2 в любой удобной точке между выводами нагрузки U4 (слева) и контуром напряжения 20%.

Аналогично, чтобы определить подходящие точки подключения отрицательной измерительной линии (S-) источника SMPS (U5), можно задать контур напряжения, например 80%, для пути возвратного тока нагрузки (U4) на слое GND. В этом случае, поскольку речь идет о возвратном токе нагрузки по отрицательной цепи, подходящая точка подключения отрицательной измерительной линии к медной области земли должна находиться внутри контура 80%.

Отчет об анализе

Для сохранения результатов анализа целостности питания с целью дальнейшего изучения или передачи заинтересованным сторонам в PDN Analyzer предусмотрена функция Report для формирования отчета с данными и документацией. Функция формирования отчета создает подробный HTML-документ, содержащий графические материалы и данные как по текущим результатам анализа, так и по самому проекту печатной платы.

Нажмите кнопку , чтобы настроить параметры отчета в диалоговом окне HTML Report. Установите флажки Results, определяющие степень детализации отчета, и просмотрите сохраненные изображения, которые будут включены в папку отчета (). Для сохранения изображений с результатами анализа используйте кнопку в основном интерфейсе.

Нажмите кнопку , чтобы сформировать интерактивный HTML-отчет и открыть папку с ним. В ней будут находиться все изображения, в том числе сохраненные вручную, и соответствующий файл конфигурации анализа (*.pdna).

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents