Создание и сопровождение ваших компонентов и библиотек
Краткий обзор
- Узнайте, как условные графические обозначения на схемах, посадочные места на печатных платах и другие модели представляют реальные компоненты.
- Сравните варианты библиотек и изучите возможности рабочего пространства, такие как совместный доступ к данным о компонентах, повторное использование моделей, информация о цепочке поставок и отслеживание жизненного цикла.
- Узнайте, как приступить к созданию компонента в рабочем пространстве с помощью редактора компонентов и шаблонов компонентов.
Электронный проект — это совокупность соединенных между собой компонентов. Самая увлекательная часть разработки изделия — находить интересные способы решения инженерных задач и соединять компоненты, создавая свой уникальный проект.
Однако значительную часть работы, которую многие разработчики считают более рутинной, составляет создание компонентов. Хотя эта работа может быть не слишком увлекательной, компоненты становятся ценным ресурсом компании, и крайне важно, чтобы они точно представляли реальные компоненты.
Компонент, который вы покупаете и припаиваете к плате или используете в кабельном жгуте, — это реальный компонент. Однако его необходимо представить в виде модели в каждой из областей электронного проектирования, в которой вы собираетесь его использовать.
В зависимости от планируемых вариантов реализации проекта компонент может включать условное графическое обозначение для схемы, имитационную модель для симулятора электрических цепей, модель IBIS для анализа целостности сигналов, посадочное место для топологии печатной платы, а также 3D-модель для визуализации, проверки зазоров в 3D и экспорта в механическую САПР.
Управление компонентами
Эффективное управление данными компонентов необходимо для проектирования электроники, а управление компонентами, используемыми в проекте, всегда было одной из основ программного обеспечения Altium. По мере развития программного обеспечения методы управления компонентами прошли долгий путь: от простых отдельных библиотек схемных обозначений и моделей печатных плат через библиотеки баз данных до компонентов рабочего пространства, которые позволяют использовать данные компонентов в более широком контексте разработки изделий и предлагают передовые, удобные функции для эффективной совместной работы на протяжении всего процесса проектирования.
| Библиотека рабочего пространства | Компоненты хранятся в подключенном рабочем пространстве, которое служит единым источником актуальных и стандартизированных данных компонентов для всей команды разработчиков. Возможности параметрического и фасетного поиска позволяют быстро и эффективно находить и размещать нужные компоненты. Эти компоненты тесно связаны с реальными изделиями производителей и данными о цепочках поставок, доступными непосредственно во время проектирования, что позволяет существенно сократить затраты и сроки закупок при изготовлении готового изделия. |
|
| Библиотека базы данных | Хотите тесно связать компоненты проекта с базой данных вашей компании? Тогда обратите внимание на библиотеки баз данных. Каждая запись представляет собой компонент со ссылками на необходимые модели и параметрическими данными. При размещении к условному графическому обозначению добавляются ссылки на модели и параметры, превращая его в компонент Altium Designer. | |
| Библиотека базы данных SVN | Библиотека базы данных SVN расширяет возможности библиотеки базы данных: ее отличие заключается в том, что исходные условные графические обозначения и модели хранятся под управлением системы контроля версий. Исходные библиотеки создаются, пополняются и обслуживаются в репозитории на базе Subversion. Ссылки на репозиторий и внешнюю базу данных задаются в файле библиотеки базы данных SVN (*.SVNDbLib). |
|
| Связь с базой данных | При использовании этого метода файл связи с базой данных (*.DbLink) определяет связь между компонентом схемы и соответствующей записью в базе данных. Сопоставление записей выполняется по ключевым полям: одному полю, например номеру детали, или нескольким полям с помощью условия Where. |
|
| Интегрированная библиотека | Предпочитаете, чтобы компоненты были заранее собраны и проверены в одном файле? Тогда скомпилируйте исходные схемные модели, модели печатных плат и имитационные модели, чтобы создать интегрированную библиотеку (*.IntLib). |
|
| Библиотека схемных компонентов | Библиотека схемных компонентов (*.SchLib) может быть библиотекой моделей, содержащей условные графические обозначения компонентов. Если же к каждому обозначению добавить ссылки на модели и параметрические данные, она становится библиотекой компонентов. |
|
| Библиотека посадочных мест | Библиотека для хранения моделей посадочных мест печатных плат (*.PcbLib). При необходимости к каждому посадочному месту можно добавить 3D-модель. 3D-модели создаются из объектов трехмерных тел или из модели STEP, импортированной в объект трехмерного тела. |
Библиотека рабочего пространства
Компоненты хранятся в вашем рабочем пространстве — едином централизованном защищенном хранилище всех проектных данных, доступном всей команде разработчиков. Использование компонентов, размещенных в рабочем пространстве, дает множество преимуществ. Вот некоторые из них:
-
Single source of component data – благодаря доступности рабочего пространства для всей команды инженеры могут получать актуальные и стандартизированные компоненты из единого защищенного хранилища, просматривать данные о цепочках поставок в реальном времени и находить нужные компоненты с помощью параметрического и фасетного поиска.
-
Design-time choice of physical components – для каждого компонента можно выбрать изделия производителей, которые допускается использовать для его реализации при сборке платы.
-
Real-time supply-chain information – данные поступают из сводной базы данных компонентов Altium Parts Provider (которая, в свою очередь, взаимодействует с подключенными поставщиками и собирает у них данные о компонентах) и позволяют разработчику узнать текущие цены и доступность выбранных компонентов у всех продавцов, предлагающих эти компоненты (согласно локальному каталогу компонентов рабочего пространства). Эту информацию можно добавить к компоненту в любой момент, в том числе после его сохранения в рабочем пространстве, — без непосредственного редактирования компонента и, следовательно, без влияния на проекты, где он уже используется, — а затем использовать в составе спецификации.
-
Concurrent editing of the library – поскольку библиотека рабочего пространства фактически представляет собой набор элементов компонентов, размещенных в этом рабочем пространстве, несколько пользователей могут независимо редактировать или создавать компоненты библиотеки, не дожидаясь завершения работы других пользователей.
-
Component Models Reuse – компонент можно рассматривать как «контейнер», в котором хранятся все параметрические данные и модели для различных областей проектирования, включая условное графическое обозначение, посадочные места, модели проводки жгутов и имитационные модели. Компонент содержит не сами модели, а ссылки на соответствующие элементы моделей, также находящиеся в рабочем пространстве, поэтому одна модель может использоваться в нескольких компонентах. При изменении модели вам будет предложено обновить все использующие ее компоненты, что исключает использование устаревших моделей.
-
Direct Component Editing – если компонент требуется изменить, его можно открыть для редактирования прямо из рабочего пространства. Временный экземпляр редактора компонентов позволяет редактировать все аспекты компонента, в том числе изменять связанные с ним модели для различных областей проектирования, без необходимости работать с файловыми документами.
-
Use of Component Templates – можно применять шаблоны на основе параметров и классификации компонентов, чтобы каждый новый тип компонента автоматически получал корректный набор параметров для спецификации, а также автоматизировать применение нужных схем именования, ревизий и жизненного цикла.
-
Component Lifecycle Validation – если компонент находится в состоянии «снятие с производства», «устарел» или «больше не поддерживается», вы получите предупреждение перед изготовлением плат, в которых он используется.
-
Where-used Component Traceability – можно отслеживать все случаи использования компонентов: если компонент устарел, вы можете узнать, в каких проектах он использовался, и определить, какие из них требуют обновления. Если в условном графическом обозначении или посадочном месте есть ошибка, можно найти все компоненты, использующие это обозначение или посадочное место, и исправить их.
-
Requests of new components – инженер может отправлять запросы на создание новых или недостающих компонентов ответственным специалистам по библиотекам и получать уведомления, когда эти компоненты станут доступны для использования в проектах как самому автору запроса, так и другим инженерам компании.
Создание нового компонента библиотеки рабочего пространства
Реальный компонент, устанавливаемый на плату или используемый при изготовлении жгута проводов, при разработке схемы представляется условным графическим обозначением, а при проектировании печатной платы — посадочным местом (при необходимости — с 3D-моделью для визуализации, проверки зазоров в 3D и экспорта в механическую САПР). Компонент проекта также может включать модель для схемотехнического моделирования и IBIS-модель для анализа целостности сигналов. Чтобы представить компоненты проекта в более широком контексте разработки изделия, к компоненту можно добавить один или несколько вариантов выбора комплектующих.
Компоненты для вашего проекта можно создавать и размещать в библиотеке рабочего пространства вашей компании. Их размещение в проекте выполняется через панель Components, которая использует расширенную поисковую систему компонентов Altium Designer.
Новый компонент библиотеки рабочего пространства создается в редакторе компонентов, где можно вручную определить все данные компонента (модели для различных областей проектирования, параметры, варианты выбора комплектующих и т. д.) или использовать данные, полученные из панели Manufacturer Part Search.
Чтобы создать новый компонент библиотеки рабочего пространства:
-
Выберите команду создания компонента. Она доступна следующими способами:
-
Выберите команду File » New » Component в главном меню.
-
Выберите File » New » Library в главном меню, затем в открывшемся диалоговом окне New Library выберите Create Library Content » Component в области Workspace этого окна.
-
На панели Компоненты щелкните правой кнопкой мыши в области списка компонентов и выберите команду Create в контекстном меню.
-
-
В открывшемся диалоговом окне Create new component выберите тип компонента. Если с выбранным типом связан шаблон компонента, данные из него будут использованы для предварительного заполнения компонента.

Откройте диалоговое окно Create new component, чтобы выбрать тип создаваемого компонента. -
После нажатия OK откроется редактор компонентов в режиме редактирования одного компонента. Он предоставляет упрощенный интерфейс для создания и редактирования одного компонента.
-
Определите компонент, добавив сведения о нем в редакторе компонентов:
- В области Component редактора компонентов задайте Name и Description компонента. Эти сведения необходимы для последующего поиска нужного компонента для использования в вашем проекте.
-
Нажмите элемент управления Advanced Settings, чтобы задать или изменить другие сведения о компоненте, например Id, используемый для сохраненного компонента в рабочем пространстве, и Folder в целевом рабочем пространстве, где будет сохранен компонент.
-
В области Parameters редактора компонентов задайте дополнительные сведения о компоненте: стандартные параметры, URL-ссылки на веб-страницы (например, сайт производителя) и ссылки на техническую документацию (в любом формате).
-
В области Part Choices редактора компонентов укажите один или несколько вариантов выбора комплектующих для компонента — допустимых изделий производителей, которые можно использовать для реализации компонента на собранной плате.
-
В области Models редактора компонентов добавьте ссылки на сохраненные (или созданные на лету) модели для различных областей проектирования, которые будет использовать компонент. Компонент может иметь одно условное графическое обозначение и несколько посадочных мест и моделей для моделирования либо одну модель соединений жгута. Компонент должен иметь хотя бы одну модель.
-
Проверьте созданный компонент, чтобы убедиться, что он соответствует требованиям согласно настройкам на странице «Управление данными — Проверки правил компонентов» диалогового окна Preferences. Сохраните компонент локально (File » Save), затем выберите команду Tools » Component Rule Check в главном меню. Все обнаруженные нарушения будут перечислены на панели Messages.
-
После определения компонента выберите команду File » Save to Server в главном меню, чтобы сохранить его в рабочем пространстве. Откроется диалоговое окно Edit Revision, в котором можно изменить имя и описание, а также при необходимости добавить примечания к выпуску. После сохранения редактор закроется.
Новый компонент будет доступен для поиска и работы через панель «Компоненты».
Примечания
-
Чтобы создать новый компонент, похожий на существующий компонент в рабочем пространстве, можно скопировать существующий компонент. На панели Components найдите нужный компонент, щелкните по нему правой кнопкой мыши и выберите команду Operations » Make a copy. Откроется редактор компонентов, в котором данные будут предварительно заполнены на основе выбранного компонента.
-
Компонент можно определить с помощью данных, предоставляемых функцией поиска компонентов производителя (Manufacturer Part Search). Начните вводить текст в поле Name и выберите подходящий компонент производителя либо добавьте вариант компонента производителя к определяемому компоненту. Откроется диалоговое окно Use Component Data с элементами управления для выбора данных, которые нужно применить к создаваемому или редактируемому компоненту: имени, описания, параметров, моделей и технических описаний.

Данные компонента можно получить с помощью поиска компонентов производителя. Здесь показан пример доступа к этой функции: ввод имени компонента в поле Name и выбор подходящей записи из всплывающего списка. -
Редактор компонентов также может работать в режиме пакетного редактирования компонентов, который предоставляет интерфейс для определения и редактирования нескольких компонентов. Если редактор компонентов работает в режиме Single Component Editing, перейти в режим пакетного редактирования можно, выбрав команду Tools » Switch to Batch Editor в главном меню редактора.
-
Для быстрого импорта существующих файловых библиотек и библиотек баз данных (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) в рабочее пространство можно использовать Library Importer. Library Importer позволяет выполнить импорт одним щелчком: он автоматически анализирует выбранные библиотеки и импортирует их в рабочее пространство, к которому вы подключены.
-
Новый компонент также можно создать, щелкнув правой кнопкой мыши запись подключенного рабочего пространства на панели Projects и выбрав в меню команду Create Component.
-
Чтобы отредактировать компонент рабочего пространства, щелкните правой кнопкой мыши запись компонента на панели Components и выберите команду Edit в контекстном меню. Откроется редактор компонентов в режиме Single Component Editing с определением компонента, доступным для редактирования. Внесите необходимые изменения, затем сохраните определение компонента в новой ревизии компонента рабочего пространства.
-
Аналогичным образом можно выбрать несколько компонентов на панели Components и выбрать команду Edit в контекстном меню. Если выбранные компоненты ссылаются на один и тот же шаблон компонента, откроется один экземпляр редактора компонентов в режиме пакетного редактирования компонентов. В противном случае для каждой группы компонентов с общим шаблоном откроется отдельный экземпляр редактора компонентов.
-
Компоненты рабочего пространства, открытые для редактирования, отображаются под записью Workspace Components на панели Projects.
В контекстном меню записи Workspace Component, вызываемом правой кнопкой мыши, можно открыть компоненты группы, закрыть их, сохранить локально, сохранить в подключенное рабочее пространство или отменить изменения (закрыть без внесения изменений)
. Если при использовании команды Close All в группе изменено несколько компонентов, появится диалоговое окно подтверждения сохранения с вариантами действий, соответствующими работе с объектом рабочего пространства, открытым для редактирования
-
Если пользователь с правами только на просмотр попытается открыть компонент рабочего пространства для редактирования, откроется редактор компонентов, позволяющий просматривать сведения о компоненте, но не сохранять изменения в рабочем пространстве. В этом случае запись данного компонента рабочего пространства на панели Projects отображается с меткой Local Edits Only
-
При сохранении отредактированного компонента в библиотеку рабочего пространства можно сохранить его текущее состояние жизненного цикла. Для этого служит параметр Preserve lifecycle state (not recommended), доступный в диалоговом окне Edit Revision при повторном сохранении (показать изображение). Если он включен, новой ревизии компонента автоматически присваивается состояние жизненного цикла предыдущей ревизии. Эта возможность доступна пользователям, которым назначено разрешение на выполнение операции Allow to skip lifecycle state change for new revisions (подробнее см. Настройка глобальных разрешений на выполнение операций для рабочего пространства).
Библиотеки баз данных
Altium Designer позволяет размещать компоненты непосредственно из базы данных компании путем создания и использования Database Library. Размещение выполняется с панели Components, которая после установки библиотеки базы данных служит средством просмотра вашей базы данных.
После размещения информацию о параметрах проекта можно синхронизировать между размещенными компонентами и соответствующими связанными записями в базе данных. Можно выполнять полное обновление компонентов, включая графическое обозначение, ссылки на модели и параметры. Информацию о параметрах из базы данных также можно включить в итоговую спецификацию (BOM), подготовленную для закупки компонентов.
Подробнее см. Библиотеки баз данных.
Файловые библиотеки
Если компоненты необходимо хранить локально в файловой системе, их можно организовать в файловые библиотеки.
Файловая библиотека Altium Designer — это произвольный набор моделей или компонентов. Способ организации моделей или компонентов в библиотеки вы выбираете сами. Например, можно структурировать библиотеки по поставщикам устройств или сгруппировать компоненты по назначению, создав отдельную библиотеку для всех микроконтроллеров, используемых в вашей компании.
Условные графические обозначения компонентов создаются в библиотеках схемных символов (*.SchLib). Компоненты в этих библиотеках ссылаются на посадочные места и другие модели, определенные в отдельных библиотеках посадочных мест (*.PcbLib) и файлах моделей. При проектировании можно размещать компоненты из этих отдельных библиотек или скомпилировать библиотеки символов, библиотеки посадочных мест и файлы моделей в интегрированные библиотеки (*.IntLib).
Подробнее см. Файловые библиотеки компонентов.
Модели
С точки зрения разработчика компонент объединяет в одной сущности всю информацию, необходимую для его представления во всех областях проектирования. В этом смысле его можно рассматривать как контейнер.
Каждый компонент представляет собой набор связанных моделей и параметрических данных компонента. Именно модели содержат подробную информацию, необходимую для каждой области проектирования.
Можно использовать следующие типы моделей:
| Схемный символ | Символ представляет компонент на листе схемы. Символ создается с помощью стандартных графических объектов, а выводы задают электрические свойства. |
| Модель SPICE | Моделирование поведения соединенных компонентов выполняется с помощью симулятора SPICE. Модели SPICE обычно предоставляются поставщиками устройств. |
| Модель целостности сигналов | По мере увеличения скорости переключения устройств и схем межсоединения на печатной плате становятся частью электрической цепи. Модели IBIS описывают поведение выводов, позволяя симулятору целостности сигналов Altium Designer анализировать трассы. |
| Посадочное место на печатной плате | Для каждого компонента на печатной плате необходимо определить место его монтажа и подключения — посадочное место представляет собой модель, определяющую эту область платы. Посадочное место создается из набора стандартных объектов, а контактные площадки обеспечивают электрическое подключение. |
| 3D-модель | Современные электронные изделия компактны, имеют плотную компоновку и необычную форму, а их печатная плата нередко складывается, чтобы поместиться в корпусе. Для проектирования такого изделия необходимо моделировать печатную плату в 3D — это позволяет увидеть готовую плату, проверить зазоры в трехмерном пространстве и передать плату с установленными компонентами в механическую САПР. Для этого потребуется 3D-модель каждого компонента. |
Подробнее о создании и управлении условными графическими обозначениями, моделями посадочных мест, моделями для моделирования и 3D-моделями в вашем рабочем пространстве.
Панель Components
Панель Components обеспечивает прямой доступ ко всем доступным компонентам в Altium Designer, включая компоненты из рабочего пространства, баз данных и файловых библиотек.
Панель получает компоненты из рабочего пространства, а также из открытых или установленных библиотечных файлов. Она предоставляет полную информацию о выбранном компоненте (параметры, модели, варианты компонентов производителя, данные поставщиков и т. д.), позволяет сравнивать компоненты, а для компонентов рабочего пространства — выполнять параметрический поиск с помощью фильтров, задавая требуемые параметры. Благодаря контекстным динамическим фильтрам поиск на панели позволяет быстро найти нужный компонент в подключенном рабочем пространстве вашей компании.
Подробнее о панели Components.
Панель Manufacturer Part Search
Вы также можете искать реально выпускаемые компоненты с помощью панели Manufacturer Part Search, которая использует базовые функции поисковой системы и представление, применяемые на панели Components. Выбранный компонент производителя можно использовать как основу для нового компонента в подключенном рабочем пространстве, а его параметры и техническую документацию — добавить к уже размещенному компоненту.
Значок
в записи компонента означает, что ему назначены модели (условные графические обозначения, посадочные места для печатной платы, модели для моделирования). При создании нового компонента на основе этого компонента производителя его модели также будут получены. Кроме того, вы можете скачать этот компонент на свой компьютер или разместить его непосредственно на схеме.
Подробнее о панели Manufacturer Part Search.
Что дальше?
Создание условного графического обозначения
Создание посадочного места для печатной платы
Создание компонента для схемы соединений жгута
Работа с шаблонами и библиотеками контактных площадок и переходных отверстий



).
).



