Altium Designer Documentation

Руководство по PDN Analyzer v2 на основе примеров

Последнее изменение: Pavel Demidov; 14.04.2019

Приложения PDN Analyzer (PDNA) относительно просто в использовании. В общем случае, процесс работы в приложении включает в себя следующие этапы: задание параметров цепей для расчёта целостности питания по постоянному току, запуск расчёта и последующий анализ результатов. Данные, которые использует PDN Analyzer для симуляции цепей питания, приложение берет непосредственно из проекта платы, который можно интерактивно редактировать для улучшения целостности питания, а затем запустить расчёт повторно для проверки результатов.

В руководстве по работе с PDN Analyzer используются два проекта Altium:

Помимо этого, установка PDN Analyzer включает в себя проект платы SpiritLevel с набором примеров файлов конфигурации расчёта. Откройте и разархивируйте этот проект и примеры через меню приложения File » Explore Samples.

Сведения, приведенные в этом руководстве, предполагают, что у вас установлен и лицензирован PDN Analyzer версии 2.x и что у вас есть основное понимание принципов целостности питания по постоянному току (PI-DC).

Примечание: PDN Analyzer на основе технологий CST® запускается только на 64-разрядных версиях Windows.

Дополнительный программный модуль PDN Analyzer 2.0 доступен только для Altium Designer 17.1 и более поздних версий.

Интерфейс PDN Analyzer

Интерфейс модуля PDN Analyzer представляет собой закрепляемое окно Altium Designer, которое можно расположить в любом удобном месте рабочего пространства, либо на другом экране, если таковой имеется. Чтобы открыть главное окно PDN Analyzer, откройте документ схемы или платы проекта и выберите приложение из меню Tools (Tools » PDN Analyzer).

Интерфейс PDN Analyzer, где выбрана одна цепь питания. Конфигурации отображения и результаты доступны в нижней части окна.

Интерфейс диалогового окна PDNA разделен на верхнюю часть, где осуществляется управление файлами/цепями и интерактивное представление текущей цепи (цепей) питания, и нижнюю часть, где доступны параметры анализа, настройки отображения и результаты. В PDN Analyzer версии 2 поддерживается анализ множества связанных цепей, что позволяет провести расчёт всего проекта платы как иерархической структуры или отдельных цепей питания.

Интерфейс PDN Analyzer с выделенной иерархией силовых цепей. Отображение отдельных цепей и слоев управляется из нижней части окна.

Интерфейс модуля также предлагает компактный режим отображения (File » Compact Layout), который не включает в себя нижнюю часть окна, что идеально подходит для его горизонтального/вертикального закрепления в окне Altium Designer. Чтобы включить возможность закрепления для компактного или стандартного отображения, нажмите правой кнопкой мыши по строке заголовка окна PDNA, выберите из контекстного меню Allow Dock (Разрешить закрепление), затем опцию Horizontally (Горизонтальное) или Vertically (Вертикальное).

Идентификация цепей

Когда открытие PDN Analyzer осуществляется в проекте первый раз, приложение пытается идентифицировать все цепи питания по постоянному току на основе общей системы наименований цепей питания. Если автоматически были определены не все цепи питания, отключите соответствующие параметры в разделе Qualifiers (Квалификаторы) или выберите параметр Enable all nets for filtering (Включить все цепи для фильтрации), чтобы увидеть все цепи.

Чтобы выбрать, какие цепи питания будут доступны для PDN Analyzer, выделите их флажками Select (Выбрать) и введите соответствующие уровни напряжений в полях Nominal Voltage (Номинальное напряжение). Нажмите кнопку Add Selected (Добавить выбранные), чтобы добавить их в список Currently Identified DC Nets (Идентифицированные цепи постоянного тока), и подтвердите их выбор в качестве идентифицированных цепей питания.

Обратите внимание, что двойной клик по цепи в списке в этом диалоговом окне выполнит перекрестный выбор этой цепи в документе платы.

Цепи можно определить и задать в процессе настройки анализа позже с помощью кнопки DC Nets в интерфейсе приложения.

На примерах анализа ниже рассматриваются основные функциональные возможности PDN Analyzer. В каждом примере показана только одна из множества возможных конфигураций параметров, которые можно использовать для разносторонней оценки целостности питания, в зависимости от интересующих аспектов. Обратите внимание, что успешно завершенный анализ можно сохранить в файл конфигурации (*.pdna) и загрузить в любой момент через File » Save As и File » Open (по умолчанию – в папку проекта PDNAnalyzer_Config).

Пример 1

Здесь на примере простой цепи питания и ее нагрузок показаны основы настройки симуляции целостности питания. В примере рассматривается настройка анализа распределения цепи питания 5В и ее возвратной цепи в проекте SpiritLevel-SL1, с экраном LCD в качестве нагрузки. В этом случае, цепь питания 5V рассматривается как простой источник напряжения, а его связанные цепи (например, подключенные через переключательS1) не включены.

Подготовительными действиями для этого примера симуляции являются:

  • Открытие проекта Spirit Level PCB в Altium Designer
  • Активация приложения PDN Analyzer (Tools » PDN Analyzer)
  • Идентификация цепей питания проекта платы в диалоговом окне PDN Analyzer DC Net Identification, как описано выше.

Начнем процесс анализа с указания цепи питания и цепи возвратных токов. Дважды кликните по элементам <Power Net> и <Ground Net> в графическом представлении цепей, чтобы открыть диалоговое окно Choose Net (Выбрать цепь), где будет предложено выбрать распознанную ранее силовую цепь.

Если необходимо, используйте параметры фильтрации/квалификаторы в этом диалоговом окне, чтобы ограничить или расширить список цепей, либо вернитесь на главный экран и выберите кнопку , чтобы провести повторную идентификацию цепей питания постоянного напряжения.

Теперь между указанными цепями питания и возвратных токов можно добавить источник или нагрузку – обратите внимание, что индикаторы состояния цепей питания и возвратных токов изменятся на . Нажмите правой кнопкой мыши в области графического представления цепи и из контекстного меню выберите Add Source (Добавить источник) или Add Load (Добавить нагрузку), чтобы открыть диалоговое окно Device Properties (Свойства устройства). Дальнейшие шаги, обозначенные в этом окне:

  1. Чтобы добавить источник питания в цепь (в этом примере – простой источник напряжения), выберите параметр Voltage Source (Источник напряжения) из выпадающего меню Device Type (Тип устройства).
  2. В списке соединений источника приложение попытается самостоятельно выбрать опции соединения на основе параметров цепи питания – между цепями 5V и GND. Используйте опции выпадающего меню Refdes, чтобы задать точки соединения компонента к источнику питания. В этом примере вывод положительной полярности источника напряжения задается элементом TP1, а его возвратной цепи – соединителем J1 (контакты 2 и 3).
  3. В нижней части диалогового окна задаются свойства модели источника питания. Здесь задаем напряжение источника (Vout) 5V, а его значение внутреннего сопротивления (Rout) оставляем по умолчанию .
  4. Наконец, значения максимального тока источника и тока контакта (для источников со множеством выходных контактов) оставляем по умолчанию – 0A: Don't Care(Не важно). Если в разделе Limits (Пределы) заданы конкретные значения токов, то приложение укажет место нарушения, если результат расчёта превысит эти значения.

Используя тот же подход, что и при добавлении источника, добавим нагрузку и укажем ее параметры в диалоговом окне Device Properties.

В этом примере, добавлена нагрузка по току (Device Type: IC (Current)), которая представляет ток, идущий от цепи 5V к компоненту LCD. Обратите внимание, что также доступен вариант чисто активного сопротивления в качестве нагрузки – Resistor в качестве типа устройства Device Type.

Задайте соединение нагрузки как LCD1 и укажите ток нагрузки Load Current, который будет протекать через нее от источника 5V – обратите внимание, что поддерживаются префиксы единиц измерения (например, 500m означает 0.5A). Опциональные значения пределов напряжения Limits здесь заданы +/-10% с помощью соответствующих кнопок – если напряжение на нагрузке упадет ниже 4,5 В или поднимется выше 5,5 В, приложение сообщит о нарушении.

Когда цепь питания задана и указаны все параметры (все элементы цепи имеют состояние ), можно запустить анализ нажатием на кнопке . Прогресс расчёта будет показан под вкладкой Messages (Сообщения) как поток событий, который также укажет причину неудачи расчёта, если завершить процесс невозможно.

Когда расчёт запущен, текущая конфигурация симуляции (заданные цепи, источники/нагрузки и т.д. и их параметры) сохраняется вместе с данными о результатах расчёта (File » Explore; см. папку PDNAnalyzer_Ouput). Эту конфигурацию для текущей симуляции можно восстановить в любой момент, кликнув правой кнопкой мыши по названию симуляции и выбрав Revert (Вернуть) в контекстном меню.

Текущие результаты расчёта можно увидеть в графической области, где будут указаны рассчитанные уровни напряжения и токов источника/нагрузки (где применимо), а части цепи, вызвавшие нарушения параметров, будут выделены. Обратите внимание, что вкладка Visual (Визуализация) станет активной.

Наведите курсор мыши на любой элемент цепи (источник, нагрузка или последовательный элемент), чтобы увидеть дополнительную информацию, такую как заданные параметры и результаты расчёта.

Визуализация в редакторе платы

Теперь результаты расчёта можно графически отобразить в редакторе плат Altium Designer с помощью элементов управления на вкладке Visual. Задайте параметры визуализации, чтобы отобразить напряжение (Voltage) для обоих слоев (Layers: Top и Bottom) цепи 5V – начальные настройки отображения по умолчанию. Результаты расчёта будут отображены в редакторе платы, заменяя собой существующие настройки графики платы.

Падение напряжения выбранной цепи, в данном случае источника 5В от TP1 к компоненту LCD1, отображается с помощью цветового градиента, который соответствует шкале внизу. Результат может быть отображен в виде относительного (параметр Per Rail в Color Scale) или абсолютного значения (параметр Displayed).

На рисунке ниже показан цветовой градиент для цепи питания платы, показывающий общее падение напряжения, минимальное значение (0%: – синий) из-за потерь на активном сопротивлении находится на компоненте LCD1 , а максимальное значение (100% – красный) – в точке указанного источника напряжения (TP1).

Чтобы отобразить результаты расчёта, соответствующие плотности тока для цепи, выберите параметр Current Density на вкладке Visual. Здесь цветовая шкала на плате относится к процентному разбросу плотности тока, где 100% (красный) означают максимальное рассчитанное значение плотности тока в цепи, а 0% (синее) – минимальное значение (как правило, 0 A/мм2.

Обратите внимание, что более информативным является отображение (Displayed) либо напряжения, либо плотности тока для одной цепи. В приложении возможно одновременное отображение нескольких анализируемых цепей питания, таких как 5V и GND в этом примере, но такой вариант отображения менее нагляден.

Чтобы отобразить и проанализировать результаты расчёта целостности питания в возвратной цепи GND, снимите выбор цепи 5V в списке Net на вкладке Visual в окне PDN Analyzer и затем выберите цепь GND. Возвратная цепь проходит через верхний и нижний слои платы, которые можно отобразить отдельно в редакторе плат с помощью выбора каждого слоя в списке Layer окна PDN Analyzer.

На рисунке ниже изображена диаграмма напряжения для нижнего слоя цепи GND, где отображена цветовая шкала (Color ScaleDisplayed). Наибольший уровень падения напряжения (красный – примерно 0,5 мВ) находится на выводе GND компонента LCD, а наименьшее (синий – примерно 0 В) – на выводе возвратной цепи источника напряжения (J1).

Выбор режима Current Density отобразит красным цветом точки максимальной плотности тока. Само максимальное значение плотности тока (1.74 A/mm2) является очень низким и находится в приемлемых границах.

Параметры отображения

PDN Analyzer предлагает несколько вариантов интерактивного отображения результатов расчёта, которые определяют, каким образом они будут графически представлены в редакторе плат Altium Designer. Наряду с настройкой отображения цветовой шкалы Color Scale, графический вид можно отобразить в 2D или 3D представлении, последний из которых обеспечивает достаточно информативный ракурс на результаты расчёта переходных отверстий и проводящих областей на различных слоях.

Также есть настройка Clear для очистки вида платы от изображения результатов анализа, которая автоматически сбрасывает параметры отображение платы в стандартное состояние. Настройка Overlay, наоборот, отображает плату со всеми результатами расчётов. Этот параметр может быть полезен для поиска интересующего места на плате, исходя из результатов расчёта.

Работа с нагрузками

Впоследствии можно добавлять нагрузки по мере необходимости, а затем проводить повторные расчёты для оценки результатов. Чтобы добавить малую нагрузку по току (скажем, 15mA), относящуюся к LED в примере, выберем последовательный резистор (R15) в качестве соединения к шине 5V и контакт LED в качестве соединения к GND.

PDN Analyzer также позволяет указывать контакты устройств, присоединенные к нагрузке, что, в свою очередь, позволяет создавать множество моделей нагрузок для одного компонента, который потребляет различные токи через разные контакты.

Устройство LCD в этом примере демонстрирует ситуацию, где его соединение к 5V через контакт 15 (LED+) питает подсветку экрана, а соединение к 5V через контакт 2 (VDD) питает внутреннюю логику – на самом деле, контакт 15 будет потреблять намного больший ток, чем контакт 2.

Когда была добавлена модель нагрузки, оба контакта LCD1 были по умолчанию соединены с цепью 5V, в этом случае расчёт распределит ток нагрузки LCD1 в равной степени между этими контактами. Чтобы повысить точность расчёта, компонент LCD1 может быть представлен двумя моделями нагрузок: по одной для контакта 5V и связанной с ним нагрузкой по току. Это изменение можно выполнить, отредактировав параметры контактов существующей модели нагрузки LCD1, а затем добавив другую нагрузку для отдельного контакта.

Откройте существующую модель нагрузки LCD1, дважды щелкнув по ее иконке в графическом изображении схемы, чтобы открыть диалоговое окно Device Properties , затем дважды щелкните в поле Pins(s) для цепи 5V. Открывшийся режим редактирования контактов позволяет указать отдельные контакты устройства для этой нагрузки. Снимите выделение контакта 2, чтобы указать нагрузку только для контакта 15 (LED+), и измените значение Load Current (Ток нагрузки) на, скажем, 75mA, показывающее силу тока подсветки LCD

Далее создайте еще одну нагрузку на цепь 5V для LCD1 и задайте контакт 2 в качестве активного (контакт 15 должен быть отключен), который показывает нагрузку VDD и которому можно задать подходящий ток нагрузки Load Current – например, 20mA.

Затем цепь 5V можно проанализировать повторно, чтобы получить более точное представление нагрузки LCD1 в цепи питания.

Разницу в распределении токовой нагрузки можно увидеть, сравнив диаграммы плотностей тока LCD1 начального и обновленного расчёта. Изображения ниже показывают результаты начального расчёта, с одной нагрузкой LCD1 (слева), и обновленные результаты с несколькими нагрузками (справа).

Обратите внимание, что плотности тока в проводниках, питающих контакты 2 (контактная площадка LCD слева) и 15. В обновленной версии расчётов показано преобладание тока LCD, текущего к контакту 15 (контактная площадка LCD справа), вместо равномерного распределения между двумя контактами, как это было в предыдущем случае (рисунок слева).

 

Настройки расчёта

Результаты расчёта, в частности степень потерь на активном сопротивлении, будет также зависеть от указанной проводимости материала в плате и толщины стенок переходных отверстий. Чтобы просмотреть и отредактировать эти значения, выберите вкладку Simulation на вкладке Settings – чтобы открыть это диалоговое окно, нажмите правой кнопкой мыши по названию текущего анализа и выберите Settings из контекстного меню.

Проводимость металла

В разделе Metal Conductivity диалогового окна представлены подробности и настройки значения проводимости металла (величина, обратная сопротивлению; 1/R), используемого в проекте. Чтобы отразить конструктивные свойства платы проекта, в диалоговом окне можно выбрать и изменить базовую проводимость (или удельное сопротивление), температурный коэффициент и/или температуру:

  • Pure Copper (Чистая медь) – обычно полагается, что у меди проводимость составляет 5.88e7S/m при 25°C с температурным коэффициентом проводимости 0.4%/°C. Этот положительный температурный коэффициент означает, что увеличение настройки Temp. Compensation в этом диалоговом окне с 25°C до 125°C (дельта 100°C) понизит проводимость на 40%, в этом примере – до 3.53e7S/m.
  • PCB Copper (Медь для плат) – настройка для расчётов по умолчанию, и она отражает значение проводимости, указанные в отраслевой литературе для электроосажденной меди: 4.7e7S/m при 25°C, с температурным коэффициентом 0.4%/°C.
  • Custom (Пользовательские настройки) – эта опция позволяет ввести собственные значения проводимости или удельного сопротивления для расчёта.

Обратите внимание, что Sim Conductivity (Расчётная проводимость) отображает финальное значение проводимости после принятия в расчёт всех параметров. Sim Resistivity (Расчётное удельное сопротивление) указывает обратное значение.

Переходные отверстия

Толщина стенок металла всех переходных отверстий в проекте для расчёта указывается в поле Via Wall Thickness (Толщина стенок переходных отверстий).

Эта настройка может значительно повлиять на потери по постоянному току из-за сопротивления, присущего тонкостенным переходящим отверстиям. С другой стороны, если размер/толщина подобраны должным образом, переходные отверстия не будут влиять на производительность конструкции, а плотность тока на них будет такой же, как на подсоединенных проводниках; не будет значительных потерь по напряжению между их точками соединения. Пример анализа потерь на переходных отверстиях по постоянному току приведен в разделе ниже.

С точки зрения расчёта, размер и толщина стенок переходного отверстия определяют количество проводящего материала и, следовательно, его сопротивление/проводимость. расчёт предполагает, что диаметр переходного отверстия представляет собой конечный диаметр отверстия, а толщина стенок увеличивает диаметр переходного отверстия. Следовательно: Конечный диаметр отверстия + (2 x Толщина металлизации стенки) = Диаметр отверстия.

Пример 2

В этом примере показано, как рассчитать ряд соединенных цепей как единое целое, с учетом параметров последовательных элементов как межсоединений. Также представлен обзор добавления модели регулятора напряжения (Voltage Regulator Model – VRM), который также выступает в роли соединения между цепями, и как разрабатывается иерархия цепи питания проекта.

В этом примере моделируется цепь от PWR_IN к 5V в проекте SpiritLevel-SL1, и здесь включены модели регулятора напряжения 3.3V (VCCO) и 1.8V (VCCINT) для создания полной структуры цепи питания.

 

Подготовительными действиями для этого примера симуляции являются:

  • Открытие проекта Spirit Level PCB в Altium Designer
  • Активация приложения PDN Analyzer (Tools » PDN Analyzer)
  • Идентификация цепей питания проекта платы в диалоговом окне PDN Analyzer DC Net Identification, как описано выше.

Начнем процесс с построения цепи питания – укажем входную цепь (PWR_IN) в новом расчёте (выберите File » New Simulation, если необходимо). Как указано в схеме проекта, параметром <Power Net> расчёта является PWR_IN, <Ground Net>GND, SourceJ1.

Расширение цепи с помощью последовательных элементов

Чтобы промоделировать полный путь питания от цепи PWR_IN к цепи 5V, необходимо добавить последовательный предохранитель (F1) и переключатель (S1) вместе с их промежуточными цепями. В интерфейсе PDN Analyzer они добавляются последовательным расширением цепи питания. Каждое «расширение» цепи присоединено универсальной моделью последовательного элемента.

Цепь расширяется щелчком правой кнопкой мыши по цепи, которую вы хотите расширить, и выбором Extend Network (Расширить цепь) в контекстном меню. В диалоговом окне Choose Net выберите цепь, подсоединенную к PWR_IN через последовательный элемент, которой в данном случае является NetD1_2 – цепь, соединяющая F1 и контакт 3 компонента S1, который распознан как контакт 2 диода D1.

Если эта цепь, скорее всего, не была зарегистрирована на первоначальном этапе идентификации цепей постоянного тока, снимите выбор параметра List DC nets only (Показывать только цепи постоянного тока) в диалоговом окне Choose Net, чтобы отобразить эту цепь для выбора.

Процесс расширения цепи автоматически добавит последовательный элемент между двумя цепями – дважды щелкните на этот элемент, чтобы задать его связи и параметры в диалоговом окне Device Properties. Модель последовательного элемента составлена из источника напряжения и последовательно включенного резистора, который позволяет провести базовое моделирование таких компонентов, как резисторы, индуктивности, диоды, переключатели и т.д.

В этом примере, последовательным компонентом является предохранитель F1, подключение которого задано с помощью параметров RefDes и номинальное внутреннее сопротивление Resistance которого задано 0.1Ω. Если последовательный элемент является полупроводниковым устройством, таким как диод, необходимо указать параметр Voltage Drop (Падение напряжения) вместе со значением внутреннего сопротивления Resistance.

Следуя схеме, дальнейшим шагом для расширения является цепь D1_2 к цепи питания 5V через переключатель S1. Как описано выше, выберите Extend Net из контекстного меню и выберите цепь для расширения в диалоговом окне Choose Net.

Последовательным элементом здесь является S1, который соединяет цепь D1_2 с выходной цепью 5V через контакты 3 и 2 (см. схему). Поскольку запасной вход S1 (контакт 1) подсоединен к его выходу (контакт 2), и он не несет нагрузки по току, то в этом примере контакт 1 может быть исключен из анализа цепи с помощью параметров выбора контактов в диалоговом окне Device Properties дважды щелкните в полеPin(s) пункта OUT.

Теперь в раздел 5V соединенных цепей можно добавить нагрузку – в этом примере, модуль LCD1.

При повторном анализе, данные и графическое представление платы будут включать в себя все три соединенные цепи питания, а также показывать рассчитанные токи и падения напряжения через последовательные элементы.

Включение модели регуляторов напряжения

PDN Analyzer предлагает модели регуляторов напряжения (VRM), которые можно включить между цепями входного и выходного напряжения. При их добавлении, они объявляют себя как нагрузкой на цепь входного напряжения, так и источником в цепи выходного напряжения. Параметры модели VRM включают в себя линейный (Linear), импульсный (Switchmode) и импульсный с внешней обратной связью (remote-sensing Switchmode) регулятор напряжения.

В проекте SpiritLevel-SL1 используется линейный регулятор напряжения для образования шин питания 3.3V (VCCO) и 1.8V (VCCINT). При добавлении регулятора VCCO (U3) в цепь анализа, он представляет собой нагрузку на цепь входного напряжения 5V и источник цепи 3.3V.

Чтобы поместить линейный регулятор U3 в качестве нагрузки на цепь 5V (как описано выше), добавим нагрузку в цепь 5V и выберем вариант VRM (Linear) в списке Device Type диалогового окна Device Properties. Задайте соединение модели, как обозначено в схеме и укажите контакт R14 как подключение к GND в Ref. Эта точка может быть в другом и, возможно, более подходящем расположении на плате, в зависимости от конструкции цепи GND.

Чтобы завершить настройку VRM, задайте параметр выходного напряжения Vout: 3.3V) и, опционально, его выходное (внутреннее) сопротивление, переменный ток покоя и пределы (Limits), который вы хотите обнаружить в процессе анализа.

PDN Analyzer включает в себя возможность автоматического добавления выходной части модели VRM в качестве источника целевой цепи выходного напряжения и, при необходимости, создания этой цепи.

В этом пример, нажмите правой кнопкой мыши по модели VRM, которая только что была создана (Load2: U3), и выберите Add VRM To New Network (Добавить VRM к новой цепи). Будет автоматически создана цепь VCCO с выходной частью модели VRM (Source 1: U3) в качестве источника напряжения (3.3V).

Обратите внимание, что два описания модели VRM 3.3V, ее входная модель в качестве нагрузки в цепи 5V и выходная модель в качестве источника для цепи 3.3V, по сути являются одной интерактивной моделью. Модель VRM можно открыть и отредактировать из любой цепи в интерфейсе PDN Analyzer.

Теперь можно выбрать новую цепь VCCO и добавить подходящую нагрузку. Для этого примера, это нагрузка по току 0.2A, текущего по множеству контактов компонента U1.

Полная цепь питания теперь включает в себя две цепи (PWR_IN и VCCO), соединенные вместе через модель VRM 3.3V линейного типа. При выборе верхнего уровня иерархии в структуре текущего файла PDN Analyzer, в графической области отображается блок-схема межсоединений цепи питания.

В этом примере, модель VRM была добавлена в качестве нагрузки к цепи 5V (входное напряжение), с помощью которой затем была автоматически создана цепь выходного напряжения 3.3V (VCCO) с моделью VRM в качестве источника. Обратный процесс также возможен, и в некоторых случаях он может быть более удобным. Модель VRM добавляется к цепи выходного напряжения в качестве источника, после чего эта модель добавляется в цепь входного напряжения в качестве нагрузки через Add VRM To New Network (Добавить VRM в новую цепь) или Add VRM To Existing Network (Добавить VRM в существующую цепь).

Расчёт будет осуществляться по всей составной цепи, включающей в себя VRM. В редакторе плат будут графически отображены все цепи при выборе верхнего уровня иерархии цепи в интерфейсе PDN Analyzer. Чтобы ограничить отображение в этой цепи, выберите отдельную цепь в списке и используйте параметры Net и Layer в нижней части окна для последующей настройки.

Обратите внимание, что путь цепи GND в этом примере теперь включает в себя токи от обеих цепей PWR_IN и VCCO.

Чтобы завершить формирование цепи распределения питания, добавим оставшуюся модель VRM (U4) и его выходную цепь 1.8V (VCCINT).

Добавим линейный регулятор к цепи 5V, как было описано ранее, и зададим его параметру Vout значение 1.8V.

Добавим VRM (здесь Load 3) в новую цепь, чтобы создать цепь питания 1.8V (VCCINT).

Добавим соответствующую нагрузку в цепь VCCINT – здесь это контакты питания 1.8V компонента U1.

Теперь в иерархии цепей в интерфейсе PDN Analyzer показаны все три связанные цепи.

Расчёт будет осуществляться по всей составной цепи, включающей в себя модели VRM.

Снова обратите внимание, что цепь GND теперь включает в себя обратный ток от всех трех цепей, которые используют топологию слоя GND. Максимальное значение плотности тока (65.8 A/mm2) теперь является достаточно высоким, и оно, скорее всего, превышает допустимые пределы.

Определение местоположения проблем целостности питания

PDN Analyzer предлагает комплексный набор графической и текстовой информации, которую можно использовать для оценки и устранения проблем целостности питания анализируемой конструкции платы.

В примере выше, анализ слоя Top Layer цепи GND показывает наличие неприемлемо большой плотности тока, обозначенной в качестве максимального значения цветовой шкалы 65.8A/mm2. Положение проблемной зоны может быть неочевидным, но ее можно обнаружить с помощью функции Highlight Peak Values (Показать пиковые значения).

При выборе этого параметра и задания Filter (Фильтр) в положение Maxima (Максимум), область с наибольшим значением плотности тока будет выделена в редакторе плат.

Нажмите кнопку , чтобы заново выделить местоположение графически, либо используйте соответствующие кнопки () для перехода между значениями/положениями пиков. Задайте параметр Scope, чтобы включить отображение пиков в видимой части платы (In View) или на всей топологии (Design) – последний вариант будет смещать и масштабировать вид для каждого положения, к которому вы переходите.

Больше информации о проблемной области можно получить, включив параметр Show Arrows (Показать стрелки), который отобразит множество стрелок, показывающих направление тока (угол стрелки) и его относительную величину (размер стрелки) в этом месте. В этом примере видно, что область наибольшей плотности тока находится в возвратном пути от U1 (на верхнем слое) к области GND на нижнем крае платы.

Одним из способов решения этой проблемы является увеличение ширины проводника.

Редактирование платы можно проводить при активном окне PDN Analyzer, что позволяет интерактивно внести правки и затем повторить расчёт. Нажмите кнопку Clear в области Views, чтобы скрыть результаты расчёта в редакторе плат и отредактировать плату необходимым образом.

После этого расчёт можно повторить (щелчок по ), чтобы проверить целостность питания. Два рисунка ниже показывают изменение плотности тока в цепи GND (на верхнем слое Top Layer), вызванное увеличением ширины проводника в проблемной области – на верхнем рисунке представлены результаты первоначального расчёта плотности тока, на нижнем – результаты расчёта после внесения изменений в плату.

При сравнении обратите внимание на следующие моменты:

  • Уровень максимальной плотности тока на слое GND уменьшился до приемлемого уровня, примерно до одной десятой от первоначального значения: от 65.8 A/мм2 до 7.1 A/мм2.
  • Области максимального тока, которые теперь имеют намного меньшие значения, теперь более равномерно распределены по GND, а не сосредоточены в одном месте.
  • Для более точного графического сравнения, задайте вручную значение шкалы плотности тока, какое было в предыдущем случае – выберите параметр масштаба Manual (Вручную), введите 65.8 в поле Max и нажмите кнопку , чтобы обновить отображение.

Нарушение допустимого предела плотности тока

Более объективным способом обнаружения и разрешения проблем целостности питания в проекте платы является определение границ плотности тока, при превышении которых произойдет нарушение. См. информацию ниже по другим типам нарушений.

Пределы по плотности тока для поверхностных/внутренних слоев и переходных отверстий задаются на вкладке Limits диалогового окна Settings, которое открывается из контекстного меню названия текущей симуляции PDN. Заданные пределы будут применены ко всем поверхностным/внутренним слоям и переходным отверстиям платы.

Заданные ограничения плотности тока применяются к результатам текущего расчёта, и их можно изменить без необходимости повторного запуска расчёта, поскольку пределы проверяются после анализа. Цепи, которые содержат нарушения, обозначены красной пунктирной границей.

При этом примере цепь питания VCCO содержит нарушения по плотности тока. Если выбрать саму цепь, то цепь питания VCCO, которая содержит нарушения, будет обведена красным пунктиром.

Наведите курсор на цепь с нарушениями, чтобы отобразить список текущих нарушений и более подробную информацию по ним. В примере единственная запись в списке показывает, что превышен заданный предел (30 A/мм2) по плотности тока в переходном отверстии (примерно 34.5 A/мм2).

Дважды щелкните по нарушению в списке, чтобы перейти к его местоположению на плате. На рисунке ниже показано, что задан 3D режим отображения, где более ясно представлено интересующее переходное отверстие и его соединение с верхним и нижним слоем.

Обратите внимание, что в целях демонстрации работы с нарушениями, размер переходного отверстия в проекте Spirit Level был уменьшен.

Данные, относящиеся к этому переходному отверстию, в том числе индикация нарушения плотности тока, доступна на вкладке Via интерфейса PDN Analyzer.

Список данных по переходным отверстиям относится ко всем цепям текущего проекта. Нажмите по заголовкам столбцов Net и Current Density, чтобы отсортировать список и отобразить переходные отверстия цепи VCCO в порядке возрастания плотности тока. Те значения плотности тока, которые превышают заданные пределы, будут выделены красным.

Чтобы перейти к переходному отверстию в редакторе платы, дважды щелкните по нему в списке.

Прочие нарушения

Помимо нарушений пределов плотности тока, PDN Analyzer будет находить другие нарушения цепей питания, такие как нарушения пределов, указанных в настройках расчёта при добавлении нагрузок, источников или последовательных элементов.

Эти пределы параметров включают в себя:

  • Диапазон допустимого напряжения на нагрузке
  • Максимальный выходной ток на источнике
  • Допустимое рассеяние мощности на линейном регуляторе и его максимальный выходной ток
  • Максимальный выходной ток для импульсного регулятора
  • Максимальный ток через последовательный элемент
В отличие от параметров элементов цепи, таких как напряжение источника или ток нагрузки, которые обрабатываются в процессе нагрузки, обнаружение нарушений пределов, таких как минимальное напряжение на нагрузке, происходит после расчёта. Это значит, что при изменении предела нарушение будет обнаружено сразу, без повторного запуска расчёта.

Если предел задан (указано ненулевое значение), элемент с нарушением будет выделен в интерфейсе PDN Analyzer. Наведите курсор мыши на элемент, чтобы увидеть его параметры и результаты анализа.

В примере, показанном ниже, рассчитанное рассеяние мощности на Source 1 (регулятор напряжения U1) превышает заданный предел максимального рассеяния мощности 2W.

Более подробная информация по цепи питания доступна на вкладке этой цепи, где в табличном виде представлены результаты расчёта и значения рассчитанной потребляемой мощности.

Пример 3

В этом примере показано применение модели импульсного источника (Switch Mode Power Supply – SMPS) в PDN Analyzer, а также показано, как обновленная модель цепи питания позволяет получить более точные результаты расчёта. В примере также приведен обзор использования инструментов PDN Analyzer для получения данных о напряжении в определенной точке или области топологии платы.

Пример основан на проекте Altium DB46 Xilinx Daughter Board, где основное внимание уделено части с импульсным источником (U5) в цепи питания 1.2V 1V2).

Подготовительными действиями для этого примера симуляции являются:

  • Открытие проекта DB46 Xilinx Daughter Board в Altium Designer
  • Активация приложения PDN Analyzer (Tools » PDN Analyzer)
  • Идентификация цепей питания проекта платы в диалоговом окне PDN Analyzer DC Net Identification, как описано выше. Обратите внимание, что для этого примера также необходимы цепи LX и AGND.

Начнем процесс построения цепи питания с указания входной цепи питания в новом расчёте (выберите File » New Simulation, если требуется). Как показано на схеме выше, цепью <Power Net> является 5V, <Ground Net>GND. Источником Source для цепи 5V является соединитель HDR_T1 или HDR_B1.

Модель импульсного источника

Модель импульсного источника следует добавить в цепь 5V указанием VRM(SMPS) для типа нагрузки Device Type в диалоговом окне Device Properties. Согласно схеме модели в диалоговом окне, контакты IN и OUT задаются отдельно.

Чтобы правильно определить эту модель для схемы, укажите LX в качестве выхода, U5 в параметре RefDes и 1.2V для параметра Vout – как обозначено на схеме выше. Опционально можно задать Rout и КПД/ток в соответствии с используемым устройством.

Добавьте модель VRM к ее выходной цепи (Add VRM To New Network), в качестве которой будет автоматически выбрана цепь LX. Эту цепь можно затем расширить, чтобы включить в нее цепь 1.2V, в соответствии со схемой.

Цепи LX и 1V2 связаны последовательным элементом L1 ((понижающий преобразователь SMPS), которому следует задать соответствующее сопротивление. Для этого примера зададим достаточно высокое значение 0.2Ω.

Наконец, добавим U4 в качестве нагрузки 0.3A на цепь 1V2 и укажем соответствующее отклонение напряжения нагрузки +/-5%. Обратите внимание, что для этого примера пределы по плотности тока на вкладке Limits в диалоговом окне Settings должны быть заданы нулевыми (предел не задан – условие по умолчанию).

Запустите анализ и обратите внимание, что нагрузка в цепи LX показывает нарушение, поскольку напряжение цепи 1V2 на нагрузке U4 неприемлемо низкое (около 1.14V).

Измерения

Помимо визуальной интерпретации результатов расчёта в редакторе платы, PDN Analyzer предлагает ряд инструментов для получения результатов расчёта в определенной области или точке топологии платы, в частности, с помощью инструмента Probe.

Этот инструмент позволяет записать и сравнить данные о напряжении и плотности тока в заданных точках и, таким образом, точно оценить результаты расчёта в любой цепи или слое. В этом примере инструмент будет использован для того, чтобы убедиться в источнике недопустимого падения напряжения на нагрузке цепи 1V2, которым, по всей видимости, является последовательный элемент L1.

Чтобы провести сравнительное измерение напряжения в цепи 1V2 сначала задайте только отображение слоя MidLayer 1 (который является основным путем 1.2V кU4) и цепи 1V2. Нажмите кнопку , чтобы открыть диалоговое окно Probe, и выберите указание места первого измерения (). Используйте перекрестие курсора, чтобы определить точку наибольшего напряжения (источник цепи 1V2 на этом слое), затем поставьте флажок у параметра Difference (Разница) и укажите место второго измерения () – точка наименьшего напряжения, на нагрузке U4.

Обратите внимание, что в поле Difference отображено падение напряжения лишь около 3mV. Аналогично проведите измерение в цепи LX (слоиTop и Bottom активны) – падение напряжения будет лишь около 0.5mV.

Измерение разницы напряжений между двумя цепями (цепи LX и 1V2 включены, слои Top и Bottom Layer) покажет падение 60mV на катушке L1, которая является основным источником падения напряжения и нарушения анализа.

Хотя измерение напряжения в этом примере выявило основную причину потерь в цепи питания, эту проблему можно было бы решить быстрее, рассмотрев данные о напряжении на контактах устройства на вкладке Pins интерфейса PDN Analyzer. Инструмент Probe идеально подходит для более подробного исследования, где необходимо точное определение местоположения.

Импульсный источник с внешней обратной связью

Модель импульсного источника в этом примере может использовать катушку (L1) с намного меньшим значением сопротивления, но результаты расчёта здесь показывают, что базовая модель импульсного источника не может учесть потери на L1 – как правило, это не вызовет проблем в реальных схемах.

В этом примере цепи с импульсным источником, обратная связь по напряжению принимается U5 на контакте 8 через цепочку резисторов R25–R26, которая находится между выходной цепью 1V2 и цепью аналоговой земли AGND. Последняя связана с цепью GND через нуль-резистор R118.

Обратите внимание, что в демонстрационных целях исходный проект DB46 Xilinx Daughter Board rбыл изменен – в место прямого соединения цепей GND и AGND добавлен резистор R118.

Для более точного моделирования цепи возле U5 можно использовать модель импульсного источника с внешней обратной связью вместо стандартной модели SMPS. У этой модели есть отдельные терминалы S+ и S-, которые можно присоединить к любым контактам на указанной выходной цепи – например, к цепочке резисторов в этой схеме.

Первым шагом в построении более полной модели цепи импульсного регулятора U5 является добавление цепи AGND к существующей цепи GND. Выберите Extend Network и цепь AGND.

Цепь AGND соединена с цепью GND через резистор R118, как показано на схеме выше, значение Resistance которого следует задать .

Чтобы обновить модель импульсного источника в цепи LX, удалите существующий источник U5 (Source 1) и затем добавьте на его место модель импульсного источника с внешней обратной связью. Задайте соединения к терминалам IN и OUT так же, как в предыдущем случае. Терминалы обратной связи (S+/S-) необходимо присоединить к концам цепочки резисторов согласно схеме.

Добавьте модель из цепи LX к цепи 5V , удалив ее нагрузку U5 и затем применив опцию Add VRM To Existing Network » 5V к цепи LX.

Чтобы оценить результаты, обновленную цепь следует рассчитать заново. Как показано на рисунке ниже, напряжение нагрузки теперь находится в требуемых пределах +/-5%, и нарушение отсутствует. В соответствии с обратной связью выходного напряжения в цепи 1V2, импульсный источник компенсировал потери на последовательном элементе L1, поэтому напряжение в цепи LX на 60mV выше.

Хотя использование модели импульсного источника с внешней обратной связью в этой цепи позволило получить более точные результаты расчёта, на практике такие источники могут подключаться напрямую к нагрузке, а не к цепи обратной связи. В этом случае, обе линии S+ and S- могут проходить через проводники на плате, идущие к соответствующим выводам нагрузки.

Контур напряжений

Поиск оптимального расположения линии обратной связи импульсного источника (как описано выше) является одним из многочисленных применений инструмента Voltage Contour модуля PDN Analyzer, который графически показывает ключевые точки перехода напряжения в топологии платы.

Этот инструмент показывает пунктирные линии контуров напряжения на отображаемых слоях в редакторе платы. Можно указать и отобразить множество контуров, как в процентах от падения напряжения цепи, так и в абсолютных значениях – см. параметры в разделе Indicate.

Помимо отображения контуров с заданными значениями, с помощью опции Slider можно включить дополнительную линию, положение которой задается ползунком.

В этом примере было бы оптимально расположить точку нагрузки для импульсного источника в области с падением напряжения, меньшим, например, 20%, т.е. проводник положительной линии обратной связи от U5 (S+) следует присоединить к цепи питания 1V2 в любой удобной точке между контактами нагрузки U4 (слева) и линией контура напряжения 20%.

Аналогично, чтобы определить оптимальное расположение отрицательной линии обратной связи (S-) источника (U5), можно задать контур напряжения, например, 80% для возвратной цепи нагрузки (U4) на слое GND . В этом случае, поскольку это отрицательный возвратный ток нагрузки, желаемое расположение для соединения отрицательной линии обратной связи будет находиться в зоне контурной линии 80%.

Отчет о результатах расчёта

Чтобы сохранить результаты расчёта целостности питания для дальнейшей проверки или их передачи сотрудникам, PDN Analyzer предлагает инструмент Report для сохранения и документирования данных. Этот инструмент создает комплексный отчет в формате HTML, которые включает в себя текстовые и графические данные по текущему расчёту и самой плате.

Нажмите кнопку , чтобы настроить параметры отчета в диалоговом окне HTML Report. Поставьте флажки в разделе Results , чтобы задать набор данных, которые будут включены в отчет, и просмотрите изображения, добавленные в папку отчета () – используйте кнопку , чтобы сохранить изображения с результатами анализа.

Нажмите кнопку , чтобы создать интерактивный HTML-отчет и открыть его главную папку, в которой содержатся все изображения и файл конфигурации анализа (*.pdna).

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.