Đồng bộ hóa dữ liệu cơ sở dữ liệu chuỗi cung ứng vào Workspace

Sơ lược

Đảm bảo dữ liệu nhà cung cấp trong Workspace luôn nhất quán với các nguồn dữ liệu nội bộ của tổ chức bằng tính năng Đồng bộ hóa nhà cung cấp linh kiện tùy chỉnh trong Altium Designer. Bài viết này hướng dẫn cách kết nối cơ sở dữ liệu, bảng tính hoặc tệp CSV, ánh xạ thông tin nhà cung cấp với các lựa chọn linh kiện trong Workspace và đồng bộ hóa các cập nhật theo yêu cầu hoặc theo lịch. Đọc tiếp để tìm hiểu cách đưa dữ liệu nhà cung cấp của công ty vào Workspace.

- Tìm hiểu cách tạo cấu hình đồng bộ hóa và kết nối các nguồn dữ liệu được hỗ trợ.
- Nắm được cách ánh xạ các tham số nhà cung cấp và các mức giá theo số lượng, sử dụng mã linh kiện của nhà sản xuất để liên kết các mục dữ liệu nhà cung cấp với linh kiện trong Workspace.
- Khám phá cách chạy hoặc lên lịch đồng bộ hóa và tìm dữ liệu nhà cung cấp linh kiện tùy chỉnh sau khi đồng bộ trong Altium Designer.
Tìm hiểu sâu hơn với AI:

Thông qua khái niệm Lựa chọn linh kiện, các linh kiện được lưu trữ trong Altium 365 Workspace hoặc Enterprise Server Workspace có thể được liên kết với các linh kiện thực tế từ nhà cung cấp, dựa trên mã linh kiện của nhà sản xuất đã được chỉ định. Theo mặc định, dữ liệu chuỗi cung ứng này được lấy từ dịch vụ đám mây Altium Parts Provider và bao gồm thông tin linh kiện theo thời gian thực từ nhà cung cấp như lượng hàng tồn kho, đơn giá và các ngưỡng số lượng áp dụng mức giá khác nhau.

Tuy nhiên, đối với nhiều tổ chức, dữ liệu nhà cung cấp linh kiện được (và bắt buộc phải được) lấy từ hệ thống doanh nghiệp nội bộ, nơi cung cấp bộ dữ liệu nhà cung cấp linh kiện riêng — có thể dựa trên danh sách nhà cung cấp được phê duyệt nghiêm ngặt và/hoặc các cơ cấu giá đặc biệt. Nhu cầu này được đáp ứng bằng giải pháp thay thế Custom Parts Provider của Altium. Khi được cấu hình để đồng bộ hóa thông qua Altium Designer, giải pháp này cho phép ánh xạ dữ liệu nhà cung cấp từ một nguồn cơ sở dữ liệu được chỉ định sang dữ liệu chuỗi cung ứng của Workspace.

Sử dụng tính năng Custom Parts Provider Synchronization của Altium Designer như trình bày bên dưới, dữ liệu nhà cung cấp từ một bảng được chọn trong cơ sở dữ liệu chính được ánh xạ để trở thành nguồn dữ liệu thay thế cho các Lựa chọn linh kiện được thiết lập trong Altium Designer. Trên thực tế, cấu hình ánh xạ bạn tạo được sử dụng để đồng bộ hóa cơ sở dữ liệu nguồn với dữ liệu nhà cung cấp trong Workspace theo lịch hoặc theo yêu cầu. Nhờ đó, các cập nhật dữ liệu nhà cung cấp trong cơ sở dữ liệu chính sẽ được truyền tới dữ liệu nhà cung cấp linh kiện tương ứng trong Workspace được kết nối.

Tính năng này cho phép các công ty quản lý tập trung dữ liệu nhà cung cấp linh kiện trong cơ sở dữ liệu của hệ thống doanh nghiệp tận dụng lợi ích của Altium Workspace, đồng thời duy trì đồng bộ hóa với hệ thống doanh nghiệp của họ (PLM, PDM, ERP, v.v.) — hoặc đơn giản là với một cơ sở dữ liệu dùng chung hay tệp CSV. Ở chế độ tự động đồng bộ hóa, tác vụ Windows được lên lịch sẽ thực hiện cập nhật dữ liệu từ cơ sở dữ liệu sang Workspace độc lập với ứng dụng thiết kế Altium Designer.

Để sử dụng khả năng đồng bộ hóa nhà cung cấp linh kiện tùy chỉnh trong Altium Designer, tính năng Custom Data Synchronization phải được bật trong bản cài đặt Altium Designer của bạn. Bạn có thể bật/tắt tính năng này sau khi cài đặt.

Để biết thêm thông tin về cách thay đổi các chức năng cốt lõi đã cài đặt, hãy tham khảo trang Installing & Managing (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Tạo cấu hình đồng bộ hóa nhà cung cấp linh kiện tùy chỉnh

Việc đồng bộ hóa dữ liệu nhà cung cấp linh kiện từ cơ sở dữ liệu sang Workspace được thiết lập bằng cách tạo và cấu hình tài liệu Custom Parts Provider Synchronization Configuration (*.PrtSync) trong Altium Designer. Giao diện và chức năng của tài liệu này tương tự như Components Synchronizer. Khi đã kết nối với Altium Workspace, hãy tạo tài liệu mới bằng lệnh menu File » New » Custom Parts Provider Synchronization Configuration.

Thêm nguồn dữ liệu chính mong muốn vào cấu hình đồng bộ hóa bằng nút hoặc bằng cách kéo và thả các tệp dữ liệu tương thích vào vùng Data Sources của giao diện. Cấu hình hỗ trợ các nguồn dữ liệu tham số linh kiện sau:

  • Tệp cơ sở dữ liệu Access (*.mdb, *.accdb)

  • Bảng tính Excel (*.xlsx)

  • Tệp CSV (*.csv)

  • Các nguồn dữ liệu khác, chẳng hạn như giao diện tương thích OLE DB trên máy chủ (bao gồm cơ sở dữ liệu PostgreSQL), thông qua chuỗi kết nối riêng. Xem phần Cấu hình MySQL bên dưới để biết quy trình kết nối MySQL ODBC.

Để kết nối cơ sở dữ liệu, Parts Provider Synchronizer cần có quyền truy cập vào phiên bản 64 bit của Microsoft OLE DB Provider.

Trong ví dụ ở đây, một cơ sở dữ liệu chứa dữ liệu nhà cung cấp linh kiện (cho các linh kiện điốt Zener) đã được thêm vào cấu hình. Cơ sở dữ liệu nguồn (SupplierData.mdb) chứa hai bảng — CustomSupplierParts1 và CustomSupplierParts2 — trong đó bảng đầu tiên được bật để ánh xạ và đồng bộ hóa.

Ánh xạ tham số dữ liệu nhà cung cấp

Cấu hình nhà cung cấp linh kiện tùy chỉnh mới truy cập bảng cơ sở dữ liệu dưới dạng nguồn dữ liệu tham số. Khi bảng được chọn trong cây Data Sources của cấu hình, bảng có thể được ánh xạ sang các tham số dữ liệu nhà cung cấp tiêu chuẩn mà Altium Designer và Altium Workspace sử dụng.

Lưu ý rằng tham số khóa (mã định danh duy nhất) liên kết các bản ghi dữ liệu nhà cung cấp với linh kiện trong Workspace là Manufacturer Part Number.

Vì vậy, trong ví dụ được trình bày ở đây, một linh kiện trong Workspace có giá trị Manufacturer Part Number (Tên) là 1N4741A sẽ được cung cấp dữ liệu nhà cung cấp tùy chỉnh từ các bản ghi trong cơ sở dữ liệu nguồn có giá trị Part Number là 1N4741A — xem ánh xạ tham số trong bảng điều khiển Properties bên dưới.

Các tham số dữ liệu nhà cung cấp được ánh xạ từ cơ sở dữ liệu nguồn sang cấu hình nhà cung cấp linh kiện trong vùng Parameter Mapping của bảng điều khiển Properties. Sử dụng các tùy chọn trong menu thả xuống của mục Column để chọn tham số cơ sở dữ liệu nguồn khớp chính xác với tham số dữ liệu nhà cung cấp hoặc để loại bỏ một tham số khỏi quá trình đồng bộ hóa (<Skip>). Mỗi bộ dữ liệu tham số được thêm vào danh sách Components Preview khi được ánh xạ. Bạn có thể sắp xếp lại các cột này bằng cách kéo tiêu đề cột và bật/tắt chúng thông qua menu Select Columns (truy cập bằng cách nhấp chuột phải vào tiêu đề cột).

Hệ thống hỗ trợ một số tham số dữ liệu nhà cung cấp, bao gồm Manufacturer Name, Manufacturer Part Number, Category, Datasheet, v.v. Bạn cũng có thể thêm và xóa các tham số dữ liệu nhà cung cấp tùy chỉnh bằng các nút  và  trong vùng Parameter Mapping của bảng Properties.

Các ngưỡng chiết khấu theo số lượng linh kiện biểu thị số lượng linh kiện cần đặt từ một nhà cung cấp để được giảm đơn giá. Số lượng đặt hàng yêu cầu thường được chia thành các mức tăng gấp mười lần – 10 chiếc, 100 chiếc, v.v. – và được hỗ trợ trong các mục Lựa chọn linh kiện thuộc dữ liệu nhà cung cấp của Altium.

Dữ liệu số này có thể được ánh xạ từ các mục trong cơ sở dữ liệu nguồn sang dữ liệu nhà cung cấp trên Workspace bằng cách thêm các mục ngưỡng chiết khấu Quantity trong phần Price Breaks của bảng Properties – với số lượng tăng tuần tự gấp mười lần – rồi ánh xạ các mục đó tới các trường cơ sở dữ liệu phù hợp. Lưu ý rằng tham số chi phí unit thông thường (Price) nằm trong phần Parameter Mapping chung.

Tham số cơ sở dữ liệu nguồn được ánh xạ tới tham số dữ liệu nhà cung cấp hệ thống Product Photo URL hỗ trợ URI chứa đường dẫn đầy đủ tới hình ảnh. Đường dẫn này có thể trỏ tới một tài nguyên cục bộ (ví dụ: C:\Component_Images\smd_cap.png) hoặc một tài nguyên trên Internet (ví dụ: http://my-website/images/smd_cap.png). Tất cả các định dạng hình ảnh tiêu chuẩn (*.bmp, *.png, *.jpeg, *.jpg, v.v.) đều được hỗ trợ.

Đồng bộ hóa từ cơ sở dữ liệu lên Workspace

Khi đã hài lòng với thiết lập ánh xạ dữ liệu nhà cung cấp, hãy lưu tài liệu cấu hình trình cung cấp linh kiện tùy chỉnh (File » Save) và thực hiện đồng bộ hóa dữ liệu từ cơ sở dữ liệu nguồn lên máy chủ bằng nút , hoặc thiết lập đồng bộ hóa theo lịch (). Bước đồng bộ hóa ban đầu sẽ tải dữ liệu nhà cung cấp đã ánh xạ từ cơ sở dữ liệu của công ty lên Altium Workspace, và các chu kỳ đồng bộ hóa tiếp theo sẽ cập nhật dữ liệu đó.

Các tệp nhật ký đồng bộ hóa chi tiết có trong thư mục C:\Users\Public\Documents\Altium\Logs\ComponentSync của hệ thống.

Trong ví dụ minh họa ở đây, dữ liệu nhà cung cấp của các linh kiện điốt Zener đã được đồng bộ hóa từ cơ sở dữ liệu nguồn lên Workspace sẽ xuất hiện dưới dạng dữ liệu Custom Parts Provider cho các linh kiện đó – bên cạnh dữ liệu nhà cung cấp linh kiện thông thường do dịch vụ đám mây Altium Parts Provider cung cấp.

Bạn có thể thấy ngay điều này trong bảng Manufacturer Part Search khi chọn danh mục Custom Parts Provider. Bảng này sẽ đưa ra các phương án cung ứng linh kiện thông qua dịch vụ Custom Parts Provider, được đồng bộ hóa từ cơ sở dữ liệu nhà cung cấp của tổ chức bạn.

Các tham số Category và Datasheet cũng như các tham số tùy chỉnh đều được hỗ trợ trong bảng Manufacturer Part Search ().

Tính năng này khả dụng khi tùy chọn EDMS.CustomOffersMerge được bật trong hộp thoại Advanced Settings. Lưu ý rằng tính năng này chỉ khả dụng khi kết nối với một Workspace trên Altium Platform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) có bật BOM Portal. Tính năng này không khả dụng khi kết nối với Enterprise Server Workspace triển khai tại chỗ.

Hợp nhất dữ liệu nhà cung cấp

Tính năng này khả dụng khi tùy chọn EDMS.CustomOffersMerge được bật trong hộp thoại Advanced Settings. Lưu ý rằng tính năng này chỉ khả dụng khi kết nối với một Workspace trên Altium Platform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) có bật BOM Portal. Tính năng này không khả dụng khi kết nối với Enterprise Server Workspace triển khai tại chỗ.

Nếu tên nhà sản xuất và mã linh kiện của nhà sản xuất của một linh kiện trong cơ sở dữ liệu nhà cung cấp mà bạn đã đồng bộ hóa trùng với tên nhà sản xuất và mã linh kiện của nhà sản xuất của một linh kiện do Altium Parts Provider cung cấp, thì dữ liệu nhà cung cấp từ Custom Parts Provider mà bạn đã cấu hình sẽ được hợp nhất với dữ liệu của Altium Parts Provider để hiển thị tổng hợp mọi thông tin nhà cung cấp tại bất kỳ nơi nào dữ liệu nhà cung cấp (SPN) xuất hiện trong giao diện phần mềm, bao gồm bảng Manufacturer Part Search , ActiveBOM và bất cứ khi nào thêm lựa chọn linh kiện.

Lựa chọn linh kiện từ dữ liệu của trình cung cấp tùy chỉnh

Khi thêm thông tin Lựa chọn linh kiện vào các mục linh kiện trong bảng Components (nhấp chuột phải, Operations » Create/Edit PCL), dữ liệu nhà cung cấp do Custom Parts Provider cung cấp sẽ xuất hiện ở đầu danh sách trong hộp thoại Add Part Choices – như minh họa ở đây cho mục điốt Zener 1N4747A. Mục được chọn (được tô sáng) sẽ được thêm làm một Lựa chọn linh kiện cho linh kiện đang chọn trong bảng Components.

Hộp thoại Add Part Choices sẽ được điền dữ liệu nhà cung cấp từ các dịch vụ Parts Provider hiện được bật trên trang Catalog Management của Workspace đang kết nối (Admin » Part Providers). Cả Altium Parts Provider và Custom Parts Provider đều được bật theo mặc định.

Tương tự dịch vụ Altium Parts Provider, Custom Parts Provider cũng hỗ trợ dữ liệu nhà cung cấp cho nhiều nhà sản xuất và từ nhiều nhà cung cấp – dữ liệu này được lấy từ nhiều mục riêng biệt trong bảng cơ sở dữ liệu nguồn. Cũng lưu ý rằng dữ liệu của trình cung cấp tùy chỉnh sẽ bao gồm thông tin ngưỡng chiết khấu theo số lượng và mức tồn kho được đồng bộ hóa từ cơ sở dữ liệu nguồn.

Ngoài bảng Components như minh họa ở đây, thông tin Lựa chọn linh kiện từ nhà cung cấp có thể được gắn vào một tham chiếu linh kiện trong các giao diện Altium Designer sau:

Lưu ý rằng khi dữ liệu nhà cung cấp thay đổi trong cơ sở dữ liệu nguồn, dữ liệu Custom Parts Provider trên Workspace sẽ tiếp nhận những thay đổi này khi quá trình đồng bộ hóa tiếp theo chạy – dù được kích hoạt thủ công hay bởi dịch vụ lập lịch. Làm mới các chế độ xem trong giao diện Altium Designer (được liệt kê ở trên) bằng phím F5 hoặc nút để xem dữ liệu nhà cung cấp mới nhất.

Đồng bộ hóa theo lịch

Các cấu hình đồng bộ hóa linh kiện đã lưu được thiết lập để tự động xử lý dữ liệu từ cơ sở dữ liệu lên Workspace thông qua hộp thoại Auto Synchronization Schedule, được mở bằng nút trong giao diện chính.

Đồng bộ hóa theo lịch, tuân theo hồ sơ cấu hình hiện tại, có thể được thiết lập để chạy vào một thời điểm cụ thể mỗi ngày, vào một thời điểm nhất định trong các ngày được chọn trong tuần hoặc khi bạn đăng nhập vào Windows. Bạn cũng có thể tắt đồng bộ hóa khi chưa đăng nhập. Khi bạn xác nhận thiết lập bằng nút , cấu hình sẽ được thêm dưới dạng một tác vụ lặp lại trong Windows Task Scheduler. Đặt thành No automatic synchronization để xóa lịch đồng bộ hóa hiện có.

Việc đồng bộ hóa dữ liệu từ cơ sở dữ liệu sang dữ liệu linh kiện cũng có thể được chạy thủ công từ dòng lệnh bằng ứng dụng ComponentSync.Executor.exe, nằm trong thư mục \System của bản cài đặt phần mềm. Cú pháp lệnh là ComponentSync.Executor.exe [configuration file name]. Cấu hình MyPrtSyncConfig trong ví dụ này đã được chạy như minh họa trong hình bên dưới, sử dụng chuỗi lệnh:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync

Tùy thuộc vào hệ điều hành, các đường dẫn chứa dấu cách có thể cần được đặt trong dấu ngoặc kép (như minh họa ở đây).

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Nav
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents