浏览文档

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

处理原理图图纸、PCB 文档或 Draftsman 文档等图形文档时,您可以缩放和平移文档,以聚焦于文档的特定区域。可用于这些操作的基本快捷键如下:

  • Ctrl+Mouse Wheel 用于放大和缩小
  • Right-Click, Hold&Drag 用于平移文档

View 主菜单包含多个命令,可用于控制当前文档的视图。

使用 View 主菜单中的命令可控制文档视图。上图显示了原理图编辑器的 View 菜单,下图显示了 PCB 编辑器的 View 菜单。

使用 View 主菜单中的命令可控制文档视图。上图显示了原理图编辑器的 View 菜单,下图显示了 PCB 编辑器的 View 菜单。

这些命令包括:

  • Fit Document - 显示当前文档的整个区域。

  • Fit All Objects - 显示当前文档中的所有设计对象。

  • Area - 放大当前文档中用户定义的区域。

  • Around Point - 以当前文档中的指定点为中心,重新定义显示区域。

  • Selected Objects - 调整设计空间中的视图,使所有选定对象均可见。

  • Zoom In - 在当前文档中,以光标位置为基准放大设计。

  • Zoom Out - 在当前文档中,以光标位置为基准缩小设计。

  • Zoom Last - 将当前文档的显示恢复到上一个屏幕视图。

您也可以使用 Z 快捷键访问包含缩放命令的弹出菜单。

在 PCB 和 PCB 封装编辑器中,您可以通过此菜单访问 Select 命令,打开 Zoom Value (0.001x..4x) 对话框,在其中按指定数值调整当前文档的显示倍率。输入大于 1 的值可进一步放大(增加显示倍率),输入小于 1 的值可进一步缩小(降低显示倍率)。

Zoom Value 对话框
Zoom Value 对话框

以 3D 模式查看 PCB 或 PCB 封装文档时,还可以使用其他命令、快捷键和控件来流畅地浏览视图。有关更多信息,请参阅控制 3D 视图页面。

跳转到文档中的指定点

使用原理图、原理图符号、PCB 或 PCB 封装编辑器主菜单中 Edit » Jump 子菜单的命令,可以跳转到当前文档中的指定点。在设计空间中按 J 键也可以访问“跳转”弹出菜单。例如,您可以跳转到:

  • 文档的原点坐标:
    • 原理图图纸的原点(位于左下角)- Origin;

    • PCB 文档的绝对原点 - Absolute Origin;

    • 当前 PCB 文档的相对原点 - Current Origin;

    • PCB 封装文档中的元件参考点位置 - Reference;

  • 当前文档中由用户指定 XY 坐标的任意位置 - 选择 New Location 命令,在弹出的 Jump To Location 对话框中输入希望光标跳转到的设计空间位置的 X 和 Y 坐标值。在 PCB 编辑器中,还可以使用 Delta X 和 Delta Y 字段指定目标跳转位置的 X 和 Y 坐标增量。

    Jump To Location 对话框 - 原理图编辑器中(第一张图)和 PCB 编辑器中(第二张图)
    Jump To Location 对话框 - 原理图编辑器中(第一张图)和 PCB 编辑器中(第二张图)

  • 文档中的对象。使用以下命令可跳转到所需对象:
    • 原理图图纸上的元件 - Jump Component。启动此命令后,将显示 Component Designator 对话框。输入要跳转到的元件的位号。如果位号有效,且该元件存在于当前项目的某个原理图源文档中,则相应的原理图文档将成为当前文档,并在设计空间中缩放显示目标元件,使其尽可能居中。找到的元件(对于多部件元件,则为其所有部件)也会列在 Messages 面板中。双击某个消息条目,即可在设计空间中跳转到该元件(或其部件)。

      Component Designator 对话框
      Component Designator 对话框

      定位多部件元件时,只需输入根位号,不要包含部件后缀。例如,要跳转到一个包含 2 个部件的 IC 元件,其部件位号分别为 IC1_CPA 和 IC1_CPB,请在 Component Designator 对话框中输入 IC1_CP。对于多部件元件,第一个部件将高亮显示,同时打开 Find Text - Jump 对话框。使用此对话框可在元件的各个子部件之间跳转。
      在 Component Designator 对话框中启用 Physical 选项,可将跳转功能限制为仅使用物理元件位号,即原理图源文档的 Compiled Document 选项卡视图中显示的位号。禁用此选项后,跳转功能将仅使用逻辑位号,即原理图源文档的 Editor 选项卡视图中显示的位号。
    • PCB 文档中的特定元件 - Component。启动此命令后,将显示 Component Designator 对话框。输入元件位号即可跳转到该元件。如果不确定位号,请输入 ? 并单击 OK ,打开 Components Placed 对话框,其中列出了设计中的所有元件。在 Mask 字段中输入文本,以搜索所需元件。随着文本的输入,列表会进行筛选,仅显示与匹配字符串相符的字符串。您可以在字符串中使用通配符 ?(任意单个字符)和 *(任意字符)。光标将跳转到所选元件的参考点。

      在 Component Designator 对话框中输入 ?,即可打开 Components Placed 对话框,其中列出了 PCB 中的所有元件。
      在 Component Designator 对话框中输入 ?,即可打开 Components Placed 对话框,其中列出了 PCB 中的所有元件。

    • PCB 文档中的特定网络 - Net。启动此命令后,将显示 Net Name 对话框。输入要跳转到的网络名称,或输入 ? 并按 OK ,打开 Nets Loaded 对话框,其中列出了设计中所有已加载的网络。在 Mask 字段中输入文本,以搜索所需网络。随着文本的输入,列表会进行筛选,仅显示与匹配字符串相符的字符串。您可以在匹配字符串中使用通配符 ?(任意单个字符)和 *(任意字符)。如果目标网络已显示在主设计窗口中,光标将跳转到属于该网络的最近设计对象。如果该网络位于当前视图之外,光标将定位到属于该网络的最近设计对象,并使该对象尽可能在设计空间中居中显示。

      在 Net Name 对话框中输入 ?,即可打开 Nets Loaded 对话框,其中列出了 PCB 中的所有网络。在 Net Name 对话框中输入 ?,即可打开 Nets Loaded 对话框,其中列出了 PCB 中的所有网络。

    • PCB 文档中的特定元件焊盘 - Pad。启动该命令后,将显示 Jump To Pad Number 对话框。以 ComponentDesignator-PadDesignator 的格式输入目标元件所需的焊盘(例如 U1-6),然后单击 OK。如果目标焊盘已显示在设计空间中,光标将直接跳转到该焊盘的中心。如果焊盘不在当前视图内,光标将定位到焊盘中心,并在可能的情况下将其居中显示在设计空间中。

      Jump To Pad Number 对话框
      Jump To Pad Number 对话框

    • PCB 文档中的特定字符串 - String。启动该命令后,将显示 Jump To String 对话框。输入要跳转到的字符串,或输入 ? 并单击 OK ,以打开 Strings 对话框,其中列出了当前活动 PCB 文档中的所有字符串(包括独立字符串和其他组合对象的子对象字符串)。使用此对话框可快速找到要跳转到的字符串。如果目标字符串已显示在设计空间中,光标将直接跳转到该字符串的锚点,即移动操作中抓取该字符串的点,或旋转操作所围绕的点。如果字符串不在当前视图内,光标将定位到该字符串的锚点,并在可能的情况下将其居中显示在设计空间中。

      在 Jump To String 对话框中输入 ?,即可打开 Strings 对话框,其中列出了 PCB 中的所有网络。
      在 Jump To String 对话框中输入 ?,即可打开 Strings 对话框,其中列出了 PCB 中的所有网络。

      系统将执行三次搜索:首先搜索大小写、字符和长度均与指定字符串完全匹配的字符串;然后搜索包含相同字符、但可能含有更多字符的字符串;最后搜索包含相同字符但不区分大小写的字符串。

    • 跳转到当前设计文档中的所有错误标记,并在这些标记之间循环切换 - Error Marker。启动该命令后,光标将跳转到第一个设计规则检查(DRC)错误标记,并将其居中显示在主设计窗口中。重复使用该命令将跳转到第二个错误标记,依此类推。无论违规是否已被豁免,此命令都会跳转到相应的错误标记。

      右键单击并从 Violations 子菜单中选择相应命令,即可查看光标下对象所关联的违规情况。

  • 跳转到当前文档中的所有选定设计对象,并在这些对象之间循环切换 - Selection。启动该命令后,光标将跳转到第一个选定对象,并在主设计窗口中缩放并居中显示该对象。重复使用该命令将跳转到第二个选定对象,依此类推,循环遍历当前文档中的所有选定对象。该命令按照对象最初被加入选择集的顺序,在选定对象之间循环切换。

  • 当前原理图或 PCB 文档中的某个位置,其坐标已预先存储在指定的位置标记中 - 选择 Location Marks » n 命令,即可跳转到使用 Set Location Marks » n 命令存储在指定位置标记中的位置。

    对于原理图文档,存储的位置仅在文档保持打开状态时可用(无论是否为活动文档)。如果关闭文档后重新打开,位置标记将为空。对于 PCB 文档,位置标记会随设计一起保存,因此在不同设计会话之间,仍可访问其中包含的用户定义位置。
AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。