导航面板
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概览
- 了解如何通过 Navigator 面板浏览单张原理图、整个项目以及设计层次结构,快速查找相连的对象。
- 了解如何在面板与原理图之间进行双向导航,以及在什么情况下可以使用 Alt+单击来定位相关的 PCB 对象。
- 理解高亮显示、缩放、调暗和验证如何影响导航时的显示效果,以便更清楚地追踪复杂设计中的连接关系。
如果设计规模较大,分布在多张图纸上,仅通过查看原理图来追踪网络并验证设计中的连接关系就会变得困难。而要在 PCB 上定位这些相同的对象,则更具挑战性。为帮助完成这一过程,可以使用 Navigator 面板。

使用 Navigator 面板查看整个设计。按住 Alt 并在面板中单击,还可以在 PCB 上定位相应对象。
Navigator 面板允许您浏览当前活动的源原理图文档,或活动项目中的所有源原理图文档。该面板以在后台自动创建的设计连接模型为导航基础。 该面板还可用于导航至 PCB 上的元件、焊盘、总线和网络。
设计导航
导航可通过两种方式进行:在 Navigator 面板中单击以在原理图中定位对象,或在原理图中单击对象以在 Navigator 面板中定位该对象。
从 Navigator 面板导航
要显示 Navigator 面板,请使用软件右下角的 Panels 按钮,或从菜单中选择 View » Panels » Navigator。
打开原理图后,元件和连接信息会立即加载到面板中,单击 Documents 区域中的图标即可显示这些信息。软件会自动为整个项目构建动态数据模型,并在执行编辑操作时维护该模型。请注意,并非所有原理图图纸都会在图形编辑区域顶部显示文档选项卡(它们会在后台打开),只有当用户对某张图纸执行操作时,才会显示该图纸的选项卡。
每个编辑器以及 Navigator 面板均可使用动态数据模型。如果您不确定面板内容是否与设计的当前状态一致,可选择 Validate Project 命令强制刷新模型(位于 Project 菜单或 Navigator 面板的右键上下文菜单中)。

在 Navigator 面板中单击某个对象,即可在整个设计中定位该对象的所有实例。
交互式导航
除了从面板中显示的对象列表进行导航,并通过单击在图形区域中定位对象外,您还可以从图形区域反向导航到列表。这称为交互式导航,可通过单击 Navigator 面板顶部的 Interactive Navigation 按钮启动。光标会变为十字形,表示您已进入导航模式;此模式会一直保持,直到您单击鼠标右键或按下 Esc 键。
在设计中导航时,图纸显示会根据当前的高亮选项更新, Navigator 面板也会更新,显示与您在图形编辑窗口中当前所选对象相关的信息。

启动交互式导航(通过 Navigator 面板顶部的按钮),然后单击图纸上的对象,即可在面板及设计的其余部分中定位该对象。
交互式导航快捷键
除了从 Navigator 面板启动交互式导航外,您还可以随时在原理图编辑器中调用导航功能:按住 Alt 并单击设计对象即可。您可以单击任意对象,包括导线、网络标签、端口、图纸入口、图纸符号或元件。
使用 Alt+单击快捷键在设计中导航。
导航期间对象的高亮显示方式
在 Navigator 面板中单击对象时,该对象会显示在图形编辑区域中。对象的显示方式取决于 Preferences 对话框中的 系统 - 导航 设置。要直接从 Navigator 面板访问这些设置,请单击面板顶部的 Navigation Options 按钮(
)以打开对话框。
Preferences 对话框中的 Highlight Methods 区域提供了一组选项,用于控制从面板或文档内部进行导航时,对文档应用的临时过滤的视觉效果。 这些选项可以任意组合启用。例如,您可能希望在设计编辑器窗口中缩放并选中所有过滤后的对象, 同时淡化其他设计对象,以减少视觉干扰。
Navigator 面板
Navigator 面板提供了设计的连接模型视图。设计结构显示在面板的四个区域中,下面将逐一介绍。
文档区域
位于面板顶部的 Documents 区域提供了三种不同的设计查看方式: individual sheets、flattened hierarchy(整个项目),或浏览 full design hierarchy。单击此第一区域中的图标可将数据加载到面板中,双击则还会在图形编辑区中显示结果。
文档区域的功能
元件区域
面板的第二区域包含第一区域中当前选定文档内的所有元件。当您在列表中选择顶层元件实例条目时,将根据该条目应用过滤,其视觉效果由所选的高亮显示方式决定。如果已启用的高亮显示选项 包含 Connective Graph 选项,则连接到所选元件的所有其他元件都将可见(过滤范围已扩展为包含这些元件)。相连的元件通过绿色连接图线进行高亮显示。
由于启用了连接图,系统会为连接到面板中所选元件的每个元件绘制一条绿色线。
元件区域的功能
元件区域 |
|
| Information available | 每个元件条目下都有 Parameters 和 Implementations (模型)子文件夹。如果在 高亮显示选项中启用了 Pins 选项,则还会显示 Pins 子文件夹 。 |
| When you click | 当您单击 Instance 列表中的引脚条目时,面板的 Net / Bus 区域中该引脚对应的条目将被选中, 其所属网络的所有引脚都将列在面板底部区域中。同时,还会根据您选择的引脚条目应用过滤,其视觉效果由已启用的高亮显示方式决定。 |
| Connective Graph | 如果您启用了 Connective Graph 选项,则连接到所选引脚所属网络的所有其他引脚都将可见(过滤范围已扩展为包含这些引脚)。相连引脚所属的网络通过红色连接图线进行高亮显示 。 |
网络/总线区域
面板的第三个区域列出了正在浏览的文档(或展平后的层次结构)中的各个网络和总线。单击某个条目时,与该网络/总线关联的所有对象(引脚、网络标签、端口、图纸入口和跨图纸连接器)都将按照已启用的高亮显示方式显示在设计编辑器窗口中 。
网络/总线区域的功能
网络/总线区域 |
|
| Information available | 与所选网络/总线关联的各类对象会列在子文件夹中,具体取决于当前启用的高亮显示选项 以及当前所选网络/总线中是否存在该类型的对象。 每个网络/总线还可以包含一个额外的子文件夹,用于列出连接相关引脚/端口/网络标签/图纸入口/跨图纸连接器的所有图形线。单击某个线条目,可仅筛选该线对象并应用 视觉控制设置。 |
| When you click | 所有已启用面板显示的网络对象(图形线除外)都会显示在面板底部区域( )中。同样,单击其中任一对象都会按照已启用的高亮显示方式进行筛选。 |
总线网络 - 网络引脚区域
面板第四个区域的内容取决于两点:您正在浏览的对象,以及您已设置为显示的对象。如果单击网络/总线区域中的 bus,则该总线中的网络将列在此区域中。如果单击 网络/总线区域中的 net,则会列出该网络中的引脚。如果已启用相应的显示选项,还会列出附加到该网络的网络标识符。
信号区域
Navigator 面板支持以信号为中心查看设计,而不是采用通常以对象为中心的方式呈现设计。如果在面板的 Documents 区域中选择了一个原理图文档,则启用面板顶部的 Show Signals 选项会将面板的第三个区域切换为 Signal 模式。
单击 某个信号条目可应用筛选,该信号的节点(引脚/端口/网络标签/图纸入口/跨图纸连接器)将按照已启用的高亮显示方式显示在设计编辑器窗口中。 对于列表中的每个信号,都会列出与该信号关联的节点引脚、图纸入口或跨图纸连接器。无论是否启用了相应对象类型的显示选项,这些条目都会显示 。
信号区域的功能
信号区域 |
|
| Signal | 信号名称(总线或网络名称)。 |
| Width | 此信号中独立网络的数量。 |
| Click on a top-level signal entry | 单击顶层信号条目,可在面板底部区域列出与该信号关联的所有信号节点。这些节点可以包括引脚、网络标签、端口、图纸入口和跨图纸连接器。只有启用了相应对象类型的显示选项,才会显示对应条目。 |
| Click on a sub-entry | 单击主信号 列表中的子条目,可在面板底部区域列出与该信号所属的父网络关联的所有网络对象。 |
| SignalName Driven By Pin X | 当与信号关联的节点引脚为输出引脚或 I/O 引脚时显示。 X 表示驱动该信号的元件-引脚标识符 。 |
| Driving Node Pin X | 当与信号关联的节点引脚为输入引脚时显示。 X 表示由该信号驱动的元件-引脚标识符 。 |
| Driven By Node Sheet Entry SignalName | 当图纸入口节点的电气类型为输出或 I/O 时显示,表示该入口正在驱动信号。 |
| Driving Node Sheet Entry X | 当图纸入口的电气类型为输入时显示,表示该入口由信号驱动。 |
在 PCB 中导航
在 Navigator 面板中单击以导航到原理图中的对象时,还可以同时导航到 PCB 上的对应对象。 如果在 Navigator 面板中单击对象时按住 Alt 键,目标对象将同时在原理图和 PCB 中高亮显示。
由于导航始终在原理图中进行,因此要导航到 PCB 上的对象,需要同时显示原理图和 PCB。您可以将 PCB 显示在单独的窗口中,也可以使用 Split Vertical 或 Split Horizonal 功能来共享图形显示区域(下图显示的是垂直方式)。右键单击文档标签页,即可在上下文菜单中找到这些命令。
浏览设计时按住 Alt 键,还可在 PCB 上定位相应对象。
Altium Designer 提供了多项用于在原理图与 PCB 之间协同工作的功能,包括:
| Cross probe | 交叉探查 - 右键单击以启动,然后在一个编辑器中单击某个对象(元件、引脚、网络),即可跳转到另一个编辑器中的对应对象。此功能有两种模式:continuous(停留在源编辑器中)或 jump-to(将目标编辑器/文档设为活动文档)。进行交叉探查时按住 Ctrl,即可调用 jump-to 模式。 可从以下位置发起交叉探查:原理图、PCB 和 BOM 编辑器;约束管理器;以及 Project、Navigator 和 Messages 面板。 |
| Cross select | 在一个编辑器中单击选中某个元件,也会在另一个编辑器中选中该元件。此功能支持在原理图和 PCB 编辑器之间使用,可在 View 菜单中启用。 |
了解有关交叉探查和交叉选择
的更多信息。Navigator 面板上下文菜单
Navigator 面板的右键上下文菜单包含以下命令:
)在历史记录中前后切换。
)
)



)
)
)

)中。同样,单击其中任一对象都会按照已启用的高亮显示方式进行筛选。
