In einem Dokument navigieren

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Wenn Sie mit einem grafischen Dokument arbeiten, beispielsweise einem Schaltplanblatt, einem PCB-Dokument oder einem Draftsman-Dokument, können Sie die Ansicht vergrößern, verkleinern und verschieben, um einen bestimmten Dokumentbereich in den Fokus zu rücken. Dafür stehen Ihnen die folgenden grundlegenden Tastenkombinationen zur Verfügung:

  • Ctrl+Mouse Wheel zum Vergrößern und Verkleinern
  • Right-Click, Hold&Drag zum Verschieben des Dokuments

Das Hauptmenü View enthält verschiedene Befehle, mit denen Sie die Ansicht des aktuellen Dokuments steuern können.

Verwenden Sie die Befehle im Hauptmenü View, um die Ansicht Ihres Dokuments zu steuern. Das obere Bild zeigt das Menü View des Schaltplaneditors. Das untere Bild zeigt das Menü View des PCB-Editors.

Verwenden Sie die Befehle im Hauptmenü View, um die Ansicht Ihres Dokuments zu steuern. Das obere Bild zeigt das Menü View des Schaltplaneditors. Das untere Bild zeigt das Menü View des PCB-Editors.

Zu diesen Befehlen gehören:

  • Fit Document – zeigt den gesamten Bereich des aktuellen Dokuments an.

  • Fit All Objects – zeigt alle Designobjekte im aktuellen Dokument an.

  • Area – vergrößert einen benutzerdefinierten Bereich des aktuellen Dokuments.

  • Around Point – legt den angezeigten Bereich um einen angegebenen Punkt im aktuellen Dokument neu fest.

  • Selected Objects – ändert die Ansicht im Designbereich so, dass alle ausgewählten Objekte sichtbar sind.

  • Zoom In – vergrößert die Ansicht des Designs im aktuellen Dokument relativ zur Cursorposition.

  • Zoom Out – verkleinert die Ansicht des Designs im aktuellen Dokument relativ zur Cursorposition.

  • Zoom Last – stellt im aktuellen Dokument die vorherige Bildschirmansicht wieder her.

Mit der Tastenkombination Z können Sie außerdem das Pop-up-Menü mit den Zoom-Befehlen aufrufen.

Im PCB-Editor und im PCB-Footprint-Editor können Sie über dieses Menü auf den Befehl Select zugreifen. Dieser öffnet den Dialog Zoom Value (0.001x..4x), in dem Sie die Vergrößerung der Ansicht des aktuellen Dokuments um einen bestimmten Faktor ändern können. Geben Sie Werte größer als 1 ein, um weiter hineinzuzoomen (die Vergrößerung zu erhöhen). Werte kleiner als 1 dienen dazu, weiter herauszuzoomen (die Vergrößerung zu verringern).

Der Dialog Zoom Value
Der Dialog Zoom Value

Wenn Sie ein PCB- oder PCB-Footprint-Dokument in 3D betrachten, stehen zusätzliche Befehle, Tastenkombinationen und Steuerelemente für eine flüssige Navigation in der Ansicht zur Verfügung. Weitere Informationen finden Sie auf der Seite Steuern der 3D-Ansicht.

Zu einem bestimmten Punkt in einem Dokument springen

Mit den Befehlen im Untermenü Edit » Jump der Hauptmenüs des Schaltplan-, Schaltplansymbol-, PCB- oder PCB-Footprint-Editors können Sie zu einem bestimmten Punkt im aktiven Dokument springen. Das Pop-up-Menü „Jump“ lässt sich auch durch Drücken der Taste J im Designbereich aufrufen. Sie können beispielsweise zu folgenden Zielen springen:

  • zum Koordinatenursprung des Dokuments:
    • zum Ursprungspunkt eines Schaltplanblatts (entspricht der unteren linken Ecke) – Origin;

    • zum absoluten Ursprung des PCB-Dokuments – Absolute Origin;

    • zum relativen Ursprung des aktuellen PCB-Dokuments – Current Origin;

    • zur Position des Bauteilreferenzpunkts im PCB-Footprint-Dokument – Reference;

  • zu einer beliebigen Position im aktuellen Dokument anhand benutzerdefinierter XY-Koordinaten – wählen Sie den Befehl New Location, um im daraufhin angezeigten Dialog Jump To Location die X- und Y-Koordinaten der Position im Designbereich einzugeben, zu der der Cursor springen soll. Im PCB-Editor können Sie außerdem die Felder Delta X und Delta Y verwenden, um die Delta-X- und Delta-Y-Koordinaten der gewünschten Zielposition anzugeben.

    Der Dialog Jump To Location – im Schaltplaneditor (erstes Bild) und im PCB-Editor (zweites Bild)
    Der Dialog Jump To Location – im Schaltplaneditor (erstes Bild) und im PCB-Editor (zweites Bild)

  • zu einem Objekt innerhalb des Dokuments. Verwenden Sie die folgenden Befehle, um zum gewünschten Objekt zu springen:
    • zu einem Bauteil auf dem Schaltplanblatt – Jump Component. Nach dem Aufrufen des Befehls erscheint der Dialog Component Designator. Geben Sie das Referenzkennzeichen des Bauteils ein, zu dem Sie springen möchten. Wenn das Referenzkennzeichen gültig ist und das Bauteil in einem Quellschaltplandokument des aktiven Projekts vorhanden ist, wird das entsprechende Schaltplandokument aktiviert und das Zielbauteil im Designbereich vergrößert und nach Möglichkeit zentriert dargestellt. Das gefundene Bauteil (bzw. alle Teile eines mehrteiligen Bauteils) wird außerdem im Panel Messages aufgelistet. Doppelklicken Sie auf einen Meldungseintrag, um zu diesem Bauteil (oder einem seiner Teile) im Designbereich zu springen.

      Der Dialog Component Designator
      Der Dialog Component Designator

      Wenn Sie zu einem mehrteiligen Bauteil springen möchten, geben Sie nur das Basis-Referenzkennzeichen ohne das Suffix des jeweiligen Teils ein. Um beispielsweise zu einem zweiteiligen IC-Bauteil zu springen, dessen Teile mit IC1_CPA und IC1_CPB bezeichnet sind, geben Sie IC1_CP im Dialog Component Designator ein. Bei einem mehrteiligen Bauteil wird der erste Teil hervorgehoben und der Dialog Find Text - Jump geöffnet. Verwenden Sie diesen Dialog, um zwischen den einzelnen Teilen des Bauteils zu springen.
      Aktivieren Sie die Option Physical im Dialog Component Designator, um die Sprungfunktion auf physische Bauteilreferenzkennzeichen zu beschränken – also diejenigen, die in den Registerkartenansichten Compiled Document der Quellschaltplandokumente angezeigt werden. Wenn diese Option deaktiviert ist, berücksichtigt die Sprungfunktion nur logische Referenzkennzeichen – also diejenigen, die in den Registerkartenansichten Editor der Quellschaltplandokumente angezeigt werden.
    • zu einem bestimmten Bauteil im PCB-Dokument – Component. Nach dem Aufrufen des Befehls erscheint der Dialog Component Designator. Geben Sie das Referenzkennzeichen ein, um zu diesem Bauteil zu springen. Wenn Sie sich beim Referenzkennzeichen nicht sicher sind, geben Sie ? ein und klicken Sie auf OK , um den Dialog Components Placed zu öffnen, der alle Bauteile des Designs auflistet. Geben Sie Text in das Feld Mask ein, um nach dem gewünschten Bauteil zu suchen. Während der Eingabe wird die Liste so gefiltert, dass nur Zeichenfolgen angezeigt werden, die dem Suchmuster entsprechen. Sie können dabei die Platzhalter ? (ein beliebiges einzelnes Zeichen) und * (beliebige Zeichen) verwenden. Der Cursor springt zum Referenzpunkt des ausgewählten Bauteils.

      Geben Sie ? im Dialog Component Designator ein, um den Dialog Components Placed aufzurufen, der alle Bauteile auf der Leiterplatte auflistet.
      Geben Sie ? im Dialog Component Designator ein, um den Dialog Components Placed aufzurufen, der alle Bauteile auf der Leiterplatte auflistet.

    • zu einem bestimmten Netz im PCB-Dokument – Net. Nach dem Aufrufen des Befehls erscheint der Dialog Net Name. Geben Sie den Namen des Netzes ein, zu dem Sie springen möchten, oder geben Sie ? ein und drücken Sie OK , um den Dialog Nets Loaded mit einer Liste aller geladenen Netze des Designs zu öffnen. Geben Sie Text in das Feld Mask ein, um nach dem gewünschten Netz zu suchen. Während der Eingabe wird die Liste so gefiltert, dass nur Zeichenfolgen angezeigt werden, die dem Suchmuster entsprechen. Sie können im Suchmuster die Platzhalter ? (ein beliebiges einzelnes Zeichen) und * (beliebige Zeichen) verwenden. Wenn das Zielnetz bereits im Hauptfenster des Designs angezeigt wird, springt der Cursor zum nächstgelegenen Designobjekt, das zu diesem Netz gehört. Befindet sich das Netz außerhalb des sichtbaren Bereichs, wird der Cursor auf dem nächstgelegenen Designobjekt dieses Netzes positioniert und dieses nach Möglichkeit im Designbereich zentriert.

      Geben Sie ? im Dialog Net Name ein, um den Dialog Nets Loaded aufzurufen, der alle Netze auf der Leiterplatte auflistet.Geben Sie ? im Dialog Net Name ein, um den Dialog Nets Loaded aufzurufen, der alle Netze auf der Leiterplatte auflistet.

    • ein bestimmtes Bauteil-Pad im PCB-Dokument – Pad. Nach dem Aufrufen des Befehls wird das Dialogfeld Jump To Pad Number angezeigt. Geben Sie das gesuchte Pad des gewünschten Bauteils im Format ComponentDesignator-PadDesignator (z. B. U1-6) ein und klicken Sie auf OK. Wenn das Ziel-Pad bereits im Arbeitsbereich angezeigt wird, springt der Cursor einfach in die Mitte dieses Pads. Befindet sich das Pad außerhalb des sichtbaren Bereichs, wird der Cursor in der Mitte des Pads positioniert und dieses im Arbeitsbereich zentriert (sofern möglich).

      Das Dialogfeld Jump To Pad Number
      Das Dialogfeld Jump To Pad Number

    • eine bestimmte Zeichenfolge im PCB-Dokument – String. Nach dem Aufrufen des Befehls wird das Dialogfeld Jump To String angezeigt. Geben Sie die Zeichenfolge ein, zu der Sie springen möchten, oder geben Sie ? ein und klicken Sie auf OK , um das Dialogfeld Strings zu öffnen. Dieses enthält eine Liste aller Zeichenfolgen im aktiven Leiterplattendokument (sowohl freie Zeichenfolgen als auch solche, die anderen Gruppenobjekten untergeordnet sind). Mit diesem Dialogfeld können Sie die Zeichenfolge, zu der Sie springen möchten, schnell finden. Wenn die Zielzeichenfolge bereits im Arbeitsbereich angezeigt wird, springt der Cursor einfach zu ihrem Ankerpunkt – dem Punkt, an dem sie beim Verschieben gehalten bzw. um den sie gedreht wird. Befindet sich die Zeichenfolge außerhalb des sichtbaren Bereichs, wird der Cursor an ihrem Ankerpunkt positioniert und dieser im Arbeitsbereich zentriert (sofern möglich).

      Geben Sie ? im Dialogfeld Jump To String ein, um das Dialogfeld Strings mit einer Liste aller Netze auf der Leiterplatte aufzurufen.
      Geben Sie ? im Dialogfeld Jump To String ein, um das Dialogfeld Strings mit einer Liste aller Netze auf der Leiterplatte aufzurufen.

      Das System führt drei Suchläufe durch: Zunächst wird nach einer Zeichenfolge gesucht, die hinsichtlich Groß-/Kleinschreibung, Zeichen und Länge mit der angegebenen Zeichenfolge übereinstimmt; anschließend nach einer Zeichenfolge mit denselben Zeichen, die jedoch möglicherweise weitere Zeichen enthält; und schließlich nach einer Zeichenfolge mit denselben Zeichen, wobei die Groß-/Kleinschreibung ignoriert wird.

    • zu allen Fehlermarkierungen im aktuellen Designdokument springen und diese nacheinander durchlaufen – Error Marker. Nach dem Aufrufen des Befehls springt der Cursor zur ersten Fehlermarkierung der Designregelprüfung (DRC), die im Haupt-Designfenster zentriert wird. Durch wiederholtes Aufrufen des Befehls springen Sie zur zweiten Fehlermarkierung und so weiter. Dieser Befehl springt unabhängig davon zu einer Fehlermarkierung, ob der Verstoß als Ausnahme zugelassen wurde oder nicht.

      Untersuchen Sie die mit dem Objekt unter dem Cursor verbundenen Verstöße, indem Sie mit der rechten Maustaste klicken und den entsprechenden Befehl im Untermenü Violations auswählen.

  • zu allen ausgewählten Designobjekten im aktuellen Dokument springen und diese nacheinander durchlaufen – Selection. Nach dem Aufrufen des Befehls springt der Cursor zum ersten ausgewählten Objekt, das im Haupt-Designfenster vergrößert und zentriert angezeigt wird. Durch wiederholtes Aufrufen des Befehls springen Sie zum zweiten ausgewählten Objekt und so weiter, bis alle ausgewählten Objekte im aktuellen Dokument durchlaufen wurden. Der Befehl durchläuft die ausgewählten Objekte in der Reihenfolge, in der sie ursprünglich zur Auswahl hinzugefügt wurden.

  • eine Position im aktuellen Schaltplan- oder PCB-Dokument, deren Koordinaten zuvor in der angegebenen Positionsmarkierung gespeichert wurden – wählen Sie den Befehl Location Marks » n, um zu der Position zu springen, die mit dem Befehl Set Location Marks » n in der angegebenen Positionsmarkierung gespeichert wurde.

    Bei einem Schaltplandokument ist eine gespeicherte Position nur verfügbar, solange das Dokument geöffnet bleibt (unabhängig davon, ob es aktiv ist oder nicht). Wird das Dokument geschlossen und erneut geöffnet, ist die Positionsmarkierung leer. Bei einem PCB-Dokument werden Positionsmarkierungen mit dem Design gespeichert, sodass die darin enthaltenen benutzerdefinierten Positionen auch in späteren Designsitzungen weiterhin verfügbar sind.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.