Schaltpläne & PCB synchron halten
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Lernen Sie den Unterschied zwischen bidirektionalen Vergleichen und direkten Aktualisierungsabläufen kennen und erfahren Sie, wann welcher Ansatz zum Einsatz kommt.
- Erfahren Sie, welche Daten Altium Designer zwischen Schaltplan und PCB synchronisieren kann, darunter Bauteile, Verbindungen, Klassen und bestimmte Designregeln.
- Sehen Sie, wie Projektoptionen wie die Einstellungen für den Komparator und die ECO-Erstellung den Synchronisierungsprozess und die anwendbaren Änderungen beeinflussen.
Die häufigste Aufgabe beim Übergang vom Schaltplan zum Leiterplattenlayout besteht darin, Schaltplan und Leiterplatte aufeinander abzustimmen oder zu synchronisieren. Ganz gleich, ob Sie einen erfassten Entwurf zum ersten Mal auf eine neue Leiterplatte übertragen oder einen bestehenden Entwurf im Schaltplan oder im Leiterplattenlayout ändern: Sie benötigen eine Möglichkeit, beide Seiten synchron zu halten. Altium Designer bietet leistungsstarke Funktionen zur Designsynchronisierung, die diese Aufgabe vereinfachen und es dem Entwickler ermöglichen, sich auf die kreativen Aspekte des Designprozesses zu konzentrieren.
Der Synchronisierungsprozess erkennt und behebt Unterschiede zwischen Schaltplan und Leiterplatte.
Die Designsynchronisierung erfolgt direkt zwischen dem Schaltplan- und dem Leiterplatteneditor; ein zwischengeschaltetes, netzlistenähnliches Dokument wird nicht verwendet. Die Software vergleicht mithilfe einer Vergleichsengine alle Aspekte des Designs und gibt die Ergebnisse als Liste von Unterschieden aus. Der Entwickler entscheidet, welche Seite geändert werden soll, um die Unterschiede zu beheben. Anschließend wird ein Satz von Engineering Change Orders (ECOs) erstellt. Sobald diese angewendet werden, sind beide Seiten des Designs wieder synchron.
Was kann synchronisiert werden?
Der Synchronisierungsprozess stellt sicher, dass die Bauteil- und Verbindungsdaten im Schaltplan mit denen auf der Leiterplatte übereinstimmen. Darüber hinaus sorgt er dafür, dass auch andere Designvorgaben wie Netzklassen, Bauteilklassen und Designregeln synchron sind.
Vergleichsoptionen konfigurieren
Dialog page: Optionen für das Leiterplattenprojekt, Registerkarte „Comparator“
Welche what Schaltplan- und Leiterplattendaten genau verglichen werden, wird auf der Registerkarte „Comparator“ des Dialogs Options for PCB Project konfiguriert. Wählen Sie Project » Project Options, um den Dialog zu öffnen.

Die Vergleichsengine berücksichtigt die Einstellungen auf der Registerkarte Comparator des Dialogs Options for Project.
Der Hauptbereich des Dialogs enthält eine umfangreiche Liste von Vergleichstypen, beispielsweise Different Designators und Changed Net Name, die in fünf Kategorien unterteilt sind. Die rechte Spalte Mode enthält für jeden Typ eine Dropdown-Liste, in der Sie den Vergleichsmodus auswählen, etwa Find Differences oder Ignore Differences. Für Textvergleiche gibt es eine dritte Option, mit der die Groß- und Kleinschreibung beim Vergleich ignoriert werden kann.
Bei einem neuen Projekt ist standardmäßig für jeden Vergleichstyp die Ermittlung von Unterschieden aktiviert. Passen Sie die Optionen an die Anforderungen Ihres Projekts an.
Am unteren Rand des Dialogs befinden sich Optionen zum Einstellen von Object Matching Criteria. Die Zuordnung ist ein ausgefeilter, mehrstufiger Prozess, der nicht auf einem einfachen exakten Zeichenfolgenvergleich beruht. Weitere Informationen finden Sie im Abschnitt Netze und Klassen zuordnen.
Beachten Sie die Option Ignore Rules Defined in the PCB Only am unteren Rand des Dialogs. Aktivieren Sie diese, um die auf der Leiterplatte definierten Regeln vom Vergleich auszuschließen.
Netz- und Bauteilklassen synchronisieren
Dialog page: Optionen für das Leiterplattenprojekt, Registerkarte „Class Generation“
Neben Bauteil- und Verbindungsdaten können Sie bei der Durchführung von Design » Update PCB auch Klassen und Designregeln erzeugen und synchronisieren.
Designregeln synchronisieren
Designregeln können mithilfe eines Parametersatz-Objekts im Schaltplan definiert werden. Wenn ein Parametersatz-Objekt ausgewählt ist, enthält das Panel oder der modale Dialog Properties einen Bereich Rules. Klicken Sie auf die Dropdown-Liste Add, um eine Designregel hinzuzufügen. Die Regel wird auf das Netz, den Bus, den Kabelbaum oder die Objekte unter der Blanket angewendet, mit denen das Parametersatz-Objekt verbunden ist.
In der folgenden Abbildung wird eine Designregel zur Begrenzung der Leiterbahnbreite auf die Netzklasse USB_data angewendet (die Netzklasse ist ebenfalls als Teil dieses Parametersatzes im Bereich Classes der Dropdown-Liste Parameters definiert).

Mit dem Parametersatz werden eine Netzklasse und eine Designregel für die Netze unter dem Blanket-Objekt im Schaltplan definiert. Beachten Sie, dass die benötigten Maßeinheiten am unteren Rand des Dialogs „Edit PCB Rule“ konfiguriert werden.
Eine Designregel im Schaltplan hinzufügen
- Verbinden Sie einen Parametersatz mit dem Netz, Bus, Kabelbaum oder der Blanket (fügen Sie bei Bedarf eine Netzklassendefinition im Parametersatz hinzu).
- Add Fügen Sie dem Parametersatz eine Regeldefinition hinzu. Dadurch wird der Dialog Choose Design Rule Type geöffnet, wie oben gezeigt.
- Wählen Sie den gewünschten Rule Type.
- Klicken Sie auf die Schaltfläche OK, um den Dialog Edit PCB Rule zu öffnen.
- Konfigurieren Sie die Anforderungen der Leiterplattenregel nach Bedarf. Beachten Sie, dass die für diese Leiterplattenregel benötigten Maßeinheiten am unteren Rand des Dialogs ausgewählt werden.
Sowohl in der obigen als auch in der folgenden Abbildung wird die Designregel in einem Parametersatz-Objekt definiert, das mit einer Blanket verbunden ist. Wenn das Parametersatz-Objekt eine Klassendefinition enthält, wird auch eine Leiterplatten-Netzklasse erstellt. Da die Klassendefinition vorhanden ist, wird der Geltungsbereich der Leiterplattenregel auf InNetClass('<PCB_NetClassName >') festgelegt.
In der folgenden Abbildung wird das Parametersatz-Objekt als Differenzpaar-Direktive dargestellt. Dies ist ein spezieller Typ von Parametersatz-Objekt, der mit dem Befehl Place » Directives » Differential Pair platziert wird.

Mit der Differenzpaar-Direktive werden eine Netzklasse und eine Designregel definiert, die anschließend auf die betreffenden Differenzpaare angewendet wird.
Optionen für die ECO-Erstellung konfigurieren
Der Dialog Options for Project enthält außerdem die Registerkarte ECO-Erstellung. Diese Registerkarte legt fest, für welche Designänderungen ECOs erstellt werden können. In der Regel sind alle Optionen aktiviert. Über die Optionen auf der Registerkarte Komparator des Dialogs wird festgelegt, welche Designänderungen zwischen Schaltplan und Leiterplatte synchronisiert werden sollen.

Die Registerkarte „ECO-Erstellung“ legt fest, für welche Arten von Änderungen ECOs erstellt werden können.
Unterschiede ermitteln
Die Designsynchronisierung kann Unterschiede in beide Richtungen erkennen und beheben, also vom Schaltplan zur Leiterplatte oder von der Leiterplatte zurück zum Schaltplan.
Die Software kann diese Unterschiede beheben, indem sie Änderungen gleichzeitig auf beiden Seiten anwendet. Stellen Sie sich beispielsweise vor, dass der Elektronikentwickler den Wert eines Kondensators geändert hat, während der Leiterplattenentwickler den Footprint desselben Kondensators geändert hat. Diese beiden Unterschiede lassen sich in einem einzigen Aktualisierungsvorgang beheben: Die Änderung des Kommentars wird vom Schaltplan auf die Leiterplatte übertragen, die Footprint-Änderung von der Leiterplatte auf den Schaltplan.
Wenn die Vergleichsengine das Schaltplanprojekt mit der Leiterplatte vergleicht, wird eine vollständige Liste der Unterschiede erstellt. Zu diesem Zeitpunkt wird noch nicht festgelegt, welche Seite geändert werden muss, um beide wieder zu synchronisieren.
Die Liste der Unterschiede wird im Dialog Differences between angezeigt.
Optionen und Bedienelemente des Dialogs „Differences between“
Der Dialog ist im Wesentlichen in drei Hauptbereiche unterteilt: Differences, Update und Change Order.
Unterschiede
Dieser Bereich des Dialogs listet alle Unterschiede auf, die der Komparator zwischen den ausgewählten Dokumenten gefunden hat. Jeder Unterschied wird in der Spalte des Dokuments aufgeführt, in dem er vorliegt. Die Unterschiede werden nach Vergleichstyp gruppiert, entsprechend den auf der Registerkarte Komparator des Dialogs Project Options aufgeführten und aktivierten Typen. Der Eintrag auf Gruppenebene zeigt die Anzahl der Unterschiede dieses Typs an.
Doppelklicken Sie auf einen Eintrag, um per Cross-Probing zum Objekt im entsprechenden Quelldokument zu navigieren.
Aktualisierung
In diesem Bereich des Dialogs legen Sie fest, welches Dokument aktualisiert werden soll, um den Unterschied zu beheben. Standardmäßig ist für alle Decision -Einträge zunächst die Entscheidung No Change festgelegt.
Die Aktualisierungsentscheidung lässt sich für jeden Unterschied einzeln festlegen. Klicken Sie dazu auf den zugehörigen Eintrag in der Spalte Decision und wählen Sie anschließend im Dialog ECO-Entscheidung die gewünschte Aktualisierungsaktion aus. Wählen Sie einfach die Aktualisierungsrichtung, also welches der verglichenen Dokumente aktualisiert werden soll, oder No Updates.
Änderungsauftrag
Dieser Bereich des Dialogs listet für jeden Unterschied, den Sie beheben möchten, die auszuführende Aktion, das davon betroffene Objekt und das Dokument auf, in dem die Aktion ausgeführt wird. Anhand dieser Informationen wird der nachfolgende ECO zusammengestellt, mit dem die Aktualisierungen vorgenommen werden. Häufig werden in diesem Bereich folgende Aktionen aufgeführt:
- Remove - Wenn die Aktualisierung in Richtung des Dokuments erfolgt, das das den Unterschied verursachende Objekt enthält, wird das Objekt entfernt.
- Add - Wenn die Aktualisierung in Richtung des Dokuments erfolgt, das das den Unterschied verursachende Objekt nicht enthält, wird das Objekt hinzugefügt.
- Update - Wenn beide Dokumente dasselbe Objekt enthalten, das sich jedoch in einem Merkmal unterscheidet, hängt es von der gewählten Richtung ab, welches Objekt geändert wird.
Kontextmenü
- Create Change Order - Erstellt einen Engineering Change Order (ECO).
- Generate Report - Erstellt einen Bericht über die vom Komparator gefundenen Unterschiede. Die von Ihnen festgelegten Aktualisierungsentscheidungen und Aktionen werden in den erzeugten ECO aufgenommen. Der Bericht wird im Dialog Report Preview geladen. In diesem Dialog können Sie den Bericht durchsehen, bevor Sie ihn in eines der unterstützten Formate exportieren oder direkt ausdrucken.
- << Update All in - Legt die Aktualisierungsrichtung für alle Unterschiede auf das linke Dokument fest, sofern dies möglich ist.
- Update All in >> - Legt die Aktualisierungsrichtung für alle Unterschiede auf das rechte Dokument fest, sofern dies möglich ist.
- Reverse Direction For All - Kehrt die Aktualisierungsrichtung für alle Unterschiede schnell um, sofern dies möglich ist. Ist eine Richtungsänderung für einen Unterschied nicht zulässig, wird der Eintrag auf No Change gesetzt.
- Set No Action For All - Setzt die Aktualisierungsentscheidung für alle Unterschiede schnell auf No Change.
- << Update Same Kind in - Legt die Aktualisierungsrichtung für alle Unterschiede desselben Vergleichstyps wie der aktuell ausgewählte Unterschied auf das linke Dokument fest, sofern dies möglich ist.
- Update Same Kind in >> - verwenden Sie diese Option, um die Aktualisierungsrichtung für alle Unterschiede desselben Vergleichstyps wie der aktuell fokussierte Unterschied auf das rechte Dokument festzulegen (sofern zutreffend).
- Reverse Direction For Same Kind - verwenden Sie diese Option, um die Aktualisierungsrichtung für alle Unterschiede desselben Vergleichstyps wie der aktuell fokussierte Unterschied schnell umzukehren, sofern zutreffend. Wenn die Richtung für einen Unterschied nicht geändert werden kann, wird der Eintrag auf No Change gesetzt.
- Set No Action For Same Kind - verwenden Sie diese Option, um die Aktualisierungsrichtung für alle Unterschiede desselben Vergleichstyps wie der aktuell fokussierte Unterschied schnell auf No Change festzulegen.
- << Update Selected in - verwenden Sie diese Option, um die Aktualisierungsrichtung für alle ausgewählten Unterschiede auf das linke Dokument festzulegen (sofern zutreffend).
- Update Selected in >> - verwenden Sie diese Option, um die Aktualisierungsrichtung für alle ausgewählten Unterschiede auf das rechte Dokument festzulegen (sofern zutreffend).
- Reverse Direction For Selected - verwenden Sie diese Option, um die Aktualisierungsrichtung für alle ausgewählten Unterschiede schnell umzukehren (sofern zutreffend). Wenn die Richtung für einen Unterschied nicht geändert werden kann, wird der Eintrag auf No Change gesetzt.
- Set No Action For Selected - verwenden Sie diese Option, um die Aktualisierungsentscheidung für alle ausgewählten Unterschiede schnell auf No Change festzulegen.
- Invert Selection - verwenden Sie diese Option, um alle derzeit nicht ausgewählten Unterschiede in der Liste auszuwählen oder die Auswahl der bereits ausgewählten Unterschiede aufzuheben.
Weitere Bedienelemente
Am unteren Rand des Dialogs stehen folgende Schaltflächen zur Verfügung:
- Create Engineering Change Order - klicken Sie auf diese Schaltfläche, um einen ECO zu erstellen. Der Dialog Engineering Change Order wird geöffnet. Dort können Sie die Aktualisierungen prüfen und ausführen, um die Dokumente zu synchronisieren.
- Report Differences - klicken Sie auf diese Schaltfläche, um einen Bericht über die vom Comparator gefundenen Unterschiede zu erstellen. Die von Ihnen festgelegten Aktualisierungsentscheidungen und die Aktionen werden in den erstellten ECO aufgenommen. Der Bericht wird in den Dialog Report Preview geladen. In diesem Dialog können Sie den Bericht durchsehen, bevor Sie ihn in eines der verschiedenen unterstützten Formate exportieren oder direkt drucken.
- Explore Differences - klicken Sie auf diese Schaltfläche, um die vom Comparator gefundenen Unterschiede vor dem Erstellen eines ECO genauer zu untersuchen. Der Dialog Differences between wird geschlossen, und Sie kehren zum Hauptarbeitsbereich zurück, in dem das Differences-Panel geöffnet ist. Das Panel enthält alle vom Comparator aufgelisteten Unterschiede in denselben Kategorien. Verwenden Sie das Panel, um per Cross-Probing zu einem Objekt zu navigieren, das einen Unterschied im zugehörigen Dokument verursacht.
So öffnen Sie den Dialog Difference between und zeigen eine Liste der Unterschiede an:
-
Um den Dialog Choose Documents to Compare zu öffnen, wie in der folgenden Abbildung gezeigt, führen Sie den Befehl Project » Show Differences aus oder klicken Sie im Projects Panel mit der rechten Maustaste auf den Eintrag des gewünschten Projekts (oder eines seiner Quelldokumente) und wählen Sie im Kontextmenü den Befehl Show Differences aus. Im Dialog Choose Documents to Compare wählen Sie die beiden Dokumente bzw. Dokumentgruppen aus, die Sie vergleichen möchten. Üblicherweise wird das Schaltplanprojekt mit der Leiterplatte verglichen. Sie können diesen Dialog auch verwenden, um beliebige Dokumente miteinander zu vergleichen, indem Sie die Option Advanced Mode aktivieren. Beispielsweise können Sie eine Netzliste mit einer Leiterplatte oder zwei Leiterplatten miteinander vergleichen.
Im Allgemeinen eignet sich die Standardkonfiguration des Dialogs – sowohl im einfachen als auch im erweiterten Modus – für die meisten Designvergleiche, bei denen die Quelldokumente und das Ziel-Leiterplattendesign verglichen werden sollen, um sie zu synchronisieren. Der Dialog ermöglicht jedoch auch den Vergleich anderer Dokumente. Dies kann hilfreich sein, wenn Sie verschiedene Versionen eines Projekts laden und die Unterschiede zwischen den entsprechenden Quelldokumenten vergleichen möchten.

Wählen Sie die Leiterplatte aus, mit der das Schaltplanprojekt verglichen werden soll. - Wählen Sie die Leiterplatte im Hauptbereich des Dialogs aus und klicken Sie auf OK, um den Dialog Difference between zu öffnen, wie unten gezeigt. Wenn das Leiterplattendokument bereits mit den Quelldokumenten synchronisiert ist, wird ein Dialog mit dem Hinweis angezeigt, dass keine Unterschiede gefunden wurden.
Der Dialog Differences between wird geöffnet. Der Synchronizer arbeitet bidirektional. Das bedeutet, dass Sie innerhalb desselben ECO Aktualisierungen für beide Dokumente festlegen können. Um die verglichenen Dokumente zu synchronisieren, muss für jeden Unterschied entschieden werden, ob eine Aktion ausgeführt werden soll und in welche Richtung die Änderung erfolgt. Dabei legen Sie fest, welches Dokument aktualisiert werden soll, um den Unterschied zu beheben. Im nächsten Schritt weisen Sie daher jedem Unterschied eine Aktualisierungsrichtung zu:
- Klicken Sie für einen einzelnen Unterschied in die Spalte Update, um eine Richtungsauswahl anzuzeigen, wie in der folgenden Abbildung gezeigt.
- Klicken Sie für mehrere Unterschiede derselben Art mit der rechten Maustaste auf eine Überschrift, beispielsweise „Unterschiedliche Footprints“, und wählen Sie den gewünschten Befehl Update Same Kind aus.
- Klicken Sie für alle Unterschiede mit der rechten Maustaste an eine beliebige Stelle im Dialog und wählen Sie den gewünschten Befehl Update All aus.

Für jeden Unterschied muss die Aktualisierungsrichtung festgelegt werden, damit ein ECO zu seiner Behebung erstellt werden kann.
Klicken Sie auf die Schaltfläche Explore Differences, um das Differences Panel aufzurufen und die Unterschiede zu untersuchen, wie im folgenden Abschnitt Designänderungen mit dem Differences-Panel untersuchen beschrieben.
Klicken Sie auf Report Differences, um einen Bericht über die vom Comparator gefundenen Unterschiede, die festgelegten Aktualisierungsentscheidungen und die Aktionen, die in den erstellten ECO aufgenommen werden, zu konfigurieren und zu drucken bzw. zu exportieren.
Nachdem die Aktualisierungsrichtung zugewiesen wurde, klicken Sie auf die Schaltfläche Create Engineering Change Order, um den Dialog Engineering Change Order zu öffnen. Dieser wird im folgenden Abschnitt Unterschiede beheben – ECOs anwenden beschrieben.
Designänderungen mit dem Differences-Panel untersuchen

Das Differences Panel zeigt eine hierarchische Ansicht der Unterschiede zwischen den Dokumenten.
Zusammenfassung
Das Differences Panel zeigt die logischen oder physischen Unterschiede an, die der integrierte Differences Comparator der Software beim Vergleich von Designdokumenten ermittelt (beispielsweise beim Vergleich der Quelldokumenthierarchie (Schaltpläne) eines Projekts mit dem PCB-Designdokument). Im Panel können Sie die Unterschiede interaktiv untersuchen, bevor Sie entscheiden, einen Engineering Change Order (ECO) zur Synchronisierung der Projektdokumente zu erstellen.
Zugriff auf das Panel
So öffnen Sie das Differences Panel:
- Wählen Sie View » Panels » Differences in den Hauptmenüs.
- Klicken Sie auf die Schaltfläche Panels unten rechts im Design-Arbeitsbereich und anschließend auf Differences.
Unterschiede anzeigen
Wie das Differences Panel verwendet wird, hängt davon ab, welches der folgenden Ziele Sie verfolgen:
- Die Integrität des gesamten Projekts hinsichtlich Inhalt und Struktur analysieren, indem logische Unterschiede innerhalb der Projekthierarchie erkannt werden.
- Zwei Versionen desselben Schaltplan- oder PCB-Dokuments vergleichen, indem ihre grafischen (physischen) Unterschiede erkannt werden.
Logische Unterschiede anzeigen
Der Vergleich von Projektdokumenten auf logische Unterschiede erfolgt im Dialog Choose Documents To Compare. Diesen öffnen Sie, indem Sie im Projects-Panel mit der rechten Maustaste auf ein Projekt (oder Projektdokument) klicken und anschließend Show Differences im zugehörigen Kontextmenü wählen.

Klicken Sie mit der rechten Maustaste auf einen Projektnamen und wählen Sie anschließend Show Differences, um den Dialog Choose Documents To Compare zu öffnen.
Üblicherweise wird das PCB-Dokument mit der Quelldokumenthierarchie des übergeordneten Projekts verglichen, um logische Unterschiede zwischen den Designinhalten des Schaltplans und der Leiterplatte zu erkennen.
Wenn Unterschiede zwischen den ausgewählten Dokumenten vorhanden sind, wird nach dem Klicken auf OK der Dialog Unterschiede zwischen geöffnet. Informationen im Differences Panel werden erst angezeigt, nachdem Sie im Dialog Differences between auf die Schaltfläche Explore Differences geklickt haben.
Das Differences Panel zeigt nur die Unterschiede an, die im Dialog Differences between aufgeführt sind. Diese werden wiederum durch die Einstellungen auf der Registerkarte Comparator des Dialogs Project Options (Project » Options) bestimmt. Auf dieser Registerkarte sind alle Vergleichstypen aufgeführt, beispielsweise Unterschiede bei Bauteilen, Netzen und Parametern. Die Einstellung von Mode für jede Vergleichskategorie auf Find Differences oder Ignore Differences bestimmt, ob der Differences Comparator seine Ergebnisse an den Dialog Differences between weitergibt.

Legen Sie im Dialog Project Options fest, wie Unterschiede erkannt und gemeldet werden.
Das Differences Panel zeigt die zwischen den Quelldokumenten gefundenen Unterschiede in einer Baumstruktur an. Der Ordner auf der obersten Ebene zeigt die Gesamtzahl der erkannten Unterschiede. Für jeden im Dialog Unterschiede zwischen aufgeführten Vergleichstyp wird ein Unterordner erstellt. Jeder Unterordner listet die konkret gefundenen Unterschiede auf, die wiederum nach den Objekten in den Dokumenten aufgeschlüsselt sind, die diese Unterschiede verursachen.
Wenn das zugehörige Dokument geöffnet ist (auch wenn es ausgeblendet ist), führt ein Klick auf einen Objekteintrag im Panel per Cross-Probing zum Objekt im Dokument.
Bei der visuellen Darstellung wird auf das Objekt gezoomt und es durch Abdunkeln aller anderen Objekte hervorgehoben. Der Kontrast der Abdunklung lässt sich mit dem Schieberegler Dimming im Bereich Highlight Methods auf der Seite System - Navigation des Dialogs Preferences einstellen.
Physische Unterschiede anzeigen
Der grafische (physische) Vergleich zweier Versionen desselben Schaltplan- oder PCB-Dokuments erfolgt grundsätzlich auf die gleiche Weise wie der oben beschriebene logische Vergleich, verwendet jedoch zusätzlich Advanced Mode im Dialog Choose Documents To Compare.
Verwenden Sie für einen physischen Dokumentvergleich den Befehl Show Differences (im Kontextmenü des ProjectsPanels), um den Dialog Choose Documents To Compare zu öffnen, und aktivieren Sie anschließend das Kontrollkästchen Advanced Mode. Da nun alle Projektdateien im Dialog angezeigt werden, können Sie die beiden Varianten eines Dokuments für den Vergleich auswählen.

Auswahl von Dokumenten für den physischen Vergleich im Dialog Choose Documents To Compare in Advanced Mode.
Ein Klick auf OK startet den grafischen Vergleich und öffnet den Dialog Unterschiede zwischen, wie zuvor beschrieben. Klicken Sie auf Explore Differences, um die interaktive Liste der Unterschiede im DifferencesPanel zu öffnen.
Das Panel zeigt die zwischen den Dokumenten gefundenen Unterschiede in einer Baumstruktur an. Der Ordner auf der obersten Ebene zeigt die Gesamtzahl der erkannten Unterschiede. Für jeden Unterschiedstyp werden Einträge erstellt, die jeweils die konkreten Referenzen und das betroffene Objekt (Port, Bauteil usw.) enthalten.
Wenn Sie den Objekteintrag eines erkannten Unterschieds auswählen, wird das Objekt im Design-Arbeitsbereich des Editors hervorgehoben und herangezoomt.
Hinweise
- Wenn sich ein Objekt im Panel auf einem derzeit ausgeblendeten Dokument befindet, wird dieses Dokument automatisch geöffnet und im Design-Editorfenster zum aktiven Dokument, sobald Sie auf den zugehörigen Eintrag klicken.
- Die beim Cross-Probing aus dem Differences Panel angewendete Filterung ist temporär. Sie können daher weiterhin Designobjekte auswählen oder bearbeiten, die außerhalb des Filterbereichs liegen.
- Die Informationen im Differences Panel werden gelöscht, wenn ein neuer Dokumentvergleich durchgeführt oder das übergeordnete Projekt kompiliert wird.
- Verwenden Sie den Befehl Project » Show Physical Differences aus den Hauptmenüs, um physische Unterschiede zwischen zwei Versionen eines Schaltplan- oder PCB-Dokuments zu erkennen und diese grafisch darzustellen, während die beiden Dokumente nebeneinander im Design-Arbeitsbereich angezeigt werden. Die Funktion „Physische Unterschiede anzeigen“ bietet einen rein visuellen Vergleich – keines der verglichenen Dokumente kann durch die Erstellung von ECOs aktualisiert werden. Sie ist für den Vergleich zweier Versionen desselben Dokuments vorgesehen. Wird sie jedoch zum Vergleich unterschiedlicher Dokumente verwendet, beispielsweise der Quellhierarchie des Projekts mit der Leiterplatte, erscheint das Differences Panel mit einer Liste der erkannten logischen Unterschiede.
Eine direkte Aktualisierung durchführen
Da Sie als Entwickler in der Regel wissen, in welche Richtung Sie die Aktualisierungen vornehmen möchten, und alle Aktualisierungen in dieselbe Richtung erfolgen, können Sie den soeben beschriebenen Prozess der Unterschiedserkennung und Richtungszuweisung überspringen.
Anstatt den Befehl Show Differences aus dem Menü Project auszuwählen, wählen Sie den Befehl Update aus dem Menü Design, entweder im Schaltplaneditor oder im PCB-Editor. Die Wahl des Editors, in dem Sie den Befehl ausführen, gibt die Richtung an, in der die Änderungen übernommen werden sollen – vom Editor this zum Editor that. Beispielsweise wählen Sie im Schaltplaneditor Design » Update, um alle Änderungen vom Schaltplan auf die Leiterplatte zu übertragen.
Der Dialog Differences between wird übersprungen, und Sie gelangen direkt zum Dialog Engineering Change Order.
Wenn alle Aktualisierungen in derselben Richtung übernommen werden sollen, verwenden Sie den Befehl Design » Update.
Unterschiede beheben – ECOs anwenden
Jeder Unterschied wird durch Anwenden eines Engineering Change Order (ECO) behoben. Die ECOs werden im Dialog Engineering Change Order mit jeweils einem ECO pro Zeile aufgeführt, jeweils mit einem eigenen Kontrollkästchen Enable.
Bei Verwendung des Dialogs Engineering Change Order:
- Beim Öffnen des Dialogs sind alle Änderungen aktiviert. Deaktivieren Sie alle Änderungen, die Sie vorerst zurückstellen möchten. Der Dialog unterstützt die Mehrfachauswahl – verwenden Sie das Kontextmenü, um den Aktivierungsstatus der ausgewählten ECOs umzuschalten.
- Verwenden Sie den Befehl „Cross Probe“ im Kontextmenü, um die von diesem ECO betroffenen Objekte zu untersuchen.
- Prüfen Sie mit der Schaltfläche Validate Changes, ob die Änderungen durchgeführt werden können. ECOs schlagen in der Regel fehl, weil ein Objekt nicht verfügbar ist – beispielsweise, weil der angegebene PCB-Footprint nicht in den verfügbaren dateibasierten Bibliotheken vorhanden ist oder das angegebene Pad im Footprint nicht existiert.
- Ein ECO kann auch fehlschlagen, weil ein für einen bestimmten ECO erforderliches Objekt zunächst nicht vorhanden war, aber während der Verarbeitung der aktuellen ECOs hinzugefügt wurde. Führen Sie in diesem Fall den Befehl „Update“ erneut aus, um diesen ECO abzuschließen.

Jede Designänderung wird als ECO dargestellt. Aktivieren Sie die benötigten ECOs.
Optionen und Bedienelemente des Dialogs Engineering Change Order
Der Dialog ist in zwei Hauptbereiche unterteilt: Modifications und Status.
Änderungen
Dieser Bereich des Dialogs listet alle Änderungen auf, die zum Herstellen der Synchronisierung erforderlich sind. Die Änderungen werden nach Änderungstyp gruppiert, wie im Dialog „Project Options – ECO Generation“ aufgeführt und aktiviert. Der Eintrag auf Gruppenebene zeigt die Anzahl der Änderungen dieses Typs an. Jede einzelne Änderung in diesem Bereich wird anhand der folgenden Angaben aufgeführt:
- Enable – Diese Option bestimmt, ob die Änderung bei der Ausführung des ECO berücksichtigt wird. Klicken Sie direkt auf das Kontrollkästchen, um zwischen aktiviert/einbezogen (angekreuzt) und deaktiviert/ausgeschlossen (nicht angekreuzt) umzuschalten. Sie können das Kontrollkästchen Enable mit der Leertaste aktivieren und deaktivieren.
- Action – Die auszuführende Aktion. Die verfügbaren Aktionstypen hängen davon ab, welcher ECO-Typ durchgeführt werden muss.
- Affected Object – Das von der Aktion betroffene Objekt.
- Affected Document – Das Dokument, in dem die Aktion ausgeführt wird.
Kontextmenü
Standardmäßig sind alle Änderungen für die Ausführung des ECO aktiviert. Aktivieren oder deaktivieren Sie die einzelnen Änderungseinträge nach Bedarf, entweder einzeln oder mithilfe der folgenden Befehle im Kontextmenü, um den Aktivierungsstatus mehrerer Änderungen zu ändern:
- Validate Changes – Klicken Sie hier, um die für den ECO aktivierten Änderungen zu validieren. Die Validierungsergebnisse werden in der Spalte Check im Bereich Status des Dialogs angezeigt.
- Execute Changes – Klicken Sie hier, um den ECO auszuführen. Die Ausführungsergebnisse werden in der Spalte Done im Bereich Status des Dialogs angezeigt. Beachten Sie, dass nur Änderungen ausgeführt werden, die die Validierung erfolgreich bestehen.
- Create Report – Klicken Sie hier, um einen Bericht über die im ECO enthaltenen Änderungen zu erstellen. Der Bericht wird in den Dialog Report Preview geladen.
- Cross Probe – Klicken Sie hier, um per Cross-Probing zu den Ziel- und Referenzobjekten zu navigieren, die an einer Änderungsaktion in den zugehörigen Schaltplan- und PCB-Dokumenten beteiligt sind.
- Expand All – Klicken Sie hier, um die Ansicht aller Änderungen in der Liste aufzuklappen.
- Contract All – Klicken Sie hier, um die Ansicht aller Änderungen in der Liste zuzuklappen.
- Enable All – Aktiviert alle Änderungen.
- Disable All – Deaktiviert alle Änderungen.
- Enable Selected – Aktiviert alle ausgewählten Änderungen.
- Disable Selected – Deaktiviert alle ausgewählten Änderungen.
- Enable all of same Kind – Aktiviert alle Änderungen desselben Änderungstyps wie die aktuell fokussierte Änderung.
- Disable all of same Kind – Deaktiviert alle Änderungen desselben Änderungstyps wie die aktuell fokussierte Änderung.
- Invert Selection – Wählt schnell alle derzeit nicht ausgewählten Änderungen in der Liste aus und hebt die Auswahl der bereits ausgewählten Änderungen auf.
Status
Dieser Bereich des Dialogs zeigt die folgenden Statusinformationen für jede aktivierte Änderung an:
- Check – Dieses Feld zeigt das Ergebnis der Validierung der Änderung an. Ein grünes Häkchen bedeutet, dass die vorgeschlagene Änderung unterstützt wird und bei der Ausführung des ECO durchgeführt wird. Ein rotes Kreuz bedeutet, dass die vorgeschlagene Änderung ungültig ist und bei der Ausführung des ECO nicht durchgeführt wird.
- Done – Dieses Feld zeigt das Ergebnis der Ausführung der Änderung an. Ein grünes Häkchen bedeutet, dass die gültige Änderung erfolgreich ausgeführt wurde.
- Message - Wenn die Änderung die Validierungsphase nicht besteht, erscheint in diesem Feld (und auch im Panel Messages) ein Eintrag mit einem Hinweis auf die Ursache.
Weitere Bedienelemente
Die folgenden Bedienelemente stehen am unteren Rand des Dialogs und im Kontextmenü zur Verfügung:
- Validate Changes - Klicken Sie hier, um die Änderungen zu validieren, die für die Aufnahme in den ECO aktiviert sind. Die Validierungsergebnisse werden in der Spalte Check im Bereich Status des Dialogs angezeigt.
- Execute Changes - Klicken Sie hier, um den ECO auszuführen und die darin enthaltenen gültigen Änderungen umzusetzen. Die Ausführungsergebnisse werden in der Spalte Done im Bereich Status des Dialogs angezeigt. Beachten Sie, dass nur Änderungen ausgeführt werden, die die Validierungsphase bestehen.
- Report Changes - Klicken Sie hier, um einen Bericht zu den im ECO enthaltenen Änderungen zu erstellen. Der Bericht wird in den Dialog Report Preview geladen.
- Only Show Errors - Aktivieren Sie diese Option, um nur Fehler des Engineering Change Order anzuzeigen. Validierte Änderungen werden nicht angezeigt. Wenn nur die Fehlerliste angezeigt wird, können Sie Ihr Design schnell überprüfen und die erforderlichen Änderungen vornehmen, damit der resultierende ECO vollständig validiert werden kann.
Die Verknüpfung zwischen Schaltplan und PCB verstehen
Bauteilzuordnung über eindeutige Kennungen
Jedes Schaltplanbauteil ist über eine eindeutige Kennung (Unique Identifier, UID) mit seinem PCB-Bauteil verknüpft. Die UID wird beim Platzieren des Schaltplanbauteils auf dem Blatt zugewiesen. Dieser Wert wird auf das PCB-Bauteil übertragen, wenn das Design in den PCB-Editor übertragen wird. Wenn Bauteilinformationen zum ersten Mal mithilfe von Synchronizer zwischen den Schaltplan-Quelldokumenten und dem leeren PCB-Designdokument übertragen werden, werden alle Bauteile automatisch über ihre eindeutige Kennung verknüpft. Dabei wird die Kennung jedes Schaltplanbauteils dem entsprechenden Bauteil-Footprint zugewiesen.
Dieses Verfahren wäre für ein einfaches Design ausreichend, kann jedoch ein Mehrkanal-Design nicht unterstützen. In einem Mehrkanal-Design wird dasselbe Schaltplanbauteil in jedem physischen Kanal wiederholt, wodurch die wiederholten PCB-Bauteile dieselbe UID hätten. Um dies zu berücksichtigen, wird die UID des PCB-Bauteils aus der UID des übergeordneten Blattsymbols und der UID des Schaltplanbauteils gebildet. Die Syntax der PCB-UID unterscheidet sich geringfügig, je nachdem, wie das Mehrkanal-Design erstellt wurde.
Bei einem Mehrkanal-Design, das durch das Platzieren mehrerer Blattsymbole erstellt wurde, die alle auf dasselbe Schaltplanblatt verweisen, kann jedes Blattsymbol eine eindeutige Kennung bereitstellen. Die PCB-UID hat daher folgendes Format:
\SheetSymbolUID\SchComponentUID
Bei einem Mehrkanal-Design, das mit dem Schlüsselwort Repeat erstellt wurde, steht nur eine Blattsymbol-UID zur Verfügung. Deshalb enthält die PCB-UID auch den Wert ChannelIndex, und zwar in folgendem Format:
\ChannelIndex+SheetSymbolUID\SchComponentUID
Wenn die Bauteile nicht verknüpft sind
Der Vorteil der Verwendung einer UID zur Zuordnung von Schaltplan- und PCB-Bauteilen besteht darin, dass die Bauteilbezeichner voneinander abweichen können (etwa nach mehrmaliger Neuannotierung der PCB), ohne dass die Synchronisierbarkeit von Schaltplan und PCB gefährdet wird.
Wenn im Schaltplan oder auf der PCB ein Bauteil vorhanden ist, zu dem es im anderen Editor kein entsprechendes Bauteil mit derselben UID gibt, geschieht Folgendes:
- Wenn das zusätzliche Bauteil nur im Quelleditor vorhanden ist, wird ein ECO erzeugt, um das Bauteil im Zieleditor hinzuzufügen.
- Wenn das zusätzliche Bauteil nur im Zieleditor vorhanden ist, wird ein ECO erzeugt, um das zusätzliche Bauteil zu entfernen.
- Wenn in beiden Editoren nicht zugeordnete Bauteile vorhanden sind, benötigt die Software Anweisungen zum Umgang mit diesen Bauteilen. Deshalb wird der Dialog Failed to Match Unique Identifiers geöffnet.
Der Dialog e Failed to Match Unique Identifiers
Die Schaltflächen des Dialogs bieten die folgenden Optionen:
- Automatically Create Component Links - Klicken Sie auf diese Schaltfläche, wenn Sie wissen, dass die nicht zugeordneten Bauteile bereits übereinstimmende Bauteilbezeichner haben. Anhand dieser Bauteilbezeichner weist die Software den zusätzlichen Bauteilen übereinstimmende UIDs zu. Für Bauteile, die anhand ihres Bezeichners zugeordnet werden können, werden bei anderen abweichenden Eigenschaften (z. B. nicht übereinstimmenden Parametern) ECOs erzeugt. Wenn Bauteile nicht anhand ihres Bezeichners zugeordnet werden können, werden ECOs zum Hinzufügen bzw. Entfernen dieser Bauteile erzeugt: Zusätzliche Bauteile im Quelleditor werden hinzugefügt, zusätzliche Bauteile im Zieleditor werden entfernt.
-
Manual Component Links - Klicken Sie auf diese Schaltfläche, wenn Sie wissen, dass es zusammengehörige Bauteile gibt, Ihnen der Status ihrer Bezeichner jedoch nicht bekannt ist. Der Dialog Edit Component Links wird geöffnet (unten beschrieben). Dort können Sie jedes Quell- und Zielbauteil manuell auswählen und in die Liste der zugeordneten Bauteile übertragen, wodurch ihnen übereinstimmende UIDs zugewiesen werden. Anschließend werden ECOs erzeugt, um die Bauteilbezeichner und alle anderen nicht übereinstimmenden Bauteileigenschaften zu synchronisieren.
- Cancel - Klicken Sie auf diese Schaltfläche, um ECOs zu erzeugen, die zusätzliche Bauteile aus dem Quelleditor hinzufügen und zusätzliche Bauteile aus dem Zieleditor entfernen.
Bauteile manuell verknüpfen
Der Status der Verknüpfungen zwischen Schaltplanbauteilen und ihren entsprechenden PCB-Bauteil-Footprints kann jederzeit im Dialog Edit Component Links überprüft und verwaltet werden (PCB-Editor, Befehl Projects » Component Links).

Der Dialog „Bauteilverknüpfungen bearbeiten“ dient dazu, UID-Abweichungen zu erkennen und zu beheben. Er wird im PCB-Editor aufgerufen.
Zusammenfassung der Dialogfunktionen:
- Nicht zugeordnete Bauteile werden in den beiden Spalten Un-Matched Components auf der linken Seite angezeigt. Bauteile mit übereinstimmender UID werden im Bereich Matched Components auf der rechten Seite des Dialogs angezeigt.
- Mit den Pfeilschaltflächen in der Mitte des Dialogs können ausgewählte Bauteile manuell zugeordnet bzw. ihre Zuordnung aufgehoben werden. Außerdem kann die Zuordnung aller derzeit zugeordneten Bauteile aufgehoben werden.
- Mit der Schaltfläche Add Pairs Matched By und den Optionen am unteren Rand des Dialogs wird die Liste der derzeit nicht zugeordneten Bauteile durchsucht und versucht, diese anhand der aktivierten Eigenschaften (Bauteilbezeichner, Kommentar, Footprint) zuzuordnen.
- Wenn Sie auf die Schaltfläche Perform Update klicken, wird jedem neu zugeordneten PCB-Bauteil die UID seines entsprechenden Schaltplanbauteils zugewiesen. Wenn Sie Einträge im Matched Bereich des Dialogs zurück in die Unmatched -Bereiche verschieben, erscheint ein Bestätigungsdialog mit dem Hinweis, dass beim Fortfahren bestehende Bauteilzuordnungen aufgehoben werden. Durch Klicken auf Yes wird die Aktualisierung fortgesetzt, und ein Informationsdialog zeigt eine Zusammenfassung der im PCB-Dokument geänderten Bauteilverknüpfungen an. Ein neuer Eintrag im Bereich Matched wird als Link Modifiedzusammengefasst, während ein zuvor verknüpfter Eintrag, dessen Zuordnung Sie nun aufgehoben haben, als Link Removedzusammengefasst wird.
- Nachdem Sie in diesem Dialog Bauteile manuell verknüpft haben, empfiehlt es sich, den Synchronisierungsstatus zu prüfen (führen Sie den Befehl Design » Update aus).
Netze und Klassen zuordnen
Sowohl Netze als auch Klassen besitzen ein übergeordnetes Element (das Netz bzw. die Klasse) und untergeordnete Elemente (die Mitglieder dieses Netzes bzw. dieser Klasse). Ihre Zuordnung erfordert einen anderen Ansatz als den UID-Mechanismus zur Bauteilverknüpfung, um Änderungen am übergeordneten Element, an den untergeordneten Elementen oder an beiden zu unterstützen. Beispielsweise sollte eine einfache Änderung des Netznamens im Schaltplan nicht dazu führen, dass das Netz und alle zugehörigen Pins von der PCB entfernt werden müssen, anschließend das umbenannte Netz hinzugefügt wird und schließlich alle zugehörigen Pins diesem neuen Netz hinzugefügt werden.
Zu diesem Zweck enthält die Software separate Zuordnungsalgorithmen, die Netze und Klassen anhand ihrer Mitglieder sowie anhand ihrer Namen zuordnen. Der Zuordnungsprozess wird im Bereich Object Matching Criteria auf der Registerkarte Comparator des Dialogs Options for Project konfiguriert.

Standardmäßig erfolgt die Zuordnung zuerst anhand der Mitglieder und anschließend anhand des Namens des Objekttyps.
Die Zuordnung dieser Objekttypen erfolgt wie folgt:
- Bei der Designsynchronisierung wird standardmäßig zunächst versucht, die Zuordnung anhand der Mitglieder vorzunehmen, entsprechend den Einstellungen Min Match % und Min Match Member.
- Wenn die Zuordnung anhand der Mitglieder fehlschlägt, versucht die Software anschließend, die Zuordnung anhand des Namens vorzunehmen (sofern die Option Use Name Matching aktiviert ist).
- Wenn einer dieser Zuordnungsprozesse erfolgreich ist, gelangen Sie zum Dialog Engineering Change Order.
-
Wenn beide Zuordnungsverfahren fehlschlagen (oder die Option Use Name Matching auf
Nevergesetzt ist), wird der Dialog Match Manually geöffnet.
- Durch Klicken auf No im Dialog Match Manually wird die manuelle Zuordnung übersprungen und direkt der Dialog Engineering Change Order geöffnet. Da Sie nicht versucht haben, Objekte ohne Zuordnung einander zuzuordnen, geht die Software davon aus, dass die Referenz- und Zielobjekte nicht zusammengehören. Daher werden ECOs erzeugt, die Unmatched Reference Objects von der Leiterplatte entfernen und Unmatched Target Objects als neue Objekte hinzufügen.
- Wenn Sie im Dialog auf Yes klicken, um die Zuordnung manuell vorzunehmen, wird der Dialog Match geöffnet, wie unten gezeigt (der Dialogtitel ändert sich entsprechend dem Objekttyp ohne Zuordnung).
Der Dialog Match dient dazu, Objekte manuell zuzuordnen, von denen Sie wissen, dass sie zusammengehören. Lassen Sie die rechte Seite leer und klicken Sie auf Continue, wenn Sie unsicher sind.
Optionen und Bedienelemente des Zuordnungsdialogs
-
Unmatched <Object>
- Unmatched Reference Objects - listet die Objekte ohne Zuordnung auf. Verwenden Sie die Steuerelemente zum Erweitern/Reduzieren, um die Liste zu öffnen bzw. zu schließen.
- Unmatched Target Objects - listet die Zielobjekte auf. Verwenden Sie die Steuerelemente zum Erweitern/Reduzieren, um die Liste zu öffnen bzw. zu schließen.
-
- klicken Sie hier, um die ausgewählten Referenz- und Zielobjekte einander zuzuordnen und die ausgewählten Objekte aus dem Bereich Unmatched in den Bereich Matched Pairs zu verschieben.
-
- klicken Sie hier, um die ausgewählten Objekte aus dem Bereich Matched Pairs in den Bereich Unmatched zu verschieben. Dadurch wird die Zuordnung der verschobenen Objekte aufgehoben.
-
- klicken Sie hier, um alle Objekte aus dem Bereich Matched Pairs in den Bereich Unmatched zu verschieben. Dadurch wird die Zuordnung der verschobenen Objekte aufgehoben.
- Matched Pairs - listet die Reference Object und Target Object auf, die nun einander zugeordnet sind.
- Continue - klicken Sie hier, um die aktualisierten Zuordnungen zu übernehmen und den Dialog Engineering Change Order zu öffnen.
- Wählen Sie in diesem Dialog die Objekte, die Sie einander zuordnen möchten, in Unmatched Reference Objects und Unmatched Target Objects aus und übertragen Sie sie anschließend in den Bereich Matched Pairs des Dialogs. Für diese Objekte erzeugt die Software einen ECO zur Aktualisierung der Namen, sodass diese übereinstimmen, sowie ECOs zum Entfernen bzw. Hinzufügen von Mitgliedern, sodass auch diese übereinstimmen.
- Wenn Sie unsicher sind, müssen Sie Objekte nicht manuell zuordnen. Bei allen Objekten ohne Zuordnung geht die Software davon aus, dass die Referenz- und Zielobjekte nicht zusammengehören. Daher erzeugt sie ECOs, die Unmatched Reference Objects von der Leiterplatte entfernen und Unmatched Target Objects als neue Objekte hinzufügen.
- Sobald Sie die Objekte zugeordnet haben, von denen Sie wissen, dass sie zusammengehören, klicken Sie auf Continue, um den Dialog Engineering Change Order zu öffnen.
- Wenn Sie auf Cancel klicken, wird der Aktualisierungsprozess beendet.
Designregeln zuordnen
Designregeln, die im Schaltplan definiert sind, müssen ebenfalls mit der entsprechenden Regel auf der PCB verknüpft werden. Ohne einen Verknüpfungsmechanismus könnten Sie die Regel im Schaltplan nicht aktualisieren und diese Änderungen auf die PCB übertragen. UIDs werden verwendet, um die Schaltplan-Designregel mit der PCB-Designregel zu verknüpfen.
Die UID wird automatisch im Parametersatz zugewiesen, der die Regeldefinition im Schaltplan enthält, und bei der Designsynchronisierung auf die PCB übertragen.
Designregeln verwenden eine UID, um die Designregeldefinition im Schaltplan der PCB-Designregel zuzuordnen.
Normalerweise müssen Sie die Zuordnung der Regeln nicht manuell verwalten, es sei denn, Sie haben die UID im Dialog PCB Rules and Constraints im PCB-Editor manuell bearbeitet. Wenn die UIDs nicht übereinstimmen, fügt die Software für jede Schaltplanregel ohne entsprechende PCB-Regel eine neue Regel zur Leiterplatte hinzu und entfernt jede PCB-Designregel, für die keine entsprechende Schaltplan-Designregel vorhanden ist.
