Suchen nach Komponenten in datenbank- und dateibasierten Bibliotheken
Altium Essentials: Schematic Capture
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Verstehen Sie die Unterschiede zwischen Projektbibliotheken, installierten Bibliotheken und Suchpfadbibliotheken und erfahren Sie, wie sich diese jeweils auf die Verfügbarkeit von Bauteilen in Altium Designer auswirken.
- Erfahren Sie, wo Sie verfügbare Bibliotheken verwalten, wie die Suchreihenfolge funktioniert und warum bestimmte Einstellungen bei der Bibliothekseinrichtung die Geschwindigkeit und Zuverlässigkeit beeinflussen können.
- Lernen Sie, wie die Bauteilsuche in dateibasierten Bibliotheken und Datenbankbibliotheken funktioniert und was Sie bei der Verwendung von DbLib- und SVNDbLib-Quellen erwarten können.
Verfügbare Datenbank- und dateibasierte Bibliotheken verwalten
In Altium Designer können Komponenten aus Datenbank- und dateibasierten Bibliotheken nur dann platziert werden, wenn diese Bibliotheken aktuell verfügbar sind. Dazu gehören:
-
Libraries in the current project – wenn eine Bibliothek Teil des Projekts ist, stehen ihre Komponenten automatisch zur Platzierung innerhalb dieses Projekts zur Verfügung.
-
Installed libraries – diese Bibliotheken wurden in Altium Designer installiert; ihre Komponenten können in jedem geöffneten Projekt verwendet werden.
-
Libraries on a defined search path – es ist auch möglich, einen Suchpfad zu einem Ordner mit mehreren Bibliotheken zu definieren. Da bei jeder Auswahl einer neuen Komponente in einem Panel alle Dateien im Suchpfad durchsucht werden, empfiehlt sich dieser Ansatz nur für kleine Bibliotheken mit einfachen Modelldefinitionen, beispielsweise Simulationsmodellen. Für komplexe Modelle, etwa Footprints mit 3D-Modellen, werden Suchpfade nicht empfohlen.
Zum Verwalten verfügbarer Datenbank- und dateibasierter Bibliotheken können Sie den Dialog Libraries Preferences verwenden. Sie öffnen ihn, indem Sie oben im Panel Components auf die Schaltfläche
klicken und im Menü Libraries Preferences auswählen.
Der Dialog Libraries Preferences verfügt über drei Registerkarten. Alle auf diesen Registerkarten definierten Bibliotheken und Modellspeicherorte werden zu Ihrer Liste der verfügbaren Bibliotheken zusammengefasst. Bei einer Aktion, die eine Modellsuche erfordert, etwa der Übertragung des Designs vom Schaltplan in das PCB-Layout, werden die Bibliotheken in der Reihenfolge der Registerkarten durchsucht. Innerhalb jeder Registerkarte erfolgt die Suche in der Reihenfolge, in der die Bibliotheken/Modelle aufgeführt sind. Sobald das richtige Modell gefunden wurde, wird die Suche beendet.
Projektbibliotheken
Bibliotheken, die zum aktiven Projekt gehören, werden auf der Registerkarte Project des Dialogs Libraries Preferences aufgeführt, wenn dieses Projekt in der Software aktiv ist. Der Vorteil von Projektbibliotheken besteht darin, dass die Modelle/Bibliotheken beim Öffnen des Projekts automatisch verfügbar werden. Der Nachteil ist, dass Modelle/Bibliotheken leicht vergessen werden können, wenn die Projektdateien verschoben werden und sie nicht in derselben Projektordnerstruktur wie die Designdateien gespeichert sind.

Die Registerkarte Project enthält eine Liste der verfügbaren Bibliotheken im aktuellen Projekt.
Installierte Bibliotheken
Bibliotheken und Modelle, die in Ihrer Softwareinstallation verfügbar gemacht wurden, werden als installierte Bibliotheken bezeichnet. Sie werden auf der Registerkarte Installed des Dialogs Libraries Preferences aufgeführt.
Installierte Bibliotheken können mit einem absoluten Pfad oder einem Pfad relativ zur Einstellung Library Path Relative To aufgeführt werden. Der Vorteil eines relativen Pfads besteht darin, dass Sie damit auf mehreren PCs eine gemeinsame Teilumgebung erstellen und die Designdateien problemlos zwischen diesen PCs verschieben können. Außerdem lassen sich installierte Bibliotheken vorübergehend deaktivieren, indem Sie das Kontrollkästchen Activated deaktivieren, anstatt sie zu entfernen.

Die Registerkarte Installed listet die Bibliotheken auf, die in dieser Installation von Altium Designer verfügbar gemacht wurden.
Suchpfad
Die Registerkarte Search Path zeigt eine Liste der Bibliotheken, die anhand der Pfadeinstellungen auf der Registerkarte „Suchpfade“ des Dialogs „Projektoptionen“ gefunden wurden. Diesen Dialog öffnen Sie über die Schaltfläche Paths. Jeder Suchpfad definiert einen Ordner und kann Unterordner einschließen, wenn die Option Recursive aktiviert ist (verfügbar auf der Registerkarte Search Paths des Dialogs Project Options , nachdem ein Pfad hinzugefügt wurde). Alle im Suchpfad gefundenen Modell- und Bibliotheksdateien stehen zur Verfügung. Suchpfade werden mit dem Projekt gespeichert.

Die Registerkarte Search Path listet die Bibliotheken auf, die in den definierten Suchpfaden gefunden wurden.
Das Abrufen von Modellen über Suchpfade kann langsam sein, wenn sich in den Suchpfadordnern sehr viele Dateien befinden. Daher wird dieser Ansatz für PCB-Bibliotheken nicht empfohlen, da diese große Dateien mit vielen Footprints sein können. Die Funktion wurde entwickelt, um auf verfügbare Simulations- und Signalintegritätsmodelle verweisen zu können.
Datenbankkomponenten durchsuchen
Sobald die DbLib/SVNDbLib zur Liste der verfügbaren dateibasierten Bibliotheken hinzugefügt wurde, können die Komponenten in der Datenbank im Panel Components durchsucht werden. Obwohl nur eine einzige DbLib/SVNDbLib-Datei hinzugefügt wird, wird jede Tabelle in der verknüpften Datenbank wie eine eigenständige Bibliothek dargestellt.
Die oberste Dropdown-Liste im Panel wird mit Einträgen im folgenden Format gefüllt:
- <LibraryName>.DbLib - <TableName> oder <LibraryName>.SVNDbLib - <TableName> ----wenn Ihre Datenbank Tabellen enthält
- <LibraryName>.DbLib - <SheetName>$ oder <LibraryName>.SVNDbLib - <SheetName>$ ----wobei Ihre Datenbank aus Tabellenblättern in einer Excel-Arbeitsmappe besteht.
Beispiel einer geladenen DbLib mit drei Tabellen, einer weiteren mit einer Tabelle und einer SVNDbLib mit einer Tabelle.
Jeder Bauteileintrag im Panel entspricht einem Datensatz in der jeweiligen Tabelle der Datenbank. Beim Durchsuchen geladener Datenbankbibliotheken verhält sich das Components Panel tatsächlich wie ein direkter Datenbankbrowser. Symbol- und Modellinformationen werden aus den zugrunde liegenden Symbol- und Modellbibliotheken abgerufen, auf die die entsprechenden Datenbankfelder verweisen (unter Berücksichtigung der definierten Suchpfade und Speicherorte).
Durchsuchen von Bauteilen in einer externen Datenbank, die über eine Datenbankbibliothek verknüpft ist.
Standardmäßig werden im Bauteillistenbereich des Panels nur die Felder Part Number und Library Ref angezeigt. Um weitere Felder der Datenbanktabelle einzublenden, klicken Sie mit der rechten Maustaste in diesen Bereich und wählen Sie im Kontextmenü Select Columns. Dadurch öffnen Sie den Dialog „Spalten auswählen“, in dem Sie die Anzeige aller weiteren Felder dieser Tabelle aktivieren können.
Lokales Zwischenspeichern von Symbolen und Modellen für SVN-Datenbankbibliotheken
Wenn eine SVNDbLib-Datei zur Liste der verfügbaren Bibliotheken hinzugefügt wird, werden die Symbol- und Modellbibliotheken aus dem Repository in einem temporären Ordner auf dem Computer des Entwicklers zwischengespeichert. Wenn eine Aktion in der Software die Verwendung eines Schaltplansymbols oder Modells erfordert, wird dieses Symbol bzw. Modell aus dem lokalen Cache abgerufen.
Automatische Cache-Aktualisierung
Die Bibliotheken im Cache werden automatisch auf den neuesten Stand des Versionsverwaltungs-Repositorys aktualisiert, wenn eine der folgenden Aktionen in der Software ausgeführt wird:
-
Platzieren eines Bauteils aus einer installierten SVNDbLib-Datei (über das Panel „Components“).
-
Durchführen einer Designübertragung (d. h. Aktualisieren der Leiterplatte).
-
Verwenden des Befehls Tools » Update From Libraries im Schaltplaneditor.
-
Verwenden des Befehls Tools » Update From PCB Libraries im PCB-Editor.
Die Aktualisierung erfolgt zwar automatisch, lässt sich jedoch über die Option Do not check files more often than xx minutes auf der Seite „Data Management - SVN Libraries“ des Preferences Dialogs steuern. Diese Option legt im Wesentlichen ein Aktualisierungsintervall für den lokalen Cache fest. Wenn die angegebene Zeit seit der letzten Cache-Aktualisierung verstrichen ist, wird der Cache beim Ausführen einer der aufgeführten Aktionen automatisch aktualisiert. Wird eine Aktion innerhalb dieses Zeitraums ausgeführt, wird der aktuelle Cache-Inhalt verwendet, der gegenüber dem Inhalt des Repositorys möglicherweise veraltet ist.
Manuelles Erzwingen einer Cache-Aktualisierung
Gelegentlich möchten Sie möglicherweise eine Aktualisierung des lokalen Caches erzwingen, um sicherzustellen, dass Sie über die neuesten Bibliotheken verfügen, die derzeit im Versionsverwaltungs-Repository gespeichert sind. Dies kann beispielsweise vor der Übertragung des Designs vom Schaltplan auf die Leiterplatte sinnvoll sein.
Sie können eine Cache-Aktualisierung mit einer der folgenden Methoden manuell erzwingen:
- Verwenden eines der Refresh Befehle, die über ein Kontextmenü im Panel „Components“ verfügbar sind.
- Deinstallieren und erneutes Installieren der SVNDbLib-Datei in der Liste der verfügbaren Bibliotheken.
Suchen nach Bauteilen in Datenbank- und dateibasierten Bibliotheken
Um die Suche nach einem Bauteil in dateibasierten Bibliotheken (sowohl installierten als auch derzeit nicht installierten) und Datenbankbibliotheken zu erleichtern, bietet Altium Designer eine Bibliothekssuchfunktion.
Die Suche nach einem Bauteil in Datenbank- und dateibasierten Bibliotheken ist über das Feld Search des Panels Components möglich. Geben Sie eine Zeichenfolge ein und drücken Sie Enter, um die aktuelle Bibliothek innerhalb aller sichtbaren Bauteilparameter nach dieser Zeichenfolge zu durchsuchen.
Sie können eine Suche direkt im Panel Components durchführen.
Der Dialog File-based Libraries Search ermöglicht eine detailliertere Suche. Sie öffnen ihn, indem Sie im Panel Components auf die Schaltfläche
klicken und im Menü File-based Libraries Search auswählen. In der oberen Hälfte des Dialogs legen Sie fest, what Sie suchen; in der unteren Hälfte legen Sie fest, where gesucht werden soll.
Durchsuchen Sie installierte Bibliotheken (Available libraries) oder Bibliotheken auf der Festplatte (Libraries on path).Der Suchvorgang lässt sich wie folgt zusammenfassen:
-
Die Suche erfolgt durch die Definition von Filters, die auf alle Bibliotheken angewendet werden, die gemäß den aktuellen Sucheinstellungen für Scope durchsucht werden können.
-
Der Scope umfasst den Typ der zu durchsuchenden Bibliotheken. Es kann jeweils nur ein Typ durchsucht werden.
-
Um die Suche nach Datenbankbauteilen zu aktivieren, setzen Sie das Feld Search in auf Database Components und wählen Sie die erforderliche Table aus. Beachten Sie, dass sich die verfügbaren Fields in der obigen Dropdown-Liste an die Spaltenüberschriften der ausgewählten Tabelle anpassen. Die übrigen Optionen im Dialog werden ausgegraut, da sie für die Suche in Datenbankbibliotheken nicht relevant sind.
-
Der Scope legt fest, welche Bibliotheken durchsucht werden: entweder die Bibliotheken, auf die die Software derzeit Zugriff hat (Available libraries), oder alle Bibliotheken innerhalb eines Ordners (Libraries on path).
-
Beim Durchsuchen von Bibliotheken in einem Pfad ist ein bestimmter Ordner das Ziel; außerdem ist Include Subdirectories möglich.
-
Sie können auch innerhalb der Suchergebnisse suchen, indem Sie Scope auf Refine last search setzen.
-
Klicken Sie auf Clear, um die eingegebenen Suchparameter zu löschen.
Festlegen des Suchfilters
Im Bereich Filters werden die Zeichenfolgen definiert, die bei der Suche verwendet werden sollen. Es sind drei Bereiche zu konfigurieren:
-
Field – Dies ist das Attribut des Bauteils, das durchsucht werden soll. Es kann sich um ein beliebiges Bauteil- oder Footprint-Attribut handeln, einschließlich Name, Beschreibung, Kommentar, Footprint oder eines beliebigen Parameters, der einem Bauteil hinzugefügt wurde. Wählen Sie ein verfügbares Feld aus der Dropdown-Liste aus oder geben Sie ein Feld in das Textfeld ein.
-
Operator – Legt fest, wie eine Übereinstimmung ermittelt wird. Diese kann vorliegen, wenn der Wert equals, contains, starts with oder ends with. Beachten Sie, dass equals eine exakte Übereinstimmung der Zeichenfolge erfordert und daher nur verwendet werden sollte, wenn Sie sicher sind, dass die Suchzeichenfolge korrekt und vollständig ist.
-
Value – Die Zeichen, nach denen im ausgewählten Field gemäß dem ausgewählten Operator gesucht werden soll. Wählen Sie einen verfügbaren Wert aus der Dropdown-Liste aus oder geben Sie einen Wert in das Textfeld ein.
Standardmäßig gibt es drei Filterbedingungen. Über das Add Row Steuerelement können Sie bis zu sieben weitere Zeilen hinzufügen, also insgesamt 10 Zeilen. Die zuletzt hinzugefügte Zeile mit einer Filterbedingung lässt sich über Remove Row entfernen. Nicht verwendete Zeilen können Sie entfernen.
Festlegen des Suchbereichs
Grundsätzlich gibt es zwei Suchansätze:
-
Derzeit verfügbare Bibliotheken – Dies ist die Liste der Bibliotheken, die in der Dropdown-Liste oben im Components Panel angezeigt wird.
-
Bibliotheken, die in einem bestimmten Ordner gespeichert sind, einschließlich der Unterverzeichnisse, sofern die Option aktiviert ist.
Die Suche liefert alle Elemente des im Dropdown-Menü Search in ausgewählten Suchtyps (Components/Footprints/3D Models/Database Components), die in allen Bibliotheken innerhalb des definierten Scope gefunden werden:
- Available libraries – aktivieren, um nur in verfügbaren Bibliotheken nach den angegebenen Modelltypen zu suchen.
-
Libraries on path – aktivieren, um in verfügbaren Bibliotheken in einem oder mehreren angegebenen Ordnern nach den angegebenen Modelltypen zu suchen. Im Bereich Path des Dialogfelds, der bei ausgewählter Suchbereichsoption Libraries on path verfügbar wird, können Sie den Pfad festlegen, Unterverzeichnisse einbeziehen und eine Dateimaske für Bibliotheken angeben, um die Suchkriterien festzulegen und einzugrenzen:
- Path – geben Sie den Ordner an, in dem nach Bibliotheken gesucht werden soll, oder klicken Sie auf das Symbol zum Durchsuchen am Ende des Felds, um einen Ordner auszuwählen.
- Include Subdirectories – aktivieren, wenn Sie im angegebenen Pfad und seinen Unterverzeichnissen nach Bibliotheken suchen möchten.
-
File Mask – geben Sie die Zeichenfolge für die Dateimaske ein oder wählen Sie eine der vorhandenen Dateimasken aus der Dropdown-Liste aus. Die Suche wird auf Dateien gefiltert, die der Zeichenfolge entsprechen. Sie können das Platzhalterzeichen * (beliebiges Zeichen) in der Zeichenfolge verwenden. Geben Sie beispielsweise * ein, um alle Dateien zu durchsuchen, und M, um alle Dateien zu durchsuchen, die mit dem Buchstaben M beginnen.
Wenn Sie beispielsweise ein Bauteil suchen möchten, das sich Ihrer Vermutung nach in einer Bibliothek in bestimmten Ordnern auf der Festplatte befindet, und diese Bibliothek derzeit nicht in Available File-based Libraries aufgeführt ist, definieren Sie die Suche wie folgt:
- Setzen Sie im Bereich Scope die Einstellung Search in auf Components und wählen Sie Libraries on path aus.
- Legen Sie im Bereich Path den Path so fest, dass er auf den Ordner mit dem zu durchsuchenden Bibliotheksdokument verweist.
- Klicken Sie auf Search. Die Ergebnisse werden während der Suche im Panel Components angezeigt.
Erweiterter Suchmodus
Die Bibliothekssuche wird mithilfe von Abfragen durchgeführt. Wechseln Sie im Dialogfeld File-based Libraries Search in den Modus Advanced, um die Abfrage zu prüfen.
Im Modus Advanced des Dialogfelds können Sie auch eigene Abfragen mithilfe der Schlüsselwörter der Abfragesprache erstellen, um eine abfragebasierte Suche durchzuführen. Weitere Informationen zu den verfügbaren Schlüsselwörtern der Abfragesprache finden Sie im folgenden Abschnitt.
Verwenden Sie die folgenden zusätzlichen Bedienelemente, wenn der Modus Advanced ausgewählt ist:
-
Helper – klicken Sie hier, um das Dialogfeld Abfrage-Assistent zu öffnen und mithilfe vordefinierter Bibliotheks- und Systemfunktionen einfach eine Bibliothekssuchabfrage zu erstellen. Sie können auch die Schaltflächen History und Favorites verwenden, um eine kürzlich verwendete oder vordefinierte Bibliotheksabfrage auszuwählen.
-
History – klicken Sie hier, um das Dialogfeld Ausdrucksverwaltung zu öffnen und einen der zuvor verwendeten Abfrageausdrücke für die Bibliothekssuche auszuwählen. Sie können auch die Schaltfläche Favorites verwenden, um eine vordefinierte Abfrage für eine bestimmte Bibliothekssuche zu verwenden.
-
Favorites – klicken Sie hier, um das Dialogfeld Ausdrucksverwaltung zu öffnen und einen Ihrer bevorzugten Abfrageausdrücke für eine Bibliothekssuche auszuwählen. Sie können die Liste Favorites auch ändern, indem Sie Ausdrücke aus der Liste History entfernen, umbenennen oder kopieren.
Bei der Suche in Database Components ermöglicht der Modus Advanced eine Suche per SQL-Abfrage. Diese Suche bietet eine präzise Eingrenzung anhand eines angegebenen Abfrageausdrucks. Dabei können Sie eine SQL-Abfrage direkt in den Abfrageeditorbereich des Dialogfelds eingeben.
Klicken Sie auf Advanced , um auf eine leistungsstarke SQL-basierte Abfragesuche zuzugreifen. Klicken Sie erneut auf Advanced , um zur einfachen Suche zurückzukehren.
Abfragefunktionen für Bauteile und Bibliotheken

Abfragefunktionen für Bauteile und Bibliotheken im Dialogfeld Query Helper
Den Schaltplan- und PCB-Editoren von Altium Designer liegt eine leistungsstarke Abfrage-Engine zugrunde. Durch die Eingabe von Abfragen in diese Engine können Sie mithilfe logischer Bedingungen genau die benötigten Objekte eingrenzen.
Eine Abfrage ist eine Zeichenfolge, die Sie unter Verwendung bestimmter Schlüsselwörter und einer bestimmten Syntax eingeben und die die gesuchten Objekte zurückgibt. Es stehen zahlreiche Schlüsselwörter zur Verfügung, mit denen Sie Objekte anhand ihres Typs, ihrer Eigenschaften oder beidem gezielt auswählen können.
Die folgenden Abschnitte beschreiben die Schlüsselwörter der Abfragesprache, die bei der Suche nach datenbank- und dateibasierten Bauteilen in Altium Designer verfügbar sind. Hilfe zu einem bestimmten Abfrageschlüsselwort erhalten Sie in den folgenden aufklappbaren Abschnitten oder indem Sie das jeweilige Schlüsselwort in Query Helper markieren (oder hineinklicken).
Bauteile
Kommentar
Zusammenfassung
Gibt alle Bauteile zurück, deren Comment der Abfrage entspricht.
Syntax
Comment : String
Anwendungsbeispiele
Comment = 'Res1'
Gibt alle Bauteile zurück, deren Comment gleich Res1 ist.
Comment = '100nF'
Gibt alle Bauteile zurück, deren Comment gleich 100nF ist.
Comment Like '*33*'
Gibt alle Bauteile zurück, deren Comment den Wert 33 enthält.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialogfeld Suche in Dateibibliotheken auf Components gesetzt ist.
-
Bei der Suche nach Bauteilen werden alle verfügbaren oder entlang eines definierten Suchpfads liegenden SchLib- und IntLib-Bibliotheken durchsucht.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Bauteiltyp
Zusammenfassung
Gibt alle Bauteile zurück, deren Eigenschaft Component Type der Abfrage entspricht.
Syntax
ComponentType = ComponentType_String
ComponentType_String muss eine der Zeichenfolgen aus der folgenden Liste sein:
- 'Graphical'
- 'Jumper'
- 'Mechanical'
- 'Net Tie'
- 'Net Tie (In BOM)'
- 'Standard'
- 'Standard (No BOM)'
Anwendungsbeispiele
ComponentType = 'Graphical'
Gibt alle Bauteile zurück, deren Component Type Graphical ist.
ComponentType = 'Standard'
Gibt alle Bauteile zurück, deren Component Type Standard ist.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialogfeld Dateibibliotheken durchsuchen auf Components eingestellt ist.
-
Bei der Bauteilsuche werden alle SchLib- und IntLib-Bibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden.
-
Alle Ergebnisse werden anschließend in der Liste Query Results im Panel Bauteile aufgeführt.
-
Die einfachen Anführungszeichen (') am Anfang und Ende von
ComponentType_Stringsind erforderlich.
Bezeichner
Zusammenfassung
Gibt alle Bauteile zurück, deren Eigenschaft Designator der Abfrage entspricht.
Syntax
Designator : String
Anwendungsbeispiele
Designator = 'U2'
Gibt alle Bauteile zurück, deren Eigenschaft Designator U2 ist.
Designator Like '*Channel*'
Gibt alle Bauteile zurück, deren Eigenschaft Designator Channel enthält.
Designator <> 'C*'
Gibt alle Bauteile zurück, except deren Eigenschaft Designator mit C beginnt.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialogfeld Dateibibliotheken durchsuchen auf Components eingestellt ist.
-
Bei der Bauteilsuche werden alle SchLib- und IntLib-Bibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
HasModel
Zusammenfassung
Gibt jedes Bauteil zurück, das mit einem Domänenmodell verknüpft ist (oder darauf verweist), dessen Eigenschaften der Abfrage entsprechen.
Syntax
HasModel(ModelType : String,ModelName : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
Die Zeichenfolge ModelType gibt die Eigenschaft Type eines verknüpften Modells an und muss eine der Zeichenfolgen aus der folgenden Liste sein:
- 'PCB3DLIB' – Verwenden Sie diese Zeichenfolge, um ein verknüpftes Modell anzusprechen, dessen Eigenschaft Type PCB3D ist.
- 'PCBLIB' – Verwenden Sie diese Zeichenfolge, um ein verknüpftes Modell anzusprechen, dessen Eigenschaft Type Footprint ist.
- 'IBIS' – Verwenden Sie diese Zeichenfolge, um ein verknüpftes Modell anzusprechen, dessen Eigenschaft Type Ibis Model ist.
- 'SI' – Verwenden Sie diese Zeichenfolge, um ein verknüpftes Modell anzusprechen, dessen Eigenschaft Type Signal Integrity ist.
- 'SIM' – Verwenden Sie diese Zeichenfolge, um ein verknüpftes Modell anzusprechen, dessen Eigenschaft Type Simulation ist.
Die Zeichenfolge ModelName gibt die Eigenschaft Name eines verknüpften Modells an.
Der Parameter CurrentModelOnly gibt an, ob das verknüpfte Modell das aktuelle Modell des jeweiligen Bauteils sein muss. Bei False muss das verknüpfte Modell nicht das aktuelle Modell sein (kann es aber sein); bei True muss das verknüpfte Modell das aktuelle Modell sein.
Anwendungsbeispiele
HasModel('PCBLIB','SOIC14',False)
HasModel('PCBLIB','SOIC14',False) = True
HasModel('PCBLIB','SOIC14',False) = 'True'
Gibt alle Bauteile zurück, die mit einem Footprint-Modell verknüpft sind, dessen Eigenschaft Name SOIC14 ist. Dieses Modell muss nicht das aktuelle Footprint-Modell des jeweiligen Bauteils sein (kann es aber sein).
HasModel('PCBLIB','DIP14',True)
HasModel('PCBLIB','DIP14',True) = True
HasModel('PCBLIB','DIP14',True) = 'True'
Gibt alle Bauteile zurück, die mit einem Footprint-Modell verknüpft sind, dessen Eigenschaft Name DIP14 ist. Dieses Modell muss das aktuelle Footprint-Modell des Bauteils sein.
HasModel('SI','RES1',False)
HasModel('SI','RES1',False) = True
HasModel('SI','RES1',False) = 'True'
Gibt alle Bauteile zurück, die mit einem Signalintegritätsmodell verknüpft sind, dessen Eigenschaft Name RES1 ist. Dieses Modell muss nicht das aktuelle Signalintegritätsmodell des jeweiligen Bauteils sein (kann es aber sein).
HasModel('SIM','RESISTOR',True)
HasModel('SIM','RESISTOR',True) = True
HasModel('SIM','RESISTOR',True) = 'True'
Gibt alle Bauteile zurück, die mit einem Simulationsmodell verknüpft sind, dessen Eigenschaft Name RESISTOR ist. Dieses Modell muss das aktuelle Simulationsmodell des Bauteils sein.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialogfeld Dateibibliotheken durchsuchen auf Components eingestellt ist.
-
Bei der Bauteilsuche werden alle SchLib- und IntLib-Bibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
HasModelParameter
Zusammenfassung
Gibt jedes Bauteil zurück, das mit einem Domänenmodell verknüpft ist (oder darauf verweist), das ein Parameterobjekt enthält, dessen Eigenschaften Parameter Name und Value der Abfrage entsprechen.
Syntax
HasModelParameter(Parameter Name : String,Value : String,CurrentModelOnly : Boolean) : Boolean/Boolean_String
Der Parameter CurrentModelOnly gibt an, ob das verknüpfte Modell (das einen passenden Parameter enthält) das aktuelle Modell des jeweiligen Bauteils sein muss. Bei False muss das verknüpfte Modell nicht das aktuelle Modell sein (kann es aber sein); bei True muss das verknüpfte Modell das aktuelle Modell sein.
Anwendungsbeispiele
HasModelParameter('Inductance A','1mH',False)
HasModelParameter('Inductance A','1mH',False) = True
HasModelParameter('Inductance A','1mH',False) = 'True'
Gibt alle Bauteile zurück, die mit einem Modell verknüpft sind, das ein Parameterobjekt enthält, dessen Eigenschaft Parameter Name Inductance A und dessen Eigenschaft Value 1mH ist. Dieses Modell muss nicht das aktuelle Modell des jeweiligen Bauteils sein (kann es aber sein).
HasModelParameter('Coupling Factor','0.999',True)
HasModelParameter('Coupling Factor','0.999',True) = True
HasModelParameter('Coupling Factor','0.999',True) = 'True'
Gibt alle Bauteile zurück, die mit einem Modell verknüpft sind, das ein Parameterobjekt enthält, dessen Eigenschaft Parameter Name Coupling Factor und dessen Eigenschaft Value 0.999 ist. Dieses Modell muss das aktuelle Modell des Bauteils sein.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialogfeld Dateibibliotheken durchsuchen auf Components eingestellt ist.
-
Bei der Bauteilsuche werden alle SchLib- und IntLib-Bibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
LibReference
Zusammenfassung
Gibt alle Bauteile zurück, deren Eigenschaft Library Reference der Abfrage entspricht.
Syntax
LibReference : String
Anwendungsbeispiele
LibReference = 'LM833'
Gibt alle Bauteile zurück, deren Eigenschaft Library Reference LM833 ist.
LibReference Like 'C*'
Gibt alle Bauteile zurück, deren Eigenschaft Library Reference mit C beginnt.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialogfeld Dateibibliotheken durchsuchen auf Components eingestellt ist.
-
Bei der Bauteilsuche werden alle SchLib- und IntLib-Bibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Teilanzahl
Zusammenfassung
Gibt alle Bauteile zurück, deren Eigenschaft Part Count der Abfrage entspricht.
Syntax
PartCount : Number
Anwendungsbeispiele
PartCount = 2
Gibt alle Bauteile zurück, deren Part Count gleich 2 ist.
PartCount > 4
Gibt alle Bauteile zurück, deren Part Count größer als 4 ist (d. h. alle mehrteiligen Bauteile mit mehr als vier Teilkomponenten).
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialog Dateibibliotheken durchsuchen auf Components eingestellt ist.
-
Bei der Suche nach Bauteilen werden alle verfügbaren oder unter einem definierten Suchpfad befindlichen SchLib- und IntLib-Bibliotheken durchsucht.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Pinanzahl
Zusammenfassung
Gibt alle Bauteile zurück, deren Eigenschaft Pin Count der Abfrage entspricht.
Syntax
PinCount : Number
Anwendungsbeispiele
PinCount = 2
Gibt alle Bauteile zurück, deren Pin Count gleich 2 ist.
PinCount > 14
Gibt alle Bauteile zurück, deren Pin Count größer als 14 ist.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialog Dateibibliotheken durchsuchen auf Components eingestellt ist.
-
Bei der Suche nach Bauteilen werden alle verfügbaren oder unter einem definierten Suchpfad befindlichen SchLib- und IntLib-Bibliotheken durchsucht.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Alle
Beschreibung
Zusammenfassung
Gibt alle Bauteile oder Footprints zurück, deren Eigenschaft Description der Abfrage entspricht.
Syntax
Description : String
Anwendungsbeispiele
Description = 'TTL-RS232 DRIVER'
Gibt alle Bauteile oder Footprints zurück, deren Eigenschaft Description gleich TTL-RS232 DRIVER ist.
Description Like '*RS485*'
Gibt alle Bauteile oder Footprints zurück, deren Eigenschaft Description den Wert RS485 enthält.
Hinweise
-
Welche Objekte zurückgegeben werden – Bauteile oder Footprints –, hängt vom gewählten Suchbereich ab, der über das Feld Search in im Dialog Dateibibliotheken durchsuchen festgelegt wird.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Hat Parameter
Zusammenfassung
Gibt alle Bauteile zurück, die ein Parameterobjekt enthalten, dessen Eigenschaften Parameter Name und Value der Abfrage entsprechen.
Syntax
HasParameter(Parameter Name : String,Value : String) : Boolean/Boolean_String
Anwendungsbeispiele
HasParameter('Comment','1K')
HasParameter('Comment','1K') = True
HasParameter('Comment','1K') = 'True'
Gibt alle Bauteile zurück, die ein Parameterobjekt enthalten, dessen Eigenschaft Parameter Name gleich Comment und dessen Eigenschaft Value gleich 1K ist.
Hinweise
-
Welche Objekte zurückgegeben werden – Bauteile oder Footprints –, hängt vom gewählten Suchbereich ab, der über das Feld Search in im Dialog Dateibibliotheken durchsuchen festgelegt wird.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Bibliotheksname
Zusammenfassung
Gibt alle Bauteile oder Footprints zurück, bei denen der Name der zugehörigen Bibliothek der Abfrage entspricht.
Syntax
LibraryName : String
Anwendungsbeispiele
LibraryName = 'Miscellaneous Devices.SchLib'
Gibt alle Bauteile zurück, deren zugehörige Bibliothek Miscellaneous Devices.SchLib ist.
LibraryName Like 'Miscellaneous*.IntLib'
Gibt alle Bauteile oder Footprints zurück, bei denen der Name der zugehörigen Bibliothek mit Miscellaneous beginnt und mit .IntLib endet.
LibraryName Like '*Vishay*'
Gibt alle Bauteile zurück, bei denen der Name der zugehörigen Bibliothek Vishay enthält.
Hinweise
-
Welche Objekte zurückgegeben werden – Bauteile oder Footprints –, hängt vom gewählten Suchbereich ab, der über das Feld Search in im Dialog Dateibibliotheken durchsuchen festgelegt wird.
-
Bei der Suche nach Bauteilen werden alle verfügbaren oder unter einem definierten Suchpfad befindlichen SchLib-, IntLib- und DbLib-Bibliotheken durchsucht. Bei der Suche nach Footprints werden alle PcbLib- und IntLib-Bibliotheken durchsucht.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Bibliothekspfad
Zusammenfassung
Gibt alle Bauteile oder Footprints zurück, die sich in der als Teil der Abfrage angegebenen Bibliothek befinden.
Syntax
LibraryPath : String
Anwendungsbeispiele
LibraryPath = 'C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Gibt alle Bauteile zurück, deren zugehörige Bibliothek MyExampleLibrary.SchLib ist und bei denen sich diese Bibliothek im Ordner C:\Documents\Altium\Library befindet.
LibraryPath Like ' C:\Documents\Altium\Library\Miscellaneous*.IntLib'
Gibt alle Bauteile oder Footprints zurück, bei denen der Name der zugehörigen Bibliothek mit Miscellaneous beginnt und mit .IntLib endet und sich diese Bibliothek im Ordner C:\Documents\Altium\Library befindet.
LibraryPath = 'C:\Test Projects\Example DBLib\VishayCapacitor.DBLib'
Gibt alle Bauteile zurück, deren zugehörige Bibliothek VishayCapacitor.DBLib ist und bei denen sich diese Bibliothek im Ordner C:\Test Projects\Example DBLib befindet.
Hinweise
-
Welche Objekte zurückgegeben werden – Bauteile oder Footprints –, hängt vom gewählten Suchbereich ab, der über das Feld Search in im Dialog Dateibibliotheken durchsuchen festgelegt wird.
-
Bei der Suche nach Bauteilen werden alle unter dem definierten Bibliothekspfad verfügbaren SchLib-, IntLib- und DbLib-Bibliotheken durchsucht. Bei der Suche nach Footprints werden alle PcbLib- und IntLib-Bibliotheken durchsucht.
-
Alle Ergebnisse werden in der Liste Query Results im Panel Bauteile aufgeführt.
Name
Zusammenfassung
Gibt alle Bauteile oder Footprints zurück, deren Name der Abfrage entspricht.
Syntax
Name : String
Anwendungsbeispiele
Name = 'Res1'
Gibt alle Bauteile oder Footprints zurück, deren Name Res1 ist.
Name Like 'DIP*'
Gibt alle Bauteile oder Footprints zurück, deren Name mit DIP beginnt.
Name Like '*33*'
Gibt alle Bauteile oder Footprints zurück, deren Name 33 enthält.
Hinweise
-
Welche Objekte zurückgegeben werden – Bauteile oder Footprints –, hängt vom gewählten Suchbereich ab, der über das Feld Search in im Dialog Dateibibliotheken durchsuchen festgelegt wird.
-
Bei der Suche nach Bauteilen werden alle verfügbaren oder unter einem definierten Suchpfad befindlichen SchLib- und IntLib-Bibliotheken durchsucht. Bei der Suche nach Footprints werden alle PcbLib- und IntLib-Bibliotheken durchsucht.
-
Alle Ergebnisse werden anschließend in der Liste Query Results im Panel Bauteile aufgeführt.
-
Der Name eines Schaltplanbauteils wird anhand seiner Eigenschaft Design Item ID geprüft, und der Name eines PCB-Footprints wird anhand seiner Eigenschaft Footprint geprüft.
Name der Quellbibliothek
Zusammenfassung
Gibt alle Bauteile oder Footprints zurück, bei denen der Name der zugehörigen Quellbibliothek der Abfrage entspricht.
Syntax
SourceLibraryName : String
Anwendungsbeispiele
SourceLibraryName = 'Miscellaneous Devices.SchLib'
Gibt alle Bauteile zurück, deren zugehörige Quellbibliothek Miscellaneous Devices.SchLib ist.
SourceLibraryName = 'Miscellaneous Devices.PcbLib '
Gibt alle Footprints zurück, deren übergeordnete Quellbibliothek Miscellaneous Devices.PcbLib ist.
Hinweise
-
Die zurückgegebenen Objekte – Bauteile oder Footprints – hängen vom gewählten Suchbereich ab, der über das Feld Search in im Dialog „File Libraries Search“ festgelegt wird.
-
Bei der Suche nach Bauteilen werden nur Schaltplan-Quellbibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden. Bei der Suche nach Footprints werden nur PCB-Bibliotheken durchsucht.
-
Alle Ergebnisse werden in der Liste Query Results im Panel „Components“ aufgeführt.
Quellbibliothekspfad
Zusammenfassung
Gibt alle Bauteile oder Footprints zurück, die sich in der in der Abfrage angegebenen Quellbibliothek befinden.
Syntax
SourceLibraryPath : String
Anwendungsbeispiele
SourceLibraryPath = ' C:\Documents\Altium\Library\MyExampleLibrary.SchLib'
Gibt alle Bauteile zurück, deren übergeordnete Quellbibliothek MyExampleLibrary.SchLib ist und deren Bibliothek sich im Ordner C:\Documents\Altium\Library befindet.
SourceLibraryPath = ' C:\Documents\Altium\Library\Miscellaneous Devices.PcbLib'
Gibt alle Footprints zurück, deren übergeordnete Quellbibliothek Miscellaneous Devices.PcbLib ist und deren Bibliothek sich im Ordner C:\Documents\Altium\Library befindet.
SourceLibraryPath Like ' C:\Documents\Altium\Library\*'
Gibt alle Bauteile oder Footprints zurück, deren übergeordnete Quellbibliothek sich im Ordner C:\Documents\Altium\Library befindet.
Hinweise
-
Die zurückgegebenen Objekte – Bauteile oder Footprints – hängen vom gewählten Suchbereich ab, der über das Feld Search in im Dialog „File Libraries Search“ festgelegt wird.
-
Bei der Suche nach Bauteilen werden nur Schaltplanbibliotheken durchsucht, die entlang des definierten Bibliothekspfads verfügbar sind. Bei der Suche nach Footprints werden nur PCB-Bibliotheken durchsucht.
-
Alle Ergebnisse werden in der Liste Query Results im Panel „Components“ aufgeführt.
Footprints
Höhe
Zusammenfassung
Gibt alle Footprints zurück, deren Eigenschaft Height die Abfrage erfüllt.
Syntax
Height : Number
Number richtet sich nach den aktuell für die Bibliothek verwendeten Maßeinheiten – entweder imperial (mil; 1 mil = 0,001 Zoll) oder metrisch (mm; 1 mm = 0,001 Meter).
Anwendungsbeispiele
Height = 300
Gibt alle Footprints zurück, deren Eigenschaft Height gleich 300 in der aktuellen Maßeinheit ist.
Height >= 5.08
Gibt alle Footprints zurück, deren Eigenschaft Height größer oder gleich 5.08 in der aktuellen Maßeinheit ist.
Height <> 550
Gibt alle Footprints zurück, deren Eigenschaft Height not gleich 550 in der aktuellen Maßeinheit ist.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialog „File Libraries Search“ auf Components eingestellt ist.
-
Bei der Suche nach Footprints werden alle PcbLib- und IntLib-Bibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden.
-
Alle Ergebnisse werden in der Liste Query Results im Panel „Components“ aufgeführt.
Pad-Anzahl
Zusammenfassung
Gibt alle Footprints zurück, deren Eigenschaft Pad Count die Abfrage erfüllt.
Syntax
PadCount : Number
Anwendungsbeispiele
PadCount = 2
Gibt alle Footprints zurück, deren Pad Count gleich 2 ist.
PadCount > 14
Gibt alle Footprints zurück, deren Pad Count größer als 14 ist.
Hinweise
-
Stellen Sie sicher, dass der Suchbereich über das Feld Search in im Dialog „File Libraries Search“ auf Components eingestellt ist.
-
Bei der Suche nach Footprints werden alle PcbLib- und IntLib-Bibliotheken durchsucht, die verfügbar sind oder sich in einem definierten Suchpfad befinden.
-
Alle Ergebnisse werden in der Liste Query Results im Panel „Components“ aufgeführt.