Schaltpläne & PCB synchron halten

Altium Training

Altium Essentials: Transfer to PCB

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Auf einen Blick

Dieser Artikel erklärt, wie Altium Designer Schaltpläne und PCB-Layouts synchron hält – von der ersten Übertragung eines erfassten Designs bis hin zu laufenden Änderungen auf beiden Seiten. Er zeigt, wie der Komparator Unterschiede erkennt, wie Engineering Change Orders (ECOs) zu deren Behebung erstellt werden und wie die beiden wichtigsten Synchronisierungsansätze funktionieren: bidirektionale und unidirektionale Aktualisierungen. Außerdem erfahren Sie, welche Daten synchronisiert werden können, wie sich die Komparator- und ECO-Optionen auf den Prozess auswirken und wie Klassen und Designregeln im Rahmen der Synchronisierung übertragen werden können. Wenn Sie besser verstehen möchten, wie Sie Ihr Design konsistent halten und manuelle Nacharbeit reduzieren, lesen Sie weiter. Dieser Leitfaden hilft Ihnen, mit mehr Sicherheit zu arbeiten.

- Lernen Sie den Unterschied zwischen bidirektionalen Vergleichen und direkten Aktualisierungsabläufen kennen und erfahren Sie, wann welcher Ansatz zum Einsatz kommt.
- Erfahren Sie, welche Daten Altium Designer zwischen Schaltplan und PCB synchronisieren kann, darunter Bauteile, Verbindungen, Klassen und bestimmte Designregeln.
- Sehen Sie, wie Projektoptionen wie die Einstellungen für den Komparator und die ECO-Erstellung den Synchronisierungsprozess und die anwendbaren Änderungen beeinflussen.
Mit KI tiefer einsteigen:

Die häufigste Aufgabe beim Übergang vom Schaltplan zum Leiterplattenlayout besteht darin, Schaltplan und Leiterplatte aufeinander abzustimmen oder zu synchronisieren. Ganz gleich, ob Sie einen erfassten Entwurf zum ersten Mal auf eine neue Leiterplatte übertragen oder einen bestehenden Entwurf im Schaltplan oder im Leiterplattenlayout ändern: Sie benötigen eine Möglichkeit, beide Seiten synchron zu halten. Altium Designer bietet leistungsstarke Funktionen zur Designsynchronisierung, die diese Aufgabe vereinfachen und es dem Entwickler ermöglichen, sich auf die kreativen Aspekte des Designprozesses zu konzentrieren.

Der Synchronisierungsprozess erkennt und behebt Unterschiede zwischen Schaltplan und Leiterplatte. Der Synchronisierungsprozess erkennt und behebt Unterschiede zwischen Schaltplan und Leiterplatte.

Die Designsynchronisierung erfolgt direkt zwischen dem Schaltplan- und dem Leiterplatteneditor; ein zwischengeschaltetes, netzlistenähnliches Dokument wird nicht verwendet. Die Software vergleicht mithilfe einer Vergleichsengine alle Aspekte des Designs und gibt die Ergebnisse als Liste von Unterschieden aus. Der Entwickler entscheidet, welche Seite geändert werden soll, um die Unterschiede zu beheben. Anschließend wird ein Satz von Engineering Change Orders (ECOs) erstellt. Sobald diese angewendet werden, sind beide Seiten des Designs wieder synchron.

Für die Synchronisierung gibt es zwei Ansätze:

  • Bidirektionale Synchronisierung, bei der Unterschiede mit dem Befehl Project » Show Differences gleichzeitig in beide Richtungen abgeglichen werden können (wie oben gezeigt). Weitere Informationen zu diesem Ansatz finden Sie im Abschnitt Unterschiede ermitteln.
  • Unidirektionale Synchronisierung mit den Befehlen Design » Update PCB oder Design » Update Schematic. Weitere Informationen zu diesem Ansatz finden Sie im Abschnitt Direkte Aktualisierung durchführen.

Bevor Sie die Schaltplaninformationen auf die neue Leiterplatte übertragen, müssen alle zugehörigen Bibliotheken für Schaltplansymbole und Leiterplatten-Footprints verfügbar sein.

Was kann synchronisiert werden?

Der Synchronisierungsprozess stellt sicher, dass die Bauteil- und Verbindungsdaten im Schaltplan mit denen auf der Leiterplatte übereinstimmen. Darüber hinaus sorgt er dafür, dass auch andere Designvorgaben wie Netzklassen, Bauteilklassen und Designregeln synchron sind.

Vergleichsoptionen konfigurieren

Dialog page: Optionen für das Leiterplattenprojekt, Registerkarte „Comparator“

Welche what Schaltplan- und Leiterplattendaten genau verglichen werden, wird auf der Registerkarte „Comparator“ des Dialogs Options for PCB Project konfiguriert. Wählen Sie Project » Project Options, um den Dialog zu öffnen.

Die Vergleichsengine berücksichtigt die Einstellungen auf der Registerkarte Comparator des Dialogs Options for Project.
Die Vergleichsengine berücksichtigt die Einstellungen auf der Registerkarte Comparator des Dialogs Options for Project.

Der Hauptbereich des Dialogs enthält eine umfangreiche Liste von Vergleichstypen, beispielsweise Different Designators und Changed Net Name, die in fünf Kategorien unterteilt sind. Die rechte Spalte Mode enthält für jeden Typ eine Dropdown-Liste, in der Sie den Vergleichsmodus auswählen, etwa Find Differences oder Ignore Differences. Für Textvergleiche gibt es eine dritte Option, mit der die Groß- und Kleinschreibung beim Vergleich ignoriert werden kann.

Bei einem neuen Projekt ist standardmäßig für jeden Vergleichstyp die Ermittlung von Unterschieden aktiviert. Passen Sie die Optionen an die Anforderungen Ihres Projekts an.

  • Bei der Synchronisierung vom Schaltplan zur Leiterplatte können alle leiterplattenbezogenen Details synchronisiert werden.
  • Bei der Synchronisierung von der Leiterplatte zum Schaltplan können nur Änderungen an Bauteilbezeichner, Kommentar und Footprint zurück in den Schaltplan übertragen werden. Bei Netzen lassen sich nur Änderungen synchronisieren, die durch das Tauschen von Pins oder Bauteilsektionen entstehen. Wie dies erfolgt, hängt von der Konfiguration der Optionen zum Tauschen von Pins und Bauteilsektionen ab. Weitere Informationen finden Sie auf der Seite Pins und Bauteilsektionen tauschen.

Am unteren Rand des Dialogs befinden sich Optionen zum Einstellen von Object Matching Criteria. Die Zuordnung ist ein ausgefeilter, mehrstufiger Prozess, der nicht auf einem einfachen exakten Zeichenfolgenvergleich beruht. Weitere Informationen finden Sie im Abschnitt Netze und Klassen zuordnen. 

Beachten Sie die Option Ignore Rules Defined in the PCB Only am unteren Rand des Dialogs. Aktivieren Sie diese, um die auf der Leiterplatte definierten Regeln vom Vergleich auszuschließen.

Netz- und Bauteilklassen synchronisieren

Dialog page: Optionen für das Leiterplattenprojekt, Registerkarte „Class Generation“

Neben Bauteil- und Verbindungsdaten können Sie bei der Durchführung von Design » Update PCB auch Klassen und Designregeln erzeugen und synchronisieren.

Weitere Informationen zum Erzeugen und Synchronisieren von Klassen aus dem Schaltplan finden Sie im Abschnitt Klassen aus dem Schaltplan erzeugen und synchronisieren auf der Seite Mit Klassen im Schaltplan & auf der Leiterplatte arbeiten.

Designregeln synchronisieren

Designregeln können mithilfe eines Parametersatz-Objekts im Schaltplan definiert werden. Wenn ein Parametersatz-Objekt ausgewählt ist, enthält das Panel oder der modale Dialog Properties einen Bereich Rules. Klicken Sie auf die Dropdown-Liste Add, um eine Designregel hinzuzufügen. Die Regel wird auf das Netz, den Bus, den Kabelbaum oder die Objekte unter der Blanket angewendet, mit denen das Parametersatz-Objekt verbunden ist.

In der folgenden Abbildung wird eine Designregel zur Begrenzung der Leiterbahnbreite auf die Netzklasse USB_data angewendet (die Netzklasse ist ebenfalls als Teil dieses Parametersatzes im Bereich Classes der Dropdown-Liste Parameters definiert).

Mit dem Parametersatz werden eine Netzklasse und eine Designregel für die Netze unter dem Blanket-Objekt im Schaltplan definiert. Beachten Sie, dass die benötigten Maßeinheiten am unteren Rand des Dialogs „Edit PCB Rule“ konfiguriert werden.
Mit dem Parametersatz werden eine Netzklasse und eine Designregel für die Netze unter dem Blanket-Objekt im Schaltplan definiert. Beachten Sie, dass die benötigten Maßeinheiten am unteren Rand des Dialogs „Edit PCB Rule“ konfiguriert werden.

Stellen Sie auf der Registerkarte Comparator des Dialogs Options for Project sicher, dass die erforderlichen Vergleiche der Regeltypen aktiviert sind, damit Designregeln auf der Leiterplatte hinzugefügt und aktualisiert werden können.

Jede Leiterplattenregel, die aus einer Regeldefinition im Schaltplan erstellt wird, erhält automatisch den Namen Schematic <RuleType>. Bei Bedarf kann dieser Name geändert werden, da er nicht für die fortlaufende Regelsynchronisierung verwendet wird.

Sowohl in der obigen als auch in der folgenden Abbildung wird die Designregel in einem Parametersatz-Objekt definiert, das mit einer Blanket verbunden ist. Wenn das Parametersatz-Objekt eine Klassendefinition enthält, wird auch eine Leiterplatten-Netzklasse erstellt. Da die Klassendefinition vorhanden ist, wird der Geltungsbereich der Leiterplattenregel auf InNetClass('<PCB_NetClassName >') festgelegt. 

In der folgenden Abbildung wird das Parametersatz-Objekt als Differenzpaar-Direktive dargestellt. Dies ist ein spezieller Typ von Parametersatz-Objekt, der mit dem Befehl Place » Directives » Differential Pair platziert wird.  

Mit der Differenzpaar-Direktive werden eine Netzklasse und eine Designregel definiert, die anschließend auf die betreffenden Differenzpaare angewendet wird.
Mit der Differenzpaar-Direktive werden eine Netzklasse und eine Designregel definiert, die anschließend auf die betreffenden Differenzpaare angewendet wird.

Mit Differenzpaaren arbeiten

Die Differential Pair-Direktive kennzeichnet Netze, die zu einem differentiellen Paar gehören. Die Software setzt voraus, dass die Netze des Paares <Name>_P und <Name>_N heißen. Das differentielle Paar auf der Leiterplatte erhält dann den Namen <Name>.

Paare können definiert werden, indem auf jedem Netz eines differentiellen Paares eine Differential Pair-Direktive platziert wird. Alternativ kann ein Blanket so platziert werden, dass es die Netznamen des Paares abdeckt, wie in der Abbildung oben gezeigt.

Das Parameter Set-Objekt für differentielle Paare in der Abbildung oben führt zur Erstellung von:

  • Acht differentiellen Paaren mit den Namen V_RX0, V_TX0, V_RX1, V_TX1, RX0, TX0, RX1, TX1.
  • Einer PCB-Netzklasse mit dem Namen ROCKET_IO_LINES.
  • Einer Designregel Differential Pairs Routing, die auf die PCB-Netzklasse ROCKET_IO_LINES angewendet wird.

Optionen für die ECO-Erstellung konfigurieren

Der Dialog Options for Project enthält außerdem die Registerkarte ECO-Erstellung. Diese Registerkarte legt fest, für welche Designänderungen ECOs erstellt werden können. In der Regel sind alle Optionen aktiviert. Über die Optionen auf der Registerkarte Komparator des Dialogs wird festgelegt, welche Designänderungen zwischen Schaltplan und Leiterplatte synchronisiert werden sollen.

Die Registerkarte „ECO-Erstellung“ legt fest, für welche Arten von Änderungen ECOs erstellt werden können.
Die Registerkarte „ECO-Erstellung“ legt fest, für welche Arten von Änderungen ECOs erstellt werden können.

Unterschiede ermitteln

Die Designsynchronisierung kann Unterschiede in beide Richtungen erkennen und beheben, also vom Schaltplan zur Leiterplatte oder von der Leiterplatte zurück zum Schaltplan.

Zum Erkennen und Beheben von Unterschieden gibt es zwei Vorgehensweisen: 

  1. Die Aktualisierungsrichtung für jede Änderung einzeln festlegen.
  2. Alle Aktualisierungen in derselben Richtung anwenden.

Wenn Sie nicht gleichzeitig Aktualisierungen in beide Richtungen vornehmen müssen, brauchen Sie weder die zu vergleichenden Dokumente auszuwählen noch die Aktualisierungsrichtung zur Behebung der Unterschiede festzulegen. In diesem Fall können Sie direkt zum Abschnitt Performing a Direct Update wechseln.

Die Software kann diese Unterschiede beheben, indem sie Änderungen gleichzeitig auf beiden Seiten anwendet. Stellen Sie sich beispielsweise vor, dass der Elektronikentwickler den Wert eines Kondensators geändert hat, während der Leiterplattenentwickler den Footprint desselben Kondensators geändert hat. Diese beiden Unterschiede lassen sich in einem einzigen Aktualisierungsvorgang beheben: Die Änderung des Kommentars wird vom Schaltplan auf die Leiterplatte übertragen, die Footprint-Änderung von der Leiterplatte auf den Schaltplan.

Wenn die Vergleichsengine das Schaltplanprojekt mit der Leiterplatte vergleicht, wird eine vollständige Liste der Unterschiede erstellt. Zu diesem Zeitpunkt wird noch nicht festgelegt, welche Seite geändert werden muss, um beide wieder zu synchronisieren.

Die Liste der Unterschiede wird im Dialog Differences between angezeigt.

So öffnen Sie den Dialog Difference between und zeigen eine Liste der Unterschiede an:

  • Um den Dialog Choose Documents to Compare zu öffnen, wie in der folgenden Abbildung gezeigt, führen Sie den Befehl Project » Show Differences aus oder klicken Sie im Projects Panel mit der rechten Maustaste auf den Eintrag des gewünschten Projekts (oder eines seiner Quelldokumente) und wählen Sie im Kontextmenü den Befehl Show Differences aus. Im Dialog Choose Documents to Compare wählen Sie die beiden Dokumente bzw. Dokumentgruppen aus, die Sie vergleichen möchten. Üblicherweise wird das Schaltplanprojekt mit der Leiterplatte verglichen. Sie können diesen Dialog auch verwenden, um beliebige Dokumente miteinander zu vergleichen, indem Sie die Option Advanced Mode aktivieren. Beispielsweise können Sie eine Netzliste mit einer Leiterplatte oder zwei Leiterplatten miteinander vergleichen.

    Im Allgemeinen eignet sich die Standardkonfiguration des Dialogs – sowohl im einfachen als auch im erweiterten Modus – für die meisten Designvergleiche, bei denen die Quelldokumente und das Ziel-Leiterplattendesign verglichen werden sollen, um sie zu synchronisieren. Der Dialog ermöglicht jedoch auch den Vergleich anderer Dokumente. Dies kann hilfreich sein, wenn Sie verschiedene Versionen eines Projekts laden und die Unterschiede zwischen den entsprechenden Quelldokumenten vergleichen möchten.

    Wählen Sie die Leiterplatte aus, mit der das Schaltplanprojekt verglichen werden soll.
    Wählen Sie die Leiterplatte aus, mit der das Schaltplanprojekt verglichen werden soll.

  • Wählen Sie die Leiterplatte im Hauptbereich des Dialogs aus und klicken Sie auf OK, um den Dialog Difference between zu öffnen, wie unten gezeigt. Wenn das Leiterplattendokument bereits mit den Quelldokumenten synchronisiert ist, wird ein Dialog mit dem Hinweis angezeigt, dass keine Unterschiede gefunden wurden.

Der Dialog Differences between wird geöffnet. Der Synchronizer arbeitet bidirektional. Das bedeutet, dass Sie innerhalb desselben ECO Aktualisierungen für beide Dokumente festlegen können. Um die verglichenen Dokumente zu synchronisieren, muss für jeden Unterschied entschieden werden, ob eine Aktion ausgeführt werden soll und in welche Richtung die Änderung erfolgt. Dabei legen Sie fest, welches Dokument aktualisiert werden soll, um den Unterschied zu beheben. Im nächsten Schritt weisen Sie daher jedem Unterschied eine Aktualisierungsrichtung zu:

  • Klicken Sie für einen einzelnen Unterschied in die Spalte Update, um eine Richtungsauswahl anzuzeigen, wie in der folgenden Abbildung gezeigt.
  • Klicken Sie für mehrere Unterschiede derselben Art mit der rechten Maustaste auf eine Überschrift, beispielsweise „Unterschiedliche Footprints“, und wählen Sie den gewünschten Befehl Update Same Kind aus.
  • Klicken Sie für alle Unterschiede mit der rechten Maustaste an eine beliebige Stelle im Dialog und wählen Sie den gewünschten Befehl Update All aus.

Für jeden Unterschied muss die Aktualisierungsrichtung festgelegt werden, damit ein ECO zu seiner Behebung erstellt werden kann.
Für jeden Unterschied muss die Aktualisierungsrichtung festgelegt werden, damit ein ECO zu seiner Behebung erstellt werden kann.

Klicken Sie auf die Schaltfläche Explore Differences, um das Differences Panel aufzurufen und die Unterschiede zu untersuchen, wie im folgenden Abschnitt Designänderungen mit dem Differences-Panel untersuchen beschrieben.

Da der Zugriff auf das Differences Panel auf diese Weise den Dialog Differences between schließt, gehen alle bereits getroffenen Aktualisierungsentscheidungen verloren. Daher ist es besser, die Unterschiede zu untersuchen, bevor Sie Aktualisierungsentscheidungen treffen. Alternativ können Sie direkt aus dem Dialog Differences between per Cross-Probing zu einem Objekt navigieren, indem Sie im Bereich Differences des Dialogs auf den Eintrag des Objekts doppelklicken.

Klicken Sie auf Report Differences, um einen Bericht über die vom Comparator gefundenen Unterschiede, die festgelegten Aktualisierungsentscheidungen und die Aktionen, die in den erstellten ECO aufgenommen werden, zu konfigurieren und zu drucken bzw. zu exportieren.

Nachdem die Aktualisierungsrichtung zugewiesen wurde, klicken Sie auf die Schaltfläche Create Engineering Change Order, um den Dialog Engineering Change Order zu öffnen. Dieser wird im folgenden Abschnitt Unterschiede beheben – ECOs anwenden beschrieben.

Designänderungen mit dem Differences-Panel untersuchen

Das Differences Panel zeigt eine hierarchische Ansicht der Unterschiede zwischen den Dokumenten.
Das Differences Panel zeigt eine hierarchische Ansicht der Unterschiede zwischen den Dokumenten.

Zusammenfassung

Das Differences Panel zeigt die logischen oder physischen Unterschiede an, die der integrierte Differences Comparator der Software beim Vergleich von Designdokumenten ermittelt (beispielsweise beim Vergleich der Quelldokumenthierarchie (Schaltpläne) eines Projekts mit dem PCB-Designdokument). Im Panel können Sie die Unterschiede interaktiv untersuchen, bevor Sie entscheiden, einen Engineering Change Order (ECO) zur Synchronisierung der Projektdokumente zu erstellen.

Zugriff auf das Panel

So öffnen Sie das Differences Panel:

  • Wählen Sie View » Panels » Differences in den Hauptmenüs.
  • Klicken Sie auf die Schaltfläche Panels unten rechts im Design-Arbeitsbereich und anschließend auf Differences.

Panels können frei schwebend im Editorbereich oder an den Bildschirmrändern angedockt angeordnet werden. Wenn sich das Differences Panel derzeit in der Gruppe der angedockten Panels befindet, verwenden Sie die Registerkarte Differences am unteren Rand der Panels, um es in den Vordergrund zu bringen.

Unterschiede anzeigen

Wie das Differences Panel verwendet wird, hängt davon ab, welches der folgenden Ziele Sie verfolgen:

  • Die Integrität des gesamten Projekts hinsichtlich Inhalt und Struktur analysieren, indem logische Unterschiede innerhalb der Projekthierarchie erkannt werden.
  • Zwei Versionen desselben Schaltplan- oder PCB-Dokuments vergleichen, indem ihre grafischen (physischen) Unterschiede erkannt werden.
Das DifferencesPanel wird bei Verwendung der Funktion Explore Differences im Dialog Unterschiede zwischen des Differences Comparator mit Daten gefüllt. Diesen Dialog öffnen Sie, indem Sie im ProjectsPanel mit der rechten Maustaste klicken und anschließend Show Differenceswählen.

Logische Unterschiede anzeigen

Der Vergleich von Projektdokumenten auf logische Unterschiede erfolgt im Dialog Choose Documents To Compare. Diesen öffnen Sie, indem Sie im Projects-Panel mit der rechten Maustaste auf ein Projekt (oder Projektdokument) klicken und anschließend Show Differences im zugehörigen Kontextmenü wählen.

Klicken Sie mit der rechten Maustaste auf einen Projektnamen und wählen Sie anschließend Show Differences, um den Dialog Choose Documents To Compare zu öffnen.
Klicken Sie mit der rechten Maustaste auf einen Projektnamen und wählen Sie anschließend Show Differences, um den Dialog Choose Documents To Compare zu öffnen.

Üblicherweise wird das PCB-Dokument mit der Quelldokumenthierarchie des übergeordneten Projekts verglichen, um logische Unterschiede zwischen den Designinhalten des Schaltplans und der Leiterplatte zu erkennen.

Wenn Unterschiede zwischen den ausgewählten Dokumenten vorhanden sind, wird nach dem Klicken auf OK der Dialog Unterschiede zwischen geöffnet. Informationen im Differences Panel werden erst angezeigt, nachdem Sie im Dialog Differences between auf die Schaltfläche Explore Differences geklickt haben.

Das Differences Panel zeigt nur die Unterschiede an, die im Dialog Differences between aufgeführt sind. Diese werden wiederum durch die Einstellungen auf der Registerkarte Comparator des Dialogs Project Options (Project » Options) bestimmt. Auf dieser Registerkarte sind alle Vergleichstypen aufgeführt, beispielsweise Unterschiede bei Bauteilen, Netzen und Parametern. Die Einstellung von Mode für jede Vergleichskategorie auf Find Differences oder Ignore Differences bestimmt, ob der Differences Comparator seine Ergebnisse an den Dialog Differences between  weitergibt.

Legen Sie im Dialog Project Options fest, wie Unterschiede erkannt und gemeldet werden.
Legen Sie im Dialog Project Options fest, wie Unterschiede erkannt und gemeldet werden.

Das Differences Panel zeigt die zwischen den Quelldokumenten gefundenen Unterschiede in einer Baumstruktur an. Der Ordner auf der obersten Ebene zeigt die Gesamtzahl der erkannten Unterschiede. Für jeden im Dialog Unterschiede zwischen aufgeführten Vergleichstyp wird ein Unterordner erstellt. Jeder Unterordner listet die konkret gefundenen Unterschiede auf, die wiederum nach den Objekten in den Dokumenten aufgeschlüsselt sind, die diese Unterschiede verursachen.

Wenn das zugehörige Dokument geöffnet ist (auch wenn es ausgeblendet ist), führt ein Klick auf einen Objekteintrag im Panel per Cross-Probing zum Objekt im Dokument.

Bei der visuellen Darstellung wird auf das Objekt gezoomt und es durch Abdunkeln aller anderen Objekte hervorgehoben. Der Kontrast der Abdunklung lässt sich mit dem Schieberegler Dimming  im Bereich Highlight Methods auf der Seite System - Navigation des Dialogs Preferences einstellen.

Physische Unterschiede anzeigen

Der grafische (physische) Vergleich zweier Versionen desselben Schaltplan- oder PCB-Dokuments erfolgt grundsätzlich auf die gleiche Weise wie der oben beschriebene logische Vergleich, verwendet jedoch zusätzlich Advanced Mode im Dialog Choose Documents To Compare.

Verwenden Sie für einen physischen Dokumentvergleich den Befehl Show Differences (im Kontextmenü des ProjectsPanels), um den Dialog Choose Documents To Compare zu öffnen, und aktivieren Sie anschließend das Kontrollkästchen Advanced Mode. Da nun alle Projektdateien im Dialog angezeigt werden, können Sie die beiden Varianten eines Dokuments für den Vergleich auswählen.

Auswahl von Dokumenten für den physischen Vergleich im Dialog Choose Documents To Compare in Advanced Mode.
Auswahl von Dokumenten für den physischen Vergleich im Dialog Choose Documents To Compare in Advanced Mode.

Ein Klick auf OK startet den grafischen Vergleich und öffnet den Dialog Unterschiede zwischen, wie zuvor beschrieben. Klicken Sie auf Explore Differences, um die interaktive Liste der Unterschiede im DifferencesPanel zu öffnen.

Das Panel zeigt die zwischen den Dokumenten gefundenen Unterschiede in einer Baumstruktur an. Der Ordner auf der obersten Ebene zeigt die Gesamtzahl der erkannten Unterschiede. Für jeden Unterschiedstyp werden Einträge erstellt, die jeweils die konkreten Referenzen und das betroffene Objekt (Port, Bauteil usw.) enthalten.

Wenn Sie den Objekteintrag eines erkannten Unterschieds auswählen, wird das Objekt im Design-Arbeitsbereich des Editors hervorgehoben und herangezoomt.

Hinweise

  • Wenn sich ein Objekt im Panel auf einem derzeit ausgeblendeten Dokument befindet, wird dieses Dokument automatisch geöffnet und im Design-Editorfenster zum aktiven Dokument, sobald Sie auf den zugehörigen Eintrag klicken.
  • Die beim Cross-Probing aus dem Differences Panel angewendete Filterung ist temporär. Sie können daher weiterhin Designobjekte auswählen oder bearbeiten, die außerhalb des Filterbereichs liegen.
  • Die Informationen im Differences Panel werden gelöscht, wenn ein neuer Dokumentvergleich durchgeführt oder das übergeordnete Projekt kompiliert wird.
  • Verwenden Sie den Befehl Project » Show Physical Differences aus den Hauptmenüs, um physische Unterschiede zwischen zwei Versionen eines Schaltplan- oder PCB-Dokuments zu erkennen und diese grafisch darzustellen, während die beiden Dokumente nebeneinander im Design-Arbeitsbereich angezeigt werden. Die Funktion „Physische Unterschiede anzeigen“ bietet einen rein visuellen Vergleich – keines der verglichenen Dokumente kann durch die Erstellung von ECOs aktualisiert werden. Sie ist für den Vergleich zweier Versionen desselben Dokuments vorgesehen. Wird sie jedoch zum Vergleich unterschiedlicher Dokumente verwendet, beispielsweise der Quellhierarchie des Projekts mit der Leiterplatte, erscheint das Differences Panel mit einer Liste der erkannten logischen Unterschiede.

Eine direkte Aktualisierung durchführen

Da Sie als Entwickler in der Regel wissen, in welche Richtung Sie die Aktualisierungen vornehmen möchten, und alle Aktualisierungen in dieselbe Richtung erfolgen, können Sie den soeben beschriebenen Prozess der Unterschiedserkennung und Richtungszuweisung überspringen.

Anstatt den Befehl Show Differences aus dem Menü Project auszuwählen, wählen Sie den Befehl Update aus dem Menü Design, entweder im Schaltplaneditor oder im PCB-Editor. Die Wahl des Editors, in dem Sie den Befehl ausführen, gibt die Richtung an, in der die Änderungen übernommen werden sollen – vom Editor this zum Editor that. Beispielsweise wählen Sie im Schaltplaneditor Design » Update, um alle Änderungen vom Schaltplan auf die Leiterplatte zu übertragen.

Das aktive PCB-Designdokument kann auch mit allen Änderungen an den Quellschaltplandokumenten aktualisiert werden, indem Sie den Befehl Design » Import Changes from <ProjectName> in den Hauptmenüs des PCB-Editors auswählen.

Der Dialog Differences between wird übersprungen, und Sie gelangen direkt zum Dialog Engineering Change Order.

Wenn alle Aktualisierungen in derselben Richtung übernommen werden sollen, verwenden Sie den Befehl Design » Update. Wenn alle Aktualisierungen in derselben Richtung übernommen werden sollen, verwenden Sie den Befehl Design » Update. 

Wenn das PCB-Dokument bereits mit den Quelldokumenten synchronisiert ist, erscheint ein Dialog mit dem Hinweis, dass keine Unterschiede erkannt wurden. Beim Aktualisieren von Schaltplänen kann es hingegen vorkommen, dass einige oder keine der erkannten Unterschiede durch automatisch generierte ECOs behoben werden können. In diesem Fall erhalten Sie die Möglichkeit, diese Unterschiede im Dialog „Differences between“ anzuzeigen. Auch wenn eine Änderung in Richtung der Schaltpläne möglicherweise nicht möglich ist, müssen Sie eventuell die Leiterplatte aktualisieren (beispielsweise durch Entfernen eines Objekts oder Elements). Wenn Sie nach dem Prüfen der Unterschiede einige oder alle davon beheben können, können Sie einen ECO generieren. Bleiben Unterschiede bestehen, die sich nicht über den Dialog beheben lassen, müssen Sie zum Design zurückkehren und die Probleme beheben, bevor Sie erneut einen Vergleich durchführen.

Unterschiede beheben – ECOs anwenden

Jeder Unterschied wird durch Anwenden eines Engineering Change Order (ECO) behoben. Die ECOs werden im Dialog Engineering Change Order mit jeweils einem ECO pro Zeile aufgeführt, jeweils mit einem eigenen Kontrollkästchen Enable.

Bei Verwendung des Dialogs Engineering Change Order:

  • Beim Öffnen des Dialogs sind alle Änderungen aktiviert. Deaktivieren Sie alle Änderungen, die Sie vorerst zurückstellen möchten. Der Dialog unterstützt die Mehrfachauswahl – verwenden Sie das Kontextmenü, um den Aktivierungsstatus der ausgewählten ECOs umzuschalten.
  • Verwenden Sie den Befehl „Cross Probe“ im Kontextmenü, um die von diesem ECO betroffenen Objekte zu untersuchen.
  • Prüfen Sie mit der Schaltfläche Validate Changes, ob die Änderungen durchgeführt werden können. ECOs schlagen in der Regel fehl, weil ein Objekt nicht verfügbar ist – beispielsweise, weil der angegebene PCB-Footprint nicht in den verfügbaren dateibasierten Bibliotheken vorhanden ist oder das angegebene Pad im Footprint nicht existiert.
  • Ein ECO kann auch fehlschlagen, weil ein für einen bestimmten ECO erforderliches Objekt zunächst nicht vorhanden war, aber während der Verarbeitung der aktuellen ECOs hinzugefügt wurde. Führen Sie in diesem Fall den Befehl „Update“ erneut aus, um diesen ECO abzuschließen.

Jede Designänderung wird als ECO dargestellt. Aktivieren Sie die benötigten ECOs.
Jede Designänderung wird als ECO dargestellt. Aktivieren Sie die benötigten ECOs.

Meldungen des Comparators werden im Panel Messages angezeigt.

Die Verknüpfung zwischen Schaltplan und PCB verstehen

Bauteilzuordnung über eindeutige Kennungen

Jedes Schaltplanbauteil ist über eine eindeutige Kennung (Unique Identifier, UID) mit seinem PCB-Bauteil verknüpft. Die UID wird beim Platzieren des Schaltplanbauteils auf dem Blatt zugewiesen. Dieser Wert wird auf das PCB-Bauteil übertragen, wenn das Design in den PCB-Editor übertragen wird. Wenn Bauteilinformationen zum ersten Mal mithilfe von Synchronizer zwischen den Schaltplan-Quelldokumenten und dem leeren PCB-Designdokument übertragen werden, werden alle Bauteile automatisch über ihre eindeutige Kennung verknüpft. Dabei wird die Kennung jedes Schaltplanbauteils dem entsprechenden Bauteil-Footprint zugewiesen.

Dieses Verfahren wäre für ein einfaches Design ausreichend, kann jedoch ein Mehrkanal-Design nicht unterstützen. In einem Mehrkanal-Design wird dasselbe Schaltplanbauteil in jedem physischen Kanal wiederholt, wodurch die wiederholten PCB-Bauteile dieselbe UID hätten. Um dies zu berücksichtigen, wird die UID des PCB-Bauteils aus der UID des übergeordneten Blattsymbols und der UID des Schaltplanbauteils gebildet. Die Syntax der PCB-UID unterscheidet sich geringfügig, je nachdem, wie das Mehrkanal-Design erstellt wurde.

Bei einem Mehrkanal-Design, das durch das Platzieren mehrerer Blattsymbole erstellt wurde, die alle auf dasselbe Schaltplanblatt verweisen, kann jedes Blattsymbol eine eindeutige Kennung bereitstellen. Die PCB-UID hat daher folgendes Format:

\SheetSymbolUID\SchComponentUID

Bei einem Mehrkanal-Design, das mit dem Schlüsselwort Repeat erstellt wurde, steht nur eine Blattsymbol-UID zur Verfügung. Deshalb enthält die PCB-UID auch den Wert ChannelIndex, und zwar in folgendem Format:

\ChannelIndex+SheetSymbolUID\SchComponentUID

Die UIDs werden in Panels und Dialogen nicht angezeigt.

Wenn die Bauteile nicht verknüpft sind

Der Vorteil der Verwendung einer UID zur Zuordnung von Schaltplan- und PCB-Bauteilen besteht darin, dass die Bauteilbezeichner voneinander abweichen können (etwa nach mehrmaliger Neuannotierung der PCB), ohne dass die Synchronisierbarkeit von Schaltplan und PCB gefährdet wird.

Wenn im Schaltplan oder auf der PCB ein Bauteil vorhanden ist, zu dem es im anderen Editor kein entsprechendes Bauteil mit derselben UID gibt, geschieht Folgendes:

  • Wenn das zusätzliche Bauteil nur im Quelleditor vorhanden ist, wird ein ECO erzeugt, um das Bauteil im Zieleditor hinzuzufügen.
  • Wenn das zusätzliche Bauteil nur im Zieleditor vorhanden ist, wird ein ECO erzeugt, um das zusätzliche Bauteil zu entfernen.
  • Wenn in beiden Editoren nicht zugeordnete Bauteile vorhanden sind, benötigt die Software Anweisungen zum Umgang mit diesen Bauteilen. Deshalb wird der Dialog Failed to Match Unique Identifiers geöffnet.

Der Dialog e Failed to Match Unique Identifiers  Der Dialog e Failed to Match Unique Identifiers  

Die Schaltflächen des Dialogs bieten die folgenden Optionen:

  • Automatically Create Component Links - Klicken Sie auf diese Schaltfläche, wenn Sie wissen, dass die nicht zugeordneten Bauteile bereits übereinstimmende Bauteilbezeichner haben. Anhand dieser Bauteilbezeichner weist die Software den zusätzlichen Bauteilen übereinstimmende UIDs zu. Für Bauteile, die anhand ihres Bezeichners zugeordnet werden können, werden bei anderen abweichenden Eigenschaften (z. B. nicht übereinstimmenden Parametern) ECOs erzeugt. Wenn Bauteile nicht anhand ihres Bezeichners zugeordnet werden können, werden ECOs zum Hinzufügen bzw. Entfernen dieser Bauteile erzeugt: Zusätzliche Bauteile im Quelleditor werden hinzugefügt, zusätzliche Bauteile im Zieleditor werden entfernt.
  • Manual Component Links - Klicken Sie auf diese Schaltfläche, wenn Sie wissen, dass es zusammengehörige Bauteile gibt, Ihnen der Status ihrer Bezeichner jedoch nicht bekannt ist. Der Dialog Edit Component Links wird geöffnet (unten beschrieben). Dort können Sie jedes Quell- und Zielbauteil manuell auswählen und in die Liste der zugeordneten Bauteile übertragen, wodurch ihnen übereinstimmende UIDs zugewiesen werden. Anschließend werden ECOs erzeugt, um die Bauteilbezeichner und alle anderen nicht übereinstimmenden Bauteileigenschaften zu synchronisieren.

    Es empfiehlt sich, alle Bauteile über eindeutige Kennungen zuzuordnen, damit die Bezeichner im Schaltplan- oder PCB-Dokument annotiert werden können, ohne die Möglichkeit einer späteren erneuten Synchronisierung der Dokumente zu beeinträchtigen. Die Dokumente können auch dann synchronisiert werden, wenn die Bauteile nicht über eindeutige Kennungen zugeordnet sind. In diesem Fall werden Sie jedoch aufgefordert, die Bauteile ausschließlich anhand ihrer Bezeichner zuzuordnen. Kommentar und Footprint werden dabei nicht berücksichtigt, sodass einige Bauteile möglicherweise falsch zugeordnet werden.
  • Cancel - Klicken Sie auf diese Schaltfläche, um ECOs zu erzeugen, die zusätzliche Bauteile aus dem Quelleditor hinzufügen und zusätzliche Bauteile aus dem Zieleditor entfernen.

Bauteile manuell verknüpfen

Der Status der Verknüpfungen zwischen Schaltplanbauteilen und ihren entsprechenden PCB-Bauteil-Footprints kann jederzeit im Dialog Edit Component Links überprüft und verwaltet werden (PCB-Editor, Befehl Projects » Component Links).

Die manuelle Verknüpfung von Bauteilen wird deshalb only im PCB-Dokument vorgenommen, weil nur die PCB-Bauteil-Footprints mit den Informationen zur eindeutigen Kennung aktualisiert werden müssen. Auf der Schaltplanseite sind diese bereits vorhanden.

Der Dialog „Bauteilverknüpfungen bearbeiten“ dient dazu, UID-Abweichungen zu erkennen und zu beheben. Er wird im PCB-Editor aufgerufen.
Der Dialog „Bauteilverknüpfungen bearbeiten“ dient dazu, UID-Abweichungen zu erkennen und zu beheben. Er wird im PCB-Editor aufgerufen.

Zusammenfassung der Dialogfunktionen:

  • Nicht zugeordnete Bauteile werden in den beiden Spalten Un-Matched Components auf der linken Seite angezeigt. Bauteile mit übereinstimmender UID werden im Bereich Matched Components auf der rechten Seite des Dialogs angezeigt.
  • Mit den Pfeilschaltflächen in der Mitte des Dialogs können ausgewählte Bauteile manuell zugeordnet bzw. ihre Zuordnung aufgehoben werden. Außerdem kann die Zuordnung aller derzeit zugeordneten Bauteile aufgehoben werden.
  • Mit der Schaltfläche Add Pairs Matched By und den Optionen am unteren Rand des Dialogs wird die Liste der derzeit nicht zugeordneten Bauteile durchsucht und versucht, diese anhand der aktivierten Eigenschaften (Bauteilbezeichner, Kommentar, Footprint) zuzuordnen.
  • Wenn Sie auf die Schaltfläche Perform Update klicken, wird jedem neu zugeordneten PCB-Bauteil die UID seines entsprechenden Schaltplanbauteils zugewiesen. Wenn Sie Einträge im Matched Bereich des Dialogs zurück in die Unmatched -Bereiche verschieben, erscheint ein Bestätigungsdialog mit dem Hinweis, dass beim Fortfahren bestehende Bauteilzuordnungen aufgehoben werden. Durch Klicken auf Yes wird die Aktualisierung fortgesetzt, und ein Informationsdialog zeigt eine Zusammenfassung der im PCB-Dokument geänderten Bauteilverknüpfungen an. Ein neuer Eintrag im Bereich Matched wird als Link Modifiedzusammengefasst, während ein zuvor verknüpfter Eintrag, dessen Zuordnung Sie nun aufgehoben haben, als Link Removedzusammengefasst wird.
  • Nachdem Sie in diesem Dialog Bauteile manuell verknüpft haben, empfiehlt es sich, den Synchronisierungsstatus zu prüfen (führen Sie den Befehl Design » Update aus).
  • Sie können den Dialog in jeder Phase des Designs verwenden, um die Verknüpfungen zwischen Bauteilen anzuzeigen und sicherzustellen, dass die Bauteile in den Schaltplan-Quelldokumenten tatsächlich den entsprechenden Bauteil-Footprints im PCB-Design korrekt zugeordnet sind.
  • Eindeutige IDs können jederzeit entfernt werden, indem Sie die verknüpften Bauteile zurück in die Bereiche ohne Zuordnung des Dialogs Edit Component Links verschieben. Beim Entfernen einer Bauteilverknüpfung wird die eindeutige ID nur aus dem entsprechenden PCB-Footprint entfernt. Das Schaltplanbauteil behält seine eindeutige ID, sofern keine neue generiert wird (mit einem Befehl zum Zurücksetzen der eindeutigen ID auf Schaltplanebene).
  • Auch jeder Parameterdefinition in einem Schaltplan-Quelldokument wird automatisch eine eindeutige ID zugewiesen. Diese wird für Parameter verwendet, die als Designregel-Direktiven hinzugefügt wurden. Beim Übertragen des Designs in das PCB-Dokument werden alle definierten Regelparameter verwendet, um die entsprechenden Designregeln auf der PCB zu erzeugen. Diese erzeugten Regeln erhalten dieselben eindeutigen IDs. Dadurch können Regelvorgaben sowohl im Schaltplan als auch auf der PCB geändert und diese Änderungen bei der Synchronisierung auf die jeweils andere Seite übertragen werden.
  • Wenn Sie ein Schaltplanbauteil kopieren und einfügen oder ausschneiden und einfügen, wird seine UID automatisch erneuert. So wird sichergestellt, dass jedes Bauteil weiterhin eine eindeutige Kennung besitzt.
  • Wenn Sie Ihren Schaltplan neu organisieren, der bereits in den PCB-Editor übertragen wurde, und Bauteile auf ein anderes Blatt verschieben müssen, verwenden Sie nicht Ausschneiden und Einfügen. Wählen Sie die Bauteile stattdessen aus und führen Sie den Befehl Edit » Refactor » Move Selected Sub-circuit to Different Sheet aus.

 

Netze und Klassen zuordnen

Sowohl Netze als auch Klassen besitzen ein übergeordnetes Element (das Netz bzw. die Klasse) und untergeordnete Elemente (die Mitglieder dieses Netzes bzw. dieser Klasse). Ihre Zuordnung erfordert einen anderen Ansatz als den UID-Mechanismus zur Bauteilverknüpfung, um Änderungen am übergeordneten Element, an den untergeordneten Elementen oder an beiden zu unterstützen. Beispielsweise sollte eine einfache Änderung des Netznamens im Schaltplan nicht dazu führen, dass das Netz und alle zugehörigen Pins von der PCB entfernt werden müssen, anschließend das umbenannte Netz hinzugefügt wird und schließlich alle zugehörigen Pins diesem neuen Netz hinzugefügt werden.  

Zu diesem Zweck enthält die Software separate Zuordnungsalgorithmen, die Netze und Klassen anhand ihrer Mitglieder sowie anhand ihrer Namen zuordnen. Der Zuordnungsprozess wird im Bereich Object Matching Criteria auf der Registerkarte Comparator des Dialogs Options for Project konfiguriert.

Standardmäßig erfolgt die Zuordnung zuerst anhand der Mitglieder und anschließend anhand des Namens des Objekttyps.
Standardmäßig erfolgt die Zuordnung zuerst anhand der Mitglieder und anschließend anhand des Namens des Objekttyps.

Die Zuordnung dieser Objekttypen erfolgt wie folgt:

  • Bei der Designsynchronisierung wird standardmäßig zunächst versucht, die Zuordnung anhand der Mitglieder vorzunehmen, entsprechend den Einstellungen Min Match % und Min Match Member.
  • Wenn die Zuordnung anhand der Mitglieder fehlschlägt, versucht die Software anschließend, die Zuordnung anhand des Namens vorzunehmen (sofern die Option Use Name Matching aktiviert ist).
  • Wenn einer dieser Zuordnungsprozesse erfolgreich ist, gelangen Sie zum Dialog Engineering Change Order.
  • Wenn beide Zuordnungsverfahren fehlschlagen (oder die Option Use Name Matching auf Never gesetzt ist), wird der Dialog Match Manually geöffnet.

  • Durch Klicken auf No im Dialog Match Manually wird die manuelle Zuordnung übersprungen und direkt der Dialog Engineering Change Order geöffnet. Da Sie nicht versucht haben, Objekte ohne Zuordnung einander zuzuordnen, geht die Software davon aus, dass die Referenz- und Zielobjekte nicht zusammengehören. Daher werden ECOs erzeugt, die Unmatched Reference Objects von der Leiterplatte entfernen und Unmatched Target Objects als neue Objekte hinzufügen.
  • Wenn Sie im Dialog auf Yes klicken, um die Zuordnung manuell vorzunehmen, wird der Dialog Match geöffnet, wie unten gezeigt (der Dialogtitel ändert sich entsprechend dem Objekttyp ohne Zuordnung).

Der Dialog Match dient dazu, Objekte manuell zuzuordnen, von denen Sie wissen, dass sie zusammengehören. Lassen Sie die rechte Seite leer und klicken Sie auf Continue, wenn Sie unsicher sind.Der Dialog Match dient dazu, Objekte manuell zuzuordnen, von denen Sie wissen, dass sie zusammengehören. Lassen Sie die rechte Seite leer und klicken Sie auf Continue, wenn Sie unsicher sind.

  • Wählen Sie in diesem Dialog die Objekte, die Sie einander zuordnen möchten, in Unmatched Reference Objects und Unmatched Target Objects aus und übertragen Sie sie anschließend in den Bereich Matched Pairs des Dialogs. Für diese Objekte erzeugt die Software einen ECO zur Aktualisierung der Namen, sodass diese übereinstimmen, sowie ECOs zum Entfernen bzw. Hinzufügen von Mitgliedern, sodass auch diese übereinstimmen.
  • Wenn Sie unsicher sind, müssen Sie Objekte nicht manuell zuordnen. Bei allen Objekten ohne Zuordnung geht die Software davon aus, dass die Referenz- und Zielobjekte nicht zusammengehören. Daher erzeugt sie ECOs, die Unmatched Reference Objects von der Leiterplatte entfernen und Unmatched Target Objects als neue Objekte hinzufügen.
  • Sobald Sie die Objekte zugeordnet haben, von denen Sie wissen, dass sie zusammengehören, klicken Sie auf Continue, um den Dialog Engineering Change Order zu öffnen.
  • Wenn Sie auf Cancel klicken, wird der Aktualisierungsprozess beendet.

Designregeln zuordnen

Designregeln, die im Schaltplan definiert sind, müssen ebenfalls mit der entsprechenden Regel auf der PCB verknüpft werden. Ohne einen Verknüpfungsmechanismus könnten Sie die Regel im Schaltplan nicht aktualisieren und diese Änderungen auf die PCB übertragen. UIDs werden verwendet, um die Schaltplan-Designregel mit der PCB-Designregel zu verknüpfen.

Die UID wird automatisch im Parametersatz zugewiesen, der die Regeldefinition im Schaltplan enthält, und bei der Designsynchronisierung auf die PCB übertragen.

Designregeln verwenden eine UID, um die Designregeldefinition im Schaltplan der PCB-Designregel zuzuordnen.Designregeln verwenden eine UID, um die Designregeldefinition im Schaltplan der PCB-Designregel zuzuordnen.

Normalerweise müssen Sie die Zuordnung der Regeln nicht manuell verwalten, es sei denn, Sie haben die UID im Dialog PCB Rules and Constraints im PCB-Editor manuell bearbeitet. Wenn die UIDs nicht übereinstimmen, fügt die Software für jede Schaltplanregel ohne entsprechende PCB-Regel eine neue Regel zur Leiterplatte hinzu und entfernt jede PCB-Designregel, für die keine entsprechende Schaltplan-Designregel vorhanden ist.

Sie können Bauteile in beiden Editoren beliebig aktualisieren und diese Änderungen mit dem jeweils anderen Editor synchronisieren. Änderungen an Netzen, Klassen und Regeln können nur vom Schaltplan auf die Leiterplatte übertragen werden. 

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents