New in CircuitMaker

Created: July 31, 2020 | Updated: June 15, 2022
All Contents

This page details the improvements included in the initial release of CircuitMaker 2.0, as well as those added in subsequent updates. Along with delivering a range of improvements that develop and mature the existing technologies, each update also incorporates fixes and enhancements based on feedback raised by the CircuitMaker Community.

Update to the latest available version of CircuitMaker is a requirement to keep using it. Where a later version of the software is detected, you will be offered the ability to update. Should you reject the update, the software will close.

CircuitMaker 2.2

Released: 15 June 2022 - Version: 2.2.1 (build 6)
Released: 6 April 2022 - Version: 2.2.0 (build 5)

This update to CircuitMaker adds the ability to import design projects and documents created in 3rd party software, including KiCAD and P-CAD, in CircuitMaker projects. It also incorporates fixes and enhancements based on feedback raised by the CircuitMaker Community.

Key Highlights

Supporting your need to work with design files in other formats and from other tools, CircuitMaker sees the arrival of importer support. Use the Import command from the File menu to access the standard Windows Open dialog, then select a file type and a file to be imported.

Import settings for each supported design application are defined on the Importers section pages of CircuitMaker's System Preferences.

KiCAD Importer

Among other importers available, CircuitMaker includes the KiCAD® importer and supports importing the following design files:

  • KiCAD Project files (*.pro, *.kicad_pro)
  • KiCAD Schematic files (*.sch, *.kicad_sch)
  • KiCAD PCB files (*.kicad_pcb)

The results of the import can be seen in the Projects panel and can be summarized as follows:

  • Schematic and PCB documents related to the selected KiCAD Project file (*.pro, *.kicad_pro) are imported into the current CircuitMaker project.
  • A KiCAD schematic (*.sch, *.kicad_sch) is imported into a CircuitMaker Schematic document (*.SchDoc).
  • A KiCAD PCB (*.kicad_pcb) is imported into a CircuitMaker PCB document (*.CMPcbDoc).

CircuitMaker 2.1

Released: 11 February 2022 - Version: 2.1.0 (build 4)

This latest update to CircuitMaker adds the ability to collaborate efficiently with your counterpart Mechanical Engineer, enabling CoDesign between CircuitMaker and Autodesk® Fusion 360®. Delivered through the Fusion 360 CoDesigner extension, your direct interface to this feature is through the new Fusion 360 CoDesigner panel (View | System | Fusion 360 CoDesigner) from the PCB ribbon menus),  which is used to Push and Pull design changes back and forth between the two design domains.

Design changes are not transferred directly between the ECAD and MCAD environments, they are transferred through the Altium 365 platform. CircuitMaker projects are stored in an Altium 365 Personal Space, CoDesigner also uses this space to store a tool-neutral snapshot of the design that is accessible to both CircuitMaker and Autodesk Fusion 360. This approach allows designers on both sides to continue to edit their design files, and Push and Pull the updates when they are ready. The tool-neutral snapshot holds details of the objects that are supported, not the entire board design.

  • Design changes created in either environment are transferred to the target environment by performing a Push in the source editor. A message can be included to explain the nature of the change, this message is displayed in the respective panel's target environment. The Send button is then clicked to push the board to the shared Altium 365 platform. The Pull button can then be clicked in the target editor to synchronize the ECAD and MCAD designs.
  • When a change is Pushed, the target editor's panel will display a message that there is a change pending the next time they open their working copy of the design file. Click View Changes to display a list of changes.
  • You can check for outstanding changes at any time by performing a Pull. When the Pull button is clicked, a list of Changes will display. Each change is a difference between the data in the PCB file, and the data pushed by the source editor. You can click on an individual change in the Change List. That change will be highlighted on the board.
  • You can select which changes are to be applied - those not selected will be discarded.

CircuitMaker 2.0

Released: 12 August 2021 - Version: 2.0.3 (build 51)
Released: 02 July 2021 - Version: 2.0.2 (build 40)
Released: 23 June 2021 - Version: 2.0.1 (build 20)
Released: 14 June 2021 - Version: 2.0.0 (build 14)
Released: 10 June 2021 - Version: 2.0.0 (build 9)

The first thing to note with this release is that Altium CircuitMaker has been completely upgraded, with robust new features and a brand new User Interface. In addition, CircuitMaker’s code has been updated to align the code base with the latest Altium Designer technology, enabling further development and quicker adaptations to changes in the operating system environment.

CircuitMaker 2.0 remains free, community-centric and simple to use, while remaining powerful enough for you to embark on that next fun project.

CircuitMaker 2.0 now comes with a free account on Altium 365, our collaborative, cloud-based infrastructure platform. An Altium 365 account is and will remain free for CircuitMaker users. You can view schematic, PCB, BOM, Gerbers, and 3D directly in a web browser with your free account. Anyone with whom you choose to share your project (including people outside the CircuitMaker Community) can easily open and view that project via a web browser, without installing CircuitMaker.

Key Highlights

CircuitMaker 2.0 is a significant upgrade to CircuitMaker 1.3 and contains many fixes and improvements in all areas of the product. Click on the following collapsible sections to take a look at some of the major highlights.

With this release of CircuitMaker, you can now experience collaboration on a whole new scale, courtesy of the software's seamless integration with Altium 365®. Altium 365 is a cloud-based infrastructure platform that works together with CircuitMaker. Your design projects and those of the wider CircuitMaker Community are collectively stored and accessible from the Altium 365 platform. And since it is cloud-based, there is nothing to install and nothing to configure. It’s just there with CircuitMaker or from a browser.

As a registered user of the CircuitMaker Community, you will be given your very own Personal Space on the Altium 365 platform, which can only be seen by you. This is the place where any project you create in CircuitMaker is stored. You can work on projects privately within your Personal Space and when you fancy a little more collaboration you can share with other, specified people, for collaboration - editing (through CircuitMaker only) or viewing only. Comments enable you to quickly create a focus group - with participants able to review a design with or without CircuitMaker.

Ultimately, once your design is ready for flight into the wider CircuitMaker Community, you can publish it to the CircuitMaker Community Workspace - all from within your Personal Space on Altium 365!

If others have shared their design projects with you, you'll be able to access these from a dedicated Shared with Me area of the Altium 365 Platform Interface - again, both from within CircuitMaker and through a Web Browser.

Altium 365 is updated regularly, bringing new features frequently. Also, in addition to being the 'base' for all your CircuitMaker design projects, your Personal Space can accommodate the persistent storage of various types of uploaded static data, including design 'snapshots' (from various ECAD platforms) and Gerber manufacturing data, with the ability to share with anyone for comments and redlining. For more information, head across to the Altium 365 Personal Space page of the Altium 365 documentation.

Signing in to your Altium account through CircuitMaker has been streamlined and made far more accessible. To do so, click on the  control at the top-right of the main application window, then click the  entry on the associated menu. Use the subsequent Sign In dialog that appears to enter your account credentials, then click . Alternatively, sign in using your Google® or Facebook® account and, in doing so, link/associate that account with your Altium account. If you don't have an Altium account, you can click the control to register for one (which will take you to a page for registering with Altium 365).

The control will change to reflect having signed in to your Altium account by displaying your profile picture or avatar (e.g., ). The menu will display this also, with full name and with a link to quickly access your account (profile) through your default Web browser.

Signing out of your account is equally intuitive - simply click the  control to the right of your name.

Studies have shown that, while a text-oriented interface generally works best with dark text on a light background, an image-intensive interface is better for the eyes with light content on a dark background. With that in mind, CircuitMaker supports a new, dark color theme. From the System Preferences for the software (File » System Preferences), head on over to the UI Theme section of the System - General page, where you can now choose between Altium Dark Gray and Altium Light Gray. Hover over the following image of the two and let your eyes gravitate to their most relaxed preference!

The new Inspector panel removes the need for object dialogs in editors and therefore makes placing and editing objects much quicker and easier. The panel provides universal editing access to the properties of documents and objects, dynamically determining its content based on the document or object that is currently selected, and presenting specific properties and settings relating to that document/object. The panel also brings in parent and child properties into one streamlined access point.

The following image shows a taste of the Inspector panel in action for a schematic sheet, displaying content for the document (where no design objects are selected), and for a selected component. Hover over the image to see similar content from the PCB perspective.

While the Inspector panel can be accessed from the View tab of an applicable editor's ribbon menus, it can also be quickly accessed by double-clicking on a design object (in the Schematic- and PCB-related editors), and also by using the F11 keyboard shortcut.
Press F1 within the confines of the Inspector panel to access information in context with what is currently being presented to you.

Management of the layer stack for your board has had a complete refurbishment in this release. Gone is the Layer Stack Manager dialog of old, to be replaced with a single document-style editor. This editor is accessed from the PCB editor (Home | Board | Layer Stack Manager) and essentially provides two tabs:

  • Stackup - this tab details the fabrication layers. Layers are added, removed and configured on this tab.
  • Via Types - tab is used to define the allowed Z-plane layer-spanning requirements of the via(s) used in the design. The diameter and hole size (X&Y properties) of the vias placed in the design continue to be controlled by the default preferences if the via is placed manually or the applicable Routing Style design rule if the via is placed during interactive routing.
The Inspector panel presents the currently selected layer or via type respectively, for ease of editing.

The following image shows the Layer Stack Manager in action, configuring the stackup for a board. Hover over the image to see the definition of via types.

As a standard document editor, the Layer Stack Manager (LSM) can be left open while the PCB is being worked on, allowing you to switch back and forth between the PCB and the LSM. All of the standard view behaviors, such as splitting the screen or opening on a separate monitor are supported. Note that a Save action must be performed in the Layer Stack Manager before changes are reflected in the PCB.

The management of System Preferences (File » System Preferences) has also been overhauled in this release - now delivered in a document-style editor rather than the Preferences dialog of old.

Along with the major features and functionality highlighted previously, this release of CircuitMaker includes numerous additional enhancements and improvements that all combine to make your design experience with the software streamlined, intuitive and fruitful. These include:

  • New graphical engines for Schematic and PCB 3D, with the latter now using DirectX, bringing smoother and faster panning and zooming, particularly on large and dense schematics.
  • Dynamic compilation in Schematic. This removes the need for manual project compilation and also lays the foundation for stronger interaction between the editors.
  • Streamlining of File menu and Ribbons in general.
  • Completely redesigned Home page (View | System | Start from the main ribbon menus).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: