Managing Layers of a CAM Document in Altium Designer

Created: February 9, 2023 | Updated: February 9, 2023
Applies to Altium Designer versions: 23 and 24

Parent page: Inspecting Fabrication Data with the CAM Editor

Layers

Add New Layer

To add a new layer to the current document, choose the Edit » Layers » Add command from the main menus. After launching the command, the Enter Value dialog will appear. Use this dialog to enter a name for the new layer. By default the layer will have the name of the next available layer number, e.g. layer19.

After entering the required name and clicking OK, the new layer will be added to the layers list in the CAMtastic panel.

The name for the new layer must be typed in lower case.

Align Selected Layers

To align layers in the current document, based on chosen layer objects, use the Edit » Layers » Align Selective command from the main menus (shortcut: Ctrl+L).

First, ensure that only the layers you wish to work with are enabled. This can be achieved using either the Layers Table dialog (Tables »  Layers), or the layers section in the CAMtastic panel.

After launching the command, the cursor will change to a square and you will enter alignment mode. Alignment is made by performing the following sequence of actions:

  1. You will be prompted to select a base object. This is an object on the target layer that you wish to align another layer with. Simply position the cursor over an object on this target layer and click.
  2. You will then be prompted to choose an object on the layer you wish to align to this target layer. Again, simply position the cursor over the required object and click. The chosen layer will be moved into alignment with the target layer - the layer will be moved so that the chosen object is centered on the base object.
  3. Continue to align other layers by selected objects, or right-click, or press Esc, to exit alignment mode.
The layer on which you choose the base object (i.e. the target layer) will become the current layer after the alignment has been effected.

Align Layer Borders

To align layers in the current document, based on matching layer boundaries, choose the Edit » Layers » Align Border (Auto-Detect) command from the main menus. After launching the command, the cursor will change to a square and you will enter alignment mode. You will be prompted to select a closed border. Simply position the cursor over an edge of the border for the target layer that you wish to align all other matching layers to, and click. All layers that contain a matching border will be aligned to the target layer.

Continue aligning layers by border, or right-click, or press Esc, to exit alignment mode.

  • Any layers where no matching border is detected will be left alone.
  • The selected border should be a straight edge of a closed boundary.

Copy to Layers

To copy selected objects to one or more layers in the current document, choose the Edit » Layers » Copy to Layers command from the main menus.

After launching the command, the cursor will change to a square and you will enter copy mode. The procedure involves the following sequence of actions:

  1. Select the objects to include in the copy. Simply position the cursor over an object you wish to include in the selection and click. Alternatively, clicking away from an object allows you to drag a selection area, for including multiple objects in the selection. Selection is cumulative.
  2. Once all required objects are selected, right-click. The Select Layers To Copy dialog will appear. Use the dialog to choose the single layer (or multiple layers) to which you wish the selection to be copied.
  3. After clicking OK, the selection will be copied to the chosen layer(s) and you will return to copy mode.
  4. Continue selecting more objects to copy, or right-click, or press Esc, to exit.
The command can be canceled at any stage before the right-click, by pressing Esc. Pressing Esc after the Select Layers To Copy dialog appears will cancel the current selection and return you to copy mode, ready to make a fresh selection.

Move Layer Data

To quickly move data between the layers of the current document, choose the Edit » Layers » Swap Layers Data command from the main menus. After launching the command, the Swap Layers Data dialog will appear. The dialog presents all currently defined layers in the document, in Before swap and After swap columns. Initially, these columns are identical listings, which means that no movement of data will occur. If you want to move the data from one layer to another, simply identify the source layer in the Before swap column, then in the corresponding row of the After swap column, click within the Layer Name field, and choose the target layer to which the data should be moved. Do this for all layers that you want to move data from.

After the swapping is configured as required, click OK - for each configured swap, the data will be moved from the source layer to the nominated target layer.

Create a New Merged Layer

To create a new layer by merging existing layers in the current document, choose the Edit » Layers » Merge command from the main menus (shortcut: L). After launching the command, the Select Layer for Merging dialog will appear. Use the dialog to enter a name for the new layer and choose which of the existing layers in the document you wish to merge. Use the Select All button to merge all existing layers into the new layer.

After clicking OK, the new layer will be created and added to the layers list in the CAMtastic panel.

  • Use standard multi-select controls (Ctrl+Click, Shift+Click, Click&Drag) for choosing the layers to include in the merge.
  • The new layer will be added to the Layers Table dialog (Tables »  Layers), and initially assigned the Temporary layer type. Change this as required.
  • The original layers involved in the merge will not be modified in any way by using this command.

Scale Layers

To scale layers in the current document in the X and/or Y directions, choose the Edit » Layers » Scale(X:Y) command from the main menus. After launching the command, the Scale Layers dialog will appear. The dialog lists each of the layers in the current .Cam file. For each layer, editable fields for X and Y scaling are available, initially set at a scale of 100% (normal imported sizing).

Use the dialog to change the scaling for any of the layers, with respect to X and/or Y axis as required. After clicking OK the visible layers will be redrawn, with the affected layers expanded, or reduced, according to the options defined.

  • Values greater than 100% will result in enlargement. Values between 0% and 100% will result in reduction.
  • Flashes are moved with respect to the origin and in accordance with the scaling applied. They are not changed in size.
  • Traces (draws) are enlarged or reduced with respect to their length (not width), in accordance with the chosen scale.

Composite Layers

The advantage of creating a composite layer is that you can create objects - through addition of overlapping objects on different layers - that are not possible to draw or flash on a single layer.

Automatically Create Composite Layer

To automatically build a composite layer, using objects selected from existing layers in the current document, choose the Edit » Composite Layers » Auto Create Composite command from the main menus. After launching the command, the cursor will change to a small square and you will be prompted to select objects that you wish to include in the composite layer. Simply position the cursor over individual objects and click to add them to the selection, or use one of the many selection tools available.

After all required objects are selected, right-click. The Auto-create Composite dialog appears. Use the dialog to select whether you wish to create the new layer with Positive (Opaque Image) or Negative (Transparent Image) polarity.

After clicking OK, the composite layer will be generated and added to the layers list in the CAMtastic panel.

The name of the new layer will, by default, be based on the next available layer number in the layers list (e.g. layer18). You can rename the layer, either in the Layers Table dialog (Tables » Layers), or by right-clicking on the layer's entry in the CAMtastic panel and choosing the Rename command.

Create Composite Layer

To create a single composite layer from selected existing layers in the current document, choose the Edit » Composite Layers » Build Composite command from the main menus. After launching the command, the Merge Composite dialog will appear, providing the following controls:

  • At the top of the dialog are controls for specifying the name for the new layer and also its polarity.
  • The main grid section of the dialog is used to specify the layers that you wish to include in the merged composite. Select a layer from the associated drop-down, which contains all currently defined and loaded layers in the design.
  • For each layer, specify the polarity as either Dark or Clear. If Dark, the contents of the layer will be added to the merged composite. If Clear, they will be subtracted.
  • The Spread field allows you to specify enlargement/reduction of apertures within the associated layer.

After setting up all layers that you wish to include in the merge, click OK - the new layer will be created and added to the layers list in the CAMtastic panel.

  • The order in which the layers are selected for the merge, is the order in which they will be compiled. This is important because if you do not get the ordering correct for what you wish to achieve with the composite, the results can be somewhat undesirable. For example, if you wish a small area of a larger polygon to be voided, make sure the layer with the polygon is listed first and then the layer containing the void.
  • Existing composite layers should not be used to create new ones.
  • The polarity options for the composite layer simply control (toggle) the polarity settings for the individual layers.

Explode Composite

To permanently explode a composite layer into its constituent layers, in order to allow layer-level editing, use the Edit » Composite Layers » Explode Composite command from the main menus.

First, ensure that the composite layer that you wish to explode is turned ON. You may also find it easier to turn all other layers OFF. This can be done quickly from the CAMtastic panel by selecting the required composite layer, and using the Left Arrow keyboard shortcut.

After launching the command, the cursor will change to a small square and you will be prompted to select the composite that you wish to explode. Simply position the cursor over an area on the layer where constituent layers overlap, and click. The constituent layers will be created, based on the composite layer name. The composite layer itself is deleted from the layers list.

For example, if your composite layer were named compro and contained three merged layers, the resulting constituent layers that would be evident in the layers list of the CAMtastic panel are:

  • compro - the first constituent layer.
  • compro-1 - the second constituent layer.
  • compro-2 - the third constituent layer.

Continue exploding further composite layers, or right-click, or press Esc, to exit.

  • This command is permanent and cannot be undone.
  • Use of this command will not be possible if the composite layer you wish to explode is not a true composite - i.e. no overlapping areas exist as a result of the merging of the member layers.

Modify Composite

To modify the merge properties of the selected composite layer, in the current document, use the Edit » Composite Layers » Modify Composite command from the main menus.

First, ensure that the composite layer that you wish to modify is turned ON. You may also find it easier to turn all other layers OFF. This can be done quickly from the CAMtastic panel by selecting the required composite layer, and using the Left Arrow keyboard shortcut.

After launching the command, the cursor will change to a small square and you will be prompted to select the composite that you wish to modify. Simply position the cursor over an area on the layer where constituent layers overlap, and click. The Merge Composite dialog will appear. Use the dialog to make any changes required, and then click OK to execute those changes.

Continue modifying further composite layers, or right-click, or press Esc, to exit.

  • Use of this command will not be possible if the composite layer you wish to modify is not a true composite - i.e. no overlapping areas exist as a result of the merging of the member layers.
  • You will notice that the original member layer names have been replaced with C1: CompositeLayerNameC2: CompositeLayerName, etc. These entries may be removed or changed to another layer altogether. All options that were available when originally building the composite, are again available when modifying it.

Open Composite for Editing

To temporarily explode a composite layer into its constituent layers, in order to allow layer-level editing, use the Edit » Composite Layers » Open Composite for Editing command from the main menus.

First, ensure that the composite layer that you wish to open is turned ON. You may also find it easier to turn all other layers OFF. This can be done quickly from the CAMtastic panel by selecting the required composite layer, and using the Left Arrow keyboard shortcut.

After launching the command, the cursor will change to a small square and you will be prompted to select the composite that you wish to open. Simply position the cursor over an area on the layer where constituent layers overlap, and click. The constituent layers will be created, based on the composite layer name. The composite layer itself is deleted from the layers list.

For example, if your composite layer were named compro and contained three merged layers, the resulting constituent layers that would be evident in the layers list of the CAMtastic panel are:

  • compro - the first constituent layer.
  • compro-1 - the second constituent layer.
  • compro-2 - the third constituent layer.

Use of this command will not be possible if the composite layer you wish to open is not a true composite - i.e. no overlapping areas exist as a result of the merging of the member layers.

Close Composite

To reunite the constituent layers of a composite layer, that has been previously opened for layer-level editing, choose the Edit » Composite Layers » Close Composite command from the main menus. The constituent layers will be re-merged and the original composite layer will be available in the layers list of the CAMtastic panel.

Use of this command will only apply to the last composite layer you have opened. If your document contains multiple composite layers, it is advisable to open, work on, and close, one at a time.

Layer Tables

Manage Layers

From the Layers Table dialog, you can define various properties for each of the available layers in the current document. To run the dialog, choose the Tables » Layers command from the main menus.

After launching the command, the Layers Table dialog will appear. Use this dialog to define the name and layer type, for each of the available layers in the document. You can also specify the Draw and Flash colors associated to each layer and control whether a layer is turned ON or OFF (i.e. toggle its display status).

The dialog also enables you to lock a layer. When a layer is locked, you will not be able to carry out any editing commands involving objects placed upon it.

Layers can also be deleted from within this dialog.

Clicking the View Layer Order button will open the View/Change Layers Order dialog, from where you can define the order in which the layers are drawn and the direction of drawing - either from Top to Bottom or from Bottom to Top.

  • You can also define layer name, visibility, locked status and layer color, in the CAMtastic panel.
  • If any layer has already been assigned as a Drill layer, then a fabrication drawing may be created from it, otherwise a Top and Bottom layer type assignment must be made, before drill drawing creation is possible.
  • Drag and drop layers in the View/Change Layers Order dialog, to obtain the specific layer drawing order that you require.

Manage Layer Type Detection

To define a template of strings/extensions that can be associated to the various available layer types in the CAMtastic Editor, use the Tables » Layer Type Detection command from the main menus. This template is used to auto-detect layers during a Gerber import. After launching the command, the Layer Types Detection Template dialog will appear. For each layer type available in the CAMtastic Editor, a series of predefined strings have been entered, based on common layer naming extensions/strings, used to identify the various layers of a design. You can edit any entry in the template simply by typing directly in the required field. When adding new strings/extensions to the template, use the comma separator (,) between entries.

  • The template is used when importing Gerber files, to auto-detect which layer type should be assigned to which layer. The layer type information is entered next to the layer in the Layers Table dialog (Tables » Layers). If auto-detection cannot determine the layer type for a particular layer, that layer will appear in the Layers Table dialog with the layer type Temporary assigned.
  • A layer type must be assigned to each layer in the design. If auto-detection cannot determine which layer type to assign, you must assign a layer manually.

Manage Layer Sets

To define layer sets, to be assigned to specified drill layers when drilling designs that incorporate blind and buried vias, choose the Tables » Layers Sets command from the main menus. This information is required when extracting/exporting the netlist, or running a DRC for example.

After launching the command, the Create/Update Layers Sets dialog will appear. Click the Insert Layers Set button to add a new layer set entry in the main area of the dialog, then define that entry as follows:

  • Click inside the Layer Set Name field for the entry and type a meaningful name, for example with respect to the layers involved in the drilling.
  • In the Assigned Drill Layer column, select which drill layer should be assigned to the layer set. The drill layer will contain the drilling information in terms of locations of drill points.
  • Click inside the Signal/Plane Layers In Set field for the entry, to open the Select Layer Pairs dialog. This dialog is where you define the layers involved in the drilling.
  • If the Gerber files have been generated from Altium Designer's PCB Editor, then the information in the Create/Update Layers Sets dialog will already be present, and will mirror the via types defined in the Layer Stack Manager.
  • When using third party software to generate the Gerber files, the Create/Update Layers Sets dialog will be empty, and you will need to define the drilling layer sets manually.
  • For blind/buried vias, you must select all layers that are drilled, not just the start and end layers. For thru-holes, start and end layers will suffice.

Manage Layer Order

From the Create/Update Layers Order dialog, you can define the physical layer order for the design. Choose the Tables » Layers Order command from the main menus to run the dialog.

The dialog lists each of the signal and internal plane layers for the current design, along with their logical and physical ordering. Use the dialog to define the physical order of the layers - the order that appears in the PCB layer stack.

The logical layer order is the order the layers appear in the layers list on the CAMtastic panel. The physical layer order is the actual layer stack-up of the signal and internal plane layers. This ordering is important when exporting the design in formats such as ODB++ and IPC-D-356.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: