Altium Designer Documentation

Interfacing to Other Design Tools from Altium Designer

Created: December 8, 2022 | Updated: December 8, 2022
All Contents

Altium's design software is probably just one of many engineering design environments that you work with, or need to interface to.

Perhaps you need to interface to another design and analysis platform to perform a power simulation, or perhaps you need to import an older design that was developed in another design environment. Whatever the reason, it's likely that one day you'll need to be able to interface to another design tool.

Performing an Import or Export

Interfacing to another design environment is all about transferring design data. That can either be done by reading/writing the design data from/to a different file format, or directly transferring data via software API's.

Import actions are performed via the File » Import command. Also, many of the importers can be accessed via the Import Wizard. Using the Wizard allows related files, such as design files and their libraries, to be batch imported.

Export outputs can be created by adding the required outputs in an Outputjob file (from the Edit » Add Export Outputs sub-menus or from the menus associated with the [Add New Export Output] control, at the bottom of the Export Outputs region, in the main job configuration window) followed by generating the outputs from the file or as part of the Project Release process. Alternatively, export actions are performed via the File » Export menu, in the appropriate editor.

Import Wizard

The Import Wizard (File » Import Wizard) will quickly and easily convert your design files from other vendors to Altium Designer files. The Wizard walks you through the import process, handling both the schematic and PCB parts of the project, as well as managing the relationship between them.

  • Click Cancel to close the Import Wizard.
  • Click Back to navigate to the previous screen.
  • Click Next to navigate to the next screen.
  • Click Finish to close the Import Wizard. This option is available only on the final page of the Wizard.

Selecting the Type of Files to Import

Use this page of the Wizard to select the types of files you want to import. See the Interfacing to EDA Design Tools section below for an overview of types of design files that can be imported using the Import Wizard.

Click Get More Importers to open the Extensions and Updates page from where you can add additional extensions if needed.

The subsequent pages of the Wizard change depending upon the file type you selected. Find the desired file type in the following list then click on the link to access the information regarding that file type.

Interfacing to EDA Design Tools

The table below summarizes EDA design tools and their file formats supported for import to and/or export from Altium Designer.

Name Supported Formats Learn More
Protel® / Altium

Import
All previous Protel/Altium Schematic files/libraries
All previous Protel/Altium PCB files/libraries
CircuitMaker (current - *.CMPcbDoc), CircuitStudio (*.CSPcbDoc), PCBWorks (*.PWPcbDoc, *.SWPcbDoc) PCB files
CircuitMaker 2000 Schematics (*.ckt)
CircuitMaker 2000 User Libraries (*.lib)
CircuitMaker 2000 Device Libraries (*.lib)
Protel 99SE Design Database (*.ddb)
Protel DOS Schematic (*.s??)
Tango PCB ASCII files (*.pcb)
Autorax PCB (*.pcb)

Export
CircuitMaker PCB files (*.CMPcbDoc)
CircuitStudio PCB files (*.CSPcbDoc)
Protel PCB 2.8 ASCII (*.pcb)

Altium Design Software Import-Export Support

P-CAD®

Import
P-CAD V16 or V17 Binary Schematic design files (*.sch)
P-CAD V16 or V17 ASCII Schematic design files (*.sch)
P-CAD V15, V16, or V17 Binary PCB design files (*.pcb)
P-CAD V15, V16, or V17 ASCII PCB design files (*.pcb)
P-CAD V16 or V17 Binary Library files (*.lib)
P-CAD V16 or V17 ASCII Library files (*.lia)
P-CAD PDIF files (*.pdf)

Export
P-CAD V16 Schematic design files (*.sch)
P-CAD V16 Schematic library files (*.lia)
P-CAD ASCII PCB (*.pcb)
P-CAD V16 PCB library files (*.lia)

Altium Design Software Import-Export Support - P-CAD Design Files Import-Export Support

Autodesk® EAGLE™

Import (XML format, versions 6.4 through to 9.4)
EAGLE Schematic (*.sch)
EAGLE PCB (*.brd)
EAGLE Library (*.lbr)

Importing a Design from EAGLE

Cadence® Allegro® Import (requires Allegro, check the Import Prerequisites)
Allegro binary PCB (*.brd)
Allegro ASCII PCB (*.alg)
Allegro Footprint (*.dra)

Importing a Design from Allegro

Cadence® OrCAD®

Import (up to OrCAD version 17.2)
OrCAD Capture Designs (*.dsn)
OrCAD Capture Libraries (*.olb)
OrCAD Layout PCB documents (*.max)

OrCAD PCB Editor (*.brd) (requires the Allegro importer)
OrCAD PCB Libraries (*.llb)
OrCAD CIS Configuration files (*.dbc)  in binary format
OrCAD SDT (*.sch)
Export
OrCAD SDT Schematic (*.sch)
OrCAD v7 Capture Design (*.sch)

Importing a Design from OrCAD

Importing a Design from OrCAD CIS

Exporting a Design to OrCAD

KiCad®

Import
KiCad pro Files (*.pro)
KiCad kicad_pro Files (*.kicad_pro)
KiCad sch Files (*.sch)
KiCad kicad_sch Files (*.kicad_sch)
KiCad lib Files (*.lib)
KiCad kicad_pcb Files (*.kicad_pcb)

Importing a Design from KiCad

LTspice® Import
LTspice ASC Files (*.asc)
LTspice ASY Files (*.asy)

Importing a Design from LTspice

Mentor Graphics® DxDesigner® Import (up to VX2.x)
DxDesigner Designs and Libraries

Importing a Design from xDX Designer or DxDesigner

Mentor Graphics® Expedition® Import (up to VX2.x)
Expedition files (*.pcb, *.lib)

Importing a Design from Expedition

Mentor Graphics® PADS®

Import (up to VX2.x)
PADS Layout ASCII Design files (*.asc)
PADS Layout ASCII Decal Libraries (*.d)
PADS Logic ASCII Design files (*.txt)
PADS Logic ASCII CAE Decal Libraries (*.c)
PADS Logic ASCII Part Type Libraries (*.p)

Export
PADS Logic 5

Importing a Design from PADS Logic & PADS Layout

Exporting a Design to PADS Logic

Mentor Graphics® xDxDesigner® Import (up to EE7.9.4)
xDxDesigner Designs (*.prj) and Libraries

Importing a Design from xDX Designer or DxDesigner

Simbeor® Export
Simbeor file (*.esx)

Defining the Layer Stack - Exporting a Layer Stack

Zuken® CADSTAR® Import (up to 2018 version)
CADSTAR Schematic Archive (*.csa)
CADSTAR PCB Archive (*.cpa)
CADSTAR Part Library (*.lib)

Importing a Design from CADSTAR

Zuken® CR-5000® Import
Zuken CR-5000 PCF Files (*.pcf)
Zuken CR-5000 FTF Files (*.ftf)
Zuken CR-5000 EDS Files (*.eds)
Zuken CR-5000 EDF Files (*.edf)
Zuken CR-5000 LAF Files (*.laf)
Zuken CR-5000 SMB Files (*.smb)
Zuken CR-5000 PRF Files (*.prf)
Zuken CR-5000 CDFLAF Files (*.cdf)

Importing a Design from CR-5000

Creating a Netlist

Altium Designer supports creation of a netlist, in the indicated format, from all relevant source documents in the active project or from the active source document. The related indexed commands are accessed from the schematic editor, from the Design » Netlist For Project or Design » Netlist For Document sub-menu, respectively.

A Netlist Output, with the indicated Data Source, can also be added to the active Output Job Configuration file by choosing a command from the Edit » Add Netlist Outputs sub-menus or from the menus associated with the [Add New Netlist Output] control, at the bottom of the Netlist Outputs region, in the main job configuration window. Each sub-menu relates to a specific format of netlist, n, while each entry on a netlist format sub-menu relates to a specific Data Source, m.

The following netlist formats are supported:

  • Cadnetix
  • Calay
  • EDIF for PCB
  • EESof
  • Intergraph
  • Mentor BoardStation
  • MultiWire
  • OrCad/PCB2
  • PADS
  • Pcad for PCB
  • PCAD
  • PCADnlt
  • Protel2
  • Protel
  • Racal
  • RINF
  • SciCards
  • Tango
  • Telesis
  • Wirelist
  • XSpice
The majority of command entries to generate netlist formats are only available in the menus, provided the associated functionality is installed as part of your Altium Designer installation. To view and change functionality available to your installation, access the Extensions & Updates view (accessed by clicking on the  control at the top-right of the design space and choosing the Extensions and Updates command from the menu). From the Installed page, click the Configure control at the top-right to access the Configure Platform page. For those netlisters listed in red above, ensure that the Netlisters entry in the Importers\Exporters region is enabled. For the PADS netlister, ensure that the PADS entry in this region is enabled. For the XSpice netlister, ensure that the Mixed Simulation entry, in the Platform Extensions region, is enabled. Once the required functionality is enabled, click Apply. You will need to restart Altium Designer for the changes to take effect.

Depending on the format of netlist you have chosen to create, launching the command will either generate the netlist directly, or an intermediate dialog will appear, allowing you to define specific format-related options. The generated file(s) will initially be closed.

  • All output files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the netlist file (<ActiveDocumentName>.NET) will be presented under the Generated\Netlist Files sub-folder. Bear in mind, that if a different format netlist is generated from the same active document, the previously generated netlist file will be overwritten.
  • If the option to Use separate folder for each output type is enabled (also on the Options tab), output will be written into a further sub-folder, named in accordance with the format of netlist you have chosen to create (e.g. Project Outputs for <ProjectName>\<NetlistFormat> Output). In the Projects panel, output will appear under the Generated (<NetlistFormat> Output) sub-folder. This allows you to generate multiple netlists from the same active document for the project, without any files being overwritten.

Interfacing to Other Design Tools

Altium Designer can also interface to other design tools (MCADs, CAEs, etc.), for example, using neutral file formats. The table below summarizes other file formats supported for import to and/or export from Altium Designer.

ECAD-MCAD CoDesign

Note that for supported MCAD packages, it is also possible to transfer the board and components directly between MCAD and ECAD using CoDesigner, Altium's ECAD-to-MCAD connectivity technology. Working through a connected Workspace, such as an Altium 365 Workspace, CoDesigner can push the board shape and placed components back and forth between your MCAD software and Altium Designer.

The features available in Altium CoDesigner depends on your Altium Designer Subscription. Learn more about the features included in each Subscription Plan.

Learn more about Direct ECAD-MCAD Design with Altium CoDesigner

Name Supported Formats Learn More
Ansoft™ Export (up to version 4.0)
Ansoft™/ANSYS ® Neutral files (*.anf)

Exporting a Design to Ansoft Neutral Format

Ansys® Export
EDB files (*.def)

Interfacing to the ANSYS Simulation Tools

AutoCAD® Import/Export (up to version 2018)
DXF files (*.dxf)
DWG files (*.dwg)

AutoCAD-DXF Import-Export Support

HyperLynx™ Export
HyperLynx files (*.hyp)

Exporting a Design to HyperLynx

IDF Import/Export
IDF Board files (*.brd, *.bdf, *.idb, *.enm, *.idf)

Mechanical Data Import-Export Support - IDF Files Import-Export Support

IDX Import/Export
Incremental Design Exchange format files (*.idx)

Mechanical Data Import-Export Support - IDX Files Import-Export Support

Parasolid

Import
Parasolid Text files (*.x_t)

Export
Parasolid Text files (*.x_t)
Parasolid Binary files (*.x_b)

Mechanical Data Import-Export Support - Parasolid Files Import-Export Support

SiSoft™ Quantum-SI™ Export
Comma-Separated Values files (*.csv)

Exporting a Design to SiSoft Quantum Format

SolidWorks® Import
SolidWorks Part files (*.sldprt)

Mechanical Data Import-Export Support - SolidWorks Part Files Import Support

Specctra®

Import
Specctra Design files (*.dsn)
Specctra Route files (*.rte)

Export
Specctra Design files (*.dsn)

Ensuring PCB Readiness for Specctra-compatible Routers

STEP Import/Export
STEP format files (*.step, *.stp)

Mechanical Data Import-Export Support - STEP Files Import-Export Support

VRML Export
VRML files (*.wrl)

Mechanical Data Import-Export Support - VRML Files Export Support

Most importers and exporters are delivered as Altium Designer extensions, and the command for a specific filetype import/export will only be present if that extension is installed. See a page for a specific importer/exporter to learn more about the required extension.

Learn more about Extending & Updating Your Installation

There is a number of software extensions delivered by Altium itself or developed by third parties for extending Altium Designer's features and functionality in some measurable way. Some of these extensions include:

  • SIMetrix/SIMPLIS Interface – SIMetrix/SIMPLIS is a combination of two independent circuit simulators: SIMetrix, a SPICE-based simulator with custom models for power transistor devices; and SIMPLIS, a fast simulator for switching power supply circuits.
  • JTAG Maps – the free JTAG Maps™ extension helps hardware engineers assess the potential of using Boundary scan testing in their designs and prepares the JTAG test data upfront. Download the extension from the JTAG Live® website.
  • XJTAG DFT Assistant x64 – the free XJTAG® DFT Assistant extension allows the board designer to assess and improve the testability of their PCBs throughout the design process.
  • MTBF and Reliability Toolkit – use BQR fiXtress™ to help you to design reliable electronics systems without expensive re-spins or physical prototypes. Download the extension from the BQR® website.

Learn more about the available design extensions in the Altium Products area.

Getting Help

If you're reading this page because you're new to designing with Altium software, here are some tips to help you get started:

  • If you're moving from another design environment, you can start exploring the software here, or dive straight into the start-to-finish introductory tutorial.
  • Use the resources available in this documentation space (www.altium.com/documentation), where you can either search via the search icon, or browse using the navigation tree on the left.
  • Whatever type of document you are editing, you can press F1 over an object, editor, panel, menu entry or button to access reference information about that item.
  • Press Shift+F1 while running a command, for a list of shortcuts you can use in that command.
  • Explore the Altium Academy Youtube channel, an online experience created to bring modern education to PCB Designers and Engineers globally. Learn directly from professionals and industry experts as they share their knowledge covering basic PCB design principles, advanced engineering topics, and everything in-between.
  • Attend a webinar or another of Altium's learning events.
  • Join a discussion forum, where you can share with and learn from your industry peers.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: