Sincronización de datos de la base de datos de la cadena de suministro con los datos del espacio de trabajo
De un vistazo
- Aprende a crear una configuración de sincronización y a conectar fuentes de datos compatibles.
- Comprende cómo asignar los parámetros de los proveedores y los precios por volumen, utilizando el número de pieza del fabricante para vincular las entradas de proveedores con los componentes del espacio de trabajo.
- Descubre cómo ejecutar o programar la sincronización y dónde encontrar los datos resultantes del proveedor de piezas personalizado en Altium Designer.
Mediante el concepto de Opciones de piezas, las piezas de componentes alojadas en un espacio de trabajo de Altium 365 o un espacio de trabajo de Enterprise Server pueden vincularse con piezas reales de proveedores, según la pieza del fabricante especificada. De forma predeterminada, estos datos de la cadena de suministro se obtienen a través del servicio en la nube Altium Parts Provider e incluyen información en tiempo real sobre las piezas de los proveedores, como los niveles de existencias, los precios unitarios y los tramos de precios por cantidad.
Sin embargo, en muchas organizaciones, los datos de los proveedores de componentes se obtienen (y deben obtenerse) de un sistema empresarial interno que proporciona un conjunto propio de datos de proveedores de piezas, que puede basarse en una selección estrictamente aprobada de proveedores o en estructuras de precios especiales. Para estos casos, Altium ofrece la alternativa Custom Parts Provider, que, al configurarse para la sincronización a través de Altium Designer, permite asignar los datos de proveedores de una base de datos específica a los datos de la cadena de suministro del espacio de trabajo.
Mediante la función Custom Parts Provider Synchronization de Altium Designer, tal como se describe a continuación, los datos de proveedores de una tabla seleccionada dentro de una base de datos maestra se asignan para servir como fuente de datos alternativa para las Opciones de piezas de los componentes definidas en Altium Designer. En la práctica, la configuración de asignación que se crea se utiliza para sincronizar la base de datos de origen con los datos de proveedores del espacio de trabajo, mediante un proceso programado o simplemente bajo demanda. Como resultado, las actualizaciones de los datos de proveedores en la base de datos maestra se propagarán a los datos de proveedores de los componentes correspondientes en el espacio de trabajo conectado.
Esta función permite a las empresas que gestionan de forma centralizada los datos de proveedores de componentes en la base de datos de un sistema empresarial aprovechar las ventajas de un espacio de trabajo de Altium y, al mismo tiempo, mantener la sincronización con su sistema empresarial (PLM, PDM, ERP, etc.), o simplemente con una base de datos compartida o un archivo CSV. En el modo de sincronización automática, una tarea programada de Windows actualizará los datos de la base de datos en el espacio de trabajo independientemente del cliente de diseño Altium Designer.
-
Consulte Importación de bibliotecas existentes a su espacio de trabajo conectado para obtener información sobre cómo importar bibliotecas de bases de datos a su espacio de trabajo.
-
Consulte Sincronización de datos de una base de datos de componentes con el espacio de trabajo para obtener información sobre el proceso relacionado de sincronización de los datos de parámetros de componentes del espacio de trabajo con una base de datos de origen.
Creación de una configuración de sincronización de un proveedor de piezas personalizado
La sincronización de datos de proveedores de piezas entre una base de datos y el espacio de trabajo se establece mediante la creación y configuración de un documento Custom Parts Provider Synchronization Configuration (*.PrtSync) en Altium Designer. La interfaz del documento y sus funciones son similares a las del Sincronizador de componentes. Cuando esté conectado a su espacio de trabajo de Altium, cree el nuevo documento mediante el comando de menú File » New » Custom Parts Provider Synchronization Configuration.
Añada la fuente de datos maestra deseada a la configuración de sincronización mediante el botón
, o arrastrando y soltando archivos de datos compatibles en el área Data Sources de la interfaz. La configuración admite las siguientes fuentes de datos de parámetros de componentes:
-
Archivos de bases de datos de Access (
*.mdb,*.accdb) -
Hojas de cálculo de Excel (
*.xlsx) -
Archivos CSV (
*.csv) -
Otras fuentes de datos, como interfaces compatibles con OLE DB basadas en servidor (incluidas las bases de datos PostgreSQL), mediante una cadena de conexión propia. Consulte la sección Configuración de MySQL que aparece más abajo para conocer el procedimiento de conexión ODBC de MySQL.
En el ejemplo que se muestra aquí, se ha añadido a la configuración una base de datos que aloja datos de proveedores de piezas (para componentes de diodos Zener). La base de datos de origen (SupplierData.mdb) contiene dos tablas, CustomSupplierParts1 y CustomSupplierParts2, de las cuales la primera está habilitada para la asignación y la sincronización.
Procedimiento de configuración de ODBC para MySQL
La sincronización de un proveedor de piezas personalizado con una base de datos MySQL se configura mediante Microsoft OLE DB Provider for ODBC con la aplicación MySQL Connector/ODB. El procedimiento de conexión y configuración es el siguiente:
-
Descargue e instale MySQL Connector, que puede obtenerse mediante la opción de instalación personalizada de MySQL Installer 8. A continuación, ejecute la aplicación ODB Data Sources de Windows para añadir el tipo MySQL ODBC ANSI Driver, especifique el origen y la base de datos MySQL en MYSQL Connector y confirme el origen de datos ODB recién añadido.
-
Cree una nueva configuración de sincronización de piezas en Altium Designer (File » New » Custom Parts Provider Synchronization Configuration) y seleccione la opción Use Connection String del menú
.
-
En el siguiente cuadro de diálogo Data Link Properties, seleccione la opción
Microsoft OLER DB Provider for ODBC Driversen la pestaña Provider, haga clic en Next y, a continuación, en la pestaña Connection del cuadro de diálogo, introduzca los detalles del origen de datos establecidos anteriormente en Step 1. -
Habilite la tabla deseada de la base de datos MySQL en el panel Properties de Altium Designer.
-
Seleccione la tabla de la base de datos en la jerarquía Data Source y, a continuación, asigne las columnas de datos a los parámetros de Altium en el panel Properties, según sea necesario.
Asignación de parámetros de datos de proveedores
La nueva configuración del proveedor de piezas personalizado accede a la tabla de la base de datos como una fuente de datos paramétricos. Al seleccionar la tabla en el árbol Data Sources de la configuración, se puede asignar a los parámetros estándar de datos de proveedores que utilizan Altium Designer y el espacio de trabajo de Altium.
Los parámetros de datos de proveedores se asignan desde la base de datos de origen a la configuración del proveedor de piezas en la sección Parameter Mapping del panel Properties. Utilice las opciones del menú desplegable de la entrada Column para elegir un parámetro de la base de datos de origen que se corresponda correctamente con un parámetro de datos de proveedores, o para excluir un parámetro de la sincronización (<Skip>). Cada conjunto de datos de parámetros se añade a la lista Components Preview a medida que se realiza la asignación. Estas columnas se pueden reordenar arrastrando sus encabezados, y habilitar o deshabilitar mediante el menú Select Columns (al que se accede haciendo clic con el botón derecho en un encabezado).
Se admiten varios parámetros del sistema para los datos de proveedores, incluidos Manufacturer Name, Manufacturer Part Number, Category, Datasheet, etc. También puede añadir y eliminar parámetros personalizados de datos de proveedores mediante los botones
y
de la sección Parameter Mapping del panel Properties.
Los umbrales de descuento por volumen de los componentes representan la cantidad de componentes que deben pedirse a un proveedor para obtener un coste unitario reducido. Las cantidades de pedido necesarias suelen organizarse en múltiplos de diez —10 unidades, 100 unidades, etc.— y se admiten en las entradas de opciones de piezas de los datos de proveedores de Altium.
Estos datos numéricos pueden asignarse desde las entradas de la base de datos de origen a los datos de proveedores del espacio de trabajo añadiendo entradas Quantity de descuentos por volumen en la sección Price Breaks del panel Properties —que aumentan secuencialmente en múltiplos de diez— y, después, asignando esas entradas a los campos correspondientes de la base de datos. Tenga en cuenta que el parámetro de coste convencional unit (Price) se incluye en la sección general Parameter Mapping.
Sincronización de la base de datos con el espacio de trabajo
Una vez que esté satisfecho con la configuración de asignación de datos de proveedores, guarde el documento de configuración del proveedor de piezas personalizado (File » Save) y realice una sincronización de los datos de la base de datos de origen con el servidor mediante el botón
, o configure una sincronización programada La sincronización inicial cargará los datos de proveedores asignados desde la base de datos de su empresa al espacio de trabajo de Altium, y los ciclos de sincronización posteriores actualizarán esos datos.
En el ejemplo que se muestra aquí, los datos de proveedores de las piezas de diodos Zener que se han sincronizado desde la base de datos de origen con el espacio de trabajo pasan a estar disponibles como datos Custom Parts Provider para esos componentes, además de los datos habituales de proveedores de piezas que ofrece el servicio en la nube Altium Parts Provider.
Esto puede comprobarse de inmediato en el panel Manufacturer Part Search al seleccionar la categoría Custom Parts Provider, que ofrecerá soluciones de suministro de componentes obtenidas a través del servicio Custom Parts Provider, tal como se han sincronizado desde la base de datos de proveedores de su organización.
Combinación de datos de proveedores
Si el nombre del fabricante y el número de pieza del fabricante de una pieza de la base de datos de proveedores que ha sincronizado coinciden con el nombre del fabricante y el número de pieza del fabricante de una pieza proporcionada por Altium Parts Provider, los datos de proveedores de su Custom Parts Provider configurado se combinan con los de Altium Parts Provider para presentar toda la información de proveedores de forma conjunta allí donde se muestran datos de proveedores (SPN) en la interfaz de usuario del software, incluidos el panel Manufacturer Part Search, ActiveBOM y cualquier lugar donde se añadan opciones de piezas.
Opciones de piezas a partir de datos de proveedores personalizados
Al añadir información de opciones de piezas a las entradas de componentes del panel Components (clic derecho, Operations » Create/Edit PCL), los datos de proveedores proporcionados por Custom Parts Provider aparecerán en la parte superior de la lista del cuadro de diálogo Add Part Choices, como se muestra aquí para la entrada del diodo Zener 1N4747A. La entrada seleccionada (resaltada) se añadirá como opción de pieza para el componente seleccionado en el panel Components.
Al igual que el servicio Altium Parts Provider, Custom Parts Provider también admite datos de proveedores para varios fabricantes y procedentes de varios proveedores; estos datos se obtienen de varias entradas independientes de la tabla de la base de datos de origen. Tenga en cuenta también que los datos del proveedor personalizado incluirán información sobre descuentos por volumen y niveles de existencias sincronizada desde la base de datos de origen.
Además de en el panel Components que se muestra aquí, las opciones de piezas de proveedores de componentes pueden asociarse a una referencia de componente en las siguientes interfaces de Altium Designer:
- El panel Explorer.
- Un documento ActiveBOM.
- El editor de componentes individuales.
- El editor de componentes por lotes.
Sincronización programada
Las configuraciones de sincronización de piezas guardadas se preparan para el procesamiento automatizado de datos desde la base de datos al espacio de trabajo mediante el cuadro de diálogo Auto Synchronization Schedule, que se abre con el botón
de la interfaz principal.
La sincronización programada, de acuerdo con el perfil de configuración actual, puede establecerse a una hora específica de cada día, a una hora determinada en varios días de la semana o al iniciar sesión en Windows. También puede desactivar la sincronización cuando no haya iniciado sesión. Al confirmar los ajustes con el botón
, la configuración se añadirá como tarea periódica en Windows Task Scheduler. Seleccione No automatic synchronization para eliminar una programación de sincronización existente.
La sincronización de los datos de componentes con la base de datos también se puede ejecutar manualmente desde la línea de comandos mediante la aplicación ComponentSync.Executor.exe, que se encuentra en la carpeta \System de la instalación del software. La sintaxis del comando es ComponentSync.Executor.exe [configuration file name]. En la imagen siguiente se ha ejecutado la configuración MyPrtSyncConfig de este ejemplo mediante la siguiente cadena de comandos:
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync








).


