Plantillas de componentes

De un vistazo

Las plantillas de componentes de un Workspace conectado ayudan a agilizar la creación de componentes en Altium Designer al proporcionar ajustes y parámetros reutilizables. Este artículo explica cómo organizar los elementos de plantilla de componentes, elegir esquemas de nomenclatura y ciclo de vida, y utilizar la edición directa para definir y guardar plantillas en el Workspace. También presenta controles para la visibilidad de los parámetros, los valores predeterminados, los campos obligatorios y las modificaciones que puede realizar el diseñador. Sigue leyendo para empezar a crear plantillas reutilizables que permitan definir componentes de forma más coherente.

- Aprende a configurar carpetas del Workspace y elementos de plantilla de componentes con esquemas de nomenclatura, revisión y ciclo de vida adecuados.
- Comprende cómo las plantillas controlan los parámetros de los componentes, incluidos los valores obligatorios y los valores predeterminados de solo lectura.
- Descubre cómo editar plantillas directamente y guardarlas de nuevo en tu Workspace como nuevas revisiones.
Profundiza con IA:

Para agilizar la creación de sus componentes, Altium Designer, junto con su Workspace conectado, permite crear y definir Component Templates (elementos de plantilla de componente) en ese Workspace. Del mismo modo que una plantilla de esquemático permite predefinir información en las hojas de esquemático que la utilizan como referencia, un componente de biblioteca del Workspace utiliza una plantilla de componente como referencia, que proporciona ajustes predefinidos para definir dicho componente.

En particular, las plantillas de componente se han desarrollado teniendo muy presente la información paramétrica, lo que permite definir, en un único lugar, un conjunto de parámetros que estarán disponibles para el componente que utilice la plantilla como referencia. A través de la plantilla, puede controlar cuáles de esos parámetros serán visibles, introducir valores predeterminados e incluso marcar como obligatorios los parámetros que sean necesarios. Al guardar el componente, se realizan comprobaciones de validación para garantizar el cumplimiento de estos requisitos.

Los valores predeterminados especificados para muchos de los ajustes de la plantilla pueden bloquearse como de solo lectura o habilitarse de forma selectiva para que el diseñador los modifique al definir un componente.

Una plantilla de componente también sirve como base para crear un componente genérico. Para obtener más información, consulte la página Creación de componentes genéricos.

El acceso a las plantillas de componente dependerá de la licencia del software. Para obtener más información, consulte el recuadro Note situado a la derecha de la página.

Estas plantillas de componente se crean directamente desde el Workspace. Una vez creada una plantilla de componente (y guardados sus datos en una revisión), puede reutilizarse para crear uno o varios componentes.

Tipo de carpeta

Al crear la carpeta en la que se almacenarán las plantillas de componente, puede especificar el tipo de carpeta. Esto no afecta al contenido de la carpeta: al publicar una plantilla de componente, siempre se generará el elemento de plantilla de componente correspondiente. Simplemente proporciona una «pista» visual sobre lo que se almacena en una carpeta y puede resultar útil al explorar un Workspace en busca de contenido específico. Para indicar que una carpeta se utilizará como contenedor de plantillas de componente, establezca su Folder Type en Component Templates al definir las propiedades de la carpeta en el cuadro de diálogo Editar carpeta.

Especificar el tipo de carpeta (su uso previsto) proporciona una indicación visual del contenido de esa carpeta al explorar el Workspace.
Especificar el tipo de carpeta (su uso previsto) proporciona una indicación visual del contenido de esa carpeta al explorar el Workspace.

Tipo de contenido

Al crear un elemento de plantilla de componente de destino en el que almacenar su plantilla de componente, asegúrese de que su Content Type esté establecido en Component Template en el cuadro de diálogo Crear nuevo elemento. Si está creando el elemento en una carpeta de tipo Component Templates, este tipo de contenido estará disponible en el menú contextual que aparece al hacer clic con el botón derecho para crear el elemento.

Creación de una plantilla de componente en una carpeta Component Templates: el Content Type correcto está disponible en el menú contextual.
Creación de una plantilla de componente en una carpeta Component Templates: el Content Type correcto está disponible en el menú contextual.

Guardar una plantilla de componente

Related page: Creación y edición de contenido

Hasta ahora, hemos analizado la compatibilidad del Workspace con las plantillas de componente en cuanto a los tipos de carpeta y contenido relacionados. Guardar una plantilla de componente ya definida en una revisión de un elemento de plantilla de componente puede realizarse de forma ágil.

Gracias a la función de edición directa del Workspace, puede editar y guardar una plantilla de componente en la revisión inicial de un elemento de plantilla de componente recién creado. La edición directa le libera de las limitaciones de mantener datos de origen independientes bajo control de versiones. Basta con editar un tipo de contenido compatible mediante un editor temporal que carga los datos de origen más recientes directamente desde el propio Workspace. Una vez finalizada la edición, la entidad se guarda (o se vuelve a guardar) en una revisión posterior planificada de su elemento principal y se cierra el editor temporal. No hay archivos en el disco duro, ni dudas sobre si está trabajando con los datos de origen correctos o más recientes, ni necesidad de mantener un software de control de versiones independiente. El Workspace se encarga de todo, con un alto grado de integridad y de una forma que agiliza considerablemente los cambios en sus datos.

Cuando crea un elemento de plantilla de componente, tiene la opción de editar y guardar una plantilla de componente en la revisión inicial de ese elemento después de crearlo. Para ello, active la opción Open for editing after creation, en la parte inferior del cuadro de diálogo Create New Item (que está activada de forma predeterminada). Se creará el elemento y se abrirá el editor temporal de plantillas de componentes, que mostrará un documento .CMPT como documento activo en la ventana principal de diseño. Este documento recibirá un nombre según el elemento y la revisión, con el formato: <Item><Revision>.CMPT (p. ej., CMPT-0001-1.CMPT).

 
 
 
 
 

Ejemplo de edición de la revisión inicial de una plantilla de componente directamente desde el espacio de trabajo: el editor temporal de plantillas de componentes proporciona el documento con el que definir la plantilla de componente.
Ejemplo de edición de la revisión inicial de una plantilla de componente directamente desde el espacio de trabajo: el editor temporal de plantillas de componentes proporciona el documento con el que definir la plantilla de componente.

Utilice el documento para definir la plantilla de componente según sea necesario. Para obtener más información sobre cómo hacerlo, consulte Definición de la plantilla.

Hay tres controles relevantes para la edición directa, disponibles en Quick Access Bar (en la parte superior izquierda de la ventana principal de la aplicación) o en la barra de herramientas Component Template Standard:

  • – Save Active Document. Utilice este botón para guardar localmente los cambios realizados en el documento. Esto le permite guardar los cambios actuales si desea volver más adelante para realizar otros cambios antes de guardarlos definitivamente en el espacio de trabajo.
  • / – Save to Server. Utilice este botón para guardar la plantilla de componente definida en el espacio de trabajo, almacenándola en la revisión inicial (planificada) del elemento de plantilla de componente de destino. Aparecerá el cuadro de diálogo Edit Revision, en el que podrá cambiar el nombre y la descripción, y añadir notas de publicación según sea necesario. El documento y el editor se cerrarán después de guardar. El documento que contiene la plantilla de componente de origen, *.CMPT, se almacenará en la revisión del elemento.

    También se proporciona un control Save to Server a la derecha de la entrada de la plantilla de componente, dentro del propio panel Projects.
  • / – Discard Local Changes. Utilice este botón si desea cancelar la edición y descartar los cambios realizados. El documento y el editor se cerrarán y no se publicará nada en el elemento de plantilla de componente de destino.

Estos controles también están disponibles como comandos: Save (atajo de teclado: Ctrl+S), Save to Server (atajo de teclado: Ctrl+Alt+S) y Discard Local Changes desde el menú principal File y desde el menú contextual de la entrada de la plantilla de componente en el panel Projects.

Los datos guardados en el espacio de trabajo consisten en la plantilla de componente de origen, definida en el archivo de plantilla de componente (<Item><Revision>.CMPT).

 
 
 
 
 

Ejemplo de una plantilla de componente definida y guardada en el espacio de trabajo.
Ejemplo de una plantilla de componente definida y guardada en el espacio de trabajo.

Herencia de una plantilla de componente

Esta función está disponible cuando la opción UI.ComponentTemplateInheritance está activada en el cuadro de diálogo Advanced Settings.

Puede utilizar una plantilla de componente del tipo de componente raíz si el subtipo no tiene una plantilla de componente vinculada. Al crear una jerarquía de tipos de componentes, los subtipos de componentes heredarán la plantilla de componente asignada al tipo de componente raíz o principal.

El editor CMPT (plantillas de componentes)

Para acceder al editor de plantillas de componentes en Altium Designer, debe estar instalada la extensión de software Component Template Editor. Esta extensión se instala con Altium Designer de forma predeterminada. Se puede instalar o eliminar manualmente.

Para obtener más información sobre la gestión de extensiones, consulte la página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definición de la plantilla

El editor de plantillas de componentes se divide esencialmente en dos áreas principales, que se ilustran en la siguiente imagen y se resumen a continuación.

 
 
 
 
 

El editor de plantillas de componentes puede dividirse, a grandes rasgos, en dos áreas clave.
El editor de plantillas de componentes puede dividirse, a grandes rasgos, en dos áreas clave.

  1. Upper Region – para definir las opciones a nivel de componente (ciclo de vida, nomenclatura y opciones de carpeta) de un componente que hace referencia a la plantilla.
  2. Lower Region – para definir los parámetros que se utilizarán para un componente que hace referencia a la plantilla.

Especificación de las opciones del componente

La mitad superior del editor está dedicada a definir los valores predeterminados de las siguientes propiedades del componente:

  • Lifecycle Definition – elija la definición del ciclo de vida que se aplicará a un componente creado con la plantilla. El campo desplegable muestra todas las definiciones establecidas para el espacio de trabajo y cuyo uso está permitido para un componente.

  • Revision Naming – elija el esquema de nomenclatura de revisiones que se aplicará a un componente creado con la plantilla. El campo desplegable muestra todos los esquemas definidos para el espacio de trabajo y cuyo uso está permitido para un componente.

    Si la opción para controlar el uso de definiciones de ciclo de vida y esquemas de nomenclatura de revisiones por tipo de contenido está habilitada para alguna definición o esquema, y el tipo de contenido Componente no está configurado para utilizar una definición o un esquema concreto, dicha definición o esquema no estará disponible en la lista desplegable correspondiente.

  • Component Naming – utilice este campo para definir un esquema de nomenclatura de elementos predeterminado para un componente creado con la plantilla, lo que garantiza un ID único para el componente resultante en el espacio de trabajo. La entrada de este campo se utilizará como plantilla para asignar automáticamente un nombre al componente (en su campo Id asociado, cuando se utilice el Editor de componentes en el modo Single Component Editing, o en el campo Item ID, cuando se utilice el Editor de componentes en el modo Batch Component Editing). El software asignará automáticamente el siguiente ID único disponible según ese esquema, tras examinar todo el espacio de trabajo y los identificadores del contenido existente. Se proporciona un esquema de nomenclatura de elementos predeterminado – CMP-{00000} –, pero, por supuesto, puede crear su propio esquema escribiéndolo en el campo y asegurándose de que la parte variable esté entre llaves (p. ej., CMP-001-{0000}).

  • Default Folder – permite especificar una carpeta predeterminada dentro del espacio de trabajo de destino en la que almacenar un componente guardado. Para ello, haga clic en el botón Choose para acceder al cuadro de diálogo Choose Folder (una variante del panel Explorador), desde el que puede buscar y seleccionar una carpeta existente en el espacio de trabajo o crear una nueva sobre la marcha.

No hay ningún campo para establecer el espacio de trabajo de destino, ya que este está fijado por el software para utilizar el mismo espacio de trabajo en el que reside la revisión de la plantilla de componente.

La opción Allow override de cada propiedad permite controlar de forma independiente si el usuario puede modificar esa propiedad (habilitada) o no (deshabilitada) al definir un componente en el Editor de componentes.

Cuando se utiliza la plantilla como referencia, las entradas especificadas en esta región se utilizan para rellenar previamente los campos correspondientes del Editor de componentes (cuando están disponibles):

  • Single Component Editing mode – los campos Id y Folder, en el área Advanced Settings de la región Component.
  • Batch Component Editing mode – en la pestaña Document Options del cuadro de diálogo Opciones del documento y, en consecuencia, los campos Item ID y FolderPath, en el área Component de la región de definiciones de componentes.

Cuando se utiliza la plantilla como referencia, las entradas se utilizan para rellenar previamente los campos correspondientes al editar un componente en el Editor de componentes en el modo Single Component Editing (izquierda) y en el modo Batch Component Editing (derecha).
Cuando se utiliza la plantilla como referencia, las entradas se utilizan para rellenar previamente los campos correspondientes al editar un componente en el Editor de componentes en el modo Single Component Editing (izquierda) y en el modo Batch Component Editing (derecha).

Definición de parámetros

La mitad inferior del editor está dedicada a definir y gestionar los parámetros que estarán disponibles para un componente que utilice la plantilla como referencia.

 
 
 
 
 

Ejemplos de parámetros definidos en una plantilla de componente.
Ejemplos de parámetros definidos en una plantilla de componente.

Parámetros de sistema predeterminados

Al crear una nueva plantilla de componente, se incluyen de forma predeterminada varios parámetros de sistema, como se ilustra en la siguiente imagen y se detalla a continuación.

 
 
 
 
 

Parámetros de sistema predeterminados incluidos en una plantilla de componente recién creada.
Parámetros de sistema predeterminados incluidos en una plantilla de componente recién creada.

  • ComponentType – este parámetro permite especificar el tipo de componente. Esto facilita las búsquedas específicas mediante la potente función de búsqueda del espacio de trabajo, que no solo permite buscar por tipo de componente, sino también realizar búsquedas más inteligentes gracias a la compatibilidad con parámetros de componentes con reconocimiento de unidades. Al explorar los componentes de su propio espacio de trabajo mediante el panel Componentes, la agrupación Categories de los componentes se deriva de los parámetros ComponentType asociados a cada componente. Haga clic en el campo Default Value asociado y, a continuación, en el botón para acceder al cuadro de diálogo Choose component type. Utilícelo para seleccionar el tipo de componente requerido y haga clic en OK; el tipo seleccionado se insertará como valor del parámetro ComponentType en la cuadrícula principal de parámetros.

    El cuadro de diálogo Choose component type refleja el conjunto de tipos de componentes definidos en la página Gestión de datos – Tipos de componentes del cuadro de diálogo Preferences. Haga clic en el botón , situado en la parte inferior del cuadro de diálogo Choose component type, para acceder a esta página de preferencias, desde la que puede adaptar esta lista a sus necesidades, ya sea añadiendo nuevos tipos y subtipos o editando y eliminando los existentes.

    Ejemplo de plantilla de componente con el parámetro de sistema ComponentType establecido en Diodes.
    Ejemplo de plantilla de componente con el parámetro de sistema ComponentType establecido en Diodes.

    El tipo de datos de este parámetro está establecido en ComponentType y no se puede modificar. Además, el parámetro ComponentType no se puede eliminar. Seleccione la celda y utilice la tecla Delete para borrar el valor.

  • SCHLIB y PCBLIB – estos dos parámetros permiten especificar los modelos de símbolo y de huella predeterminados, respectivamente. Haga clic en el campo Default Value asociado a cada parámetro y, a continuación, en el botón para acceder a un cuadro de diálogo en el que seleccionar el modelo requerido.

    Tenga en cuenta que está seleccionando el modelo, no una revisión específica de ese modelo. De este modo, un componente que utilice la plantilla siempre utilizará la última revisión del modelo seleccionado.

    Especifique modelos de símbolo y de huella como parte de su plantilla.
    Especifique modelos de símbolo y de huella como parte de su plantilla.

    Los tipos de datos de estos parámetros están establecidos en SCHLIB y PCBLIB, respectivamente, y no se pueden modificar. Además, los parámetros de modelo no se pueden eliminar. Seleccione la celda y utilice la tecla Delete para borrar el valor.

  • Name y Description – estos dos parámetros permiten definir el nombre y la descripción del componente, respectivamente. Introduzca las cadenas de texto requeridas en el campo Default Value asociado a cada parámetro.

    Especifique los parámetros Name y Description como parte de su plantilla.
    Especifique los parámetros Name y Description como parte de su plantilla.

    El tipo de datos de ambos parámetros está establecido en Text y no se puede modificar. Además, estos parámetros no se pueden eliminar.

Se permite copiar y pegar parámetros del sistema entre documentos de plantilla.

Seleccione uno o varios parámetros en una plantilla de componente y, a continuación, utilice el comando Copy del menú contextual de la selección (atajo: Ctrl+C). Los parámetros copiados se pueden pegar en otra plantilla de componente mediante el comando Paste del menú contextual (atajo: Ctrl+V).

 
 
 
 
 

SCHLIB, Name y Description son los parámetros del sistema que se seleccionaron y copiaron en la plantilla de componente Diodes.

Estos parámetros se pegaron en otra plantilla de componente (Zeners) y sus valores se aplicaron a los parámetros correspondientes. 

 

Adición de un nuevo parámetro de usuario

Para añadir un nuevo parámetro de usuario a la lista, haga clic en el botón (o utilice el comando Add del menú contextual): el parámetro se añade al final de la lista actual.

 
 
 
 
 

Ejemplo de adición de un nuevo parámetro de usuario a la plantilla.
Ejemplo de adición de un nuevo parámetro de usuario a la plantilla.

Cada parámetro se presenta en la cuadrícula con la siguiente información:

  • Name – utilice este campo para asignar un nombre al parámetro, normalmente un nombre significativo que indique su propósito. Al añadirlos, los parámetros reciben nombres predeterminados (Parameter, Parameter 1, Parameter 2, etc.).

  • Type – el tipo de parámetro. Inicialmente, esta entrada tiene el valor predeterminado Text, pero se admiten diversos tipos de datos con reconocimiento de unidades, así como el tipo PCBLIB, que facilita la definición de múltiples huellas, y HarnessWiring, que facilita la definición de un componente de cableado de arnés. También se admiten los tipos de parámetros definidos por los diccionarios disponibles; más información.

  • Visible – active esta opción (que es el estado predeterminado de un parámetro recién añadido) para que la opción Show correspondiente al parámetro esté activada al editar uno o varios componentes en el editor de componentes (configurado en el modo Batch Component Editing). Esto, a su vez, controla la visualización de la columna correspondiente a ese parámetro en la zona inferior del editor de componentes, donde se definen los propios componentes. Esta propiedad no tiene efecto al definir un componente mediante el modo Single Component Editing del editor.

  • Read Only – active esta opción para que el parámetro sea de solo lectura. Al editar un componente que haga referencia a la plantilla, el valor del parámetro no se podrá editar.

  • Required – active esta opción para que el parámetro sea obligatorio. Al editar un componente que haga referencia a la plantilla, el parámetro deberá tener un valor definido; de lo contrario, no se podrá guardar el componente. En el editor de componentes, este tipo de parámetro se distingue porque la celda del valor tiene un borde rojo (en el modo Batch Component Editing) o contiene el icono (en el modo Single Component Editing) cuando no se ha introducido ningún valor.

  • Default Value – utilice este campo para introducir un valor predeterminado para el parámetro.

    • Si el parámetro está marcado como obligatorio (opción Required activada) y también se ha configurado como de solo lectura (opción Read Only activada), MUST introducirse un valor predeterminado. De lo contrario, al editar un componente que haga referencia a la plantilla, se indicará que el parámetro no tiene ningún valor, pero no será posible resolverlo, ya que el parámetro no se puede editar por ser de solo lectura. No se podrá guardar una nueva revisión de esta plantilla de componente en el espacio de trabajo hasta que se resuelva este problema.

    • Al editar una revisión de un componente, cualquier parámetro existente definido por el usuario que tenga el mismo nombre que un parámetro de la plantilla de componente vinculada se sustituirá por la versión de la plantilla. Se conservará cualquier valor existente de ese parámetro (y no se sobrescribirá con el valor predeterminado de la plantilla).

  • Description – añada una descripción del parámetro, por ejemplo, una nota breve sobre lo que aporta. Si un parámetro de la plantilla tiene una descripción definida, la columna Description se mostrará en la zona Parameters del editor de componentes en su Single Component Editing, según corresponda.

La lista de parámetros también admite operaciones sencillas de copiar y pegar, lo que permite duplicar uno o varios parámetros de usuario existentes. Los parámetros pegados se añadirán al final de la lista.

Se admiten los atajos estándar para copiar (Ctrl+C) y pegar (Ctrl+V), y estos comandos también están disponibles en el menú contextual. Se pueden seleccionar varios parámetros de usuario para copiarlos y pegarlos mediante las técnicas estándar de Ctrl+Click y Shift+Click.
Para eliminar uno o varios parámetros de usuario de la lista, seleccione cada parámetro y, a continuación, haga clic en el botón o utilice el comando Remove del menú contextual.

Tipos de datos de parámetros de componentes con reconocimiento de unidades

El Editor de plantillas de componentes permite definir tipos de datos explícitos para los parámetros de componentes definidos en una plantilla de componente (*.CMPT). Además, estos tipos de datos reconocen las unidades y admiten diversos prefijos de unidades de uso habitual. Por lo tanto, puede introducir el valor de un parámetro utilizando distintos formatos, como 2.2k, 2k2, 4M o 2.5GHz, ya que el espacio de trabajo incorpora la lógica necesaria para reconocer el valor numérico de esas entradas.

Esta función de las plantillas de componentes facilita las búsquedas específicas mediante la función de búsqueda avanzada del servidor, que no solo permite buscar por tipo de componente, sino también realizar búsquedas más inteligentes mediante intervalos. Gracias a los parámetros de componentes con reconocimiento de unidades, puede definir rápidamente una búsqueda, por ejemplo, para encontrar todos los condensadores con una capacitancia de entre 47uF y 220uF.

Los parámetros con reconocimiento de unidades también se utilizan para el filtrado inteligente al buscar entre sus propios componentes mediante el panel Components.

Consulte las siguientes secciones desplegables para obtener más información sobre los parámetros con reconocimiento de unidades.

Tipos de datos de parámetros definidos por diccionarios

Los diccionarios son tipos de parámetros personalizados con varios valores definidos. Los administradores del espacio de trabajo gestionan los diccionarios en la página Settings – Vault – Dictionaries de la interfaz web del espacio de trabajo, a la que se puede acceder desde el editor de plantillas de componentes seleccionando la opción Add New Dictionary en la lista desplegable Type o haciendo clic en el control Manage Dictionaries situado en la parte superior derecha de la región Parameters.

  • También se puede acceder a la página Settings – Vault – Dictionaries desde la página Gestión de datos – Diccionarios del cuadro de diálogo Preferences, haciendo clic en el control Manage Dictionaries, y desde la página Gestión de datos – Servidores del cuadro de diálogo Preferences, haciendo clic en el control Properties del espacio de trabajo activo o de uno conocido y seleccionando la entrada Dictionaries del menú.

  • Cuando se selecciona un tipo definido por un diccionario para un parámetro, también se puede acceder a la página Settings – Vault – Dictionaries haciendo clic en la celda del parámetro en la columna Type y, a continuación, en el botón  ().

Acceda a la página de gestión de diccionarios en la interfaz web del espacio de trabajo desde el editor de plantillas de componentes.
Acceda a la página de gestión de diccionarios en la interfaz web del espacio de trabajo desde el editor de plantillas de componentes.

Obtenga más información sobre la gestión de diccionarios desde la interfaz web del espacio de trabajo (Espacio de trabajo de Altium 365, Espacio de trabajo de Enterprise Server).

Los diccionarios definidos están disponibles como tipos de parámetros en la lista desplegable Type.

Seleccione un tipo de parámetro definido por un diccionario en la lista desplegable Tipo.
Seleccione un tipo de parámetro definido por un diccionario en la lista desplegable Tipo.

Los valores definidos para el tipo seleccionado definido en el diccionario están disponibles en la lista desplegable Default Value. Seleccione el valor que desee utilizar como valor predeterminado del parámetro o seleccione <None>.

Seleccione un valor predeterminado entre los definidos para el tipo seleccionado definido en el diccionario.
Seleccione un valor predeterminado entre los definidos para el tipo seleccionado definido en el diccionario.

  • Los valores predeterminados se validan al guardar la plantilla de componentes en el espacio de trabajo. Si el valor predeterminado deja de ser coherente con el diccionario (por ejemplo, si el valor se ha eliminado del diccionario y, posteriormente, se ha abierto para editar la plantilla que utiliza ese valor), este valor predeterminado se resaltará en rojo en la columna Valor predeterminado y se mostrará un mensaje de error en el panel Messages al intentar guardar la plantilla de nuevo en el espacio de trabajo.

  • Si el valor de un parámetro de componente deja de ser coherente con el diccionario (por ejemplo, si el tipo de ese parámetro se ha cambiado de Texto a un tipo definido en el diccionario en la plantilla de componentes y el valor actual del componente no coincide con ningún valor del tipo seleccionado definido en el diccionario), este parámetro se resaltará al editar el componente en el editor de componentes: se mostrará un icono de signo de exclamación junto al valor incoherente del parámetro al editar el componente en el modo de edición de un solo componente del editor, y el valor del parámetro se resaltará en rojo al editar el componente en el modo de edición de componentes por lotes del editor. Asegúrese de que todos los parámetros del componente sean coherentes con los valores de la plantilla; de lo contrario, no podrá guardar el componente en la siguiente revisión.

  • Si se han modificado los diccionarios en la interfaz de navegador del espacio de trabajo conectado, debe desconectarse del espacio de trabajo y volver a conectarse para que estos cambios se reflejen en Altium Designer. Consulte la página Acceso a su espacio de trabajo para obtener más información.

Definición de múltiples huellas

El editor de plantillas de componentes también permite definir múltiples huellas de PCB como parte de una plantilla de componentes. Se puede especificar cualquier número de enlaces a modelos de huella, una función muy útil para quienes deseen crear componentes que hagan referencia a 3 huellas y cumplan los requisitos del IPC para distintos niveles de densidad: L (menor, o cobre mínimo), M (mayor, o cobre máximo) y N (nominal, o cobre intermedio).

Para añadir una definición de modelo de huella adicional a la plantilla, haga clic en para añadir un nuevo parámetro y, a continuación, elija la entrada PCBLIB en el menú desplegable asociado al campo Type.

Convierta un parámetro recién añadido en una definición de modelo de huella estableciendo su Type en PCBLIB.
Convierta un parámetro recién añadido en una definición de modelo de huella estableciendo su Type en PCBLIB.

El nombre del parámetro cambiará de Parameter a PCBLIB n, donde n es el siguiente número entero disponible para distinguir entre los distintos modelos de huella (por ejemplo, PCBLIB 1, PCBLIB 2, etc.). El modelo predeterminado será el asociado a la entrada PCBLIB. Cuando las huellas se incorporan al editor de componentes al definir un componente, el modelo de huella predeterminado se distingue por el icono situado en la esquina superior izquierda de la ventana de vista previa del modelo (en el modo Single Component Editing) y por la entrada PCBLIB (default) en la región Required Models/Parameters (en el modo Batch Component Editing).

Ejemplo de un componente definido en el editor de componentes (modo Single Component Editing) utilizando una plantilla de componentes referenciada. La plantilla tiene tres modelos de huella definidos, que se incorporan a la definición del componente. Observe que la entrada de modelo PCBLIB de la plantilla se utiliza como modelo de huella predeterminado (identificado por un icono en la esquina superior izquierda) al definir el componente. Pase el cursor sobre la imagen para ver cómo se define el mismo componente con el editor de componentes en el modo Batch Component Editing. En este caso, la huella predeterminada se denomina PCBLIB (default).
Ejemplo de un componente definido en el editor de componentes (modo Single Component Editing) utilizando una plantilla de componentes referenciada. La plantilla tiene tres modelos de huella definidos, que se incorporan a la definición del componente. Observe que la entrada de modelo PCBLIB de la plantilla se utiliza como modelo de huella predeterminado (identificado por un icono en la esquina superior izquierda) al definir el componente. Pase el cursor sobre la imagen para ver cómo se define el mismo componente con el editor de componentes en el modo Batch Component Editing. En este caso, la huella predeterminada se denomina PCBLIB (default).

Importación y exportación de plantillas de componentes

Se puede importar un archivo de plantilla de componentes existente (*.CMPT) o un archivo de biblioteca de componentes (*.CMPLIB) al editor de plantillas de componentes, y la plantilla de componentes que se está editando se puede exportar a un archivo de plantilla de componentes (*.CMPT). Utilice los comandos File » Import » Component Template, File » Import » Component Library y File » Export del menú principal del editor de componentes para seleccionar la acción deseada y el cuadro de diálogo estándar de Windows que se abre para ir a la ubicación deseada y seleccionar un archivo para importar o definir el nombre del archivo que se exportará.

Reutilización de una plantilla de componentes

El uso de una revisión de una plantilla de componentes —o, más concretamente, la referencia a una de ellas desde la revisión de un componente que se está editando— puede realizarse de las siguientes formas.

Un componente solo puede hacer referencia a una plantilla de componentes a la vez.

Al crear un nuevo componente

Al crear un nuevo componente mediante el comando File » New » Component de los menús principales, puede elegir la plantilla en el cuadro de diálogo Create new component.

Vinculación rápida de una plantilla de componentes desde una lista de todas las plantillas disponibles al crear un nuevo componente.
Vinculación rápida de una plantilla de componentes desde una lista de todas las plantillas disponibles al crear un nuevo componente.

Manualmente desde el editor de componentes

La reutilización de una revisión de una plantilla de componentes desde el editor de componentes depende del modo de funcionamiento del editor.

En el modo de edición de un solo componente

Al editar un único componente en este modo del editor de componentes, elija la plantilla de componentes que desee en el menú desplegable asociado al campo Template, que forma parte del grupo Advanced Settings, en la región Component del editor. Se enumeran por nombre todas las plantillas de componentes disponibles actualmente en el mismo espacio de trabajo en el que reside el componente, con sus últimas revisiones indicadas entre paréntesis. Elija la plantilla que desee para aplicarla.

Vinculación rápida de una plantilla de componentes desde un menú de todas las plantillas disponibles al editar la revisión de un componente con el editor de componentes en su modo Single Component Editing.
Vinculación rápida de una plantilla de componentes desde un menú de todas las plantillas disponibles al editar la revisión de un componente con el editor de componentes en su modo Single Component Editing.

En el modo de edición de componentes por lotes

Existen dos formas de vincular una revisión de una plantilla de componentes a la revisión del componente que se está editando:

  • Desde la pestaña Template del cuadro de diálogo Opciones del documento (Edit » Document Options). Haga clic en el botón Choose situado a la derecha del campo Item Revision. Esto permite acceder al cuadro de diálogo Choose Item (una variante del panel Explorador). Utilice este cuadro de diálogo para buscar y seleccionar la revisión de la plantilla de componentes que desee. Tras hacer clic en OK, se creará un enlace entre la revisión del componente y la revisión de destino de la plantilla de componentes. Este enlace se puede comprobar al volver a la pestaña Template del cuadro de diálogo Document Options.

    Vinculación manual de un componente a una revisión de una plantilla de componentes en el espacio de trabajo de destino.
    Vinculación manual de un componente a una revisión de una plantilla de componentes en el espacio de trabajo de destino.

    La plantilla de componentes utilizada se puede cambiar en cualquier momento: haga clic en Choose y seleccione una revisión de otra plantilla de componentes.
    El estado de la revisión del elemento de plantilla de componentes vinculado se refleja en la pestaña Template del cuadro de diálogo Document Options. Si hay disponible una revisión más reciente del elemento vinculado, haga clic en el botón para utilizar esa última revisión.
  • Desde el menú Add asociado a la región Required Models/Parameters del Editor de componentes. El submenú Templates enumera por nombre todas las plantillas de componentes disponibles actualmente en el mismo espacio de trabajo en el que reside el propio componente, con sus últimas revisiones indicadas entre paréntesis. Haga clic en una entrada para crear un vínculo a la última revisión de esa plantilla de componentes. De nuevo, puede comprobar el vínculo en la pestaña Templates del cuadro de diálogo Document Options.

    Vinculación rápida de una plantilla de componentes desde un menú con todas las plantillas disponibles.
    Vinculación rápida de una plantilla de componentes desde un menú con todas las plantillas disponibles.

Heredada de la carpeta de componentes del espacio de trabajo

Puede especificar una plantilla de componentes para que se utilice automáticamente en todos los componentes (y sus revisiones) almacenados en una carpeta de componentes del espacio de trabajo.

Solo se puede definir una plantilla de componentes predeterminada para una carpeta de tipo Components.

Especifique la plantilla que necesite mediante el campo Component Template al definir las propiedades de la carpeta en el cuadro de diálogo Editar carpeta. La lista desplegable asociada al campo enumera por nombre todas las plantillas de componentes disponibles actualmente en el mismo espacio de trabajo en el que reside la propia carpeta de componentes, con sus últimas revisiones indicadas entre paréntesis. Seleccione una entrada para crear un vínculo a la última revisión de esa plantilla de componentes para cada componente que se cree posteriormente en esa carpeta.

Especifique una plantilla de componentes predeterminada que se aplicará a todos los componentes creados en la carpeta de componentes principal.
Especifique una plantilla de componentes predeterminada que se aplicará a todos los componentes creados en la carpeta de componentes principal.

Para no utilizar esta función, deje o establezca el campo Component Template en None.

Si se selecciona una plantilla de componentes en el nivel de carpeta, se utilizará esa misma plantilla de forma predeterminada al crear componentes en las subcarpetas que contiene. Esto permite que todos los componentes de las subcarpetas hereden rápidamente la plantilla.

Al guardar una revisión de un componente en el espacio de trabajo, se fija la revisión específica de la plantilla de componentes utilizada, lo que crea un vínculo persistente a esa revisión, a menos que se cambie manualmente.

Efectos del uso de una plantilla de componentes en los modelos y parámetros del componente

Al editar una revisión de un componente y vincular o hacer referencia a una revisión de una plantilla de componentes, ocurre lo siguiente en el Editor de componentes con respecto a los modelos y parámetros:

  • Los modelos definidos en la plantilla referenciada se añaden a la región Models (modo Single Component Editing) y a la región Model Links (modo Batch Component Editing).
  • Se conservará cualquier modelo referenciado existente y el componente seguirá utilizándolo, a menos que se cambie manualmente de forma intencionada.
  • Los parámetros definidos en la plantilla referenciada se añaden a la región Parameters (modo Single Component Editing) y a la región Required Models/Parameters (modo Batch Component Editing).

    Ejemplo de parámetros tras vincular una revisión de una plantilla de componentes al utilizar el Editor de componentes en modo Single Component Editing (izquierda) y en modo Batch Component Editing (derecha).
    Ejemplo de parámetros tras vincular una revisión de una plantilla de componentes al utilizar el Editor de componentes en modo Single Component Editing (izquierda) y en modo Batch Component Editing (derecha).

    Todos los parámetros procedentes de la plantilla de componentes referenciada se distinguen mediante el icono (modo Single Component Editing) y el icono (modo Batch Component Editing). Además, solo en el modo de edición de componentes por lotes, la opción Show de cada parámetro basado en la plantilla adopta el estado de la opción Visible correspondiente en la plantilla.
    Los parámetros basados en la plantilla no se pueden eliminar.
    Puede añadir parámetros de usuario adicionales según sea necesario.
  • Solo en el modo Batch Component Editing, los parámetros basados en la plantilla que estén configurados para mostrarse se agrupan en el área de definiciones de componentes del editor, con Template Parameters como texto de encabezado.

    Aspecto de los parámetros de ejemplo basados en la plantilla en el área donde se definen los propios componentes, al utilizar el Editor de componentes en su modo Batch Component Editing.
    Aspecto de los parámetros de ejemplo basados en la plantilla en el área donde se definen los propios componentes, al utilizar el Editor de componentes en su modo Batch Component Editing.

  • Los campos de valor de los parámetros basados en la plantilla que se hayan marcado como de solo lectura no se podrán editar. Para los demás parámetros basados en la plantilla que no se hayan marcado como de solo lectura, puede cambiar los valores según sea necesario.

    Con el Editor de componentes en modo Single Component Editing, un parámetro de plantilla de solo lectura se distingue en la región Parameters mediante el icono .
  • Si un parámetro basado en la plantilla se ha marcado como obligatorio, pero no se le ha asignado un valor en la plantilla, su campo de valor aparecerá con un borde rojo (en el modo Batch Component Editing) o con el icono (en el modo Single Component Editing), lo que indica que es necesario introducir un valor para ese parámetro. No podrá guardar un componente en el espacio de trabajo hasta que se definan los valores de todos los parámetros obligatorios.

    Con el Editor de componentes en modo Single Component Editing, un parámetro de plantilla obligatorio se distingue en la región Parameters mediante el icono .

Volver a guardar una plantilla de componentes

En cualquier momento, puede volver a cualquier revisión de una plantilla de componentes en el espacio de trabajo y editarla directamente. Haga clic con el botón derecho en la revisión y seleccione el comando Edit en el menú contextual. Se abrirá de nuevo el editor temporal con la plantilla contenida en la revisión abierta para su edición. Realice los cambios necesarios y, a continuación, guarde la plantilla de componentes en la siguiente revisión del elemento.

Al hacer clic con el botón derecho en la entrada de nivel superior de la propia plantilla de componentes, se editará la última revisión de esa plantilla.

Acceso al comando para iniciar la edición directa de una revisión existente de una plantilla de componentes.
Acceso al comando para iniciar la edición directa de una revisión existente de una plantilla de componentes.

Descarga de datos guardados

Para descargar los datos almacenados en una revisión de una plantilla de componentes, haga clic con el botón derecho en esa revisión (en el panel Explorer) y seleccione el comando Operations » Download en el menú contextual. El archivo de la plantilla de componentes se descargará en una subcarpeta dentro del directorio seleccionado, cuyo nombre será el ID de revisión del elemento. El archivo se encuentra en la carpeta Released que contiene.

Acceda al comando Download desde la entrada de nivel superior de la propia plantilla de componentes para descargar el archivo de plantilla de componentes almacenado en la última revisión de esa plantilla.
Haga clic en el botón Explore del cuadro de diálogo Download from Server para abrir rápidamente la carpeta de descarga.

Eliminación reversible

Cuando está conectado a un espacio de trabajo, dispone de una función flexible para eliminar una plantilla de componentes directamente desde Altium Designer, a través del panel Explorador. Haga clic con el botón derecho en la entrada de la plantilla de componentes en el panel y seleccione el comando Delete Item en el menú contextual. Aparecerá el cuadro de diálogo Delete Items, donde podrá confirmar la eliminación. En realidad, la acción es una «eliminación reversible», mediante la cual la plantilla de componentes se trasladará al área Trash del espacio de trabajo. Trash es, en esencia, una papelera de reciclaje a la que se puede trasladar cualquier contenido del espacio de trabajo mediante una acción de eliminación reversible. Está aislada del resto del espacio de trabajo.

La función de eliminación reversible permite eliminar una plantilla de componentes que se esté utilizando actualmente.
Se pueden eliminar varias plantillas de componentes en una sola acción. Seleccione todas las plantillas de componentes que desee mediante los controles habituales de selección múltiple (Shift+Click, Ctrl+Click); a continuación, haga clic con el botón derecho y seleccione el comando Delete Items en el menú contextual.

Eliminación reversible de una plantilla de componentes. La plantilla se trasladará al área Trash del espacio de trabajo.
Eliminación reversible de una plantilla de componentes. La plantilla se trasladará al área Trash del espacio de trabajo.

Para proceder con la eliminación, haga clic en el botón . El elemento se eliminará y un cuadro de diálogo Deletion Summary confirmará que la eliminación se ha realizado correctamente. Si se produce algún problema durante la eliminación, se le notificará.

Todo el contenido eliminado de esta manera se puede encontrar en la página Trash de la interfaz web del espacio de trabajo. Tenga en cuenta que solo puede ver el contenido que usted mismo haya eliminado de forma lógica. Los administradores podrán ver todo el contenido de la página Trash, es decir, todo el contenido que se haya eliminado de forma lógica.

Aspectos que debe tener en cuenta en relación con una plantilla de componentes eliminada de forma lógica:

  • La plantilla de componentes no estará disponible en su software de diseño ni en la interfaz web.
  • En cualquier lugar donde se estuviera utilizando la plantilla de componentes, se indicará que esta se ha eliminado.
  • Una plantilla de componentes se puede restaurar o eliminar permanentemente desde la página Trash, siempre que tenga permisos de edición. La eliminación permanente solo es posible si ningún elemento principal la está utilizando.
Tenga en cuenta que, si ha eliminado de forma lógica una plantilla de componentes, trasladándola a Trash, puede volver a crear una nueva plantilla de componentes con el mismo nombre. Si posteriormente restaura la plantilla de componentes original y el nombre original ya está en uso, se añadirá un sufijo numérico entero para que su nombre siga siendo único dentro del espacio de trabajo.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents