Plantillas de componentes

Para agilizar la creación de componentes, Altium Designer, junto con su espacio de trabajo conectado, permite crear y definir Component Templates (elementos de plantilla de componentes) en ese espacio de trabajo. Al igual que una plantilla de esquemas puede utilizarse para predefinir información en las hojas de esquemas que hacen referencia a ella, un componente de la biblioteca del espacio de trabajo hace referencia a una plantilla de componentes, que proporciona ajustes predefinidos para definir dicho componente.

En particular, las plantillas de componentes se han desarrollado teniendo muy en cuenta la información paramétrica, lo que permite definir, en un único lugar, un conjunto de parámetros que estarán disponibles para el componente que haga referencia a la plantilla. Mediante la plantilla, puede controlar cuáles de esos parámetros serán visibles, introducir valores predeterminados e incluso marcar como obligatorios los parámetros requeridos. Al guardar el componente, se realizan comprobaciones de validación para garantizar el cumplimiento de estos requisitos.

Los valores predeterminados especificados para muchos de los ajustes de la plantilla pueden bloquearse para que sean de solo lectura o habilitarse de forma selectiva para que el diseñador pueda modificarlos al definir un componente.

Una plantilla de componentes también es la base para crear un componente genérico. Para obtener más información, consulte la página Creación de componentes genéricos.

El acceso a las plantillas de componentes dependerá de la licencia del software. Para obtener más información, consulte el recuadro Note situado en el lado derecho de la página.

Estas plantillas de componentes se crean directamente desde el espacio de trabajo. Una vez creada una plantilla de componentes (y guardados los datos en una de sus revisiones), puede reutilizarse para crear uno o varios componentes.

Tipo de carpeta

Al crear la carpeta en la que se almacenarán las plantillas de componentes, puede especificar su tipo. Esto no afecta al contenido de la carpeta: publicar una plantilla de componentes siempre dará como resultado el correspondiente elemento de plantilla de componentes. Simplemente proporciona una indicación visual de lo que se almacena en la carpeta y puede resultar útil al explorar un espacio de trabajo en busca de contenido específico. Para indicar que una carpeta se utilizará como contenedor de plantillas de componentes, establezca su Folder Type como Component Templates al definir las propiedades de la carpeta en el cuadro de diálogo Editar carpeta.

Especificar el tipo de carpeta —su uso previsto— proporciona una indicación visual de su contenido al explorar el espacio de trabajo.
Especificar el tipo de carpeta —su uso previsto— proporciona una indicación visual de su contenido al explorar el espacio de trabajo.

Tipo de contenido

Al crear un elemento de plantilla de componentes de destino en el que almacenar su plantilla de componentes, asegúrese de que su Content Type esté establecido en Component Template en el cuadro de diálogo Crear nuevo elemento. Si está creando el elemento en una carpeta de tipo Component Templates, este tipo de contenido estará disponible en el menú contextual que aparece al hacer clic con el botón derecho para crear el elemento.

Creación de una plantilla de componentes en una carpeta Component Templates: el Content Type correcto está disponible en el menú contextual.
Creación de una plantilla de componentes en una carpeta Component Templates: el Content Type correcto está disponible en el menú contextual.

Guardar una plantilla de componentes

Related page: Creación y edición de contenido

Hasta ahora, hemos tratado la compatibilidad del espacio de trabajo con las plantillas de componentes en lo que respecta a los tipos de carpeta y de contenido relacionados. Una plantilla de componentes ya definida puede guardarse de forma ágil en una revisión de un elemento de plantilla de componentes.

Una plantilla de componentes puede editarse y guardarse en la revisión inicial de un elemento de plantilla de componentes recién creado gracias a la función de edición directa del espacio de trabajo. La edición directa le libera de las limitaciones de mantener datos de origen separados bajo control de versiones. Puede editar un tipo de contenido compatible utilizando un editor temporal que carga los datos de origen más recientes directamente desde el propio espacio de trabajo. Una vez finalizada la edición, la entidad se guarda (o vuelve a guardarse) en una revisión planificada posterior de su elemento principal y se cierra el editor temporal. No hay archivos en el disco duro, ni dudas sobre si está trabajando con los datos de origen correctos o más recientes, ni necesidad de mantener un software de control de versiones independiente. El espacio de trabajo se encarga de todo, con un alto grado de integridad y de una forma que agiliza considerablemente los cambios en sus datos.

Al crear un elemento de plantilla de componentes, tiene la opción de editar y guardar una plantilla de componentes en la revisión inicial de ese elemento, después de crearlo. Para ello, habilite la opción Open for editing after creation, en la parte inferior del cuadro de diálogo Crear nuevo elemento (que está habilitada de forma predeterminada). Se creará el elemento y se abrirá el editor temporal de plantillas de componentes, que mostrará un documento .CMPT como documento activo en la ventana principal de diseño. Este documento recibirá un nombre según el elemento y su revisión, con el formato: <Item><Revision>.CMPT (p. ej., CMPT-0001-1.CMPT).

 
 
 
 
 

Ejemplo de edición de la revisión inicial de una plantilla de componentes directamente desde el espacio de trabajo: el editor temporal de plantillas de componentes proporciona el documento con el que puede definir su plantilla de componentes.
Ejemplo de edición de la revisión inicial de una plantilla de componentes directamente desde el espacio de trabajo: el editor temporal de plantillas de componentes proporciona el documento con el que puede definir su plantilla de componentes.

Utilice el documento para definir la plantilla de componentes según sus necesidades. Para obtener más información sobre cómo hacerlo, consulte Definición de la plantilla.

Hay tres controles relevantes para la edición directa, fácilmente accesibles desde Quick Access Bar (en la parte superior izquierda de la ventana principal de la aplicación) o desde la barra de herramientas Component Template Standard:

  • – Save Active Document. Utilice este botón para guardar localmente los cambios realizados en el documento. Esto le permite guardar los cambios actuales si desea volver más adelante para realizar otros cambios antes de guardarlos definitivamente en el espacio de trabajo.
  • / – Save to Server. Utilice este botón para guardar la plantilla de componentes definida en el espacio de trabajo, almacenándola en la revisión inicial (planificada) del elemento de plantilla de componentes de destino. Aparecerá el cuadro de diálogo Edit Revision, en el que puede cambiar el nombre y la descripción, y añadir notas de publicación según sea necesario. El documento y el editor se cerrarán después de guardar. El documento que contiene la plantilla de componentes de origen, *.CMPT, se almacenará en la revisión del elemento.

    También se proporciona un control Save to Server a la derecha de la entrada de la plantilla de componentes, dentro del propio panel Proyectos .
  • / – Discard Local Changes. Utilice este botón si desea cancelar la edición y descartar los cambios realizados. El documento y el editor se cerrarán y no se publicará nada en el elemento de plantilla de componentes de destino.

Estos controles también están disponibles como comandos: Save (atajo de teclado: Ctrl+S), Save to Server (atajo de teclado: Ctrl+Alt+S) y Discard Local Changes , desde el menú principal File y desde el menú contextual de la entrada de la plantilla de componentes en el panel Projects.

Los datos guardados en el espacio de trabajo consisten en la plantilla de componentes de origen, definida en el archivo de plantilla de componentes (<Item><Revision>.CMPT).

 
 
 
 
 

Ejemplo de una plantilla de componentes definida y guardada en el espacio de trabajo.
Ejemplo de una plantilla de componentes definida y guardada en el espacio de trabajo.

Herencia de una plantilla de componentes

Esta función está disponible cuando la opción UI.ComponentTemplateInheritance está habilitada en el cuadro de diálogo Configuración avanzada.

Puede utilizar una plantilla de componentes del tipo de componente raíz si el subtipo no tiene una plantilla de componentes vinculada. Al crear una jerarquía de tipos de componentes, los subtipos de componentes heredarán la plantilla de componentes asignada al tipo de componente raíz o padre.

El editor CMPT (plantilla de componentes)

Para acceder al editor de plantillas de componentes en Altium Designer, debe estar instalada la extensión de software Component Template Editor. Esta extensión se instala con Altium Designer de forma predeterminada. Se puede instalar o eliminar manualmente.

Para obtener más información sobre la gestión de extensiones, consulte la página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definición de la plantilla

El editor de plantillas de componentes se divide esencialmente en dos áreas principales, que se ilustran en la siguiente imagen y se resumen a continuación.

 
 
 
 
 

El editor de plantillas de componentes se puede dividir, a grandes rasgos, en dos áreas clave.
El editor de plantillas de componentes se puede dividir, a grandes rasgos, en dos áreas clave.

  1. Upper Region – para definir las opciones a nivel de componente (opciones de ciclo de vida, nomenclatura y carpeta) de un componente que utiliza la plantilla.
  2. Lower Region – para definir los parámetros que se utilizarán para un componente que utiliza la plantilla.

Especificación de las opciones del componente

La mitad superior del editor está dedicada a definir los valores predeterminados de las siguientes propiedades del componente:

  • Lifecycle Definition – elija la definición de ciclo de vida que se aplicará a un componente creado con la plantilla. El campo desplegable muestra todas las definiciones del espacio de trabajo cuyo uso está permitido para un componente.

  • Revision Naming – elija el esquema de nomenclatura de revisiones que se aplicará a un componente creado con la plantilla. El campo desplegable muestra todos los esquemas definidos para el espacio de trabajo cuyo uso está permitido para un componente.

    Si la opción para controlar el uso de definiciones de ciclo de vida y esquemas de nomenclatura de revisiones por tipo de contenido está habilitada para alguna definición o esquema, y el tipo de contenido Componente no está configurado para utilizar una definición o un esquema en particular, dicha definición o esquema no estará disponible en la lista desplegable correspondiente.

  • Component Naming – utilice este campo para definir un esquema de nomenclatura de elementos predeterminado para los componentes creados con la plantilla, lo que garantiza un ID único para el componente resultante en el espacio de trabajo. La entrada de este campo se utilizará como plantilla para asignar automáticamente un nombre al componente (en su campo Id asociado, cuando se utilice el editor de componentes en modo Single Component Editing, o en el campo Item ID, cuando se utilice el editor de componentes en modo Batch Component Editing). El software asignará automáticamente el siguiente ID único disponible según ese esquema, tras examinar todo el espacio de trabajo y los identificadores del contenido existente. Se proporciona un esquema de nomenclatura de elementos predeterminado, CMP-{00000}, pero, por supuesto, puede crear su propio esquema escribiéndolo en el campo y asegurándose de que la parte variable esté entre llaves (p. ej., CMP-001-{0000}).

  • Default Folder – para especificar una carpeta predeterminada dentro del espacio de trabajo de destino en la que almacenar un componente guardado. Para ello, haga clic en el botón Choose para acceder al cuadro de diálogo Choose Folder (una variante del panel Explorador), desde el que puede buscar y seleccionar una carpeta existente en el espacio de trabajo o crear una nueva sobre la marcha.

No hay ningún campo para establecer el espacio de trabajo de destino, ya que este se fija para utilizar el mismo espacio de trabajo en el que reside la revisión de la plantilla de componentes.

La opción Allow override de cada propiedad permite controlar de forma independiente si el usuario puede modificar esa propiedad (habilitada) o no (deshabilitada) al definir un componente en el editor de componentes.

Cuando se utiliza la plantilla como referencia, las entradas especificadas en esta sección se utilizan para rellenar previamente los campos correspondientes del editor de componentes (cuando estén disponibles):

  • Single Component Editing mode – los campos Id y Folder, en el área Advanced Settings de la sección Component.
  • Batch Component Editing mode – en la pestaña Document Options del cuadro de diálogo Opciones del documento y, por consiguiente, en los campos Item ID y FolderPath, en el área Component de la sección de definiciones de componentes.

Cuando se utiliza la plantilla como referencia, las entradas se utilizan para rellenar previamente los campos correspondientes al editar un componente en el editor de componentes en modo Single Component Editing (izquierda) y en modo Batch Component Editing (derecha).
Cuando se utiliza la plantilla como referencia, las entradas se utilizan para rellenar previamente los campos correspondientes al editar un componente en el editor de componentes en modo Single Component Editing (izquierda) y en modo Batch Component Editing (derecha).

Definición de parámetros

La mitad inferior del editor está dedicada a definir y gestionar los parámetros que estarán disponibles para los componentes que utilicen la plantilla como referencia.

 
 
 
 
 

Ejemplo de parámetros definidos en una plantilla de componentes.
Ejemplo de parámetros definidos en una plantilla de componentes.

Parámetros de sistema predeterminados

Al crear una nueva plantilla de componentes, se incluyen de forma predeterminada varios parámetros de sistema, como se muestra en la siguiente imagen y se detalla a continuación.

 
 
 
 
 

Parámetros de sistema predeterminados incluidos en una plantilla de componentes recién creada.
Parámetros de sistema predeterminados incluidos en una plantilla de componentes recién creada.

  • ComponentType – este parámetro permite especificar el tipo de componente. Esto facilita las búsquedas específicas mediante la potente función de búsqueda del espacio de trabajo, que no solo permite buscar por tipo de componente, sino también realizar búsquedas más inteligentes gracias a la compatibilidad con parámetros de componentes que reconocen las unidades. Al explorar los componentes de su propio espacio de trabajo mediante el panel Componentes, la agrupación Categories de los componentes se obtiene a partir de los parámetros ComponentType asociados a cada componente. Haga clic en el campo Default Value asociado y, a continuación, en el botón para acceder al cuadro de diálogo Choose component type. Utilícelo para seleccionar el tipo de componente necesario y haga clic en OK; el tipo elegido se insertará como valor del parámetro ComponentType en la tabla principal de parámetros.

    El cuadro de diálogo Choose component type refleja el conjunto de tipos de componentes definidos en la página Gestión de datos – Tipos de componentes del cuadro de diálogo Preferences. Haga clic en el botón situado en la parte inferior del cuadro de diálogo Choose component type para acceder a esta página de preferencias, desde la que puede adaptar la lista a sus necesidades, ya sea añadiendo nuevos tipos y subtipos o editando y eliminando tipos existentes.

    Ejemplo de plantilla de componentes con el parámetro de sistema ComponentType establecido en Diodes.
    Ejemplo de plantilla de componentes con el parámetro de sistema ComponentType establecido en Diodes.

     
     
     
     
     

    El tipo de datos de este parámetro está establecido en ComponentType y no se puede modificar. Además, el parámetro ComponentType no se puede copiar ni eliminar. Seleccione la celda y utilice la tecla Delete para borrar el valor.

  • SCHLIB y PCBLIB – estos dos parámetros permiten especificar los modelos predeterminados de símbolo y huella, respectivamente. Haga clic en el campo Default Value asociado a cada parámetro y, a continuación, haga clic en el botón para acceder a un cuadro de diálogo en el que podrá elegir el modelo requerido.

    Tenga en cuenta que está eligiendo el modelo, y no una revisión específica de ese modelo. De este modo, un componente que utilice la plantilla siempre usará la revisión más reciente del modelo elegido.

    Especifique modelos de símbolo y huella como parte de su plantilla.
    Especifique modelos de símbolo y huella como parte de su plantilla.

     
     
     
     
     

    Los tipos de datos de estos parámetros están establecidos en SCHLIB y PCBLIB, respectivamente, y no se pueden modificar. Además, los parámetros de modelo no se pueden copiar ni eliminar. Seleccione la celda y utilice la tecla Delete para borrar el valor.

  • Name y Description – estos dos parámetros permiten definir el nombre y la descripción del componente, respectivamente. Introduzca las cadenas de texto requeridas en el campo Default Value asociado a cada parámetro.

    Especifique los parámetros Name y Description como parte de su plantilla.
    Especifique los parámetros Name y Description como parte de su plantilla.

     
     
     
     
     

    El tipo de datos de ambos parámetros está establecido en Text y no se puede modificar. Además, estos parámetros no se pueden copiar ni eliminar.

Adición de un nuevo parámetro de usuario

Para añadir un nuevo parámetro de usuario a la lista, haga clic en el botón (o utilice el comando Add del menú contextual del botón derecho); el parámetro se añade al final de la lista actual.

 
 
 
 
 

Ejemplo de adición de un nuevo parámetro de usuario a la plantilla.
Ejemplo de adición de un nuevo parámetro de usuario a la plantilla.

Cada parámetro se presenta en la tabla con la siguiente información:

  • Name – utilice este campo para asignar un nombre al parámetro, normalmente un nombre significativo que indique su propósito. Al añadirlos inicialmente, los parámetros recibirán nombres predeterminados (Parameter, Parameter 1, Parameter 2, etc.).

  • Type – el tipo de parámetro. Inicialmente, esta entrada tendrá el valor predeterminado Text, pero se admite una variedad de tipos de datos compatibles con unidades, así como el tipo PCBLIB, que facilita la definición de múltiples huellas, y HarnessWiring, que facilita la definición de un componente de cableado de arnés. También se admiten los tipos de parámetros definidos por los diccionarios disponibles – más información.

  • Visible – active esta opción (que es el estado predeterminado de un parámetro recién añadido) para que la opción Show correspondiente al parámetro esté activada al editar uno o más componentes en el Editor de componentes (configurado en modo Batch Component Editing). Esto, a su vez, controla la visualización de la columna correspondiente a ese parámetro en la zona inferior del Editor de componentes, donde se definen los propios componentes. Esta propiedad no tiene efecto al definir un componente mediante el modo Single Component Editing del editor.

  • Read Only – active esta opción para que el parámetro sea de solo lectura. Al editar un componente que haga referencia a la plantilla, el valor del parámetro no se podrá editar.

  • Required – active esta opción para que el parámetro sea un «parámetro obligatorio». Al editar un componente que haga referencia a la plantilla, el parámetro deberá tener un valor definido; de lo contrario, no será posible guardar el componente. En el Editor de componentes, cuando no se ha introducido ningún valor, este tipo de parámetro se distingue porque la celda del valor tiene un borde rojo (en modo Batch Component Editing) o contiene el icono (en modo Single Component Editing).

  • Default Value – utilice este campo para introducir un valor predeterminado para el parámetro.

    • Si el parámetro está marcado como obligatorio (opción Required activada) y también se ha configurado como de solo lectura (opción Read Only activada), entonces MUST introducirse un valor predeterminado. De lo contrario, al editar un componente que haga referencia a la plantilla, se indicará que el parámetro no tiene un valor, pero esto no podrá resolverse porque el parámetro no se puede editar al ser de solo lectura. No se podrá guardar una nueva revisión de esta plantilla de componente en el espacio de trabajo hasta que se resuelva este problema.

    • Al editar una revisión de un componente, un parámetro existente definido por el usuario que tenga el mismo nombre que un parámetro de la plantilla de componente vinculada se sustituirá por la versión de la plantilla. Se conservará cualquier valor existente de ese parámetro (y no se sobrescribirá con el valor predeterminado de la plantilla).

  • Description – añada una descripción del parámetro, por ejemplo, una nota concisa sobre lo que aporta. Si un parámetro de la plantilla tiene una descripción definida, la columna Description se mostrará en la zona Parameters del Editor de componentes en su Single Component Editing, según corresponda.

La lista de parámetros también admite operaciones sencillas de copiar y pegar, lo que le permite duplicar uno o varios parámetros de usuario existentes. Los parámetros pegados se añadirán al final de la lista.

Se admiten los atajos estándar de copiar (Ctrl+C) y pegar (Ctrl+V), y estos comandos también están disponibles en el menú contextual. Se pueden seleccionar varios parámetros de usuario para las operaciones de copiar y pegar mediante las técnicas estándar de Ctrl+Click y Shift+Click.
Para eliminar uno o varios parámetros de usuario de la lista, seleccione cada parámetro y, a continuación, haga clic en el botón o utilice el comando Remove del menú contextual.

Tipos de datos con reconocimiento de unidades para parámetros de componentes

El Editor de plantillas de componentes permite definir tipos de datos explícitos para los parámetros de componentes definidos en una plantilla de componentes (*.CMPT). Además, estos tipos de datos reconocen las unidades y admiten diversos prefijos de unidades habituales. Por tanto, puede introducir el valor de un parámetro en distintos formatos, como 2.2k, 2k2, 4M o 2.5GHz, y el espacio de trabajo cuenta con la inteligencia necesaria para reconocer el valor numérico de esas entradas.

Esta función de las plantillas de componentes facilita las búsquedas específicas mediante la función de búsqueda avanzada del servidor, que no solo permite buscar por tipo de componente, sino también realizar búsquedas más inteligentes mediante intervalos. Gracias a los parámetros de componentes con reconocimiento de unidades, puede definir rápidamente una búsqueda, por ejemplo, para encontrar todos los condensadores con una capacitancia entre 47uF y 220uF.

Los parámetros con reconocimiento de unidades también se utilizan para el filtrado inteligente al buscar entre sus propios componentes mediante el panel Componentes.

Utilice las siguientes secciones desplegables para obtener más información sobre los parámetros con reconocimiento de unidades.

Tipos de datos de parámetros definidos mediante diccionarios

Los diccionarios son tipos de parámetros personalizados con varios valores definidos. Los administradores del espacio de trabajo gestionan los diccionarios en la página Settings – Vault – Dictionaries de la interfaz web del espacio de trabajo, a la que se puede acceder desde el editor de plantillas de componentes seleccionando la opción Add New Dictionary del menú desplegable Type o haciendo clic en el control Manage Dictionaries situado en la esquina superior derecha de la región Parameters.

  • También se puede acceder a la página Settings – Vault – Dictionaries desde la página Gestión de datos – Diccionarios del cuadro de diálogo Preferences, haciendo clic en el control Manage Dictionaries, y desde la página Gestión de datos – Servidores del cuadro de diálogo Preferences, haciendo clic en el control Properties del espacio de trabajo activo o de uno conocido y seleccionando la entrada Dictionaries del menú.

  • Cuando se selecciona un tipo definido mediante un diccionario para un parámetro, también se puede acceder a la página Settings – Vault – Dictionaries haciendo clic en la celda del parámetro en la columna Type y, a continuación, en el botón  ().

Acceda a la página de gestión de diccionarios de la interfaz web del espacio de trabajo desde el editor de plantillas de componentes.
Acceda a la página de gestión de diccionarios de la interfaz web del espacio de trabajo desde el editor de plantillas de componentes.

Obtenga más información sobre la gestión de diccionarios desde la interfaz web del espacio de trabajo (Espacio de trabajo de Altium 365, Espacio de trabajo de Enterprise Server).

Los diccionarios definidos están disponibles como tipos de parámetros en el menú desplegable Type.

Seleccione un tipo de parámetro definido mediante un diccionario en el menú desplegable Tipo.
Seleccione un tipo de parámetro definido mediante un diccionario en el menú desplegable Tipo.

Los valores definidos para el tipo seleccionado están disponibles en el menú desplegable Default Value. Seleccione el valor que desee utilizar como valor predeterminado del parámetro o seleccione <None>.

Seleccione un valor predeterminado entre los definidos para el tipo seleccionado.
Seleccione un valor predeterminado entre los definidos para el tipo seleccionado.

  • Los valores predeterminados se validan al guardar la plantilla de componente en el espacio de trabajo. Si el valor predeterminado deja de ser coherente con el diccionario (p. ej., el valor se ha eliminado del diccionario y después se ha abierto para su edición la plantilla que utiliza dicho valor), este valor predeterminado se resaltará en rojo en la columna Valor predeterminado y se mostrará un mensaje de error en el panel Messages al intentar volver a guardar la plantilla en el espacio de trabajo.

  • Si el valor de un parámetro de componente deja de ser coherente con el diccionario (p. ej., el tipo de ese parámetro se ha cambiado de Texto a un tipo definido mediante un diccionario en la plantilla de componente y el valor actual del componente no coincide con ningún valor del tipo seleccionado), este parámetro se resaltará al editar el componente en el editor de componentes: se mostrará un icono de exclamación junto al valor incoherente del parámetro al editar el componente en el modo de edición de un solo componente del editor, y el valor del parámetro se resaltará en rojo al editar el componente en el modo de edición de componentes por lotes del editor. Asegúrese de que todos los parámetros del componente sean coherentes con los valores de la plantilla; de lo contrario, no podrá guardar el componente en la siguiente revisión.

  • Si se han modificado los diccionarios en la interfaz web del espacio de trabajo conectado, deberá desconectarse del espacio de trabajo y volver a conectarse para que estos cambios se reflejen en Altium Designer. Consulte la página Acceso a su espacio de trabajo para obtener más información.

Definición de múltiples huellas

El editor de plantillas de componentes también permite definir múltiples huellas de PCB como parte de una plantilla de componente. Se puede especificar cualquier número de enlaces a modelos de huella, una función especialmente útil para quienes deseen crear componentes que hagan referencia a 3 huellas y cumplan los requisitos de IPC para distintos niveles de densidad: L (mínimo cobre), M (máximo cobre) y N (cobre nominal o intermedio).

Para añadir una definición de modelo de huella adicional a la plantilla, haga clic en para añadir un nuevo parámetro y, a continuación, seleccione la entrada PCBLIB en el menú desplegable asociado al campo Type.

Convierta un parámetro recién añadido en una definición de modelo de huella estableciendo su Type en PCBLIB.
Convierta un parámetro recién añadido en una definición de modelo de huella estableciendo su Type en PCBLIB.

El nombre del parámetro cambiará de Parameter a PCBLIB n, donde n es el siguiente número entero disponible para distinguir entre los distintos modelos de huella (p. ej., PCBLIB 1, PCBLIB 2, etc.). El modelo predeterminado será el asociado a la entrada PCBLIB. Cuando las huellas se incorporan al editor de componentes al definir un componente, el modelo de huella predeterminado se distingue por el icono en la esquina superior izquierda de la ventana de vista previa del modelo (en el modo Single Component Editing) y por la entrada PCBLIB (default) en la región Required Models/Parameters (en el modo Batch Component Editing).

Ejemplo de un componente definido en el Editor de componentes (modo Single Component Editing), utilizando una plantilla de componentes referenciada. La plantilla tiene definidos tres modelos de huella, que se incorporan a la definición del componente. Observe que la entrada del modelo PCBLIB de la plantilla se utiliza como modelo de huella predeterminado (identificado por un icono en su esquina superior izquierda) al definir el componente. Pase el cursor sobre la imagen para ver el mismo componente definido con el Editor de componentes en modo Batch Component Editing. En este caso, la huella predeterminada se denomina PCBLIB (default).
Ejemplo de un componente definido en el Editor de componentes (modo Single Component Editing), utilizando una plantilla de componentes referenciada. La plantilla tiene definidos tres modelos de huella, que se incorporan a la definición del componente. Observe que la entrada del modelo PCBLIB de la plantilla se utiliza como modelo de huella predeterminado (identificado por un icono en su esquina superior izquierda) al definir el componente. Pase el cursor sobre la imagen para ver el mismo componente definido con el Editor de componentes en modo Batch Component Editing. En este caso, la huella predeterminada se denomina PCBLIB (default).

Importación y exportación de plantillas de componentes

Se puede importar un archivo de plantilla de componentes existente (*.CMPT) o un archivo de biblioteca de componentes (*.CMPLIB) al editor de plantillas de componentes, y la plantilla de componentes que se está editando se puede exportar a un archivo de plantilla de componentes (*.CMPT). Utilice los comandos File » Import » Component Template, File » Import » Component Library y File » Export del menú principal del editor de componentes para seleccionar la acción deseada y, en el cuadro de diálogo estándar de Windows que se abre, vaya a la ubicación necesaria y seleccione un archivo para importar o defina el nombre del archivo que se exportará.

Reutilización de una plantilla de componentes

Puede utilizar una revisión de una plantilla de componentes —o, más concretamente, referenciarla desde la revisión de un componente que esté editando— de las siguientes maneras.

Un componente solo puede referenciar una plantilla de componentes a la vez.

Al crear un componente nuevo

Al crear un componente nuevo mediante el comando File » New » Component de los menús principales, puede elegir la plantilla en el cuadro de diálogo Create new component.

Vinculación rápida de una plantilla de componentes desde una lista de todas las plantillas disponibles al crear un componente nuevo.
Vinculación rápida de una plantilla de componentes desde una lista de todas las plantillas disponibles al crear un componente nuevo.

Manualmente desde el Editor de componentes

La reutilización de una revisión de una plantilla de componentes desde el Editor de componentes depende del modo de funcionamiento del editor.

En el modo de edición de un solo componente

Al editar un único componente en este modo del Editor de componentes, elija la plantilla de componentes necesaria en el menú desplegable asociado al campo Template, que forma parte del grupo Advanced Settings, en la región Component del editor. Se muestran por nombre todas las plantillas de componentes disponibles actualmente en el mismo espacio de trabajo en el que reside el componente, con sus revisiones más recientes indicadas entre paréntesis. Elija la plantilla necesaria para aplicarla.

Vinculación rápida de una plantilla de componentes desde un menú de todas las plantillas disponibles al editar la revisión de un componente mediante el Editor de componentes en modo Single Component Editing.
Vinculación rápida de una plantilla de componentes desde un menú de todas las plantillas disponibles al editar la revisión de un componente mediante el Editor de componentes en modo Single Component Editing.

En el modo de edición de componentes por lotes

Hay dos formas de vincular una revisión de una plantilla de componentes a la revisión del componente que se está editando:

  • Desde la pestaña Template del cuadro de diálogo Opciones del documento (Edit » Document Options). Haga clic en el botón Choose a la derecha del campo Item Revision. Esto permite acceder al cuadro de diálogo Choose Item (una variante del panel Explorer). Utilice este cuadro de diálogo para buscar y seleccionar la revisión de la plantilla de componentes necesaria. Tras hacer clic en OK, se creará un vínculo entre la revisión del componente y la revisión de destino de la plantilla de componentes. Puede comprobar este vínculo en la pestaña Template del cuadro de diálogo Document Options.

    Vinculación manual de un componente a una revisión de una plantilla de componentes en el espacio de trabajo de destino.
    Vinculación manual de un componente a una revisión de una plantilla de componentes en el espacio de trabajo de destino.

    La plantilla de componentes utilizada puede cambiarse en cualquier momento: haga clic en Choose y seleccione una revisión de otra plantilla de componentes.
    El estado de la revisión del elemento de plantilla de componentes vinculado se refleja en la pestaña Template del cuadro de diálogo Document Options. Si hay disponible una revisión más reciente del elemento vinculado, haga clic en el botón para utilizarla.
  • Desde el menú Add asociado a la región Required Models/Parameters del Editor de componentes. El submenú Templates muestra por nombre todas las plantillas de componentes disponibles actualmente en el mismo espacio de trabajo en el que reside el componente, con sus revisiones más recientes indicadas entre paréntesis. Haga clic en una entrada para crear un vínculo a la revisión más reciente de esa plantilla de componentes. De nuevo, puede comprobar el vínculo en la pestaña Templates del cuadro de diálogo Document Options.

    Vinculación rápida de una plantilla de componentes desde un menú de todas las plantillas disponibles.
    Vinculación rápida de una plantilla de componentes desde un menú de todas las plantillas disponibles.

Herencia desde la carpeta de componentes del espacio de trabajo

Puede especificar una plantilla de componentes para que se utilice automáticamente en todos los componentes (y sus revisiones) almacenados en una carpeta de componentes del espacio de trabajo.

Solo se puede definir una plantilla de componentes predeterminada para una carpeta de tipo Components.

Especifique la plantilla necesaria mediante el campo Component Template al definir las propiedades de la carpeta en el cuadro de diálogo Editar carpeta. La lista desplegable asociada al campo muestra por nombre todas las plantillas de componentes disponibles actualmente en el mismo espacio de trabajo en el que reside la carpeta de componentes, con sus revisiones más recientes indicadas entre paréntesis. Elija una entrada para crear un vínculo a la revisión más reciente de esa plantilla de componentes para cada componente que se cree posteriormente en esa carpeta.

Especifique una plantilla de componentes predeterminada para aplicarla a todos los componentes creados en la carpeta de componentes principal.
Especifique una plantilla de componentes predeterminada para aplicarla a todos los componentes creados en la carpeta de componentes principal.

Para no utilizar esta función, deje o establezca el campo Component Template en None.

Si se elige una plantilla de componentes a nivel de carpeta, esa misma plantilla se utilizará de forma predeterminada al crear componentes en las subcarpetas que contiene. Esto facilita que todos los componentes de las subcarpetas hereden rápidamente la plantilla.

Cuando se guarda una revisión de un componente en el espacio de trabajo, la revisión específica de la plantilla de componentes utilizada queda fijada, lo que crea un vínculo firme con esa revisión, a menos que se cambie manualmente.

Efecto sobre los modelos y parámetros de los componentes al utilizar una plantilla de componentes

Al editar una revisión de un componente y vincular o referenciar una revisión de una plantilla de componentes, ocurre lo siguiente en el Editor de componentes con respecto a los modelos y parámetros:

  • Los modelos definidos en la plantilla referenciada se añaden a la región Models (modo Single Component Editing) y a la región Model Links (modo Batch Component Editing).
  • Se conservará cualquier modelo referenciado existente, y el componente seguirá utilizándolo a menos que se cambie manualmente de forma deliberada.
  • Los parámetros definidos en la plantilla referenciada se añaden a la región Parameters (modo Single Component Editing) y a la región Required Models/Parameters (modo Batch Component Editing).

    Ejemplo de parámetros tras vincular una revisión de una plantilla de componentes, utilizando el Editor de componentes en modo Single Component Editing (izquierda) y en modo Batch Component Editing (derecha).
    Ejemplo de parámetros tras vincular una revisión de una plantilla de componentes, utilizando el Editor de componentes en modo Single Component Editing (izquierda) y en modo Batch Component Editing (derecha).

    Todos los parámetros procedentes de la plantilla de componentes referenciada se identifican mediante el icono (modo Single Component Editing) y el icono (modo Batch Component Editing). Además, únicamente en el modo de edición de componentes por lotes, la opción Show de cada parámetro basado en la plantilla adopta el estado de la opción Visible correspondiente en la plantilla.
    Los parámetros basados en la plantilla no se pueden eliminar.
    Puede añadir parámetros de usuario adicionales según sea necesario.
  • Solo en el modo Batch Component Editing, los parámetros basados en la plantilla que están configurados para mostrarse se agrupan en el área de definiciones de componentes del editor, con Template Parameters como texto del encabezado.

    Aspecto de los parámetros de ejemplo basados en una plantilla en el área donde se definen los propios componentes, al utilizar el Editor de componentes en su modo Batch Component Editing.
    Aspecto de los parámetros de ejemplo basados en una plantilla en el área donde se definen los propios componentes, al utilizar el Editor de componentes en su modo Batch Component Editing.

  • Los campos de valor de los parámetros basados en una plantilla que se hayan marcado como de solo lectura no se podrán editar. Para todos los demás parámetros basados en una plantilla que no se hayan marcado como de solo lectura, puede cambiar los valores según sea necesario.

    Con el Editor de componentes en modo Single Component Editing, un parámetro de plantilla de solo lectura se distingue en la región Parameters mediante el icono .
  • Si un parámetro basado en una plantilla se ha marcado como obligatorio, pero no se le ha asignado un valor en la plantilla, su campo de valor aparecerá con un borde rojo (en modo Batch Component Editing) o con el icono (en modo Single Component Editing), lo que le indica que este parámetro requiere un valor. No podrá guardar un componente en el espacio de trabajo hasta que se hayan definido los valores de todos los parámetros obligatorios.

    Con el Editor de componentes en modo Single Component Editing, un parámetro de plantilla obligatorio se distingue en la región Parameters mediante el icono .

Volver a guardar una plantilla de componentes

En cualquier momento, puede volver a cualquier revisión de una plantilla de componentes en el espacio de trabajo y editarla directamente. Haga clic con el botón derecho en la revisión y seleccione el comando Edit en el menú contextual. Se abrirá de nuevo el editor temporal, con la plantilla contenida en la revisión abierta para su edición. Realice los cambios necesarios y, a continuación, guarde la plantilla de componentes en la siguiente revisión del elemento.

Al hacer clic con el botón derecho en la entrada de nivel superior de una plantilla de componentes, se editará la última revisión de esa plantilla.

Acceso al comando para iniciar la edición directa de una revisión existente de una plantilla de componentes.
Acceso al comando para iniciar la edición directa de una revisión existente de una plantilla de componentes.

Descarga de datos guardados

Descargue los datos almacenados en una revisión de una plantilla de componentes haciendo clic con el botón derecho en esa revisión (en el panel Explorer) y seleccionando el comando Operations » Download en el menú contextual. El archivo de la plantilla de componentes se descargará en una subcarpeta del directorio elegido, cuyo nombre corresponderá al ID de revisión del elemento. El archivo se encuentra en la carpeta Released dentro de esa subcarpeta.

Acceda al comando Download desde la entrada de nivel superior de una plantilla de componentes para descargar el archivo de la plantilla de componentes almacenado en su última revisión.
Haga clic en el botón Explore del cuadro de diálogo Download from Server para abrir rápidamente la carpeta de descarga.

Eliminación temporal

Cuando está conectado a un espacio de trabajo, dispone de funciones flexibles para eliminar una plantilla de componentes directamente desde Altium Designer, desde el panel Explorer. Haga clic con el botón derecho en la entrada de la plantilla de componentes en el panel y seleccione el comando Delete Item en el menú contextual. Aparecerá el cuadro de diálogo Delete Items, en el que podrá confirmar la eliminación. La acción es, en realidad, una «eliminación temporal», mediante la cual la plantilla de componentes se trasladará al área Trash del espacio de trabajo. Trash es, en esencia, una papelera de reciclaje a la que se puede trasladar cualquier contenido del espacio de trabajo mediante una acción de eliminación temporal. Está aislada del resto del espacio de trabajo.

La función de eliminación temporal permite eliminar una plantilla de componentes que esté en uso.
Se pueden eliminar varias plantillas de componentes en una sola acción. Seleccione todas las plantillas de componentes que desee eliminar mediante los controles estándar de selección múltiple (Shift+Click, Ctrl+Click); a continuación, haga clic con el botón derecho y seleccione el comando Delete Items en el menú contextual.

Eliminación temporal de una plantilla de componentes. La plantilla se trasladará al área Trash del espacio de trabajo.
Eliminación temporal de una plantilla de componentes. La plantilla se trasladará al área Trash del espacio de trabajo.

Para proceder con la eliminación, haga clic en el botón . El elemento se eliminará y un cuadro de diálogo Deletion Summary confirmará que la eliminación se ha realizado correctamente. Si se produce algún problema durante la eliminación, se le notificará.

Todo el contenido eliminado de esta manera se puede encontrar en la página Trash de la interfaz web del espacio de trabajo. Tenga en cuenta que solo puede ver el contenido que usted haya eliminado temporalmente. Los administradores podrán ver todo el contenido de la página Trash, es decir, todo el contenido que se haya eliminado temporalmente.

Aspectos que debe tener en cuenta sobre una plantilla de componentes eliminada temporalmente:

  • La plantilla de componentes no estará disponible en su software de diseño ni en la interfaz web.
  • En cualquier lugar donde se estuviera utilizando la plantilla de componentes se indicará que esta se ha eliminado.
  • Una plantilla de componentes se puede restaurar o eliminar permanentemente desde la página Trash, siempre que tenga permisos de edición. La eliminación permanente solo es posible si ningún elemento principal la está utilizando.
Tenga en cuenta que, si ha eliminado temporalmente una plantilla de componentes, trasladándola a Trash, puede crear una nueva plantilla de componentes con el mismo nombre. Si posteriormente restaura la plantilla de componentes original y su nombre original ya está en uso, se añadirá un sufijo numérico entero para que su nombre siga siendo único dentro del espacio de trabajo.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents