Power Analyzer by Keysight QuickStart Guide

En un coup d'œil

Ce guide de démarrage rapide vous présente comment Power Analyzer by Keysight vous aide à évaluer le réseau de distribution d’alimentation en courant continu d’un PCB dans Altium Designer. Vous pouvez ainsi dépasser les simples estimations et vérifier si les chemins de cuivre, les plans, les pistes et les vias peuvent répondre aux besoins en alimentation de votre conception. Il explique comment l’extension s’intègre directement à votre projet actuel, comment l’installer et la lancer, quelles informations sont nécessaires avant d’exécuter une analyse, et comment commencer à définir et à simuler les réseaux d’alimentation. Si vous cherchez un point de départ plus clair pour utiliser Power Analyzer by Keysight dans votre processus de travail existant, cet article vous présente les étapes essentielles pour démarrer. Poursuivez votre lecture pour prendre l’outil en main en toute confiance.

- Découvrez ce que fait Power Analyzer by Keysight dans Altium Designer et comment il facilite l’analyse de l’intégrité de l’alimentation en courant continu à partir des données de conception existantes de votre projet.
- Découvrez les étapes de base pour installer l’extension, ouvrir le document d’analyse et préparer les paramètres de votre carte et de vos réseaux en vue de la simulation.
- Comprenez les principales exigences de préparation, notamment la synchronisation entre le schéma et le PCB, les options de configuration, les abonnements nécessaires et la sélection des réseaux d’alimentation.
Approfondissez avec l'IA :

Dans les conceptions numériques modernes, qui comportent des circuits à haute vitesse, des cartes à forte densité de composants et plusieurs rails d’alimentation basse tension, les exigences imposées au réseau de distribution d’alimentation en courant continu nécessitent une approche analytique de sa conception. L’analyse en courant continu d’un réseau de distribution d’alimentation, ou les résultats de son analyse d’intégrité de l’alimentation en courant continu (PI-DC), vise à garantir qu’une quantité suffisante de cuivre est présente sur le trajet entre les sources de tension et les charges. Autrement dit, les plans, les pistes et les vias de la carte doivent présenter des dimensions et des caractéristiques suffisantes pour répondre aux besoins de consommation électrique des composants de la carte.

Heureusement, il est possible d’évaluer le réseau de distribution d’alimentation d’un PCB sans recourir à des approximations, grâce à un outil de simulation de l’intégrité de l’alimentation en courant continu (PI-DC) qui analyse les performances en courant continu de la carte à partir de ses propriétés électriques et physiques. Un tel outil est disponible pour Altium Designer : le Power Analyzer by Keysight.

Proposé sous la forme d’une extension Altium téléchargeable, Power Analyzer s’intègre directement à Altium Designer pour permettre la simulation et l’analyse PI-DC du projet PCB en cours. Puisque Power Analyzer fonctionne au sein d’Altium Designer, aucune importation ou exportation manuelle de données, aucune conversion de données ni aucune application distincte n’est nécessaire : lancez Power Analyzer depuis l’éditeur de schémas ou de PCB, définissez les paramètres de test souhaités, puis exécutez la simulation. Les résultats sont principalement présentés au moyen d’une modélisation 2D/3D de la géométrie du cuivre de la carte, ce qui permet de les évaluer rapidement et d’effectuer des tests exploratoires de type « que se passerait-il si » sur le routage du PCB.

  • Power Analyzer by Keysight simule les structures en cuivre présentes sur la carte, en extrayant les données physiques de la carte ainsi que les données relatives aux composants et aux connexions du modèle de données unifié. Si des modifications de conception ont été apportées au schéma, resynchronisez toujours le schéma et le PCB avant d’effectuer une analyse de l’alimentation. Pour en savoir plus, consultez Gestion des modifications de conception entre le schéma et le PCB.

  • Si vous préférez apprendre en regardant des vidéos, découvrez la playlist vidéo Comment utiliser Power Analyzer by Keysight.

Accès aux fonctionnalités de Power Analyzer by Keysight

Pour accéder aux fonctionnalités de Power Analyzer by Keysight dans Altium Designer, l’Power Analyzer by Keysight extension logicielle doit être installée. Cette extension peut être installée ou supprimée manuellement.

Pour plus d’informations sur la gestion des extensions, consultez la Extending Your Installation page (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Lorsque vous cliquez pour télécharger et installer l’extension, la End-User License Agreement s’ouvre (). Cliquer sur Accept indique que vous acceptez les conditions générales du contrat de licence utilisateur final (CLUF) ; l’installation se poursuit alors. Cliquer sur Close indique que vous n’acceptez pas les conditions générales du CLUF, et le processus d’installation s’arrête.

Lorsque l’extension logicielle Power Analyzer by Keysight est installée, elle permet de :

 
 
 
 
 
  • ajouter un nouveau document d’analyse de l’alimentation ou en ouvrir un existant ; 

  • Button, Manage Power Nets configurer Power Analyzer et les nets d’alimentation ; 

  • Button, Show Power Net in Tree examiner l’arborescence des nets ;

  • Button, Show the Power Net Analysis on the PCB examiner les résultats d’analyse de l’alimentation existants ;

  • Button, View the Power Net Analysis results as a Report consulter les rapports existants et générer de nouveaux rapports à partir des résultats d’analyse de l’alimentation existants.

Toutefois, pour effectuer une nouvelle analyse de l’alimentation, vous devez disposer d’un abonnement valide à Power Analyzer by Keysight. Sinon, toute tentative de lancement d’une analyse de l’alimentation ouvrira la boîte de dialogue Analyze Your Power Nets, dans laquelle vous pourrez demander un essai gratuit ().

Lancement de Power Analyzer

Pour commencer à utiliser Power Analyzer, ouvrez le document PCB du projet ou l’un de ses schémas, puis sélectionnez Tools » Power Analyzer by Keysight dans les menus principaux.

Le document Power Analyzer Keysight (<ProjectName>.pdnaK) s’ouvre et est ajouté à la zone Source Documents du projet (dans le panneau Projects), comme illustré ci-dessous.

La commande Power Analyzer by Keysight n’est pas disponible dans le menu ? Vérifiez que l’extension est installée et que vous disposez d’un abonnement correspondant (en savoir plus).

Power Analyzer peut être lancé depuis les menus de l’éditeur de schémas ou de l’éditeur de PCB. Toutefois, comme Power Analyzer simule les structures du PCB, toute modification de conception apportée au schéma doit être synchronisée avec le PCB avant de pouvoir être détectée depuis le document de l’analyseur (*.pdnaK). Si une modification de conception n’a pas été détectée, enregistrez, fermez, puis rouvrez le document de l’analyseur.

Préparation de l’analyse

Vous êtes prêt à effectuer une analyse, mais lorsque vous cliquez sur le bouton Analyze, une boîte de dialogue s’ouvre et vous propose une version d’essai ? Vérifiez que l’extension est installée et que vous disposez d’un abonnement correspondant (en savoir plus).

Power Analyzer doit connaître les propriétés physiques de votre carte. Celles-ci comprennent les densités de courant maximales pour les couches externes et internes, les diamètres minimal et maximal des vias, le type de cuivre, la température de fonctionnement, etc. Ces propriétés sont définies dans la zone Configuration du document de l’analyseur.

Options de configuration

  • Les valeurs de densité de courant maximale et de courant maximal dans les vias sont identiques pour tous les nets, car elles dépendent de la géométrie du cuivre.

  • Les paramètres Max Current Density for Surface / Internal Layers définissent la valeur admissible pour les couches correspondantes du PCB.

  • Le courant maximal dans les vias est spécifié pour les tailles minimale et maximale des trous utilisés dans le projet. Les valeurs de diamètre des trous sont définies dans les champs Min Via Diameter et Max Via Diameter, ainsi que le Max Current autorisé pour cette taille de trou.

  • Le logiciel subdivise le PCB en mailles pendant la simulation. Par défaut, la taille du maillage est dynamique. En cochant la case Simulation Mesh Size, vous pouvez définir la taille de maillage souhaitée.

  • Par défaut, le net de masse est exclu des résultats de la carte thermique. Pour inclure le net de masse, décochez la case Skip Ground, puis sélectionnez le net GND dans la liste déroulante Network / Net en haut du panneau Power Analysis by Keysight pour explorer les résultats de la carte thermique. Notez que la carte thermique prend en charge les structures polygonales sur les couches de signal, mais que le comportement d’une couche de plan d’alimentation ne peut pas être simulé.

  • Le champ Copper Type spécifie le type de cuivre utilisé, ainsi que les paramètres associés et les paramètres de température. 

  • Le Work Temperature sert à déterminer la résistivité des conducteurs, et le Temperature Compensation est une caractéristique du matériau lui-même liée à sa conductivité thermique. Les matériaux ont des coefficients de conductivité thermique différents et influencent donc l’échauffement du matériau en fonction de la charge. Cet échauffement modifie la résistance interne du matériau, ce qui influe à son tour sur la chute de tension.

  • Le Via Plating Thickness affiché dans la zone Global PCB Parameters est défini dans le panneau Properties du Layer Stack Manager – en savoir plus.

Modifiez ces valeurs par défaut selon les besoins de votre conception.

Outre la densité de courant maximale et le courant maximal dans les vias, la chute de tension admissible doit être spécifiée pour chaque net d’alimentation défini. Configurez le DC Drop Limit pour chaque net, soit en sélectionnant un pourcentage prédéfini, soit en saisissant une valeur Custom.

Les Auto-Define Settings sont utilisés par Power Analyzer lorsqu’il tente d’identifier automatiquement les nets d’alimentation de votre conception. Pour ce faire, il doit savoir comment identifier les éléments du circuit tels que les régulateurs de tension, les connecteurs et les composants en série. Outre l’utilisation d’indices tels que les préfixes des désignateurs de composants, vous pouvez également ajouter des paramètres à certains composants pour améliorer le processus de détection automatique. Pour plus d’informations, consultez la section Exigences de reconnaissance automatique.

Ajout d’un net d’alimentation pour la simulation

Pour ajouter un net d’alimentation pour la simulation, cliquez sur le bouton  en haut à gauche afin d’ouvrir la boîte de dialogue Manage Nets. Cochez la case du Power Net Name souhaité et configurez le Reference Net correspondant. Si aucun objet de port d’alimentation n’est associé à un net dans le schéma, ce net ne figurera pas dans la liste Power Net Name. Cliquez sur Show Custom Nets pour inclure tous les nets de la conception. Plusieurs nets d’alimentation peuvent être activés si nécessaire. Les relations hiérarchiques entre les nets d’alimentation sont résolues automatiquement une fois le net d’alimentation entièrement configuré.

Chaque net d’alimentation nécessite une source d’alimentation ; celles-ci seront configurées à l’étape suivante.

Vous pouvez également cliquer sur le bouton  pour que le logiciel crée les nets d’alimentation à votre place. Il tente alors de reconnaître automatiquement la topologie du projet en s’appuyant sur les paramètres actuels de la zone Auto-Define Settings de la section Configuration du document de l’analyseur (*.pdnaK).

Ajout d’une source d’alimentation

Pour ajouter une source d’alimentation, cliquez sur + (ou sur la commande Gérer associée) dans la section Sources du circuit d’alimentation souhaité. Si le circuit comprend plusieurs sources d’alimentation, cliquez sur Gérer et sélectionnez les autres composants.

Pour qu’un composant soit disponible en tant que source, il doit être connecté au Power Net sélectionné, mais il peut être connecté au Reference Net sélectionné par l’intermédiaire de tout composant connecté à ce Reference Net.

La fiche du composant

Chaque composant inclus en tant que source ou charge est représenté dans le document Power Analyzer par une Component Card.

  • Survolez la fiche du composant pour afficher les boutons Edit et Delete.
  • Double-cliquez sur la fiche du composant pour ouvrir la boîte de dialogue Properties de ce composant.
  • Cliquez sur la valeur Identifiant de l’élément de conception pour localiser ce composant sur le schéma par navigation croisée. Le niveau de zoom de la navigation croisée est défini dans la section Highlight Methods de la page System - Navigation de la boîte de dialogue Preferences.
  • Modifiez la valeur d’analyse principale de ce composant directement dans la fiche (ou modifiez le composant pour accéder à toutes ses propriétés).

Extension d’un net

Les nets d’alimentation de la carte peuvent traverser des éléments passifs, tels que des fusibles ou des résistances, avec un net différent de l’autre côté du composant. Dans ce cas, il est recommandé de extend the net en intégrant un composant intermédiaire et son second net au net principal. La fonction Extend Nets est prévue à cet effet.

Pour prolonger un réseau, cliquez sur l’icône +Prolonger les réseaux à côté de son nom pour ouvrir la boîte de dialogue <PowerNet> Extensions Manager. Cliquez sur + pour prolonger le réseau cible. Power Analyzer affiche uniquement les réseaux pouvant être raccordés par l’intermédiaire d’un seul composant d’extension. Une fois le réseau Add, un composant associé est automatiquement ajouté dans la boîte de dialogue <PowerNet> Extensions Manager ; vous pouvez le modifier si nécessaire.

Les réseaux d’alimentation peuvent être prolongés par l’intermédiaire d’un composant en série.Les réseaux d’alimentation peuvent être prolongés par l’intermédiaire d’un composant en série.

Vous pouvez ensuite continuer à prolonger le réseau en cliquant sur le symbole + , comme illustré ci-dessous. Une fois terminé, cliquez sur Enregistrer dans la boîte de dialogue <PowerNet> Extensions Manager.

Continuez à ajouter des composants en série et des réseaux.Continuez à ajouter des composants en série et des réseaux.

Remarques sur le prolongement d’un réseau

  • Pour chaque composant en série, vous pouvez définir sa chute de tension, sa résistance et son courant maximal admissible, qui seront pris en compte lors de l’analyse (voir l’image).

  • Si vous définissez un réseau incorrect, vous pouvez le supprimer en survolant son nom et en cliquant sur l’icône de suppression qui apparaît.

  • Une fois le réseau prolongé enregistré, les composants connectés aux réseaux prolongés apparaissent dans la liste des charges, et vous pouvez les ajouter.

  • Le nombre de prolongements ajoutés est indiqué à côté du nom du réseau d’alimentation. Survolez ce nombre avec le curseur pour afficher les noms des réseaux de prolongement (comme illustré ci-dessus).

  • La prise en charge de la simulation des composants en parallèle dans un réseau prolongé a été ajoutée dans la version V1.0.6 de l’extension PABK, et leur prise en charge dans l’interface utilisateur dans la version V1.0.9. Pour définir des composants en parallèle, sélectionnez le réseau dans la boîte de dialogue contextuelle Extensions Manager, puis activez tous les composants en parallèle, comme illustré ci-dessous. Survolez l’image pour afficher la boîte de dialogue une fois le prolongement du réseau terminé.

    Sélectionnez tous les composants en parallèle du réseau.Sélectionnez tous les composants en parallèle du réseau.

Définition d’une charge

Pour ajouter un composant de charge, cliquez sur + (ou sur la commande Gérer associée) dans la section Loads , puis sélectionnez le composant souhaité. Un composant figure dans la boîte de dialogue lorsqu’il est connecté au réseau principal ou à un réseau prolongé.

Après avoir ajouté un composant, vous pouvez définir sa consommation directement dans sa fiche de composant, ou en cliquant sur le bouton  pour ouvrir la boîte de dialogue <NetName>/<LoadName> Load Properties.

Remarques sur la configuration d’une charge

  • Définissez les propriétés de la charge, notamment Load Type, Total Load Current, ainsi que Min et Max Voltage.
  • Vérifiez que le réseau d’alimentation IN est correctement configuré, ainsi que les options Reference et Connected to reference through.
  • Le courant de charge est automatiquement réparti de manière égale entre toutes les broches d’alimentation identifiées ; modifiez ces valeurs si nécessaire.
  • Lors de la configuration d’une charge de type IC (Current) , vous pouvez voir toutes les broches du composant de charge qui le relient à la source par l’intermédiaire de différents composants en série, et sélectionner les broches requises.

Lorsque la boîte de dialogue Manage Loads (ou Add Sources) est ouverte, elle comporte une colonne Design Item Id. Cliquez sur une entrée de cette colonne pour localiser le composant correspondant sur le schéma par navigation croisée, ce qui permet de vérifier plus facilement que vous sélectionnez le bon composant.

Le niveau de zoom de la navigation croisée est défini dans la section Highlight Methods de la page System - Navigation de la boîte de dialogue Preferences.

Définition d’un VRM

Pour définir un module régulateur de tension (VRM), ajoutez-le d’abord en tant que charge. Ouvrez ensuite la boîte de dialogue Load Properties du composant (cliquez sur le bouton  ) pour le configurer.

Une fois une charge configurée en tant que VRM, elle apparaît également comme source du réseau d’alimentation défini comme son réseau OUT.Une fois une charge configurée en tant que VRM, elle apparaît également comme source du réseau d’alimentation défini comme son réseau OUT.

Remarques sur la configuration d’un VRM

  • Définissez Load Type comme VRM du type souhaité.
  • Indiquez la tension de sortie dans le champ Vout, ainsi que les autres propriétés du régulateur.
  • Configurez les réseaux IN et OUT dans la zone Nets Management de la boîte de dialogue.
  • Si le VRM n’est pas directement connecté au réseau de référence ou utilise une autre référence, configurez les options Reference et Connected to reference through selon les besoins.
  • Un réseau d’alimentation enfant est automatiquement créé dans la hiérarchie, avec ce VRM comme source (comme illustré ci-dessus).
  • Si le VRM possède plusieurs réseaux de sortie, ajoutez tous les réseaux nécessaires à l’aide du lien +Ajouter un réseau de sortie dans la boîte de dialogue Load Properties, et indiquez leur courant de sortie dans les champs correspondants qui apparaissent.

Le réseau d’alimentation configuré

Chaque réseau d’alimentation configuré est présenté sous la forme d’une définition repliable distincte dans le document *.pdnaK. Le réseau PWR_IN configuré est illustré ci-dessous, avec ses deux réseaux d’alimentation enfants, 3V3 et 1V8, légèrement en retrait pour indiquer leur statut de réseaux enfants.

Comprendre la définition d’un réseau d’alimentation

  • Chaque réseau d’alimentation est présenté sous la forme d’un élément Power Net Definition repliable distinct.
  • Le bandeau de la définition du réseau d’alimentation comprend :
    • Le nom du réseau d’alimentation 
    • Le réseau de référence 
    • Un indicateur affichant le nombre de réseaux supplémentaires (), si le réseau a été prolongé. Survolez-le pour afficher les noms des réseaux enfants.
    • Un bouton  : cliquez dessus pour afficher la structure des connexions des composants de ce réseau dans le contexte de l’ensemble de la hiérarchie des réseaux d’alimentation.
    • Un bouton  : cliquez dessus pour exclure ce réseau du processus d’analyse, ainsi que tous ses réseaux enfants.
    • Un bouton  : cliquez dessus pour analyser ce réseau ainsi que ses éventuels réseaux enfants.
  • Chaque composant du réseau est représenté par une fiche de composant.
  • Une fois le réseau analysé, les résultats Voltage Drop, Current Density et Max Via Current de ce réseau sont affichés dans la définition du réseau d’alimentation, comme illustré ci-dessus.
    • Chaque jauge indique la valeur simulée par rapport à la limite définie. Si la valeur reste entièrement dans la limite, la ligne de l’échelle est verte. Si elle est proche de la limite, la ligne est jaune ; si la limite est dépassée, la ligne est rouge. 
    • Cliquez sur le bouton  pour basculer vers l’éditeur PCB et afficher le cuivre de ce réseau sur le circuit imprimé. Dans l’éditeur PCB, utilisez le panneau Power Analyzer by Keysight pour contrôler le processus d’analyse.
    • Cliquez sur le bouton  pour générer et ouvrir un rapport détaillé sur ce réseau d’alimentation. Dans le rapport, utilisez  bouton pour enregistrer une copie HTML.

Vue arborescente des nets d’alimentation

Pour afficher le net d’alimentation configuré (et les éventuels sous-nets définis par des VRM) sous forme d’arborescence, cliquez sur le bouton  associé. La structure complète s’affiche, et le net d’alimentation concerné ainsi que les composants associés sont mis en surbrillance.

La vue arborescente vous permet de vérifier rapidement si l’ensemble du réseau d’alimentation a été défini comme prévu et est prêt à être analysé. Pour revenir à la fenêtre principale, cliquez sur le lien Power Analyzer by Keysight dans le coin supérieur gauche du document .pdnaK.

Exécuter une analyse

Une fois la configuration terminée, vous pouvez lancer l’analyse d’un net spécifique en cliquant sur le bouton  associé. Un résumé des résultats de l’analyse est présenté dans la définition du net d’alimentation, comme illustré ci-dessous. Pour afficher les résultats sur le PCB, cliquez sur le bouton  associé.

Pour analyser tous les nets configurés en une seule opération, cliquez sur le bouton  (en haut à droite du document de l’analyseur). Si vous choisissez d’analyser le net d’alimentation de niveau supérieur de l’arborescence, tous les sous-nets (créés à l’aide de composants VRM) seront également analysés. Si tous les nets ont été analysés, vous pouvez sélectionner le net actuellement mis en surbrillance à l’aide de la liste déroulante Network/Net en haut du panneau Power Analyzer by Keysight. 

Gestion des couches

Vous pouvez changer de couche de simulation de la même manière que lorsque vous travaillez sur un PCB, à l’aide des onglets de couche situés en bas de la fenêtre de l’éditeur PCB. Vous pouvez également vous concentrer sur la couche active à l’aide du raccourci Shift+S ; utilisez ce raccourci pour parcourir les options de visibilité du mode monocouche.

Utilisez les onglets de couche du PCB pour changer rapidement l’affichage des résultats d’analyse. Les résultats de la couche supérieure sont présentés ici. Survolez l’image pour voir ceux de la couche inférieure.Utilisez les onglets de couche du PCB pour changer rapidement l’affichage des résultats d’analyse. Les résultats de la couche supérieure sont présentés ici. Survolez l’image pour voir ceux de la couche inférieure.

Le panneau Power Analyzer by Keysight

Dans l’éditeur PCB, le processus d’analyse et les résultats sont contrôlés depuis le panneau Power Analyzer by Keysight. Notez que ce panneau est ajouté à la liste des panneaux disponibles (accessible via le bouton Panels) une fois qu’une analyse d’alimentation a été effectuée et que vous avez cliqué sur le bouton  .  

Réseau / Net

  • Network / Net - permet de sélectionner le réseau () ou le net () à afficher sous forme de carte thermique dans l’espace de travail graphique.
  • Only nets with violations - lorsque cette option est activée (par défaut), seuls les nets présentant actuellement une violation sont disponibles dans la liste déroulante. Désactivez cette option pour répertorier tous les nets d’alimentation. 
  • Utilisez les méthodes habituelles de l’éditeur PCB pour effectuer des déplacements panoramiques et des zooms dans l’espace de travail afin d’examiner les résultats de simulation.

Sous le sélecteur Network / Net, le panneau comporte deux onglets, General et Heatmap. Les options de ces onglets s’appliquent au net actuellement sélectionné dans la liste déroulante Network / Net.

Sélectionnez le net à afficher, puis configurez les options générales ou de carte thermique pour ce net.Sélectionnez le net à afficher, puis configurez les options générales ou de carte thermique pour ce net.

Carte thermique

L’onglet Heatmap du panneau Power Analyzer by Keysight permet de choisir les données présentées sous forme de carte thermique, à savoir la densité de courant ou la chute de tension, ainsi que la manière dont les couleurs sont appliquées à ces données.

Utilisez l’onglet Heatmap  du panneau Power Analyzer by Keysight pour modifier les résultats de simulation présentés sur le PCB. Ici, les résultats de densité de courant sont affichés. Survolez l’image avec le curseur pour voir les résultats de chute de tension.Utilisez l’onglet Heatmap du panneau Power Analyzer by Keysight pour modifier les résultats de simulation présentés sur le PCB. Ici, les résultats de densité de courant sont affichés. Survolez l’image avec le curseur pour voir les résultats de chute de tension.

Les options de chacun de ces modes sont décrites ci-dessous.

Carte thermique de la densité de courant
  • L’ensemble du net est coloré pour représenter la densité de courant en chaque point du net : plus la densité de courant est élevée, plus la couleur est chaude (rouge). 
  • Show Heatmap - utilisez cette commande pour supprimer rapidement la carte thermique et rétablir l’affichage standard du PCB. 
  • Show Arrows of Current Direction - activez cette option pour afficher de petites flèches indiquant le sens de circulation du courant dans l’ensemble du net.
  • Use Noise Suppression - lorsque le courant calculé s’approche de zéro, les flèches de direction du courant donnent l’impression qu’un courant circule dans cette zone, alors qu’il est pratiquement nul. Activez cette option pour exclure ces valeurs de faible courant susceptibles d’induire en erreur.
  • Scope Controller - la manière dont les couleurs sont appliquées au net pour représenter l’intensité, ou la chaleur, est contrôlée par Scope Controller. La valeur Max correspond par défaut à la densité de courant maximale calculée dans ce net (afficher l’image), tandis que la valeur Min est définie par défaut sur 0 A/mm2. Cette échelle s’affiche sous forme de barre colorée sous le PCB et reflète les paramètres Min et Max actuels, une échelle déterminée par le type d’échelle sélectionné, ainsi que les unités. Les valeurs Min et Max peuvent être ajustées en cliquant sur le curseur et en le faisant glisser, ou en saisissant une nouvelle valeur dans les champs Min ou Max. Les valeurs calculées inférieures à Min sont affichées en bleu, et celles supérieures à Max sont affichées en rouge. 
  • Use Logarithmic Scale - activez cette option pour passer d’une échelle linéaire à une échelle logarithmique. Une échelle logarithmique a pour effet de concentrer les valeurs élevées vers l’extrémité hot de l’échelle de couleurs. Par exemple, vous pouvez activer l’échelle logarithmique pour repérer rapidement les sections de routage transportant des courants élevés, puis passer à l’échelle linéaire pour examiner la répartition des densités de courant dans cette section de routage.

La carte thermique logarithmique de la densité de courant révèle une zone problématique ; survolez l’image avec le curseur pour afficher cette zone à l’aide de l’échelle linéaire.La carte thermique logarithmique de la densité de courant révèle une zone problématique ; survolez l’image avec le curseur pour afficher cette zone à l’aide de l’échelle linéaire.

Carte thermique de la chute de tension
  • L'ensemble du net est coloré pour représenter la chute de tension en chaque point du net : plus la tension est élevée, plus la couleur est chaude (rouge). Avec cette représentation, plus la couleur est froide, plus la tension est faible (et plus la chute de tension est importante). 
  • Show Heatmap - utilisez cette commande pour supprimer rapidement la carte thermique et rétablir l'affichage standard du PCB. 
  • Show Arrows of Current Direction - activez cette option pour afficher de petites flèches indiquant le sens de circulation du courant dans l'ensemble du net.
  • Use Noise Suppression - Lorsque le courant calculé se rapproche de zéro, les flèches de direction du courant donnent l'impression qu'un courant circule dans cette zone, alors qu'il est pratiquement nul. Activez cette option pour exclure ces valeurs de faible courant, potentiellement trompeuses.
  • Scope Controller - la manière dont la couleur est appliquée au net pour représenter l'intensité, ou la chaleur, est contrôlée par Scope Controller. La valeur Max est définie par défaut juste en dessous de la tension maximale spécifiée pour ce net, et la valeur Min est Max - calculated voltage drop (voir l'image). Cette échelle est affichée sous la forme d'une barre colorée sous le PCB, indiquant la chute de tension en valeur absolue ou en pourcentage, les réglages Min et Max actuels, ainsi que les unités. Les valeurs Min et Max peuvent être ajustées en faisant glisser les poignées du curseur ou en saisissant une nouvelle valeur dans les champs Min ou Max. Les valeurs calculées inférieures à Min sont affichées en bleu, et les valeurs supérieures à Max sont affichées en rouge. 
  • Scale Type - l'échelle de chute de tension peut être exprimée en volts (cliquez sur le bouton  ) ou en pourcentage (cliquez sur le bouton  ).
  • Enable Visual Slider for Voltage Contour - lorsque cette option est activée, elle affiche sur la carte thermique les emplacements où la tension est égale aux valeurs spécifiées pour les points de contour de tension, ce qui permet de les identifier facilement. Les valeurs des points de contour peuvent être ajustées en faisant glisser les curseurs ou en saisissant des valeurs dans les champs Voltage Contour Points ci-dessous. Vous pouvez ajouter des points ou supprimer des points existants en cliquant sur l'icône correspondante.

Les points de contour peuvent être configurés pour identifier rapidement les emplacements de la carte où la tension correspond à la valeur définie.Les points de contour peuvent être configurés pour identifier rapidement les emplacements de la carte où la tension correspond à la valeur définie.

Détection des violations

Si la simulation détecte une violation de type Voltage Drop, Current Density ou Max Via Current, celle-ci est répertoriée dans la section Violations du panneau Power Analyzer by Keysight. Cliquez sur une violation dans le panneau pour accéder, par navigation croisée, à l'emplacement précis du PCB où cette erreur s'est produite. Si vous ne pouvez pas lire l'intégralité de la description de la violation, survolez sa section Description avec le curseur pour afficher une infobulle contenant tous les détails.

Les violations sont automatiquement détaillées dans la section Violations du panneau Power Analyzer by Keysight. Survolez l'image avec le curseur pour afficher une violation de courant dans un via.Les violations sont automatiquement détaillées dans la section Violations du panneau Power Analyzer by Keysight. Survolez l'image avec le curseur pour afficher une violation de courant dans un via.

Notez que le mode de carte thermique (densité de courant ou chute de tension) est automatiquement sélectionné en fonction du type de violation sur laquelle vous cliquez. 

Sondes

La section Sondes du panneau Power Analyzer by Keysight permet de placer des sondes de mesure directement sur le PCB. Les sondes peuvent mesurer la densité de courant ou la chute de tension ; le type de mesure est déterminé par le mode de carte thermique actuel de la carte.

Les sondes peuvent être :

  1. Une sonde simple, pour mesurer une valeur absolue à l'emplacement de la sonde, ou
  2. Une sonde différentielle, pour mesurer la différence entre les deux emplacements de sonde. 

Les deux types de sondes se placent en cliquant sur le bouton  dans la zone Probes du panneau. Pour placer une sonde simple, cliquez à l'emplacement souhaité, puis faites un clic droit (ou appuyez sur Esc). Pour placer une sonde différentielle, cliquez une fois pour définir le premier emplacement de sonde, puis une seconde fois pour définir le deuxième emplacement. Une fois la sonde définie, les résultats de mesure s'affichent dans le panneau.

Lors du placement d'une sonde, les mêmes fonctions d'accrochage s'appliquent que lors du placement d'autres objets de conception dans l'éditeur PCB. Pour plus d'informations sur le système unifié d'accrochage du curseur, consultez la page Utilisation du système d'accrochage du curseur.

Cliquez sur le bouton  pour créer une image du PCB à l'emplacement de la dernière sonde sur laquelle vous avez cliqué. L'image s'affiche dans la zone Image Captures du panneau, identifiée par un badge Probe. Survolez la capture d'écran avec le curseur pour afficher les détails de la sonde (voir l'image). 

Les sondes peuvent mesurer la tension ou le courant, en valeur absolue ou comme différence entre deux emplacements. Survolez l'image avec le curseur pour afficher une sonde de courant.Les sondes peuvent mesurer la tension ou le courant, en valeur absolue ou comme différence entre deux emplacements. Survolez l'image avec le curseur pour afficher une sonde de courant.

Si la conception est modifiée de quelque manière que ce soit, les sondes existantes doivent être supprimées () et de nouvelles sondes doivent être placées.

Captures d'image

La fonction de capture d'image du panneau Power Analyzer by Keysight permet de réaliser une capture d'écran du net sélectionné, propre à la conception, qui pourra ensuite être incluse dans un rapport.

Pour capturer une zone précise de la carte, ajustez d'abord la vue de la carte dans l'espace de conception principal afin que les éléments à inclure dans la capture soient visibles. Lorsque vous êtes prêt, cliquez sur le bouton   dans la zone Image Captures du panneau pour effectuer la capture d'écran. Vous pouvez continuer à modifier la vue de la carte et Add d'autres images. Pour supprimer une image, survolez-la avec le curseur afin de faire apparaître le bouton  , puis cliquez une fois dessus.

Les captures d'image ne sont pas conservées avec le projet. Pour enregistrer les images, générez un rapport d'analyse.

Rapport d'analyse

Pour générer un rapport d'analyse complet, cliquez sur le bouton  en haut du document d'analyse. Le rapport complet comprend une section pour chaque net d'alimentation du réseau, comme illustré dans l'image ci-dessous. 

Dans le rapport, cliquez sur un net d'alimentation pour afficher un rapport détaillé le concernant, comprenant :

  • Les paramètres de configuration globaux
  • L'empilage des couches de la carte
  • Les cartes thermiques de densité de courant pour chaque couche de signal
  • Les cartes thermiques de chute de tension pour chaque couche de signal
  • L'arborescence du réseau d'alimentation, mettant en évidence le net choisi.
  • Les détails de l'analyse du net choisi, notamment : la consommation électrique ; les détails des marges et des résultats de réussite/échec ; un récapitulatif détaillé des performances de tous les vias de ce net ; toutes les captures d'écran définies par l'utilisateur.

  • Cliquez sur le bouton  pour enregistrer le rapport au format HTML. Utilisez la boîte de dialogue Save Report Settings qui s'affiche ensuite pour choisir les réseaux et les données spécifiques à inclure dans le rapport.
  • Le rapport est enregistré dans un sous-dossier du dossier du projet, nommé \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime>.
  • Toutes les images du rapport sont enregistrées dans un sous-dossier \Images.
  • Plusieurs fichiers journaux sont également générés pendant l'analyse ; ils sont eux aussi enregistrés dans un sous-dossier du dossier du projet, nommé \PowerAnalyzerByKeysight_Output\<BoardName>\.

Conditions requises pour la reconnaissance automatique

Outre l’ajout manuel de nets d’alimentation, Power Analyzer by Keysight permet de reconnaître et d’ajouter automatiquement les nets d’alimentation, y compris les sources et les charges, ce qui réduit le temps nécessaire à la définition d’une structure d’alimentation.

Paramètres de définition automatique

Avant de lancer la reconnaissance automatique, vous devez configurer les paramètres de l’algorithme en fonction de votre projet. Ces paramètres se configurent dans la section Auto-Define Settings de la section Configuration de la fenêtre du document Power Analyzer by Keysight.

Les composants qui ne répondent pas à ces critères de définition automatique sont traités comme des charges normales. Vous pouvez également ajouter des paramètres nommés à chaque composant du schéma afin de définir son type et ses propriétés dans le système d’alimentation. Ces paramètres peuvent être spécifiés lors de la création du composant ou ajoutés ultérieurement dans le schéma.

Paramètres des composants

Pour une reconnaissance correcte, tous les composants liés à l’alimentation doivent respecter les critères suivants :

  • Pour qu’un composant source soit détecté automatiquement, il doit posséder un paramètre nommé Component Type, dont la valeur est Source.

  • Si ce paramètre est introuvable, la recherche s’appuie sur les Default Connectors Designators, définis dans la zone Auto-Define Settings de la section Configuration du document de l’analyseur (*.pdnaK). Notez que seuls les connecteurs comportant des connexions d’alimentation seront définis, sauf s’ils sont référencés comme faisant partie d’un net étendu.
  • Modules de régulation de tension (VRM) :
    • Les régulateurs linéaires doivent posséder un paramètre nommé Component Type, dont la valeur est VRM.
    • Pour un régulateur VRM de type SMPS, le paramètre Component Type doit avoir la valeur SMPS.
    • Si le VRM comprend une fonction de mesure de tension (Sense), le paramètre Component Type doit avoir la valeur Sense.

  • Si le paramètre n’est pas défini, la recherche s’appuie sur les VRM Keywords définis dans la zone Auto-Define Settings de la section Configuration du document de l’analyseur. Par défaut, ces mots-clés sont : PWR, REG, Regulator, Voltage, Switch.

  • La consommation du composant (charge) doit être définie à l’aide d’un paramètre nommé Current Consumption. Faites attention au séparateur décimal utilisé dans la valeur : il peut s’agir d’un point ou d’une virgule, selon les préférences du système.

Si un composant possède le paramètre Current Consumption, la valeur spécifiée est répartie entre toutes les broches connectées au même circuit.

Synchronisation des paramètres

Tous les paramètres doivent être synchronisés entre le PCB et le schéma. Pour le vérifier, sélectionnez un composant sur le PCB et assurez-vous que les paramètres d’analyse de l’alimentation figurent dans l’onglet Parameters du panneau Properties.

Exigences de conception

  • Tous les nets d’alimentation doivent être définis :
    • à l’aide d’un objet Power Port,
    • en configurant la propriété Power Net afin que le net inclue le Supply Net Parameter (comme décrit ci-dessous),
    • ou en leur attribuant un nom détectable par le Name Mask (défini dans la zone Auto-Define Settings de la section Configuration du document de l’analyseur).
  • Pour obtenir une valeur de tension à l’aide du Name Mask, le nom du net d’alimentation doit respecter le format *V* ou *.*V, où * est une valeur numérique, comme illustré ci-dessous.

  • Une autre manière de définir la valeur de tension du net d’alimentation consiste à configurer la propriété Power Net, définie dans le panneau Properties pour n’importe quel fil du net. Pour activer cette propriété, placez d’abord une directive de jeu de paramètres (Parameter Set) (Place » Directives » Parameter Set) sur le net (survolez l’image ci-dessous avec le curseur pour afficher une illustration de cette procédure). La taille, la couleur et le libellé sont définis par l’utilisateur ; c’est la présence de la directive qui active la propriété Power Net de ce net. Une fois la directive ajoutée, sélectionnez un fil de ce net, activez la propriété Power Net et configurez le Voltage du net, comme illustré ci-dessous. 

  • Les composants en série doivent respecter les désignateurs définis pour les résistances, les inductances et les composants en série personnalisés (tels que définis dans la zone Auto-Define Settings de la section Configuration du document de l’analyseur).

  • Les VRM doivent être connectés à au moins deux nets d’alimentation.

Commandes de Power Analyzer

Les commandes suivantes sont disponibles dans les menus principaux de l’éditeur Power Analyzer.

Commande

Résumé et utilisation

Tools » Define Automatically

Tente de reconnaître automatiquement la topologie du projet en fonction des paramètres actuels de la zone Auto-Define Settings de la section Configuration du document de l’analyseur (*.pdnaK). Cette commande est également accessible en cliquant sur le bouton Define Automatically en haut à gauche de l’éditeur.

File » Load from File

Charge un document Power Analyzer by Keysight enregistré (*.pdnaK) dans l’éditeur Power Analyzer.

Edit » Manage Nets

Ouvre la boîte de dialogue Manage Nets, dans laquelle vous sélectionnez les nets d’alimentation à analyser. Cocher un net l’ajoute au document de l’analyseur (*.pdnaK). Décocher un net le supprime du document, ainsi que tous ses nets d’alimentation enfants. Cette commande est également accessible en cliquant sur le bouton Manage Nets en haut à gauche de l’éditeur. En savoir plus sur la gestion des nets.

File » Save

Enregistre la configuration actuelle de Power Analyzer dans un document Power Analyzer by Keysight (*.pdnaK).

File » Save As

Enregistre la configuration actuelle de Power Analyzer dans un document Power Analyzer by Keysight (*.pdnaK) sous un nouveau nom défini par l’utilisateur.

Tools » Measurement Units » mil

Configure Power Analyzer pour utiliser les unités de mesure impériales (mils).

Tools » Measurement Units » mm

Configure Power Analyzer pour utiliser les unités de mesure métriques (mm).

Limitations de Power Analyzer

À ce stade, Power Analyzer by Keysight ne prend pas en charge :

  1. Les tensions négatives.
  2. Les composants enfouis (composants placés sur une couche interne). En savoir plus sur la conception d’un PCB avec des composants enfouis.

 

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents