SI Analyzer by Keysight
En un coup d'œil
- Découvrez les fonctions de l’extension SI Analyzer by Keysight dans Altium Designer et les types de vérifications d’intégrité du signal qu’elle prend en charge.
- Apprenez à installer l’extension, à ouvrir un document SI Analyzer, à ajouter des nets ou des classes et à attribuer des spécifications prédéfinies ou personnalisées.
- Comprenez le processus de base pour préparer les contraintes et les données d’analyse afin de pouvoir ensuite effectuer des vérifications d’intégrité du signal sur votre conception.
De plus en plus d’appareils électroniques modernes intègrent des circuits imprimés à haute vitesse, et les vitesses des signaux augmentent à mesure que les technologies évoluent (17 GHz pour la DDR6, 400 Gbit/s pour le QSFP++, etc.). Garantir l’intégrité du signal (SI) est une étape cruciale de la conception à haute vitesse. Le non-respect des exigences du développeur de l’interface risque fortement de provoquer des problèmes lors des étapes ultérieures de conception et de fabrication, ainsi que des problèmes de performances.
Pour effectuer une analyse de l’intégrité du signal directement dans l’environnement Altium Designer, la solution SI Analyzer by Keysight est disponible. Proposé sous forme d’extension logicielle, le SI Analyzer by Keysight s’intègre directement à Altium Designer pour permettre d’effectuer une série de vérifications SI après routage, couvrant les paramètres les plus importants de la conception à haute vitesse :
-
Impédance
-
Retard
-
Pertes d’insertion (IL)
-
Pertes de retour (RL)
Accès aux fonctionnalités du SI Analyzer by Keysight
Pour accéder aux fonctionnalités du SI Analyzer by Keysight dans Altium Designer, l’extension logicielle SI Analyzer by Keysight doit être installée. Cette extension peut être installée ou supprimée manuellement.
Pour plus d’informations sur la gestion des extensions, consultez la page Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).
Lorsque l’extension logicielle SI Analyzer by Keysight est installée, elle permet de :
-
Créer un document SI Analyzer by Keysight ou en ouvrir un existant.
-
Ajouter et configurer des nets pour une analyse SI.
-
Consulter les résultats d’analyses SI existantes.
-
Générer un rapport d’analyse SI.
Toutefois, pour effectuer une nouvelle analyse SI, vous devez disposer d’un abonnement valide au SI Analyzer by Keysight. Sinon, toute tentative de lancement d’une analyse SI ouvrira la boîte de dialogue Analyze Your Nets, dans laquelle vous pourrez demander un essai gratuit
Lancement du SI Analyzer by Keysight
Pour démarrer une analyse de l’intégrité du signal, ouvrez le document PCB du projet et sélectionnez Tools » SI Analyzer by Keysight dans les menus principaux.
Le document SI Analyzer by Keysight (<ProjectName> [SIK]) s’ouvre et est ajouté à la zone Source Documents du projet (dans le panneau Projects). Le document n’est pas enregistré initialement. Utilisez la commande File » Save As des menus principaux pour enregistrer le document à l’emplacement souhaité.
Préparation de l’analyse
Ajout des nets à analyser
Après le lancement du SI Analyzer by Keysight, les données du PCB sont importées (au format ODB++) dans le solveur. À ce stade, vous pouvez définir la liste des nets à analyser et leur attribuer des spécifications. Pour cela, cliquez sur le bouton Manage Nets en haut du document SI Analyzer by Keysight ou utilisez la commande Edit » Manage Nets des menus principaux (si le document ne contient aucun net, le bouton Manage Nets est également disponible au centre du document). La boîte de dialogue Manage Nets s’ouvre et présente la liste des classes de nets, de paires différentielles et de xSignals du PCB.
Cochez la case de chaque classe souhaitée (ou utilisez la case à cocher dans l’en-tête du tableau pour sélectionner toutes les classes). Vous pouvez également cliquer sur la cellule de la colonne Specifications pour afficher une fenêtre contextuelle et sélectionner les spécifications souhaitées, qui définiront les contraintes de la classe sélectionnée (ces contraintes peuvent être redéfinies ultérieurement si nécessaire – en savoir plus). Vous pouvez choisir parmi les spécifications intégrées ou définies par l’utilisateur (onglet Specifications de la fenêtre contextuelle) ou définir manuellement les valeurs de contrainte requises pour une classe (onglet Custom Constraints de la fenêtre contextuelle).
Consultez la section Gestion des spécifications pour en savoir plus sur la gestion des spécifications intégrées ou définies par l’utilisateur.
Vous pouvez également développer la liste All Nets au bas de la boîte de dialogue pour sélectionner des nets individuels de la conception et leur attribuer des spécifications.
Après avoir cliqué sur OK dans la boîte de dialogue, les classes sélectionnées s’affichent dans le document SI Analyzer by Keysight. Si un net a été sélectionné dans la zone All Nets de la boîte de dialogue Manage Nets, il s’affichera dans l’entrée de classe All Nets. Développez une entrée de classe pour afficher ses nets/xSignals.
Développez l’entrée d’un net/xSignal ou d’une paire différentielle pour afficher les objets qui le constituent (pastilles, pistes, arcs et vias) dans la zone Transmission Line. Placez le curseur sur la vignette d’un objet et cliquez sur l’icône
pour localiser cet objet dans le PCB par sélection croisée.
Pour supprimer une classe ou un net ajouté individuellement du document, cliquez sur le bouton
à droite de son entrée.
Gestion des spécifications
La boîte de dialogue Manage Specifications, accessible en cliquant sur le bouton Manage Specifications en haut du document SI Analyzer by Keysight, permet de gérer les spécifications intégrées et celles définies par l’utilisateur. Les spécifications peuvent ensuite être attribuées à une classe ou à un net pour en définir rapidement les contraintes, comme décrit dans la section précédente.
-
La partie gauche de la boîte de dialogue présente la liste des spécifications actuellement définies. Chaque spécification est présentée avec son nom et le ou les types de contraintes qu’elle définit.
- Sélectionnez une spécification dans la liste pour afficher ses détails (nom, type de spécification Built-In ou User-Defined, et contraintes) dans la partie droite de la boîte de dialogue.
-
Pour créer une spécification, cliquez sur le bouton Add New en bas à gauche de la liste des spécifications. La partie droite de la boîte de dialogue affiche alors les commandes permettant de définir la spécification :
-
Définissez le nom de la nouvelle contrainte à l’aide du champ Specification Name.
-
Sélectionnez les types de contraintes que cette spécification doit définir à l’aide des cases à cocher : Impedance, Delay, Insertion Losses (IL) et/ou Return Losses (RL).
-
Pour les types de contraintes activés, définissez les valeurs correspondantes. Pour les contraintes de type Impedance et Delay, utilisez les champs de texte fournis. Pour les contraintes de type Insertion Losses (IL) et Return Losses (RL), vous pouvez ajouter, modifier et supprimer des limites afin de délimiter les valeurs de pertes autorisées et interdites dans la plage de fréquences souhaitée.
-
Une fois la spécification définie selon vos besoins, cliquez sur le bouton Save en haut de la partie droite de la boîte de dialogue pour la créer, ou cliquez sur Cancel pour quitter sans la créer.
-
-
Vous pouvez également créer une spécification en dupliquant une spécification existante (définie par l’utilisateur ou intégrée). Sélectionnez la spécification à dupliquer dans la liste, puis cliquez sur le bouton Duplicate en bas à gauche de la liste des spécifications. Une nouvelle spécification, initialement nommée
<OriginalSpecificationName>(Copy)et possédant les mêmes contraintes que l’originale, est créée et prête à être modifiée dans la partie droite de la boîte de dialogue. Effectuez les modifications souhaitées et cliquez sur le bouton Save en haut pour créer la spécification, ou cliquez sur Cancel pour quitter sans la créer. -
Pour modifier une spécification définie par l’utilisateur, sélectionnez-la dans la liste, puis cliquez sur le bouton
dans la partie droite de la boîte de dialogue. Effectuez les modifications souhaitées et cliquez sur le bouton Save en haut pour les enregistrer, ou cliquez sur Cancel pour quitter sans appliquer de modifications.
-
Pour supprimer une spécification (définie par l’utilisateur ou intégrée), sélectionnez-la dans la liste, puis cliquez sur le bouton
dans la partie droite de la boîte de dialogue.
- Les spécifications intégrées supprimées peuvent être restaurées en faisant un clic droit dans la liste des spécifications et en sélectionnant la commande Restore Built-In Spec. Cette commande n’affecte pas les spécifications définies par l’utilisateur.
Définition des contraintes
Chaque net est analysé pour vérifier s’il respecte les contraintes spécifiées. Si une spécification a été sélectionnée pour la classe parente, les contraintes sont définies par cette spécification.
Pour consulter les contraintes actuelles d’un net/xSignal ou d’une paire différentielle, sélectionnez l’onglet Constraints après avoir développé son entrée.
Cliquez sur la valeur d’une contrainte pour la modifier dans la fenêtre contextuelle qui s’affiche.
Notez que si la valeur d’une contrainte a été modifiée manuellement, le message d’avertissement Custom constraints are used s’affiche dans l’entrée correspondante.
Exécution d’une analyse
Une fois la configuration terminée, vous pouvez lancer une analyse pour tous les nets ajoutés, une classe spécifique ou un net spécifique. Cliquez sur le bouton Analyze All en haut à droite du document SI Analyzer by Keysight pour analyser tous les nets, ou sur le bouton Analyze de l’entrée d’une classe ou d’un net spécifique pour analyser uniquement cette classe ou ce net.
Consultation des résultats
Une fois l’analyse terminée, ses résultats sont présentés dans le document SI Analyzer by Keysight. Le message Analyzed s’affiche en haut à droite du document. Si tous les nets analysés respectent les contraintes, le texte All Passed s’affiche à côté du message. Dans le cas contraire, le texte Failed s’affiche, accompagné du nombre de nets qui ne respectent pas les contraintes.
Si tous les nets d’une classe réussissent l’analyse, le texte Success s’affiche pour son entrée. Dans le cas contraire, le texte Failed s’affiche.
Développez l’entrée d’une classe pour afficher les valeurs calculées (impédance, délai, pertes d’insertion et pertes de retour) pour chaque net analysé de cette classe. Les valeurs qui respectent les contraintes sont affichées en vert ; celles qui ne les respectent pas sont affichées en rouge.
Développez l’entrée d’un net pour afficher ses valeurs calculées dans l’onglet Results. De plus, les vignettes des objets du net qui ne respectent pas les contraintes sont encadrées en rouge dans la zone Transmission Line, et la valeur non conforme est affichée en rouge.
Pour afficher les résultats d’analyse d’une classe ou d’un net/xSignal/d’une paire différentielle du PCB, cliquez sur le bouton Show on PCB correspondant.
Le panneau SI Analyzer by Keysight
Dans l’éditeur de PCB, le processus d’analyse et les résultats sont gérés depuis le panneau SI Analyzer by Keysight. Notez que ce panneau est ajouté à la liste des panneaux disponibles (via le bouton Panels) après qu’une analyse de l’intégrité du signal a été effectuée et que le bouton Show on PCB a été activé.
Signal simulé
- Simulated Signal – permet de sélectionner la classe ou le net/xSignal/la paire différentielle à afficher sous forme de carte thermique dans l’espace de conception.
- Only nets with violations – lorsque cette option est activée, seules les entités présentant actuellement une violation sont disponibles dans la liste déroulante. Désactivez cette option pour répertorier toutes les entités analysées.
- Show Heatmap – lorsque cette option est activée, une carte thermique est affichée dans l’espace de conception pour l’entité actuellement sélectionnée dans la liste déroulante Simulated Signal.
Sous ces commandes, le panneau comporte deux onglets, General et Heatmap. Les options de ces onglets s’appliquent à l’entité actuellement sélectionnée dans la liste déroulante Simulated Signal.
Carte thermique
L’onglet Heatmap du panneau SI Analyzer by Keysight permet de choisir les données présentées sous forme de carte thermique, à savoir l’impédance ou le délai, ainsi que la manière dont les couleurs sont appliquées à l’impédance ou au délai. Notez que ces commandes de réglage de la carte thermique ne sont disponibles que lorsque l’option Show Heatmap est activée.
Utilisez les boutons Impedance et Delay pour basculer entre les deux modes. Le net entier est coloré pour refléter l’impédance ou le délai en chaque point du net, comme suit :
- Pour l’impédance, plus celle-ci est proche de la valeur cible Z0, plus la couleur est verte ; plus elle s’en éloigne, plus la couleur est rouge. Les valeurs calculées inférieures au minimum ou supérieures au maximum sont affichées en rouge.
- Pour le délai, plus celui-ci est élevé, plus la couleur est chaude (rouge) ; plus il est faible, plus la couleur est froide. Les valeurs calculées inférieures au minimum sont affichées en bleu, et celles supérieures au maximum sont affichées en rouge.
L’échelle de couleurs indique la manière dont les couleurs sont appliquées. Les valeurs minimale et maximale peuvent être ajustées en faisant glisser le curseur ou en saisissant une nouvelle valeur dans les champs situés en dessous. L’échelle est également affichée sous forme de barre de couleurs dans l’espace de conception, sous le PCB.
Activez l’option Color focus on results pour mettre en surbrillance l’entité actuellement sélectionnée dans la liste déroulante Simulated Signal et masquer les autres objets du PCB.

Exemple de carte thermique affichée pour les calculs d’impédance.

Exemple de carte thermique affichée pour les calculs de délai.
Détection des violations
Si l’analyse détecte des violations de contraintes pour l’entité actuellement sélectionnée dans la liste déroulante Simulated Signal, celles-ci sont répertoriées dans la zone Violations de l’onglet General du panneau SI Analyzer by Keysight.
- Utilisez les boutons en haut de la zone pour définir les types de violations à afficher dans la liste.
- Utilisez le bouton Analyze en bas de la zone pour relancer l’analyse de l’intégrité du signal. Cela permet de vérifier rapidement si l’entité respecte la contrainte après l’application de modifications dans l’éditeur de PCB, sans revenir au document SI Analyzer by Keysight.
Sondes
La zone Probes du panneau SI Analyzer by Keysight permet de placer des sondes de mesure directement sur le PCB. Les sondes peuvent mesurer l’impédance ou le délai ; le type de mesure est déterminé par le mode actuel de la carte thermique du circuit.
Il peut s’agir d’une sonde simple, pour mesurer une valeur absolue à l’emplacement de la sonde, ou d’une sonde différentielle, pour mesurer la différence entre les deux emplacements de sonde. Les deux types de sondes se placent en cliquant sur le bouton Add dans la zone Probes du panneau. Pour placer une sonde simple, cliquez à l’emplacement souhaité, puis faites un clic droit (ou appuyez sur Esc). Pour placer une sonde différentielle, cliquez une première fois pour définir le premier emplacement de sonde, puis une seconde fois pour définir le deuxième. Une fois la sonde définie, les résultats de mesure s’affichent dans le panneau.

Exemple de sonde différentielle
Cliquez sur une entrée de sonde dans le panneau pour afficher son ou ses emplacements sur le PCB. Sélectionnez une entrée de sonde dans le panneau et cliquez sur le bouton
en bas de la zone pour supprimer la sonde.
Cliquez sur le bouton Add to Report pour créer une image du PCB à l’emplacement de la sonde sélectionnée. L’image s’affiche dans la zone Image Captures du panneau, identifiée par une pastille Probe. Survolez la capture d’écran avec le curseur pour afficher les détails de la sonde.
Captures d’écran
La fonction de capture d’écran du panneau SI Analyzer by Keysight permet de capturer une vue propre à la conception, qui peut ensuite être incluse dans un rapport.
Pour capturer une zone précise du circuit, commencez par ajuster la vue du circuit dans l’espace de conception afin que les éléments à inclure dans la capture soient visibles. Lorsque la vue est prête, cliquez sur le bouton Add dans la zone Image Captures du panneau pour effectuer la capture d’écran. Vous pouvez continuer à modifier la vue du circuit et ajouter d’autres images.
Pour supprimer une image, survolez-la avec le curseur afin de faire apparaître le bouton
, puis cliquez dessus.
Rapport des résultats
Pour générer un rapport d’analyse complet, cliquez sur le bouton Full Report en haut du document SI Analyzer by Keysight. Le rapport complet comprend une section pour chaque classe (ainsi que l’entrée All Nets pour les nets ajoutés individuellement en dehors des classes de nets).
Dans le rapport complet, cliquez sur le nom d’une classe de nets (ou sur le nom du net dans la liste All Nets) pour afficher un rapport détaillé comprenant :
- Le nom de la classe de nets ou du net.
- La ou les spécifications attribuées.
- Un récapitulatif de la vérification des contraintes. Cliquez sur une vérification ayant échoué pour afficher des recommandations permettant de résoudre les problèmes associés.
- L’empilage des couches de la carte.
- Les vérifications des contraintes pour chaque net. Développez l’entrée d’un net pour afficher les vérifications des contraintes pour chacun de ses objets.
- Le graphique des pertes d’insertion.
- Le graphique des pertes de retour.
Lorsque vous consultez un rapport détaillé, cliquez sur le bouton Show on PCB pour ouvrir le PCB et le panneau SI Analyzer by Keysight afin d’explorer la classe ou le net.
Utilisation des graphiques
Les graphiques des pertes d’insertion et des pertes de retour affichent les courbes correspondantes pour chaque net de la classe examinée. La zone rouge du graphique indique la zone interdite définie par les contraintes.
-
Utilisez la liste déroulante en haut à droite du graphique des pertes d’insertion ou des pertes de retour pour gérer les nets affichés. Vous pouvez afficher tous les nets, les nets dont les vérifications ont échoué ou certains nets spécifiques.
-
Cliquez sur le nom d’une courbe à droite du graphique pour la mettre en évidence en estompant les autres courbes. Cliquez à nouveau sur le nom de la courbe pour supprimer la mise en évidence.
-
Faites tourner la molette de la souris pour zoomer autour de la position du pointeur sur un graphique. Lorsque le pointeur se trouve sur un axe du graphique, faites tourner la molette pour zoomer uniquement autour de la position du pointeur sur cet axe (l’échelle de l’autre axe ne changera pas).
-
Vous pouvez effectuer des mesures à l’aide des curseurs de mesure. Deux curseurs sont disponibles et peuvent être ajoutés à une même courbe ou à des courbes différentes d’un graphique. Faites un clic droit sur le nom d’une courbe à droite du graphique et utilisez les commandes Cursor A et Cursor B du menu contextuel pour activer ou désactiver les curseurs. Déplacez le curseur en cliquant sur son onglet et en le faisant glisser. Les données mesurées par un curseur activé s’affichent en bas du graphique.

Exemple de curseurs A et B ajoutés à la même courbe.
Exportation du rapport
Cliquez sur le bouton Save Report pour enregistrer le rapport au format HTML. Dans la boîte de dialogue Report Settings qui s’ouvre ensuite, sélectionnez les nets (si vous accédez à cette boîte de dialogue depuis le rapport complet) et les données spécifiques à inclure dans le rapport.
Après avoir cliqué sur le bouton Generate Report, le rapport est enregistré dans un sous-dossier du dossier du projet nommé \SiAnalyzerByKeysight_Output\HTMLReport\<ProjectName>.sik_<CurrentDate>_<CurrentTime>. Toutes les images du rapport sont enregistrées dans un sous-dossier \Images.
).
).

).
. Si un net fait partie d’une paire différentielle, il est ajouté au document SI Analyzer by Keysight avec le net qui lui est associé, sous forme de paire différentielle, et son entrée porte l’icône
.













