Panneau Navigateur
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Découvrez comment le panneau Navigator vous permet de parcourir les feuilles de schéma individuelles, l’ensemble du projet et la hiérarchie de la conception pour trouver rapidement les objets connectés.
- Apprenez à naviguer dans les deux sens, du panneau vers le schéma et du schéma vers le panneau, et découvrez dans quels cas un Alt-clic peut vous aider à localiser les éléments associés sur le PCB.
- Comprenez comment la mise en surbrillance, le zoom, l’atténuation visuelle et la validation influencent l’affichage pendant la navigation, afin de mieux suivre les connexions dans les conceptions complexes.
Si la conception est volumineuse et répartie sur de nombreuses feuilles, il peut devenir difficile de suivre un net et de vérifier la connectivité de la conception en examinant simplement les schémas. Localiser ces mêmes objets sur le PCB représente un défi encore plus important. Pour faciliter cette tâche, utilisez le panneau Navigator.

Utilisez le panneau Navigator pour obtenir une vue d'ensemble de la conception. Maintenez Alt enfoncé lorsque vous cliquez dans le panneau pour localiser également cet élément sur le PCB.
Le panneau Navigator vous permet de parcourir soit le document schématique source actif, soit tous les documents schématiques sources du projet actif. Le panneau s'appuie sur le modèle de connectivité de la conception, créé automatiquement en arrière-plan, pour assurer la navigation. Il permet également d'accéder aux composants, aux pastilles, aux bus et aux nets sur le PCB.
Navigation dans la conception
La navigation peut s'effectuer de deux manières : en cliquant dans le panneau Navigator pour localiser l'objet dans le schéma, ou en cliquant sur l'objet dans le schéma pour le localiser dans le panneau Navigator.
Depuis le panneau Navigator
Pour afficher le panneau Navigator, utilisez le bouton Panels en bas à droite du logiciel, ou sélectionnez View » Panels » Navigator dans les menus.
Les informations sur les composants et la connectivité sont chargées dans le panneau dès qu'un schéma est ouvert. Cliquez sur une icône dans la section Documents pour les afficher. Le logiciel crée automatiquement un modèle de données dynamique pour l'ensemble du projet et le met à jour au fil des modifications. Notez que les onglets des documents ne sont pas affichés (en haut de l'espace d'édition graphique) pour toutes les feuilles de schéma, car celles-ci sont ouvertes en arrière-plan. Un onglet n'apparaît que lorsqu'une action utilisateur est effectuée sur la feuille correspondante.
Le modèle de données dynamique est disponible pour chacun des éditeurs, ainsi que pour le panneau Navigator. Si vous avez un doute sur la correspondance entre le contenu du panneau et l'état actuel de la conception, sélectionnez la commande Validate Project pour forcer l'actualisation du modèle (menu Project ou menu contextuel accessible par clic droit dans le panneau Navigator).

Cliquez sur un objet dans le panneau Navigator pour localiser toutes ses instances dans l'ensemble de la conception.
Navigation interactive
Outre la navigation à partir des listes d'objets du panneau, où un clic permet de localiser l'objet dans l'espace graphique, vous pouvez également naviguer de l'espace graphique vers la liste. Ce mode, appelé navigation interactive, s'active en cliquant sur le bouton Interactive Navigation en haut du panneau Navigator. Le curseur prend la forme d'un réticule, indiquant que vous êtes en mode navigation. Ce mode reste actif jusqu'à ce que vous cliquiez avec le bouton droit ou appuyiez sur la touche Esc .
Lorsque vous naviguez dans une conception, l'affichage de la feuille est mis à jour selon les options de mise en évidence actuelles, et le panneau Navigator est actualisé pour afficher les informations relatives à votre sélection dans la fenêtre d'édition graphique.

Activez la navigation interactive (bouton en haut du panneau Navigator), puis cliquez sur un objet de la feuille pour le localiser dans le panneau et dans le reste de la conception.
Raccourci de navigation interactive
Outre l'activation de la navigation interactive depuis le panneau Navigator, vous pouvez lancer la navigation à tout moment dans l'éditeur de schémas : maintenez Alt enfoncé lorsque vous cliquez sur un objet de conception. Vous pouvez cliquer sur n'importe quel objet, notamment un fil, une étiquette de net, un port, une entrée de feuille, un symbole de feuille ou un composant.
Utilisez le raccourci Alt+clic pour naviguer dans votre conception.
Mise en évidence des objets pendant la navigation
Lorsque vous cliquez sur un objet dans le panneau Navigator, celui-ci s'affiche dans l'espace d'édition graphique. Son apparence dépend des paramètres Système - Navigation de la boîte de dialogue Preferences. Pour accéder directement à ces paramètres depuis le panneau Navigator, cliquez sur le bouton Navigation Options en haut du panneau afin d'ouvrir la boîte de dialogue.
La zone Highlight Methods de la boîte de dialogue Preferences propose des options permettant de contrôler le rendu visuel du filtrage temporaire appliqué au document lors de la navigation, aussi bien depuis le panneau que dans le document lui-même. Ces options peuvent être activées dans n’importe quelle combinaison. Par exemple, vous pouvez souhaiter zoomer sur tous les objets filtrés et les sélectionner dans la fenêtre de l’éditeur de conception, tout en atténuant les autres objets de la conception pour réduire l’encombrement visuel.
Le panneau Navigator
Le panneau Navigator offre une vue du modèle de connectivité de la conception. La structure de la conception est présentée dans les quatre sections du panneau, décrites ci-dessous.
Le panneau Navigator présente une vue de l’ensemble de la conception centrée sur la connectivité.
Section Documents
Située en haut du panneau, la section Documents propose trois façons de visualiser la conception : individual sheets, flattened hierarchy (l’ensemble du projet), ou la possibilité de parcourir full design hierarchy. Cliquez une fois sur une icône de cette première section pour charger les données dans le panneau ; double-cliquez pour afficher également les résultats dans l’espace d’édition graphique.
Fonctionnalités de la section Documents
Section Documents |
|
| Individual Sheets | Affiche une icône pour chacune des feuilles de schéma saisies, identifiée par Cliquez une fois pour afficher les résultats dans le panneau Navigator ; double-cliquez pour afficher également les résultats dans l’espace d’édition graphique. |
| Flattened Hierarchy (ensemble du projet |
Affiche tous les objets et toutes les connexions de l’ensemble du projet. Si la conception comporte des feuilles répétées (canaux), une icône enfant s’affiche pour chaque classe de canaux, identifiée par le nom du canal (dérivé de Cliquez une fois pour afficher les résultats dans le panneau Navigator ; double-cliquez pour afficher également les résultats dans l’espace d’édition graphique. |
| Full Design Hierarchy | Affiche une icône pour chaque feuille logique du projet. Si la conception comporte des feuilles répétées (canaux), une icône de feuille est présente pour chaque canal, identifiée par Cliquez une fois pour afficher les résultats dans le panneau Navigator ; double-cliquez pour afficher également les résultats dans l’espace d’édition graphique. Si vous double-cliquez sur l’icône d’un canal répété, la feuille de ce canal s’affiche et l’onglet du canal concerné est sélectionné en bas de l’espace d’édition du schéma. |
Section Composants
La deuxième zone du panneau contient tous les composants présents dans le document actuellement sélectionné dans la première section. Lorsque vous sélectionnez une entrée d’instance de composant de premier niveau dans la liste, un filtre est appliqué en fonction de cette entrée ; son rendu visuel est déterminé par les méthodes de mise en surbrillance choisies. Si les options de mise en surbrillance activées incluent l’option Connective Graph, tous les autres composants connectés au composant sélectionné sont visibles (le filtre étant étendu pour les inclure). Les composants connectés sont mis en évidence visuellement par les lignes de connexion vertes du graphe.
Le graphe de connectivité étant activé, une ligne verte est tracée vers chaque composant connecté au composant sélectionné dans le panneau.
Fonctionnalités de la section Composants
Section Composants |
|
| Information available | Chaque entrée de composant comporte des sous-dossiers pour Parameters et Implementations (modèles). Si l’option Pins est activée dans les options de mise en surbrillance, un sous-dossier Pins est également disponible |
| When you click | Lorsque vous cliquez sur une entrée de broche dans la liste Instance, l’entrée correspondante de cette broche est sélectionnée dans la section Net / Bus du panneau et toutes les broches du net auquel elle appartient sont répertoriées dans la section inférieure du panneau. Un filtre est également appliqué en fonction de l’entrée de broche choisie ; son rendu visuel est déterminé par les méthodes de mise en surbrillance activées. |
| Connective Graph | Si vous avez activé l’option Connective Graph, toutes les autres broches connectées au net auquel appartient la broche sélectionnée sont visibles (le filtre étant étendu pour les inclure). Le net auquel appartiennent les broches connectées est mis en évidence visuellement par les lignes de connexion rouges du graphe |
Section Nets / Bus
La troisième section du panneau répertorie chacun des nets et des bus du document (ou de la hiérarchie aplatie) parcouru. Lorsque vous cliquez sur une entrée, tous les objets associés au net/bus — broches, étiquettes de net, ports, entrées de feuille et connecteurs interfeuilles — s’affichent dans la fenêtre de l’éditeur de conception selon les méthodes de mise en surbrillance activées.
Fonctionnalités de la section Nets / Bus
Section Nets / Bus |
|
| Information available | Les différents types d’objets associés au net/bus sélectionné sont répertoriés dans des sous-dossiers, en fonction des options de mise en surbrillance actuellement activées et de la présence de ce type d’objet dans le net/bus sélectionné. Pour chaque net/bus, un sous-dossier supplémentaire peut répertorier les lignes graphiques utilisées pour relier les broches, ports, étiquettes de net, entrées de feuille et connecteurs interfeuilles associés. Cliquez sur une entrée de ligne pour filtrer uniquement cet objet ligne et appliquer les paramètres de contrôle visuel. |
| When you click | Tous les objets de net dont l’affichage a été activé dans le panneau (à l’exception des lignes graphiques) s’affichent dans la section inférieure du panneau Là encore, cliquer sur l’un de ces objets applique un filtrage selon les méthodes de mise en surbrillance activées. |
Section Nets du bus - Broches du net
Le contenu de la quatrième section du panneau dépend de deux éléments : l’objet que vous parcourez et les objets dont vous avez activé l’affichage. Si vous cliquez sur un bus dans la section Nets / Bus, les nets de ce bus sont répertoriés dans cette section du panneau. Si vous cliquez sur un net dans la section Nets / Bus, les broches de ce net sont répertoriées. Les identifiants de net rattachés à ce net sont également répertoriés si leur affichage est activé.
Section Signal
Le panneau Navigator permet de visualiser la conception selon une approche centrée sur les signaux, plutôt que selon l’approche centrée sur les objets qu’il utilise habituellement. Si un document schématique est sélectionné dans la section Documents du panneau, l’activation de l’option Show Signals en haut du panneau fait passer la troisième section du panneau en mode Signal.
Cliquez sur une entrée de signal pour appliquer un filtre : les nœuds de ce signal (broches, ports, étiquettes de net, entrées de feuille et connecteurs interfeuilles) s’affichent dans la fenêtre de l’éditeur de conception selon les méthodes de mise en surbrillance activées. Pour chaque signal de la liste, les broches de nœud, entrées de feuille ou connecteurs interfeuilles associés à ce signal sont répertoriés. Ces entrées s’affichent que l’option d’affichage correspondant à ce type d’objet soit activée ou non.
Fonctionnalités de la section Signal
Section Signal |
|
| Signal | Nom du signal (nom du bus ou du net). |
| Width | Nombre de nets distincts au sein de ce signal. |
| Click on a top-level signal entry | Cliquez sur une entrée de signal de premier niveau pour afficher dans la section inférieure du panneau tous les nœuds associés à ce signal. Il peut s’agir de broches, d’étiquettes de net, de ports, d’entrées de feuille et de connecteurs interfeuilles. Les entrées ne s’affichent que si l’option d’affichage correspondant à ce type d’objet est activée. |
| Click on a sub-entry | Cliquez sur une sous-entrée de la liste principale Signal pour afficher dans la section inférieure du panneau tous les objets de net associés au net parent de ce signal. |
| SignalName Driven By Pin X | S’affiche lorsqu’une broche de nœud associée à un signal est une broche de sortie ou d’E/S. X représente le désignateur de la broche du composant qui pilote le signal. |
| Driving Node Pin X | S’affiche lorsqu’une broche de nœud associée à un signal est une broche d’entrée. X représente le désignateur de la broche du composant qui est pilotée par le signal. |
| Driven By Node Sheet Entry SignalName | S’affiche lorsque le type électrique d’un nœud d’entrée de feuille est sortie ou E/S : l’entrée pilote le signal. |
| Driving Node Sheet Entry X | S’affiche lorsque le type électrique de l’entrée de feuille est entrée : l’entrée est alors pilotée par le signal. |
Navigation dans le PCB
Lorsque vous cliquez dans le panneau Navigator, vous pouvez non seulement accéder aux objets du schéma, mais aussi accéder simultanément à ces objets sur le PCB. Si vous maintenez la touche Alt enfoncée tout en cliquant sur un objet dans le panneau Navigator, les objets ciblés sont mis en surbrillance à la fois dans le schéma et sur le PCB.
Comme la navigation s’effectue toujours dans le schéma, vous devez afficher le schéma et le PCB simultanément pour accéder aux objets sur le PCB. Pour cela, vous pouvez afficher le PCB dans une fenêtre séparée ou partager l’espace graphique à l’aide de la fonctionnalité Split Vertical ou Split Horizonal (disposition verticale illustrée ci-dessous). Les commandes correspondantes sont disponibles dans le menu contextuel qui s’affiche lorsque vous cliquez avec le bouton droit sur un onglet de document.
Maintenez la touche Alt enfoncée lorsque vous parcourez votre conception pour localiser également ces objets sur le PCB.
Altium Designer propose plusieurs fonctionnalités permettant de travailler conjointement sur le schéma et le PCB, notamment :
| Cross probe | Navigation croisée — Cliquez avec le bouton droit pour l’activer, puis cliquez sur un objet (composant, broche, net) dans un éditeur pour accéder à cet objet dans l’autre éditeur. Deux modes sont disponibles : continuous (rester dans l’éditeur source) ou jump-to (rendre l’éditeur/document cible actif). Maintenez la touche Ctrl enfoncée pendant la navigation croisée pour activer le mode jump-to. La navigation croisée est prise en charge depuis les éditeurs de schéma, de PCB et de nomenclature, le Constraint Manager et les panneaux Project, Navigator et Messages. |
| Cross select | Cliquez pour sélectionner un composant dans un éditeur et le sélectionner également dans l’autre. Cette fonctionnalité est prise en charge entre les éditeurs de schéma et de PCB et s’active dans le menu View. |
En savoir plus sur la navigation croisée et la sélection croisée
Menu contextuel du panneau Navigator
Le menu contextuel du panneau Navigator, accessible par un clic droit, comprend les commandes suivantes :
)
)
).


).
).
).

).
