Utiliser la couleur pour mettre en évidence les nets

En un coup d'œil

Cet article explique comment la fonction de remplacement de la couleur des nets (Net Color Override) d’Altium Designer peut améliorer la lisibilité des schémas denses et des routages de PCB chargés en attribuant des couleurs aux nets et aux bus importants. Il décrit comment ajouter des couleurs dans les éditeurs de schémas et de PCB, les transférer entre le schéma et la carte, activer et désactiver cette fonction, et contrôler l’affichage des couleurs des nets routés dans l’espace de conception du PCB. Il présente également les principales limitations et les paramètres qui influencent l’affichage des couleurs, afin de vous éviter des surprises lors de l’utilisation de cette fonction. Si vous souhaitez suivre plus facilement les connexions critiques à mesure que votre conception se complexifie, poursuivez votre lecture.

- Découvrez comment appliquer, supprimer et gérer les couleurs des nets dans les éditeurs de schémas et de PCB.
- Comprenez comment les paramètres de couleur des nets sont transférés entre le schéma et le PCB, et quelles options du projet doivent être activées pour permettre ce transfert.
- Découvrez les différents motifs d’affichage des couleurs de remplacement des nets routés et leur comportement selon le niveau de zoom, pour mieux faire ressortir les nets critiques sur la carte.
Approfondissez avec l'IA :

À mesure que la conception progresse, elle devient rapidement dense et détaillée : le schéma se remplit de fils et la carte devient un labyrinthe de lignes de connexion et de nets routés. Pour améliorer la clarté et la lisibilité, le concepteur peut appliquer des couleurs aux fils du schéma, ainsi qu’aux lignes de connexion et aux pistes du PCB.

La possibilité de remplacer de manière sélective la couleur de certains nets est appelée Net Color Override. Des couleurs peuvent être appliquées aux nets du schéma, puis transférées au PCB. Elles peuvent également être définies directement dans l’éditeur de PCB.

L’image ci-dessous montre une conception complexe à haute vitesse utilisant les couleurs des nets pour permettre au concepteur d’identifier facilement des groupes de nets critiques. Plus bas sur cette page, une image montre la même carte avec et sans couleurs sur les nets routés.

Des couleurs ont été appliquées à des groupes de nets critiques, tant sur le schéma que sur la carte (image fournie par FEDEVEL Open Source, www.fedevel.com)
Des couleurs ont été appliquées à des groupes de nets critiques, tant sur le schéma que sur la carte (image fournie par FEDEVEL Open Source, www.fedevel.com)

Activez ou désactivez le remplacement des couleurs des nets dans chaque éditeur à l’aide du raccourci clavier F5.

Appliquer des couleurs aux nets du schéma

Une couleur de surbrillance peut être appliquée à un net ou à un bus dans l’éditeur de schémas à l’aide des commandes du sous-menu View » Set Net Colors, comme illustré ci-dessous. 

Net Color Override

Sélectionnez une commande correspondant à une couleur ou choisissez la commande Custom pour définir la couleur de surbrillance souhaitée pour les nets dans la boîte de dialogue standard Choose Color qui s’ouvre. Cliquez sur une broche, un fil, un bus ou un identifiant de net (étiquette de net, entrée de feuille, port, port d’alimentation ou connecteur hors feuille) pour appliquer la couleur sélectionnée à ce net (ou à tous les nets d’un bus). La commande reste active après le premier clic sur un net, afin de vous permettre d’appliquer la même couleur aux nets suivants si nécessaire.

  • Pour voir la surbrillance des nets, la fonctionnalité Net Color Override doit être activée. Si vous essayez d’appliquer une surbrillance aux nets alors que cette fonctionnalité est désactivée, la boîte de dialogue Net Color Override s’affiche : cliquez sur Yes pour l’activer. Vous pouvez également activer ou désactiver cette fonctionnalité à l’aide de la commande View » Show Net Color Override (F5), ou en cochant/décochant l’option Net Color Override sur la page Schéma - Édition graphique de la boîte de dialogue Preferences.
  • Lorsqu’un bus est mis en surbrillance, toutes les entrées de bus associées le sont également.
  • Pour appliquer une couleur à un net ou à un bus reliant deux symboles de feuille, ajoutez une étiquette de net sur le net ou le bus qui relie ces symboles.

    La couleur n’est pas appliquée aux broches des composants ni aux ports d’alimentation. Si aucune couleur n’apparaît sur cette section du net, éloignez-les l’un de l’autre pour ajouter un fil.

  • Cliquez sur le contour d’une directive Blanket pour mettre en surbrillance tous les segments de fils et de bus associés aux nets couverts par cette directive. Les nets formés par une connexion directe entre les broches de composants (par exemple, deux résistances en série) ou par une connexion directe entre une broche de composant et un port d’alimentation (par exemple, un condensateur relié à GND) ne seront pas mis en surbrillance.

Lorsqu’une couleur est appliquée à un net ou à un bus, elle remplace toute couleur précédemment définie. Notez que les réglages de couleur des nets ne peuvent pas être annulés. Pour supprimer une couleur, utilisez la commande Clear Net Color ou la commande Clear All Net Colors (sous-menu View » Set Net Colors).

La couleur est automatiquement appliquée à toutes les sections du net, sur toutes les feuilles de schéma du projet. Cette opération s’effectue automatiquement lorsque le compilateur en arrière-plan met à jour la connectivité de chaque feuille.

Où les réglages de couleur du schéma sont-ils enregistrés ?

Un net étant un objet compilé, déterminé à partir de la disposition actuelle des fils et des identifiants de nets, son réglage de couleur n’est pas enregistré avec les différents objets placés sur les feuilles. Les réglages de couleur sont en réalité enregistrés dans le fichier du projet en tant que paramètres propres aux nets. Ils sont appliqués à chaque feuille de schéma après son ouverture et sa compilation par le compilateur en arrière-plan.

► En savoir plus sur la création de la connectivité.

Transférer les couleurs entre le schéma et le PCB

Les couleurs des nets peuvent être transférées entre les éditeurs de schémas et de PCB (dans les deux sens) à l’aide de la commande Design » Update.

Si les couleurs ne sont pas transférées, vérifiez que les options suivantes sont activées dans la boîte de dialogue Options for Project :

Appliquer des couleurs aux nets du PCB

Dans l’éditeur de PCB, un net possède deux représentations : une ligne de connexion non routée ou un net routé défini par une série de segments de piste.

Les couleurs des nets sont toujours appliquées aux lignes de connexion. Les nets routés peuvent être affichés avec la couleur de la couche ou celle du net. L’affichage des couleurs des nets dans l’éditeur de PCB peut être contrôlé individuellement pour chaque net, ainsi qu’au niveau de l’éditeur. Ce point est détaillé ci-dessous.

Modifier la couleur d’un net dans l’éditeur de PCB

Lorsque la conception est transférée du schéma vers l’espace de travail PCB, des réglages de couleur par défaut sont appliqués à tous les nets. Toutes les lignes de connexion des nets reçoivent la couleur Connection Lines par défaut, définie dans la section System Colors de l’onglet Layers & Colors du panneau Configuration de l’affichage (raccourci L). Les couleurs des nets définies dans le schéma remplacent cette couleur par défaut.

Vous pouvez également définir de manière sélective la couleur des nets directement dans le panneau PCB, réglé sur le mode Nets :

  • Pour modifier la couleur d’un ou de plusieurs nets, sélectionnez les nets souhaités dans le panneau, puis faites un clic droit sur l’un des nets sélectionnés et choisissez la commande Change Net Color, comme illustré ci-dessous, ou
  • Pour un net individuel, double-cliquez sur son nom dans le panneau PCB pour ouvrir la boîte de dialogue Edit Net, dans laquelle vous pouvez modifier la couleur des lignes de connexion.

Dans le panneau PCB, faites un clic droit sur les nets sélectionnés pour modifier leur couleur.
Dans le panneau PCB, faites un clic droit sur les nets sélectionnés pour modifier leur couleur.

Comme le montre l’image ci-dessus, la couleur du net est affichée dans le panneau PCB, derrière la case à cocher située à gauche de son nom.

Cette case à cocher permet d’appliquer la couleur aux pistes. Ce point est détaillé ci-dessous.

La liste des nets peut être triée en cliquant sur n’importe quel en-tête de colonne, y compris celui de la colonne des cases à cocher activant le remplacement de couleur.

► En savoir plus sur le mode Nets du panneau PCB.

Afficher la couleur des nets sur les nets routés

Par défaut, les nets routés sont affichés dans la couleur de la couche sur laquelle les objets de routage ont été placés. Vous pouvez également utiliser la couleur du net pour les nets routés en activant la fonctionnalité de remplacement des couleurs des nets pour les nets concernés, ainsi que pour l’éditeur de PCB.

Le remplacement de couleur est activé pour le net YOUT ; les objets de ce net sont donc affichés avec un motif en damier.
Une couleur est définie pour le net YOUT_ALT, mais le remplacement de couleur n’est pas activé.

Pour utiliser la fonctionnalité de remplacement des couleurs des nets :

  1. Apply the required color to the net(s) - Faites un clic droit sur le net (ou les nets sélectionnés) dans le panneau PCB et utilisez la commande Change Net Color, comme expliqué précédemment sur cette page.
  2. Enable Color Override for the net(s) - la substitution de couleur est activée pour chaque net à l’aide de la case à cocher située à côté de son nom dans le panneau PCB, comme illustré pour le net YOUT dans l’image ci-dessus. Les cases à cocher peuvent être activées ou désactivées pour plusieurs nets sélectionnés à l’aide des commandes Right-click » Display Override » Selected On/Off.
  3. Configure the Color Override options - la couleur du net remplace celle de la couche conformément aux paramètres de substitution de couleur configurés sur la page PCB Editor - Board Insight Color Overrides de la boîte de dialogue Preferences, comme expliqué ci-dessous.
  4. Enable the Net Color Override feature - appuyez sur F5 pour activer ou désactiver globalement la fonction Net Color Override, ou utilisez le bouton de l’onglet Options d’affichage du panneau View Configuration .

Affichage de la substitution de couleur

L’éditeur PCB peut afficher la couleur de substitution de différentes façons : en remplaçant entièrement la couleur d’origine par la couleur choisie, ou en utilisant différents motifs de substitution. Ce comportement se configure sur la page PCB Editor - Board Insight Color Overrides de la boîte de dialogue Preferences.

L’option Base Pattern détermine l’affichage du routage lorsque vous zoomez. Les options de motif permettent de distinguer à la fois la couleur de la couche de routage et la couleur de substitution. Cela est utile lorsque vous suivez un net qui traverse plusieurs couches et que vous devez également savoir sur quelle couche il se trouve actuellement.

Lorsque vous dézoomez, ce comportement d’affichage peut :

  • être conservé à mesure que vous dézoomez (Base Pattern Scales), ou
  • laisser le motif s’estomper pour rétablir la couleur de la couche (Layer Color Dominates), ou
  • accentuer la couleur de substitution (Override Color Dominates).

Chacune des options Zoom Out Behavior est utile dans une situation différente.

Utilisez la fonction de substitution de couleur pour faire ressortir les nets routés.
Utilisez la fonction de substitution de couleur pour faire ressortir les nets routés.

L’affichage dans l’espace de travail de chaque net dont la case de substitution de couleur est cochée dépend des paramètres de substitution de couleur actuels. L’image ci-dessus en montre un exemple.

  • Vue agrandie - tout net dont la case de couleur de substitution est cochée s’affiche selon le Base Pattern choisi. Dans l’exemple ci-dessus, il s’agit d’un damier combinant la couleur de la couche et celle du net.
  • Vue réduite - le Zoom Out Behavior dans l’image ci-dessus est configuré pour que la couleur de substitution (celle du net) domine, comme le montre la petite image à droite.

L’image ci-dessous montre à quel point plusieurs groupes de nets critiques ressortent dans une conception de PCB à haute vitesse une fois qu’ils ont été identifiés par différentes couleurs. Dans cet exemple, le comportement lors du dézoom est réglé pour que la couleur de substitution domine. Survolez l’image avec le curseur pour afficher la même couche avec la substitution de couleur des nets désactivée.

Un excellent exemple d’utilisation de la substitution de couleur des nets pour identifier facilement des classes de nets dans une conception à haute vitesse. Survolez l’image pour désactiver la fonction de substitution.
(image fournie par FEDEVEL Open Source, www.fedevel.com)

 

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents