Création de la connectivité des circuits dans vos schémas

Altium Training

Altium Essentials: Creating Hierarchy

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

En un coup d'œil

Cet article explique comment établir la connectivité des circuits dans les schémas d’Altium Designer, en abordant aussi bien la connectivité physique au moyen de fils que la connectivité logique à l’aide d’étiquettes de nets et d’autres identificateurs de nets. Il présente également la manière dont la connectivité peut s’étendre à plusieurs feuilles de schéma selon la structure de votre conception, et met en avant des outils intégrés comme Connectivity Insight, qui vous permettent de visualiser, de suivre et d’explorer les relations entre les nets dans l’ensemble d’un projet. Vous découvrirez aussi un aperçu pratique des objets de schéma utilisés pour définir la connectivité, ainsi que les points essentiels concernant l’influence des noms et de la portée sur les connexions attendues entre les éléments. Si vous souhaitez mieux comprendre comment établir et vérifier la connectivité dans vos schémas, cet article constitue un excellent point de départ. Poursuivez votre lecture pour gagner en confiance dans votre processus de conception.

- Découvrez la différence entre connectivité physique et logique, et dans quels cas chaque approche est utile dans un schéma.
- Identifiez les objets de schéma qui établissent la connectivité, notamment les fils, les étiquettes de nets, les ports, les ports d’alimentation, les bus et les entrées de feuille.
- Comprenez comment Altium Designer vous aide à examiner et à explorer les connexions grâce à Connectivity Insight et aux outils associés de sélection et de mise en surbrillance.
Approfondissez avec l'IA :

Ce sont les composants et la manière dont ils sont connectés entre eux qui constituent votre circuit électronique unique. Dans le schéma, vous créez la représentation logique de votre conception en reliant les broches des composants entre elles ; pour concevoir le circuit imprimé, vous placez les composants physiques et reproduisez cette connectivité par le routage.

Si vous apprenez à structurer votre conception et à créer la connectivité, les pages suivantes pourront vous être utiles.

► En savoir plus sur la validation de votre projet de conception

► En savoir plus sur les conceptions multifeuilles et hiérarchiques

► En savoir plus sur la création d'une conception multicanal

► En savoir plus sur le regroupement de plusieurs nets en bus et faisceaux de signaux

► En savoir plus sur la synchronisation de la conception

Connectivité physique et logique

Dans le schéma, vous pouvez créer cette connectivité en traçant un fil d'un composant à un autre : c'est ce que l'on appelle la connectivité physique.

Vous pouvez également connecter une broche à une autre en plaçant un court fil et une étiquette de net sur chaque broche de composant. Le logiciel identifie ces deux sections de net et les relie pour former un seul net. Ce type de connectivité est appelé connectivité logique.

La connectivité physique permet à l'utilisateur de suivre chaque fil lorsqu'il étudie le circuit, mais un grand nombre de fils peut rendre le schéma dense et chargé. À l'inverse, les étiquettes de net réduisent la quantité de fils, mais l'utilisateur doit parcourir la feuille pour trouver toutes les connexions possibles. En tant que concepteur, vous êtes libre de choisir le modèle de connectivité qui convient le mieux à votre conception, y compris une combinaison des deux techniques.

Animated image showing the difference between physical connectivity and logical connectivity

Placez des fils pour créer une connectivité physique ou utilisez des étiquettes de net pour créer une connectivité logique.

Outre la création d'une connectivité logique within une feuille de schéma, il existe également des objets permettant de créer une connectivité logique between feuilles de schéma. La manière dont cette connectivité est créée dépend de la structure de votre schéma : soit une conception à plat, soit une conception hiérarchique. Vous trouverez plus de détails ci-dessous.

Plusieurs identificateurs de net peuvent être utilisés pour établir des connexions entre les feuilles.
Plusieurs identificateurs de net peuvent être utilisés pour établir des connexions entre les feuilles.

Connectivity Insight

La fonctionnalité Connectivity Insight d'Altium Designer (qui fait partie de la fonction Design Insight) offre une vue instantanée des relations de connexion au sein d'un projet. Présentés sous la forme d'une arborescence de documents avec des aperçus de schéma facultatifs, les éléments sélectionnables permettent de naviguer rapidement et visuellement dans la structure de connectivité d'un projet.

Dans sa configuration par défaut, la fonctionnalité Connectivity Insight affiche :

  • Les informations de connexion du net associé lorsque le curseur survole un objet de connectivité du schéma (fil, port, etc.).
  • Un aperçu de la connectivité sous forme d'arborescence lorsque Alt+Double-click est utilisé sur l'objet.

Cette capacité est complétée par une fonction accessible en survolant un objet appartenant à un net de signal, puis en appuyant sur Ctrl+Alt. Cela ouvre une arborescence dont les éléments peuvent être sélectionnés. Cliquez sur la feuille souhaitée dans l'arborescence pour accéder rapidement à ce document. 

Cette fonction peut être activée ou désactivée sur la page System - Design Insight de la boîte de dialogue Preferences en cochant ou décochant l'option Mouse Hover pour l'entrée Document Tree .

La connectivité d'un net dans l'ensemble d'une conception peut également être mise en surbrillance dans tous les schémas en maintenant la touche Alt enfoncée lors de la sélection d'un net par un clic sur un fil (Alt+Click).
Pour sélectionner tous les objets électriquement connectés à un point choisi du circuit, vous pouvez utiliser la commande Edit » Select » Connection des menus principaux ou la commande Select Connection du Active Bar. Après avoir cliqué sur un objet dont vous souhaitez sélectionner les objets électriquement connectés, tous les objets électriquement connectés à cet objet seront sélectionnés, et un filtrage sera appliqué pour estomper tous les autres objets de la feuille.

Objets utilisés pour créer la connectivité

L'éditeur de schémas comprend les objets suivants, qui servent à créer la connectivité. Ces objets sont collectivement appelés net identifiers.

Identificateur de net Fonction
Bus Sert à regrouper un ensemble de nets, par exemple Data[0..7]. Les nets doivent être nommés de manière séquentielle selon une convention de nommage spécifique (par exemple Data0, Data1,... Data7). Ce nommage détermine ensuite le nom du bus, par exemple Data[0..7].
Entrée de bus Élément graphique permettant de faire sortir deux nets différents de part et d'autre d'une ligne de bus sans créer de court-circuit entre eux. Il n'est pas nécessaire dans les autres situations.
Connecteur interfeuilles Sert à connecter un net d'une feuille de schéma à une autre (et non au sein d'une même feuille). Il prend uniquement en charge la connectivité horizontale (conceptions à plat). Les connecteurs interfeuilles offrent des fonctionnalités limitées par rapport aux ports.
Étiquette de net Identificateur de net utilisé pour établir une connectivité avec d'autres étiquettes de net portant le même nom sur la même feuille de schéma. Le net est automatiquement nommé d'après l'étiquette de net. Les étiquettes de net peuvent être placées sur les broches des composants, les fils et les bus. Notez que les étiquettes de net n'établissent pas de connexion entre les feuilles, sauf si les options du projet sont configurées pour utiliser un Net Identifier Scope de Global.
Broche Les broches sont placées dans l'éditeur de symboles schématiques pour représenter les broches physiques du composant. Une seule extrémité de la broche est électriquement active ; elle est parfois appelée extrémité active de la broche.
Port Sert à connecter un net d'une feuille de schéma à une autre. La connectivité peut être verticale dans une conception hiérarchique, ou horizontale dans une conception à plat (les conceptions verticales et horizontales sont expliquées ci-dessous). Les noms des ports sont utilisés pour nommer les nets si l'option Allow Ports to Name Nets est activée dans l'onglet Options de la boîte de dialogue Project Options . Dans ce cas, les ports établissent également des connexions au sein d'une feuille de schéma, mais ils ne se connectent pas aux étiquettes de net portant le même nom (en savoir plus).
Port d'alimentation Établit une connectivité avec tous les autres ports d'alimentation portant le même nom dans l'ensemble du projet de schéma, quelle que soit la structure de la conception. Le net est automatiquement nommé d'après le port d'alimentation. Ce net peut être limité à une feuille de schéma spécifique si nécessaire (en savoir plus).
Entrée de feuille Placée dans un symbole de feuille pour établir une connectivité avec un port portant le même nom sur la feuille enfant de ce symbole. Les entrées de feuille sont utilisées comme noms de nets si l'option Allow Sheet Entries to Name Nets est activée dans l'onglet Options de la boîte de dialogue Project Options .
Faisceau de signaux Sert à regrouper toute combinaison de nets, de bus et de faisceaux de signaux de niveau inférieur.
Fil Primitive de conception électrique sous forme de polyligne, utilisée pour établir des connexions électriques entre des points d'un schéma. Un fil de schéma est analogue à un fil physique.
  • Les différents types d'identificateurs de net portant le même nom ne se connectent pas automatiquement entre eux. Cela dépend de la configuration des options de nommage des nets. Ces options sont présentées ci-dessous.

  • Notez que les noms de nets définis par les identifiants de nets ne sont pas sensibles à la casse. Par exemple, si deux fils portent les étiquettes de net abc et ABC, ils seront affectés au même net abc (si le paramètre Net Identifier Scope du projet le permet).

  • Évitez d’utiliser l’apostrophe (') à la fin d’un nom de net, car ce caractère est un opérateur fonctionnel du langage de requête ; une erreur peut donc se produire, car un autre paramètre est attendu après ce caractère.

Influence de la structure de la conception sur la connectivité

Related page: Conceptions multifeuilles et hiérarchiques

Si la conception ne tient pas sur une seule feuille de schéma, elle peut être répartie sur plusieurs feuilles. Il existe deux modèles distincts pour organiser et créer la connectivité dans un schéma multifeuille : une conception à plat, que l’on peut voir comme une grande feuille de schéma découpée en plusieurs feuilles plus petites ; ou une conception hiérarchique, dans laquelle les feuilles sont liées selon une structure de type grand-parent-parent-enfant.

Les conceptions multifeuilles sont réalisées en plaçant un symbole de feuille sur la feuille parente. Ce symbole représente la feuille enfant et établit un lien vers celle-ci, comme le montre l’image ci-dessous.

Les symboles de feuille représentent les feuilles de niveau inférieur et établissent un lien vers celles-ci. Dans une conception à plat, cette structure ne peut comporter qu’un seul niveau de profondeur ; dans une conception hiérarchique, la profondeur n’est pas limitée.
Les symboles de feuille représentent les feuilles de niveau inférieur et établissent un lien vers celles-ci. Dans une conception à plat, cette structure ne peut comporter qu’un seul niveau de profondeur ; dans une conception hiérarchique, la profondeur n’est pas limitée.

Qu’est-ce qui détermine donc si une conception est à plat ou hiérarchique ? C’est le réglage de la portée des identificateurs de nets qui définit la manière dont la connectivité entre les feuilles est créée. Effectuez ce réglage dans l’onglet Options de la boîte de dialogue Project Options .

Il est important de rappeler que, pour les conceptions hiérarchiques, un projet ne peut contenir qu’une seule feuille de niveau supérieur. Tous les autres documents sources doivent être référencés par des symboles de feuille. Lors de la validation d’une conception, le contrôle de violation Plusieurs documents de niveau supérieur permet de signaler les cas où cette condition n’est pas respectée. En outre, aucun symbole de feuille ne doit référencer la feuille sur laquelle il se trouve ni une feuille située plus haut dans la hiérarchie, car cela créerait une boucle impossible à résoudre dans la structure.

Conception à plat

Related page: Conceptions multifeuilles et hiérarchiques

Une conception est dite à plat lorsque la connectivité est créée directement d’une feuille à une autre. Elle ne passe pas par les symboles de feuille de la feuille parente. Dans une conception à plat, les symboles de feuille représentent simplement les feuilles enfants et les référencent. Toutes les feuilles de la conception apparaissent au même niveau dans le panneau Projects puisqu’il n’y a pas de hiérarchie. Les deux images ci-dessous montrent une conception à plat.

Les conceptions à plat sont plus simples à créer. Une conception à plat peut inclure une feuille de niveau supérieur comportant un symbole de feuille pour chaque feuille enfant, mais cela reste facultatif, car cette feuille de niveau supérieur n’est pas utilisée pour créer la connectivité entre les feuilles. Pour une petite conception qui ne comporte que deux ou trois feuilles de schéma, vous pouvez estimer qu’une feuille de niveau supérieur n’apporte aucune valeur ajoutée. Lorsque le nombre de feuilles augmente, une feuille de niveau supérieur peut aider le lecteur à comprendre le fonctionnement du circuit grâce à la disposition des blocs logiques (symboles de feuille) sur la feuille.

La même conception, présentée sans feuille de niveau supérieur (à gauche) et avec une feuille de niveau supérieur (à droite) : il s’agit dans les deux cas d’une conception à plat.  Projects panel showing a simple project that is a flat design, with a top sheet
La même conception, présentée sans feuille de niveau supérieur (à gauche) et avec une feuille de niveau supérieur (à droite) : il s’agit dans les deux cas d’une conception à plat.

Dans une conception à plat, les connexions entre les feuilles peuvent être créées à l’aide de ports, de connecteurs hors feuille, de ports d’alimentation et d’étiquettes de net, comme le montre l’image ci-dessus avec la loupe. L’approche recommandée consiste à utiliser des étiquettes de net within chaque feuille et des ports pour relier les feuilles between. Les ports offrent davantage de fonctionnalités que les connecteurs hors feuille, notamment la possibilité d’ajouter des références croisées de ports, ce qui ajoute un SheetName[GridReference] à chaque port, renvoyant à un port correspondant sur une autre feuille, comme le montre l’image ci-dessous.

Le nombre de feuilles dans une conception à plat n’est pas limité.

Des références croisées de ports ont été ajoutées à côté de chaque port, indiquant la feuille cible et les coordonnées dans la grille du port correspondant.
Des références croisées de ports ont été ajoutées à côté de chaque port, indiquant la feuille cible et les coordonnées dans la grille du port correspondant.

Une conception est à plat lorsque la connectivité s’établit directement d’une feuille à une autre. Ce comportement de connexion est défini en réglant la portée des identificateurs de nets sur Automatic, Flat ou Global. Notez que si vous choisissez d’utiliser à la fois des ports et des étiquettes de net pour créer la connectivité entre les feuilles, vous ne pouvez pas utiliser l’option Automatic. Dans ce cas, vous devez régler manuellement Net Identifier Scope sur Global.

Conception hiérarchique

Main page: Conceptions multifeuilles et hiérarchiques

Une conception est dite hiérarchique lorsque la connectivité entre les feuilles s’établit d’un symbole de feuille vers la feuille enfant référencée par ce symbole. Au niveau des nets, la connectivité est créée entre une entrée de feuille de ce symbole de feuille et un port portant le même nom que cette entrée sur la feuille enfant. Ce type de connectivité est également appelé connectivité verticale, car la connectivité entre les feuilles ne s’établit que dans le sens ascendant ou descendant, entre une feuille parente et sa feuille enfant.

Dans une conception hiérarchique, la connectivité au niveau des nets s’établit d’une entrée de feuille sur la feuille parente vers un port correspondant sur la feuille enfant.
Dans une conception hiérarchique, la connectivité au niveau des nets s’établit d’une entrée de feuille sur la feuille parente vers un port correspondant sur la feuille enfant.

Les conceptions hiérarchiques présentent deux atouts majeurs.

  1. Le premier est la possibilité de montrer au lecteur le fonctionnement de la conception grâce à la manière dont les feuilles de schéma sont structurées et présentées sous forme de blocs logiques (symboles de feuille). Le schéma de niveau supérieur présente la conception comme un ensemble de blocs fonctionnels de haut niveau, dont la disposition reflète leur place dans le cheminement traditionnel du circuit, de gauche à droite et des entrées vers les sorties. Ces blocs peuvent à leur tour être décomposés en blocs plus petits si nécessaire, ce qui permet aux schémas de niveau le plus bas, qui contiennent les composants, de conserver une structure relativement simple avec un nombre réduit de composants. Chaque feuille étant relativement simple, ses dimensions peuvent rester réduites, ce qui constitue un avantage considérable lors de l’impression du schéma.
  2. L’autre avantage majeur est qu’il est généralement beaucoup plus facile de suivre un signal dans une conception hiérarchique, puisque le lecteur n’a qu’à faire correspondre une entrée de feuille sur la feuille parente au port de la feuille enfant, puis à suivre le signal le long des connexions dans chaque feuille.

La création d’une conception hiérarchique demande un travail supplémentaire. Les symboles de feuille nécessitent des entrées de feuille et la feuille de niveau supérieur doit être câblée pour acheminer les signaux d’un symbole de feuille à l’autre. Le logiciel comprend un outil permettant de synchroniser les entrées de feuille avec les ports des feuilles enfants (Design » Synchronize Sheet Entries and Ports pour tous les symboles de feuille, ou un clic droit sur un symbole de feuille, puis le choix de Sheet Symbol Actions » Synchronize Sheet Entries and Ports pour un seul symbole de feuille). Il comprend également des outils permettant de décomposer une conception volumineuse en éléments plus petits (Edit » Refactor » Move Selected Subcircuit to Different Sheet). Pour en savoir plus sur ces outils de restructuration et de refactorisation, consultez la page  Refactorisation de la conception.

Une conception hiérarchique peut comporter un nombre quelconque de niveaux et de feuilles de schéma.

Une conception est hiérarchique lorsque les connexions entre feuilles s’établissent uniquement entre les entrées de feuille de la feuille parente et les ports correspondants de la feuille enfant. Ce mode de connexion est défini en réglant la portée des identifiants de nets sur Automatic, Hierarchical ou Strict Hierarchical.

Conception multicanal

Main article: Création d’une conception multicanal

Il n’est pas rare qu’une conception électronique comporte des sections de circuit répétées. Il peut s’agir d’un amplificateur stéréo ou d’une console de mixage à 64 canaux. Ce type de conception est entièrement pris en charge par un ensemble de fonctionnalités appelé multi-channel design. Dans une conception multicanal, vous saisissez le circuit répété une seule fois, puis vous demandez au logiciel de le répéter, soit en plaçant plusieurs symboles de feuille qui font tous référence au même schéma enfant, soit en configurant un seul symbole de feuille pour répéter le schéma enfant référencé autant de fois que nécessaire. La conception compilée est développée dans la mémoire de l’ordinateur, tous les composants et toutes les connexions étant répétés le nombre de fois requis, conformément au schéma de nommage défini par l’utilisateur.

À gauche, quatre symboles de feuille font tous référence à la même feuille enfant (PortIO.SchDoc). À droite, InputChannel.SchDoc est répété huit fois à l’aide du mot-clé Repeat .  An example of a multi-channel design where the child schematic is repeated by including the Repeat keword in its Sheet Symbol
À gauche, quatre symboles de feuille font tous référence à la même feuille enfant (PortIO.SchDoc). À droite, InputChannel.SchDoc est répété huit fois à l’aide du mot-clé Repeat .

La conception logique que vous saisissez n’est jamais réellement aplatie : elle reste toujours sous la forme d’un schéma multicanal. Lorsque vous la transférez vers l’implantation du PCB, les composants physiques et les nets sont dupliqués le nombre de fois requis, et vous disposez de tous les outils de navigation et de sélection croisées permettant de Travailler entre le schéma et le circuit imprimé. L’éditeur de PCB comprend également un outil permettant de reproduire le placement et le routage d’un canal sur tous les autres canaux, ainsi que de déplacer et de réorienter facilement un canal entier. Consultez le document consacré à la conception multicanal pour en savoir plus sur ce sujet. 

Une conception multicanal doit être hiérarchique, car le logiciel utilise ce modèle structurel pour instancier les canaux en mémoire.

Pour une conception multicanal, réglez Net Identifier Scope sur Automatic, Hierarchical ou Strict Hierarchical.

Le logiciel gère la duplication des composants et des nets à l’aide du schéma de nommage sélectionné dans l’onglet Multi-Channel de la boîte de dialogue Project Options .

Définition de la portée des identifiants de nets

Dialog page: Options du projet

Le logiciel utilise le réglage actuel de Net Identifier Scope pour déterminer comment les connexions sont établies entre les feuilles de schéma. Le paramètre Net Identifier Scope se configure dans l’onglet Options de la boîte de dialogue Project Options (Project » Project Options).

Sélectionnez le mode Net Identifier Scope adapté à la structure de votre conception.
Sélectionnez le mode Net Identifier Scope adapté à la structure de votre conception.

Le comportement des options Global, Flat et Hierarchical est illustré dans les images ci-dessous.

Exemples simples montrant comment les connexions sont établies pour chacun des trois modes principaux : global, à plat et hiérarchique. Configuring the Net Identifier Scope, example of what connects with the Flat option Configuring the Net Identifier Scope, example of what connects with the Hierarchical option
Exemples simples montrant comment les connexions sont établies pour chacun des trois modes principaux : global, à plat et hiérarchique.

Outre les trois options mentionnées ci-dessus, une option Automatic est également disponible. En général, il est préférable de laisser le paramètre Net Identifier Scope réglé sur Automatic. Le logiciel sélectionnera l’option la plus appropriée parmi les trois, en fonction de la structure des feuilles et de la présence ou de l’absence de ports et d’entrées de feuille.

Lorsque le paramètre est réglé sur Automatic, le logiciel sélectionne automatiquement le mode d’identification des nets à utiliser parmi les trois modes principaux, selon les critères suivants :

  • Si la feuille de niveau supérieur comporte des entrées de feuille, Hierarchical est utilisé.
  • S’il n’y a pas d’entrées de feuille, mais que des ports sont présents, Flat est utilisé.
  • S’il n’y a ni entrées de feuille ni ports, Global est utilisé.

Le mode Strict Hierarchical rend tous les ports d’alimentation locaux à chaque feuille. Dans ce mode, vous devez acheminer tous les nets d’alimentation et de masse vers chaque feuille enfant à l’aide de ports et d’entrées de feuille. Vous pouvez également le faire pour certaines feuilles seulement, sans utiliser le mode Strict Hierarchical, en plaçant tout de même des entrées de feuille et des ports pour les nets d’alimentation que vous souhaitez rendre locaux. En savoir plus sur les Nets d’alimentation.

Nommage des nets

Chaque fois que vous placez un fil entre les broches de composants, vous créez une connexion. Chaque net de la conception reçoit un nom. Si vous n’avez pas placé d’identifiant de net pouvant servir à le nommer, le logiciel nomme ce net en fonction de l’une de ses broches, par exemple NetR7_1 comme illustré dans l’image ci-dessous. Si le repère du composant est modifié à un moment donné, ce nom de net généré par le système est également modifié. Ces changements doivent être répercutés entre le schéma et le PCB pour que l’ensemble reste synchronisé.

Les nets sans identifiant de net reçoivent un nom généré par le système à partir de l’une de leurs broches.
Les nets sans identifiant de net reçoivent un nom généré par le système à partir de l’une de leurs broches.

Les étiquettes de net nomment toujours le net auquel elles sont rattachées. Le point de rattachement par défaut est le coin inférieur gauche de l’étiquette de net, indiqué par une petite croix lors du déplacement.

Les autres identifiants de nets nomment le net si l’option correspondante est activée dans la section Netlist Options de l’onglet Options de la boîte de dialogue Project Options .

Les différents types d’identifiants de nets ne se connectent pas automatiquement entre eux. Par exemple, un port nommé Inta ne se connectera pas à une étiquette de net nommée Inta même si l’option Allow Ports to Name Nets de la boîte de dialogue Project Options est activée. Ils doivent être reliés par un fil. Un exemple est présenté dans les images ci-dessous.

  

Plusieurs identifiants de nets sur un même net

Vous ne pouvez pas placer plusieurs étiquettes de net portant des noms différents sur un même net au sein d’une feuille de schéma. Cette situation sera détectée et signalée comme une erreur lors de la validation. En revanche, il est tout à fait possible d’attribuer plusieurs identifiants à un net sur les différentes feuilles où il apparaît.

Cette possibilité vous permet de :

  • Modifier le nom d’un net à différents niveaux de la hiérarchie pour mieux refléter sa fonction sur la feuille concernée.
  • Réutiliser une feuille de schéma enfant sans avoir à renommer ses nets.

Par défaut, les identifiants de net multiples sont considérés comme non autorisés. S’ils sont détectés lors de la validation, un avertissement est émis. Si votre conception en nécessite, vous devrez :

  • Modifier le réglage du contrôle d’erreur Nets with multiple names dans l’onglet Error Reporting de la boîte de dialogue Project Options  ou,
  • Supprimer des avertissements spécifiques en plaçant un marqueur No ERC sur chaque avertissement, puis en choisissant Specific Violations dans le mode No ERC du panneau Properties pour définir les erreurs à supprimer. Notez que vous pouvez placer des marqueurs No ERC en effectuant un clic droit sur un avertissement répertorié dans le panneau Messages ou sur la ligne ondulée colorée qui signale une violation sur la feuille de schéma. Leur forme et leur couleur peuvent être modifiées dans le panneau Properties lorsque le marqueur No ERC est sélectionné.

Options de contrôle du nommage des nets

Dialog page: Options du projet

En définitive, chaque net ne peut porter qu’un seul nom sur le PCB (un net de PCB ne peut pas avoir deux noms, sauf si vous connectez intentionnellement deux nets à l’aide d’un Net Tie). Le logiciel attribue automatiquement un nom unique dans le projet aux nets qui en possèdent plusieurs, mais ce nom peut ne pas être celui que vous attendiez. Plusieurs options permettent de contrôler le choix du nom dans la section Netlist Options de l’onglet Options de la boîte de dialogue Project Options. Consultez la page consacrée à la boîte de dialogue Options du projet pour obtenir plus de détails sur chacune de ces options.

Une bonne approche consiste à activer les options Allow Ports to Name Nets et Higher Level Names Take Priority. Associez-les à une utilisation judicieuse des étiquettes de net sur les nets importants de chaque feuille afin de vous assurer que tous les nets importants, y compris ceux qui traversent plusieurs feuilles, sont nommés et que les noms attribués dans les schémas de niveau supérieur sont utilisés dans les schémas de niveau inférieur.

Lorsque plusieurs options de nommage des nets sont activées, l’ordre de priorité est le suivant :

  • Si l’option Power Port Names Take Priority est désactivée, l’ordre est : étiquettes de net, ports d’alimentation, ports, broches.
  • Si l’option Power Port Names Take Priority est activée, l’ordre est : ports d’alimentation, étiquettes de net, ports, broches.

Deux nets distincts portant le même nom

Un autre problème de nommage peut survenir lorsqu’un même nom de net a été utilisé sur différentes feuilles de schéma pour étiqueter des nets distincts. Cette situation sera détectée lors de la validation par le contrôle d’erreur Duplicate Nets. Vous ne pouvez pas transférer une conception vers le PCB dans ces conditions. Ces deux nets distincts seront fusionnés en un seul net de PCB lors du transfert de la conception.

Pour résoudre ce problème, activez l’option Append Sheet Numbers to Local Nets dans l’onglet Options de la boîte de dialogue Project Options . Lorsque cette option est activée, la valeur du paramètre SheetNumber est ajoutée au nom de chaque net local, comme le montrent les images ci-dessous.

Example of how a duplicated net name, Input, appears on the schematic Editor tab  Example of how a duplicated net name, Input, appears on the schematic compiled tab
L’étiquette de net Input ayant été utilisée sur plusieurs feuilles, l’option Append Sheet Numbers to Local Net a été activée pour éviter une erreur de nets en double.
Vous pouvez en voir l’effet en cliquant sur l’onglet de la feuille compilée (image de droite) : notez que _2 a été ajouté au nom du net.

L’option Append Sheet Numbers to Local Nets ne fonctionne que si un SheetNumber unique a été attribué à chaque feuille de schéma. Le paramètre SheetNumber est défini dans l’onglet Parameters du mode Options du document du panneau Propriétés pour chaque feuille de schéma. Au lieu d’attribuer manuellement un numéro unique à chaque feuille, vous pouvez exécuter la commande Tools » Annotation » Number Schematic Sheets, qui ouvre la boîte de dialogue Numérotation des feuilles du projet. Cette boîte de dialogue permet d’attribuer à toutes les feuilles des valeurs uniques pour SheetNumber (une simple valeur numérique pour chaque feuille) et DocumentNumber (généralement utilisé pour la numérotation des documents propre à l’entreprise).

Connecter intentionnellement deux nets

Dans certaines situations, vous devez connecter intentionnellement deux nets différents. Il ne s’agit pas d’un simple problème de nommage, mais d’une exigence de conception imposant de court-circuiter deux nets. Par exemple, vous pouvez avoir besoin de relier une masse analogique et une masse numérique de manière contrôlée.

Pour cela, les deux nets sont reliés par un composant Net Tie. Un composant Net Tie n’est rien d’autre qu’un court-circuit contrôlé, qui vous permet de décider à quel endroit de la carte les nets sont reliés. Sur le schéma, le composant Net Tie possède deux broches ou plus, chacune étant reliée à l’un des nets à court-circuiter. La propriété Component Type du composant est définie sur Net Tie, comme illustré ci-dessous.

Un composant Net Tie utilisé sur le schéma pour acheminer un même signal d’horloge vers deux broches d’horloge d’un FPGA.
Un composant Net Tie utilisé sur le schéma pour acheminer un même signal d’horloge vers deux broches d’horloge d’un FPGA.

Notez que les broches ne sont not reliées entre elles par un fil sur le schéma (elles n’y sont pas court-circuitées), mais qu’elles sont are reliées entre elles dans l’empreinte du PCB.

Côté PCB, l’empreinte comporte autant de pastilles que le symbole schématique comporte de broches, avec du cuivre entre elles. Dans l’exemple ci-dessous, deux pastilles carrées sont reliées par un segment de piste. Cette liaison est réalisée dans l’empreinte, à l’aide de l’éditeur de bibliothèques PCB. La propriété Component Type du composant PCB est également définie sur Net Tie.

Le logiciel ignore automatiquement les courts-circuits créés à l’intérieur d’un composant PCB Net Tie ; aucune erreur DRC n’est donc générée.

Le même composant Net Tie sur le PCB ; les pastilles (sélectionnées) de l’empreinte Net Tie sont court-circuitées par une piste.
Le même composant Net Tie sur le PCB ; les pastilles (sélectionnées) de l’empreinte Net Tie sont court-circuitées par une piste.

Lorsqu’un composant Net Tie est utilisé pour connecter deux nets différents, chaque net conserve son propre nom dans l’ensemble du schéma et sur le PCB.

  • Lors de la création du symbole et de l’empreinte du Net Tie, deux modes Net Tie sont proposés pour le type de composant : l’un permet d’inclure le Net Tie dans la nomenclature (par exemple, s’il s’agit d’un cavalier de court-circuit), l’autre permet de l’en exclure (s’il s’agit simplement d’une portion de cuivre). Sélectionnez le type de composant approprié.
  • Lors du routage du Net Tie sur la carte, tous les modes de routage peuvent être utilisés pour router away à partir d’une pastille du Net Tie. Pour router into vers une pastille du Net Tie, vous devez passer au mode Ignore Obstacle.

► Démonstration du routage d’un composant Net Tie

Nets d’alimentation

Par défaut, les paramètres considèrent les nets d’alimentation comme globaux, c’est-à-dire disponibles sur toutes les feuilles de schéma. Pour accéder à un net d’alimentation, placez un port d’alimentation portant le nom de net requis, puis reliez les composants à ce port d’alimentation. Lors de la compilation de la conception, toutes les broches reliées à chaque net d’alimentation sont connectées entre elles, sur l’ensemble des feuilles du projet.

C’est le nom du net qui détermine à quel net un port d’alimentation est connecté, et non le style du symbole : les trois ports d’alimentation mis en évidence sont tous connectés au net d’alimentation GND.
C’est le nom du net qui détermine à quel net un port d’alimentation est connecté, et non le style du symbole : les trois ports d’alimentation mis en évidence sont tous connectés au net d’alimentation GND.

Rendre un net d’alimentation local — Globalement

Comme indiqué précédemment, les nets d’alimentation peuvent être rendus locaux à chaque feuille de schéma d’une conception hiérarchique en sélectionnant l’option Strict Hierarchical pour la portée des identificateurs de nets. Cette approche rend tous les nets d’alimentation locaux sur chaque feuille. Ils doivent donc être reliés manuellement entre eux, de la même manière que les nets de signaux. S’ils ne sont pas reliés entre eux, une erreur Duplicate Net Name sera signalée pour chaque net d’alimentation présent sur chaque feuille de schéma. Vous devrez également ajuster les paramètres de la matrice de connexion pour autoriser la connexion des ports aux ports d’alimentation.

Si Net Identifier Scope est défini sur Strict Hierarchical, 
Si Net Identifier Scope est défini sur Strict Hierarchical, chaque net d’alimentation doit être relié à toutes les feuilles sur lesquelles il est utilisé.

Relier un net d’alimentation local entre plusieurs feuilles

Un net d’alimentation rendu local dans une conception hiérarchique se connecte de la même manière que tout autre net : d’un port sur la feuille enfant à une entrée de feuille dans le symbole de feuille de la feuille parente. Notez que, pour les nets d’alimentation, cette technique prend uniquement en charge les nets individuels, et non les nets d’alimentation regroupés dans un bus ().

Si vous créez une conception multicanal et souhaitez fournir un net d’alimentation distinct à chaque canal à l’aide de l’instruction Repeat (comme illustré ci-dessous), cela est possible, car vous ne transmettez qu’un seul net à chaque canal par l’intermédiaire de la paire entrée de feuille-port. Tant que la conception ne tente de connecter qu’un seul net d’alimentation de la feuille parente à la feuille enfant via chaque paire entrée de feuille-port, la netlist sera générée correctement.

Les nets d’alimentation locaux peuvent être distribués à chaque canal d’une conception multicanal s’ils parcourent la hiérarchie en tant que nets individuels, et non sous forme de bus.Les nets d’alimentation locaux peuvent être distribués à chaque canal d’une conception multicanal s’ils parcourent la hiérarchie en tant que nets individuels, et non sous forme de bus.

Si vous préférez regrouper plusieurs nets d’alimentation dans un bus et transmettre ce bus à travers la hiérarchie de la conception, ces nets doivent être des nets standard ; ils ne peuvent pas être connectés à l’aide de ports d’alimentation.

Rendre un net d’alimentation local — Individuellement

Un net d’alimentation spécifique dans une conception hiérarchique (c’est-à-dire dans une conception où Net Identifier Scope est défini sur Hierarchical ou dans une conception contenant des entrées de feuille sur la feuille de niveau supérieur et où Net Identifier Scope est défini sur Automatic – pour en savoir plus, consultez Définir la portée des identificateurs de nets) peut également être rendu local à une feuille spécifique en reliant le port d’alimentation à un port sur cette feuille de schéma.

Ici, le net d’alimentation 3V3 a été rendu local uniquement à cette feuille. Il doit donc également être relié manuellement sur la feuille parente. Les nets GND et 5V restent des nets d’alimentation globaux.
Ici, le net d’alimentation 3V3 a été rendu local uniquement à cette feuille. Il doit donc également être relié manuellement sur la feuille parente. Les nets GND et 5V restent des nets d’alimentation globaux.

Nets d’alimentation et broches d’alimentation masquées

Les anciennes versions du logiciel de conception d’Altium comprenaient des fonctionnalités et des options permettant d’utiliser des broches de composants de schéma masquées. Cette fonctionnalité était utile lorsqu’une conception comportait un seul net d’alimentation et un seul net de masse : le masquage des broches d’alimentation permettait de connecter automatiquement toutes les broches d’alimentation de tous les composants à leurs nets respectifs. Elle était particulièrement utilisée pour les composants à plusieurs parties, évitant d’avoir à afficher leurs broches d’alimentation sur le schéma.  

Aujourd’hui, les conceptions électroniques comportent généralement plusieurs nets d’alimentation et de masse. Ces nets ne sont plus simplement routés vers les broches d’alimentation correspondantes ; la distribution de l’alimentation est désormais un aspect essentiel à la réussite de la conception d’une carte. 

À mesure que la conception des réseaux de distribution d’alimentation a évolué, le besoin de masquer les broches des composants et de laisser le logiciel les connecter automatiquement a diminué au point que la plupart des concepteurs s’opposent à cette pratique. C’est pourquoi le logiciel ne permet plus de définir une broche comme masquée et de lui préattribuer un nom de net. Les anciens projets utilisant cette approche de conception continueront à générer une netlist correcte lorsqu’ils seront ouverts dans la dernière version du logiciel de conception d’Altium.

Compilation dynamique

Related page: Valider votre projet de conception

Lorsque vous reliez deux broches par un fil, vous représentez vos intentions de conception, sans créer de net réel. Le net n’est créé qu’à la compilation du projet. Outre les informations sur les composants et leurs connexions, la compilation extrait également des informations paramétriques détaillées sur les composants et la conception. Le modèle compilé du projet est appelé modèle de données unifié.

Le modèle de données de la conception est mis à jour de manière incrémentale après chaque opération de l’utilisateur grâce à la compilation dynamique, créant ainsi ce que l’on appelle le modèle de données dynamique (DDM). Aucune compilation manuelle du projet n’est nécessaire : tout se fait automatiquement. Le modèle de connectivité de la conception est mis à jour de manière incrémentale après chaque opération de l’utilisateur grâce à la compilation dynamique. Pour un projet de conception, le processus de compilation automatique remplit trois fonctions :

  1. Instancie la hiérarchie de la conception.
  2. Établit la connectivité des nets entre toutes les feuilles de la conception.
  3. Construit un modèle de données dynamique (DDM) interne de la conception.

Cela garantit que toute modification de la conception est immédiatement répercutée dans Navigator et le panneau Projets .

Pour vérifier les erreurs logiques, électriques et de dessin entre le DDM et les paramètres du compilateur, vous devez valider le projet. Cette commande est accessible en sélectionnant la commande Project » Validate Project  dans les menus principaux, ou en cliquant avec le bouton droit sur l’entrée d’un projet dans le panneau Projets et en sélectionnant la commande Validate Project dans le menu contextuel.  

Toute violation détectée par le compilateur sera répertoriée sous forme d’avertissement et/ou d’erreur dans le panneau Messages. Le compilateur utilise les options définies dans les onglets Signalement des erreurs et  Matrice de connexion de la boîte de dialogue Project Options (selon le type de projet) pour rechercher les violations dans les documents sources.

Le modèle de données dynamique

Un élément fondamental du logiciel est le modèle de données unifié (UDM). Grâce à la compilation dynamique automatique, un modèle unique et cohérent est créé et placé au cœur du processus de conception. Les différents éditeurs et services du logiciel, notamment les éditeurs de schémas et de PCB, peuvent accéder aux données de ce modèle et les manipuler. Plutôt que d’utiliser un stockage de données distinct pour chaque domaine de conception, l’UDM est structuré pour accueillir toutes les informations relatives à tous les aspects de la conception, y compris les composants et leur connectivité. Ce modèle unique et cohérent, au cœur du processus de conception, est créé par la compilation dynamique de la conception. Le modèle de données unifié est donc disponible dès l’ouverture d’un projet et ne devrait nécessiter aucune compilation manuelle supplémentaire : un véritable modèle de données dynamique (DDM). Ainsi, le modèle est mis à jour (compilé) de manière incrémentale après chaque opération de l’utilisateur. Vous pouvez librement placer, câbler, réorganiser, renommer, ajouter et supprimer du contenu dans votre schéma.

Le processus de compilation de la conception du PCB est géré par du code extérieur aux éditeurs de schémas et de PCB. Cette approche présente plusieurs avantages, le principal étant que le modèle de données unifié de la conception est indépendant de ces éditeurs. L’UDM comprend une description détaillée de chaque composant de la conception et de ses connexions avec les autres composants.

Le logiciel gère les données de connexion entre le schéma et le PCB.
Le logiciel gère les données de connexion entre le schéma et le PCB.

La compilation étant dynamique, les emplacements et opérations suivants ne nécessitent aucune action manuelle supplémentaire pour compiler la conception :

  • Navigator et le panneau Projects
  • ActiveBOM
  • Exécution d’ECO
  • Localisation croisée
  • Mise en évidence des nets par couleur
  • Permutation de broches
  • Références croisées des composants

Pour actualiser la vue du projet et le panneau Navigator après une compilation dynamique, utilisez la commande Refresh du menu contextuel des panneaux Projects et Navigator. Pour actualiser automatiquement la vue du projet et le panneau Navigator après une compilation dynamique, activez l’option Schematic.DynamicCompiler.Navigator.Autorefresh dans la boîte de dialogue Paramètres avancés.

Placez un masque de compilation pour hide les sections de la conception qui ne sont pas prêtes pour la vérification des erreurs ou le transfert vers l’éditeur de PCB. Lorsque vous êtes prêt, cliquez sur la commande pour réduire le masque et exposer le circuit afin de l’inclure dans le processus de compilation et de transfert de la conception.

Les masques de compilation appartiennent à une catégorie d’objets appelés directives de conception. Utilisez-les pour ajouter au schéma des instructions au niveau de la conception, telles que l’appartenance à une classe de nets, l’identification d’un emplacement où le compilateur doit ignorer une violation spécifique, l’identification d’un groupe de nets constituant des paires différentielles, etc. Survolez l’image pour voir une démonstration d’un masque de compilation.

Comment interagir avec le modèle de données unifié, par exemple pour suivre un net à travers la conception ? Pour cela, utilisez le panneau Navigator.

Examen de la connectivité

Panel page: Panneau Navigator

Si la conception est volumineuse et répartie sur de nombreuses feuilles, il peut devenir difficile de suivre et de vérifier sa connectivité. Pour faciliter cette tâche, vous pouvez utiliser le panneau Navigator. Ce panneau offre une vue de l’ensemble de la conception compilée. 

Pour utiliser le panneau, procédez comme suit :

  • Définissez le comportement de navigation en cliquant sur le bouton  Ellipsis button on the Navigator panel, click to configure the navigation preferences en haut du panneau pour ouvrir la boîte de dialogue Preferences et activer les Highlight Methods de votre choix. Vous pouvez également cliquer avec le bouton droit sur l’objet souhaité dans le panneau et utiliser les options du menu pour configurer le comportement de navigation, comme illustré ci-dessous.
  • Définissez le périmètre de navigation dans la zone Documents for du panneau ; pour parcourir l’ensemble de la conception, sélectionnez Flattened Hierarchy.
  • Cliquez sur un composant dans la section Instance de la liste pour y accéder ; développez le composant pour repérer une broche ou y accéder.
  • Cliquez sur un net ou un bus dans la section Net /Bus pour y accéder.
  • Maintenez la touche Alt enfoncée lorsque vous cliquez pour accéder à cet objet à la fois sur le schéma et sur le PCB.

Cliquez sur un composant ou un net dans le panneau Navigator pour le localiser et suivre sa connectivité à travers la conception. Cliquez avec le bouton droit pour accéder aux options d’affichage. Survolez l’image pour voir comment accéder simultanément à un composant sur le schéma et sur le PCB (maintenez la touche Alt enfoncée lorsque vous cliquez dans le panneau Navigator pour inclure l’objet du PCB).
Cliquez sur un composant ou un net dans le panneau Navigator pour le localiser et suivre sa connectivité à travers la conception. Cliquez avec le bouton droit pour accéder aux options d’affichage. Survolez l’image pour voir comment accéder simultanément à un composant sur le schéma et sur le PCB (maintenez la touche Alt enfoncée lorsque vous cliquez dans le panneau Navigator pour inclure l’objet du PCB).

Navigation parmi les composants de la carte

Outre la localisation des composants sur le schéma et le PCB (si la touche Alt est maintenue enfoncée) depuis le panneau Navigator, vous pouvez également accéder aux broches, composants, nets, bus et faisceaux sur le PCB directement depuis le schéma.

Par exemple, lorsque vous cliquez pour localiser un composant sur le schéma, vous pouvez également localiser ce même composant sur le PCB.

Pour ce faire :

  • Activez l’option Selecting dans Highlight Methods, ainsi que les options de votre choix dans la section Cross Select Mode de la page System - Navigation de la boîte de dialogue Preferences.
  • Activez la sélection croisée (Tools » Cross Select Mode) dans les éditeurs de schémas et de PCB.

Ces options configurent le comportement de navigation et de sélection croisée.
Ces options configurent le comportement de navigation et de sélection croisée.

Désormais, lorsque vous sélectionnez des broches, composants, nets, bus ou faisceaux sur le schéma, ces objets sont également sélectionnés sur le PCB, comme illustré ci-dessous.

Lorsque vous sélectionnez des composants et des nets sur le schéma, ces objets sont également sélectionnés sur le PCB. La sélection croisée fonctionne aussi du PCB vers le schéma.
Lorsque vous sélectionnez des composants et des nets sur le schéma, ces objets sont également sélectionnés sur le PCB. La sélection croisée fonctionne aussi du PCB vers le schéma.

Recherche de composants et de nets dans la structure du projet

Parcourez la structure dans le panneau pour trouver le composant ou le net souhaité, puis double-cliquez sur l’objet pour afficher ses instances dans les documents schématiques du projet. Utilisez les options de la page Système - Navigation de la boîte de dialogue Preferences pour définir le comportement de mise en évidence des objets (zoom, atténuation, sélection, etc.).

Cliquez avec le bouton droit dans l’espace de conception et sélectionnez l’option Clear Filter pour supprimer la mise en évidence ou la sélection des objets dans l’éditeur de schémas ou de PCB.

La navigation parmi les objets du projet est également disponible dans le panneau Navigator, qui présente une structure hiérarchique détaillée des objets de conception et des données qui leur sont associées. Les préférences Système - Navigation déterminent le comportement de mise en évidence des objets dans les panneaux Project et Navigator.

Mise en évidence des connexions

L’option de navigation dans la connectivité affiche les relations de connexion d’un objet sélectionné dans le panneau Projects. Double-cliquez sur une entrée, telle qu’un net, dans la liste hiérarchique des objets du panneau pour mettre en évidence ses interconnexions dans le schéma.

La fonction d’aperçu est activée par l’option Connectivity Graph dans la section Highlight Methods de la page Système – Navigation de la boîte de dialogue Preferences. Sélectionnez également l’option Inclure Power Parts pour afficher la connectivité des objets d’alimentation associés à l’objet sélectionné.

Mise en surbrillance globale des nets

La connectivité d’un net dans l’ensemble d’une conception peut être mise en surbrillance dans tous les schémas en maintenant la touche Alt enfoncée lors de la sélection du net par un clic sur un fil (Alt+Click). Toutes les occurrences du net dans les schémas sont mises en surbrillance, tandis que les autres objets sont estompés, afin de montrer clairement la propagation du signal ou de l’alimentation dans la conception en une seule action.

La mise en surbrillance du net est annulée en cliquant dans une zone vide, et son comportement est défini par les paramètres Highlight Methods sur la page Système - Navigation de la boîte de dialogue Preferences. Notez que décocher l’option Dimming désactive la fonction de mise en surbrillance des nets.

Localisation et sélection croisées

Outre la possibilité de sélectionner des objets d’un éditeur à l’autre (sélection croisée), Altium Designer prend également en charge la localisation croisée. Celle-ci propose deux modes : continu (rester dans l’éditeur source) et basculement (passer à l’éditeur cible). Vous pouvez également effectuer une localisation croisée depuis différents panneaux et boîtes de dialogue, par exemple le panneau Messages et la boîte de dialogue Engineering Change Order. Pour en savoir plus, consultez la page Localisation et sélection croisées.

Configuration de la couleur des nets

Main page: Application de couleurs aux nets

Pour améliorer la lisibilité du schéma et faciliter le travail sur les nets et les pistes dans l’éditeur PCB, vous pouvez appliquer des couleurs aux fils du schéma ainsi qu’aux nets et aux pistes du PCB.

Vous pouvez appliquer une couleur de surbrillance à un net ou à un bus dans l’éditeur de schémas à l’aide des commandes du sous-menu View » Set Net Colors, comme illustré dans l’image ci-dessous. Ces couleurs peuvent être transférées à l’éditeur PCB à tout moment, via la commande Update PCB.

Dans l’éditeur PCB, la couleur par défaut et la visibilité de Connection Lines sont configurées dans la section System Colors du panneau Configuration de l’affichage du PCB. Notez que cette couleur par défaut est appliquée lors de la création des nets (pendant le transfert initial de la conception depuis le schéma) ; la couleur des lignes de connexion existantes ne change pas si cette option est modifiée.

Dans l’éditeur PCB, la couleur appliquée à chaque net est affichée dans le mode Nets du panneau PCB. Repérez la couleur derrière la case à cocher à côté du nom du net, comme illustré dans le coin inférieur droit de l’image ci-dessous.

La couleur est toujours appliquée aux nets non routés (lignes de connexion). Pour afficher la couleur sur les nets routés, cochez la case à côté du nom du net dans le panneau PCB et configurez les options d’affichage sur la page Remplacements de couleur Board Insight de la boîte de dialogue Preferences. Dans l’image ci-dessous, le motif de base de la couleur de remplacement est défini sur Solid, et le comportement lors d’un zoom arrière est défini sur Override Color Dominates.

Les couleurs des nets appliquées dans le schéma sont transférées au PCB par la commande Mettre à jour le PCB. Configurez les fonctions de remplacement des couleurs du PCB pour contrôler leur affichage sur la carte.Les couleurs des nets appliquées dans le schéma sont transférées au PCB par la commande Mettre à jour le PCB. Configurez les fonctions de remplacement des couleurs du PCB pour contrôler leur affichage sur la carte.

Appuyez sur F5 pour activer ou désactiver la fonction de remplacement des couleurs des nets, dans les éditeurs de schémas et de PCB. Il peut également être nécessaire d’actualiser l’affichage (End).

Modification de la couleur des nets du PCB

Il n’est pas toujours possible d’appliquer des couleurs aux fils du schéma et de les transférer au PCB. Dans ce cas, vous pouvez néanmoins appliquer des couleurs aux lignes de connexion et aux pistes dans l’éditeur PCB. Pour modifier la couleur d’un net après le transfert de la conception, double-cliquez sur le nom du net dans le mode Nets du panneau PCB. La couleur d’un net individuel peut être modifiée dans la boîte de dialogue Modifier le net.

Pour modifier la couleur de plusieurs nets, utilisez le mode Nets du panneau PCB :

  • Utilisez les méthodes standard de sélection multiple de Windows (Shift+click ou Ctrl+click) pour sélectionner plusieurs classes de nets ou plusieurs nets individuels.
  • Faites un clic droit sur un objet sélectionné et choisissez la commande Change Net Color dans le menu contextuel pour attribuer une nouvelle couleur aux nets sélectionnés.
  • Faites un deuxième clic droit et choisissez Display Override » Selected On pour activer la fonction de remplacement des couleurs pour les nets sélectionnés.

Améliorez la visibilité des nets en modifiant la couleur de leurs lignes de connexion et en activant la fonction de remplacement de l’affichage.
Améliorez la visibilité des nets en modifiant la couleur de leurs lignes de connexion et en activant la fonction de remplacement de l’affichage.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents