Guida rapida di Power Analyzer by Keysight

A colpo d'occhio

Questa guida introduttiva illustra come Power Analyzer by Keysight ti aiuta a valutare la rete di distribuzione dell’alimentazione in corrente continua di un PCB all’interno di Altium Designer, consentendoti di andare oltre le supposizioni e verificare se percorsi in rame, piani, piste e via sono in grado di soddisfare il fabbisogno energetico del tuo progetto. Spiega come l’estensione si integra direttamente nel progetto corrente, come installarla e avviarla, quali informazioni sono necessarie prima di eseguire un’analisi e come iniziare a definire e simulare le reti di alimentazione. Se cerchi un punto di partenza più chiaro per utilizzare Power Analyzer by Keysight nel tuo flusso di lavoro, questo articolo illustra i passaggi essenziali per iniziare: continua a leggere per acquisire dimestichezza con lo strumento.

- Scopri cosa fa Power Analyzer by Keysight in Altium Designer e come supporta l’analisi dell’integrità dell’alimentazione in corrente continua utilizzando i dati già presenti nel progetto.
- Esplora il flusso di lavoro di base per installare l’estensione, aprire il documento dell’analizzatore e predisporre le impostazioni della scheda e delle reti per la simulazione.
- Comprendi i requisiti fondamentali di configurazione, tra cui la sincronizzazione tra schema elettrico e PCB, le opzioni di configurazione, i requisiti di abbonamento e la selezione delle reti di alimentazione.
Approfondisci con l'IA:

Nei moderni progetti digitali, caratterizzati da circuiti ad alta velocità, schede densamente popolate e più linee di alimentazione a bassa tensione, i requisiti imposti alla rete di distribuzione dell'alimentazione in continua richiedono un approccio analitico alla sua progettazione. L'analisi in continua di una rete di distribuzione dell'alimentazione, o i risultati dell'analisi dell'integrità dell'alimentazione in continua (PI-DC), mira a garantire che sia stata prevista una quantità adeguata di rame lungo il percorso dalle sorgenti di tensione ai carichi; in altre parole, che i piani, le piste e i via della scheda abbiano dimensioni (e caratteristiche) sufficienti a soddisfare i requisiti di consumo energetico dei dispositivi presenti sulla scheda.

Fortunatamente, è possibile eliminare le valutazioni approssimative della rete di distribuzione dell'alimentazione di un PCB utilizzando uno strumento di simulazione dell'integrità dell'alimentazione in continua (PI-DC), che analizza le prestazioni in continua del progetto di una scheda in base alle sue proprietà elettriche e fisiche. Uno strumento di questo tipo è disponibile per Altium Designer: Power Analyzer by Keysight.

Disponibile come estensione Altium scaricabile, Power Analyzer si integra direttamente con Altium Designer per consentire la simulazione e l'analisi PI-DC del progetto PCB corrente. Poiché Power Analyzer funziona all'interno di Altium Designer, non è necessario importare o esportare manualmente i dati, convertirli o eseguire applicazioni separate: basta avviare Power Analyzer dall'editor degli schemi o del PCB, impostare i parametri di test desiderati ed eseguire la simulazione. I risultati vengono presentati principalmente tramite la modellazione 2D/3D della disposizione del rame sulla scheda, consentendo una rapida valutazione dei risultati e la possibilità di eseguire test esplorativi di tipo “what-if” sul layout del PCB.

Accesso alle funzionalità di Power Analyzer by Keysight

Per accedere alle funzionalità di Power Analyzer by Keysight in Altium Designer, è necessario installare l'estensione software Power Analyzer by Keysight . Questa estensione può essere installata o rimossa manualmente.

Per ulteriori informazioni sulla gestione delle estensioni, consultare la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Quando si fa clic per scaricare e installare l'estensione, si apre End-User License Agreement (). Facendo clic su Accept si accettano i termini e le condizioni dell'EULA e l'installazione prosegue. Facendo clic su Close si rifiutano i termini e le condizioni dell'EULA e il processo di installazione viene interrotto.

Quando l'estensione software Power Analyzer by Keysight è installata, è possibile:

 
 
 
 
 
  • aggiungere un nuovo documento di analisi dell'alimentazione o aprirne uno esistente; 

  • Button, Manage Power Nets configurare Power Analyzer e le reti di alimentazione; 

  • Button, Show Power Net in Tree esaminare la struttura ad albero delle reti;

  • Button, Show the Power Net Analysis on the PCB esaminare gli eventuali risultati esistenti dell'analisi dell'alimentazione;

  • Button, View the Power Net Analysis results as a Report visualizzare i report esistenti e generarne di nuovi a partire dai risultati esistenti dell'analisi dell'alimentazione.

Tuttavia, per eseguire una nuova analisi dell'alimentazione, è necessario disporre di un abbonamento valido a Power Analyzer by Keysight. In caso contrario, il tentativo di avviare un'analisi dell'alimentazione aprirà la finestra di dialogo Analyze Your Power Nets, dove è possibile richiedere una prova gratuita ().

Avvio di Power Analyzer

Per iniziare a lavorare con Power Analyzer, aprire il documento PCB del progetto o uno dei suoi schemi e selezionare Tools » Power Analyzer by Keysight dai menu principali.

Il documento Power Analyzer Keysight (<ProjectName>.pdnaK) si aprirà e verrà aggiunto all'area Source Documents del progetto (nel pannello Projects), come mostrato di seguito.

Il comando Power Analyzer by Keysight non è disponibile nel menu? Verificare che l'estensione sia installata e di disporre del relativo abbonamento (ulteriori informazioni).

Power Analyzer può essere avviato dai menu dell'editor degli schemi o dell'editor del PCB. Tuttavia, poiché Power Analyzer simula le strutture del PCB, tutte le modifiche di progetto apportate allo schema devono essere sincronizzate con il PCB prima che possano essere rilevate dal documento dell'analizzatore (*.pdnaK). Se una modifica di progetto non viene rilevata, salvare, chiudere e riaprire il documento dell'analizzatore.

Preparazione all'analisi

È tutto pronto per eseguire un'analisi, ma quando fai clic sul pulsante Analyze si apre una finestra di dialogo che propone l'accesso a una versione di prova? Verifica che l'estensione sia installata e che tu disponga del relativo abbonamento (scopri di più).

Power Analyzer deve conoscere le proprietà fisiche della scheda. Queste includono le densità di corrente massime per gli strati superficiali e interni, i diametri minimo e massimo dei via, il tipo di rame, la temperatura di esercizio e così via. Queste proprietà sono definite nell'area Configuration del documento dell'analizzatore.

Opzioni di configurazione

  • I valori di densità di corrente massima e corrente massima nei via sono uguali per tutte le net, poiché dipendono dalla geometria del rame.

  • Le impostazioni Max Current Density for Surface / Internal Layers specificano il valore ammissibile per i corrispondenti strati del PCB.

  • La corrente massima nei via è specificata per le dimensioni minima e massima dei fori utilizzati nel progetto. I valori del diametro dei fori sono definiti nei campi Min Via Diameter e Max Via Diameter, insieme alla Max Current ammessa per quella dimensione del foro.

  • Durante il processo di simulazione, il software suddivide il layout del PCB in una mesh. Per impostazione predefinita, viene utilizzata una dimensione dinamica della mesh. Selezionando la casella di controllo Simulation Mesh Size, puoi definire la dimensione della mesh desiderata.

  • L'impostazione predefinita esclude la net di massa dai risultati della mappa termica. Per includere la net di massa, deseleziona la casella di controllo Skip Ground, quindi seleziona la net GND nel menu a discesa Network / Net nella parte superiore del pannello Power Analysis by Keysight per esplorare i risultati della mappa termica. Tieni presente che la mappa termica supporta le strutture poligonali sugli strati di segnale, ma non è possibile simulare il comportamento di uno strato del piano di alimentazione.

  • Il campo Copper Type specifica il tipo di rame utilizzato, insieme ai parametri associati e a quelli relativi alla temperatura. 

  • Il parametro Work Temperature viene utilizzato per determinare la resistività dei conduttori, mentre il parametro Temperature Compensation è una caratteristica del materiale stesso legata alla sua conducibilità termica. Materiali diversi hanno coefficienti di conducibilità termica diversi e, di conseguenza, influiscono sul riscaldamento del materiale in funzione del carico. Questo riscaldamento influisce sulla resistenza interna del materiale, che a sua volta influisce sulla caduta di tensione.

  • Il valore Via Plating Thickness visualizzato nell'area Global PCB Parameters è definito nel pannello Properties del Layer Stack Manager – scopri di più.

Modifica questi valori predefiniti secondo le esigenze del tuo progetto.

Oltre alla densità di corrente massima e alla corrente massima nei via, è necessario specificare il valore della caduta di tensione ammissibile per ogni net di alimentazione definita. Configura DC Drop Limit per ogni net, selezionando una percentuale predefinita oppure inserendo un valore Custom.

Le impostazioni Auto-Define Settings vengono utilizzate da Power Analyzer quando tenta di definire automaticamente le net di alimentazione del progetto. A questo scopo, deve sapere come identificare elementi del circuito quali regolatori di tensione, connettori e componenti in serie. Oltre a utilizzare indizi come i prefissi dei designatori dei componenti, puoi anche aggiungere parametri a determinati componenti per migliorare il processo di rilevamento automatico. Per ulteriori informazioni, consulta la sezione Requisiti per il riconoscimento automatico.

Aggiunta di una net di alimentazione per la simulazione

Per aggiungere una net di alimentazione per la simulazione, fai clic sul pulsante  in alto a sinistra per aprire la finestra di dialogo Manage Nets. Seleziona la casella di controllo relativa alla Power Net Name desiderata e configura il corrispondente Reference Net. Se una net non dispone di un oggetto porta di alimentazione nello schema elettrico, non verrà visualizzata nell'elenco Power Net Name. Fai clic su Show Custom Nets per includere tutte le net del progetto. Se necessario, è possibile abilitare più net di alimentazione. Le relazioni gerarchiche tra le net di alimentazione vengono risolte automaticamente una volta completata la configurazione della net di alimentazione.

Ogni net di alimentazione richiede una sorgente di alimentazione; queste verranno configurate nel passaggio successivo.

Puoi anche fare clic sul pulsante  per lasciare che il software crei le net di alimentazione, tentando di riconoscere automaticamente la topologia del progetto in base alle impostazioni correnti nell'area Auto-Define Settings della sezione Configuration del documento dell'analizzatore (*.pdnaK).

Aggiunta di una sorgente di alimentazione

Per aggiungere una sorgente di alimentazione, fai clic su + (o sul relativo comando Gestisci) nella sezione Sources del circuito di alimentazione desiderato. Se il circuito include più di una sorgente di alimentazione, fai clic su Gestisci e seleziona i componenti rimanenti.

Affinché un componente sia disponibile come sorgente, deve essere collegato alla Power Net selezionata, ma può essere collegato alla Reference Net selezionata tramite qualsiasi componente connesso a tale Reference Net.

La scheda del componente

Ogni componente incluso come sorgente o carico è rappresentato nel documento di Power Analyzer da una Component Card.

  • Passa il puntatore sulla scheda del componente per visualizzare i pulsanti Edit e Delete.
  • Fai doppio clic sulla scheda del componente per aprire la finestra di dialogo Properties relativa al componente.
  • Fai clic sul valore ID elemento di progetto per individuare il componente nello schema elettrico tramite cross-probing. Il livello di zoom del cross-probing è definito nella sezione Highlight Methods della pagina System - Navigation della finestra di dialogo Preferences.
  • Modifica il valore principale di analisi del componente direttamente nella scheda (oppure modifica il componente per accedere a tutte le proprietà).

Estensione di una net

Le net di alimentazione sulla scheda possono attraversare elementi passivi, come fusibili o resistori, che presentano una net diversa dall'altro lato del componente. In questa situazione, si consiglia di extend the net includendo un componente intermedio e la sua seconda net come parte della net principale. A questo scopo viene utilizzata la funzione Extend Nets.

Per estendere una net, fai clic sull'icona +Estendi net accanto al suo nome per aprire la finestra di dialogo <PowerNet> Extensions Manager. Fai clic su + per estendere la net di destinazione. Power Analyzer visualizza solo le net che possono essere collegate tramite un singolo componente di estensione. Una volta eseguita l'operazione Add sulla net, un componente associato verrà aggiunto automaticamente nella finestra di dialogo <PowerNet> Extensions Manager e potrà essere modificato, se necessario.

Le net di alimentazione possono essere estese tramite un componente in serie.Le net di alimentazione possono essere estese tramite un componente in serie.

Puoi quindi continuare a estendere la net facendo clic sul simbolo +, come mostrato nell'immagine seguente. Al termine, fai clic su Salva nella finestra di dialogo <PowerNet> Extensions Manager.

Continua ad aggiungere componenti in serie e net.Continua ad aggiungere componenti in serie e net.

Note sull'estensione di una net

  • Per ogni componente in serie puoi impostare la caduta di tensione, la resistenza e la corrente massima consentita, che verranno prese in considerazione durante l'analisi (mostra immagine).

  • Se definisci una net errata, puoi eliminarla passando il cursore sul suo nome e facendo clic sull'icona di eliminazione che appare.

  • Una volta salvata la net estesa, i componenti collegati alle net estese appariranno nell'elenco dei carichi e potrai aggiungerli.

  • Accanto al nome della net di alimentazione puoi vedere il numero di estensioni aggiunte; passa il cursore sul numero per visualizzare i nomi delle net di estensione (come mostrato nell'immagine precedente).

  • Il supporto alla simulazione dei componenti in parallelo in una net estesa è stato aggiunto nella versione V1.0.6 dell'estensione PABK, mentre il supporto nell'interfaccia utente è stato aggiunto nella versione V1.0.9. Per definire i componenti in parallelo, seleziona la net nella finestra di dialogo a comparsa Extensions Manager, quindi abilita tutti i componenti in parallelo, come mostrato nell'immagine seguente. Passa il cursore sull'immagine per visualizzare la finestra di dialogo al termine dell'estensione della net.

    Seleziona tutti i componenti in parallelo nella net.Seleziona tutti i componenti in parallelo nella net.

Definizione di un carico

Per aggiungere un componente di carico, fai clic su + (o sul comando Gestisci associato) nella sezione Loads e seleziona il componente desiderato. Un componente viene elencato nella finestra di dialogo quando è collegato alla net principale o a una net estesa.

Dopo aver aggiunto un componente, puoi specificarne il consumo direttamente nella relativa scheda componente oppure facendo clic sul pulsante  per aprire la finestra di dialogo <NetName>/<LoadName> Load Properties.

Note sulla configurazione di un carico

  • Definisci le proprietà del carico, tra cui Load Type, Total Load Current, Min e Max Voltage.
  • Verifica che la net di alimentazione IN sia configurata correttamente, così come le opzioni Reference e Connected to reference through.
  • La corrente di carico viene automaticamente ripartita in modo uniforme tra tutti i pin di alimentazione identificati; modifica questi valori se necessario.
  • Quando configuri un carico di tipo IC (Current), puoi vedere tutti i pin del componente di carico che lo collegano alla sorgente tramite diversi componenti in serie, con la possibilità di selezionare i pin necessari.

Quando la finestra di dialogo Manage Loads (o Add Sources) è aperta, include una colonna Design Item Id. Fai clic su una voce di questa colonna per individuare il componente corrispondente sullo schema tramite cross-probing, così da verificare più facilmente di aver selezionato il componente corretto.

Il livello di zoom del cross-probing è definito nella sezione Highlight Methods della pagina System - Navigation della finestra di dialogo Preferences.

Definizione di un VRM

Per definire un componente modulo regolatore di tensione (VRM), aggiungilo innanzitutto come carico. Quindi apri la finestra di dialogo Load Properties del componente (fai clic sul pulsante ) per configurarlo.

Una volta configurato un carico come VRM, questo apparirà anche come sorgente per la net di alimentazione specificata come sua net OUT.Una volta configurato un carico come VRM, questo apparirà anche come sorgente per la net di alimentazione specificata come sua net OUT.

Note sulla configurazione di un VRM

  • Specifica Load Type come VRM del tipo desiderato.
  • Specifica la tensione di uscita nel campo Vout, insieme alle altre proprietà del regolatore.
  • Configura le net IN e OUT nell'area Nets Management della finestra di dialogo.
  • Se il VRM non si collega direttamente alla net di riferimento o utilizza un riferimento diverso, configura le opzioni Reference e Connected to reference through secondo necessità.
  • Nella gerarchia viene creata automaticamente una rete di alimentazione figlia che ha quel VRM come sorgente (come mostrato sopra).
  • Se il VRM ha più di una net di uscita, aggiungi tutte le net necessarie utilizzando il collegamento +Aggiungi net di uscita nella finestra di dialogo Load Properties e specifica la relativa corrente di uscita nei campi corrispondenti che vengono visualizzati.

La net di alimentazione configurata

Ogni net di alimentazione configurata viene visualizzata come una definizione comprimibile separata nel documento *.pdnaK. Di seguito è mostrata la net PWR_IN configurata, con le sue due net di alimentazione figlie, 3V3 e 1V8, leggermente rientrate per indicarne lo stato di net figlie.

Comprendere la definizione della net di alimentazione

  • Ogni net di alimentazione viene visualizzata come un elemento Power Net Definition comprimibile separato.
  • L'intestazione della definizione della net di alimentazione include:
    • Il nome della net di alimentazione 
    • La net di riferimento 
    • Un indicatore che mostra il numero di net aggiuntive (), se la net è stata estesa. Passa il cursore sull'indicatore per mostrare i nomi delle net figlie.
    • Un pulsante  : fai clic per mostrare la struttura delle connessioni dei componenti di questa net nel contesto dell'intera gerarchia delle net di alimentazione.
    • Un pulsante  : fai clic per eliminare questa net dal processo di analisi, insieme a tutte le net figlie.
    • Un pulsante  : fai clic per analizzare questa net insieme a tutte le eventuali net figlie.
  • Ogni componente della net è rappresentato da una scheda componente.
  • Una volta analizzata la net, i risultati Voltage Drop, Current Density e Max Via Current relativi a quella net vengono mostrati nella definizione della net di alimentazione, come illustrato nell'immagine precedente.
    • Ogni indicatore mostra il valore simulato rispetto al limite specificato. Se il valore è pienamente entro il limite, la linea della scala è verde. Se è vicino al limite, la linea è gialla; se il limite viene superato, la linea è rossa. 
    • Fai clic sul pulsante  per passare all'editor PCB e visualizzare il rame appartenente a questa net sul PCB. Nell'editor PCB, utilizza il pannello Power Analyzer by Keysight per controllare il processo di analisi.
    • Fai clic sul pulsante  per generare e aprire un report dettagliato sulla net di alimentazione. All'interno del report, utilizza  pulsante per salvare una copia HTML.

La vista ad albero delle reti di alimentazione

Per visualizzare la rete di alimentazione configurata (e le eventuali reti figlie definite tramite VRM) in una struttura ad albero, fai clic sul pulsante  corrispondente. Verrà mostrata l'intera struttura, con la rete di alimentazione specifica e i componenti associati opportunamente evidenziati.

La vista ad albero consente di verificare rapidamente se l'intera rete di alimentazione è stata definita come richiesto ed è pronta per l'analisi. Per tornare alla finestra principale, fai clic sul collegamento Power Analyzer by Keysight nell'angolo superiore sinistro del documento .pdnaK.

Eseguire un'analisi

Una volta completata la configurazione, puoi eseguire un'analisi per una rete specifica facendo clic sul pulsante  corrispondente. Un riepilogo dei risultati dell'analisi viene presentato nella definizione della rete di alimentazione, come mostrato di seguito. Per visualizzare i risultati sul PCB, fai clic sul pulsante  corrispondente.

Per analizzare tutte le reti configurate in un'unica operazione, fai clic sul pulsante  (in alto a destra nel documento dell'analizzatore). Se scegli di analizzare la rete di alimentazione di livello superiore nella struttura ad albero, verranno analizzate anche tutte le sottoreti (create tramite componenti VRM). Se tutte le reti sono state analizzate, puoi selezionare la rete attualmente evidenziata utilizzando il menu a discesa Network/Net nella parte superiore del pannello Power Analyzer by Keysight. 

Gestione dei layer

Puoi passare da un layer all'altro della simulazione come quando lavori sul PCB, tramite le schede dei layer nella parte inferiore della finestra dell'editor PCB. Puoi anche concentrarti sul layer corrente con la scorciatoia Shift+S; usa questa scorciatoia per scorrere le opzioni di visibilità della modalità layer singolo.

Usa le schede dei layer del PCB per cambiare rapidamente la visualizzazione dei risultati dell'analisi. Qui sono mostrati i risultati del layer superiore. Passa il cursore sull'immagine per visualizzare quelli del layer inferiore.Usa le schede dei layer del PCB per cambiare rapidamente la visualizzazione dei risultati dell'analisi. Qui sono mostrati i risultati del layer superiore. Passa il cursore sull'immagine per visualizzare quelli del layer inferiore.

Il pannello Power Analyzer by Keysight

Nell'editor PCB, il processo di analisi e i risultati vengono gestiti tramite il pannello Power Analyzer by Keysight. Nota che il pannello viene aggiunto all'elenco dei pannelli disponibili (tramite il pulsante Panels) dopo aver eseguito un'analisi dell'alimentazione e aver fatto clic sul pulsante  .  

Rete di alimentazione / Net

  • Network / Net - consente di selezionare la rete di alimentazione () o la net () da visualizzare come mappa termica nell'area di lavoro grafica.
  • Only nets with violations - quando questa opzione è attiva (impostazione predefinita), nel menu a discesa sono disponibili solo le reti che presentano attualmente una violazione. Disattiva questa opzione per elencare tutte le reti di alimentazione. 
  • Usa le tecniche standard dell'editor PCB per eseguire panoramiche e zoom nell'area di lavoro ed esaminare i risultati della simulazione.

Sotto il selettore Network / Net, il pannello presenta due schede, General e Heatmap. Le opzioni di queste schede si applicano alla net attualmente selezionata nel menu a discesa Network / Net.

Seleziona la rete da visualizzare, quindi configura le opzioni generali o della mappa termica per quella rete.Seleziona la rete da visualizzare, quindi configura le opzioni generali o della mappa termica per quella rete.

Mappa termica

La scheda Heatmap del pannello Power Analyzer by Keysight consente di controllare quali dati vengono presentati come mappa termica, ossia la densità di corrente o la caduta di tensione, e come viene applicato il colore alla densità di corrente o alla caduta di tensione.

Usa la scheda Heatmap  del pannello Power Analyzer by Keysight per modificare i risultati della simulazione presentati sul PCB. Qui sono visualizzati i risultati della densità di corrente. Passa il cursore sull'immagine per visualizzare i risultati della caduta di tensione.Usa la scheda Heatmap del pannello Power Analyzer by Keysight per modificare i risultati della simulazione presentati sul PCB. Qui sono visualizzati i risultati della densità di corrente. Passa il cursore sull'immagine per visualizzare i risultati della caduta di tensione.

Le opzioni per ciascuna di queste modalità sono descritte di seguito.

Mappa termica della densità di corrente
  • L'intera rete viene colorata per rappresentare la densità di corrente in ogni suo punto: maggiore è la densità di corrente, più caldo (più rosso) è il colore. 
  • Show Heatmap - usa questo controllo per rimuovere rapidamente la mappa termica e ripristinare la visualizzazione standard del PCB. 
  • Show Arrows of Current Direction - abilita questa opzione per visualizzare piccole frecce che indicano la direzione del flusso di corrente lungo tutta la rete.
  • Use Noise Suppression - Quando la corrente calcolata si avvicina a zero, le frecce della direzione della corrente danno l'impressione che in quell'area scorra corrente, mentre in realtà è pressoché assente. Abilita questa opzione per escludere questi valori di corrente più bassi e potenzialmente fuorvianti.
  • Scope Controller - il modo in cui il colore viene applicato alla rete per visualizzare l'intensità, o il calore, è controllato da Scope Controller. Il valore Max è impostato per impostazione predefinita sulla densità di corrente massima calcolata per quella rete (mostra immagine), mentre Min è impostato su 0 A/mm2. Questa scala viene visualizzata come una barra colorata sotto il PCB e rappresenta: le impostazioni Min e Max correnti, una scala determinata dal tipo di scala selezionato e le unità di misura. I valori Min e Max possono essere regolati facendo clic e trascinando il cursore oppure inserendo un nuovo valore nei campi Min o Max. I valori calcolati inferiori a Min sono visualizzati in blu e quelli superiori a Max in rosso. 
  • Use Logarithmic Scale - abilita questa opzione per passare dalla scala lineare a quella logaritmica. Una scala logaritmica ha l'effetto di concentrare i valori più alti verso l'estremità hot della scala cromatica. Ad esempio, puoi abilitare la scala logaritmica per individuare rapidamente i tratti di piste che trasportano correnti più elevate, quindi passare alla scala lineare per esaminare la distribuzione delle densità di corrente all'interno di quel tratto.

La mappa termica logaritmica della densità di corrente mostra un'area critica; passa il cursore sull'immagine per visualizzare quell'area con la scala lineare.La mappa termica logaritmica della densità di corrente mostra un'area critica; passa il cursore sull'immagine per visualizzare quell'area con la scala lineare.

Mappa termica della caduta di tensione
  • L'intera net viene colorata per rappresentare la caduta di tensione in ogni suo punto: maggiore è la tensione, più caldo (tendente al rosso) è il colore. Con questo approccio, più freddo è il colore, minore è la tensione (e maggiore è la caduta di tensione). 
  • Show Heatmap - usa questo controllo per rimuovere rapidamente la mappa termica e ripristinare la visualizzazione standard del PCB. 
  • Show Arrows of Current Direction - abilita questa opzione per visualizzare piccole frecce che indicano la direzione del flusso di corrente lungo l'intera net.
  • Use Noise Suppression - Quando la corrente calcolata si avvicina allo zero, le frecce di direzione danno l'impressione che in quell'area scorra corrente, mentre in realtà è pressoché assente. Abilita questa opzione per escludere questi valori di corrente più bassi e potenzialmente fuorvianti.
  • Scope Controller - il modo in cui il colore viene applicato alla net per visualizzare l'intensità, o il calore, è controllato da Scope Controller. Il valore Max è impostato per default appena al di sotto della tensione massima specificata per quella net, mentre il valore Min è Max - calculated voltage drop (mostra immagine). Questa scala viene visualizzata come una barra colorata sotto il PCB e rappresenta la caduta di tensione come valore assoluto o percentuale, le impostazioni Min e Max correnti e le unità di misura. I valori Min e Max possono essere regolati facendo clic e trascinando i cursori oppure inserendo un nuovo valore nei campi Min o Max. I valori calcolati inferiori a Min vengono visualizzati in blu, mentre quelli superiori a Max vengono visualizzati in rosso. 
  • Scale Type - la scala della caduta di tensione può essere espressa in volt (fai clic sul pulsante  ) oppure in percentuale (fai clic sul pulsante  ).
  • Enable Visual Slider for Voltage Contour - se abilitata, questa opzione visualizza sulla mappa termica i punti in cui la tensione è uguale ai valori di tensione specificati per i punti di contorno, consentendo di individuarli facilmente. I valori dei punti di contorno possono essere regolati trascinando i cursori oppure digitando i valori nei campi Voltage Contour Points sottostanti. È possibile aggiungere altri punti e rimuovere quelli esistenti facendo clic sull'icona corrispondente.

I punti di contorno possono essere configurati per individuare rapidamente i punti della scheda in cui la tensione corrisponde a quel valore.I punti di contorno possono essere configurati per individuare rapidamente i punti della scheda in cui la tensione corrisponde a quel valore.

Rilevamento delle violazioni

Se la simulazione rileva una violazione di tipo Voltage Drop, Current Density o Max Via Current, questa viene elencata nella sezione Violations del pannello Power Analyzer by Keysight. Fai clic su una violazione nel pannello per individuare tramite cross-probing il punto specifico del PCB in cui si è verificato l'errore. Se non riesci a leggere l'intera descrizione della violazione, passa il cursore sulla sezione Descrizione della violazione per visualizzare un suggerimento con tutti i dettagli.

Le violazioni vengono riportate automaticamente in dettaglio nella sezione Violations del pannello Power Analyzer by Keysight. Passa il cursore sull'immagine per visualizzare una violazione della corrente in un via.Le violazioni vengono riportate automaticamente in dettaglio nella sezione Violations del pannello Power Analyzer by Keysight. Passa il cursore sull'immagine per visualizzare una violazione della corrente in un via.

Nota che la modalità della mappa termica (Densità di corrente o Caduta di tensione) viene selezionata automaticamente in base al tipo di violazione su cui fai clic. 

Sonde

La sezione Sonde del pannello Power Analyzer by Keysight viene utilizzata per posizionare sonde di misura direttamente sul PCB. Le sonde possono misurare la densità di corrente o la caduta di tensione; il tipo di misura è determinato dalla modalità corrente della mappa termica della scheda.

Le sonde possono essere di due tipi:

  1. Una sonda singola, per misurare un valore assoluto nel punto in cui è posizionata, oppure
  2. Una sonda differenziale, per misurare la differenza tra i due punti di misura. 

Entrambi i tipi di sonde vengono posizionati facendo clic sul pulsante  nell'area Probes del pannello. Per posizionare una sonda singola, fai clic nel punto desiderato, quindi fai clic con il pulsante destro del mouse (oppure premi Esc). Per posizionare una sonda differenziale, fai clic una volta per definire il primo punto di misura, quindi fai clic una seconda volta per definire il secondo. Una volta definita una sonda, i risultati delle misure vengono visualizzati nel pannello.

Quando si posiziona una sonda, si applicano le stesse funzioni di aggancio utilizzate per posizionare gli altri oggetti di progettazione nell'editor PCB. Per ulteriori informazioni sul sistema unificato di aggancio del cursore, consulta la pagina Utilizzo del sistema di aggancio del cursore.

Fai clic sul pulsante  per creare un'immagine del PCB in corrispondenza dell'ultima sonda su cui hai fatto clic. L'immagine verrà visualizzata nell'area Image Captures del pannello, contrassegnata da un indicatore Probe. Passa il cursore sulla schermata acquisita per visualizzare i dettagli della sonda (mostra immagine). 

Le sonde possono misurare la tensione o la corrente, sia come valore assoluto sia come differenza tra due punti. Passa il cursore sull'immagine per visualizzare una sonda di corrente.Le sonde possono misurare la tensione o la corrente, sia come valore assoluto sia come differenza tra due punti. Passa il cursore sull'immagine per visualizzare una sonda di corrente.

Se il progetto viene modificato in qualsiasi modo, è necessario eliminare le sonde esistenti () e posizionarne di nuove.

Acquisizioni di immagini

La funzione di acquisizione delle immagini nel pannello Power Analyzer by Keysight consente di acquisire una schermata specifica del progetto relativa alla net selezionata, che può poi essere inclusa in un report.

Per acquisire un'immagine di un'area specifica della scheda, imposta innanzitutto la vista della scheda nello spazio di progettazione principale in modo che siano visibili gli elementi da includere nell'acquisizione. Quando sei pronto, fai clic sul pulsante   nell'area Image Captures del pannello per acquisire la schermata. Puoi continuare a modificare la vista della scheda e Add altre immagini. Per eliminare un'immagine, passa il cursore sull'immagine per visualizzare il pulsante  , quindi fai clic una volta per eliminarla.

Le immagini acquisite non vengono conservate con il progetto. Per salvarle, genera un report di analisi.

Report di analisi

Per generare un report di analisi completo, fai clic sul pulsante  nella parte superiore del documento dell'analizzatore. Il report completo include una sezione per ogni net di alimentazione della rete, come mostrato nell'immagine seguente. 

All'interno del report, fai clic su una net di alimentazione per visualizzarne un report dettagliato, che include:

  • Impostazioni di configurazione globali
  • Stackup dei layer della scheda
  • Mappe termiche della densità di corrente per ogni layer di segnale
  • Mappe termiche della caduta di tensione per ogni layer di segnale
  • La vista ad albero della rete di alimentazione, con la net scelta evidenziata.
  • Dettagli dell'analisi per la net scelta, tra cui: consumo energetico; dettagli dei margini e degli esiti di superamento o mancato superamento; un riepilogo dettagliato delle prestazioni di tutti i via della net; tutte le schermate acquisite definite dall'utente.

  • Fai clic sul pulsante  per salvare il report in formato HTML. Usa la successiva finestra di dialogo Save Report Settings per configurare quali reti e dati specifici includere nel report.
  • Il report viene salvato in una sottocartella della cartella del progetto, denominata \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime>.
  • Tutte le immagini del report vengono salvate in una sottocartella \Images.
  • Durante l'analisi vengono generati anche diversi file di log, anch'essi salvati in una sottocartella della cartella del progetto, denominata \PowerAnalyzerByKeysight_Output\<BoardName>\.

Requisiti per il riconoscimento automatico

Oltre all'aggiunta manuale delle reti di alimentazione, Power Analyzer by Keysight consente di riconoscere e aggiungere automaticamente le reti di alimentazione, incluse sorgenti e carichi, riducendo il tempo necessario per definire una struttura di alimentazione.

Impostazioni di definizione automatica

Prima di avviare il riconoscimento automatico, è necessario configurare i parametri dell'algoritmo in base al progetto. Questi parametri si configurano nell'area Auto-Define Settings della sezione Configuration della finestra del documento di Power Analyzer by Keysight.

I componenti che non soddisfano questi criteri di definizione automatica vengono trattati come carichi normali. È inoltre possibile aggiungere parametri con nomi specifici ai singoli componenti dello schema, definendone il tipo e le proprietà nel sistema di alimentazione. Questi parametri possono essere specificati durante la creazione del componente oppure aggiunti successivamente nello schema.

Parametri dei componenti

Per un riconoscimento corretto, tutti i componenti relativi all'alimentazione devono soddisfare i seguenti criteri:

  • Per rilevare automaticamente un componente sorgente, il componente deve avere un parametro denominato Component Type, con valore Source.

  • Se il parametro non viene trovato, la ricerca si baserà su Default Connectors Designators, definiti nell'area Auto-Define Settings della sezione Configuration nel documento dell'analizzatore (*.pdnaK). Si noti che verranno definiti solo i connettori con connessioni di alimentazione, a meno che non siano indicati come parte di una rete estesa.
  • Moduli regolatori di tensione (VRM):
    • I regolatori lineari devono avere un parametro denominato Component Type, con valore VRM.
    • Per un regolatore VRM di tipo SMPS, il parametro Component Type deve avere il valore SMPS.
    • Se il VRM include una funzione di rilevamento (Sense), il parametro Component Type deve avere il valore Sense.

  • Se il parametro non è definito, la ricerca si baserà su VRM Keywords definiti nell'area Auto-Define Settings della sezione Configuration nel documento dell'analizzatore. Per impostazione predefinita, queste parole chiave sono: PWR, REG, Regulator, Voltage, Switch.

  • Il valore di assorbimento del componente (carico) deve essere definito con un parametro denominato Current Consumption. Prestare attenzione al simbolo del separatore decimale utilizzato nel valore: può essere . oppure , in base alle preferenze di sistema.

Se un componente dispone del parametro Current Consumption, il valore specificato viene suddiviso tra tutti i pin collegati allo stesso circuito.

Sincronizzazione dei parametri

Tutti i parametri devono essere sincronizzati tra il PCB e lo schema. Per verificarlo, selezionare un componente sul PCB e controllare che i parametri di analisi dell'alimentazione siano presenti nella scheda Parameters del pannello Properties.

Requisiti del progetto

  • Tutte le reti di alimentazione devono essere definite:
    • utilizzando un oggetto Power Port,
    • configurando la proprietà Power Net in modo che la rete includa Supply Net Parameter (come descritto di seguito),
    • oppure assegnando loro un nome che venga rilevato da Name Mask (definito nell'area Auto-Define Settings della sezione Configuration nel documento dell'analizzatore).
  • Per ottenere un valore di tensione utilizzando Name Mask, il nome della rete di alimentazione deve rispettare il formato *V* o *.*V, dove * è un valore numerico, come mostrato nell'immagine seguente.

  • Un modo alternativo per definire il valore di tensione della rete di alimentazione consiste nel configurare la proprietà Power Net, definita nel pannello Properties per qualsiasi filo della rete. Per abilitare la proprietà, posizionare prima una direttiva Parameter Set (Place » Directives » Parameter Set) sulla rete (passare il cursore sull'immagine seguente per visualizzare un'immagine di questa procedura). Dimensioni, colore ed etichetta sono definiti dall'utente: è la presenza della direttiva ad abilitare la proprietà Power Net della rete. Una volta aggiunta la direttiva, selezionare un filo della rete, abilitare la proprietà Power Net e configurare Voltage della rete, come mostrato di seguito. 

  • I componenti in serie devono rispettare i designatori definiti per resistori, induttori e componenti in serie personalizzati (come definiti nell'area Auto-Define Settings della sezione Configuration nel documento dell'analizzatore).

  • I VRM devono essere collegati ad almeno due reti di alimentazione.

Comandi di Power Analyzer

I seguenti comandi sono disponibili nei menu principali dell'editor di Power Analyzer.

Comando

Descrizione e utilizzo

Tools » Define Automatically

Tenta di riconoscere automaticamente la topologia del progetto in base alle impostazioni correnti nell'area Auto-Define Settings della sezione Configuration nel documento dell'analizzatore (*.pdnaK). Questo comando è accessibile anche facendo clic sul pulsante Define Automatically in alto a sinistra nell'editor.

File » Load from File

Carica un documento di Power Analyzer by Keysight salvato (*.pdnaK) nell'editor di Power Analyzer.

Edit » Manage Nets

Apre la finestra di dialogo Manage Nets, in cui selezionare le reti di alimentazione da analizzare. Selezionando la casella di una rete, questa viene aggiunta al documento dell'analizzatore (*.pdnaK). Deselezionandola, la rete viene rimossa dal documento insieme a tutte le reti di alimentazione figlie. Questo comando è accessibile anche facendo clic sul pulsante Manage Nets in alto a sinistra nell'editor. Per ulteriori informazioni, consultare Gestione delle reti.

File » Save

Salva la configurazione corrente di Power Analyzer in un documento di Power Analyzer by Keysight (*.pdnaK)

File » Save As

Salva la configurazione corrente di Power Analyzer in un documento di Power Analyzer by Keysight (*.pdnaK) con un nuovo nome definito dall'utente.

Tools » Measurement Units » mil

Configura Power Analyzer per utilizzare le unità di misura imperiali (mil).

Tools » Measurement Units » mm

Configura Power Analyzer per utilizzare le unità di misura metriche (mm).

Limitazioni di Power Analyzer

Attualmente, Power Analyzer by Keysight non supporta:

  1. Tensioni negative.
  2. Componenti incorporati (componenti posizionati su uno strato interno). Per ulteriori informazioni, consultare Progettazione di un PCB con componenti incorporati.

 

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents