Navigazione in un documento
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Quando lavori con un documento grafico, come un foglio schematico, un documento PCB o un documento Draftsman, puoi ingrandire, ridurre e spostare la vista per concentrarti su un'area specifica del documento. Le scorciatoie di base che puoi utilizzare sono:
- Ctrl+Mouse Wheel per ingrandire e ridurre la vista
- Right-Click, Hold&Drag per spostare il documento
Il menu principale View include diversi comandi che consentono di controllare la visualizzazione del documento corrente.


Utilizza i comandi del menu principale View per controllare la visualizzazione del documento. Nell'immagine in alto è mostrato il menu View dell'editor degli schemi. Nell'immagine in basso è mostrato il menu View dell'editor PCB.
Questi comandi includono:
-
Fit Document - visualizza l'intera area del documento corrente.
-
Fit All Objects - visualizza tutti gli oggetti di progettazione presenti nel documento corrente.
-
Area - ingrandisce un'area del documento corrente definita dall'utente.
-
Around Point - ridefinisce l'area di visualizzazione attorno a un punto specificato nel documento corrente.
-
Selected Objects - modifica la vista nell'area di progettazione in modo che tutti gli oggetti selezionati siano visibili.
-
Zoom In - ingrandisce il progetto nel documento corrente rispetto alla posizione del cursore.
-
Zoom Out - riduce il progetto nel documento corrente rispetto alla posizione del cursore.
-
Zoom Last - ripristina la visualizzazione precedente del documento corrente.
Passaggio a un punto specifico di un documento
Utilizzando i comandi del sottomenu Edit » Jump nei menu principali degli editor degli schemi, dei simboli schematici, PCB o delle impronte PCB, puoi passare a un punto specifico del documento attivo. Puoi accedere al menu a comparsa di navigazione anche premendo il tasto J nell'area di progettazione. Ad esempio, puoi passare a:
- le coordinate di origine del documento:
-
qualsiasi posizione nel documento corrente, in base alle coordinate XY specificate dall'utente - seleziona il comando New Location per inserire, nella finestra di dialogo Jump To Location che si apre, i valori delle coordinate X e Y della posizione nell'area di progettazione in cui desideri spostare il cursore. Nell'editor PCB puoi anche utilizzare i campi Delta X e Delta Y per specificare gli scostamenti delle coordinate X e Y per la posizione desiderata.

La finestra di dialogo Jump To Location - nell'editor degli schemi (prima immagine) e nell'editor PCB (seconda immagine) -
un oggetto all'interno del documento. Utilizza i seguenti comandi per passare all'oggetto desiderato:
-
un componente sul foglio schematico - Jump Component. Dopo aver avviato il comando, viene visualizzata la finestra di dialogo Component Designator. Inserisci il designatore del componente a cui desideri passare. Se il designatore è valido e il componente esiste in un documento schematico sorgente del progetto attivo, il documento schematico corrispondente viene reso attivo e il componente di destinazione viene ingrandito e centrato (ove possibile) nell'area di progettazione. Il componente trovato (o tutte le parti, nel caso di un componente multiparte) viene elencato anche nel pannello Messages . Fai doppio clic su una voce del messaggio per passare al componente (o a una sua parte) nell'area di progettazione.

La finestra di dialogo Component Designator -
un componente specifico nel documento PCB - Component. Dopo aver avviato il comando, viene visualizzata la finestra di dialogo Component Designator. Digita il designatore del componente per passare a quel componente. Se non conosci con certezza il designatore, digita
?e fai clic su OK per aprire la finestra di dialogo Components Placed, che elenca tutti i componenti del progetto. Inserisci del testo nel campo Mask per cercare il componente desiderato. Durante la digitazione, l'elenco viene filtrato per mostrare solo le stringhe che corrispondono alla maschera di ricerca. Nella stringa puoi utilizzare i caratteri jolly?(qualsiasi carattere singolo) e*(qualsiasi sequenza di caratteri). Il cursore si sposta sul punto di riferimento del componente selezionato.
Digita?nella finestra di dialogo Component Designator per accedere alla finestra di dialogo Components Placed, che elenca tutti i componenti del PCB. -
una net specifica nel documento PCB - Net. Dopo aver avviato il comando, viene visualizzata la finestra di dialogo Net Name. Digita il nome della net a cui desideri passare, oppure digita ? e premi OK per aprire la finestra di dialogo Nets Loaded, che contiene l'elenco di tutte le net caricate per il progetto. Inserisci del testo nel campo Mask per cercare la net desiderata. Durante la digitazione, l'elenco viene filtrato per mostrare solo le stringhe che corrispondono alla maschera di ricerca. Nella maschera di ricerca puoi utilizzare i caratteri jolly
?(qualsiasi carattere singolo) e*(qualsiasi sequenza di caratteri). Se la net di destinazione è già visualizzata nella finestra principale di progettazione, il cursore si sposta sull'oggetto di progettazione più vicino appartenente a quella net. Se la net non è visibile, il cursore viene posizionato sull'oggetto di progettazione più vicino appartenente a quella net, che viene centrato nell'area di progettazione (ove possibile).
Digita ?nella finestra di dialogo Net Name per accedere alla finestra di dialogo Nets Loaded, che elenca tutte le net del PCB. -
una piazzola specifica di un componente nel documento PCB - Pad. Dopo aver avviato il comando, verrà visualizzata la finestra di dialogo Jump To Pad Number. Inserire la piazzola richiesta del componente desiderato nel formato ComponentDesignator-PadDesignator (ad esempio, U1-6) e fare clic su OK. Se la piazzola di destinazione è già visibile nell'area di progettazione, il cursore si sposterà semplicemente al centro della piazzola. Se la piazzola non è visibile, il cursore verrà posizionato al centro della piazzola, centrata nell'area di progettazione (ove possibile).

La finestra di dialogo Jump To Pad Number -
una stringa specifica nel documento PCB - String. Dopo aver avviato il comando, verrà visualizzata la finestra di dialogo Jump To String. Digitare la stringa a cui si desidera passare oppure digitare ? e fare clic su OK per aprire la finestra di dialogo Strings, contenente un elenco di tutte le stringhe presenti nel documento della scheda attivo (sia indipendenti sia appartenenti ad altri oggetti di gruppo). Utilizzare questa finestra di dialogo per individuare rapidamente la stringa a cui si desidera passare. Se la stringa di destinazione è già visibile nell'area di progettazione, il cursore si sposterà semplicemente al punto di ancoraggio della stringa, ovvero il punto da cui viene afferrata durante uno spostamento o attorno al quale viene ruotata. Se la stringa non è visibile, il cursore verrà posizionato sul punto di ancoraggio della stringa, centrato nell'area di progettazione (ove possibile).

Digitare?nella finestra di dialogo Jump To String per accedere alla finestra di dialogo Strings, che elenca tutte le net del PCB.Il sistema eseguirà tre ricerche: prima cercherà una stringa che corrisponda a quella specificata per maiuscole e minuscole, caratteri e lunghezza; poi una stringa contenente gli stessi caratteri, ma eventualmente con caratteri aggiuntivi; infine una stringa con gli stessi caratteri, senza distinzione tra maiuscole e minuscole.
-
passare in rassegna tutti i marcatori di errore nel documento di progetto corrente - Error Marker. Dopo aver avviato il comando, il cursore si sposterà sul primo marcatore di errore del controllo delle regole di progettazione (DRC), centrato nella finestra di progettazione principale. Utilizzando ripetutamente il comando, si passerà al secondo marcatore di errore e così via. Questo comando consente di passare a un marcatore di errore indipendentemente dal fatto che la violazione sia stata accettata in deroga o meno.
Esaminare le violazioni associate all'oggetto sotto il cursore facendo clic con il pulsante destro del mouse e scegliendo il comando pertinente dal sottomenu Violations .
-
-
passare in rassegna tutti gli oggetti di progetto selezionati nel documento corrente - Selection. Dopo aver avviato il comando, il cursore si sposterà sul primo oggetto selezionato, che verrà ingrandito e centrato nella finestra di progettazione principale. Utilizzando ripetutamente il comando, si passerà al secondo oggetto selezionato e così via, scorrendo ciclicamente tutti gli oggetti selezionati nel documento corrente. Il comando scorre gli oggetti selezionati nell'ordine in cui sono stati originariamente aggiunti alla selezione.
-
una posizione nel documento schematico o PCB corrente, le cui coordinate sono state precedentemente memorizzate nel marcatore di posizione indicato - selezionare il comando Location Marks » n per passare alla posizione memorizzata nel marcatore di posizione indicato tramite il comando Set Location Marks » n.
