Pannello Navigator
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
A colpo d'occhio
- Scopri come il pannello Navigator consente di esplorare i singoli fogli dello schema elettrico, l'intero progetto e la gerarchia del progetto per trovare rapidamente gli oggetti connessi.
- Scopri come navigare in entrambe le direzioni, dal pannello allo schema elettrico e dallo schema elettrico al pannello, e in quali casi Alt-clic può aiutarti a individuare gli elementi correlati sul PCB.
- Comprendi come l'evidenziazione, lo zoom, l'attenuazione e la validazione influiscono su ciò che visualizzi durante la navigazione, per seguire meglio le connessioni nei progetti complessi.
Se il progetto è di grandi dimensioni e distribuito su molti fogli, può diventare difficile seguire una net e verificare la connettività del progetto semplicemente osservando gli schemi. Individuare gli stessi oggetti sul PCB rappresenta una sfida ancora maggiore. Per agevolare questo processo, si utilizza il pannello Navigator.

Utilizza il pannello Navigator per avere una visione dell'intero progetto. Tieni premuto Alt mentre fai clic nel pannello per individuare l'elemento anche sul PCB.
Il pannello Navigator consente di esplorare il documento schematico sorgente attivo oppure tutti i documenti schematici sorgente del progetto attivo. Il pannello utilizza come base per la navigazione il modello di connettività del progetto, che viene creato automaticamente in background. Il pannello può essere utilizzato anche per individuare componenti, pad, bus e net sul PCB.
Navigazione nel progetto
La navigazione può essere eseguita in due modi: facendo clic nel pannello Navigator per individuare l'oggetto nello schema, oppure facendo clic sull'oggetto nello schema per individuarlo nel pannello Navigator.
Dal pannello Navigator
Per visualizzare il pannello Navigator, utilizza il pulsante Panels in basso a destra nel software oppure seleziona View » Panels » Navigator dai menu.
Le informazioni sui componenti e sulla connettività vengono caricate nel pannello non appena viene aperto uno schema; fai clic su un'icona nella sezione Documents per visualizzarle. Il software crea automaticamente un modello dati dinamico per l'intero progetto e lo mantiene aggiornato durante le operazioni di modifica. Tieni presente che le schede dei documenti non vengono visualizzate (nella parte superiore dell'area di modifica grafica) per tutti i fogli dello schema, che vengono aperti in background: una scheda compare solo quando l'utente esegue un'azione sul relativo foglio.
Il modello dati dinamico è disponibile per ciascun editor e anche per il pannello Navigator. Se in qualsiasi momento non sei sicuro che il contenuto del pannello corrisponda allo stato attuale del progetto, seleziona il comando Validate Project per forzare l'aggiornamento del modello (dal menu Project o dal menu contestuale accessibile con il tasto destro del mouse nel pannello Navigator).

Fai clic su un oggetto nel pannello Navigator per individuarne tutte le istanze nell'intero progetto.
Navigazione interattiva
Oltre a navigare dagli elenchi di oggetti presenti nel pannello e fare clic per individuare un oggetto nell'area grafica, puoi anche navigare dall'area grafica all'elenco. Questa modalità, denominata navigazione interattiva, si attiva facendo clic sul pulsante Interactive Navigation nella parte superiore del pannello Navigator. Il cursore assume la forma di un mirino, a indicare che sei in modalità di navigazione, che rimane attiva finché non fai clic con il tasto destro del mouse o premi il tasto Esc .
Durante la navigazione nel progetto, la visualizzazione del foglio viene aggiornata in base alle opzioni di evidenziazione correnti e il pannello Navigator si aggiorna per mostrare le informazioni relative alla selezione corrente nella finestra di modifica grafica.

Attiva la navigazione interattiva (tramite il pulsante nella parte superiore del pannello Navigator), quindi fai clic su un oggetto nel foglio per individuarlo nel pannello e nel resto del progetto.
Scorciatoia per la navigazione interattiva
Oltre ad avviare la navigazione interattiva dal pannello Navigator, puoi attivarla in qualsiasi momento nell'editor schematico tenendo premuto Alt mentre fai clic su un oggetto del progetto. Puoi fare clic su qualsiasi oggetto, inclusi un filo, un'etichetta di net, una porta, un ingresso di foglio, un simbolo di foglio o un componente.
Utilizza la scorciatoia Alt+clic per navigare nel progetto.
Come vengono evidenziati gli oggetti durante la navigazione
Quando fai clic su un oggetto nel pannello Navigator, l'oggetto viene visualizzato nell'area di modifica grafica. Il modo in cui viene visualizzato dipende dalle impostazioni System - Navigation nella finestra di dialogo Preferences. Per accedere alle impostazioni direttamente dal pannello Navigator, fai clic sul pulsante Navigation Options nella parte superiore del pannello per aprire la finestra di dialogo.
La sezione Highlight Methods della finestra di dialogo Preferences offre opzioni per controllare il risultato visivo del filtraggio temporaneo applicato al documento durante la navigazione, sia dal pannello sia all'interno del documento stesso. È possibile attivare qualsiasi combinazione di queste opzioni. Ad esempio, potresti voler ingrandire e selezionare tutti gli oggetti filtrati nella finestra dell'editor di progettazione, attenuando al contempo gli altri oggetti del progetto per ridurre l'affollamento visivo.
Il pannello Navigator
Il pannello Navigator offre una vista del modello di connettività del progetto. La struttura del progetto è presentata nelle quattro sezioni del pannello, ciascuna descritta di seguito.
Il pannello Navigator presenta una vista dell'intero progetto incentrata sulla connettività.
Sezione Documenti
Situata nella parte superiore del pannello, la sezione Documents offre tre diversi modi per visualizzare il progetto: individual sheets, flattened hierarchy (l'intero progetto) oppure la possibilità di esplorare full design hierarchy. Fai clic una volta su un'icona in questa prima sezione per caricare i dati nel pannello; fai doppio clic per visualizzare i risultati anche nell'area di modifica grafica.
Funzionalità della sezione Documenti
Sezione Documenti |
|
| Individual Sheets | Visualizza un'icona per ciascuno dei fogli schematici acquisiti, identificati da Fai clic una volta per visualizzare i risultati nel pannello Navigator; fai doppio clic per visualizzarli anche nell'area di modifica grafica. |
| Flattened Hierarchy (intero progetto |
Visualizza tutti gli oggetti e la connettività dell'intero progetto. Se il progetto contiene fogli ripetuti (canali), viene visualizzata un'icona figlia per ciascuna classe di canali, identificata dal nome del canale (derivato da Fai clic una volta per visualizzare i risultati nel pannello Navigator; fai doppio clic per visualizzarli anche nell'area di modifica grafica. |
| Full Design Hierarchy | Visualizza un'icona per ogni foglio logico del progetto. Se il progetto contiene fogli ripetuti (canali), è presente un'icona di foglio per ogni canale, identificato da Fai clic una volta per visualizzare i risultati nel pannello Navigator; fai doppio clic per visualizzarli anche nell'area di modifica grafica. Se fai doppio clic sull'icona di un canale ripetuto, oltre a visualizzare il foglio di quel canale, viene selezionata la scheda del canale specifico nella parte inferiore dell'area di modifica dello schema. |
Sezione Componenti
La seconda sezione del pannello contiene tutti i componenti presenti nel documento attualmente selezionato nella prima sezione. Quando selezioni nell'elenco una voce relativa a un'istanza di componente di primo livello, viene applicato un filtro basato su tale voce, il cui risultato visivo è determinato dai metodi di evidenziazione scelti. Se le opzioni di evidenziazione attive includono l'opzione Connective Graph, saranno visibili tutti gli altri componenti collegati al componente selezionato (il filtro viene esteso per includerli). I componenti collegati sono evidenziati visivamente dalle linee di connessione verdi del grafo.
Poiché il grafo di connettività è attivo, viene tracciata una linea verde verso ciascun componente collegato al componente selezionato nel pannello.
Funzionalità della sezione Componenti
Sezione Componenti |
|
| Information available | Per ogni voce di componente sono presenti sottocartelle per Parameters e Implementations (modelli). Se l'opzione Pins è attiva nelle opzioni di evidenziazione, è disponibile anche una sottocartella Pins |
| When you click | Quando fai clic sulla voce di un pin nell'elenco Instance, la voce corrispondente a quel pin viene selezionata nella sezione Net / Bus del pannello e tutti i pin della net a cui appartiene vengono elencati nella sezione inferiore del pannello. Viene inoltre applicato un filtro basato sulla voce del pin scelto; il risultato visivo è determinato dai metodi di evidenziazione attivi. |
| Connective Graph | Se hai attivato l'opzione Connective Graph, saranno visibili tutti gli altri pin collegati alla net a cui appartiene il pin selezionato (il filtro viene esteso per includerli). La net a cui appartengono i pin collegati viene evidenziata visivamente mediante linee di connessione rosse del grafo |
Sezione Net / Bus
La terza sezione del pannello elenca tutte le net e i bus nel documento (o nella gerarchia appiattita) che stai esplorando. Facendo clic su una voce, tutti gli oggetti associati alla net o al bus (pin, etichette di net, porte, ingressi di foglio e connettori tra fogli) vengono visualizzati nella finestra dell'editor di progettazione in base ai metodi di evidenziazione abilitati.
Funzionalità della sezione Net / Bus
Sezione Net / Bus |
|
| Information available | I vari tipi di oggetti associati alla net o al bus selezionato sono elencati in sottocartelle, in base alle opzioni di evidenziazione attualmente abilitate e alla presenza di quel tipo di oggetto nella net o nel bus selezionato. Per ogni net o bus, può essere inclusa un'ulteriore sottocartella che elenca le linee grafiche utilizzate per collegare i pin, le porte, le etichette di net, gli ingressi di foglio e i connettori tra fogli associati. Fai clic sulla voce di una linea per filtrare solo quell'oggetto e applicare le impostazioni di controllo visivo. |
| When you click | Tutti gli oggetti della net abilitati per la visualizzazione nel pannello (ad eccezione delle linee grafiche) vengono visualizzati nella sezione inferiore del pannello Anche in questo caso, facendo clic su uno di questi oggetti viene applicato un filtro in base ai metodi di evidenziazione abilitati. |
Sezione Net del bus - Pin della net
Il contenuto della quarta sezione del pannello dipende da due fattori: l'oggetto che stai esplorando e gli oggetti che hai impostato per la visualizzazione. Se fai clic su un bus nella sezione Net / Bus, in questa sezione del pannello vengono elencate le net di quel bus. Se fai clic su una net nella sezione Net / Bus, vengono elencati i pin di quella net. Vengono elencati anche gli identificatori associati a quella net, se ne è abilitata la visualizzazione.
Sezione Segnale
Il pannello Navigator consente di visualizzare il progetto con un approccio incentrato sui segnali, anziché con il consueto approccio incentrato sugli oggetti. Se nella sezione Documents del pannello è selezionato un documento schematico, abilitando l'opzione Show Signals nella parte superiore del pannello, la terza sezione passa alla modalità Signal.
Fai clic sulla voce di un segnale per applicare un filtro: i nodi di quel segnale (pin, porte, etichette di net, ingressi di foglio e connettori tra fogli) vengono visualizzati nella finestra dell'editor di progettazione in base ai metodi di evidenziazione abilitati. Per ogni segnale nell'elenco vengono elencati i pin dei nodi, gli ingressi di foglio o i connettori tra fogli associati a quel segnale. Queste voci vengono visualizzate indipendentemente dal fatto che l'opzione di visualizzazione corrispondente a quel tipo di oggetto sia abilitata o meno.
Funzionalità della sezione Segnale
Sezione Segnale |
|
| Signal | Nome del segnale (nome del bus o della net). |
| Width | Numero di net distinte all'interno di questo segnale. |
| Click on a top-level signal entry | Fai clic sulla voce di un segnale di primo livello per popolare la sezione inferiore del pannello con tutti i nodi associati a quel segnale. Questi possono includere pin, etichette di net, porte, ingressi di foglio e connettori tra fogli. Le voci vengono visualizzate solo se è stata abilitata l'opzione corrispondente per la visualizzazione di quel tipo di oggetto. |
| Click on a sub-entry | Fai clic su una sottovoce nell'elenco principale dei segnali per popolare la sezione inferiore del pannello con tutti gli oggetti associati alla net principale di quel segnale. |
| SignalName Driven By Pin X | Viene visualizzato quando un pin di un nodo associato a un segnale è un pin di uscita o un pin I/O. X rappresenta il designatore componente-pin che pilota il segnale. |
| Driving Node Pin X | Viene visualizzato quando un pin di un nodo associato a un segnale è un pin di ingresso. X rappresenta il designatore componente-pin che viene pilotato dal segnale. |
| Driven By Node Sheet Entry SignalName | Viene visualizzato quando il tipo elettrico di un nodo di ingresso di foglio è di uscita o I/O: l'ingresso di foglio pilota il segnale. |
| Driving Node Sheet Entry X | Viene visualizzato quando il tipo elettrico dell'ingresso di foglio è di ingresso: l'ingresso di foglio viene pilotato dal segnale. |
Navigazione nel PCB
Oltre a raggiungere gli oggetti nello schematico facendo clic nel pannello Navigator, puoi raggiungere contemporaneamente quegli stessi oggetti anche sul PCB. Se tieni premuto il tasto Alt mentre fai clic su un oggetto nel pannello Navigator, gli oggetti di destinazione vengono evidenziati sia nello schematico sia sul PCB.
Poiché la navigazione avviene sempre nello schematico, per raggiungere gli oggetti sul PCB devi visualizzare contemporaneamente lo schematico e il PCB. Puoi farlo visualizzando il PCB in una finestra separata oppure condividendo l'area grafica tramite la funzione Split Vertical o Split Horizonal (di seguito è mostrata la disposizione verticale). I comandi per entrambe le funzioni sono disponibili nel menu contestuale che si apre facendo clic con il pulsante destro del mouse sulla scheda di un documento.
Tieni premuto il tasto Alt mentre esplori il progetto per individuare gli oggetti anche sul PCB.
Altium Designer include diverse funzionalità per lavorare tra lo schematico e il PCB, tra cui:
| Cross probe | Cross probing: fai clic con il pulsante destro del mouse per avviarlo, quindi fai clic su un oggetto (componente, pin, net) in un editor per passare a quell'oggetto nell'altro editor. Sono disponibili due modalità: continuous (rimani nell'editor di origine) o jump-to (rendi attivo l'editor/documento di destinazione). Tieni premuto Ctrl durante il cross probing per attivare la modalità jump-to. Il cross probing è supportato dagli editor di schematici, PCB e BOM, da Constraint Manager e dai pannelli Project, Navigator e Messages. |
| Cross select | Fai clic per selezionare un componente in un editor e selezionarlo anche nell'altro. Questa funzionalità è supportata tra gli editor di schematici e PCB e si abilita nel menu View. |
Scopri di più su Cross probing e selezione incrociata
Menu contestuale del pannello Navigator
Il menu contestuale del pannello Navigator, accessibile con il pulsante destro del mouse, include i seguenti comandi:
)
)
).


).
).
).

).
