Condivisione di un progetto

Poiché l'essenza della collaborazione consiste nel lavoro congiunto di più persone per raggiungere un risultato comune, un fattore essenziale è la possibilità di fornire e gestire l'accesso a tale elemento condiviso: in questo caso, un progetto e i dati associati. Il Workspace offre questa funzionalità tramite la condivisione controllata del progetto, basata su autorizzazioni, nel suo stato corrente di lavoro in corso (WIP) oppure come istantanea fissa del progetto in un determinato momento.

Per impostazione predefinita, un progetto appena creato o reso disponibile nel Workspace viene condiviso con:

  • Il proprietario del progetto, solitamente il progettista che lo ha creato (o reso disponibile nel Workspace): con autorizzazioni di accesso complete (lettura/scrittura).

  • Il ruolo Administrators: con autorizzazioni di accesso complete (lettura/scrittura).

All'interno di Altium Designer sono supportati i seguenti livelli di condivisione:

  • Sharing of a live design – il progetto in corso (WIP), che può essere condiviso:
    • Con altri membri del team del Workspace, per la modifica e/o la visualizzazione. Un membro del team invitato può visualizzare il progetto tramite Altium Designer o tramite il Workspace del team. Le modifiche vengono effettuate esclusivamente tramite Altium Designer. Il membro del team invitato deve essere registrato su AltiumLive e disporre di un abbonamento attivo per la licenza di Altium Designer.
    • Con persone esterne al team del Workspace, per la visualizzazione o la modifica, tramite invito e-mail. Questa funzionalità è disponibile solo quando si è connessi a un Workspace Altium 365. Questo tipo di condivisione consente alle parti interessate invitate di visualizzare/modificare (a seconda dei casi) un progetto in corso, aggiornato in tempo reale, senza accedere all'intero Workspace o ai dati di progettazione. La persona invitata deve essere registrata su AltiumLive e può accedere al progetto condiviso dal proprio Spazio personale di Altium 365 (o dal Workspace della propria organizzazione, se disponibile), oppure aprirlo in Altium Designer.

    Se dispone del solo accesso in visualizzazione, la parte interessata invitata può visualizzare e commentare il progetto all'interno di Altium Designer o tramite l'interfaccia del proprio Workspace Altium 365. Quando le persone con diritti di modifica apportano modifiche al progetto ed eseguono il commit, tali modifiche possono essere visualizzate «in tempo reale» dagli utenti esterni. Per visualizzare il progetto condiviso tramite l'interfaccia del browser, da qualsiasi luogo, è sufficiente registrarsi su AltiumLive per ottenere l'accesso.

    Se alla parte interessata invitata sono stati concessi diritti di modifica sul progetto, questa può aprirlo e modificarlo all'interno di Altium Designer: una soluzione ideale per i collaboratori esterni.

    La condivisione di progetti WIP aggiornati in tempo reale con persone esterne al team del Workspace è possibile quando si è connessi a un Workspace Altium 365, ma non quando si utilizza un Workspace Enterprise Server. È tuttavia possibile condividere un'istantanea del progetto con una persona esterna al team del Workspace, consentendone la visualizzazione e il download (vedere di seguito).

    Altium Designer offre funzionalità aggiuntive che integrano la collaborazione tramite la condivisione dei progetti nel Workspace, tra cui i commenti ai documenti e la prevenzione dei conflitti tra collaboratori.

    Quando si è connessi a un Workspace Altium 365 aggiornato al nuovo sistema di ereditarietà delle autorizzazioni (ulteriori informazioni), si noti che non è impossibile ridurre o rimuovere le autorizzazioni per un progetto se queste sono ereditate dalla cartella superiore. Quando si tenta di farlo, viene visualizzato un messaggio di errore (). L'opzione Inherit permissions from parent del progetto deve essere disabilitata nell'interfaccia browser del Workspace per interrompere intenzionalmente l'ereditarietà delle autorizzazioni dalla cartella superiore.

  • Sharing of a design 'snapshot' – un'istantanea statica del progetto in un determinato momento, condivisa:
    • Tramite link, accessibile a chiunque tramite un browser. L'accesso al progetto condiviso a questo livello non richiede né un abbonamento attivo per la licenza di Altium Designer né la registrazione su AltiumLive. Il destinatario del link condiviso apre il visualizzatore autonomo di Altium 365 per visualizzare il progetto (senza poterlo commentare). La visualizzazione non richiede la registrazione su AltiumLive e il link è disponibile per 48 ore.

    • Con persone specifiche, tramite invito e-mail. L'accesso al progetto condiviso a questo livello richiede la registrazione su AltiumLive, ma non un abbonamento attivo per la licenza di Altium Designer. Il destinatario accede all'istantanea del progetto dall'invito e-mail tramite il visualizzatore Web dell'interfaccia Workspace della piattaforma Altium 365. La visualizzazione richiede la registrazione su AltiumLive, ma l'istantanea rimane disponibile in modo permanente. È inoltre possibile commentare il progetto.

    Un'istantanea del progetto condivisa in questo modo è essenzialmente di sola lettura. Può essere scaricata o visualizzata in un Workspace Altium 365, ma, a differenza di un progetto WIP condiviso, non può essere aperta in Altium Designer per la visualizzazione o la modifica.

    Se il destinatario di un progetto (o di un'istantanea del progetto) condiviso tramite la piattaforma Altium 365 non dispone di un account AltiumLive, deve prima registrarsi: nella pagina Altium 365 Sign In è disponibile un link.

Per i progetti Altium 365 è supportata la creazione e la gestione di istanze di revisione del progetto. Queste istanze possono essere consultate in Altium Designer: ulteriori informazioni.  

Accesso ai controlli di condivisione

I controlli per condividere un progetto da Altium Designer si trovano nella finestra di dialogo Share, accessibile nei seguenti modi:

  • Per il progetto attivo, facendo clic sul pulsante in alto a destra nella finestra principale dell'applicazione oppure scegliendo il comando Project » Share dai menu principali.
  • Per il progetto selezionato nel pannello Projects, facendo clic con il pulsante destro del mouse sulla voce del progetto e scegliendo il comando Share dal menu contestuale.
  • Quando si commenta un documento di progetto, pubblicando un commento in cui viene menzionato un utente che non dispone dell'accesso al progetto corrente.

Se non è presente alcun progetto attivo, ovvero se nessun documento di progetto è attualmente aperto, il pulsante agirà sul progetto attualmente selezionato nel pannello Projects.

Accesso alla finestra di dialogo Share, il centro di controllo per la condivisione di un progetto da Altium Designer.
Accesso alla finestra di dialogo Share, il centro di controllo per la condivisione di un progetto da Altium Designer.

Condivisione di un progetto in tempo reale

Se un progetto è registrato in un Workspace Altium 365 (reso disponibile al suo interno), puoi condividerlo con altre persone, siano esse membri del team del tuo Workspace o persone esterne al team. Per condividere il progetto in questo modo, fai clic sulla voce sul lato sinistro della finestra di dialogo Share.

Gli amministratori del team del Workspace possono sempre condividere un progetto con altre persone, sia per la modifica sia per la visualizzazione. I membri non amministratori del team del Workspace, o gli utenti esterni al team del Workspace con cui è stato condiviso un progetto, possono condividere un progetto con altre persone per la modifica o la visualizzazione, a seconda del proprio livello di accesso. Quindi, se dispongono dei diritti di modifica, possono condividerlo con altri sia per la modifica sia per la visualizzazione. Se dispongono solo dei diritti di visualizzazione, possono condividerlo con altri utenti solo per la visualizzazione e l'aggiunta di commenti.

Accesso ai controlli per condividere con altre persone un progetto in tempo reale/in corso (WIP). L'immagine mostra il caso di un progetto già disponibile in un Workspace connesso.Accesso ai controlli per condividere con altre persone un progetto in tempo reale/in corso (WIP). L'immagine mostra il caso di un progetto già disponibile in un Workspace connesso.

Utilizza il controllo Copy Link per copiare un link diretto al progetto, che gli utenti che dispongono già dell'accesso possono utilizzare per aprire il progetto nel Web Viewer del Workspace.

Condivisione con nuove persone

Una volta completata la preparazione, selezionato un progetto e stabilita la connessione a un Workspace di destinazione, puoi specificare con quali persone condividere il progetto. Per verificare chi ha già accesso al progetto, fai clic sul controllo Shared with. L'area si espanderà per mostrare con chi è condiviso il progetto e se tali persone dispongono dei diritti di modifica (Can Edit) oppure possono solo visualizzare il progetto e aggiungere commenti (Can View).

Verifica con chi è attualmente condiviso il progetto facendo clic sul campo Share with. Passa il puntatore sull'immagine per vedere il risultato.
Verifica con chi è attualmente condiviso il progetto facendo clic sul campo Share with. Passa il puntatore sull'immagine per vedere il risultato.

Puoi condividere il progetto con chiunque: altri utenti AltiumLive della tua organizzazione, utenti AltiumLive di organizzazioni diverse e utenti non registrati ad AltiumLive (che dovranno poi creare un account AltiumLive). Tieni presente che, quando sei connesso a un Workspace Enterprise Server, puoi condividere il progetto WIP solo con utenti registrati di quel Workspace; per la condivisione all'esterno, consulta Condivisione di un'istantanea del progetto oppure la modalità di condivisione disponibile nel tuo spazio personale Altium 365.

Per aggiungere una voce, inizia a digitare il nome, l'indirizzo e-mail o il ruolo desiderato nel campo, quindi seleziona l'utente o il ruolo corrispondente dall'elenco dinamico, che conterrà solo gli utenti filtrati del team del tuo Workspace o della tua organizzazione e i ruoli esistenti definiti per il Workspace. Puoi scegliere più utenti o ruoli. Per rimuovere un utente o un ruolo inserito, fai clic sul controllo associato alla voce.

Per condividere il progetto con una persona esterna alla tua organizzazione, indipendentemente dal fatto che disponga o meno di un account AltiumLive, devi inserire il suo indirizzo e-mail completo e premere Enter.

Imposta le autorizzazioni di accesso per le persone o i ruoli aggiunti dal menu a discesa associato, selezionando Can View () oppure Can Edit (); quest'ultima opzione include anche la possibilità di visualizzazione. L'impostazione si applica inizialmente a tutte le voci (persone/ruoli) incluse nel campo. Utilizza il campo facoltativo delle note per includere informazioni relative alle modalità di condivisione di questo progetto.

Gli amministratori del team del Workspace possono sempre condividere un progetto con altre persone, sia per la modifica sia per la visualizzazione. I membri non amministratori del team del Workspace possono condividere un progetto con altre persone per la modifica o la visualizzazione, a seconda del proprio livello di accesso.

Solo gli utenti con cui è stato condiviso il progetto e a cui sono state assegnate le autorizzazioni Edit possono ricondividerlo con altre persone. Tutti gli utenti con cui è stato condiviso il progetto e che dispongono dei diritti Edit possono scaricare i file di progettazione del progetto. Ulteriori autorizzazioni di condivisione sono disponibili per gli amministratori e il proprietario del progetto nella finestra di dialogo Share. Utilizza il Advanced Settings opzioni per specificare i diritti di ricondivisione e download per gli utenti con cui condividere il progetto.

Le opzioni aggiuntive di condivisione e download sono raggruppate come segue:

  • Member Rights – per i membri del Workspace:

    • Editors can share – consente ai membri del Workspace che dispongono dei diritti Edit sul progetto condiviso di ricondividerlo con altri.

    • Viewers can download – consente ai membri del Workspace che dispongono dei diritti View sul progetto condiviso di scaricare i file di progettazione.

  • Guest and External Share Rights – per gli utenti ospiti esterni con cui sono stati condivisi i progetti:

    • Editors can share – consente agli utenti che non sono membri del Workspace e dispongono dei diritti Edit sul progetto condiviso di ricondividerlo con altri.

    • Viewers can download – consente agli utenti che non sono membri del Workspace e dispongono dei diritti View sul progetto condiviso di scaricare i file di progettazione.

Le modifiche alle impostazioni avanzate vengono confermate facendo clic sul pulsante  nella finestra di dialogo principale Share.

Dopo aver definito i destinatari e specificato i diritti di accesso, fai clic sul pulsante per procedere con la condivisione del progetto. La finestra di dialogo mostrerà un messaggio che conferma la corretta condivisione del progetto. Da qui, puoi fare clic sul controllo Who has access per tornare all'elenco degli utenti che hanno accesso al progetto, fare clic sul pulsante  per copiare il collegamento diretto al progetto oppure chiudere semplicemente la finestra di dialogo facendo clic su OK.

Condivisione con un utente esterno al team

Quando si è connessi a un Workspace di Enterprise Server, non è possibile condividere un progetto in lavorazione (WIP) con utenti non registrati in quel Workspace (utenti esterni al team). Per la condivisione all'esterno di un Workspace di Enterprise Server, consulta Condivisione di un'istantanea del progetto, oppure il metodo di condivisione tramite caricamento disponibile nel tuo spazio personale di Altium 365.

Se tenti di condividere un progetto di un Workspace Altium 365 con una persona esterna al team, verrà visualizzata la finestra di dialogo Confirm che avvisa che l'utente avrà accesso ai documenti sorgente del progetto condiviso, ai commenti inseriti e ai pacchetti di rilascio. Fai clic su OK per procedere con la condivisione del progetto.

Puoi condividere un progetto con chiunque sia esterno al team del Workspace, per la modifica o la visualizzazione.Puoi condividere un progetto con chiunque sia esterno al team del Workspace, per la modifica o la visualizzazione.

La condivisione con un utente esterno al team del Workspace per la modifica è ideale per i collaboratori esterni, quando desideri che lavorino attivamente al progetto senza includerli nel tuo team.

Condivisione di un progetto locale

Se condividi un progetto locale (non gestito da un VCS esterno), il progetto verrà reso disponibile nel Workspace attualmente connesso nel momento in cui viene condiviso con le persone designate. Ciò che accade effettivamente dipende dal fatto che la condivisione sia destinata alla visualizzazione o alla modifica:

  • Condivisione per la sola visualizzazione (con connessione a un Workspace Altium 365): il progetto viene reso disponibile tramite Simple Sync. In questa modalità, il progetto può essere modificato da una sola persona (il proprietario del progetto). Il punto di forza di Simple Sync emerge quando non desideri che altri modifichino il tuo progetto, ma vuoi sfruttare il paradigma Global Sharing di Altium 365 e condividere il progetto con più persone per la visualizzazione e l'inserimento di commenti. Per ulteriori informazioni su questa funzionalità, consulta Mirroring di un progetto nel Workspace tramite Simple Sync.
  • Condivisione per la modifica: il progetto deve essere aggiunto al repository di progettazione Git Versioned Storage del Workspace. In questa modalità, il progetto può essere condiviso con più persone per la modifica ed è inoltre possibile utilizzare il supporto di condivisione globale di Altium 365 per la visualizzazione condivisa e l'inserimento di commenti. Verrà visualizzata una finestra di dialogo che ti informa di questo requisito e offre l'opzione Use Altium 365 VCS per procedere. Fai clic su Learn More per accedere alla pagina Condivisione, che ti guiderà nella condivisione del progetto.

Quando condividi un progetto locale (non gestito da un VCS) con una persona per la modifica, sarà necessario sottoporre il progetto al controllo di versione aggiungendolo al repository di progettazione Git Versioned Storage del Workspace.Quando condividi un progetto locale (non gestito da un VCS) con una persona per la modifica, sarà necessario sottoporre il progetto al controllo di versione aggiungendolo al repository di progettazione Git Versioned Storage del Workspace.

Se il progetto locale è già sottoposto al controllo di versione (in un repository di progettazione esterno), rimarrà nel repository di progettazione VCS esterno e non verrà aggiunto al repository di progettazione VCS (Git) integrato del Workspace. In questo caso, si applica Simple Sync (mirroring), ma naturalmente più collaboratori possono continuare a lavorare al progetto e modificarlo, poiché è gestito da un VCS.

Tuttavia, le funzionalità complete offerte dalla piattaforma Altium 365, o più precisamente da un Workspace Altium 365, sono disponibili solo se il progetto è interamente archiviato nel VCS nativo del Workspace (nel relativo repository Git Versioned Storage). Puoi migrare il progetto dal sistema VCS esterno al sistema VCS nativo del Workspace utilizzando la funzionalità integrata di migrazione dei repository VCS di Altium Designer.

► Per informazioni al riguardo, consulta Passaggio da un VCS esterno al VCS nativo del Workspace.

  • Quando si è connessi a un Workspace di Enterprise Server, un progetto locale da condividere con un altro utente del Workspace viene aggiunto automaticamente al VCS del Workspace. Il progetto, ora appartenente al Workspace, verrà condiviso con l'utente del Workspace specificato con diritti di visualizzazione o modifica, in base alla selezione effettuata nella finestra di dialogo Share.
  • Tieni presente che un Workspace di Enterprise Server non può condividere un progetto WIP con persone esterne al team del Workspace, ovvero che non siano utenti registrati del Workspace.

Risultato della condivisione

Ciò che accade successivamente dipende dal tipo di utente invitato:

  • Un utente che fa già parte del team del Workspace verrà aggiunto direttamente all'elenco degli utenti con accesso al progetto e riceverà un'e-mail che lo informa che il progetto è stato condiviso con lui. Potrà aprire il progetto in Altium Designer o accedervi tramite l'interfaccia del Workspace (dalla pagina Projects ).
  • Quando viene aggiunto un ruolo esistente del Workspace, questo apparirà nell'elenco di accesso al progetto e tutti i membri del ruolo riceveranno un'e-mail che li informa che il progetto è stato condiviso con loro. Potranno aprire il progetto in Altium Designer o accedervi tramite l'interfaccia del Workspace (dalla pagina Projects ).
  • Quando utilizzi un Workspace Altium 365 per condividere un progetto con una persona esterna al team del Workspace, questa verrà aggiunta all'elenco di condivisione e riceverà un'e-mail che la informa che il progetto è stato condiviso con lei. Potrà aprire il progetto in Altium Designer tramite l'opzione Condivisi con me oppure accedervi tramite la propria interfaccia dello spazio personale della piattaforma Altium 365 (dalla pagina Shared with Me ). L'e-mail ricevuta fornisce l'accesso diretto al progetto tramite Altium 365. Facendo clic sul pulsante nell'e-mail, verrà indirizzata alla pagina Altium 365 Sign In (a meno che non abbia già effettuato l'accesso alla piattaforma o al proprio account AltiumLive). Dopo aver effettuato l'accesso, verrà indirizzata direttamente al visualizzatore Web, con il progetto condiviso già caricato.

    Non puoi condividere un progetto WIP all'esterno del team (con utenti esterni) quando sei connesso a un Workspace di Enterprise Server. Tuttavia:

Se la persona non dispone di un account AltiumLive, dovrà prima crearne uno: nella pagina Altium 365 Sign In è disponibile un link.

Accesso a un progetto condiviso in tempo reale dall'invito e-mail ricevuto da un utente che non fa parte del team del Workspace.
Accesso a un progetto condiviso in tempo reale dall'invito e-mail ricevuto da un utente che non fa parte del team del Workspace.

Modifica dei diritti di accesso per gli utenti esistenti

In qualsiasi momento, un amministratore (o un membro del team del Workspace con diritti di modifica) può modificare le autorizzazioni di accesso esistenti per un progetto. Per accedere all'elenco delle persone e dei ruoli con cui il progetto è già condiviso, fai clic sulla voce sul lato sinistro della finestra di dialogo Share , quindi espandi il campo Shared with sulla destra.

Accesso all'elenco delle persone e dei ruoli che attualmente hanno accesso condiviso al progetto.Accesso all'elenco delle persone e dei ruoli che attualmente hanno accesso condiviso al progetto.

Aspetti da tenere presenti:

  • In termini di autorizzazioni, una persona o un ruolo dispone dell'accesso completo in modifica al progetto quando è selezionata l'opzione Can Edit (). In caso contrario, dispone di un accesso in sola visualizzazione ().
  • Owner e il ruolo Administrators dispongono sempre dell'accesso completo in modifica (Can Edit).
  • Ad eccezione di Owner e del ruolo Administrators, le autorizzazioni per tutte le persone e i ruoli inclusi possono essere impostate singolarmente su Can View o Can Edit, oppure i diritti di accesso possono essere rimossi completamente. Inoltre, la proprietà del progetto può essere trasferita a un altro utente (vedi sotto). Fai clic sullo stato attuale delle autorizzazioni per accedere ai controlli.

  • Un progetto può essere condiviso esplicitamente con persone e/o ruoli specifici, oppure semplicemente con tutti i membri del team del Workspace. In quest'ultimo caso, imposta l'accesso richiesto per la voce Workspace Members . Per non condividere il progetto con l'intero team, imposta questa voce su None.

Modifica le autorizzazioni di accesso secondo necessità. Ogni entità modificata viene evidenziata nell'elenco con uno sfondo più scuro.

Esempio di modifiche alle autorizzazioni di due persone con cui il progetto è attualmente condiviso.Esempio di modifiche alle autorizzazioni di due persone con cui il progetto è attualmente condiviso.

Per applicare le modifiche, fai clic sul pulsante . Le modifiche verranno applicate e la conferma verrà mostrata nella finestra di dialogo. Per visualizzare l'elenco aggiornato degli accessi condivisi, fai clic sul link Who has access.

Dopo aver salvato le modifiche alle autorizzazioni, puoi visualizzare il risultato aggiornato direttamente nella finestra di dialogo Share.Dopo aver salvato le modifiche alle autorizzazioni, puoi visualizzare il risultato aggiornato direttamente nella finestra di dialogo Share.

  • Tieni presente che la condivisione di un progetto con un altro utente può essere revocata in qualsiasi momento scegliendo l'opzione Remove per quell'utente nella finestra di dialogo Share.
  • Tieni inoltre presente che, se stai modificando le autorizzazioni in Can Edit per una persona esterna al team del Workspace di Altium 365, ti verrà chiesto, tramite la finestra di dialogo Sharing Outside of the Workspace, di confermare se assegnarle diritti di sola visualizzazione o di modifica.

Trasferimento della proprietà del progetto

Gli amministratori e i proprietari possono trasferire la proprietà a un altro utente utilizzando l'opzione Owner  del menu a discesa dello stato attuale delle autorizzazioni. L'opzione può essere utilizzata dall'attuale proprietario del progetto o da un amministratore del Workspace.

La proprietà può essere trasferita solo a un altro membro del Workspace. Il trasferimento a un utente esterno al Workspace non è disponibile.

Selezionando l'opzione Owner per un utente, si apre la finestra di dialogo Transfer Ownership. Fai clic su Yes per eseguire l'operazione.

Le modifiche alle autorizzazioni dell'attuale proprietario e del nuovo proprietario verranno mostrate nella finestra di dialogo. Fai clic su Save per procedere con le modifiche.

Con il trasferimento, i diritti di accesso per l'attuale proprietario vengono assegnati come segue:

  • Vengono trasferiti i diritti di modifica se il progetto è sotto controllo di versione.
  • Vengono trasferiti i diritti di visualizzazione se il progetto utilizza SimpleSync.

L'utente a cui viene trasferita la proprietà riceverà una notifica e-mail.

Accesso a un progetto condiviso in tempo reale

L'accesso a un progetto condiviso con un utente dipende dal fatto che l'utente sia un membro del team del Workspace o una persona esterna al team.

Membro del team del Workspace

Un membro del team del Workspace può accedere al progetto condiviso tramite Altium Designer o tramite la pagina Projects dell'interfaccia del Workspace. Tieni presente che la modifica del progetto, se l'utente dispone dei diritti di modifica, è possibile solo tramite Altium Designer.

In Altium Designer, accedi al progetto utilizzando il comando File » Open Project o il pulsante con i puntini di sospensione associato alla voce del Workspace nel pannello Projects. Verrà visualizzata la finestra di dialogo Open Project, da cui puoi scegliere quale progetto aprire nel Workspace a cui sei connesso. Quando sei connesso a un Workspace, questo viene visualizzato nell'area Locations della finestra di dialogo, contraddistinto dall'icona e con il nome assegnato al Workspace. Verranno elencati solo i progetti del Workspace che sono stati condivisi con te e per i quali disponi dell'autorizzazione di accesso.

Una volta aperto, il progetto verrà visualizzato sotto la voce del Workspace nel pannello Projects.

Scegli quale progetto aprire nel Workspace a cui sei connesso, direttamente da Altium Designer, tra quelli attualmente condivisi con te. Scegli quale progetto aprire nel Workspace a cui sei connesso, direttamente da Altium Designer, tra quelli attualmente condivisi con te.

Puoi aprire il progetto nel percorso di checkout predefinito oppure utilizzare il menu a discesa per specificare un percorso personalizzato. Il percorso di checkout predefinito viene ricavato dal campo Document Path nella pagina System – Default Locations della finestra di dialogo Preferences.
Quando esplori il progetto tramite il pannello Explorer di Altium Designer, configurato nella modalità predefinita Project View anziché Classic View, fai clic sul pulsante in alto a destra nel pannello per aprire il progetto in Altium Designer (aggiungendolo al pannello Projects). Utilizza il pulsante per aprire il progetto e visualizzarlo nell'interfaccia browser del Workspace connesso.

Parte interessata invitata esterna al team del Workspace

Una persona esterna al team del Workspace di Altium 365 con cui è stato condiviso il progetto può accedervi tramite Altium Designer o tramite l'interfaccia della piattaforma Altium 365 (dalla pagina Condivisi con me). Per aprire il progetto, seleziona il riquadro del progetto e fai clic sul nome del progetto, oppure scegli l'opzione Open dal menu con i puntini di sospensione del riquadro. In alternativa, fai doppio clic direttamente sul riquadro. Tieni presente che la modifica del progetto, se l'utente dispone dei diritti di modifica, è possibile solo tramite Altium Designer.

Quando si utilizza un Workspace di Enterprise Server, un progetto WIP non può essere condiviso all'esterno del team (con utenti esterni).

Tuttavia, se sei il destinatario di un progetto condiviso con te da un membro di un Workspace Altium 365, questo sarà disponibile in Altium Designer nella posizione Shared with Me, come descritto di seguito, e potrà essere visualizzato anche nel tuo Spazio personale.

In Altium Designer, accedi al progetto utilizzando il comando File » Open Project. Verrà visualizzata la finestra di dialogo Apri progetto, dalla quale potrai scegliere quale progetto del Workspace aprire dalla posizione Shared With Me.

Una volta aperto, il progetto verrà visualizzato sotto la voce Shared with me, nel pannello Progetti. Le operazioni che puoi eseguire sul progetto dipendono dai diritti di accesso che ti sono stati concessi. Se ti sono stati assegnati diritti di modifica, potrai modificare il progetto normalmente, come avviene in genere per un collaboratore esterno: poiché il progetto è condiviso da un Workspace, le modifiche vengono sincronizzate in entrambe le direzioni. Se disponi solo dei diritti di visualizzazione, potrai comunque aggiungere commenti al progetto in corso di sviluppo.

Scegli, da Altium Designer, quale progetto del Workspace aprire tra quelli attualmente condivisi con te in qualità di collaboratore esterno. Tieni presente che puoi accedere a questi progetti senza avere accesso al Workspace.Scegli, da Altium Designer, quale progetto del Workspace aprire tra quelli attualmente condivisi con te in qualità di collaboratore esterno. Tieni presente che puoi accedere a questi progetti senza avere accesso al Workspace.

Puoi aprire il progetto nel percorso di checkout predefinito oppure utilizzare il menu a discesa per specificare un percorso personalizzato. Il percorso di checkout predefinito viene ricavato dal campo Document Path nella pagina Sistema – Posizioni predefinite della finestra di dialogo Preferences.

Condivisione di un'istantanea del progetto

La creazione di un'istantanea di sola lettura di un progetto consente di condividere rapidamente quel progetto, nello stato in cui si trova in un determinato momento del suo sviluppo, per collaborare con altre persone tramite il Web. Può essere utile per una revisione estemporanea del progetto, per condividere una particolare tappa del suo sviluppo o anche per stimolare una discussione contestualizzata. Per condividere in questo modo, fai clic sulla voce sul lato sinistro della finestra di dialogo Share.

Accesso ai controlli per condividere un'istantanea di un progetto.Accesso ai controlli per condividere un'istantanea di un progetto.

Qualsiasi utente che stia visualizzando un progetto in Altium Designer può condividerne un'istantanea.

Condivisione tramite link

Per impostazione predefinita, la finestra di dialogo è impostata su Condividi tramite link: chiunque riceva il link potrà visualizzare l'istantanea del progetto nel proprio browser per un periodo limitato di 48 ore. Questo livello di condivisione non consente di aggiungere commenti al progetto.

Questo livello di condivisione non richiede l'accesso al tuo account Altium in Altium Designer.
Tieni presente che le istantanee dei progetti condivise tramite link potrebbero essere indicizzate dai motori di ricerca e rese disponibili ai loro utenti.

Fai clic sul pulsante per generare il link all'istantanea del progetto. In background, il progetto viene compresso in un archivio ZIP utilizzando Project Packager di Altium Designer. Una volta che il link è pronto, fai clic sul pulsante per copiarlo, quindi condividilo con le persone desiderate.

Generazione del link a durata limitata che può essere condiviso con chiunque, ovunque.Generazione del link a durata limitata che può essere condiviso con chiunque, ovunque.

Quando il destinatario apre il link in un browser, viene indirizzato a un'istanza di Altium 365 Viewer, sul sito principale altium.com, con il progetto elaborato e caricato.

Utilizzando il link condiviso, il destinatario può esplorare l'istantanea del progetto con Altium 365 Viewer, caricato sul sito principale altium.com. Qui è mostrato uno schema elettrico: passa il puntatore sull'immagine per vedere il PCB.Utilizzando il link condiviso, il destinatario può esplorare l'istantanea del progetto con Altium 365 Viewer, caricato sul sito principale altium.com. Qui è mostrato uno schema elettrico: passa il puntatore sull'immagine per vedere il PCB.

Quando il progetto (nell'archivio ZIP) viene caricato in Altium 365 Viewer, viene rimosso non appena l'elaborazione è completata. Di conseguenza, la visualizzazione del progetto è limitata nel tempo: è disponibile per la durata della sessione del browser e non è più accessibile se chiudi la scheda del browser. In alternativa, puoi utilizzare nuovamente il link in qualsiasi momento entro il periodo consentito di 48 ore.

Condivisione con persone specifiche

Facendo clic sul controllo Share with specific people, la modalità di condivisione dell'istantanea del progetto cambia, consentendoti di condividerla con una o più persone specifiche tramite invito via e-mail. I destinatari potranno visualizzare, condividere o scaricare l'istantanea del progetto tramite l'interfaccia Web della piattaforma Altium 365. L'istantanea rimane disponibile permanentemente sulla piattaforma e questo livello di condivisione consente di aggiungere commenti al progetto.

Questo livello di condivisione richiede l'accesso al tuo account Altium in Altium Designer, utilizzando le credenziali del tuo account AltiumLive. Se non hai ancora effettuato l'accesso al tuo account Altium, la finestra di dialogo mostrerà un link per farlo (aprendo la finestra di dialogo Accedi) oppure per registrarti ad AltiumLive, se non disponi ancora delle credenziali.

Cambia modalità per condividere permanentemente un'istantanea del progetto con persone specifiche.Cambia modalità per condividere permanentemente un'istantanea del progetto con persone specifiche.

Inserisci l'indirizzo e-mail completo della persona con cui desideri condividere l'istantanea e premi Enter. Puoi specificare più persone in questo modo, secondo necessità. Puoi anche aggiungere una nota facoltativa per comunicare informazioni pertinenti sull'istantanea condivisa.

Esempio di condivisione di un'istantanea del progetto con una persona specifica tramite e-mail.Esempio di condivisione di un'istantanea del progetto con una persona specifica tramite e-mail.

Utilizza le opzioni Advanced Settings della finestra di dialogo Share per specificare le autorizzazioni applicate all'istantanea del progetto condivisa (). Seleziona Allow sharing per consentire alla persona specificata di condividere a sua volta l'istantanea del progetto e l'opzione Allow downloading per consentire il download dell'istantanea in formato ZIP.

Quando sei pronto, fai clic sul pulsante . Il progetto viene compresso in un archivio ZIP utilizzando Project Packager di Altium Designer, quindi caricato sulla piattaforma Altium 365. Al termine del processo viene fornita una conferma del caricamento.

L'istantanea condivisa viene compressa e quindi caricata sulla piattaforma Altium 365, dove rimane disponibile permanentemente.L'istantanea condivisa viene compressa e quindi caricata sulla piattaforma Altium 365, dove rimane disponibile permanentemente.

La persona con cui hai condiviso l'istantanea del progetto caricata riceverà un invito via e-mail per accedervi tramite Altium 365. Facendo clic sul pulsante nell'e-mail, verrà indirizzata alla pagina Altium 365 Sign In, a meno che non abbia già effettuato l'accesso alla piattaforma o al proprio account AltiumLive. Dopo l'accesso, verrà indirizzata al visualizzatore Web, con l'istantanea del progetto condivisa già caricata.

Se la persona non dispone di un account AltiumLive, dovrà prima crearne uno: all'apertura del link Altium 365 viene visualizzato un modulo per la creazione dell'account.

Accesso all'istantanea del progetto dall'invito via e-mail ricevuto dall'utente con cui è stata condivisa.Accesso all'istantanea del progetto dall'invito via e-mail ricevuto dall'utente con cui è stata condivisa.

Accesso a un'istantanea del progetto condivisa

Oltre a seguire il link nell'invito via e-mail, la persona con cui è stata condivisa un'istantanea permanente del progetto potrà accedervi in qualsiasi momento per aprirla, condividerla e visualizzarla dalla Shared with Me pagina dell'  interfaccia della piattaforma Altium 365. Un'istantanea del progetto è contrassegnata dall'icona all'interno del relativo riquadro.

Per aprire il progetto nel visualizzatore integrato, seleziona il riquadro del progetto e fai clic sul nome del progetto, oppure scegli l'opzione Open dal menu con i puntini di sospensione del riquadro. In alternativa, fai doppio clic direttamente sul riquadro. Tieni presente che un'istantanea condivisa del progetto non può essere modificata e pertanto non è accessibile da Altium Designer tramite la posizione Shared With Me nella finestra di dialogo Apri progetto; può tuttavia essere scaricata se è stata condivisa con questa autorizzazione abilitata.

Accesso a un'istantanea del progetto dalla pagina Shared with Me  dell'interfaccia della piattaforma Altium 365. In questo esempio è stato inserito un commento nel progetto condiviso.Accesso a un'istantanea del progetto dalla pagina Shared with Me dell'interfaccia della piattaforma Altium 365. In questo esempio è stato inserito un commento nel progetto condiviso.

La persona che ha originariamente condiviso l'istantanea del progetto, caricandola in modo permanente sulla piattaforma Altium 365, potrà accedervi anche dalla pagina Files del proprio Spazio personale.

Disabilitazione della condivisione

Per disabilitare completamente la condivisione, deseleziona l'opzione Altium Cloud nella pagina Sistema – Attività di rete della finestra di dialogo Preferences. Se tenti di condividere un progetto tramite la finestra di dialogo Share, in tempo reale o come istantanea, verrà visualizzata una finestra di avviso che segnala che questa opzione è stata disabilitata.

La disabilitazione della connessione ad Altium Cloud impedirà la condivisione dei progetti.
La disabilitazione della connessione ad Altium Cloud impedirà la condivisione dei progetti.

Supporto per le revisioni del progetto

La finestra di dialogo Share consente di consultare un elenco delle istanze di revisione del progetto.

La funzionalità di revisione del progetto consente di creare e gestire istanze di revisione strutturate per i progetti del Workspace Altium 365.

Per saperne di più, consulta la pagina Revisioni del progetto.

Quando la voce  è selezionata sul lato sinistro della finestra di dialogo Share, sul lato destro sono elencate le revisioni attive del progetto (quelle nello stato In Progress) per le quali sei stato designato come revisore. Ogni istanza di revisione del progetto viene presentata con i seguenti dati:

  • Nome dell'istanza. Fai clic sul collegamento per aprire l'istanza nell'interfaccia browser di Altium 365.

  • Descrizione.

  • Data e ora del commit/rilascio per il quale viene creata l'istanza di revisione del progetto.

  • Autore e data e ora di creazione dell'istanza.

Se il progetto non dispone di istanze nello stato In Progress, il pulsante  è disponibile in basso a destra nella finestra di dialogo. Fai clic su di esso per chiudere la finestra di dialogo e accedere alla pagina Design Reviews del progetto nell'interfaccia browser del Workspace. Si apre la finestra Create Design Review, in cui puoi definire i revisori, la descrizione e il modello di checklist da utilizzare.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents