Condivisione di un progetto
Poiché l'essenza della collaborazione consiste nel lavoro congiunto di più persone per raggiungere un risultato comune, un fattore essenziale è la possibilità di fornire e gestire l'accesso a tale elemento condiviso: in questo caso, un progetto e i dati associati. Il Workspace offre questa funzionalità tramite la condivisione controllata del progetto, basata su autorizzazioni, nel suo stato corrente di lavoro in corso (WIP) oppure come istantanea fissa del progetto in un determinato momento.
Per impostazione predefinita, un progetto appena creato o reso disponibile nel Workspace viene condiviso con:
-
Il proprietario del progetto, solitamente il progettista che lo ha creato (o reso disponibile nel Workspace): con autorizzazioni di accesso complete (lettura/scrittura).
-
Il ruolo Administrators: con autorizzazioni di accesso complete (lettura/scrittura).
All'interno di Altium Designer sono supportati i seguenti livelli di condivisione:
-
Sharing of a live design – il progetto in corso (WIP), che può essere condiviso:
- Con altri membri del team del Workspace, per la modifica e/o la visualizzazione. Un membro del team invitato può visualizzare il progetto tramite Altium Designer o tramite il Workspace del team. Le modifiche vengono effettuate esclusivamente tramite Altium Designer. Il membro del team invitato deve essere registrato su AltiumLive e disporre di un abbonamento attivo per la licenza di Altium Designer.
- Con persone esterne al team del Workspace, per la visualizzazione o la modifica, tramite invito e-mail. Questa funzionalità è disponibile solo quando si è connessi a un Workspace Altium 365. Questo tipo di condivisione consente alle parti interessate invitate di visualizzare/modificare (a seconda dei casi) un progetto in corso, aggiornato in tempo reale, senza accedere all'intero Workspace o ai dati di progettazione. La persona invitata deve essere registrata su AltiumLive e può accedere al progetto condiviso dal proprio Spazio personale di Altium 365 (o dal Workspace della propria organizzazione, se disponibile), oppure aprirlo in Altium Designer.
Se dispone del solo accesso in visualizzazione, la parte interessata invitata può visualizzare e commentare il progetto all'interno di Altium Designer o tramite l'interfaccia del proprio Workspace Altium 365. Quando le persone con diritti di modifica apportano modifiche al progetto ed eseguono il commit, tali modifiche possono essere visualizzate «in tempo reale» dagli utenti esterni. Per visualizzare il progetto condiviso tramite l'interfaccia del browser, da qualsiasi luogo, è sufficiente registrarsi su AltiumLive per ottenere l'accesso.
Se alla parte interessata invitata sono stati concessi diritti di modifica sul progetto, questa può aprirlo e modificarlo all'interno di Altium Designer: una soluzione ideale per i collaboratori esterni.
-
Sharing of a design 'snapshot' – un'istantanea statica del progetto in un determinato momento, condivisa:
-
Tramite link, accessibile a chiunque tramite un browser. L'accesso al progetto condiviso a questo livello non richiede né un abbonamento attivo per la licenza di Altium Designer né la registrazione su AltiumLive. Il destinatario del link condiviso apre il visualizzatore autonomo di Altium 365 per visualizzare il progetto (senza poterlo commentare). La visualizzazione non richiede la registrazione su AltiumLive e il link è disponibile per 48 ore.
-
Con persone specifiche, tramite invito e-mail. L'accesso al progetto condiviso a questo livello richiede la registrazione su AltiumLive, ma non un abbonamento attivo per la licenza di Altium Designer. Il destinatario accede all'istantanea del progetto dall'invito e-mail tramite il visualizzatore Web dell'interfaccia Workspace della piattaforma Altium 365. La visualizzazione richiede la registrazione su AltiumLive, ma l'istantanea rimane disponibile in modo permanente. È inoltre possibile commentare il progetto.
Un'istantanea del progetto condivisa in questo modo è essenzialmente di sola lettura. Può essere scaricata o visualizzata in un Workspace Altium 365, ma, a differenza di un progetto WIP condiviso, non può essere aperta in Altium Designer per la visualizzazione o la modifica.
-
Accesso ai controlli di condivisione
I controlli per condividere un progetto da Altium Designer si trovano nella finestra di dialogo Share, accessibile nei seguenti modi:
-
Per il progetto attivo, facendo clic sul pulsante
in alto a destra nella finestra principale dell'applicazione oppure scegliendo il comando Project » Share dai menu principali.
- Per il progetto selezionato nel pannello Projects, facendo clic con il pulsante destro del mouse sulla voce del progetto e scegliendo il comando Share dal menu contestuale.
- Quando si commenta un documento di progetto, pubblicando un commento in cui viene menzionato un utente che non dispone dell'accesso al progetto corrente.

Accesso alla finestra di dialogo Share, il centro di controllo per la condivisione di un progetto da Altium Designer.
Preparazione alla condivisione
Per poter condividere un progetto WIP aggiornato in tempo reale tramite un Workspace Altium 365:
- È necessario aver effettuato l'accesso al proprio account Altium (utilizzando le credenziali AltiumLive).
- È necessario disporre di un abbonamento Altium attivo (valido) per la licenza di Altium Designer.
- È necessario essere connessi al proprio Workspace Altium 365.
- Il progetto deve essere registrato nel Workspace (reso disponibile al suo interno).
- Devi disporre delle autorizzazioni per condividere il progetto.
Per poter condividere un progetto in corso (WIP) tramite un Workspace Enterprise Server:
- Devi disporre di una licenza Altium Designer attiva (valida).
- Devi essere connesso al tuo Workspace.
- Il progetto deve essere registrato nel Workspace (reso disponibile al suo interno).
Per poter condividere un'istantanea del progetto tramite un Workspace:
- Devi essere connesso al tuo Workspace Altium.
- Il progetto deve essere registrato nel Workspace (reso disponibile al suo interno).
- Al destinatario di un link a un'istantanea condivisa è sufficiente un normale browser.
-
Il destinatario di un'istantanea condivisa specificamente con il suo nome deve:
- essere registrato ad AltiumLive e aver effettuato l'accesso.
- essere connesso al proprio spazio personale Altium 365.
La finestra di dialogo Share fornisce indicazioni per prepararti correttamente alla condivisione del progetto scelto. Di seguito sono riportati alcuni esempi relativi alla condivisione con un Workspace Altium 365 (quando si utilizza un Workspace Enterprise Server vengono visualizzate finestre di dialogo con indicazioni analoghe):
- Se non hai effettuato l'accesso al tuo account Altium, la finestra di dialogo presenta un link per farlo (per accedere alla finestra di dialogo di accesso) oppure per registrarti ad AltiumLive, se non disponi ancora delle credenziali. In genere, dopo aver effettuato l'accesso al tuo account, ti connetterai a un Workspace (se ne disponi di uno), purché tale Workspace sia stato impostato come predefinito.
-
Se hai effettuato l'accesso al tuo account Altium e stai tentando di condividere un progetto aperto non registrato in un Workspace (ovvero un progetto locale o VCS), e non hai un Workspace a disposizione, la finestra di dialogo presenta un controllo per attivare il Workspace della tua azienda.
-
Se hai effettuato l'accesso al tuo account Altium e stai tentando di condividere un progetto aperto registrato in un Workspace, ma non sei attualmente connesso a tale Workspace, la finestra di dialogo presenta un controllo per connetterti a quel Workspace specifico o per passare a esso se sei attualmente connesso a un altro Workspace.
-
Se hai effettuato l'accesso al tuo account Altium e stai tentando di condividere un progetto aperto non registrato in un Workspace (ovvero un progetto locale o VCS), e non sei attualmente connesso a un Workspace, la finestra di dialogo presenta un elenco di tutti i Workspace a tua disposizione, invitandoti a selezionare quello in cui registrare il progetto.
-
Se hai effettuato l'accesso al tuo account Altium e stai tentando di condividere un progetto aperto, ma non disponi dell'autorizzazione necessaria, la finestra di dialogo mostra un messaggio che lo segnala. Ciò può accadere se non disponi dei diritti di modifica per questo progetto oppure se un amministratore del Workspace o il proprietario del progetto ha limitato la possibilità per gli editor di ricondividerlo all'interno e/o all'esterno del Workspace.
Condivisione di un progetto in tempo reale
Se un progetto è registrato in un Workspace Altium 365 (reso disponibile al suo interno), puoi condividerlo con altre persone, siano esse membri del team del tuo Workspace o persone esterne al team. Per condividere il progetto in questo modo, fai clic sulla voce
sul lato sinistro della finestra di dialogo Share.
Accesso ai controlli per condividere con altre persone un progetto in tempo reale/in corso (WIP). L'immagine mostra il caso di un progetto già disponibile in un Workspace connesso.
Utilizza il controllo Copy Link per copiare un link diretto al progetto, che gli utenti che dispongono già dell'accesso possono utilizzare per aprire il progetto nel Web Viewer del Workspace.
Condivisione con nuove persone
Una volta completata la preparazione, selezionato un progetto e stabilita la connessione a un Workspace di destinazione, puoi specificare con quali persone condividere il progetto. Per verificare chi ha già accesso al progetto, fai clic sul controllo Shared with. L'area si espanderà per mostrare con chi è condiviso il progetto e se tali persone dispongono dei diritti di modifica (Can Edit) oppure possono solo visualizzare il progetto e aggiungere commenti (Can View).

Verifica con chi è attualmente condiviso il progetto facendo clic sul campo Share with. Passa il puntatore sull'immagine per vedere il risultato.
Puoi condividere il progetto con chiunque: altri utenti AltiumLive della tua organizzazione, utenti AltiumLive di organizzazioni diverse e utenti non registrati ad AltiumLive (che dovranno poi creare un account AltiumLive). Tieni presente che, quando sei connesso a un Workspace Enterprise Server, puoi condividere il progetto WIP solo con utenti registrati di quel Workspace; per la condivisione all'esterno, consulta Condivisione di un'istantanea del progetto oppure la modalità di condivisione disponibile nel tuo spazio personale Altium 365.
Per aggiungere una voce, inizia a digitare il nome, l'indirizzo e-mail o il ruolo desiderato nel campo, quindi seleziona l'utente o il ruolo corrispondente dall'elenco dinamico, che conterrà solo gli utenti filtrati del team del tuo Workspace o della tua organizzazione e i ruoli esistenti definiti per il Workspace. Puoi scegliere più utenti o ruoli. Per rimuovere un utente o un ruolo inserito, fai clic sul controllo
associato alla voce.
Imposta le autorizzazioni di accesso per le persone o i ruoli aggiunti dal menu a discesa associato, selezionando Can View oppure Can Edit ; quest'ultima opzione include anche la possibilità di visualizzazione. L'impostazione si applica inizialmente a tutte le voci (persone/ruoli) incluse nel campo. Utilizza il campo facoltativo delle note per includere informazioni relative alle modalità di condivisione di questo progetto.
Solo gli utenti con cui è stato condiviso il progetto e a cui sono state assegnate le autorizzazioni Edit possono ricondividerlo con altre persone. Tutti gli utenti con cui è stato condiviso il progetto e che dispongono dei diritti Edit possono scaricare i file di progettazione del progetto. Ulteriori autorizzazioni di condivisione sono disponibili per gli amministratori e il proprietario del progetto nella finestra di dialogo Share. Utilizza il Advanced Settings opzioni per specificare i diritti di ricondivisione e download per gli utenti con cui condividere il progetto.
Le opzioni aggiuntive di condivisione e download sono raggruppate come segue:
-
Member Rights – per i membri del Workspace:
-
Editors can share – consente ai membri del Workspace che dispongono dei diritti
Editsul progetto condiviso di ricondividerlo con altri. -
Viewers can download – consente ai membri del Workspace che dispongono dei diritti
Viewsul progetto condiviso di scaricare i file di progettazione.
-
-
Guest and External Share Rights – per gli utenti ospiti esterni con cui sono stati condivisi i progetti:
-
Editors can share – consente agli utenti che non sono membri del Workspace e dispongono dei diritti
Editsul progetto condiviso di ricondividerlo con altri. -
Viewers can download – consente agli utenti che non sono membri del Workspace e dispongono dei diritti
Viewsul progetto condiviso di scaricare i file di progettazione.
-
Le modifiche alle impostazioni avanzate vengono confermate facendo clic sul pulsante
nella finestra di dialogo principale Share.
Dopo aver definito i destinatari e specificato i diritti di accesso, fai clic sul pulsante
per procedere con la condivisione del progetto. La finestra di dialogo mostrerà un messaggio che conferma la corretta condivisione del progetto. Da qui, puoi fare clic sul controllo Who has access per tornare all'elenco degli utenti che hanno accesso al progetto, fare clic sul pulsante
per copiare il collegamento diretto al progetto oppure chiudere semplicemente la finestra di dialogo facendo clic su OK.
Condivisione con un utente esterno al team
Se tenti di condividere un progetto di un Workspace Altium 365 con una persona esterna al team, verrà visualizzata la finestra di dialogo Confirm che avvisa che l'utente avrà accesso ai documenti sorgente del progetto condiviso, ai commenti inseriti e ai pacchetti di rilascio. Fai clic su OK per procedere con la condivisione del progetto.
Puoi condividere un progetto con chiunque sia esterno al team del Workspace, per la modifica o la visualizzazione.
Condivisione di un progetto locale
Se condividi un progetto locale (non gestito da un VCS esterno), il progetto verrà reso disponibile nel Workspace attualmente connesso nel momento in cui viene condiviso con le persone designate. Ciò che accade effettivamente dipende dal fatto che la condivisione sia destinata alla visualizzazione o alla modifica:
- Condivisione per la sola visualizzazione (con connessione a un Workspace Altium 365): il progetto viene reso disponibile tramite Simple Sync. In questa modalità, il progetto può essere modificato da una sola persona (il proprietario del progetto). Il punto di forza di Simple Sync emerge quando non desideri che altri modifichino il tuo progetto, ma vuoi sfruttare il paradigma Global Sharing di Altium 365 e condividere il progetto con più persone per la visualizzazione e l'inserimento di commenti. Per ulteriori informazioni su questa funzionalità, consulta Mirroring di un progetto nel Workspace tramite Simple Sync.
- Condivisione per la modifica: il progetto deve essere aggiunto al repository di progettazione Git Versioned Storage del Workspace. In questa modalità, il progetto può essere condiviso con più persone per la modifica ed è inoltre possibile utilizzare il supporto di condivisione globale di Altium 365 per la visualizzazione condivisa e l'inserimento di commenti. Verrà visualizzata una finestra di dialogo che ti informa di questo requisito e offre l'opzione Use Altium 365 VCS per procedere. Fai clic su Learn More per accedere alla pagina Condivisione, che ti guiderà nella condivisione del progetto.
Quando condividi un progetto locale (non gestito da un VCS) con una persona per la modifica, sarà necessario sottoporre il progetto al controllo di versione aggiungendolo al repository di progettazione Git Versioned Storage del Workspace.
Risultato della condivisione
Ciò che accade successivamente dipende dal tipo di utente invitato:
- Un utente che fa già parte del team del Workspace verrà aggiunto direttamente all'elenco degli utenti con accesso al progetto e riceverà un'e-mail che lo informa che il progetto è stato condiviso con lui. Potrà aprire il progetto in Altium Designer o accedervi tramite l'interfaccia del Workspace (dalla pagina Projects ).
- Quando viene aggiunto un ruolo esistente del Workspace, questo apparirà nell'elenco di accesso al progetto e tutti i membri del ruolo riceveranno un'e-mail che li informa che il progetto è stato condiviso con loro. Potranno aprire il progetto in Altium Designer o accedervi tramite l'interfaccia del Workspace (dalla pagina Projects ).
-
Quando utilizzi un Workspace Altium 365 per condividere un progetto con una persona esterna al team del Workspace, questa verrà aggiunta all'elenco di condivisione e riceverà un'e-mail che la informa che il progetto è stato condiviso con lei. Potrà aprire il progetto in Altium Designer tramite l'opzione Condivisi con me oppure accedervi tramite la propria interfaccia dello spazio personale della piattaforma Altium 365 (dalla pagina Shared with Me ). L'e-mail ricevuta fornisce l'accesso diretto al progetto tramite Altium 365. Facendo clic sul pulsante
nell'e-mail, verrà indirizzata alla pagina Altium 365 Sign In (a meno che non abbia già effettuato l'accesso alla piattaforma o al proprio account AltiumLive). Dopo aver effettuato l'accesso, verrà indirizzata direttamente al visualizzatore Web, con il progetto condiviso già caricato.

Accesso a un progetto condiviso in tempo reale dall'invito e-mail ricevuto da un utente che non fa parte del team del Workspace.
Modifica dei diritti di accesso per gli utenti esistenti
In qualsiasi momento, un amministratore (o un membro del team del Workspace con diritti di modifica) può modificare le autorizzazioni di accesso esistenti per un progetto. Per accedere all'elenco delle persone e dei ruoli con cui il progetto è già condiviso, fai clic sulla voce
sul lato sinistro della finestra di dialogo Share , quindi espandi il campo Shared with sulla destra.
Accesso all'elenco delle persone e dei ruoli che attualmente hanno accesso condiviso al progetto.
Aspetti da tenere presenti:
- In termini di autorizzazioni, una persona o un ruolo dispone dell'accesso completo in modifica al progetto quando è selezionata l'opzione Can Edit In caso contrario, dispone di un accesso in sola visualizzazione
- Owner e il ruolo Administrators dispongono sempre dell'accesso completo in modifica (Can Edit).
-
Ad eccezione di Owner e del ruolo Administrators, le autorizzazioni per tutte le persone e i ruoli inclusi possono essere impostate singolarmente su Can View o Can Edit, oppure i diritti di accesso possono essere rimossi completamente. Inoltre, la proprietà del progetto può essere trasferita a un altro utente (vedi sotto). Fai clic sullo stato attuale delle autorizzazioni per accedere ai controlli.
- Un progetto può essere condiviso esplicitamente con persone e/o ruoli specifici, oppure semplicemente con tutti i membri del team del Workspace. In quest'ultimo caso, imposta l'accesso richiesto per la voce Workspace Members . Per non condividere il progetto con l'intero team, imposta questa voce su None.
Modifica le autorizzazioni di accesso secondo necessità. Ogni entità modificata viene evidenziata nell'elenco con uno sfondo più scuro.
Esempio di modifiche alle autorizzazioni di due persone con cui il progetto è attualmente condiviso.
Per applicare le modifiche, fai clic sul pulsante
. Le modifiche verranno applicate e la conferma verrà mostrata nella finestra di dialogo. Per visualizzare l'elenco aggiornato degli accessi condivisi, fai clic sul link Who has access.
Dopo aver salvato le modifiche alle autorizzazioni, puoi visualizzare il risultato aggiornato direttamente nella finestra di dialogo Share.
Trasferimento della proprietà del progetto
Gli amministratori e i proprietari possono trasferire la proprietà a un altro utente utilizzando l'opzione Owner del menu a discesa dello stato attuale delle autorizzazioni. L'opzione può essere utilizzata dall'attuale proprietario del progetto o da un amministratore del Workspace.
Selezionando l'opzione Owner per un utente, si apre la finestra di dialogo Transfer Ownership. Fai clic su Yes per eseguire l'operazione.
Le modifiche alle autorizzazioni dell'attuale proprietario e del nuovo proprietario verranno mostrate nella finestra di dialogo. Fai clic su Save per procedere con le modifiche.
L'utente a cui viene trasferita la proprietà riceverà una notifica e-mail.
Accesso a un progetto condiviso in tempo reale
L'accesso a un progetto condiviso con un utente dipende dal fatto che l'utente sia un membro del team del Workspace o una persona esterna al team.
Membro del team del Workspace
Un membro del team del Workspace può accedere al progetto condiviso tramite Altium Designer o tramite la pagina Projects dell'interfaccia del Workspace. Tieni presente che la modifica del progetto, se l'utente dispone dei diritti di modifica, è possibile solo tramite Altium Designer.
In Altium Designer, accedi al progetto utilizzando il comando File » Open Project o il pulsante con i puntini di sospensione associato alla voce del Workspace nel pannello Projects. Verrà visualizzata la finestra di dialogo Open Project, da cui puoi scegliere quale progetto aprire nel Workspace a cui sei connesso. Quando sei connesso a un Workspace, questo viene visualizzato nell'area Locations della finestra di dialogo, contraddistinto dall'icona
e con il nome assegnato al Workspace. Verranno elencati solo i progetti del Workspace che sono stati condivisi con te e per i quali disponi dell'autorizzazione di accesso.
Una volta aperto, il progetto verrà visualizzato sotto la voce del Workspace nel pannello Projects.
Scegli quale progetto aprire nel Workspace a cui sei connesso, direttamente da Altium Designer, tra quelli attualmente condivisi con te.
Parte interessata invitata esterna al team del Workspace
Una persona esterna al team del Workspace di Altium 365 con cui è stato condiviso il progetto può accedervi tramite Altium Designer o tramite l'interfaccia della piattaforma Altium 365 (dalla pagina Condivisi con me). Per aprire il progetto, seleziona il riquadro del progetto e fai clic sul nome del progetto, oppure scegli l'opzione Open dal menu con i puntini di sospensione del riquadro. In alternativa, fai doppio clic direttamente sul riquadro. Tieni presente che la modifica del progetto, se l'utente dispone dei diritti di modifica, è possibile solo tramite Altium Designer.
In Altium Designer, accedi al progetto utilizzando il comando File » Open Project. Verrà visualizzata la finestra di dialogo Apri progetto, dalla quale potrai scegliere quale progetto del Workspace aprire dalla posizione Shared With Me.
Una volta aperto, il progetto verrà visualizzato sotto la voce Shared with me, nel pannello Progetti. Le operazioni che puoi eseguire sul progetto dipendono dai diritti di accesso che ti sono stati concessi. Se ti sono stati assegnati diritti di modifica, potrai modificare il progetto normalmente, come avviene in genere per un collaboratore esterno: poiché il progetto è condiviso da un Workspace, le modifiche vengono sincronizzate in entrambe le direzioni. Se disponi solo dei diritti di visualizzazione, potrai comunque aggiungere commenti al progetto in corso di sviluppo.
Scegli, da Altium Designer, quale progetto del Workspace aprire tra quelli attualmente condivisi con te in qualità di collaboratore esterno. Tieni presente che puoi accedere a questi progetti senza avere accesso al Workspace.
Condivisione di un'istantanea del progetto
La creazione di un'istantanea di sola lettura di un progetto consente di condividere rapidamente quel progetto, nello stato in cui si trova in un determinato momento del suo sviluppo, per collaborare con altre persone tramite il Web. Può essere utile per una revisione estemporanea del progetto, per condividere una particolare tappa del suo sviluppo o anche per stimolare una discussione contestualizzata. Per condividere in questo modo, fai clic sulla voce
sul lato sinistro della finestra di dialogo Share.
Accesso ai controlli per condividere un'istantanea di un progetto.
Condivisione tramite link
Per impostazione predefinita, la finestra di dialogo è impostata su Condividi tramite link: chiunque riceva il link potrà visualizzare l'istantanea del progetto nel proprio browser per un periodo limitato di 48 ore. Questo livello di condivisione non consente di aggiungere commenti al progetto.
Fai clic sul pulsante
per generare il link all'istantanea del progetto. In background, il progetto viene compresso in un archivio ZIP utilizzando Project Packager di Altium Designer. Una volta che il link è pronto, fai clic sul pulsante
per copiarlo, quindi condividilo con le persone desiderate.
Generazione del link a durata limitata che può essere condiviso con chiunque, ovunque.
Quando il destinatario apre il link in un browser, viene indirizzato a un'istanza di Altium 365 Viewer, sul sito principale altium.com, con il progetto elaborato e caricato.
Utilizzando il link condiviso, il destinatario può esplorare l'istantanea del progetto con Altium 365 Viewer, caricato sul sito principale altium.com. Qui è mostrato uno schema elettrico: passa il puntatore sull'immagine per vedere il PCB.
Condivisione con persone specifiche
Facendo clic sul controllo Share with specific people, la modalità di condivisione dell'istantanea del progetto cambia, consentendoti di condividerla con una o più persone specifiche tramite invito via e-mail. I destinatari potranno visualizzare, condividere o scaricare l'istantanea del progetto tramite l'interfaccia Web della piattaforma Altium 365. L'istantanea rimane disponibile permanentemente sulla piattaforma e questo livello di condivisione consente di aggiungere commenti al progetto.
Cambia modalità per condividere permanentemente un'istantanea del progetto con persone specifiche.
Inserisci l'indirizzo e-mail completo della persona con cui desideri condividere l'istantanea e premi Enter. Puoi specificare più persone in questo modo, secondo necessità. Puoi anche aggiungere una nota facoltativa per comunicare informazioni pertinenti sull'istantanea condivisa.
Esempio di condivisione di un'istantanea del progetto con una persona specifica tramite e-mail.
Quando sei pronto, fai clic sul pulsante
. Il progetto viene compresso in un archivio ZIP utilizzando Project Packager di Altium Designer, quindi caricato sulla piattaforma Altium 365. Al termine del processo viene fornita una conferma del caricamento.
L'istantanea condivisa viene compressa e quindi caricata sulla piattaforma Altium 365, dove rimane disponibile permanentemente.
La persona con cui hai condiviso l'istantanea del progetto caricata riceverà un invito via e-mail per accedervi tramite Altium 365. Facendo clic sul pulsante
nell'e-mail, verrà indirizzata alla pagina Altium 365 Sign In, a meno che non abbia già effettuato l'accesso alla piattaforma o al proprio account AltiumLive. Dopo l'accesso, verrà indirizzata al visualizzatore Web, con l'istantanea del progetto condivisa già caricata.
Accesso all'istantanea del progetto dall'invito via e-mail ricevuto dall'utente con cui è stata condivisa.
Accesso a un'istantanea del progetto condivisa
Oltre a seguire il link nell'invito via e-mail, la persona con cui è stata condivisa un'istantanea permanente del progetto potrà accedervi in qualsiasi momento per aprirla, condividerla e visualizzarla dalla Shared with Me pagina dell' interfaccia della piattaforma Altium 365. Un'istantanea del progetto è contrassegnata dall'icona
all'interno del relativo riquadro.
Per aprire il progetto nel visualizzatore integrato, seleziona il riquadro del progetto e fai clic sul nome del progetto, oppure scegli l'opzione Open dal menu con i puntini di sospensione del riquadro. In alternativa, fai doppio clic direttamente sul riquadro. Tieni presente che un'istantanea condivisa del progetto non può essere modificata e pertanto non è accessibile da Altium Designer tramite la posizione Shared With Me nella finestra di dialogo Apri progetto; può tuttavia essere scaricata se è stata condivisa con questa autorizzazione abilitata.
Accesso a un'istantanea del progetto dalla pagina Shared with Me dell'interfaccia della piattaforma Altium 365. In questo esempio è stato inserito un commento nel progetto condiviso.
Disabilitazione della condivisione
Per disabilitare completamente la condivisione, deseleziona l'opzione Altium Cloud nella pagina Sistema – Attività di rete della finestra di dialogo Preferences. Se tenti di condividere un progetto tramite la finestra di dialogo Share, in tempo reale o come istantanea, verrà visualizzata una finestra di avviso che segnala che questa opzione è stata disabilitata.

La disabilitazione della connessione ad Altium Cloud impedirà la condivisione dei progetti.
Supporto per le revisioni del progetto
La finestra di dialogo Share consente di consultare un elenco delle istanze di revisione del progetto.
Quando la voce
è selezionata sul lato sinistro della finestra di dialogo Share, sul lato destro sono elencate le revisioni attive del progetto (quelle nello stato In Progress) per le quali sei stato designato come revisore. Ogni istanza di revisione del progetto viene presentata con i seguenti dati:
-
Nome dell'istanza. Fai clic sul collegamento per aprire l'istanza nell'interfaccia browser di Altium 365.
-
Descrizione.
-
Data e ora del commit/rilascio per il quale viene creata l'istanza di revisione del progetto.
-
Autore e data e ora di creazione dell'istanza.
Se il progetto non dispone di istanze nello stato In Progress, il pulsante
è disponibile in basso a destra nella finestra di dialogo. Fai clic su di esso per chiudere la finestra di dialogo e accedere alla pagina Design Reviews del progetto nell'interfaccia browser del Workspace. Si apre la finestra Create Design Review, in cui puoi definire i revisori, la descrizione e il modello di checklist da utilizzare.
).









).