Mantenere sincronizzati gli schemi elettrici e il PCB
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
A colpo d'occhio
- Scopri la differenza tra i flussi di lavoro basati sul confronto bidirezionale e quelli basati sull'aggiornamento diretto, e quando viene utilizzato ciascun approccio.
- Comprendi quali dati Altium Designer può sincronizzare tra schema elettrico e PCB, inclusi componenti, connettività, classi e alcune regole di progettazione.
- Scopri come le opzioni di progetto, quali le impostazioni del comparatore e della generazione degli ECO, influenzano il processo di sincronizzazione e le modifiche che possono essere applicate.
L'attività più comune nella progettazione dallo schema al PCB consiste nel mantenere lo schema e il PCB allineati o sincronizzati. Che si tratti di trasferire per la prima volta un progetto acquisito a un nuovo PCB o di apportare modifiche a un progetto esistente sullo schema o sul PCB, è necessario un modo per mantenere sincronizzate le due parti. Altium Designer include potenti funzionalità di sincronizzazione del progetto che semplificano questa attività, consentendo al progettista di concentrarsi sugli aspetti creativi del processo di progettazione.
Il processo di sincronizzazione rileva e risolve le differenze tra lo schema e il PCB.
La sincronizzazione del progetto viene eseguita direttamente tra gli editor dello schema e del PCB, senza utilizzare alcun documento intermedio simile a una netlist. Il software utilizza un motore di confronto per confrontare tutti gli aspetti del progetto, presentando i risultati sotto forma di elenco delle differenze. Il progettista decide quale parte modificare per risolvere le differenze e viene creato un insieme di ordini di modifica tecnica (ECO). Una volta applicati, le due parti del progetto sono nuovamente sincronizzate.
Cosa può essere sincronizzato?
Il processo di sincronizzazione garantisce che i dati dei componenti e delle connessioni nello schema corrispondano a quelli sul PCB. Oltre ai dati dei componenti e delle connessioni, il processo di sincronizzazione garantisce che siano sincronizzati anche altri vincoli di progettazione, come le classi di net, le classi di componenti e le regole di progettazione.
Configurazione delle opzioni del comparatore
Dialog page: Opzioni del progetto PCB, scheda Comparatore
I dati dello schema e del PCB da confrontare what vengono configurati nella scheda Comparatore della finestra di dialogo Options for PCB Project. Selezionare Project » Project Options per aprire la finestra di dialogo.

Il motore di confronto segue le impostazioni definite nella scheda Comparator della finestra di dialogo Options for Project.
L'area principale della finestra di dialogo include un ampio elenco di tipi di confronto, come Different Designators e Changed Net Name, raggruppati in 5 categorie. La colonna Mode sulla destra include un menu a discesa per ciascun tipo, in cui selezionare la modalità di confronto, come Find Differences o Ignore Differences. I confronti di tipo testuale dispongono di una terza opzione, che consente di ignorare la distinzione tra maiuscole e minuscole.
Per un nuovo progetto, l'impostazione predefinita prevede l'individuazione delle differenze per ogni tipo di confronto; impostare le opzioni in base alle esigenze del progetto.
Nella parte inferiore della finestra di dialogo sono presenti le opzioni per impostare Object Matching Criteria. La corrispondenza viene determinata mediante un processo sofisticato a più passaggi, che non si basa sulla semplice corrispondenza esatta delle stringhe. Per saperne di più, consultare la sezione Corrispondenza di net e classi.
Notare l'opzione Ignore Rules Defined in the PCB Only nella parte inferiore della finestra di dialogo: abilitarla per escludere dal processo di confronto le regole definite nel PCB.
Sincronizzazione delle classi di net e di componenti
Dialog page: Opzioni del progetto PCB, scheda Generazione delle classi
Oltre ai dati dei componenti e delle connessioni, è possibile generare e sincronizzare anche classi e regole di progettazione quando si esegue un Design » Update PCB.
Sincronizzazione delle regole di progettazione
Le regole di progettazione possono essere definite nello schema utilizzando un oggetto Set di parametri. Quando si seleziona un oggetto Set di parametri, il pannello o la finestra di dialogo modale Properties include un'area Rules. Fare clic sul menu a discesa Add per aggiungere una regola di progettazione. La regola verrà applicata alla net, al bus, al cablaggio o agli oggetti sotto il blanket con cui l'oggetto Set di parametri è a contatto.
Nell'immagine seguente, una regola di progettazione che impone un vincolo di larghezza viene applicata alla classe di net USB_data (anche la classe di net è definita come parte di questo Set di parametri, nell'area Classes del menu a discesa Parameters ).

Il Set di parametri viene utilizzato per definire una classe di net e una regola di progettazione per le net sotto l'oggetto blanket dello schema. Notare che le unità di misura richieste vengono configurate nella parte inferiore della finestra di dialogo Modifica regola PCB.
Aggiunta di una regola di progettazione nello schema
- Collegare un Set di parametri alla net, al bus, al cablaggio o al blanket (aggiungere una definizione di classe di net nel Set di parametri, se necessario).
- Add una definizione di regola nel Set di parametri. Si aprirà la finestra di dialogo Choose Design Rule Type, come mostrato sopra.
- Selezionare il Rule Type richiesto.
- Fare clic sul pulsante OK per aprire la finestra di dialogo Edit PCB Rule.
- Configurare i requisiti della regola PCB secondo necessità. Notare che le unità di misura richieste per questa regola PCB vengono selezionate nella parte inferiore della finestra di dialogo.
Sia nell'immagine precedente sia in quella seguente, la regola di progettazione è definita in un oggetto Set di parametri collegato a un blanket. Includendo una definizione di classe nell'oggetto Set di parametri, verrà creata anche una classe di net PCB e, poiché è presente la definizione di classe, l'ambito di applicazione della regola PCB sarà InNetClass('<PCB_NetClassName >').
Nell'immagine seguente si può notare che l'oggetto Set di parametri è visualizzato come una direttiva Coppia differenziale. Si tratta di un tipo speciale di oggetto Set di parametri, posizionato utilizzando il comando Place » Directives » Differential Pair.

La direttiva Coppia differenziale viene utilizzata per definire una classe di net e una regola di progettazione, che viene poi applicata alle coppie differenziali di destinazione.
Configurazione delle opzioni di generazione degli ECO
La finestra di dialogo Options for Project include anche una scheda Generazione ECO. Questa scheda definisce per quali modifiche al progetto è possibile creare ECO. In genere queste opzioni sono tutte abilitate, mentre le opzioni nella scheda Comparatore della finestra di dialogo vengono utilizzate per configurare quali modifiche al progetto devono essere sincronizzate tra lo schema elettrico e il PCB.

La scheda Generazione ECO definisce per quali tipi di modifiche è possibile creare ECO.
Individuazione delle differenze
La funzione di sincronizzazione del progetto è in grado di rilevare e risolvere le differenze in entrambe le direzioni, ovvero dallo schema elettrico al PCB o dal PCB allo schema elettrico.
Il software è in grado di risolvere queste differenze applicando modifiche a entrambi i lati contemporaneamente. Ad esempio, si immagini uno scenario in cui il progettista elettronico abbia modificato il valore di un condensatore, mentre il progettista del PCB abbia modificato il footprint dello stesso condensatore. Queste due differenze possono essere risolte con un'unica procedura di aggiornamento, applicando la modifica del commento come aggiornamento dallo schema elettrico al PCB e la modifica del footprint come aggiornamento dal PCB allo schema elettrico.
Quando il motore di confronto confronta il progetto dello schema elettrico con il PCB, viene creato un elenco completo delle differenze: in questa fase non viene fatta alcuna ipotesi su quale lato debba essere modificato per ripristinare la sincronizzazione.
L'elenco delle differenze è visualizzabile nella finestra di dialogo Differences between.
Opzioni e controlli della finestra di dialogo Differences between
La finestra di dialogo è essenzialmente suddivisa in tre aree principali: Differences, Update e Change Order.
Differenze
Quest'area della finestra di dialogo elenca tutte le differenze rilevate dal comparatore tra i documenti selezionati. Ogni differenza è elencata nella colonna corrispondente al documento in cui si trova. Le differenze sono raggruppate per tipo di confronto, secondo quanto elencato e abilitato nella scheda Comparatore della finestra di dialogo Project Options . La voce a livello di gruppo indica il numero di differenze di quel tipo.
Fare doppio clic su una voce per individuare l'oggetto nel relativo documento sorgente tramite il cross-probing.
Aggiornamento
Utilizzare quest'area della finestra di dialogo per specificare quale documento deve essere aggiornato per risolvere la differenza. Per impostazione predefinita, a tutte le voci Decision viene inizialmente applicata la decisione No Change .
La decisione di aggiornamento per ciascuna differenza può essere definita singolarmente facendo clic sulla voce associata nella colonna Decision e selezionando l'azione di aggiornamento desiderata nella successiva finestra di dialogo Decisione ECO. È sufficiente scegliere la direzione dell'aggiornamento (quale dei documenti confrontati aggiornare) oppure No Updates.
Ordine di modifica
Quest'area della finestra di dialogo elenca, per ogni differenza su cui si decide di intervenire, l'azione da eseguire, l'oggetto interessato dall'azione e il documento su cui verrà eseguita. Queste informazioni vengono utilizzate per compilare il successivo ECO, che servirà ad applicare gli aggiornamenti. Le azioni più comuni elencate in quest'area sono:
- Remove - quando l'aggiornamento è diretto verso il documento che contiene l'oggetto che causa la differenza; l'oggetto verrà rimosso.
- Add - quando l'aggiornamento è diretto verso il documento che non contiene l'oggetto che causa la differenza; l'oggetto verrà aggiunto.
- Update - quando entrambi i documenti contengono lo stesso oggetto, che differisce per qualche aspetto; l'oggetto modificato dipende dalla direzione scelta.
Menu contestuale
- Create Change Order - consente di creare un ordine di modifica tecnica (Engineering Change Order, ECO).
- Generate Report - consente di generare un report delle differenze rilevate dal comparatore. Le decisioni di aggiornamento prese e le azioni saranno incluse nell'ECO generato. Il report verrà caricato nella finestra di dialogo Report Preview. Utilizzare questa finestra di dialogo per consultare il report prima di esportarlo in uno dei vari formati supportati o stamparlo direttamente.
- << Update All in - consente di impostare la direzione di aggiornamento di tutte le differenze verso il documento a sinistra (ove applicabile).
- Update All in >> - consente di impostare la direzione di aggiornamento di tutte le differenze verso il documento a destra (ove applicabile).
- Reverse Direction For All - consente di invertire rapidamente la direzione di aggiornamento di tutte le differenze (ove applicabile). Se non è possibile cambiare la direzione per una differenza, la voce verrà impostata su No Change.
- Set No Action For All - consente di impostare rapidamente la decisione di aggiornamento per tutte le differenze su No Change.
- << Update Same Kind in - consente di impostare la direzione di aggiornamento di tutte le differenze dello stesso tipo di confronto della differenza attualmente selezionata verso il documento a sinistra (ove applicabile).
- Update Same Kind in >> - utilizzare per impostare la direzione di aggiornamento verso il documento di destra per tutte le differenze dello stesso tipo di confronto della differenza attualmente selezionata (ove applicabile).
- Reverse Direction For Same Kind - utilizzare per invertire rapidamente la direzione di aggiornamento per tutte le differenze dello stesso tipo di confronto della differenza attualmente selezionata, ove applicabile. Se non è consentito modificare la direzione per una differenza, la voce verrà impostata su No Change.
- Set No Action For Same Kind - utilizzare per impostare rapidamente la direzione di aggiornamento per tutte le differenze dello stesso tipo di confronto della differenza attualmente selezionata su No Change.
- << Update Selected in - utilizzare per impostare la direzione di aggiornamento verso il documento di sinistra per tutte le differenze selezionate (ove applicabile).
- Update Selected in >> - utilizzare per impostare la direzione di aggiornamento verso il documento di destra per tutte le differenze selezionate (ove applicabile).
- Reverse Direction For Selected - utilizzare per invertire rapidamente la direzione di aggiornamento per tutte le differenze selezionate (ove applicabile). Se non è consentito modificare la direzione per una differenza, la voce verrà impostata su No Change.
- Set No Action For Selected - utilizzare per impostare rapidamente la decisione di aggiornamento per tutte le differenze selezionate su No Change.
- Invert Selection - utilizzare per selezionare tutte le differenze attualmente non selezionate nell'elenco o deselezionare quelle selezionate.
Controlli aggiuntivi
Nella parte inferiore della finestra di dialogo sono disponibili i seguenti pulsanti:
- Create Engineering Change Order - fare clic su questo pulsante per generare un ECO. Verrà visualizzata la finestra di dialogo Engineering Change Order, da cui è possibile convalidare ed eseguire gli aggiornamenti per sincronizzare i documenti.
- Report Differences - fare clic su questo pulsante per generare un report delle differenze rilevate dal Comparatore. Le decisioni di aggiornamento prese e le azioni verranno incluse nell'ECO generato. Il report verrà caricato nella finestra di dialogo Report Preview. Utilizzare questa finestra di dialogo per esaminare il report prima di esportarlo in uno dei vari formati supportati o stamparlo direttamente.
- Explore Differences - fare clic su questo pulsante per esaminare più a fondo le differenze rilevate dal Comparatore prima di generare un ECO. La finestra di dialogo Differences between verrà chiusa e si tornerà all'area di lavoro principale con il pannello Differenze aperto. Il pannello conterrà tutte le differenze elencate dal Comparatore, suddivise nelle stesse categorie. Utilizzare il pannello per individuare tramite cross-probing un oggetto responsabile di una differenza nel documento a cui appartiene.
Per aprire la finestra di dialogo Difference between e visualizzare un elenco delle differenze:
-
Per aprire la finestra di dialogo Choose Documents to Compare, come mostrato nell'immagine seguente, eseguire il comando Project » Show Differences oppure fare clic con il pulsante destro del mouse sulla voce del progetto desiderato (o su uno dei suoi documenti di origine) nel pannello Projects e scegliere il comando Show Differences dal menu contestuale. La finestra di dialogo Choose Documents to Compare consente di selezionare i due documenti o insiemi di documenti da confrontare; in genere si confronta il progetto schematico con il PCB. È inoltre possibile utilizzare questa finestra di dialogo per confrontare qualsiasi documento con un altro selezionando l'opzione Advanced Mode. Ad esempio, si può confrontare una netlist con un PCB oppure un PCB con un altro PCB.
In genere, la configurazione predefinita della finestra di dialogo, sia in modalità base sia avanzata, è adatta alla maggior parte delle esigenze di confronto dei progetti, quando occorre confrontare i documenti di origine con il progetto PCB di destinazione per sincronizzarli. La finestra di dialogo consente tuttavia di confrontare anche altri documenti, il che può essere utile se è necessario caricare versioni di un progetto e confrontare le differenze tra i corrispondenti documenti di origine.

Selezionare il PCB con cui confrontare il progetto schematico. - Selezionare il PCB nella parte principale della finestra di dialogo e fare clic su OK per aprire la finestra di dialogo Difference between, come mostrato di seguito. Se il documento PCB è attualmente sincronizzato con i documenti di origine, verrà visualizzata una finestra di dialogo che indica che non sono state rilevate differenze.
Si aprirà la finestra di dialogo Differences between. Il Sincronizzatore è bidirezionale. Ciò significa che è possibile specificare aggiornamenti per entrambi i documenti nello stesso ECO. Per sincronizzare i documenti confrontati, occorre determinare, per ogni differenza, se intervenire e in quale direzione apportare la modifica, specificando quale documento deve essere aggiornato per eliminare la differenza. Il passaggio successivo consiste quindi nell'assegnare una direzione di aggiornamento a ogni differenza:
- Per una singola differenza, fare clic nella colonna Update per visualizzare un selettore di direzione, come mostrato nell'immagine seguente.
- Per più differenze dello stesso tipo, fare clic con il pulsante destro del mouse su un'intestazione, ad esempio Footprint diversi, e selezionare il comando Update Same Kind desiderato.
- Per tutte le differenze, fare clic con il pulsante destro del mouse in un punto qualsiasi della finestra di dialogo e selezionare il comando Update All desiderato.

Per ogni differenza, è necessario impostare la direzione di aggiornamento affinché venga creato un ECO per risolverla.
Fare clic sul pulsante Explore Differences per accedere al pannello Differences ed esaminare le differenze come descritto nella sezione Esplorazione delle modifiche al progetto con il pannello Differenze riportata di seguito.
Fare clic su Report Differences per configurare e stampare/esportare un report delle differenze rilevate dal Comparatore, delle decisioni di aggiornamento specificate e delle azioni che verranno incluse nell'ECO generato.
Una volta assegnata la direzione di aggiornamento, fare clic sul pulsante Create Engineering Change Order per aprire la finestra di dialogo Engineering Change Order, descritta nella sezione Risoluzione delle differenze - Applicazione degli ECO riportata di seguito.
Esplorazione delle modifiche al progetto con il pannello Differenze

Il pannello Differences mostra una vista gerarchica delle differenze tra i documenti.
Riepilogo
Il pannello Differences viene utilizzato per visualizzare le differenze logiche o fisiche rilevate dal comparatore delle differenze integrato nel software durante il confronto dei documenti di progetto (ad esempio, quando si confronta la gerarchia dei documenti sorgente (schemi elettrici) di un progetto con il documento di progettazione PCB). Il pannello consente di esplorare in modo interattivo le differenze prima di decidere se creare un ordine di modifica tecnica (ECO) da utilizzare per sincronizzare i documenti del progetto.
Accesso al pannello
Per aprire il pannello Differences :
- Scegliere View » Panels » Differences dai menu principali.
- Fare clic sul pulsante Panels in basso a destra nell'area di lavoro di progettazione, quindi fare clic su Differences.
Visualizzazione delle differenze
L'utilizzo del pannello Differences dipende dall'obiettivo:
- Analizzare l'integrità dell'intero progetto in termini di contenuto e struttura, rilevando le differenze logiche all'interno della gerarchia del progetto.
- Confrontare due versioni dello stesso documento schematico o PCB, rilevandone le differenze grafiche (fisiche).
Visualizzazione delle differenze logiche
Il confronto dei documenti di progetto per individuare le differenze logiche viene eseguito nella finestra di dialogo Choose Documents To Compare, che si apre facendo clic con il pulsante destro del mouse su un progetto (o su un documento di progetto) nel pannello Projects e selezionando Show Differences dal relativo menu contestuale.

Fare clic con il pulsante destro del mouse sul nome di un progetto, quindi selezionare Show Differences per aprire la finestra di dialogo Choose Documents To Compare.
In genere, il documento PCB viene confrontato con la gerarchia dei documenti sorgente del progetto di appartenenza per rilevare le differenze logiche tra il contenuto dello schema elettrico e quello del progetto PCB.
Dopo aver fatto clic su OK, se esistono differenze tra i documenti selezionati, si apre la finestra di dialogo Differenze tra. Le informazioni nel pannello Differences vengono visualizzate solo dopo aver fatto clic sul pulsante Explore Differences nella finestra di dialogo Differences between.
Il pannello Differences visualizza solo le differenze elencate nella finestra di dialogo Differences between. Queste, a loro volta, sono determinate dalle selezioni effettuate nella scheda Comparatore della finestra di dialogo Project Options (Project » Options). Questa scheda elenca tutti i tipi di confronto, ad esempio le differenze associate a componenti, reti e parametri. Impostando Mode per ciascuna categoria di confronto su Find Differences o Ignore Differences si determina se il comparatore delle differenze debba trasferire i risultati nella finestra di dialogo Differences between .

Configurare le modalità di rilevamento e segnalazione delle differenze nella finestra di dialogo Project Options.
Il pannello Differences visualizza le differenze rilevate tra i documenti sorgente in una struttura ad albero, nella quale la cartella di primo livello mostra il numero totale di differenze rilevate. Vengono quindi create sottocartelle per ogni tipo di confronto specifico presente nella finestra di dialogo Differenze tra. Ogni sottocartella elenca le differenze specifiche rilevate, ulteriormente suddivise negli oggetti presenti nei documenti che hanno generato tali differenze.
Se il documento associato è aperto (o aperto ma nascosto), facendo clic su una voce relativa a un oggetto nel pannello si passa all'oggetto nel documento tramite cross-probing.
La visualizzazione dell'oggetto utilizza lo zoom e l'effetto di attenuazione, che evidenzia l'oggetto attenuando tutti gli altri. Il contrasto dell'attenuazione può essere regolato con il cursore Dimming presente nell'area Highlight Methods della pagina Sistema - Navigazione della finestra di dialogo Preferences .
Visualizzazione delle differenze fisiche
Il confronto grafico (fisico) di due versioni dello stesso documento schematico o PCB viene eseguito sostanzialmente allo stesso modo del confronto logico descritto sopra, ma utilizza anche Advanced Mode nella finestra di dialogo Choose Documents To Compare.
Per eseguire un confronto fisico dei documenti, utilizzare il comando Show Differences (nel menu accessibile con il pulsante destro del mouse nel pannello Projects) per aprire la finestra di dialogo Choose Documents To Compare, quindi selezionare la casella Advanced Mode. Una volta visualizzati tutti i file del progetto nella finestra di dialogo, selezionare le due versioni di un documento da confrontare.

Selezione dei documenti per il confronto fisico dalla finestra di dialogo Choose Documents To Compare in Advanced Mode.
Facendo clic su OK si avvia il confronto grafico e si apre la finestra di dialogo Differenze tra, come descritto in precedenza. Fare clic su Explore Differences per aprire l'elenco interattivo delle differenze nel pannello Differences.
Il pannello visualizza le differenze rilevate tra i documenti in una struttura ad albero. La cartella di primo livello mostra il numero totale di differenze rilevate. Viene creata una voce per ciascun tipo di differenza, che a sua volta contiene i riferimenti specifici e l'oggetto coinvolto (porta, componente, ecc.).
Selezionando la voce relativa all'oggetto di una differenza rilevata, l'oggetto viene evidenziato e ingrandito nell'area di progettazione dell'editor.
Note
- Se un oggetto nel pannello si trova in un documento attualmente nascosto, facendo clic sulla voce associata il documento viene aperto automaticamente e reso attivo nella finestra dell'editor di progettazione.
- Il filtro applicato durante il cross-probing dal pannello Differences è temporaneo. Pertanto, è comunque possibile selezionare o modificare gli oggetti di progetto che non rientrano nell'ambito del filtro.
- Le informazioni nel pannello Differences vengono cancellate quando si esegue un nuovo confronto dei documenti o si compila il progetto di appartenenza.
- Utilizzare il comando Project » Show Physical Differences dai menu principali per rilevare le differenze fisiche esistenti tra due versioni di un documento schematico o PCB e presentarle graficamente visualizzando i due documenti affiancati nell'area di progettazione. Questa funzione di visualizzazione delle differenze fisiche offre un confronto puramente visivo: nessuno dei documenti confrontati può essere aggiornato mediante la generazione di ECO. È pensata per confrontare due versioni dello stesso documento, ma se viene utilizzata per confrontare documenti diversi, ad esempio la gerarchia dei documenti sorgente del progetto con il PCB, viene visualizzato il pannello Differences con l'elenco delle differenze logiche rilevate.
Esecuzione di un aggiornamento diretto
Poiché il progettista in genere sa già in quale direzione applicare gli aggiornamenti e questi vengono tutti applicati nella stessa direzione, è possibile scegliere di saltare il processo di rilevamento delle differenze e assegnazione della direzione appena descritto.
Anziché selezionare il comando Show Differences dal menu Project, scegli il comando Update dal menu Design, nell'editor degli schemi o nell'editor PCB. La scelta dell'editor da cui esegui il comando indica la direzione in cui desideri applicare le modifiche: dall'editor this all'editor that. Ad esempio, scegli Design » Update nell'editor degli schemi per trasferire tutte le modifiche dallo schema al PCB.
La finestra di dialogo Differences between verrà ignorata e passerai direttamente alla finestra di dialogo Engineering Change Order.
Se tutti gli aggiornamenti devono essere applicati nella stessa direzione, usa il comando Design » Update.
Risoluzione delle differenze - Applicazione degli ECO
Ogni differenza viene risolta applicando un ordine di modifica tecnica (Engineering Change Order, ECO). Gli ECO sono elencati nella finestra di dialogo Engineering Change Order, uno per riga, ciascuno con la propria casella di controllo Enable.
Quando usi la finestra di dialogo Engineering Change Order:
- La finestra di dialogo si apre con tutte le modifiche abilitate; disabilita quelle che desideri rimandare. La finestra di dialogo supporta la selezione multipla: usa il menu contestuale accessibile con il tasto destro del mouse per attivare o disattivare gli ECO selezionati.
- Usa il comando Cross Probe del menu contestuale per esaminare gli oggetti interessati dall'ECO.
- Usa il pulsante Validate Changes per verificare che le modifiche possano essere eseguite. In genere, gli ECO non riescono perché un oggetto non è disponibile: ad esempio, il footprint PCB specificato non esiste nelle librerie basate su file disponibili, oppure la piazzola specificata non esiste nel footprint.
- Un ECO può non riuscire anche perché un oggetto necessario per un determinato ECO non era presente, ma è stato aggiunto durante l'elaborazione degli ECO correnti. In questo caso, esegui nuovamente il comando Update per completare l'ECO.

Ogni modifica al progetto viene presentata come un ECO: abilita quelli necessari.
Opzioni e controlli della finestra di dialogo Engineering Change Order
La finestra di dialogo è suddivisa in due aree principali: Modifications e Status.
Modifiche
Quest'area della finestra di dialogo elenca tutte le modifiche necessarie per ottenere la sincronizzazione. Le modifiche sono raggruppate per tipo, secondo quanto elencato e abilitato nella finestra di dialogo Project Options - ECO Generation. La voce a livello di gruppo indica il numero di modifiche di quel tipo. Ogni singola modifica in quest'area è descritta dalle seguenti informazioni:
- Enable - questa opzione determina se la modifica verrà inclusa o meno nell'esecuzione dell'ECO. Fai clic direttamente sulla casella di controllo per alternarne lo stato tra abilitata/inclusa (selezionata) e disabilitata/esclusa (deselezionata). Puoi selezionare e deselezionare la casella di controllo Enable usando la barra spaziatrice.
- Action - l'azione specifica da eseguire. I tipi di azione dipendono dal tipo di ECO da eseguire.
- Affected Object - l'oggetto interessato dall'azione.
- Affected Document - il documento su cui verrà eseguita l'azione.
Menu contestuale
Per impostazione predefinita, tutte le modifiche sono abilitate per essere incluse nell'esecuzione dell'ECO. Abilita o disabilita ciascuna modifica in base alle esigenze, singolarmente oppure usando i seguenti comandi disponibili nel menu contestuale per cambiare lo stato di abilitazione di più modifiche:
- Validate Changes - fai clic per eseguire una verifica di validità delle modifiche abilitate per l'inclusione nell'ECO. I risultati della verifica verranno visualizzati nella colonna Check dell'area Status della finestra di dialogo.
- Execute Changes - fai clic per eseguire l'ECO. I risultati dell'esecuzione verranno visualizzati nella colonna Done dell'area Status della finestra di dialogo. Ricorda che verranno eseguite solo le modifiche che superano la fase di verifica.
- Create Report - fai clic per generare un report delle modifiche contenute nell'ECO. Il report verrà caricato nella finestra di dialogo Report Preview.
- Cross Probe - fai clic per individuare tramite cross-probing gli oggetti di destinazione e di riferimento coinvolti in una modifica nei documenti schematici e PCB associati.
- Expand All - fai clic per espandere la visualizzazione di tutte le modifiche nell'elenco.
- Contract All - fai clic per comprimere la visualizzazione di tutte le modifiche nell'elenco.
- Enable All - usa questo comando per abilitare tutte le modifiche.
- Disable All - usa questo comando per disabilitare tutte le modifiche.
- Enable Selected - usa questo comando per abilitare tutte le modifiche selezionate.
- Disable Selected - usa questo comando per disabilitare tutte le modifiche selezionate.
- Enable all of same Kind - usa questo comando per abilitare tutte le modifiche dello stesso tipo della modifica attualmente attiva.
- Disable all of same Kind - usa questo comando per disabilitare tutte le modifiche dello stesso tipo della modifica attualmente attiva.
- Invert Selection - usa questo comando per selezionare rapidamente tutte le modifiche attualmente non selezionate nell'elenco e deselezionare quelle selezionate.
Stato
Quest'area della finestra di dialogo presenta le seguenti informazioni di stato per ogni modifica abilitata:
- Check - questo campo mostra il risultato della verifica di validità della modifica. Un segno di spunta verde indica che la modifica proposta è supportata e verrà applicata durante l'esecuzione dell'ECO. Una croce rossa indica che la modifica proposta non è valida e non verrà applicata durante l'esecuzione dell'ECO.
- Done - questo campo mostra il risultato dell'esecuzione della modifica. Un segno di spunta verde indica che la modifica valida è stata eseguita correttamente.
- Message - se la modifica non supera la fase di convalida, in questo campo (e anche nel pannello Messages) verrà visualizzata una voce che ne indica il motivo.
Controlli aggiuntivi
I seguenti controlli sono disponibili nella parte inferiore della finestra di dialogo e nel menu contestuale:
- Validate Changes - fare clic per eseguire una verifica di convalida delle modifiche abilitate per l'inclusione nell'ECO. I risultati della convalida verranno visualizzati nella colonna Check nell'area Status della finestra di dialogo.
- Execute Changes - fare clic per eseguire l'ECO e applicare le modifiche valide in esso contenute. I risultati dell'esecuzione verranno visualizzati nella colonna Done nell'area Status della finestra di dialogo. Ricordare che verranno eseguite solo le modifiche che superano la fase di convalida.
- Report Changes - fare clic per generare un report delle modifiche contenute nell'ECO. Il report verrà caricato nella finestra di dialogo Report Preview.
- Only Show Errors - selezionare questa opzione per visualizzare solo gli errori dell'ordine di modifica tecnica (ECO). Le modifiche convalidate non verranno visualizzate. Visualizzare solo l'elenco degli errori consente di esaminare rapidamente il progetto e apportare le modifiche necessarie affinché l'ECO risultante superi completamente la convalida.
Comprendere il collegamento tra lo schema e il PCB
Associazione dei componenti tramite identificatori univoci
Ogni componente dello schema è collegato al relativo componente sul PCB tramite un identificatore univoco (UID). L'UID viene assegnato quando il componente dello schema viene posizionato sul foglio e questo valore viene trasferito al componente sul PCB quando il progetto viene trasferito nell'editor PCB. Quando le informazioni sui componenti vengono trasferite per la prima volta dai documenti sorgente dello schema al documento di progetto PCB vuoto, utilizzando Synchronizer, tutti i componenti vengono collegati automaticamente tramite ID univoco: le informazioni sull'ID di ciascun componente dello schema vengono assegnate al footprint del componente corrispondente.
Questo sistema sarebbe adeguato per un progetto semplice, ma non è in grado di supportare un progetto multicanale. In un progetto multicanale, lo stesso componente dello schema viene ripetuto in ogni canale fisico, il che significherebbe che i componenti ripetuti sul PCB avrebbero lo stesso UID. Per gestire questa situazione, l'UID del componente sul PCB viene creato combinando l'UID del simbolo di foglio padre con l'UID del componente dello schema. La sintassi dell'UID sul PCB varia leggermente a seconda di come è stato creato il progetto multicanale.
Per un progetto multicanale creato posizionando più simboli di foglio che fanno tutti riferimento allo stesso foglio schematico, ogni simbolo di foglio può fornire un ID univoco, quindi l'UID sul PCB ha il formato:
\SheetSymbolUID\SchComponentUID
Per un progetto multicanale creato utilizzando la parola chiave Repeat, è disponibile un solo UID del simbolo di foglio, quindi l'UID sul PCB include anche il valore ChannelIndex, nel formato:
\ChannelIndex+SheetSymbolUID\SchComponentUID
Quando i componenti non sono collegati
Il vantaggio di utilizzare un UID per associare i componenti dello schema e del PCB è che consente ai designatori di perdere la sincronizzazione (ad esempio, eseguendo più volte una riannotazione del PCB), senza alcun rischio di rendere impossibile la risincronizzazione dello schema e del PCB.
Se nello schema o sul PCB è presente un componente che non ha un componente corrispondente (con lo stesso UID) nell'altro editor, si verificherà quanto segue:
- Se il componente aggiuntivo è presente solo nell'editor sorgente, verrà generato un ECO per aggiungerlo nell'editor di destinazione.
- Se il componente aggiuntivo è presente solo nell'editor di destinazione, verrà generato un ECO per rimuoverlo.
- Quando in entrambi gli editor sono presenti componenti non associati, il software necessita di istruzioni su come gestirli, quindi si apre la finestra di dialogo Failed to Match Unique Identifiers.
La finestra di dialogo e Failed to Match Unique Identifiers
I pulsanti della finestra di dialogo offrono le seguenti opzioni:
- Automatically Create Component Links - fare clic su questo pulsante se si sa che i componenti non associati hanno già designatori corrispondenti. Utilizzando i designatori dei componenti, il software assegnerà UID corrispondenti a questi componenti aggiuntivi. Per i componenti che possono essere associati in base al designatore, eventuali differenze nelle altre proprietà (ad esempio parametri non corrispondenti) comporteranno la generazione di ECO. Se sono presenti componenti che non possono essere associati in base al designatore, verranno generati ECO per aggiungerli o rimuoverli (i componenti aggiuntivi presenti nell'editor sorgente verranno aggiunti, mentre quelli presenti nell'editor di destinazione verranno rimossi).
-
Manual Component Links - fare clic su questo pulsante se si sa che esistono componenti corrispondenti, ma non si conosce lo stato dei relativi designatori. Si aprirà la finestra di dialogo Edit Component Links (descritta di seguito), nella quale è possibile selezionare manualmente ogni componente sorgente e di destinazione e trasferirli nell'elenco dei componenti associati, assegnando loro UID corrispondenti. Verranno quindi generati ECO per sincronizzare i designatori (e qualsiasi altra proprietà non corrispondente dei componenti).
- Cancel - fare clic su questo pulsante per generare ECO che aggiungano i componenti aggiuntivi presenti nell'editor sorgente e rimuovano quelli presenti nell'editor di destinazione.
Collegamento manuale dei componenti
Lo stato dei collegamenti tra i componenti dello schema e i footprint dei componenti corrispondenti sul PCB può essere verificato e gestito in qualsiasi momento nella finestra di dialogo Edit Component Links (editor PCB, comando Projects » Component Links).

La finestra di dialogo Edit Component Links viene utilizzata per rilevare e risolvere le discrepanze tra gli UID e viene aperta dall'editor PCB.
Riepilogo delle funzionalità della finestra di dialogo:
- I componenti non associati vengono presentati nelle due colonne Un-Matched Components a sinistra; i componenti che condividono un UID corrispondente vengono presentati nell'area Matched Components a destra della finestra di dialogo.
- I pulsanti freccia al centro della finestra di dialogo vengono utilizzati per associare manualmente i componenti selezionati (o annullarne l'associazione), oppure per annullare tutte le associazioni correnti.
- Il pulsante Add Pairs Matched By e le opzioni nella parte inferiore della finestra di dialogo vengono utilizzati per esaminare l'elenco dei componenti attualmente non associati e tentare di associarli in base alle proprietà abilitate (Designatore, Commento, Footprint).
- Quando si fa clic sul pulsante Perform Update, a ogni componente sul PCB appena associato viene assegnato l'UID della relativa controparte nello schema. Se sono state spostate delle voci in Matched sezione della finestra di dialogo alle Unmatched sezioni, verrà visualizzata una finestra di conferma che avvisa che, procedendo, le associazioni esistenti tra i componenti verranno interrotte. Facendo clic su Yes si procederà con l'aggiornamento e verrà visualizzata una finestra informativa con un riepilogo dei collegamenti tra componenti modificati nel documento PCB. Una nuova voce nella sezione Matched viene riepilogata come Link Modified, mentre una voce precedentemente collegata di cui è stata ora annullata l'associazione viene riepilogata come Link Removed.
- Dopo aver utilizzato questa finestra di dialogo per collegare manualmente i componenti, è buona prassi verificare lo stato di sincronizzazione (eseguire il comando Design » Update).
Associazione di net e classi
Sia le net che le classi hanno un elemento padre (la net o la classe) ed elementi figli (i membri di quella net o classe). Per associarle è necessario un approccio diverso dal meccanismo UID utilizzato per collegare i componenti, in modo da supportare modifiche all'elemento padre, agli elementi figli o a entrambi. Ad esempio, una semplice modifica del nome di una net nello schematico non dovrebbe richiedere la rimozione dal PCB della net e di tutti i suoi pin figli, seguita dall'aggiunta della net con il nuovo nome e, infine, dall'aggiunta di tutti i pin figli alla nuova net.
A questo scopo, il software include algoritmi di associazione distinti per associare net e classi in base ai loro membri e al loro nome. Il processo di associazione viene configurato nella sezione Object Matching Criteria della scheda Comparator della finestra di dialogo Options for Project.

L'impostazione predefinita prevede l'associazione prima in base ai membri, poi in base al nome del tipo di oggetto.
L'associazione per questi tipi di oggetti viene gestita nel modo seguente:
- Durante la sincronizzazione del progetto, il comportamento predefinito consiste nel tentare prima l'associazione in base ai membri, in conformità con le impostazioni Min Match % e Min Match Member.
- Se l'associazione in base ai membri non riesce, il software tenterà l'associazione in base al nome (se l'opzione Use Name Matching è abilitata).
- Se uno di questi processi di associazione riesce, si passerà alla finestra di dialogo Engineering Change Order.
-
Se entrambe le tecniche di associazione non riescono (o se l'opzione Use Name Matching è impostata su
Never), si aprirà la finestra di dialogo Match Manually.
- Facendo clic su No nella finestra di dialogo Match Manually, si salterà il processo di associazione manuale e si passerà direttamente alla finestra di dialogo Engineering Change Order. Poiché non è stato effettuato alcun tentativo di associare gli oggetti non associati, il software presume che gli oggetti di riferimento e quelli di destinazione non siano correlati, quindi verranno generati degli ECO che rimuovono i Unmatched Reference Objects dalla scheda e aggiungono i Unmatched Target Objects come nuovi oggetti.
- Se fai clic su Yes nella finestra di dialogo per eseguire l'associazione manuale, si aprirà la finestra di dialogo Match, come mostrato di seguito (il titolo della finestra cambierà in base al tipo di oggetto non associato).
La finestra di dialogo Match viene utilizzata per associare manualmente gli oggetti che sai essere corrispondenti. In caso di dubbi, lascia vuoto il lato destro e fai clic su Continue.
Opzioni e controlli della finestra di dialogo di associazione
-
Unmatched <Object>
- Unmatched Reference Objects - elenca gli oggetti non associati. Utilizza i controlli di espansione/compressione per aprire/chiudere l'elenco.
- Unmatched Target Objects - elenca gli oggetti di destinazione. Utilizza i controlli di espansione/compressione per aprire/chiudere l'elenco.
-
- fai clic per associare gli oggetti di riferimento e di destinazione selezionati e spostare gli oggetti selezionati dall'area Unmatched all'area Matched Pairs.
-
- fai clic per spostare gli oggetti selezionati dall'area Matched Pairs all'area Unmatched. Questa azione annullerà l'associazione degli oggetti spostati.
-
- fai clic per spostare tutti gli oggetti dall'area Matched Pairs all'area Unmatched. Questa azione annullerà l'associazione degli oggetti spostati.
- Matched Pairs - elenca i Reference Object e i Target Object che ora sono associati.
- Continue - fai clic per accettare gli aggiornamenti delle associazioni e aprire la finestra di dialogo Engineering Change Order.
- In questa finestra di dialogo, seleziona gli oggetti da associare in Unmatched Reference Objects e Unmatched Target Objects, quindi trasferiscili nella sezione Matched Pairs della finestra di dialogo. Per questi oggetti, il software genererà un ECO per aggiornare i nomi in modo che corrispondano, ed ECO per rimuovere/aggiungere membri, affinché anche questi corrispondano.
- In caso di dubbi, non è necessario associare manualmente gli oggetti. Per tutti gli oggetti non associati, il software presume che gli oggetti di riferimento e quelli di destinazione non siano correlati, quindi genererà degli ECO che rimuovono i Unmatched Reference Objects dalla scheda e aggiungono i Unmatched Target Objects come nuovi oggetti.
- Dopo aver associato gli oggetti di cui conosci la corrispondenza, fai clic su Continue per aprire la finestra di dialogo Engineering Change Order.
- Se fai clic su Cancel, il processo di aggiornamento termina.
Associazione delle regole di progettazione
Anche le regole di progettazione definite nello schematico devono essere collegate alla regola corrispondente sul PCB. Senza un meccanismo di collegamento, non sarebbe possibile aggiornare la regola nello schematico e trasferire tali modifiche al PCB. Gli UID vengono utilizzati per collegare la regola di progettazione dello schematico alla regola di progettazione del PCB.
L'UID viene assegnato automaticamente nel set di parametri che contiene la definizione della regola nello schematico e trasferito al PCB durante la sincronizzazione del progetto.
Le regole di progettazione utilizzano un UID per associare la definizione della regola di progettazione nello schematico alla regola di progettazione del PCB.
In genere, non è necessario gestire manualmente la corrispondenza delle regole, a meno che non sia stato modificato manualmente l'UID nella finestra di dialogo PCB Rules and Constraints dell'editor PCB. Se gli UID non corrispondono, il software aggiungerà al PCB una nuova regola per ogni regola dello schema che non ha una regola corrispondente nel PCB e rimuoverà qualsiasi regola di progettazione del PCB che non ha una regola di progettazione corrispondente nello schema.
