Webビューアー
Altium 365のWeb Viewerインターフェースでは、標準的なWebブラウザーを通じてPCBプロジェクトのドキュメントに幅広くアクセスできます。単なるWebベースのビューアーにとどまらず、高度なブラウザー技術により、プロジェクト構造の参照、設計ドキュメントの操作、設計内の要素に関する情報の抽出、コメントを付ける領域やオブジェクトのハイライト表示が可能です。
ドキュメントの表示時には、Web形式であっても回路図やPCBの表示品質が損なわれることはありません。また、パンやズームに加え、設計全体にわたるコンポーネントやネットの検索、クロスプローブ、選択、詳細確認も行えます。
独立したブラウザーベースの表示プラットフォームであるWeb Viewerインターフェースでは、設計編集環境でプロジェクトを開かなくても、設計ドキュメントに読み取り専用でアクセスし、インタラクティブに操作できます。設計の「所有者」であるエンジニアなど、その設計に取り組んでいる他のユーザーが、Web Viewer内での操作の影響を受けることはありません。ただし、該当する場合は、関連するコメント通知が送信されます。
Web Viewerへのアクセス
Web Viewerインターフェースは、次の場合に使用されます。
-
特定のプロジェクトを管理する際に、詳細管理インターフェースから作業中の設計プロジェクトのソースを表示する場合。
-
製造ポータルから、リリース済み設計パッケージの設計スナップショットを表示する場合。
-
共有されたライブ設計の設計データを表示する場合。
-
共有されたデータスナップショットのデータを表示する場合。
-
製造パッケージビューアーから、製造パッケージの基板製造データと実装データを表示する場合。
以下の折りたたみセクションでは、それぞれの場合のアクセス方法と、各場合におけるWeb Viewerインターフェースの表示について詳しく説明します。
設計プロジェクトのソースの表示
この場合、Web Viewerインターフェースは、プロジェクトの詳細管理ページのDesignビューに表示されます。このページにアクセスするには、ワークスペースのブラウザーインターフェースのProjectsページで目的のプロジェクトを選択し、プロジェクト一覧の上にある
コントロールをクリックして、表示されるメニューからOpen 項目を選択します。または、一覧内の目的のプロジェクト項目を直接ダブルクリックします。ページは新しいブラウザータブで開きます。
ワークスペースのブラウザーインターフェースのProjectsページから、プロジェクトの詳細管理ページにアクセスします。Web Viewerインターフェースは、このページのDesignビューに表示されます。
リリースパッケージの設計スナップショットの表示
この場合、Web Viewerインターフェースは、現在確認している管理対象プロジェクトの選択したリリースパッケージについて、製造ポータルのDesign Snapshotビューに表示されます。ポータルにアクセスするには、次の手順を実行します。
- 目的のプロジェクトの詳細管理ページ(プロジェクトをダブルクリックしてアクセス)で、Releasesビューに切り替えます。
-
リリースパッケージを開いて表示するには、対応する
ボタンをクリックしてリリースパッケージ全体を開きます。または、
ボタンをクリックし、表示する対象としてリリースパッケージ全体(All Release)または特定の実装(バリアント)を選択します。開いたプロジェクトリリースは、新しいManufacturing Portal ブラウザータブに表示されます。
- Manufacturing Portal内で、Design Snapshotビューに切り替えます。表示されているのはソース設計データの最新バージョンではなく、この特定のリリースパッケージを作成するために設計がリリースされた時点のスナップショットであることに注意してください。
Manufacturing PortalからWeb Viewerインターフェースにアクセスして、設計プロジェクトの特定のリリースパッケージに含まれる設計スナップショットを確認します。
製造パッケージ内の基板製造・実装データの表示
この場合、特定の製造パッケージを表示すると、Web Viewerインターフェースが製造パッケージビューアーのFabricationページとAssemblyページに表示されます。Manufacturing Package Viewerには、次の方法でアクセスできます。
-
パッケージの送信先の製造業者には、Altium 365からそのパッケージにアクセスするための招待メールが届きます。メール内の
ボタンをクリックすると、Altium 365 Sign Inページが表示されます(プラットフォームまたはAltiumLiveアカウントにすでにサインインしている場合を除きます)。サインインすると、共有パッケージが読み込まれた状態でManufacturing Package Viewerが表示されます。
-
送信された製造パッケージは、Altium 365プラットフォームインターフェースのShared with Me ページから利用できます。製造パッケージは、タイル内の
アイコンで示されます。Manufacturing Package Viewerでパッケージを開くには、目的のパッケージを選択し、タイル内の
ボタンをクリックして、表示されるメニューからOpen コマンドを選択します。または、タイルを直接ダブルクリックするか、パッケージ名をクリックします。
-
特定のプロジェクト用に作成して送信した製造パッケージは、そのプロジェクトの詳細管理ページにアクセスすると、Releases ビューのSent 領域に一覧表示されます。上記を参照してください。Manufacturing Package Viewerでパッケージを開くには、目的のパッケージを選択し、タイル内の
ボタンをクリックして、表示されるメニューからOpen コマンドを選択します。
Webビューアーの機能
Web Viewerインターフェースには、設計データに詳細にアクセスできるさまざまな統合機能が用意されています。コメントシステムなどの機能は、プロジェクトの詳細管理ページのDesignビューから使用すると、Altium Designerとリアルタイムで直接通信します。以降のセクションでは、利用可能な各種の機能について説明します。
データビュー
Web Viewerインターフェースでは、情報が個別のデータビューに表示されます。表示されるビューは、表示するデータの種類によって異なります。
- 設計ソースを表示する場合は、4つのデータビューに、ソース回路図、基板の2D表示、基板の3D表示、部品表がそれぞれ表示されます。レイヤースタックビューにもアクセスできます。
- 製造パッケージ内のデータを表示する場合は、3つのデータビューが表示されます。Fabricationページでは、GerberビューアーであるFabrication データビューを利用できます。Assembly ページには、基板のPCB データビューと3Dデータビューが用意されています。
- 共有されたGerberデータのスナップショットを表示する場合は、単一のデータビュー(Gerber)が表示されます。このGerberビューは、製造パッケージを表示する際に基板製造ページのFabrication データビューで表示されるものと同じです。
SCH
このビューには、設計のソース回路図シートが表示されます。
SCH データビューには、現在選択されている回路図ソースドキュメントが表示されます。
マルチチャネル設計のサポート
Webビューアーは、マルチチャネル設計の表示に対応しています。この表示モードでは、物理チャネルごとに個別の回路図ドキュメントが表示されます。物理シート名(Altium Designerで表示した際の、その回路図ドキュメントのコンパイル済みタブの名前)が論理ドキュメント名の末尾に付加され、複数のチャネルが論理ドキュメント名の下に物理シートとして表示されます。これは物理回路図シートのPDFドキュメントを生成した場合に似ていますが、Altium 365のWebビューアーによる高度なインタラクティブ操作が可能です。
Altium Designerでのマルチチャネル設計の操作については、マルチチャネル設計の作成を参照してください。
表示操作
メイン表示領域の操作方法は次のとおりです。
-
マウスホイールを前後に回すと、ズームイン/ズームアウトします。
-
クリックしたまま(または右クリックしたまま)ドラッグすると、ドキュメントをパンできます。
-
クリックすると選択できます。
-
Rを押すと、ドキュメントの表示がリセットされます(ドキュメント全体が表示されます)。
PCB
このビューでは、PCBを2Dで表示します。
表示操作
メイン表示ウィンドウの操作方法は次のとおりです。
- マウスホイールを前後に回すと、ズームイン/ズームアウトします。
- クリックしたまま(または右クリックしたまま)ドラッグすると、ドキュメントをパンできます。
- クリックすると選択できます。繰り返しクリックすると、同じ位置にあるオブジェクトを順番に切り替えたり、親ネットを選択したりできます。
- テンキーの+または–を押すと、単一レイヤーモードでレイヤーリストを順方向または逆方向に切り替えられます。
- Rを押すと、ドキュメントの表示がリセットされます(ドキュメント全体が表示されます)。
- 3を押すと、基板の3Dビューが開きます。
レイヤーの表示制御
PCB データビューの表示とレイヤーの表示/非表示は、Layers/Objects ペインのLayerモードで制御します。このペインにアクセスするには、ビューの左上にある
コントロールをクリックし、Layers表示モードを選択します。Stackup Viewコマンドをクリックすると、現在のPCBのレイヤースタックビューが開きます。
Layer/Objectsペイン – レイヤーとオブジェクトの表示/非表示を制御する中心的な場所です。
Layers/Objectsペインに表示される各レイヤー項目には、描画順序を最前面に設定するチェックボックスがあります。チェックを入れると、そのレイヤーは最後に描画され、他のPCBレイヤーのグラフィックスに重ねて表示されます。配置したコメントは、現在選択されている(チェックが入っている)レイヤーに関連付けられます。その後、コメントペインでそのコメントを選択すると、同じレイヤー順序が復元されます。
上部の
コントロールを使用してレイヤー順序の表示をリセットすると、描画順序はデフォルトの状態(Topレイヤー)に戻ります。
ペイン内のレイヤー項目は、次のカテゴリに分類されています。
- Copper – 使用されているすべての信号レイヤーと内部プレーンレイヤー。
- Solder Mask – Top Solder、Bottom Solder。
- Paste Mask – Top Paste、Bottom Paste。
- Silkscreen – Top Overlay、Bottom Overlay。
- Mechanical – 使用されているすべてのメカニカルレイヤー。
- Other – Mutli-Layer、Drill Guide、Keep-Out Layer、Drill Drawingなど。
ペイン上部のTopおよびBottom view コントロールを使用すると、基板を上面から見る表示と下面から見る表示をすばやく切り替えられます。必要に応じて、レイヤー項目のチェックボックスで最前面の描画順序を変更できます。
LayersObjectsペインでレイヤーの表示/非表示を操作する際は、次の点に留意してください。
-
現在表示されているレイヤーは、ペイン内で名前が通常の明るさで表示されます(例:
)。現在非表示のレイヤーは、名前が薄く表示され(例:
)、右端に
アイコンが表示されます。
-
現在表示されているレイヤーを非表示にするには、その項目をクリックするか、項目にカーソルを合わせて右端の
アイコンをクリックします。逆に、現在非表示のレイヤーを表示するには、その項目をクリックするか、項目にカーソルを合わせて右端の
アイコンをクリックします。
-
レイヤーのグループ全体(たとえば
Solder Mask)を非表示にするには、グループ項目にカーソルを合わせて右端の
アイコンをクリックします。逆に、グループ内のすべてのレイヤーが非表示の場合は、グループ項目にカーソルを合わせて右端の
アイコンをクリックすると表示できます。グループ内に表示中と非表示のレイヤーが混在する場合は、グループに
アイコンが表示されます。クリックすると表示中のレイヤーがすべて非表示になり、もう一度クリックすると(この時点では
として表示)、すべてのレイヤーが表示されます。
-
「単一レイヤーモード」で素早く表示するには、対象のレイヤーにカーソルを合わせ、
コントロールをクリックします。他のすべてのレイヤーが非表示になります。
コントロールをもう一度クリックすると、「単一レイヤーモード」が解除されます。
-
レイヤーの表示/非表示を、設計に最初にアクセスしたときの状態に戻すには、Layers/Objectsペインの右上にある
コントロールをクリックします。
オブジェクトの表示制御
PCBデータビューにおける基板オブジェクトの表示/非表示は、Layers/Objectsペインで制御します。オブジェクトの表示オプションにアクセスするには、ビューの左上にある
コントロールをクリックし、続いてObjects表示オプションをクリックします。
Objects表示モードのLayers/Objectsペイン。
リスト内のオブジェクトタイプ(または対応する
アイコン)を選択すると、表示/非表示が切り替わります。複数のオブジェクトタイプを選択できます。
コントロールを使用すると、オブジェクトの表示をデフォルトの状態(すべてのオブジェクトを表示)にリセットできます。
特定のオブジェクトタイプだけを表示するには、その項目に対応するOnlyオプションを使用します。そのオブジェクトタイプだけが表示され、他のすべてのオブジェクトタイプは自動的に非表示になります。
コントロールを使用すると、オブジェクトの表示を基板のデフォルトの表示状態にリセットできます。
複数のPCBドキュメントの表示
PCBパネル、基板レイアウトの試作版、別のPCB設計(および対応する回路図ドキュメント)など、追加のPCBドキュメントを含むプロジェクトでは、Web Viewerでこれらの「プライマリ以外」のPCBドキュメントを表示し、クロスプローブできます。
このようなPCBドキュメントを開いて表示すると、Web Viewerの関連機能は、可能な限り選択した基板レイアウトに対して動作します。それ以外の場合は、プライマリPCB(プロジェクト構造で最初に見つかったPCB)がデフォルトの対象となります。配置したコメントはその基板レイアウトに関連付けられ、ネットナビゲーション、レイヤースタックアップビュー、測定、Information ペインのデータなどの機能は、開いている追加のPCBドキュメントに適用されます。
デフォルトでは、最初(順序が最上位)のPCBが表示されます。別のPCBドキュメントを選択すると、その基板設計と関連するWeb Viewerの機能にアクセスできます。
PCB測定、配置したコメント、オブジェクト検索など、Web Viewerの各機能は、追加のPCBドキュメントでも使用できます。選択した検索対象のオブジェクトやコメントが別のPCBドキュメントに属する場合は、以下に示すように、そのPCBドキュメントでコメントまたはオブジェクトが自動的に選択され、ハイライト表示されます。
Web Viewerの各機能は、それぞれのPCBドキュメントに対して使用でき、各ドキュメントに関連付けられます。
追加のPCBドキュメントでも、可能な場合はメインの設計ビュー間でクロスプローブできます。
-
1つの回路図ドキュメントが、物理レイアウトの異なる2つのPCBなどに関連している場合、その回路図からのクロスプローブは、プロジェクトのプライマリ(最初の)PCBドキュメントを対象とします。
-
上記の場合、どちらのPCBからクロスプローブしても、共通の回路図ドキュメントが開きます。
-
追加のPCBに専用の回路図ドキュメントが関連付けられている場合は、この2つのドキュメント間で直接クロスプローブが行われます。
-
BOMデータ、レイヤースタックアップ、およびシミュレーションのアップロードは、プロジェクト設計全体に関連します。
測定
PCB データビューを使用して基板を2Dで表示しているときは、測定を行えます。測定するには、
ボタンをクリックします。Measurements ペインが開き、カーソルが十字に変わり、測定モードになります。次の3つの測定モードが用意されています。
- Free – スナップによるガイドを使用せず、データビュー内の任意の2点間を自由に測定します。
- Point to Point – オブジェクト上にカーソルを移動したときのスナップガイドを使用して、データビュー内の任意の2点間を測定します。カーソルは次のように変化します。
-
– パッドまたはビアの中心。
-
– プリミティブオブジェクトの頂点。
-
– トラックセグメントの中点。
-
– ビュー内の任意の点。
- Object to Object – データビュー内で選択した任意の2つのオブジェクト間を測定します。対応するオブジェクトはパッド、ビア、トラック、フィル、リージョンで、カーソルを合わせると選択候補としてハイライト表示されます。
測定は次の手順で行います。
- Free モードまたは Point to Point モードでは、測定を開始する位置(ポイント1)にカーソルを合わせてクリックします。その点に小さな白い十字のマークが付きます。Object to Object モードでは、最初のオブジェクト(オブジェクト1)を選択します。
- Free モードまたは Point to Point モードでは、目的の終点(ポイント2)にカーソルを移動し、もう一度クリックします。カーソルを移動すると、ガイドとして測定線が表示され、現在のXY距離(ポイント1から線の終点まで)が示されます。Object to Object モードでは、2つ目のオブジェクト(オブジェクト2)を選択します。
- Measurements ペインには、測定したXY距離、X(水平方向)距離、Y(垂直方向)距離が表示されます。Object to Object モードでは、選択した2つのオブジェクト間の最短距離がXY距離になります。
-
続けて他の点やオブジェクト間の距離を測定するか、
ボタンをもう一度クリック(または Esc)して測定モードを終了します。
3D
このビューではPCBを3Dで表示します。
表示操作
メイン表示ウィンドウの操作方法は次のとおりです。
-
マウスホイールを前後に回すと、拡大/縮小します。
-
クリックしたままドラッグすると、基板が回転します。
-
右クリックしたままドラッグすると、ドキュメントをパンします。
-
クリックすると選択します。
-
R を押すと、ドキュメントの表示がリセットされます(ドキュメント全体が表示されます)。
-
2 を押すと、2D基板ビュー(PCB タブ)が開きます。
Draftsman
このビューには、設計内で利用可能なDraftsmanドキュメントが表示されます。左側のナビゲーションツリーでDraftsmanドキュメント(*.PCBDwf)を選択して開くこともできます。他の設計ビューと同様に、Draftsmanビューでもドキュメントへのコメント追加がサポートされています。
Draftsmanデータビューには、現在選択されているDraftsmanソースドキュメントのすべてのページが表示されます。
表示操作
メイン表示領域では、次の操作が可能です。
- マウスホイールを前後に回すと、拡大/縮小できます。
- クリックしたまま(または右クリックしたまま)ドラッグすると、ドキュメントをパンできます。
- Rを押すと、ドキュメントの表示がリセットされ、ドキュメント全体が表示されます。
BOM
このビューには、設計の部品表が表示されます。部品表はソース回路図ドキュメントからその場で生成されます。プロジェクトにActiveBOMドキュメント(*.BomDoc)が含まれている場合は、そのドキュメントから生成されます。このビューは対話的な操作と設定のカスタマイズが可能で、Altiumのサプライチェーンリソースから取得した最新の部品データが組み込まれています。
BOMには、基板1枚の実装に必要なすべての部品が反映されます。また、現在のデータの妥当性も継続的にチェックされ、その結果がステータスアイコンで示されます。たとえば、
問題なし/OK、
部品の値の重複、
生産終了部品または在庫不足などです。価格情報はAltiumの部品プロバイダーサービスから取得されます。このサービスでは、部品やサプライヤーのデータへのWebリンクも提供されます。
このビューを使用する際のポイントは次のとおりです。
-
部品のメーカー型番の項目をクリックすると、対応する実際のメーカー部品へのWebリンクにアクセスできます。
-
部品のサプライヤー型番の項目をクリックすると、サプライヤーの部品情報への直接のWebリンクにアクセスできます。
-
デジグネーターをクリックすると、他のデータビュー内の該当部品にクロスプローブできます。
-
列ヘッダーをクリックして昇順(
)と降順(
)を切り替えることで、その列を基準に項目を並べ替えられます。
-
ヘッダー間の境界をドラッグすると、列幅を変更できます。
-
列設定メニュー(
)を使用して、ビューに表示する列を指定できます。選択肢には、BOM部品に存在するすべてのパラメーターが含まれます。
-
BOMデータビューの行項目に追加されたコメントは、行頭のアイコンで示されます。このアイコンを選択すると、関連するコメントがコメントウィンドウに表示されます。なお、BOMのコメントはAltium Designerでは利用できません。
-
一覧の上にあるSearch フィールド(
)を使用すると、目的の部品をすばやく検索できます。
プロジェクトにActiveBOMドキュメントが含まれている場合、BOMビューには、カスタム列、列のエイリアス、定義済みの検証チェック、行番号など、そのドキュメントの設定が適用されます。
ActiveBOMドキュメントの作成と設定の詳細は、ActiveBOMによるBOM管理を参照してください。
プロジェクトに含まれるActiveBOMドキュメントの設定は、WebのBOMビューに適用されます。
SiliconExpertによる拡張データ
お客様の会社にSiliconExpertアカウントがあり、Altium 365のSiliconExpert連携機能が有効になっている場合、SiliconExpertから取得した部品のパラメトリックデータを、WorkspaceのBOMドキュメントビュー、部品のPart Choiceの選択、およびBOM Portalで利用できます。SiliconExpertの高度なメーカー部品リスク評価データは、必要に応じてBOMドキュメントに取り込まれます。このデータは、部品の将来的な生産終了の可能性、規格への適合性、調達リスクなどを評価するパラメーターとして提供されます。
SiliconExpertのパラメトリックBOMデータは、対応する
アイコンで示される専用のパラメーター列に含まれます。このアイコンは、列設定ドロップダウンメニューにも目印として表示されます。
すべてのSiliconExpertデータを有効にしたWorkspaceのBOMビュー。デフォルトで有効になっているのは、Lifecycle、YTEOL、RoHSのパラメーターのみです。
この拡張された調達データを最大限に活用するには、要件に照らしてパラメーター値の重要性を評価します。詳細は、SiliconExpertから取得できるパラメーターを参照してください。SiliconExpert連携はAltium Designerでも利用できます。Altium DesignerでのSiliconExpertからの部品データ取得を参照してください。
Z2Dataによる拡張データ
上記と同様に、会社でAltium 365のZ2Data連携が有効になっており、WorkspaceのAdminページでアクティブ化されている場合(Z2Dataアプリケーションの設定を参照)、Z2Dataの拡張された部品およびサプライチェーンのパラメトリックデータをWorkspaceで利用できます。
アイコンで示されるZ2Dataパラメーターは、Column Settingsドロップダウンメニュー(
)から有効にして、設計のBOMに含めることができます。有効にした(チェックを入れた)パラメーターはBOMビューに列として追加され、BOMの各行に対応するZ2Dataパラメーターが表示されます。表示例を参照してください。
マルチボード設計ビュー
このビューには、マルチボードプロジェクトのドキュメント用に設定された回路図ビューと3Dビューが表示されます。上位レベルのマルチボード回路図(MBS)ドキュメントとマルチボードアセンブリ(MBA)ドキュメントは、マルチボードの「子」プロジェクト間の電気的および物理的な接続情報を表すデータを提供します。これらの子プロジェクトは、全体としてマルチボードプロジェクトを構成するサブプロジェクトです。
マルチボード設計データビューは、Workspaceのメインのプロジェクトビューからマルチボードプロジェクトを開くと表示されます。回路図(MBS)、基板アセンブリ(MBA)、集約されたBOMビューをタブで切り替えることができ、相互接続された子プロジェクトをマルチボードの視点から確認できます。ナビゲーションツリーでChild Projectsオプションを選択すると、マルチボードプロジェクトの構成(サブ)プロジェクトを表示してアクセスできます。
MBS情報ペイン
MBS回路図内のモジュール、接続、またはエントリポイントをクリックすると、右側のInformationペインに詳細が表示されます。ネットレベルまでのすべての接続データが含まれます。
アイコンをクリックしてComments and Tasksペインを開くと、モジュール、エントリポイント、接続、または空白領域にコメントを配置できます。詳しくは、以下のコメントのセクションを参照してください。
MBAオブジェクトペイン
MBAビューのObjectsペイン(
)にアクセスすると、マルチボードアセンブリビューに表示する基板モジュールと3Dデータオブジェクトを指定できます。各オブジェクト項目に対応する
アイコンで表示と非表示を切り替え、ペイン上部の
アイコンですべてのオブジェクトを表示した状態にビューをリセットできます。
ハーネス設計ビュー
このビューには、ハーネス設計プロジェクトのドキュメントの基本となる配線ビューとレイアウトビューが表示されます。専用のHarness Wiring Diagram(*.WirDoc)ドキュメントとHarness Layout Drawing(*.LdrDoc)ドキュメントには、コネクタ間のワイヤ/ケーブルと、そのハーネスの物理的な構造を表すデータが含まれます。ハーネスプロジェクトには、補足情報を記載するDraftsmanドキュメントや、必要なハーネス部品の詳細を記載するActiveBOMドキュメントを含めることもできます。また、ハーネスプロジェクトをマルチボードプロジェクトと統合して、既存のハーネスタイプの接続を表現することもできます。
ハーネス設計の作成について詳しくは、Altium Designerでのハーネス設計を参照してください。
ハーネス設計プロジェクトは、Workspaceのプロジェクトページから開きます。このビューには、含まれるドキュメントタイプ(配線、レイアウト、Draftsman、BOM)ごとに選択可能なタブがあり、メインの配線/レイアウトビューで選択したオブジェクトの詳細が右側のInformationペインに表示されます。以下の折りたたみ可能なセクションを参照してください。
製造ビュー
このビューには、以下の場所でガーバーデータと製造データの両方を確認できるガーバービューアーが表示されます。
-
共有されたガーバーデータのスナップショット内。
-
リリース済みのWorkspaceプロジェクト内(ファイルセクションの
FAB»Gerber領域)。
閲覧操作
メイン表示ウィンドウでの閲覧操作は次のとおりです。
-
マウスホイールを前後に回して拡大/縮小します。
-
クリックしたまま(または右クリックしたまま)ドラッグすると、ドキュメントをパンできます。
-
シングルレイヤーモードで、テンキーの+または–を押すと、レイヤー一覧を順方向または逆方向に切り替えられます。
-
Rを押すと、ドキュメントの表示がリセットされます(ドキュメント全体が表示されます)。
レイヤーの表示制御
Gerber/Fabrication データビューの表示とレイヤーの表示/非表示は、Layers ペインで制御します。ビューの左上にある
コントロールをクリックすると、このペインにアクセスできます。
ガーバーレイヤーは、次のカテゴリに分類されます。
- Copper – 使用されているすべての信号レイヤーと内部プレーンレイヤー。
- Solder Mask – Top Solder、Bottom Solder。
- Silkscreen – Top Overlay、Bottom Overlay。
- Paste – Top Paste、Bottom Paste。
- Other Layers – Top Pad Master、Bottom Pad Master、NC Drill(*.txt形式)、Mechanical xxを含みます。
ペイン上部の Top View コントロールと Bottom View コントロールを使用すると、それぞれ上面または下面のガーバーデータの表示にすばやく切り替えられます。どちらの場合も、内層銅箔層、メカニカルレイヤー、およびNCドリルレイヤーは無効になります。
Layers/Objects ペインでのレイヤーの表示/非表示の操作については、以下の点に留意してください。
-
現在表示されているレイヤーは、ペイン内で名前が通常の明るさで表示されます(例:
)。現在非表示のレイヤーは、名前が薄く表示され(例:
)、右端に
アイコンが表示されます。
-
現在表示されているレイヤーを非表示にするには、その項目をクリックするか、項目にカーソルを合わせて右端の
アイコンをクリックします。逆に、現在非表示のレイヤーを表示するには、その項目をクリックするか、項目にカーソルを合わせて右端の
アイコンをクリックします。
-
レイヤーのグループ全体(例:
Solder Mask)を非表示にするには、グループの項目にカーソルを合わせて右端の
アイコンをクリックします。逆に、グループ内のすべてのレイヤーが現在非表示の場合は、グループの項目にカーソルを合わせて右端の
アイコンをクリックすると表示できます。グループ内に表示と非表示のレイヤーが混在している場合、そのグループには
アイコンが表示されます。クリックすると、表示されている残りのレイヤーがすべて非表示になります。もう一度クリックすると(この時点では
と表示)、すべてのレイヤーが表示されます。
-
「単一レイヤーモード」ですばやく表示するには、対象のレイヤーにカーソルを合わせて
コントロールをクリックします。他のすべてのレイヤーが非表示になります。
コントロールをもう一度クリックすると、「単一レイヤーモード」が終了します。
-
レイヤーの表示状態を、ガーバーデータに最初にアクセスしたときの状態に戻すには、 Layers/Objects ペインの右上にある
コントロールをクリックします。
測定の実行
Gerber/Fabrication データビューでガーバーデータを表示しているときは、測定を行うことができます。測定するには、
ボタンをクリックします。Measurements ペインが開き、カーソルが十字に変わって測定モードになります。測定は次の手順で行います。
-
測定を開始する位置(点1)にカーソルを合わせてクリックします。その点に小さな白い十字マークが付きます。
-
目的の終点(点2)にカーソルを移動し、もう一度クリックします。カーソルを移動すると、補助用の測定線が表示され、現在のXY距離(点1から線の終端まで)が示されます。
- Measurements ペインには、測定したXY距離、X方向(水平方向)の距離、およびY方向(垂直方向)の距離が表示されます。
-
続けて他の点の間の距離を測定するか、
ボタンをもう一度クリックして(または Esc)、測定モードを終了します。
ガーバー比較の実行
共有されたガーバーファイルパッケージを表示しているときは、現在のデータと別のガーバーデータパッケージのデータを比較できます。一般的には、連続するプロジェクトリリースから生成された共有ガーバーデータ間や、設計の主要な反復段階間で比較を行います。
比較処理を開始するには、ビューの
メニューから Compare Geber オプションを選択し、続いて表示される Compare Gerber ウィンドウで比較対象の別のガーバーデータセットを選択します。ウィンドウにガーバーパッケージをドロップするか、適切なファイルを参照して選択し、アップロードしてください。比較処理が完了するとガーバー比較ビューが開き、2つのガーバーデータセット間のグラフィックとネットの両方の変更点を詳しく確認できます。
詳細については、関連する ガーバー設計データの比較 または スタンドアロンのガーバー比較ビューアーを参照してください。
レイヤースタックビュー
現在の設計の PCBレイヤースタック(基板の物理的な層構成)をグラフィカルに表したものを、Web Viewerのさまざまな場所から表示できます。レイヤースタックアップビューには、基板の内部構造とともに、レイヤーの種類、材料、寸法などの関連データが表示されます。
Altium Designerでの基板レイヤースタックの操作については、レイヤースタックの定義を参照してください。
レイヤースタックビューを使用すると、関係者は主要な製造情報をビューアーですぐに確認できます。Draftsmanのレイヤースタックドキュメントを作成してリリースしたり、リリース済みの ガーバー出力ファイルから情報を抽出したりする必要はありません。このビューには、プロジェクト設計ビュー、設計リリースのスナップショット、送信された製造パッケージなど、設計ソースファイルが表示される場所からアクセスできます。
レイヤースタックビューを開くには、プロジェクト設計ビューアーの 基板情報ペインから Stackup View コマンドを選択するか、PCBの表示中に レイヤーメニューから選択します。プロジェクトリリースの 設計スナップショットを表示している場合も、同じ方法でレイヤースタックビューにアクセスできます。
Web Viewerで利用できるほかのビューと同様に、レイヤースタックビューにもコメントを追加できます。この場合、レイヤースタック要素のグラフィカルオブジェクトを選択し、コンテキストコメントウィンドウにコメントを入力することで、任意の要素にコメントを追加できます。ユーザーへのメンションや割り当ても指定できます。なお、レイヤースタックへのコメント追加では、フリーハンド描画と領域選択は使用できません。
コメントの追加について詳しくは、下記の「コメント」セクションを参照してください。
その他のドキュメント
元のAltium Designerプロジェクトに保存されているその他の種類のドキュメントファイルは、Workspaceの Design ビュー内の Other Documents にまとめて表示されます。これらの「非CAD」ファイル(通常は設計仕様書、参考資料、ステータスログなど)は、主要な設計ファイルとともにバージョン管理されます。選択したファイルは、対応する
アイコンまたはメインビュー領域からダウンロードできます。ただし、PDFファイルは例外で、WorkspaceのPDFビューアーで自動的に開かれます。
DRCおよびERCレポート
Web Viewerには、現在のプロジェクトのデザインルールチェック(DRC)およびエレクトリカルルールチェック(ERC)のレポートが表示されます。これらは、プロジェクトドキュメントに保存されたAltium Designerの設定に従って、元の設計データから生成されます。これにより、Altium Designerで設計を開くことなく、ルールのエラーや違反に簡単にアクセスして確認できます。
これらのレポートは、Project ナビゲーションペインの Design セクション内で、展開可能なリストとして利用できます。レポートは、Altium Designerでプロジェクトが更新され、サーバーに再保存された場合など、必要に応じて動的に生成されます。なお、DRCまたはERCレポートは、関連するエラーが検出された場合にのみ含まれます。
該当する場合、レビュー用のデザインルールチェックとエレクトリカルルールチェックの両方がサーバーによって生成されます。
DRCまたはERCレポートを展開すると、含まれるカテゴリが表示されます。各カテゴリを開くと、検出された個々の違反やエラー、警告などのサブリストが表示されます。Altium Designerで免除されたDRC違反には、その項目に
アイコンが表示されます。
個々の項目を選択すると、関連するドキュメントが開き、該当する領域にズーム/パンします。右側の Report 情報ペインには、ルール情報、クラスと種類、影響を受ける具体的なオブジェクトなど、選択した項目の詳細が表示されます。
共通のインターフェース要素
次のコントロール(すべて右上のコントロール群に配置されています)は、さまざまなデータビューで共通して使用できます。
-
– このコントロールを使用すると、右側のペインが Comments and Tasks モードに切り替わり、コメントの追加、管理、およびタスクとしてのユーザーへの割り当てができます。詳しくは、下記の「コメント」セクションを参照してください。
-
– このコントロールを使用すると、Search 機能にアクセスして、コンポーネントやネットを検索できます。この機能は、SCH、PCB 、3D データビューで利用できます(独自の検索機能を持つ BOM データビュー、および Gerber/Fabrication データビューでは利用できません)。検索機能の使用方法について詳しくは、検索を参照してください。
-
– このコントロールを使用すると、Info ペインにアクセスできます。
オブジェクトが選択されていない場合、このペインはさらに2つのサブビューに分かれます。
-
Controls – SCH、PCB、3D 、Gerber/Fabrication データビューの閲覧時に使用できるコントロールの一覧を表示します(一部のコントロールは特定のビューでのみ使用できます)。
-
Board Info – プロジェクトの設計に関する次の概要情報を表示します。Board Size(基板のX寸法とY寸法)、Layers(信号層とプレーン層の合計数、およびそれぞれの層数)、Components(すべての種類のコンポーネントを含む合計数、および基板の上面と下面の内訳)、Nets(合計)。このペインのサブビューは、Gerber/Fabrication データビューにはありません。
-
– このコントロールを使用すると、データをダウンロードできます。現在表示しているデータの種類に応じてダウンロードされる内容や、ダウンロード可能な内容について詳しくは、ダウンロードを参照してください。
-
– このコントロールを使用すると、全画面モードに切り替わります。
-
– 全画面モードでは、このコントロールを使用して全画面モードを終了します(または Esc を押します)。
バリアントのサポート
設計ソースを表示しているときに、プロジェクトにバリアントが定義されていれば、各種データビューで設計を表示する際にバリアントを切り替えることができます。左側のナビゲーションペインには、利用可能なバリアントの一覧が表示されます。デフォルトでは [No Variations] に設定され、基本設計が表示されます。
プロジェクトに定義されている利用可能なバリアントへのアクセス。
プロジェクトに定義されているすべてのバリアントの一覧から、バリアントを選択します。現在のデータビューが更新され、そのバリアントの内容が反映されます。これには、未実装コンポーネントに対して有効になっている表示オプションも含まれます(SCH および PCB データビュー)。3D および BOM データビューでは、コンポーネントが実装されるかどうかに応じて、そのコンポーネントが表示/一覧表示されるかどうかが決まります。
選択
設計ソースの表示中は、SCH、PCB、3Dの各データビューから、次のように設計内のオブジェクトを選択できます。
- SCH データビューから(コンポーネントとネットの選択)– コンポーネントまたはワイヤ上にカーソルを合わせ、クリックして選択します。ハイライトとマスキングが適用され、選択したコンポーネントまたはネットのみが完全に表示されます。選択したコンポーネント/ネットの情報は、右側のペインに表示されます。
-
PCB データビューから(コンポーネント、パッド、ビア、配線セグメント、ネットの選択)– 対応する種類のオブジェクト上にカーソルを合わせ、クリックして選択します。マスキングが適用され、選択したオブジェクトのみが完全に表示されます。選択したオブジェクトの情報は、右側のペインに表示されます。
オブジェクトを繰り返しクリックすると、カーソル下のネットとオブジェクトが順番に選択されます。ダブルクリックすると、そのオブジェクトに関連するネットがすぐに選択されます。
- 3D データビューから(コンポーネント、パッド、ビアの選択)– コンポーネント、パッド、またはビア上にカーソルを合わせ、クリックして選択します。マスキングが適用され、選択したオブジェクトのみが完全に表示されます。選択したオブジェクトの情報は、右側のペインに表示されます。
ネットの選択
ProjectsペインのNetsセクションを展開すると、プロジェクトの設計内にあるネットの一覧にアクセスできます。リスト内の項目を選択すると、回路図、PCB、3Dの各ビューでそのネットの位置が示され、ハイライトされます。また、右側の情報ペインに詳細が表示されます。このペインには、そのネットが使用するレイヤーの一覧と、そのネットを含む回路図ドキュメントの選択可能な一覧が含まれます。
選択したネットを対応するすべてのビューで確認するには、上部のタブ、または右側のネット情報ペインにあるビュータブのオプションから、SCH、PCB、3Dを選択します。
クロスプローブ
設計ソースの表示中に、アクティブなデータビュー内で対応するオブジェクトを選択すると、他の1つ以上のデータビューでも、該当する場合はそのオブジェクトが選択されます。これにより、同じ選択対象をすばやくクロスプローブできます。クロスプローブは、右側のペインにあるコントロールからも実行できます。このペインは、メインの表示ウィンドウでオブジェクトが選択されているときに表示されます。
以下の折りたたみ可能なセクションでは、対応するクロスプローブの例をいくつか紹介します。
SCHデータビューからネットをクロスプローブ
SCH データビュー内の回路図ドキュメントで目的のネットを選択し、コントロール(PCB、3D)のいずれかをクリックして、対象のデータビュー内のそのネットをクロスプローブします。Informationペインの上部からも選択できます。可能な場合は、ビュー内でネットが選択されてズーム表示され、選択したネットだけが完全に見えるようにマスキングが適用されます。
PCBデータビューからパッド/ビア/トラックをクロスプローブ
PCB データビュー内の基板上で目的のパッド、ビア、またはトラックセグメントを選択し、3D コントロールをクリックして、3Dデータビュー内のそのパッド/ビア/トラックセグメントをクロスプローブします。可能な場合は、ビュー内でオブジェクトが選択されてズーム表示され、選択したオブジェクトだけが完全に見えるようにマスキングが適用されます。
ブラウザータブ間のクロスプローブ
ブラウザーのタブやウィンドウ間での動的なクロスプローブにも対応しています。同じ設計を2つ開いた状態(それぞれ別のブラウザータブに表示されます)で、ビューアーのInfoペインにあるCross Select Across Tabsオプションを有効にします(オブジェクトを選択すると利用できます)。これにより、2つのブラウザービュー間でリアルタイムにクロスプローブが連動します。
検索
Related information: 検索クエリリファレンスおよび高度な設計検索。
設計ソースを表示する際、Web Viewerインターフェースでは、クエリに基づく高度な検索機能を利用できます。単純な設計検索から、クエリ用語やフィルタリングロジックを使った非常に詳細な検索まで対応しています。検索機能には、ビューアー上部のSearchフィールドを選択するか、Ctrl+Kコマンドを使用してアクセスします。Recentの下には、コンテキストに応じた再利用可能な検索式が表示されます。
Web Viewerの検索には、利用可能な設計データと現在のクエリキーワードに基づいて候補を提示する、コンテキスト対応のユーザーインターフェースが用意されています。
検索フィールドを選択すると、ドロップダウンに選択可能なクエリキーワード(Terms)のリストが表示され、現在の設計に含まれるデータに基づいて、入力中に候補が動的に提示されます。特定のコンポーネントやネットを探すなどの単純な検索は、直接入力できます。
検索語では大文字と小文字は区別されず、キーワードの一部にワイルドカードを使用することもできます。たとえば、VCC*は「VCC」で始まるすべてのネットを検索します。
高度な検索用語を使用すると、特定の条件に基づく柔軟な検索が可能になります。入力中に検索ドロップダウンリストへ表示される、コンテキストに応じた候補が検索を支援します。コマンドは標準のfield:value構文に従います。設計項目は、オブジェクトまたは種類(例:Object:Port
、Type:IC
)、プロパティ(例:Value:1k
、Package:0402
)、特定のパラメーター(例:Tolerance:5%
、Manufacturer:Micron
)、接続関係(ConnectsTo:R12
、ConnectsTo:U8.OUT、またはConnectsTo:U8.4
)に基づいて検索し、ハイライト表示できます。
クエリ用語の使用をさらに柔軟にする機能として、組み合わせロジックと値の範囲指定があります。例として、フィルタリングロジック(例:Type:Resistor AND Package:0402
、ConnectsTo:u8 NOT net:GND
)、範囲条件(例:Value:[1k to 2k]
)、電源ネットの除外(ConnectsTo.NoPower:U8
)や、信号経路の接続ではなく物理的なネット経路の接続(ConnectsToDirect:U1.17
)などの接続ロジックが挙げられます。
ダウンロード
Web Viewerでは、どのデータビューからでもデータをダウンロードできます。ダウンロードするには、右上のコントロール群にある
コントロールをクリックします。現在表示している内容によって、動作は異なります。
-
Design Project Source or Shared Live Design – Downloadペインにアクセスします。
作業中(WIP)の設計プロジェクト(基本設計)のスナップショットを含むZipアーカイブをダウンロードできます。また、該当するOutput Jobファイルが存在する場合は、その設定情報を直接使用して、以下の派生出力を生成し、ダウンロードできます。
-
GerberファイルとNCドリルファイルを含むZipアーカイブ(基本設計についてのみ生成)。
-
Draftsmanで作成されたドキュメント全体のPDF(プロジェクト内にDraftsmanドキュメントが必要。基本設計についてのみ生成され、バリアントには対応しません)、または組立図のみのPDF(アクティブなバリアントについて生成)。
-
回路図ドキュメントのPDF(アクティブなバリアントについて生成)。
-
基板アセンブリの3D STEPファイル(
*.step)(アクティブなバリアントについて生成)。 -
CSV形式のBOM(アクティブなバリアントについて生成)。
ペイン上の項目にカーソルを合わせ、対応する
コントロールをクリックするとダウンロードできます。必要に応じて、まずデータが生成され、その後ダウンロードされます。事前に生成が必要な出力については、そのまま待つか、Download ペインを閉じることができます。データの準備ができるとメールが送信され、そのメールからダウンロードできます。
ペインのReleases 領域は、設計プロジェクトソースを表示している場合にのみ表示されます(Shared Live Designでは表示されません)。プロジェクトから生成されたすべてのリリースパッケージが一覧表示されます。項目をクリックすると、別のブラウザータブで開いて内容を確認できます。
- Shared Data Snapshot – スナップショットの作成元となったソースドキュメントを含む、単一のZipアーカイブをダウンロードします。
- Fabrication & Assembly Data in a Manufacturing Package – パッケージに含まれるデータセットごとのフォルダーを含む、単一のZipアーカイブをダウンロードします。
コメント
Web Viewer インターフェースでは、設計ドキュメントにコメントを付けることができます。コメントは、対応するデータビュー上の特定の位置、オブジェクト、または領域(該当する場合)に割り当てられる、ユーザーが追加するメモです。他のユーザーはコメントに返信できます。コメントは、共有データとは独立して Workspace に保存されるため、共有データ自体を変更することなく、ユーザー間のコラボレーションを促進します。コメントの投稿、返信、管理は、メイン表示領域内のコンテキストに応じたコメントウィンドウで直接行います。コメントは、右側に表示される Comments and Tasks ペインにも表示されます。このペインは、操作用インターフェースというよりも、全体の把握やナビゲーションのためのツールとして機能します。
管理対象プロジェクトの子回路図シート上に重ねて表示されたコメントの例。 Comments and Tasks ペインにはすべてのコメントが表示され、メイン表示領域で開けるウィンドウでは、必要な場所でコンテキストに応じたコメントのやり取りができます。
コメント機能を使用できる場所
コメント機能は、以下の場所で使用できます。
- 特定のプロジェクトにアクセスした際の、詳細管理ページの Design ビュー。コメントは、SCH、PCB/3D、Draftsman、BOM の各データビューに追加できます。ここで追加したコメントは、共有ライブ設計の Design ビューと Altium Designer に自動的に表示され、その逆も同様です。BOM のコメントは、Altium Designer の ActiveBOM ドキュメントとは共有されません。
- 現在確認中の管理対象プロジェクトで選択したリリースパッケージに対する、製造ポータルの Design Snapshot ビュー。コメントは、SCH、PCB/3D、Draftsman、BOM の各データビューに追加できます。ここで追加したコメントは、プロジェクトの詳細管理ページの Design ビュー、共有ライブ設計の Design ビュー、および Altium Designer に自動的に表示されます。BOM のコメントは、Altium Designer の ActiveBOM ドキュメントとは共有されません。
- 共有ライブ設計を表示する際の、統合ビューアー内の回路図ドキュメント(SCH データビュー)、PCB(PCB および 3D データビュー)、Draftsman、または部品表(BOM データビュー)。ここで追加したコメントは、プロジェクトの詳細管理ページの Design ビューと Altium Designer に自動的に表示され、その逆も同様です。BOM のコメントは、Altium Designer の ActiveBOM ドキュメントとは共有されません。
- 共有設計スナップショットを表示する際の、統合ビューアー内の回路図ドキュメント(SCH データビュー)および PCB(PCB および 3D データビュー)。ビューアー内で追加したコメントは、Altium Designer とは共有されません。これらのコメントは、設計スナップショットの共有先であり、ビューアーを使用してその設計を確認している関係者にのみ表示されます。
- 開いている マルチボードプロジェクトで、最上位の 回路図(MBS)ドキュメントを表示する際の Design ビュー。
- 開いている ハーネスプロジェクトで、Wiring、Layout、Draftsman、BOM の各ドキュメントを表示する際の Design ビュー。
- Managed BOM ドキュメントを表示する際の BOM Portal。コメントとタスクペインから BOM の行エントリにコメントを追加し、必要に応じて タスクとしてユーザーに割り当てることができます。
- 共有ガーバーデータスナップショットを表示する際の、ガーバービューアー(Gerber データビュー)。ビューアー内で追加したコメントは、Altium Designer とは共有されません。これらのコメントは、データスナップショットの共有先であり、ビューアーを使用してそのガーバーデータを確認している関係者にのみ表示されます。
- 特定の製造パッケージ(設計プロジェクトの特定のリリースから作成されたもの)を表示する際の、製造パッケージビューアーの Fabrication(Fabrication データビュー)および Assembly(PCB および 3D データビュー)ページ。ビューアー内で追加したコメントは、Altium Designer とは共有されません。これらのコメントは、製造パッケージの共有先であり、ビューアーを使用してそのパッケージを確認している関係者にのみ表示されます。
- 開いているプロジェクトの Design ビュー、プロジェクトのリリースの Design Snapshot ビュー、および 送信済みの製造パッケージの Fabrication ビューから利用できる、レイヤースタックアップビュー。Web ビューアー内で追加したコメントは、製造パッケージの共有先であり、ビューアーを使用してそのパッケージを確認している関係者に表示されます。これらのコメントは、Altium Designer の レイヤースタックマネージャーとは共有されません。
コメントの配置
コメント配置モードには、次の 3 つの方法のいずれかで入ることができます。
-
ブラウザータブ上部のバナー領域にある
ボタンをクリックする。
- Alt+C キーボードショートカットを使用する。
-
ボタン(Comments and Tasks ペインの上部)をクリックする。
いずれの場合も、カーソルが十字形に変わり、コメント配置モードになります。次の手順に従って操作します。
-
必要に応じて、サポートされている次の 3 種類のコメントのいずれかを配置します。
-
Comment on a point – 任意の位置をクリックすると、その位置にコメントを添付(「ピン留め」)できます。BOMドキュメントでコメントする場合は、明細行を選択します。
-
Comment on object – オブジェクトをクリックすると、そのオブジェクトにコメントを添付(「ピン留め」)できます。SCHデータビューで対応するオブジェクトは、コンポーネント、ピン、ワイヤ、バス、ポートです。PCBデータビューで対応するオブジェクトは、コンポーネント、パッド、ビア、トラックセグメントです。3Dデータビューで対応するオブジェクトは、コンポーネント、パッド、ビアです。SCH およびPCB データビューでは、ビュー内でカーソルを移動すると、コメントを添付できるオブジェクトがハイライト表示されます。この種類のコメントは、Draftsmanビュー、またはGerberデータを表示している場合のGerber およびFabricationデータビューでは使用できません。
-
Comment on area – クリックしてドラッグすると、コメントを添付(「ピン留め」)する領域を指定できます。この種類のコメントは、3D データビューでは使用できません。
-
-
いずれの場合もコメントウィンドウが表示され、選択した位置、オブジェクト、または領域に関連付けてコメントを入力できます。入力欄にコメントを入力してください。コメント内では、1人以上のユーザーやグループをメンションできます。コメント欄に@文字を入力すると、Workspaceのメンバー一覧にすばやくアクセスできます。また、コメントをメンバーにassignedすることもできます。これらの追加機能の詳細については、「コンテキストコメントウィンドウの操作」セクションを参照してください。
-
コメントを入力し、メンションを追加して、必要に応じて割り当てを行ったら、下にある
ボタンをクリックします。コメントが確定され、コンテキストコメントウィンドウとComments and Tasksペインの両方に表示されます。メインの設計表示領域には、コメント固有の番号が付いたマーカーが表示されます。
以下の一連の画像では、回路図ドキュメントのコンポーネント(SCH データビュー内)にコメントを追加し、チームメンバーへのメンションを追加して、そのメンバーにタスクを割り当てる例を示しています(詳細は以下を参照)。
2Dモードで表示中にPCBに配置したコメントは、現在のレイヤービュー、つまりコメント配置時のレイヤーの表示設定とアクティブレイヤー設定に関連付けられます。その後、Comments and TasksペインまたはPCBビュー内のマーカーからコメントを選択すると、そのコメントのレイヤービュー設定が復元されます。
コンテキストコメントウィンドウの操作
コメントと、インターフェースのコンテキストコメントウィンドウの操作に関するポイントを以下に示します。
- コメントウィンドウは、Comments and Tasksペインとは独立して開くことができます。コメントマーカーをクリックして開いてください。
-
コメントウィンドウの左上にある
ボタンを使用すると、それぞれ前のコメントと次のコメントへ順番に切り替えられます。切り替えはコメントマーカーの番号順に行われます。前後のコメントに関連付けられた設計上の位置、オブジェクト、または領域がズームされて中央に表示され、そのコメントがコメントウィンドウに表示されます。
-
最初のコメントが作成された後は、コメントウィンドウを開くと返信を入力できる状態になります。入力欄にテキストを入力し、
ボタンをクリックして確定します。返信せずに終了するには、
ボタンをクリックします。
-
コメント内でユーザーやグループをメンションできます。@文字を入力すると、Workspaceチームの全メンバーを一覧表示するポップアップが開きます。また、「@」に続けて1文字以上入力すると、グループやユーザー(名前またはメールアドレスで検索)を検索できます。一致するグループ、チームメンバー、およびチーム外のユーザー(組織内のユーザー)の一覧が表示され、そこから選択できます。一覧の項目をクリックして追加するか、Up/Down Arrowキーを使用して選択し、Enter を押して追加します。
@<theirfullemail>を入力すると、Workspaceチーム外(および組織外)のユーザーをメンションすることもできます。そのユーザーが表示中の対象への共有アクセス権をすでに持っている場合、メンションされたことを知らせる通知メールが送信されます。アクセス権を持っていない場合は、Shareウィンドウが表示され、アクセス権を設定して対象を共有するか、アクセス権を付与しないかを選択できます。そのユーザーには、共有状況に関するメールが送信されます。
続いて表示される情報ウィンドウでは、対象者をWorkspaceのメンバーとして招待するリクエストを送信するオプションを選択できます。次のRequest Invitationウィンドウでメモや他の招待対象者を追加してから、Workspace管理者による処理のためにリクエストを送信します。詳細については、招待リクエストの処理を参照してください。関係するすべてのユーザー(あなた、プロジェクトの共有相手、Workspace管理者)に、共有権限(
)またはWorkspaceへのアクセスの変更に関する通知メールが送信されます。
-
メンションされたユーザー(Workspaceのチームメンバーのみ)にタスクを割り当てることができます。必要に応じてAssign a Task toオプションを有効にしてください。デフォルトでは、最初にメンションされたユーザーに割り当てられます。メンションがない場合は、自分自身(
Me)に割り当てられます。また、ドロップダウンメニューを使用して、タスクの割り当て先として別のWorkspaceメンバーを選択することもできます。割り当てられたユーザーは、Comments and Tasksペインのエントリに、関連するタスク参照とともにユーザープロフィールの画像または文字で表示されます。タスクの割り当ては、コメントの編集中に変更または解除できます。
コメントにタスクが関連付けられている場合、コメントウィンドウの上部には次の項目が表示されます。
-
コメントのタスクを割り当てられたメンバーを示すアイコン(画像または文字)。アイコンを選択すると、ドロップダウンリストから別のWorkspaceメンバーにタスクを再割り当てできます。
-
プロジェクトのIDまたは名前にタスク番号を付加した、英数字のタスク参照。参照をクリックすると、Workspace内のそのプロジェクトのタスクページにある該当タスクのエントリにクロスプローブします。
-
タスクの優先度アイコン(矢印または炎)。デフォルトは
Mediumで、WorkspaceのTasksページにあるタスクのエントリから変更できます。 -
タスクの現在の作業ステータス(
To Do、In Progress、Resolved)。対応するドロップダウンメニューから変更できます。
-
ウィンドウの
メニューにあるConvert to Taskオプションを使用して、既存のコメントにタスクを追加できます。新しいタスクは最初に自分に割り当てられますが、左上の担当者アバターから開くドロップダウンリストで別のWorkspaceメンバーのエントリを選択すると、割り当て先を変更できます。ドキュメントビュー内のマーカーは、単純なコメント参照番号からタスクIDに変わります。
-
新しいコメントの追加時や既存のコメントの編集時に、デザインビューにフリーハンドの描画を追加して、そのコメントに関連付けたり添付したりできます。これを行うには、コメントウィンドウの上にある
ボタンをクリックします。フリーハンド描画モードに入り、コメントウィンドウが一時的にフローティングコントロールバーに置き換わります。
ボタンをクリックすると、いつでも「コメント」モードに戻ることができます。フリーハンド描画モードでは、カーソルを配置してクリックし、ドラッグして必要な描画を行います。コントロールバーのボタンで線の色と太さを変更できます(PCBの2Dビューで特に便利です)。描き直す場合は、
をクリックするだけで描画を削除して最初からやり直せます。コントロールバーの右端にあるボタンを使用して、コメントを投稿(Post)またはキャンセル(X)できます。
-
コメントウィンドウには、Windowsクリップボードから画像ファイルやキャプチャしたスクリーンショットを貼り付けることもできます。コメント欄のテキストメモやユーザーのメンションの前後に、スクリーンショット(またはコピーした画像ファイル)を貼り付けられます。画像はコメントウィンドウの本文に表示され、クリックすると原寸大で表示できます。投稿したコメントのComment and Tasksペイン内のエントリには、関連するIncludes Imagesの注記が表示されます。
-
新しいコメントが投稿されると、元のビューのスクリーンショットが撮影され、そのコメントに添付されます。コメントウィンドウ内のOriginal Snapshotコントロールをクリックすると、このスクリーンショットにアクセスできます。スナップショットには、コメント作成時にビューに表示されていた内容がそのまま記録されます。ズームレベルやアクティブなレイヤー(PCB)が同じ状態で表示され、コメント投稿前にフリーハンドの描画を作成していた場合は、その描画も含まれます。
-
コメントの編集と削除は、コメントウィンドウからのみ、それぞれEdit コマンドとDelete コマンドを使用して行えます。これらのコマンドは、
コントロールに関連付けられたメニューから使用できます。なお、これらのコマンドは自分が作成したコメントに対してのみ使用でき、他のユーザーが作成したコメントを編集または削除することはできません。既存のコメントを編集する場合は、変更を加えてから
ボタンをクリックして確定します。変更を適用せずに終了するには、
ボタンをクリックします。
-
コントロールに関連付けられたメニューには、Copy Linkコマンドも含まれています。このコマンドを使用すると、コメントスレッドの作成者は、そのスレッドを表示するためのリンクを取得して共有できます。提供されたリンクを開いたユーザーにプロジェクトへのアクセス権がない場合(そのユーザーとまだ共有されていない場合)、アクセスをリクエストできます。詳細については、直接リンクによる共有を参照してください。
- コメントウィンドウを開いたとき(関連するマーカーをクリックするか、Comments and Tasksペインで選択したとき)は、スレッドの最初と最新のコメントのみが表示されます。スレッド内のすべてのコメントを表示するには、これらのエントリの間にあるコントロールをクリックします。スクロールバーを使用して、すべてのコメントを確認できます。
-
共有されたデザインプロジェクトを表示しているユーザーは誰でも、コメントウィンドウ上部の
コントロールを切り替えて、コメントを解決済みにしたり、再びアクティブにしたりできます。コメントにタスクが割り当てられている場合は、ステータスのドロップダウンメニューから現在のステータスを「解決済み」または別のステータスに変更できます。解決済みのコメントは、デフォルトではComments and Tasksペインに表示されませんが、ピンの表示/非表示オプションを使用すると表示できます。詳細については、次のセクションを参照してください。
- デザインプロジェクトの特定のリリースをレビューしているとき(製造ポータルのDesign Snapshotビュー内)にコメントを投稿した場合、そのコメントにはリリース情報が、そのリリースへのリンクとして含まれます。
- 以前にコミットされたプロジェクト(Historyビューでコミットイベントとして表示)にVCSタグが付いている場合、コメントにはタグ名も表示されます。このタグ名は、そのコミットのスナップショットへのリンクとして機能します。
- コメントの投稿にURLリンクを含めることができます。URLをコピーしてコメント欄に貼り付けるだけで、自動的に検出され、クリックしてアクセスできる通常のリンクとして表示されます。
コメントペインの操作
以下では、コメントとインターフェースのComments and Tasksペインの操作について説明します。
- Comments and Tasksペインは、プロジェクト全体のコメントを一覧表示し、目的のコメントに移動するためのツールです。投稿、編集、返信を行うための操作インターフェースではありません。これらの操作は、コンテキストコメントウィンドウでのみ行えます。
- メイン表示領域でコメントマーカーをクリックしても、Comments and Tasksペインは開きません。この操作で開くのは、コンテキストコメントウィンドウのみです。
-
ペインの左上にあるコントロールを使用すると、メイン表示ウィンドウ内のコメントマーカーピンを表示(
)または非表示(
)にできます。画像にマウスポインターを合わせると、例を確認できます。
-
Comments and Tasksペインの上部には、スレッドのフィルタリング設定にアクセスするためのコントロールがあり、ペインに表示する内容を指定できます。フィルタリングは基本的に2つのレベルで設定できます。第1のレベル(プライマリレベル)では、表示するユーザーコメントを制御できます。
ペインのフィルターオプションでは、コメントの表示を以下のように絞り込めます。
- Tasks only – ユーザータスクとして割り当てられたコメントのみ。これらは、タスクページのフローでも利用できます。
- ASSIGNED TO – 下のリストで選択したユーザーに割り当てられたコメントのみ。ユーザーのチェックボックスを選択すると、そのユーザーにタスクが割り当てられているコメントのみが、ペイン(および表示中のドキュメント)に表示されます。なお、現在サインインしているユーザーは、コメントのタスクが割り当てられているかどうかにかかわらず、リストの先頭に表示されます。
プライマリフィルタリングと組み合わせて適用する第2のフィルタリングレベルには、2つのオプションがあります。解決済みのコメントまたはタスクをすべて非表示にする(Unresolved onlyを有効化)、プロジェクト全体ではなく現在表示しているアクティブなドキュメントのコメントのみを表示する(Current documentのみを有効化)、または両方を適用することができます。
- 上記のオプションウィンドウの下部にあるNotification Settings項目をクリックすると、プロジェクト内のどのコメントについてメール通知を受信するかを設定するウィンドウが開きます。すべてのコメントスレッドの通知を受信する、どのスレッドの通知も受信しない、または自分が関与しているスレッド(自分が開始した、返信した、または自分がメンションされたスレッド)の通知のみを受信する、のいずれかを選択できます。
-
ペイン内のコメントスレッドの表示順序にも、2つのレベルがあります。まず、コメントは配置されているドキュメントごとに並べられ、その順序は左側のペインにあるソースドキュメントのナビゲーション構造と同じです。次に、各ドキュメント内のコメントは、作成日時の降順で並べられます。
-
ペイン内のコメントスレッドの項目をクリックすると、メイン表示ウィンドウでそのコメントにフォーカスが移り、コンテキストコメントウィンドウで開かれます。Comments and Tasksペイン内の該当するコメント項目も青色で強調表示されます。Comments and Tasksペインにも同じコメントマーカー番号が表示されるため、どのコメントを表示しているかを簡単に確認できます。現在表示しているドキュメント以外のコメントをクリックすると、そのコメントが配置されているドキュメントがアクティブになります。
- ペイン内の各コメント項目には、以下の例のように、そのコメントに関する主要な情報の概要が表示されます。
コメントに関するその他の注意点
-
コメントがオブジェクトに関連付けられており、そのオブジェクトが設計から削除された場合、コメントはエリアコメントに変換され、同じ座標に残ります。このような場合、コメントに保存されている元の設計のスクリーンショットが非常に役立ちます。
-
設計ドキュメントがプロジェクトから削除されると、そのドキュメントに関連付けられたコメントはすべて非表示になります。
-
設計内でオブジェクトを移動すると、それに関連付けられたコメントも移動します。
-
以前のバージョンのAltium Designerでフリーハンドコメントを使用していた設計では、それらがエリアコメントに変換され、それぞれのフリーハンド描画がコメントに添付されます。
-
Altium Designer 20.xでは、フリーハンド描画で使用されていた線の色と幅の設定は無視されます。代わりに、これらの描画は赤色の線のみで表示され、線幅には、それらの旧バージョンのソフトウェアでコメントに使用されていた、調整できない標準の線幅が適用されます。
-
解決済みのコメントは削除できません。未解決の状態に戻してから削除する必要があります。
Jiraタスクの操作
Related page: Jiraタスクの操作
WorkspaceでJira連携が有効になっており、AdminページでJiraアプリケーションが設定されている場合、配置したコメントには、Atlassian Jira
コメントと同じ方法で配置するJira課題は、Comments and Tasksペインに表示され、Jiraスペース内の課題へのリンクが提供されます。また、そのタスクの優先度とステータスの設定を直接操作できます。
配置したJiraタスクのインスタンスは、Jiraスペース内の対応する課題と同期されます。Jira課題とWorkspaceタスク間の双方向データ同期により、Altium 365と連携しながらJiraスペースで設計プロジェクトを管理できます。例を表示。
Jira連携の設定の詳細については、Jiraアプリケーションの情報を参照してください。
要件ポータルの操作
Related page: 要件の操作
Altium 365 Web Viewerは、Requirements Portalとの連携にも対応しており、設計ドキュメントレベルでシステム要件を管理・検証できます。
お使いのワークスペースでこの機能が有効になっている場合、Requirements Portalのインターフェースで定義された正式な要件仕様(例を表示)をワークスペースの設計ドキュメントに配置したり、担当者を割り当て可能なワークスペースタスクとして作成したりできます。要件インスタンスはワークスペースとRequirements Portalの間で常に同期されるため、プロジェクトのすべての関係者が、設計の要件仕様への適合状況を確認、管理、検証できます。
要件インスタンスは、Requirementsペインからドキュメントに配置するか、対応が必要なワークスペースタスクとして作成します。
Requirements Portalで提供される要件には、ワークスペースのRequirementsペインからアクセスでき、コメントを配置する場合と同じ方法で設計ドキュメントに配置できます。選択した要件への設計の適合状況は、要件ウィンドウまたはそのRequirementsペインのタイルにある検証メニューのオプションから設定できます。
設計ビュー内で、要件を検証済みなどの状態に設定できます。検証ステータスは、Requirements Portal内の対応する要件エントリと同期されます。
新しいデータへの更新
Web Viewerインターフェースを使用して最新のソースプロジェクトのドキュメントを確認する場合(特定のプロジェクトを管理しているときに詳細管理ページのDesign ビューから確認する場合、または共有されたライブ設計を表示する場合)、プロジェクトがAltium Designerからワークスペースにコミットされるたびに、データが自動的に更新されます。コミット後まもなく、インターフェース内に通知が表示されます。新しいデータが生成されたら、Refresh Pageコントロールをクリックして、ビューを最新のデータセットに更新します。










































































)にあるNet Nameの項目をクリックします。PCBデータビューでネットを選択するには、SCH データビューでネットを選択してからPCB データビューに切り替えるか、































































