BOMドキュメントの作成
概略
- BomDocの作成方法、プロジェクトに追加した際の動作、および1つのプロジェクトに追加できるBomDocは1つだけという重要な制限について学びます。
- 表示モード、列の操作、編集ツール、グループ化の動作、表示設定オプションなど、BOM Itemsリストの構成を確認します。
- ActiveBOMがグループ化されたコンポーネントやカスタムBOMエントリをどのように扱うかを理解し、設計内のコンポーネントとプロジェクトに必要な追加アイテムの両方を漏れなく管理できるようになります。
BOMドキュメントの作成
ActiveBOMで使用するBOMドキュメントは、BomDocと呼ばれます。File » Newサブメニューから、またはProjectsパネルでプロジェクトを右クリックして、新しいBomDocをプロジェクトに追加します。プロジェクトに少なくとも1つのコンポーネントがある場合は、Projectsパネルのプロジェクト構造内にあるActiveBOMエントリの横の+ Createコントロールをクリックして、新しいBomDocを作成できます。各PCBプロジェクトに含めることができるBomDocは1つだけです。
プロジェクトに新しいBomDocを追加すると、回路図が自動的にコンパイルされ、既存のすべてのコンポーネントがBomDocに一覧表示されます。Part Choicesを含むWorkspaceライブラリコンポーネントについては、以下のソリューションについてのセクションで説明するように、インターフェースの下部領域にソリューションの詳細が表示されます。
回路図にコンポーネントを追加配置すると、それらは自動的にBomDocに追加されます。コンポーネントリストの上にあるAdd newボタンを使用して、ActiveBOMで追加のBOM項目やパラメーターを直接手動で追加することもできます。詳細については、カスタムBOM項目と列のセクションを参照してください。
BOM項目リスト
BomDocの上部領域には、PCB設計プロジェクトで検出されたすべてのコンポーネントと、BomDocに直接追加したBOM項目が表形式で一覧表示されます。この領域をBOM項目リストと呼びます。

Baseビューに表示されたコンポーネント、つまりBOM項目のリスト。
BOM項目の表示には、3つのビューモードを使用できます。リストの上にあるボタンで、必要なモードを選択します。
Flat view - コンポーネントごとに1行で表示します。
Base view - プロジェクト内の同一のコンポーネントを1行にまとめて表示します。Designator列には、その種類のすべてのコンポーネントのデジグネーターが表示されます。グループ化されたデジグネーターには、複数の表示オプションがあります。Propertiesパネルで必要なDesignator Groupingモードを選択します。
Consolidated view - プロジェクトにバリアントが含まれている場合に使用し、すべてのバリアントを統合したBOMを表示します。
BOM項目リストの編集機能
コンポーネントリストは、次のようなスプレッドシートに似たさまざまな編集機能をサポートしています。
- PropertiesパネルのColumnタブを使用して、列の表示と非表示を切り替えたり、列名のエイリアスを定義したりできます。エイリアスは、 Enter Column Propertiesダイアログでも定義できます。このダイアログにアクセスするには、BomDocの列ヘッダー領域で列名を右クリックし、コンテキストメニューから Rename Column コマンドを選択します。 なお、生成されるBOM出力では、エイリアスが列名として使用されます。
-
列の追加と削除は、 Select Columns ダイアログでも行えます。このダイアログにアクセスするには、BomDocの列ヘッダー領域で列名を右クリックし、 Select Columnsを選択します。
Select Columnsダイアログのオプション/コントロール
- Search - フィールドに文字を入力して列のリストをフィルタリングし、入力した文字を名前に含む列だけを表示します。
-
Visibility column - ActiveBOMドキュメント(
*.BomDoc)内でActiveBOMの列を表示するかどうかを制御します。目のアイコンをクリックすると、列の表示と非表示が切り替わります。表示される列は常にダイアログの上部に、BomDoc内での表示順に並びます。 -
Data Source column - 列のデータソースを表示します。次のデータソースがサポートされています。
-
- BOMに直接追加された項目
-
- 回路図コンポーネントのパラメーター
-
- Workspaceコンポーネントのパラメーター
-
- リンクされたデータベースのパラメーター(DbLink、DbLib)
-
- 回路図ドキュメントのパラメーター
-
- Altium Cloud Services
-
- Column Name - データソースの名前を表示します。この名前は、BomDocで列名として表示されます。
- Up / Down - 現在選択されている列をリスト内で上下に移動します。その結果、OKをクリックすると、その列がBomDoc内で左右に移動します。順序を変更できるのは、表示されている列だけです。
-
- 各見出しの横にあるフィルター記号をクリックすると、選択したリスト項目でグリッド内の情報をフィルタリングできます。
- ドラッグ&ドロップで列の順序を変更できます。
- 任意の列で並べ替えを行えます。Shiftを押しながら操作すると、さらに別の列を使って並べ替えできます。
-
フィルターアイコンをクリックすると、列の値でフィルタリングできます。
- Windowsの標準的な選択操作でセルを選択できます。
- ActiveBOMからセルの内容をコピーしたり、外部のスプレッドシートエディターからカスタムActiveBOM列に値を貼り付けたりできます。
-
BOMがBaseビューの場合、ユーザー設定可能な行番号を定義できます。BaseビューでSet line numbersボタン(
)をクリックすると、各行に行番号が追加されます。ボタンの右側にあるドロップダウンアイコンをクリックすると、Line # Optionsダイアログが開き、開始値と増分値を定義できます。詳細については、行番号列のセクションを参照してください。
-
Add Newドロップダウン(
)をクリックすると、行や列を追加できます。詳細については、カスタムBOM項目と列のセクションを参照してください。
-
Group byボタン(
)をクリックすると、有効になっている列でグリッドをグループ化できます。複数のGroup By列を有効にすることができ(画像を表示)、ドラッグ&ドロップでその順序を変更できます。これはグリッドの表示機能であり、Bill of Materialsコマンドを実行しても、このグループ化はReport Managerダイアログに引き継がれません。
- Reset Supply Chainボタン(
)をクリックすると、選択したBOM項目から、ユーザー定義のソリューションランキングと手動で割り当てたSPNの優先順位が削除されます。
- BOM Itemsグリッドの現在の設定は、BOMセットとして保存できます。詳細については、BOM Itemsグリッドの表示の設定と保存セクションを参照してください。
-
標準のWindowsショートカットを使用して、BOM項目のリストをスクロールできます。
- 垂直スクロール = MouseWheel Roll
- 水平スクロール = Shift + MouseWheel Roll
列グループ

ActiveBOMのコンポーネントリストには、各ビューモードに表示される、いくつかの列グループがあります。上の画像はBaseビューを示しています。
BOM Itemsグリッドは、次の主要なグループに分かれています。
- Item Details(画像内のオレンジ色のハイライト)- これらの列には、デジグネーター、説明、ライブラリ参照、その他のコンポーネントパラメーターなど、コンポーネントのパラメーター情報が表示されます。
- Solutions(画像内の緑色のハイライト)- サプライチェーンで最上位にランク付けされたメーカーとサプライヤーです。ソリューション(メーカー部品)の数と、各ソリューションのサプライヤー数は、ActiveBOMのPropertiesパネルで設定します。これらは、サプライヤータイル内の単色のカラーバナーで示されます。ランキングは自動的に行われますが、以下のソリューションについてセクションで説明するように、手動で定義することもできます。
- BOM Status(画像内のシアン色のハイライト)- 各コンポーネントに関連する現在のリスクを示します。アイコンにカーソルを合わせると説明が表示されます。または、Propertiesパネルで詳細なBOM Status列を有効にして、説明を表示することもできます。
カスタムBOM項目と列
PCB設計プロジェクトのBOM管理では、回路図やPCBに配置されたもの以外のコンポーネントやBOM項目も管理する必要があります。たとえば、詳細がまだ決まっていない部品、留め具、ベアボード、実装用接着剤などです。PCB設計プロジェクトでは、カスタムBOM項目やパラメーターが必要になることが多くあります。このような場合に対応するため、ActiveBOMではBOM項目や列(パラメーター)を追加し、生成されるBOMに含めることができます。
- Custom row - 設計で考慮する必要があるカスタムBOM項目(ベアボード、接着剤など)を簡単に追加できます。カスタム行のすべてのフィールドはユーザー定義です。カスタム行はActiveBOMによって管理されません。たとえば、数量を3に設定しても、Flatビューに3つの個別項目として表示されることはありません。また、カスタム行ではサプライチェーン検索もサポートされません。
- Custom column - ActiveBOMで管理される追加のBOM列です。ユーザー定義の任意のテキストを入力できます。
- Custom Item - 追加のBOM項目です。通常は、必要になるものの、まだ詳細が確定していない項目や、ライブラリにまだ存在しない項目に使用します。これにより、これらの項目のコストを基板全体のコスト見積もりに含めることができます。
-
Managed Component - BOMドキュメント内で手動管理する追加のBOM項目です。Component Searchダイアログが開き、現在接続されているWorkspace内のコンポーネントが一覧表示されます。
Component Searchダイアログのオプションとコントロール
- Search - 検索テキストボックスを使用して、特定のコンポーネントを手動で検索します。
-
- クリックしてメニューを開き、次の項目から選択します。
- File-based Libraries Preferences - クリックしてAvailable File-based Librariesダイアログを開き、ライブラリを追加または削除します。
- File-based Libraries Search - クリックしてFile-based Libraries Searchダイアログを開き、ライブラリを検索します。
- Refresh - クリックしてダイアログを更新します。
-
- クリックして、ダイアログのDetails 領域 (後述)を開く、または閉じます。
カテゴリ
このフィルターを使用して、特定の種類のコンポーネント、または使用可能なすべてのコンポーネントを表示します。
を使用してCategories 検索バーを開くと、特定のコンポーネントや.IntLibファイルを手動で検索できます。
フィルター
Filters アイコン(
)をクリックするとFilters 領域が開き、Components リストで選択したカテゴリをさらに絞り込むことができます。
コンポーネント
- Name - コンポーネントの名前。
- Description -各コンポーネントの説明。
- Footprint - コンポーネントのフットプリント。
- Operating Temperature Range - これらのコンポーネントが動作する適切な温度範囲。
- Package Description - コンポーネントのパッケージの説明。
- Manufacturer Part Search - クリックすると、Manufacturer Part Searchパネルが開き、最適なコンポーネント部品を検索して選択できます。
- Create component - クリックすると、Create new componentダイアログが開き、コンポーネントの種類を選択できます。
- Results - 検索で見つかった、または一覧表示されたコンポーネントの総数を表示します。
詳細
- Component Revision ID - コンポーネントのリビジョンIDと価格を表示します。リビジョンIDをクリックすると、Explorerパネルが開き、コンポーネントの詳細情報を確認できます。
- References - クリックすると、コンポーネントの参考情報がWebブラウザーで開きます。ドロップダウンからManufacturer URLまたはDatasheetにアクセスできます。
- Place - クリックすると、選択したコンポーネントを回路図ドキュメントに配置できます。
- Component information - メーカー、リリース日、説明など、コンポーネントに関する情報を表示します。Show More リンクをクリックするとすべての情報が表示され、Show Less をクリックすると情報が折りたたまれます。
- Models - 展開すると、提供されているモデルを表示できます。利用可能なリンクを使用して、1つのモデルのさまざまな部分を表示できます。
- References - 展開すると、Manufacturer URLまたはDatasheetにアクセスできます。
- Part Choices - 展開すると、部品候補を表示できます。名前、価格、説明が表示されます。コンポーネントのデータシートも一覧表示されます。
- Where Used - 展開すると、このコンポーネントを使用しているプロジェクトを表示できます。
右クリックメニュー
- Place <component> - クリックすると、適切なドキュメントにコンポーネントを配置できます。
- Edit - クリックすると、選択したコンポーネントのコンポーネントライブラリドキュメントが開きます。
- Navigate to <revision> - クリックすると、選択したコンポーネントがExplorerパネル内で開きます。
- Operations - カーソルを合わせると、Submit Request、Create、Download、Make a copy、Change Component Type、Create / Edit PCL、Full Item Historyの操作を実行できます。
- Refresh - クリックすると、表示が更新され、最新の更新内容や編集内容を確認できます。F5ショートカットでも表示を更新できます。
管理対象コンポーネントまたはカスタムアイテムのインスタンスの追加
管理対象コンポーネントまたはカスタムアイテムを追加したら、それを右クリックしてOperations » Add Instances ofコマンドを選択し、Add to BOM Componentsダイアログを開きます。このダイアログで、BOMに追加するコンポーネントのインスタンス数を定義します。
Designator prefix、任意のSeparator(X-1やX:1などの結果になるように定義できます)、および必要なコンポーネントのQuantity を指定します(この値はデジグネーターの範囲を定義するために使用され、ActiveBOMのQuantity 列にも表示されます)。説明など、その他すべてのパラメーターは、BOMアイテムグリッドで直接編集できます。
管理対象コンポーネントまたはカスタムアイテムの変更と削除
デジグネーターを編集する場合、または管理対象コンポーネントやカスタムアイテムのインスタンスを削除する場合は、それを右クリックしてOperations » Edit itemコマンドを選択します。Change / Removeダイアログが開きます。
Change/Removeダイアログのオプションとコントロール
- BOM Components - ダイアログのグリッド領域には、新しいアイテムの各インスタンスが一覧表示されます。デジグネーターの接頭辞や値を編集するには、該当するNew Designatorセルをクリックし、必要に応じて編集します。
- Remove All - このボタンをクリックすると、ダイアログに一覧表示されている追加BOMアイテムのすべてのインスタンスが選択され、削除フラグが設定されます。ダイアログのOKボタンをクリックすると、削除フラグが設定されたすべてのアイテムがActiveBOMのBOMアイテムグリッドから削除されます。新しいアイテムのインスタンスがなくなるため、アイテム自体も削除されることに注意してください。この操作は元に戻せません。
- Remove None - このボタンをクリックすると、すべての削除フラグが解除されます。
- Remove Selected - 削除フラグが設定されていないインスタンスを選択している場合、3番目のボタンで、現在選択しているインスタンスに削除フラグを設定できます。
- Restore Selected - 削除フラグが設定されているインスタンスを選択している場合、3番目のボタンで、現在選択しているインスタンスの削除フラグを解除できます。
データソース
ActiveBOMで利用可能なデフォルトのデータソースは、回路図コンポーネントのパラメーター(
)、WorkspaceコンテンツのWorkspaceコンポーネントのパラメーター(
)、およびActiveBOMが提供するデータ(
)です。ActiveBOMは、これらのソースからプロジェクトのメインBOMアイテムグリッドを生成します。データソースの有効化と表示の制御は、ActiveBOMのPropertiesパネルのColumnsタブで行います。
該当するSourcesボタン(列リストの上部)を有効にすると、次の追加データソースから取得した情報もBOMに含めることができます。
The PCB - これらを有効にすると、各コンポーネントのPCB上の位置、回転、基板面のデータを、利用可能なColumnsに含めることができます。プロジェクトに複数のPCBドキュメントが含まれる場合は、 Choose PCB to Useダイアログが開き、使用するPCBを選択できます。
Database - 外部データベースから追加のコンポーネントパラメーターを読み込みます(*.DbLib、*.SVNDbLib、または*.DbLink経由)。
Altium Cloud Services - これを有効にすると、Altium Parts Providerによって識別され、サプライチェーンソリューションが表示されているBOMアイテムについて、幅広い追加コンポーネントデータにアクセスできます。
Document Parameters - これを有効にすると、PCBプロジェクト内のすべての回路図から検出された回路図ドキュメントのパラメーターを、利用可能なColumnsに含めることができます。

各パラメーターのソースは、列リスト内のアイコンで示されます。
データソースのパラメーターの優先順位
同じパラメーターが複数のデータソースに存在する場合、ActiveBOMでは次の優先順位が適用されます(高い順)。
- BOM
- PCB
- ドキュメント
- サーバー
- データベース
- クラウド
- 回路図
- 手動
行番号列
組立図を含むPCB設計や、設計エンジニア、コストエンジニア、購買担当者間でのBOMデータ交換では、BOM行番号(BOM項目位置番号)を使用することで、BOMの各行を簡単に区別できます。これにより、設計内の対応するコールアウト、コンポーネント、図示を明確に識別したり、findしたりできます。
プロジェクトのBOMデータソースであるActiveBOMは、プロジェクトBOMのユーザー定義のLine #に対応しており、Line #(BOM項目位置番号)を手動および自動で管理する機能を備えています。
-
すべてのプロジェクトBOM項目の位置番号を自動設定するには(Base表示で)、Set Line #
ボタンをクリックします。行番号は、Item Details列グループのLine #列に表示されます。ボタン右側のドロップダウンアイコンをクリックすると、Line # Optionsダイアログが開き、開始値と増分値を設定できます。

Line Number Optionsダイアログ- Start number - 最初のLine #セルが空の場合に使用する値です。
- Increment - 空の各Line #フィールドをこの値ずつ増加させます。
-
Line #を手動で変更するには、Base表示モードに切り替え、Line #列で必要なセルを選択して、次の操作を行います。
- キーボードのDeleteを押してセルをクリアし、次に
- 新しい値を手動で入力するか、
- Windowsクリップボードから一連の値を貼り付けます。
-
番号を振り直す場合や、任意に追加した番号から連番を続ける場合は、対象項目のLine #セルをクリックし、Set Line #
ボタンをクリックします。Line Numberingダイアログが開き、既存の番号を基準にして、選択した空のセルまたはすべての空のセルに、上方の最も近い空でないセルの番号から連番を付ける(Continue numbering)か、既存の番号をすべて削除して全行に番号を振り直す(Renumber all)ことができます。追加する番号の計算には、Line # Optionsダイアログで最後に設定した基準値と増分値が使用されます。必要に応じて、選択したLine #セルに初期値を入力して開始番号を指定できます。
BOM Itemsグリッドの表示設定と保存
一般的な表計算アプリケーションと同様に、BOM Itemsグリッドも要件に合わせて設定できます。通常の列の並べ替えやソート機能に加え、現在の設定をBOM Setとして保存できます。
グリッドの設定機能
- 任意の列の表示/非表示 - PropertiesパネルのColumns機能で設定します。パネル上部のSearch フィールドを使用すると、列をすばやく見つけられます。
- 列の順序の変更 - 列タイトルをクリックしたままドラッグ&ドロップします。
-
列幅の変更 - タイトル領域の列の端にカーソルを合わせ、クリックしてドラッグします(
カーソルが目印です)。また、その位置でダブルクリックすると、列の内容に合わせて幅が自動調整されます。
-
列を基準にグリッド全体をソート:
- 列タイトルをクリックすると、その列の内容に基づいてグリッドが英数字順にソートされます。
- もう一度クリックすると、逆順にソートされます。
- Shiftキーを押しながら別の列タイトルをクリックすると、その列の内容に基づいてさらにソートされます。
-
特定の値によるグリッドのフィルタリング - フィルターアイコン
をクリックすると、その列で使用されている値でグリッドを絞り込めます。(Custom)を選択するとFilter Editorダイアログが開き、選択した列をフィルタリングするための条件、演算子、値、演算子の種類などを設定できます。
- 設定をBOM Setとして保存 - 詳細は以下を参照してください。
BOM Setの操作
BOM Itemsグリッドの設定は、いくつでも保存できます。保存した各設定をBOM Setと呼びます。要件に合わせてグリッドを設定したら、ActiveBOMのPropertiesパネルのBOM Sets領域にあるAddボタンをクリックして、BOM Setをリストに追加します。

目のアイコンをクリックすると、BOM Setが有効になります。
BOM Setは、ActiveBOMのPropertiesパネルで設定します。
コンポーネントの置き換え
部品の発注に向けてBomDocを確認し、準備を進める際に、コンポーネントの問題が見つかることは珍しくありません。たとえば、設計者がコンポーネントの選定を確定し忘れていたり、コンポーネントが生産終了(EOL)となり、代替候補の価格や入手性を調べたい場合などがあります。以前は、この問題を解決するには、回路図に戻ってコンポーネントを編集し、適切な部品を選択してから、BomDocを更新するしかありませんでした。
現在は、BomDoc内でコンポーネントを変更し、Engineering Change Orderを介してその変更を回路図に反映することもできます。選択したコンポーネントを右クリックし、Operations » Change <ComponentName>コマンドを選択します。Replace Componentダイアログが開き、置き換え用のコンポーネントを検索できます。
Replace Component OKボタンをクリックすると、Engineering Change Orderダイアログが開き、回路図とBomDocを同期するために必要な変更の詳細が表示されます。
バリアントの操作
ActiveBOMは、設計バリアントを含むPCBプロジェクトをサポートしています。設計バリアント機能を使用すると、単一の基本PCB設計を作成し、それに対して異なる部品実装を定義できます。部品実装が異なる各組立基板をdesign variantと呼びます。
設計バリアントの操作:
- 設計バリアントは、Variant ManagementダイアログまたはVariant Manager(Project » Variants)で設定します。
- バリアントを確認するには、下の画像に示すように、ProjectsパネルにあるプロジェクトのVariantsフォルダー内で、その名前をダブルクリックします。
ActiveBOMは、次の方法でバリアントをサポートしています。
- 基本表示モードまたはフラット表示モードで、特定のバリアントのBOMを表示
- BOM項目リストに未実装項目を含めるオプション
- 統合表示モードで、すべてのバリアントに使用されている全部品の統合リストを表示
- 基本コンポーネントと変更されたコンポーネントの両方に対して、手動ソリューションを定義
基本表示モードでのバリアント
選択したバリアントについて、PropertiesパネルのShow Not Fittedオプションを有効にすると、これらの部品がBOM項目グリッドに含まれます。このオプションを有効にすると、項目の詳細にFitted列が自動的に表示されます。
基本表示モードでは、Fitted列にFittedまたはNot Fittedが表示されます。部品が変更されている場合(このバリアントで代替部品が選択されている場合)、そのBOM項目には代替部品の詳細が自動的に表示されます。

現在のバリアントは、ActiveBOMのステータス行に表示されます。
統合表示モードでのバリアント
統合表示モードでは、すべてのバリアントに使用されているすべてのコンポーネントが表示されます。統合表示には、次の機能があります。
- コンポーネントが変更されている場合、使用されている代替コンポーネントごとにBOM項目が作成され、これらのBOM項目には同じデジグネーターが付けられます。たとえば下の画像では、BGAバリアントでTSOPバリアントとは異なる色のLEDが使用されているため、コンポーネントDS1とDS2がそれぞれ2回ずつ表示されています。コンポーネントR1が3回表示されているのは、BGAバリアントとTSOPバリアントの両方で、基本設計の元の抵抗とは異なる抵抗が使用されているためです。
-
統合表示モードでShow Not Fittedオプションを有効にすると、Fitted列に
FittedまたはVariedが表示されます。統合表示にはすべてのバリアントで使用されるすべてのコンポーネントが表示されるため、表示される各コンポーネントは、基本設計またはいずれかのバリアントに実装されています。 - 各バリアントには、<VariantName> - Qty列(このバリアントで使用される、このコンポーネントの数量を示す)と、単価に数量列の値を掛けた値を示す<VariantName> - Price列があります。
- バリアントだけでなく基本設計についても製造用ドキュメントを作成する設計者がいるため、基本設計の製造時に使用されるこのコンポーネントの数を示すQuantity列もあります。基本設計から製造用ドキュメントを生成しない場合は、この列を非表示にしてください。
- 統合表示モードのグリッドでは、下に示すように、基本設計の対応するセルと値が異なるセルが色で示されます。

セルの色は、そのセルの値が基本設計の対応するセルの値と異なることを示します。
バリアントの詳細については、設計バリアントページを参照してください。
BomDoc、回路図、PCB間での操作
BomDoc、回路図、PCB設計間での作業を支援する機能として、クロスセレクトとクロスプローブの2つがあります。これらの機能の動作は、PreferencesダイアログのSystem - Navigationページ で設定します。
どちらの機能も、他のドキュメントで同じコンポーネントを見つけるために使用できます。クロスセレクトとクロスプローブの違いは、クロスセレクトモードでは対象ドキュメントのコンポーネントが選択されるだけで、そのドキュメントが前面に表示されないのに対し、クロスプローブでは対象ドキュメントが前面に表示され、さらに対象ドキュメントのエディターに切り替えてアクティブにすることもできる点です。
BomDocから回路図およびPCBへのクロスセレクトやクロスプローブは可能ですが、回路図またはPCBからBomDocへのクロスセレクトやクロスプローブはできません。
クロスセレクトモード
クロスセレクトモードは、使用する各エディターで有効にする必要があります。Tools » Cross Select Modeコマンド(Shift+Ctrl+X)を選択します。クロスセレクトモードが有効になると、メニューアイコンが枠線で強調表示されます
。
クロスセレクトモードを使用するには、対象ドキュメントが開いている必要があります。BomDocのBOM項目リストでコンポーネントを選択すると、対象の回路図およびPCBドキュメントでそのコンポーネントが選択され、中央に表示されます(PreferencesダイアログのSystem - NavigationページにあるCross Select ModeオプションでZoomingが有効になっている場合)。ただし、対象ドキュメントはアクティブなドキュメントとして表示されません。
BomDocが基本表示モードの場合、下の画像に示すように、その部品のすべてのインスタンスが回路図およびPCB上で選択されます。

クロスセレクト機能を使用すると、BOM項目リストで選択したコンポーネントを回路図およびPCB上で見つけて選択できます。
クロスプローブ
クロスセレクトは、有効にするとBOM項目リストをクリックするたびに結果が表示されるモードであるのに対し、クロスプローブは明示的に実行する操作です。
次を選択します: Tools » Cross Probeメインメニューの コマンドを使用するか、BOMアイテムを右クリックしてコンテキストメニューからCross Probeを選択すると、回路図上の該当コンポーネントにクロスプローブできます。基板ファイルが開いている場合は、PCB上のコンポーネントにもクロスプローブされます。
クロスプローブの主な機能の1つは、対象ドキュメントのエディターに切り替えられることです。クロスプローブと同時にエディターを切り替えるには、Ctrlキーを押しながらCross Probeコマンドを選択します。

右クリックすると、クロスプローブコマンドにアクセスできます。そのBOMアイテムに含まれる各コンポーネントのデジグネーターに対応する項目が表示されます。
Propertiesパネル
アクティブなドキュメントがBOMドキュメント(*.BomDoc)の場合、PropertiesパネルにDocument Optionsが表示されます。
以下の折りたたみ可能なセクションでは、利用可能なオプションとコントロールについて説明します。
全般
- Production Quantity – 製造する基板の枚数です。このフィールドは、サプライチェーン検索でサプライヤーの部品の供給状況を確認する際に使用されるため、設定することが重要です。
- Currency – 部品価格の表示に使用する優先通貨です。Altiumアカウントにサインインしている場合、通貨換算の為替レートは毎日更新されます。Altiumから切断すると(PreferencesダイアログのSystem – Account Managementページ)、これらの最新レートにアクセスできなくなります。この場合、BOMレポートダイアログでキャッシュデータを使用するオプションを利用できます。
- Price Per Board – サプライヤーのデータから算出される値で、以下で説明するSupplier Subtotals per Boardの合計です。Price Per Boardでは、最小発注数量(MOQ)は考慮されないことに注意してください。
- Order Price – Supplier Subtotalsの合計です。Order PriceではMOQが考慮され、これがサプライヤーへの支払額になります。
サプライチェーン
サプライチェーン情報はActiveBOMインターフェースの下部に表示され、左側にメーカーのコンポーネント、その右側に1つ以上の色付きサプライヤータイルが表示されます。この領域には、BOMアイテムの有効なサプライチェーン情報を特定できた場合にデータが表示されます。これらのManufacturer & Supplier(s) Details行はそれぞれソリューションと呼ばれます。メーカーの詳細情報はMPN(メーカー部品番号)、サプライヤーの詳細情報はSPN(サプライヤー部品番号)と略記されます。
- Solutions per Item – 各BOMアイテムに対して検索するメーカー部品の数。
- Suppliers per Solution – 各メーカー部品に対して検索するサプライヤーの数。
-
Solutions
- Exclude Invalid SPNs – 選択すると、無効なSPNが除外されます。
- Favorite Suppliers List – Favorite Suppliersダイアログを開きます。このダイアログでは、このBomDocのサプライヤーリスト全体を設定できます。
-
Manufacturer Link – Define Manufacturer Link Fieldsダイアログを開きます。このダイアログでは、メーカー名とメーカー部品番号を格納する回路図コンポーネントのパラメーターを指定します。設計にWorkspace以外のライブラリ部品(Workspaceから配置されておらず、サプライヤーの詳細情報もない部品)が含まれている場合、ActiveBOMはAltium Parts Providerに問い合わせて、適切なサプライチェーンソリューションを特定できます。名前/部品番号のパラメーターペアは複数定義できます。ダイアログで Detect fieldsボタンをクリックすると、名前に
manufacturerという語を含み、論理的にペアにできるすべてのパラメーターペアが自動的に追加されます。
BOMアイテム
この領域では、BOMアイテムグリッドでのBOMアイテムのグループ化方法を設定します。
-
Items
-
Show not Fitted – PCBプロジェクトにバリアントが含まれ、選択したバリアントに
Not Fittedに設定された部品がある場合、このオプションを有効にすると、非実装アイテムがBOMアイテムグリッドに表示されます。 - Designator Grouping – BaseおよびConsolidated表示モードでは、共通の部品がBOMアイテムグリッドの1行に表示されます。このオプションを使用して、1行に複数の部品が表示される場合に、デジグネーターを個別に表示するか、範囲で表示するかを設定します。
- Component Grouping – Edit ボタンをクリックすると、Component Groupingダイアログが開きます。Base表示またはConsolidated表示では、ActiveBOMはItemID(Workspaceライブラリ)またはLibRef(ファイルベースまたはデータベースライブラリ)が同じコンポーネントを、同一のものとして識別します。ダイアログでパラメーターを有効にすると、コンポーネントのグループ化方法をさらに細かく設定できます。 プロジェクトに管理対象コンポーネントのみが含まれる場合、管理対象コンポーネントは常にItemIDでグループ化されるため、Edit ボタンは使用できません。
-
Show not Fitted – PCBプロジェクトにバリアントが含まれ、選択したバリアントに
BOMセット
BOMセットを使用すると、BOMアイテムグリッドのレイアウトと設定を記録し、名前付きのセットとして保存できます。BOMセットは任意の数だけ定義できます。
-
Current BOM Set – 目のアイコンをクリックすると、そのBOMセットがBOMアイテムグリッドに適用されます。
-
Add – 列の表示/非表示、順序、幅を設定し、Add をクリックして、その設定を BOM セットとして保存します。BOM セット名を編集するには、1 回クリックして選択し、もう一度クリックして文字列を編集します。
-
Update – BOM 項目グリッドの設定を変更した場合は、Update をクリックして設定を再保存します。
-
Delete –
をクリックして、現在選択されている BOM セットを削除します。
BOM チェック
ActiveBOM は、各 BOM 項目と、その項目について検出されたサプライチェーンデータを包括的にチェックします。
- Violation Type grid – BomDoc に現在存在する違反の種類と件数を一覧表示します。フィルターアイコンをクリックすると、その BOM チェックに不合格となった BOM 項目のみが表示されます。1 つの BOM 項目が複数の BOM チェックで不合格になる場合があります。
-
BOM Checks –
をクリックすると、BOM Checks ダイアログが開き、各違反の種類に対するレポートモードを設定できます。
列
パネルのこの領域では、各 BOM 項目に表示するパラメーターと、それらのパラメーターで利用できるデータソースを設定します。
-
Sources – BomDoc に直接追加されたデータ(
)に加え、ActiveBOM で利用できるデフォルトのデータソースには、回路図コンポーネントのパラメーター(
)と、Workspace コンテンツの Workspace ライブラリコンポーネントのパラメーター(
)があります。ActiveBOM はこれらのソースから、プロジェクトのメイン BOM 項目グリッドを生成します。BOM には、次の追加データソースから取得した情報も含めることができます。
-
PCB – 有効にすると、各コンポーネントで利用できる Columns に、PCB 上の位置、回転、基板面のデータが含まれます。
-
Database – 有効にすると、外部データベース(*.DbLib、*.SVNDbLib、または*.DbLink)から追加のコンポーネントパラメーターを読み込みます。 -
Document – 有効にすると、PCB プロジェクト内のすべての回路図で検出されたすべての回路図ドキュメントパラメーターが、利用可能な Columns に含まれます。
-
Altium Cloud Services – 有効にすると、Altium Parts Provider によって識別され、サプライチェーンソリューションが表示されている BOM 項目について、幅広い追加コンポーネントデータにアクセスできます。
-
-
Columns – ActiveBOM で利用可能な部品情報のすべてのソースの一覧です。列領域は、いずれかの見出しフィールドをクリックすると並べ替えられます。
- Visibility – 各行には目のアイコンがあり、クリックするとメイン BOM 項目グリッドでその列の表示/非表示を切り替えられます。
- Source – そのパラメーターの取得元を示すアイコンが表示されます。
- Name – ソースドキュメントで定義されたプロパティ/パラメーターの名前、またはユーザーが作成した BomDoc 列に入力された名前です。
- Alias – 必要に応じて、エイリアスを定義して列名を変更できます。
- Add – クリックすると、BOM 項目グリッドに新しいカスタム列が追加されます。






