デザイン・プロジェクトの検証
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- プロジェクト検証を実行する場所、Altium Designerが警告やエラーを報告する仕組み、問題のある箇所に直接移動する方法を学びます。
- Error ReportingのチェックとConnection Matrixのルールの違い、および設計に合わせてそれぞれを調整すべきタイミングを理解します。
- プロジェクト全体の検証を無効にすることなく、No ERCディレクティブを使用して、既知の特定の違反の報告を抑制する方法を確認します。
回路図は単なる図面ではなく、回路の電気的な接続情報を含んでいます。この接続情報を利用して、設計を検証できます。
回路図の検証と検証オプションの設定
設計を検証するには、メインの Project メニューから Validate PCB Project <ProjectName> コマンドを選択します。Projects パネルでフォーカスされているプロジェクトを検証するには、プロジェクトのエントリの右クリックメニューにある Validate Project コマンド、またはパネル上部の
コントロールも使用できます。

Validate PCB Project <ProjectName> コマンドを使用して設計を検証します。
ソフトウェアは、統合データモデルとプロジェクトのチェック設定を照合し、論理的なエラー、電気的なエラー、作図エラーをチェックします。検証エラーと警告を回路図上に表示する設定が有効な場合(Preferences ダイアログの Schematic – Compiler ページで有効にします)、問題のあるオブジェクトの下に色付きの波線が表示されます。オブジェクトにカーソルを合わせると、違反の概要を示すポップアップヒントが表示されます。Messages パネルにも通知が表示されます。
設計の検証では、多数の作図チェックや電気的チェックを実行できます。これらはプロジェクトオプションの一部として設定します。メインメニューから Project » Project Options コマンドを選択し、Project Options ダイアログを開きます。デフォルト設定がすべての設計に適しているわけではないため、各オプションと、設計に合わせた設定方法を理解しておくことが重要です。
作図チェック
検証時には、Project Options ダイアログの Error Reporting タブの設定に従って、一般的な作図エラーや編集エラーがチェックされます。 エラーチェックは、Violations Associated with Nets、Violations Associated with Components などのグループに分類されています。 グループはダイアログ内にアルファベット順で表示されます。 各違反の Report Mode は、クリックしてドロップダウンから目的の値を選択することで、4 つの値のいずれかに変更できます。

Project Options ダイアログの Error Reporting タブで、必要なエラーチェックを設定します。違反の Report Mode セル内をクリックすると、その違反に対する設定を変更できます。
通常は、まずデフォルト設定で設計を検証し、警告を確認することをお勧めします。現在の設計で問題にならない警告については、レポートレベルを変更できます。
各エラーチェックの詳細については、以下の「PCB 設計の違反タイプ」セクションを参照してください。
接続チェック
電気的な接続は、Project Options ダイアログの Connection Matrix タブの設定に従ってチェックされます。

接続マトリックスでは、許容される電気的条件と許容されない電気的条件を定義します。
このマトリックスは、コンポーネントのピンと、ポートやシートエントリなどのネット識別子との間に接続ルールを設定する仕組みを提供します。警告またはエラーとして報告する論理的条件や電気的条件を定義します。たとえば、出力ピン同士の接続は通常エラーと見なされますが、パッシブピン同士の接続はエラーとは見なされません。
特定のルールを変更するには、マトリックス内の小さな四角をクリックします。 各ルールは、特定のピンとネット識別子の組み合わせに対するレポートレベルを決定します。各ルールには、Fatal Error、Error、Warning、No Report の 4 つの値を設定できます。
メッセージの解釈とエラー箇所の特定
プロジェクトを検証すると、警告またはエラーを発生させるすべての条件が Messages パネルに一覧表示されます。なお、Messages パネルが自動的に開くのは、Error または Fatal Error の条件が少なくとも 1 つある場合のみです。Warning を確認するには、デザインスペースの右下にある Panels ボタンをクリックして Messages を選択し、手動でパネルを開く必要があります。 プロジェクトの検証が完了すると、検出された警告とエラーがパネルに一覧表示されます。

Messages パネルには、プロジェクトで検出された警告とエラーが表示されます。
Messages パネルは、違反の表示を一元管理する場所です。以下の点に注意してください。
-
Messages パネルには 2 つの領域があります。上部のグリッド領域には警告やエラーの概要が表示され、下部の領域には現在選択されている警告やエラーの詳細が表示されます。
-
メッセージをダブルクリックすると、その警告やエラーにクロスプローブできます。詳細をダブルクリックすると、該当するオブジェクトが表示されます。
-
Messages パネルの列見出し(Class、Document、Message など)をクリックすると、エラーや警告を並べ替えることができます。
-
Messages パネル内で右クリックし、Group By サブメニューのオプションを使用すると、特定の条件でエラーや警告をグループ化できます。
-
Messages パネル内で右クリックし、該当する Clear コマンドでメッセージを削除するか、Export To Report コマンドでメッセージをレポートにエクスポートできます。
-
このパネルには、Error Reporting タブと Connection Matrix タブの両方の設定に基づいて検出された警告とエラーが表示されます。
-
Messagesパネルで警告/エラーを右クリックし、Place Specific No ERC for this violationコマンドを選択すると、エラーの位置に自動的にクロスプローブされ、カーソルにNo ERCディレクティブが表示されます。このディレクティブをエラーの位置に配置すると、エラーチェックを抑制できます。詳しくは、ERC違反の抑制をご覧ください。
警告またはエラーの解決
検出された警告やエラーには、一つひとつ対処することが重要です。デフォルトのエラー設定は、安全側に設定されています。これは、ソフトウェアが慎重に判定し、チェック条件を緩和してもよいかどうかをユーザーが判断できるようにするためです。たとえば、設計上、IOピンを入力ポートに接続する必要がある場合は、Connection Matrixタブの該当するセルを調整する必要があります。また、変更が必要になることの多いエラーチェックとしてNets with no driving sourceがあり、これはError Reportingタブで無効にする必要があります。
特定の条件について設計全体をチェックしつつ、回路内の特定の箇所では警告/エラーを無視したい場合があります。たとえば、ある箇所でのみネット名の変更を許可したい場合です。これは、その箇所にNo ERCディレクティブを配置することで実現できます。
ERC違反の抑制
回路内の特定の箇所でエラーを報告させたくない場合は、その箇所にNo ERC(Electrical Rules Check:電気ルールチェック)ディレクティブを配置します。これはdo not flag a warning/error at this locationを意味します。 No ERCディレクティブを使用すると、警告が発生することがわかっている箇所(未接続のピンなど)のエラーチェックを意図的に制限しながら、回路のその他の部分は包括的にチェックできます。
No ERCディレクティブは、複数のスタイルに対応しており、任意の色で表示できます。この機能を活用して、回路内のその箇所における設計意図を表現してください。

回路内のその箇所での役割を最もよく表すNo ERCスタイルを選択してください。
No ERCディレクティブには、次の2つの動作モードがあります。
- Suppress All Violations – このモードでは、発生し得るすべての警告および/またはエラー条件を抑制します。このモードのディレクティブは、通常、汎用No ERCディレクティブと呼ばれます。
- Suppress Specific Violations – このモードでは、選択した警告またはエラー条件のみを抑制し、それ以外の警告やエラーは検出して報告します。このモードのディレクティブは、通常、個別No ERCディレクティブと呼ばれます。
使用例
ネットに「駆動源がない」という警告が表示されても、確認してみると無視してよいメッセージだった、という経験は何度もあるのではないでしょうか。たとえば、入力ピンがコネクタに接続されており、そのコネクタのピンは定義上パッシブで、外部ケーブルを接続したときにのみ駆動信号が供給される場合があります。また、ネットの駆動源が、やはりパッシブなプルアップ抵抗やスイッチである場合もあります。この警告を解消するには、次のいずれかの方法を使用できます。
- ネット上の信号供給元のピンの電気的特性を変更します。これは抑制ではなく修正ですが、ピンのデフォルトの動作モードを変更するため、後の工程で問題を引き起こす可能性があります。たとえば、ピンの方向を示すグラフィック表示が無効になっている設計で、配線を変更する場合を考えてみてください。その変更により、出力がパッシブデバイスのピンに接続されることがあります。そのデバイスのピンが、以前の駆動源に関する警告を解消するために電気的に出力として設定されていた場合、接続違反が発生します。
- [Options For Project]ダイアログの[Error Reporting]タブで定義されている、該当する違反チェックのレポートモードを[No Report]に設定します。これにより、この特定の違反のチェックは無効になりますが、設計内の他の箇所にある実際のエラーも検出できなくなります。
-
3つ目の方法(おそらく最善の方法)は、ネット上にNo ERCディレクティブを配置することです。問題ではないとわかっている警告メッセージの「ノイズ」を抑制するだけで、設計自体には何の変更も加えません。

「駆動源がない」という警告が発生することがわかっているネットに、No ERCディレクティブを配置します。
No ERCディレクティブの配置
No ERCディレクティブを回路図ドキュメントに配置するには、いくつかの方法があります。
-
メインメニューからPlace » Directives » Generic No ERCコマンドを選択するか、Wiring ツールバーの
ボタンをクリックするか、デザインスペースで右クリックしてPlace » Directives » Generic No ERCコマンドを選択すると、汎用No ERCディレクティブを配置できます。
-
すでに違反が表示されている回路内の箇所に個別No ERCディレクティブを配置するには、デザインスペースで違反のあるオブジェクト(色付きの波線で強調表示されているオブジェクト)を右クリックし、コンテキストメニューからPlace NoERC to Suppressコマンドを選択します。

右クリックのコンテキストメニューを使用して、個別No ERCディレクティブを配置します。 -
すでに違反が表示されている回路内の箇所に個別No ERCディレクティブを配置するには、Messagesパネルで警告/エラーを右クリックし、Place Specific No ERC for this violationコマンドを選択します。すると、回路図内の該当箇所に直接移動するので、その警告/エラーを抑制するように設定されたNo ERCディレクティブを配置します。

Messages パネルの右クリックのコンテキストメニューを使用して、個別No ERCディレクティブを配置します。
No ERCディレクティブの編集
配置中、No ERCオブジェクトがまだカーソルに追従している間は、次の編集操作を実行できます。
-
[Properties]パネルから編集します。この編集方法では、対応するPropertiesパネルモードを使用して、オブジェクトのプロパティを変更します。

PropertiesパネルのNo ERCモード配置中は、Tabキーを押すことで、PropertiesパネルのNo ERCモードにアクセスできます。
配置後は、次のいずれかの方法で、PropertiesパネルのNo ERCモードにアクセスできます。
- 配置済みのディレクティブをダブルクリックします。
- ディレクティブにカーソルを合わせて右クリックし、コンテキストメニューからPropertiesを選択します。
- Propertiesが パネルがすでにアクティブな場合は、 ディレクティブを選択します。
-
No ERCダイアログから。この編集方法では、No ERCダイアログを使用して、Specific No ERCオブジェクトの違反タイプと接続エラーを変更します。

Violation Typesモード(最初の画像)とConnection Matrixモード(2番目の画像)を表示したNo ERCダイアログこのダイアログには、No ERC モード(前述)のPropertiesパネルのSuppressed Violations領域でSpecific Violationsをクリックするとアクセスできます。
No ERCダイアログのオプションとコントロール
- Top statement - 現在抑制されている違反タイプと接続エラーの数をすばやく確認できる表示です。ダイアログ内で変更を行うと、この表示も更新されます。
- Show - Violation TypesまたはConnection Matrixを選択して、対応するNo ERCディレクティブを表示および設定します。
違反タイプ
このモードでは、違反タイプの抑制または抑制解除を行えます。- Violation Type To Suppress - 設定可能な違反タイプの一覧を表示します。
- Report Mode - 一覧にある違反タイプの現在のレポートモードを表示します。
- Suppress - チェックボックスをオンにすると、対応する違反タイプが抑制されます。オフにすると抑制が解除されます。
右クリックメニュー
- Suppress only "[xxx]" - 引用符内に示されている違反タイプのみを抑制します。
- Unsuppress only "[xxx]" - 引用符内に示されている違反タイプのみの抑制を解除します。
- Suppress All "[xxx]" - 引用符内に示されているオブジェクトのすべての違反タイプを抑制します。
- Unsuppress All "[xxx]" - 引用符内に示されているオブジェクトのすべての違反タイプの抑制を解除します。
- Suppress All - オブジェクトやカーソルの位置に関係なく、一覧にあるすべての違反タイプを抑制します。
- Unsuppress All - オブジェクトやカーソルの位置に関係なく、一覧にあるすべての違反タイプの抑制を解除します。
- Toggle All - すべての違反タイプのSuppress チェックボックスのオン/オフを切り替えます。
接続マトリックス
このモードでは、接続エラーの抑制または抑制解除を行えます。- Grid - グリッド内のチェックボックスを使用して、対象の接続エラーを抑制(オン)または抑制解除(オフ)します。
右クリックメニュー
- Suppress only "[xxx]" - 引用符内に示されている接続エラーのみを抑制します。
- Unsuppress only "[xxx]" - 引用符内に示されている接続エラーのみの抑制を解除します。
- Suppress All "[xxx]" - 引用符内のすべての接続エラーを抑制します。このコマンドは、接続の各側に対応して2つあります。
- Unsuppress All "[xxx]" - 引用符内のすべての接続エラーの抑制を解除します。 このコマンドは、接続の各側に対応して2つあります。
- Suppress All - グリッド内のすべての接続エラーを抑制します。
- Unsuppress All - グリッド内のすべての接続エラーの抑制を解除します。
- Toggle All - すべての接続エラーのチェックボックスのオン/オフを切り替えます。オンのチェックボックスはオフに、オフのチェックボックスはオンになります。
-
SCH ListパネルおよびSCH Filterパネルから。 Listパネルでは、1つまたは複数のドキュメントの設計オブジェクトを表形式で表示でき、オブジェクトの属性をすばやく確認および変更できます。対応するFilterパネル、またはFind Similar Objectsダイアログを使用した適切なフィルタリングと組み合わせることで、アクティブなフィルターの対象となるオブジェクトのみを表示でき、複数の設計オブジェクトをより正確かつ効率的に選んで編集できます。
No ERCディレクティブの無効化
No ERCディレクティブは、削除する代わりに非アクティブ(検証時に無効と見なされる状態)にできます。この状態は、いずれかの編集方法でディレクティブのActiveプロパティを切り替えることで変更できます。非アクティブなNo ERCディレクティブは、設計スペース内でグレー表示されます。

No ERCディレクティブの使用を一時的に停止する必要がある場合は、削除せずに非アクティブにしてください。
No ERCディレクティブの印刷制御
デフォルトでは、No ERCマーカーは印刷に含まれます。すべてのマーカーを印刷対象から除外するか、特定のシンボルのみを除外するには、以下に示す Printダイアログ を使用します。

Print ダイアログでNo ERCマーカーの印刷を制御します。
No ERC
No ERCマーカーを使用して、回路内の特定のノードに関するエラー/警告メッセージを抑制します。
概要
No ERCオブジェクトは設計ディレクティブです。回路内のノードに配置することで、回路図プロジェクトのコンパイル時に検出される電気ルールチェックの警告やエラーをすべて抑制します。No ERCを使用すると、警告が発生することがわかっている回路内の特定の箇所(未接続ピンなど)で意図的にエラーチェックを制限しつつ、回路の残りの部分では包括的なチェックを実行できます。
No ERCディレクティブはさまざまなスタイルに対応しており、任意の色で表示できます。この機能を使用して、回路内のその箇所の設計意図を表現してください。
回路内のその箇所における機能を最もよく表すNo ERCスタイルを選択してください。
No ERCディレクティブには2つのタイプがあります。
- All Violations – 発生し得るすべての警告やエラーが抑制されます。
- Specific Violations – 選択した警告またはエラー条件のみが抑制されます。 それ以外の警告やエラーは検出され、報告されます。
使用可能なエディター
No ERCデザインディレクティブは、回路図エディターでのみ配置できます。No ERCディレクティブを配置するには、次の操作を行います。
- メインメニューからPlace » Directives » Generic No ERC をクリックすると、すべての違反を対象とするように事前設定されたNo ERCマーカーを配置できます。これは、汎用No ERCディレクティブとも呼ばれます。
- 回路図エディター内で右クリックし、 Place » Directives » Generic No ERCをクリックします。
配置 - 汎用No ERCディレクティブ
コマンドを実行すると、カーソルが十字に変わり、配置モードになります。次の手順でNo ERCディレクティブを配置します。
- ワイヤーまたはその他のネットオブジェクト上にカーソルを合わせ、Enter をクリックして、回路内のその位置にディレクティブを配置します。
- 引き続きNo ERCディレクティブを配置するか、右クリックまたは Esc を押して配置モードを終了します。
配置中は、次の操作も実行できます。
- Tab キーを押すと、配置が一時停止し、 PropertiesパネルのNo ERCモードにアクセスして、プロパティをその場で変更できます。配置を再開するには、デザインスペースに重ねて表示される一時停止ボタンをクリックします。
グラフィカルな編集
No ERCマーカーは、位置の変更以外のグラフィカルな編集はできません。No ERCマーカーを移動するには、クリックしたまま新しい位置にドラッグします。
非グラフィカルな編集
次の非グラフィカルな編集方法を使用できます。
No ERCダイアログまたはPropertiesパネルによる編集
Panel page: No ERCのプロパティ
この編集方法では、対応するNo ERCダイアログとProperties パネルモードを使用して、オブジェクトのプロパティを変更します。
No ERC ダイアログ(1枚目の画像)とPropertiesパネルのNo ERCモード(2枚目の画像)
配置後は、次の方法でNo ERC ダイアログにアクセスできます。
- 配置済みのNo ERCオブジェクトをダブルクリックします。
- No ERCオブジェクトにカーソルを合わせて右クリックし、コンテキストメニューからPropertiesを選択します。
配置中は、Tabキーを押すと、PropertiesパネルのNo ERCモードにアクセスできます。No ERCを配置すると、すべてのオプションが表示されます。
配置後は、次のいずれかの方法でPropertiesパネルのNo ERCモードにアクセスできます。
- Propertiesパネルがすでにアクティブになっている場合は、No ERCオブジェクトを選択します。
- No ERCオブジェクトを選択した後、ワークスペース右下のPanels ボタンからProperties パネルを選択するか、メインメニューからView » Panels » Propertiesを選択します。
関連するプロパティダイアログによる編集
この編集方法では、No ERCダイアログを使用して、特定の違反を対象とするNo ERCオブジェクトの違反タイプと接続エラーを変更します。
Violation Typesモード(1枚目の画像)とConnection Matrixモード(2枚目の画像)を表示したNo Ercダイアログ
このダイアログには、No ERCダイアログ、およびNo ERC モードのProperties パネルにあるSuppressed Violations 領域で、Specific Violationsをクリックしてアクセスできます。
複数オブジェクトの編集
Properties パネルは複数オブジェクトの編集に対応しており、現在選択されているすべてのオブジェクトで共通するプロパティ設定を変更できます。同じタイプのオブジェクトを、手動、 Find Similar Objectsダイアログ、または SCH Filter パネルや SCH List パネルを使用して複数選択すると、 Properties パネルでアスタリスク(*)として表示されていないフィールドの値を、選択したすべてのオブジェクトに対して編集できます。
リストパネルによる編集
Panel pages: SCH List、 SCH Filter
List パネルでは、1つまたは複数のドキュメントのデザインオブジェクトを表形式で表示でき、オブジェクトの属性をすばやく確認、変更できます。適切なフィルタリング(該当するFilter パネル、またはFind Similar Objectsダイアログを使用)と組み合わせることで、アクティブなフィルターの対象となるオブジェクトのみを表示でき、複数のデザインオブジェクトをより正確かつ効率的に絞り込んで編集できます。
No ERCのプロパティ
回路図エディターのオブジェクトプロパティは、配置されたオブジェクトの外観、内容、動作を指定する設定可能なオプションです。各オブジェクトタイプのプロパティ設定は、次の2つの方法で定義します。
-
Pre-placement settings – No ERCオブジェクトのほとんどのプロパティ、または事前に定義可能なプロパティは、Preferencesダイアログの Schematic - Defaultsページで、編集可能なデフォルト設定として指定できます(デザインスペースの右上にある
ボタンからアクセス)。Primitive Listでオブジェクトを選択すると、右側にそのオプションが表示されます。
- Post-placement settings – 配置済みのNo ERCをデザインスペースで選択すると、No ERC ダイアログおよびPropertiesパネルで、No ERCオブジェクトのすべてのプロパティを編集できます。
位置 (Properties パネルのみ)
-
(X/Y)
- X (1番目のフィールド)- 現在のデザインスペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位を含めてください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位を含めてください。
- Rotation - ドロップダウンで回転角度を選択します。
プロパティ
- Color - 色付きのボックスをクリックしてドロップダウンを開き、デフォルトの色を選択します。
- Symbol - ドロップダウンの選択肢からデフォルトを選択します。
- Active - 有効にすると、プリミティブがアクティブになります。
抑制する違反 (Properties パネルのみ)
- All Violations - 選択すると、このオブジェクトのすべての違反が表示されます。違反のViolation TypeおよびReport Modeがグリッドに表示されます。
- Specific Violations - 選択すると、このオブジェクトの特定の違反が表示されます。違反のViolation TypeおよびReport Modeがグリッドに表示されます。
-
Add - クリックすると、No ERCダイアログが開き、新しい違反を追加できます。OKをクリックすると、新しい違反がグリッドに追加されます。現在選択されている違反を削除するには、
をクリックします。
PCB設計の違反の種類
バスに関連する違反
バスのインデックスが範囲外
この違反は、バスに接続された構成ネットのインデックスが、バスに関連付けられたネットで指定されている範囲外にある場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Bus index out of range on <NetPrefix> Index = <NetIndex>
各項目の意味は次のとおりです。
-
NetPrefixは、バスに接続された構成ネットの接頭辞です(例:ネットA[0..7]に関連付けられたバスに接続されたネットA8の場合はA)。. -
NetIndexは、構成ネットの誤ったインデックスです(例:ネットA8のインデックスは8)。
推奨される解決方法
問題のあるネットのインデックスを正しい範囲内の値に修正するか、ネット名そのものを変更してください。ネットに誤った名前を付けてしまい、そのネットがバスオブジェクトで伝送されるネットの構成要素ではない場合は、通常、後者の方法を使用します。
バス範囲の構文エラー
この違反は、バスに関連付けられたネットの構文が正しく指定されていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Bus range syntax error <NetName> at <Location>
各項目の意味は次のとおりです。
-
NetNameは、問題のあるバスオブジェクトに関連付けられた親ネットの名前です。 -
Locationは、問題のあるバスオブジェクトの電気的ホットスポットのX、Y座標です。
推奨される解決方法
問題のあるネット識別子(ネットラベル、ポート、シートエントリなど)のバス構文を正しく定義してください。正しい構文は、次のいずれかの形式になります。
-
NetName[LowerIndex..UpperIndex] -
NetName[UpperIndex..LowerIndex]
たとえば、2つの構成ネットA0とA1を伝送するバスを考えます。この場合のバス構文は、A[0..1]またはA[1..0]になります。誤った構文の例としては、A[0.1]、A[1-0]、A[0,1]、A[..1]、A[0..]などがあります。
不正なバス範囲の値
この違反は、バスに関連付けられたネットの構文で、少なくとも1つのインデックスが負の値になっている場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Illegal bus range value <BusLabel> at <Location>
各項目の意味は次のとおりです。
-
BusLabelは、不正な値が検出されたバスのラベル表記です。 -
Locationは、問題のあるバスオブジェクトの電気的ホットスポットのX、Y座標です。
推奨される解決方法
問題のあるネット識別子(ネットラベル、ポート、シートエントリなど)のバス構文を正しく定義してください。正しい構文は、次のいずれかの形式になります。
-
<NetName>[<LowerIndex>..<UpperIndex>] -
<NetName>[<UpperIndex>..<LowerIndex>]
バスラベルの並び順の不一致
この違反は、同じバススライスに関連付けられた2つのネット識別子で、バスラベルの並び順の方向(昇順または降順)が一致していない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Mismatched bus ordering on <NetName> Low value first and High value first
各項目の意味は次のとおりです。
-
NetNameは、バスの並び順が一致していない親ネットの名前です。
推奨される解決方法
バスの並び順が一致していないネット識別子(ポート、ネットラベル、シートエントリなど)を特定してください。 正しい並び順を確認し、誤っているオブジェクトの名前を修正してください。
バス幅の不一致
この違反は、同じバススライスに関連付けられた2つのネット識別子が、幅の異なるバスラベルを定義している場合に発生します。たとえば、名前が A[0..7] のポートが、ネットラベルを A[0..15] として定義したバスに接続されている場合です。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Mismatched bus widths on bus section <NetName> (<BusSize1> and <BusSize2>)
ここで:
-
NetNameは、不一致のバスオブジェクトが関連付けられている親ネットの名前です。 -
BusSize1は、問題のある1つ目のバスオブジェクトの幅です。 -
BusSize2は、問題のある2つ目のバスオブジェクトの幅です。
推奨される解決方法
バスラベルの幅が一致していないネット識別子(ポート、ネットラベル、シートエントリなど)を特定します。正しい幅を判断し、誤っているオブジェクトの名前を修正してください。
ワイヤ/バス上のバス/ワイヤオブジェクトの不一致
この違反は、ワイヤオブジェクトが誤ってバスに接続されている場合、またはバスオブジェクトが誤ってワイヤに接続されている場合に発生します。たとえば、ポート A がバスに接続されていても、ポート名に正しいバスラベル構文(例: A[0..1])が入力されていない場合です。この場合、実際には単一信号(またはワイヤ)オブジェクトであるポートが、誤ってバスに接続されています。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
<ObjectIdentifier> at <Location> placed on a <ObjectType>
ここで:
-
ObjectIdentifierは、不一致のオブジェクトを表します。これはバスまたはワイヤオブジェクト(ピン、ポート、電源ポート、ネットラベル、オフシートコネクタ、シートエントリなど)のいずれかです。識別子は、次の2つの形式のいずれかで表示されます。-
バスの場合 –
Bus <Object> <Name>(例:Bus Net Label GND_BUS[..])。 -
ワイヤの場合 –
Wire <Object> <Name>(例:Wire Port TXD)。
-
バスの場合 –
-
Locationは、オブジェクトの電気的ホットスポットのX、Y座標です。 -
ObjectTypeは、問題のあるオブジェクトが配置されているオブジェクトで、ワイヤまたはバスのいずれかです。
推奨される解決方法
問題を解決するには、次の点を確認してください。
- Is the connection correct? – オブジェクトに接続されているバスは、本来ワイヤであるべきではありませんか。または、その逆ではありませんか。
-
Is the object defined correctly? – バスオブジェクトの場合は、オブジェクトの名前が
<Name>[<LowIndex>..<HighIndex>]または<Name>[<HighIndex>..<LowIndex>]の形式の正しいバス構文で指定されていることを確認してください。たとえば、バイト幅のデータ出力ポートはDAT_OUT[7..0]と指定できます。ワイヤオブジェクトの場合は、オブジェクトの名前が単一の信号を定義しており、バス構文で定義されていないことを確認してください。
ジェネリック形式と数値形式のバスラベルの混在
この違反は、同じバススライスに接続された2つのネット識別子(ポート、ネットラベル、シートエントリなど)でバス構文が異なり、一方が数値形式(例: A[0..2])でバス範囲を定義し、もう一方がジェネリック形式(例: A[0..b])で範囲を定義している場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Mismatched generic and numeric bus labeling on <NetName> <Level> value first and Generic
ここで:
-
NetNameは、不一致のバスラベルが関連付けられている親ネットの名前です。 -
Levelは、ネットの数値の順序によって異なります。昇順(例:[0..2])の場合、LevelはLowと表示されます。降順(例:[2..0])の場合、LevelはHighと表示されます。
推奨される解決方法
問題のあるオブジェクトのうち、どちらのバスラベル指定が誤っているかを判断し、適切に変更してください。
コンポーネントに関連する違反
コンポーネントが削除されている
この違反は、プロジェクトの設計から1つ以上のコンポーネントが削除されている場合に発生します。削除は「論理削除」として処理され、削除されたコンポーネントは専用の Trash の場所に移動されます。接続先のWorkspaceのブラウザインターフェースで、削除されたエントリのメニューオプション(⋯)から復元(Restore)または完全に削除(Permanently Delete)できます。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
ComponentName: Component has been deleted
ここで:
-
ComponentNameは、Workspaceコンポーネントの名前です。
推奨される解決方法
コンポーネントが誤って削除された場合は、適切なアクセス権を持つユーザーが、Workspaceのブラウザインターフェースの Trash ページから復元できます。それ以外の場合は、設計で使用されているコンポーネントを、接続先のWorkspaceで利用isできる別の同等のコンポーネントに置き換えてください。
ピンマッピングが無効なコンポーネント実装
この違反は、統合ライブラリパッケージ(*.LibPkg)のコンパイル時に、回路図コンポーネントとリンクされたモデル間のピンマッピングが無効であることが検出された場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
ComponentName: Could not find port <ModelPinNumber> on model <ModelName> for pin <ComponentPinNumber> – PCBモデル関連
ComponentName: Could not map port <ModelPinNumber> on model <ModelName> to a pin – シミュレーションモデル関連
ここで:
-
ComponentNameは、ソース回路図ライブラリ内のコンポーネントの名前です。 -
ModelPinNumberは、リンクされたモデル上で見つからなかったピン/パッドに想定されるデジグネータです。 -
ModelNameは、コンポーネントにリンクされているモデルの名前です。 -
ComponentPinNumberは、モデルの問題のあるピンがマッピングされている、ソース回路図コンポーネントのピンのデジグネータです。
推奨される解決方法
解決するには、回路図シンボルと対象ドメインのモデル間のマッピングにアクセスします。そのためには、まず該当する回路図ライブラリコンポーネントのプロパティを表示する必要があります。SCH Libraryパネルの Components リストでコンポーネントのエントリをダブルクリックすると、そのコンポーネントのプロパティが読み込まれた状態で Propertiesパネルが開きます。
PCBモデルに関連する違反メッセージが表示された場合は、パネルのFootprintセクションでモデルを選択し、リストの下にある
ボタンをクリックして、PCB Modelダイアログを開きます。そこでPin Mapボタンをクリックし、Model Mapダイアログを開きます。Component Pin Designator列で、メッセージに示されたピン番号(ComponentPinNumber)を探します。この違反は、Model Pin Designator列の対応するエントリが、PCBモデルに存在しないパッドデジグネータを指定しているために発生します。必要に応じてエントリを修正してください。通常は1対1のマッピングとなり、両側のデジグネータは同じになります。
シミュレーションモデルに関連するメッセージが表示された場合は、パネルのModelsセクションでモデルを選択し、リストの下にある
ボタンをクリックして、Sim Modelダイアログを開きます。そこでPort Mapタブをクリックします。この違反は、モデルのピンが回路図コンポーネントのピンに正しくマッピングされていない場合に発生します。これは、モデルのピンのエントリに、すでにマッピングされているピン、またはNot Connectedが設定されている場合に起こることがあります。必要に応じてエントリを修正してください。
コンポーネントのリビジョンが使用不可の状態になっている
この違反は、接続されたWorkspaceから配置されたコンポーネントアイテムのリビジョンのインスタンスのうち、少なくとも1つが使用不可の状態であると検出された場合に発生します。たとえば、コンポーネントが現在DepracatedまたはObsoleteであり、最新の設計には含めるべきではない場合です。 使用可否は、State PropertiesダイアログのAllowed to be used in designsオプションで決まります。Edit Lifecycle Definitionsダイアログで、親のライフサイクル定義内にある対象状態のエントリをダブルクリックするか、そのエントリを選択して表示される編集アイコン(
)をクリックすると、その状態のダイアログが開きます。このオプションが有効な場合、この状態のアイテムリビジョンは設計で使用することが許可され、Applicableと見なされます。このオプションが無効な場合、この状態のアイテムリビジョンは有効なものとして使用できず、Inapplicable(使用不可)と見なされます。
Messagesパネルの通知
Messagesパネルに、次の形式で通知が表示されます。
Component <Designator> <Comment>: Component revision has inapplicable state
各項目の意味は次のとおりです。
-
Designatorは、コンポーネントインスタンスのDesignatorです。 -
Commentは、コンポーネントインスタンスのCommentです。
推奨される解決方法
Item Managerダイアログを使用して、設計で使用可能な代替のコンポーネントアイテムリビジョンを選択します。使用不可の状態にあるコンポーネントごとに、この操作を行ってください。または、コンポーネント単位で、既存のコンポーネントアイテムリビジョンを別のリビジョンや、別のコンポーネントアイテムのリビジョンに置き換えることもできます。回路図上のコンポーネントを選択し、Propertiesパネルでそのプロパティを表示します。パネルのPropertiesセクションで、Updateボタンをクリックして現在のコンポーネントアイテムの最新リビジョンを使用するか、Design Item IDフィールドの右側にある
ボタンをクリックしてWorkspaceにアクセスし、使用する別のコンポーネントアイテムリビジョンを探します。
注記
-
配置済みのコンポーネントがソースWorkspaceとの接続を失った場合(たとえば、配置元のWorkspaceが切断された場合や、Workspaceからサインアウトした場合)、
Component revision has inapplicable stateチェックの違反となります。これは、Messages パネルに次の形式のエントリとして表示されます。Component <Designator> <Comment>: Can't perform revision status validation: Failed to get session: Access denied! User login required for this service. -
設計のリリースプロセス中に、設計内で不適切に使用されているコンポーネントを検出することもできます。リリース検証全体の手順にComponent State Checkingを追加し、設定してください。
コンポーネントのリビジョンが最新ではない
この違反は、接続されたWorkspaceから配置されたコンポーネントが最新ではないと検出された場合に発生します。
Messagesパネルの通知
Messagesパネルに、次の形式で通知が表示されます。
Component <Designator> at <Location>: Component revision is Out of Date
各項目の意味は次のとおりです。
-
Designatorは、コンポーネントインスタンスのDesignatorです。 -
Locationは、違反のあるコンポーネントインスタンスの原点を示すX、Y座標です。
推奨される解決方法
Item Managerダイアログを使用して、最新リビジョンではないコンポーネントを特定し、更新します。Item ManagerにはRevision Status列があり、最新リビジョンではないコンポーネントのステータスはOut of Dateになります。最新ではないコンポーネントを選択し、右クリックしてメニューからUpdate to latest revisionを選択します。その後、ECOをGenerateして、これらの変更を対象の回路図に適用します。
または、コンポーネント単位で、既存のコンポーネントアイテムリビジョンを最新リビジョンに置き換えることもできます。回路図上のコンポーネントを選択し、Propertiesパネルでそのプロパティを表示します。パネルのPropertiesセクションで、Updateボタンをクリックして、現在のコンポーネントアイテムの最新リビジョンを使用します。
注記
配置済みのコンポーネントがソースWorkspaceとの接続を失った場合(たとえば、配置元のWorkspaceが切断された場合や、Workspaceからサインアウトした場合)、Component revision is Out of Dateチェックの違反となります。これは、Messagesパネルに次の形式のエントリとして表示されます。Component <Designator> <Comment>: Can't perform revision status validation: Failed to get session: Access denied! User login required for this service.
重複したサブパートを含むコンポーネント
この違反は、マルチパートコンポーネントのインスタンスの同じパートが、回路図設計内に複数回配置されている場合に発生します。たとえば、デジグネータがU9の74HC32コンポーネントを配置した際に、誤ってこのコンポーネントのパート1を2つ配置し、設計内にU9Aのインスタンスが2つ存在する場合です。
Messagesパネルの通知
Messagesパネルに、次の形式で通知が表示されます。
Component <ComponentName> has duplicate sub-parts at <Location1> and <Location2>
各項目の意味は次のとおりです。
-
ComponentNameは、違反のあるコンポーネントのデジグネータとライブラリ参照で表される名前です。 -
Location1は、該当するサブパートの最初のインスタンスのX、Y座標です。 -
Location2は、該当するサブパートの重複したインスタンスのX、Y座標です。
推奨される解決方法
必要に応じて、Increment Part Number コマンドを使用して問題のあるパートの番号を変更します。このコマンドは、メインの Edit メニュー、またはパートを右クリックしたときに表示される Part Actions サブメニューから使用できます。Edit メニューからコマンドを実行すると、インクリメントモードが維持されるため、目的の番号になるまでパート番号を順に切り替えられます。
ピンが重複しているコンポーネント
この違反は、コンポーネント内の2つ以上のピンに同じデジグネーターが割り当てられている場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Duplicate pins in component Pin <Identifier1> and Pin <Identifier2>
各項目の意味:
-
Identifier1は、重複するピンの最初のインスタンスの識別子で、パートのデジグネーターとピンのデジグネーターの組み合わせで表されます。 -
Identifier2は、重複するピンの2番目のインスタンスの識別子で、パートのデジグネーターとピンのデジグネーターの組み合わせで表されます。
推奨される解決方法
問題のあるピンのデジグネーターを変更し、それぞれが一意になるようにします。配置済みコンポーネントのピンデジグネーターは、回路図エディター内で編集できます。
- コンポーネントのピンがロックされていない場合は、ピンを選択し、Propertiesパネルでデジグネーターを編集するだけです。
-
それ以外の場合は、Component Pin Editorダイアログでピンを編集します。デザインスペースでコンポーネントを選択し、Propertiesパネルの Pins タブにある Pins セクションの下の
ボタンをクリックすると、このダイアログを開けます。
通常、重複はライブラリコンポーネント内に存在します。その場合は、ソース回路図ライブラリでそのコンポーネントのピンデジグネーターを編集し、Update From Libraries(回路図エディター)または Update Schematics(回路図ライブラリエディター)コマンドを使用して、配置済みのコンポーネントインスタンスに変更を反映します。これらのコマンドは、それぞれのエディターのメインの Tools メニューから使用できます。
注記
Messages パネルには、コンポーネントごとに違反が1件のみ表示されます。コンポーネントに同じデジグネーターを持つピンが3つ以上ある場合でも、パネルの Details 領域で違反を調査するときに表示されるのは、重複するピンのうち最初の2つ(ピン名のアルファベット順)のみです。
パートのデジグネーターの重複
この違反は、デザインのソース回路図シート全体で、2つ以上のパートに同じデジグネーターが割り当てられている場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Duplicate Component Designators <PartDesignator>
各項目の意味:
-
PartDesignatorは、問題のあるデジグネーターです。
推奨される解決方法
必要に応じて、重複しているパートにそれぞれ異なる一意のデジグネーターを割り当てます。問題のあるデジグネーターを1つずつ手動で編集するか、Annotateダイアログ(Tools » Annotation » Annotate Schematics)を使用して実行できます。
または、まず Tools » Annotation » Reset Duplicate Schematic Designators コマンドで重複するコンポーネントのデジグネーターをリセットし、次に Tools » Annotation » Annotate Schematics Quietly コマンドを使用して、Annotate ダイアログを開かずにアノテーションを実行します。
コンポーネントの表示モードで余分なピンを検出
この違反は、パートのいずれかの表示モードで余分なピンが検出された場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
<NumberOfExtraPins> extra pins in <DisplayMode> of design item <DesignItemID>
各項目の意味:
-
NumberOfExtraPinsは、パートで検出された余分なピンの数です。 -
DisplayModeは、余分なピンが検出されたパートのグラフィカル表示モードです。パートには Normal モードがあり、最大255個の Alternate モードを定義できます。 -
DesignItemIDは、問題のあるパートのDesign Item IDプロパティです。
推奨される解決方法
この違反は通常、コンポーネントに代替のグラフィカル表示モードが定義され、そのモードに余分なピンが存在する場合に発生します。Normal表示モードで指定されていないピンが表示に追加されている場合、そのピンは余分なピンと見なされます(つまり、各グラフィカル表示モードのピン数は同じでなければなりません)。
ソース回路図ライブラリで、そのコンポーネントの問題のある表示モードを表示し、余分なピンを削除します。配置済みのパートについては回路図シート上で直接実行することもできますが、通常はライブラリ内で問題を解決し、その変更を反映します(Tools » Update Schematics)。
汎用コンポーネント
この違反は、最終デザインに 汎用コンポーネントが含まれている場合に発生します。汎用コンポーネントは、利用可能なコンポーネントソースから特定のメーカー部品を探して選択することなく、デザインにすばやく配置できます。適切なコンポーネントに簡単に置き換えられるプレースホルダーとして使用することを目的としています。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Generic Component <PartDesignator> is placed at <Location>
各項目の意味:
-
Designatorは、配置された汎用コンポーネントインスタンスの Designator です。 -
Locationは、問題のある汎用コンポーネントインスタンスの原点を示すX、Y座標です。
推奨される解決方法
デザインが進み、汎用コンポーネントを特定の実部品に置き換えられる段階になったら、Properties パネルの Design Item ID field にある省略記号メニューを選択して、Replace Componentダイアログを使用できます。この操作は、Item Managerから、またはプロジェクトの ActiveBOMドキュメントからも実行できます。
ピンの表示設定の不一致
この違反は、マルチパートコンポーネントの電源ピン(VCCおよびGND)に関するものです。通常、これらのピンはパート0に関連付けられ、設計内のVCCおよびGNDネットに自動的に接続され、非表示になっています。コンポーネントのいずれかのパートでこのようなピンを表示すると、そのピンは接続先の電源ネットに接続されなくなり、エラーが報告されます。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Pin is visible in one sub-part and hidden in another sub-part
推奨される解決方法
設計スペースで問題の電源ピンを非表示にするか、ピンを表示したままにする場合は、対応するVCCまたはGNDの電源ポートオブジェクトを各ピンに接続してください。
コンポーネントモデルの欠落
この違反は、統合ライブラリパッケージ(*.LibPkg)のコンパイル時に、ソース回路図ライブラリ内のコンポーネントにリンクされたモデルが見つからない場合に発生します。
Messagesパネルでの通知
リンクされたモデルがフットプリントモデルまたはシミュレーションモデルの場合、Messagesパネルに次のいずれかの形式で通知が表示されます。
<ComponentName>: Could not find <ModelName> – モデルの検索範囲がAnyの場合。
<ComponentName>: Could not find <ModelName> in <LibraryName> – モデルの検索範囲がLibrary Nameの場合。
<ComponentName>: Could not find <ModelName> in <Path> – モデルの検索範囲がLibrary Pathの場合。
各項目の意味は次のとおりです。
-
ComponentNameは、ソース回路図ライブラリ内のコンポーネント名です。 -
ModelNameは、ソースコンポーネントにリンクされているものの、見つからなかったフットプリントまたはシミュレーションモデルの名前です。 -
LibraryNameは、リンクされたモデルが含まれるものとして指定されたライブラリファイルの名前です。 -
Pathは、リンクされたモデルが含まれるものとして指定されたライブラリファイルへの絶対パスです。
リンクされたモデルがシグナルインテグリティモデルの場合、Messagesパネルに次の形式でメッセージが表示されます。
<ComponentName>: Could not find 'GenericEntity' in <Path>
各項目の意味は次のとおりです。
-
ComponentNameは、ソース回路図ライブラリ内のコンポーネント名です。 -
Pathは、ライブラリまたはモデルへの絶対パスです。
推奨される解決方法
リンクされたフットプリントまたはシミュレーションモデルに問題がある場合
この問題は通常、次のいずれかの状況で発生します。
- モデルのリンクを定義する際に、モデル名が誤って指定されている。
- リンクされたモデルが、指定されたライブラリファイルに存在しない。
- リンクされたモデルを含むライブラリファイルが移動または削除されている。
この違反を解決するには、まずリンク先のモデルタイプに対応する設定ダイアログ(PCB ModelダイアログまたはSim Modelダイアログ)を確認します。いずれの場合も、次の点を確認してください。
- リンク先のモデル名が正しいこと。
- そのモデルを含むライブラリ/モデルファイルを検索するためのオプションが適切に設定されていること。
表示されるエラーメッセージの形式は、モデルの検索時に有効にした検索範囲によって異なり、モデルのリンクに関する問題の原因を特定するうえで大いに役立ちます。
-
指定したパスでモデルが見つからなかった場合(検索範囲:
Library path)、指定したライブラリ/モデルファイルがその場所に実際に存在することを確認し、さらに、そのファイル内に指定した名前のモデルが存在するか確認してください。 -
指定したライブラリ/モデルファイルでモデルが見つからなかった場合(検索範囲:
Library name)、そのファイルがAvailable Librariesリスト(Project Libraries、Installed Libraries、Project Search Paths)に追加されていることを確認してください。また、そのファイルに、リンクで指定したものと同じ名前のモデルが含まれていることも確認してください。 -
モデルが見つからなかった場合(検索範囲:
Any)、リンクで指定したものと同じ名前のモデルを含むライブラリ/モデルファイルが、Available Librariesリストに追加されていることを確認してください。
リンクされたシグナルインテグリティモデルに問題がある場合
通常、この問題はシグナルインテグリティモデルの種類(ダイオード、ICなど)が指定されていない場合に発生し、対応するシグナルインテグリティモデルの設定ダイアログで解決できます。このダイアログにアクセスする最も簡単な方法は、選択したコンポーネントのプロパティを表示しているときに、Propertiesパネル から開くことです。パネルのGeneralタブにあるModelsセクション で、正しいモデルを使用していることを確認し、必要に応じて修正してください。Add ボタンおよび
ボタンを使用すると、新しいモデルを作成(リストからSignal Integrityを選択)したり、既存のシグナルインテグリティモデルを変更したりできます。これによりSignal Integrity Modelダイアログが開き、Import Ibisボタンを使用してIBISモデルファイルからピンモデルをインポートできます。
コンポーネントの表示モードでピンの欠落を検出
この違反は、パートのいずれかの表示モードでピンの欠落が検出された場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
<NumberOfMissingPins> missing pins in <DisplayMode> of design item <DesignItemID>
各項目の意味は次のとおりです。
-
NumberOfMissingPinsは、パート内で欠落が検出されたピンの数です。 -
DisplayModeは、ピンの欠落が検出されたパートのグラフィック表示モードです。パートにはNormalモードがあり、最大255個のAlternateモードを定義できます。 -
DesignItemIDは、問題のパートのDesign Item IDプロパティです。
推奨される解決方法
この違反は通常、コンポーネントに代替グラフィック表示モードが定義されているものの、通常モードで指定されたピンの一部が代替モードで指定されていない場合に発生します(つまり、各グラフィック表示モードのピン数は同一である必要があります)。
ソース回路図ライブラリで、欠落しているピンを既存の表示モードからコンポーネントの問題のある表示モードにコピーしてください。すでに配置されているパートについては、回路図シート上で直接修正することもできますが、通常はライブラリ内で問題を修正し、その変更を反映します(Tools » Update Schematics)。
エントリが重複しているシートシンボル
この違反は、シートシンボルに同じ名前のシートエントリが2つ含まれている場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Sheet Symbol with duplicate entries Sheet Entry <Identifier> at <Location1> and <Location2>
各項目の意味は次のとおりです。
-
Identifierは、問題のシートエントリを表します。識別子はSheetSymbolName-SheetEntryName(SheetEntryIOType)の形式で表示されます。 -
Location1は、1つ目の違反シートエントリのX、Y座標です。 -
Location2は、2つ目の違反シートエントリのX、Y座標です。
推奨される解決方法
問題のあるシートエントリオブジェクトの名前を、必要に応じて変更してください。名前をその場で編集するか、問題のあるシートエントリをダブルクリックし、選択したシートエントリのすべてのプロパティが表示されるPropertiesパネルのPropertiesセクションでNameを編集します。
インデックスが重複しているシートシンボル
この違反は、マルチチャネル設計において、同じ子回路図シートを参照し、DesignatorフィールドにRepeatキーワードを含む2つ以上のシートシンボルで、チャネルインデックスの範囲に重複する値がある場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Sheet Symbols <ChannelIdentifier> have duplicated indexes: <ChannelIndexList>
ここで:
-
ChannelIdentifierは、シートシンボルのDesignatorフィールドで使用されるチャネル識別子です。 -
ChannelIndexListは、問題のあるシートシンボル間で重複しているチャネルインデックスをカンマで区切ったリストです。
推奨される解決方法
問題のあるシートシンボルオブジェクトのデジグネータを変更し、インデックス範囲に重複する値がないようにしてください。デジグネータをその場で編集するか、問題のあるシートシンボルをダブルクリックし、選択したシートシンボルのすべてのプロパティが表示されるPropertiesパネルのPropertiesセクションでDesignatorを編集します。
アノテーションが必要なデジグネータ未割り当ての部品
この違反は、設計内のコンポーネントにデフォルトのデジグネータ(末尾に「?」が付いたもの)が設定されている場合に発生します。つまり、まだアノテーションが行われていないか、デジグネータがリセットされています。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Un-Designated Part <PartDesignator>
ここで、
-
PartDesignatorは、デジグネータが割り当てられていない部品のデフォルトのデジグネータです(例:U?、D?、C?など)。
推奨される解決方法
問題のあるコンポーネントに、必要に応じて一意のデジグネータを割り当ててください。デジグネータを手動で編集するか、Annotateダイアログ(Tools » Annotation » Annotate Schematics)を使用して割り当てることができます。
または、Tools » Annotation » Annotate Schematics Quietlyコマンドを使用すると、Annotate ダイアログを開かずにアノテーションを行えます。
注記
Messagesパネルには、デジグネータの種類(U?、D?、C?など)ごとに1件のエラーのみが表示されます。実際には複数のエラーが存在する場合があります。
コンポーネント内の未使用のサブパート
この違反は、マルチパートコンポーネントのインスタンスの一部のパートが、設計内で使用されていない場合に発生します。たとえば、74HC32コンポーネントのインスタンスに含まれる4つのパートのうち、3つは配置および配線されているものの、4つ目が配置されていない場合です。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Component <Identifier> has unused sub-part(s) (<PartNumber>)
ここで、
-
Identifierは親コンポーネントで、Designator Library Referenceの形式で表されます(例:U11 74HC32)。 -
PartNumberは、使用されていないパートを示す整数です(例:1はパートAを、2はパートBを表し、以降も同様です)。
推奨される解決方法
未使用のパートを配置し、その入力をグランドに接続してください。デジグネータのルート部分を同じにするには、そのコンポーネントのインスタンスの既存のパートをコピーし、貼り付け後にパート番号を適切に増やします。
ドキュメントに関連する違反
デバイスシートのパス解決が不明確
この違反は、シートシンボルのFile Nameフィールドで指定された対象のデバイスシートが、登録されている複数のデバイスシートフォルダ内で見つかった場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Ambiguous Device Sheet Resolution for <DeviceSheetName>
ここで:
-
DeviceSheetNameは、親デバイスシートシンボルのFile Nameフィールドに現在入力されている値です。File Nameフィールドの値とは異なり、メッセージには拡張子(*.SchDoc)も含まれます。
推奨される解決方法
MessagesパネルのDetails領域を使用して、該当するデバイスシートシンボルをクロスプローブします。シンボルをダブルクリックすると、Propertiesパネルでそのプロパティにアクセスできます。パネルのGeneralタブにあるSourceセクションには、現在使用されているデバイスシートのインスタンスへのフルパスが表示されます。
使用されるデバイスシートのインスタンスは、登録されたデバイスシートフォルダ内で最初に検出されたものであることに注意してください。これらのフォルダは、PreferencesダイアログのData Management – Device Sheetsページで登録され、上から順に検索されます。現在使用されているデバイスシートが正しいインスタンスであれば、この違反は無視できます。そうでない場合は、正しいインスタンスが存在するフォルダを選択し、そのフォルダがリストの一番上に来るまでMove Upボタンをクリックしてください。
ただし、これによって該当するデバイスシートの当面の問題は解決できても、曖昧さは依然として残ります。この問題を完全に解決するには、重複しているデバイスシートを特定し、登録されている他のデバイスシートフォルダから削除してください。
ドキュメントの循環依存
この違反は、DesignメインメニューからCreate Sheet Symbol From Sheetコマンドを実行し、Choose Document to Placeダイアログでプロジェクト内ですでに子ドキュメントになっている回路図ドキュメントを選択した際に、選択した回路図ドキュメント間に相互のデバイスシートリンクが存在する場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Circular dependency between document <DocumentName1> and document <DocumentName2>
ここで:
-
DocumentName1とDocumentName2は、相互にデバイスシートリンクを持つ2つのドキュメントの名前です。
推奨される解決方法
エラーメッセージに記載されている回路図ドキュメントを確認し、それらの間のデバイスシートリンクを修正してください。
シートシンボルの子シートが見つからない
この違反は、シートシンボルと対象の回路図サブドキュメント間のリンクが無効な場合に発生します。これは、次の場合に発生する可能性があります。
- シートシンボルが手動で配置されていますが、シンボルの File Name フィールドに下位ドキュメントへの参照が入力されていません。
- シンボルの File Name フィールドに入力されたドキュメント参照が正しくなく、存在しないドキュメントを参照しています。
- 参照先のドキュメントがプロジェクトから除外されたか、削除されています。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Missing child-sheet in <SymbolFileName> in Symbol <SymbolDesignator>
各項目の意味は次のとおりです。
-
SymbolFileNameは、親シートシンボルの File Name フィールドに現在入力されている値です。 -
SymbolDesignatorは、親シートシンボルのデジグネータです。
推奨される解決方法
デザインスペースでシートシンボルを選択し、Propertiesパネルの General タブにある Properties セクションで、シートシンボルの File Name フィールドの入力内容を確認してください。参照先のドキュメント自体は、同じタブの Source セクションで指定します。標準のシートシンボルでは、ソースを Local に設定します。必要な参照先ドキュメントがすでに存在する場合は、ドキュメント名(拡張子を含む)がフィールドに正しく入力されていることを確認してください。参照先ドキュメントがプロジェクトから除外されていて、そのドキュメントにアクセスできる場合は、プロジェクトに再度追加してください。参照先ドキュメントが存在しない場合は、シンボルを右クリックし、Sheet Symbol Actions サブメニューから Create Sheet From Symbol コマンドを選択してください。
注記
このエラーは、デバイスシートシンボルが配置されていても、参照先のデバイスシートが見つからない場合にも発生します。参照先のドキュメント自体は、デザインスペースでデバイスシートシンボルを選択した状態で、Propertiesパネルの General タブにある Source セクションで指定します。デバイスシートシンボルでは、ソースを Device に設定します。
複数の最上位ドキュメント
この違反は、階層設計で2つ以上の回路図シートが階層構造の最上位にある場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Multiple top level documents: <SheetName> has been used
各項目の意味は次のとおりです。
-
SheetNameは、現在最上位シートとして使用されている回路図ドキュメントの名前です。
推奨される解決方法
この問題は通常、本来の最上位シートにあるシートシンボルが、意図した下位シートを正しく参照していない場合に発生します。解決するには、まず、どの回路図シートを下位シートにする必要があるかを確認します。最上位の回路図に、対象の下位シートに対応するシートシンボルが配置されているか確認してください。
- シートシンボルが存在しない場合は、手動で配置するか、メインメニューの Design » Create Sheet Symbol From Sheet コマンドを使用して作成してください。
- シートシンボルが存在する場合は、そのシンボルが下位シートを参照していることを確認してください。デザインスペースでシートシンボルを選択し、Propertiesパネルの General タブにある Properties セクションで、シートシンボルの File Name フィールドの入力内容を確認します。参照先のドキュメント自体は、同じタブの Source セクションで指定します。標準のシートシンボルでは、ソースを Local に設定します。
ポートが親シートシンボルにリンクされていない
この違反は、子シートのポートが親シートシンボルのシートエントリと一致していない場合に発生します。親シートシンボルのすべてのシートエントリは、子シートの対応するポートと同期(一致)している必要があります。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Port <PortName> not matched to Sheet-Entry at <Location>
各項目の意味は次のとおりです。
-
PortNameは、子シートのポート名です。 -
Locationは、ポートの電気的ホットスポットのX、Y座標です。
推奨される解決方法
この問題は、次のような理由で発生することがあります。
- ポートに対応するシートエントリが存在しません。
- ポートに対応するシートエントリは存在しますが、名前が異なっています。
- ポートに対応するシートエントリは存在しますが、I/Oタイプが異なっています。
対象のポートで Ctrl+Double Click を使用して、親シートシンボルに移動します。シートシンボルを右クリックし、表示されるメニューから Sheet Symbol Actions » Synchronize Sheet Entries and Ports を選択します。そのシートシンボルの「ポートとシートエントリの同期」ダイアログが開きます。
このダイアログで、対象のポートを必要なシートエントリと一致させます。シートエントリが存在しない場合は、ダイアログから直接作成できます。シートエントリが存在していても名前やI/Oタイプが異なる場合は、一致させる際に、ポートとシートエントリのどちらの名前とI/Oタイプを使用するかを指定できます。
注記
シートエントリとポートが存在していても名前やI/Oタイプが異なる場合は、シートエントリがポートと一致していないことを示す対応するエラーメッセージも表示されます。シートエントリとポートを同期すると、両方のエラーが解消されます。
シートエントリが子シートにリンクされていない
この違反は、親シートシンボルが参照する子シート上のポートと、シートエントリが一致していない場合に発生します。親シートシンボルのすべてのシートエントリは、子シートの対応するポートと同期(一致)している必要があります。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Sheet-Entry <SheetEntryName> not matched to Port at <Location>
各項目の意味は次のとおりです。
-
SheetEntryNameは、親シートシンボルに関連付けられたシートエントリの名前です。 -
Locationは、シートエントリの電気的ホットスポットのX、Y座標です。
推奨される解決方法
この問題は、次のような理由で発生することがあります。
- シートエントリに対応するポートが存在しません。
- シートエントリに対応するポートは存在しますが、名前が異なっています。
- シートエントリに対応するポートは存在しますが、I/Oタイプが異なっています。
対象のシートエントリが属する親シートシンボルを右クリックし、表示されるメニューから Sheet Symbol Actions » Synchronize Sheet Entries and Ports を選択します。そのシートシンボルの「ポートとシートエントリの同期」ダイアログが開きます。
このダイアログで、対象のシートエントリを必要なポートと一致させます。ポートが存在しない場合は、ダイアログから直接作成できます。ポートが存在していても名前やI/Oタイプが異なる場合は、一致させる際に、シートエントリとポートのどちらの名前とI/Oタイプを使用するかを指定できます。
注記
シートエントリとポートが存在していても、名前やI/Oタイプが異なる場合は、ポートに対応するシートエントリがないことを示すエラーメッセージが表示されます。シートエントリをポートと同期すると、両方のエラーが解消されます。
シート名の重複
この違反は、プロジェクト内の異なるフォルダーに、同じ名前の回路図ドキュメントが複数存在する場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Project <ProjectName> contains several documents named <SchematicDocumentName>
各項目の意味:
-
ProjectNameは、エラーに関連するプロジェクトの名前です。 -
SchematicDocumentNameは、プロジェクト内の他の回路図ドキュメントと同じ名前を持つ回路図ドキュメントです。
推奨される解決方法
問題のある回路図ドキュメントを別の名前で保存します。
ハーネスに関連する違反
ハーネス定義の競合
この違反は、同じハーネスタイプに対して、グラフィック上またはテキスト上(ハーネス定義ファイル内)でハーネスエントリが競合している場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Conflicting Harness Definition for <HarnessType>
各項目の意味:
-
HarnessTypeは、現在競合しているハーネスタイプです。
推奨される解決方法
変更を反映するようにハーネス定義ファイルを更新するか、問題のあるハーネスエントリを削除するか、問題のあるハーネスエントリのHarness Typeを変更します。
ハーネスコネクタタイプの構文エラー
この違反は、ハーネスタイプに無効な文字([ ] { } . : など)が含まれている場合、またはハーネスタイプが空欄の場合に発生します。
Messagesパネルでの通知
Messagesパネルに通知が表示されます。
ハーネスタイプに無効な文字が含まれている場合、次の形式でメッセージが表示されます。
Harness Connector Type <HarnessType> should not contain these characters [] {}. :
各項目の意味:
-
HarnessTypeは、現在競合しているハーネスタイプです。
ハーネスタイプが空欄の場合、次の形式でメッセージが表示されます。
Harness Connector Type cannot be Blank
推奨される解決方法
問題のあるハーネスコネクタを選択した状態で、PropertiesパネルのPropertiesセクションに有効なHarness Typeを指定します。入力内容に無効な文字が含まれていないことを確認してください。
ハーネスコネクタへの無効な接続
この違反は、ワイヤ、バス、または信号ハーネスの終端がハーネスコネクタの内部にあるか、その端に接続されているものの、ハーネスエントリには接続されていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
<ObjectType> (<Location1> To <Location2>) ends inside Harness Connector <HarnessType> but it is not connected to any of its Harness Entries
各項目の意味:
-
ObjectTypeは、問題のあるオブジェクトの種類で、Net(ワイヤの場合)、Bus、またはSignal Harnessです。 -
Location1は、問題のあるオブジェクトの始点のX、Y座標です。 -
Location2は、問題のあるオブジェクトの終点のX、Y座標です。 -
HarnessTypeは、問題のあるハーネスコネクタのハーネスタイプです。
推奨される解決方法
ワイヤ、バス、または信号ハーネスがハーネスコネクタのハーネスエントリに接続されていることを確認するか、ワイヤ/バス/信号ハーネスを編集して、終端がハーネスコネクタの内部に位置せず、その端にも接続されないようにします。
ハーネスのハーネスタイプが未指定
この違反は、シートエントリ同士、またはシートエントリとポートを接続する信号ハーネスに、ハーネスタイプが指定されていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Missing Harness Type on Signal Harness
推奨される解決方法
信号ハーネスに接続されている次のオブジェクトのうち、少なくとも1つにハーネスタイプを指定します。
- ポート – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のGeneralタブにあるPropertiesセクションで、Harness Typeを指定します。
- シートエントリ – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のPropertiesセクションで、Harness Typeを指定します。
ハーネスに複数のハーネスタイプが指定されている
この違反は、1つの信号ハーネスに複数のハーネスタイプが定義されている場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Multiple harness types on harness <HarnessType1>, <HarnessType2>
各項目の意味:
-
HarnessType1とHarnessType2は、信号ハーネスに指定されている複数のハーネスタイプです。
推奨される解決方法
信号ハーネス全体で、ハーネスタイプを1つだけ指定します。
- ポート – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のGeneralタブにあるPropertiesセクションで、Harness Typeを指定します。
- シートエントリ – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のPropertiesセクションで、Harness Typeを指定します。
- ハーネスコネクタ – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のPropertiesセクションで、Harness Typeを指定します。
- ハーネスエントリ – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のPropertiesセクションで、Harness Typeを指定します。
未接続のハーネスエントリ
この違反は、ハーネスエントリにワイヤ、バス、信号ハーネスのいずれも接続されていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Unconnected Harness Entry <Identifier>
各項目の意味:
-
Identifierは、該当するハーネスエントリを識別するために使用されます。識別子はHarnessType-HarnessNameの形式で表示されます。
推奨される解決方法
ハーネスエントリにワイヤ、バス、または信号ハーネスが接続されていることを確認します。
不明なハーネスタイプ
この違反は、ハーネスタイプが存在するものの、それに一致する定義がハーネス定義ファイル内に見つからない場合に発生します。次のいずれかが原因として考えられます。
- 不明なハーネスタイプを持つオブジェクト(シートエントリ、ポート、またはハーネスエントリ)に信号ハーネスが接続されている。
- ハーネス定義ファイル内のハーネスエントリが、不明なハーネスタイプを参照している。
Messagesパネルの通知
Messagesパネルに、次の形式で通知が表示されます。
Unknown Harness Type <HarnessType>
各項目の意味:
-
HarnessTypeは、現在の不明なハーネスタイプです。
推奨される解決方法
シートエントリ、ポート、ハーネスエントリに既知のハーネスタイプが設定されており、ハーネス定義が正確であることを確認してください。
- ポート – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のGeneralタブにあるPropertiesセクションで、Harness Typeを指定します。
- シートエントリ – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のPropertiesセクションで、Harness Typeを指定します。
- ハーネスエントリ – Propertiesパネル(選択したオブジェクトのすべてのプロパティを表示)のPropertiesセクションで、Harness Typeを指定します。
ネットに関連する違反
ハーネス上のバスオブジェクト
この違反は、信号ハーネス内のポート、シートエントリ、またはネットラベルの名前が、バスオブジェクトを示す[X..Y]形式になっている場合に発生します。
Messagesパネルの通知
Messagesパネルに、次の形式で通知が表示されます。
Bus <Object> <ObjectName> at <Location> placed on a harness
各項目の意味:
-
Objectは、違反のあるポート、シートエントリ、またはネットラベルです。 -
ObjectNameは、違反のあるオブジェクトの名前です。 -
Locationは、違反のあるオブジェクトのX、Y座標です。
推奨される解決方法
違反のあるオブジェクトの名前を変更し、バス構文を使用しない名前にしてください。
差動ペアネット接続の極性反転
この違反は、差動ペアネットの極性が、接続先の差動ペアピンの極性と一致しない場合に発生します。たとえば、正極側のネットが負極側のピンに接続されている場合、またはその逆の場合です。
Messagesパネルの通知
Messagesパネルに、次の形式で通知が表示されます。
Inversed connection on differential pair <PairName>: net <NetName> is connected to pin <PinDesignator> (<Polarity>)
各項目の意味:
-
PairNameは、差動ペアの名前です(例:V_TX1)。 -
NetNameは、違反のあるネットの名前です(例:V_TX1_P)。 -
PinDesignatorは、違反のあるネットが接続されているデバイスピンのデジグネータです(例:E6)。 -
Polarityは、ピンの極性です(例:negative)。
推奨される解決方法
接続されたワイヤに付けられたネットラベルの極性が、接続先の差動ペアピンの極性と一致していることを確認してください。たとえば、ピン名がIO_L02N_0でネットラベルがV_TX1_Pの場合は、ネットラベルをV_TX1_Nに変更します。
このタイプの違反メッセージが2つ表示され、一方がデバイスの負極ピンに接続されたペアの正極ネットに関するもので、もう一方が正極ピンに接続された同じペアの負極ネットに関するものである場合は、接続されているネットラベルを入れ替えるだけで解決できます。
差動ペアピンに接続されていない差動ペアネット
この違反は、差動ペアネットが物理デバイスの差動ペアピンに接続されていない場合に表示されます。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Net <NetName> of differential pair <PairName> is not connected to a differential pair pin
各項目の意味は次のとおりです。
-
NetNameは、ペア内の正極または負極のネット名です(例:V_RX1_NまたはV_RX1_P)。 -
PairNameは、差動ペアの名前です(例:V_RX1)。
推奨される解決方法
実際の差動ペアピンは、物理デバイス(Xilinx Virtex-II Pro FPGAデバイスなど)の内部でハードウェアとして配線されています。このようなピンの名前には、識別子としてN(負極)またはP(正極)が含まれることがありますが、名前を変更するだけでピンを差動ピンにすることはできません。
このタイプの違反を解決する際は、次の点を確認してください。
- 差動ペアネット自体は正しいものの、デバイスの誤ったピンに接続または配線されている場合は、正しいピンを特定し、それに合わせてネットラベルを移動します。
- ネットが誤って差動ペアネットとして指定されている場合は、関連するネットラベルを正しい(非差動の)名前に変更し、接続ワイヤーに付いている差動ペアディレクティブを削除します。
- 差動ペアネットが現在接続されているピンを設計でまったく使用しない場合は、ネットラベル、ワイヤー、差動ペアディレクティブを確実に削除し、そのピンにNo ERCマーカーを配置します。
デバイスに正しく接続されていない差動ペア
この違反は、差動ペアネットが物理デバイスの差動ペアピンに正しく接続されていない場合に表示されます。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Misconnected differential pair <PairName>: net <NetName> should be connected to pin <PinDesignator>
各項目の意味は次のとおりです。
-
PairNameは、差動ペアの名前です(例:V_TX1)。 -
NetNameは、ペア内の正極または負極のネット名です(例:V_TX1_NまたはV_TX1_P)。 -
PinDesignatorは、問題のネットが接続されるべきデバイスピンのデジグネーターです(例:E6)。
推奨される解決方法
このタイプの違反は通常、差動ペアネットのワイヤーオブジェクトが、デバイスの対象ピンと電気的に接続されていない場合に発生します。ネットのワイヤーとデバイスのピン自体が正しく接続されていることを確認してください。
重複するネット
この違反は、設計内で同じ名前のネットが2つ検出された場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Duplicate Net Names <Object> <NetName>
各項目の意味は次のとおりです。
-
Objectは、Wire、Bus Slice、またはElement[n](バス要素の場合)のいずれかです。 -
NetNameは、該当するネットの名前です。
推奨される解決方法
この違反は、たとえば次のような場合に発生します。
-
設計がフラット構造で、設計内でポートが使用されている場合。Net Identifier Scopeは、自動(または手動)で
Flat (Only ports global)に設定されます。シート間で同じネットラベルを使用すると、この違反が発生します。これは、各シートで定義されたネットラベルは、同じ名前であってもそのシート内でのみ有効なためです。この場合は、シート間でネットラベルが重複しないようにしてください。 - 異なる名前のポートやオフシートコネクターを誤って使用したため、フラット化された回路図シート間でネットの連続性が途切れている場合。各シートの入力/出力ポートまでネットをたどり、ポート名が同じであることを確認してください。
- 階層設計の2つの異なる分岐で、同じネットを使用している場合。つまり、異なるシートシンボルが異なる子シートを参照しているものの、最上位のシートエントリと下位のポートに同じ名前が使用され、2つのシンボルが物理的なワイヤーまたはバスで接続されている場合です。異なる名前のシートエントリを誤って使用したり、シートエントリを接続する物理的なバスやワイヤーが欠けていたりすると、これらの分岐間でネットの連続性が途切れることがあります。2つのシートシンボルを接続する物理的なワイヤーが存在し、正しく配線されていること、およびシートエントリの名前が同じであることを確認してください。
外部ファイルと回路図のネット名が同期されていない
この違反は、回路図上のFPGAコンポーネントのピンのネット名が、外部ソースファイルのピンのネット名と一致しない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
External <NetLabelName> and Schematic <NetLabelName> are Unsynchronized for Pin <xx>
各項目の意味は次のとおりです。
-
NetLabelNameは、問題のネットラベルの名前です。 -
xxは、ピン番号です。
推奨される解決方法
Pin Mapperダイアログで問題のピンを選択し、Schematic領域で解決方法のドロップダウンオプションを開き、Update Pin File(
)を選択して、回路図のネット名を外部FPGAピンファイルに転送します。その後、プロジェクトの検証を再実行してください。
未接続のネットラベル
この違反は、設計内で未接続のネットラベル、つまりワイヤーやバスオブジェクトに接続されていないネットラベルが検出された場合に発生します。また、バス電源ポートオブジェクトが回路の他の部分と電気的に接続されていない場合にも、このメッセージが表示されます。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Floating Net Label <NetLabelName>
各項目の意味は次のとおりです。
-
NetLabelNameは、問題のあるネットラベルの名前です。
推奨される解決方法
問題のあるネットラベルオブジェクトが、必要なワイヤまたはバスオブジェクトに接続されていることを確認してください。ネットラベルが不要な場合は、設計から削除してください。
ワイヤ/バスオブジェクトと、それに関連付けられたネットラベルがグリッド上にあることも確認してください。オブジェクトは、手動で、または Edit » Align » Align To Grid コマンドを使用してグリッド上に戻すことができます。
フローティング状態の電源オブジェクト
この違反は、設計内で電源ポートオブジェクトがフローティング状態、つまりコンポーネントに電気的に接続されていない状態であることが検出された場合に発生します。たとえば、電源ポートが配置されていても、回路の他の部分にまだ配線されていない場合です。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Floating Power Object <NetName>
ここで:
-
NetNameは、フローティング状態の電源ポートオブジェクトに関連付けられているネットの名前です。
推奨される解決方法
問題のある電源ポートオブジェクトが、必要に応じて回路に接続されていることを確認してください。電源ポートが不要な場合は、設計から削除してください。
注記
このメッセージは、標準の単一信号電源ポートオブジェクトに関するものです。
グローバル電源オブジェクトのスコープ変更
この違反は、ポートベースのオブジェクト(ポート、オフシートコネクタ)が電源ポートオブジェクトに接続された場合に発生します。電源オブジェクトは、グローバル電源ネットに接続されたグローバルレベルのオブジェクトではなくなり、ローカルレベルの電源ネットに変更されます。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Global Power-Object <NetName> at <Location1> has been reduced to local level by presence of port at <Location2>
ここで:
-
NetNameは、電源ポートオブジェクトに関連付けられているネットです。 -
Location1は、電源ポートオブジェクトの電気的ホットスポットのX、Y座標です。 -
Location2は、ポートオブジェクトの電気的ホットスポットのX、Y座標です。
推奨される解決方法
この違反は通常、電源ポートオブジェクトが、本来接続すべきピンやシートエントリではなく、誤ってポートに配線されている場合に発生します。ただし、このようなスコープ変更を意図的に適用して使用したい場合もあります。ポートと電源ポートの接続が意図したものかどうかを確認し、意図したものでない場合は、電源ポートを削除して、残ったポートオブジェクトを本来の接続先に適切に配線してください。
バスに接続されたハーネスオブジェクト
この違反は、ポート、シートエントリ、ハーネスエントリなどのオブジェクトに、シグナルハーネスへの接続を表すハーネスタイプが関連付けられているにもかかわらず、そのオブジェクトがバスに配線されている場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Harness <Object> <ObjectName> at <Location> placed on bus
ここで:
-
Objectは、問題のあるポート、シートエントリ、またはハーネスエントリです。 -
ObjectNameは、問題のあるオブジェクトのラベルです。 -
Locationは、問題のあるオブジェクトのX、Y座標です。
推奨される解決方法
問題のあるオブジェクト(ポート、シートエントリ、またはハーネスエントリ)が、バスではなくシグナルハーネスに接続されていることを確認してください。
ワイヤに接続されたハーネスオブジェクト
この違反は、ポート、シートエントリ、ハーネスエントリなどのオブジェクトに、シグナルハーネスへの接続を表すハーネスタイプが関連付けられているにもかかわらず、そのオブジェクトがワイヤに接続されている場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Harness <Object> <ObjectName> at <Location> placed on wire
ここで:
-
Objectは、問題のあるポート、シートエントリ、またはハーネスエントリです。 -
ObjectNameは、問題のあるオブジェクトのラベルです。 -
Locationは、問題のあるオブジェクトのX、Y座標です。
推奨される解決方法
問題のあるオブジェクト(ポート、シートエントリ、またはハーネスエントリ)が、ワイヤではなくシグナルハーネスに接続されていることを確認してください。
差動ペアの負極性ネットの欠落
この違反は、設計内の特定の差動ペアオブジェクトについて、負極性ネットが検出されなかった場合に表示されます。このペアの正極性ネットは存在しています。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Missing Negative Net for differential pair <PairName>, positive net <NetName>
ここで:
-
PairNameは、正極性ネットがすでに定義されている差動ペアの名前です(例:V_RX1)。 -
NetNameは、正極性ネットの名前です(例:V_RX1_P)。
推奨される解決方法
この違反は通常、次のような状況で発生します。
-
信号ペアの負極性ワイヤに差動ペアディレクティブが付加されていません。必要なネットラベル(例:
V_RX1_N)は、ワイヤに適切に付加されています。 -
信号ペアの負極性ワイヤに、適切な名前のネットラベル(例:
V_RX1_N)が付加されていません。必要な差動ペアディレクティブは、ワイヤに適切に付加されています。
この違反を解決するには、ペアの負極性ワイヤオブジェクトを見つけ、ネットラベルと差動ペアディレクティブの両方が付加されていること、およびネットラベルの名前が適切に指定されていることを確認してください。負極性ワイヤのネットラベルは、基本的に正極性ワイヤのものと同じですが、接尾辞が _P ではなく _N になります。また、負極性ワイヤオブジェクトが適切な名前のポートオブジェクトに接続されている場合は、ワイヤにネットラベルを付加する代わりに、Project OptionsダイアログのOptionsタブで Allow Ports to Name Nets オプションを有効にすることもできます。
差動ペアの正極性ネットの欠落
この違反は、設計内の特定の差動ペアオブジェクトについて、正極性ネットが検出されなかった場合に表示されます。このペアの負極性ネットは存在しています。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Missing Positive Net for differential pair <PairName>, negative net <NetName>
ここで:
-
PairNameは、正極性ネットがすでに定義されている差動ペアの名前です(例:V_RX1)。 -
NetNameは負極性ネットの名前です(例:V_RX1_N)。
推奨される解決方法
この違反は通常、次の状況で発生します。
-
信号ペアの正極性ワイヤに差動ペアディレクティブが接続されていません。必要なネットラベル(例:
V_RX1_P)は、ワイヤに正しく接続されています。 -
信号ペアの正極性ワイヤに、適切な名前のネットラベル(例:
V_RX1_P)が接続されていません。必要な差動ペアディレクティブは、ワイヤに正しく接続されています。
この違反を解決するには、ペアの正極性ワイヤオブジェクトを見つけ、ネットラベルと差動ペアディレクティブの両方が接続されていること、およびネットラベルの名前が要件どおりに指定されていることを確認します。正極性ワイヤのネットラベルは、基本的に負極性ワイヤと同じですが、接尾辞が _N ではなく _P になります。あるいは、正極性ワイヤオブジェクトが適切な名前のポートオブジェクトに接続されている場合は、ワイヤにネットラベルを接続する代わりに、Project OptionsダイアログのOptionsタブでAllow Ports to Name Netsオプションを有効にできます。
名前のないネットパラメーター
この違反は、パラメーターセットオブジェクトがネットオブジェクト(ワイヤまたはバス)に接続されており、そのセット内で定義されているパラメーターの少なくとも1つに名前が割り当てられていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Invalid net-parameter name at <Location>
各項目の意味は次のとおりです。
-
Locationは、ネットに関連付けられたパラメーターセットオブジェクトのホットスポットのX、Y座標です。
推奨される解決方法
問題のあるパラメーターセットオブジェクトのPropertiesパネルのParameter Setモードにアクセスし、内部で定義されているすべてのパラメーターに名前が割り当てられていることを確認します。問題のあるパラメーターが不要な場合は、セットから削除してください。
値のないネットパラメーター
この違反は、パラメーターセットオブジェクトがネットオブジェクト(ワイヤまたはバス)に接続されており、そのセット内で定義されているクラスの少なくとも1つに値が割り当てられていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Invalid net-parameter value at <Location>
各項目の意味は次のとおりです。
-
Locationは、ネットに関連付けられたパラメーターセットオブジェクトのホットスポットのX、Y座標です。
推奨される解決方法
デザインスペースで問題のあるパラメーターセットオブジェクトを選択し、Propertiesパネルでそのプロパティにアクセスします。パネルのClassesセクションで定義されているすべてのパラメーターに値が割り当てられていることを確認します。問題のあるクラスパラメーターが不要な場合は、セットから削除してください。
フローティング入力ピンを含むネット
この違反は、設計内に配置された部品の入力ピンがフローティング状態、つまり回路の他のどの部分にも電気的に接続されていないことが検出された場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Net <NetName> contains floating input pins (<PinList>)
各項目の意味は次のとおりです。
-
NetNameは、問題のあるネットの名前です。 -
PinListは、そのネット内でフローティング状態にあるピンのカンマ区切りのリストです。
推奨される解決方法
この違反は、さまざまな状況で発生する可能性があります。この種類の違反を解決する際は、次の点を検討してください。
-
設計内でそのピンを使用しない場合は、適切な電源ライン(例:
GND)に接続するか、No ERCディレクティブを配置します。 - ピンへの配線が電気的に接触していること、つまりワイヤまたはバスがピンの電気的ホットスポットに接続されていることを確認します。
- Navigatorパネルを使用して、問題のあるピンが属する親ネットの接続をたどります。ネット内の別の場所に断線があると、ピンがフローティング状態になることがあります。たとえば、ピンがシート上の入力ポートから信号を受け取り、そのポートには設計階層の上位にあるリンクされたシートエントリから信号が供給されている場合、そのシートエントリへの入力が切断されている可能性があります。シートエントリへの接続を修正すると、フローティング入力ピンの違反が解消されます。
- Messagesパネルで、同じ親ネットに関連する他の違反メッセージ、特に未接続のオブジェクトに言及しているメッセージを確認します。これにより、接続が途切れている場所を特定する手がかりが得られます。
同種のオブジェクトを複数含むネット
この違反は、同じ種類(ピン、ポート、シートエントリ)で、同じ電気的I/O仕様を持つ2つ以上のオブジェクトが、同じ親ネット内で互いに接続されていることが検出された場合に発生します。たとえば、Input Port が Input Port に接続されている場合です。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Net <NetName> contains multiple <ObjectType> (<ObjectList>)
各項目の意味は次のとおりです。
- NetName は、問題のあるネットの名前です。
- ObjectType は、問題のあるネット内で複数のインスタンスが見つかったオブジェクトの種類です。この項目には、オブジェクトの電気的タイプも反映されます。
- ObjectList は、問題のあるネット内で見つかった、そのオブジェクトのすべてのインスタンスのカンマ区切りのリストです。
推奨される解決方法
問題のある接続済みオブジェクトが実際に接続上の問題を引き起こしているかどうかを判断し、問題がある場合は、一方または両方のオブジェクトのI/O仕様を適切に変更します。オブジェクトが不要な場合は、設計から削除します。オブジェクトを設計の別の部分に配線する意図だったにもかかわらず、誤った接続先に接続されている(その結果、誤ったネットの一部になっている)場合は、現在のネットから切り離し、正しいネットに配線し直してください。
注記
- このタイプの違反に実際に使用されるレポートモードは、具体的なオブジェクトタイプ、電気的I/Oタイプ、および Options for Project ダイアログ(Project » Project Options)の 接続マトリクス タブで定義されている対応するレポートレベルによって決まります。
-
Options for Project ダイアログの エラーレポート タブにある Report Mode 設定は、このタイプの違反について Messages パネルに表示される Report Mode 設定には影響しません。ただし、この設定は、設計スペース内で直接行われるオンライン(リアルタイム)エラーレポートに使用されます。オンラインレポートのコントロールは、 Preferences ダイアログの 回路図 – コンパイラ ページにあります。接続マトリクスで、特定のオブジェクトタイプとI/Oタイプの組み合わせに対する個別のチェックが
No Reportに設定されている場合、その組み合わせに対するオンラインエラーレポートは表示されません。
複数の名前を持つネット
この違反は、設計内のネットに複数の名前が関連付けられていることが検出された場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Nets <Identifier> has multiple names (<NameList>)
各項目の意味は次のとおりです。
-
Identifierは、接続のタイプとネット名を表します。接続は次のいずれかになります。-
Wire – 識別子は
Wire NetNameの形式で表示されます(例:Wire DTSA)。 -
Bus – 識別子は
Bus Slice NetNameの形式で表示されます(例:Bus Slice A[0..7])。 -
Bus Element – 識別子は
Element[n]: NetPrefixの形式で表示されます(例:Element[0]: A)。
-
Wire – 識別子は
-
NameListは、問題のあるネットに関連付けられているすべての名前をカンマで区切ったリストです。これらの名前は、接続されているネットラベル、シートエントリ、パワーポート、オフシートコネクタに由来します。
推奨される解決方法
この違反は、特定のネットに関連付けられているすべてのネット識別子の名前を同じにすることで解決できます。ただし、多くの場合、特定のネットに異なる名前を使用することが有用です。たとえば、階層設計の異なる分岐に同じネットが存在し、それぞれの分岐を通る信号を異なる名前で表した方が適切な場合です。同様に、特定のシートシンボルのシートエントリに、入出力ワイヤやバスに接続されたネットラベルとは異なる名前を付けたい場合もあります。
設計内のネットに複数の名前を自由に使用し、関連する違反メッセージが Messages パネルに表示されないようにするには、 Options for Project ダイアログ(Project » Project Options)の エラーレポート タブで、この違反タイプの Report Mode を No Report に設定します。
駆動源のないネット
この違反は、設計内のネットに駆動源がないことが検出された場合に発生します。つまり、そのネットには、次のいずれかの電気的タイプを持つピンが1つも含まれていません。
- 入出力
- 出力
- オープンコレクタ
- ハイインピーダンス
- オープンエミッタ
- 電源
ネットにこれらのタイプのピンが含まれないことは珍しくありません。たとえば、次のような場合に発生します。
- ネットがコネクタのピンから入力ピンに接続されている。
- ネットが直列に接続された受動部品(受動ピンを持つ部品)から入力ピンに接続されている。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Net <NetName> has no driving source (<PinList>)
各項目の意味は次のとおりです。
-
NetNameは、問題のあるネットの名前です。 -
PinListは、そのネット内のピンをカンマで区切ったリストです。
推奨される解決方法
コネクタまたは受動部品のピンを編集し、その電気的タイプを上記のいずれかに変更します。
ピンが1つしかないネット
この違反は、部品のピンが電気的オブジェクト(ワイヤやネットラベルなど)に接続されていて、そのピンがネットに属していることが示されているものの、そのネットにほかのピンが存在しない場合に発生します。通常、これは配線ミスがある場合や、未使用の部品ピンにワイヤの一部が接続されている場合に発生します。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
Net <NetName> has only one pin (Pin <PinName>)
各項目の意味は次のとおりです。
-
NetNameは、所属するネットの名前です。 -
PinNameは、部品デジグネータとピンデジグネータからなる識別子です。
推奨される解決方法
デフォルトでは、このメッセージは Messages パネルに表示されません。この違反タイプのレポートを有効にしていて、問題を解決したい場合は、問題のあるネットが設計内の少なくとも2つの部品ピンに配線されていることを確認してください。
接続に問題がある可能性のあるネット
この違反は、同じネット上で互いに接続されている2つのオブジェクトの電気的タイプが一致せず、接続に問題が生じる可能性がある場合に発生します。このエラーチェックの対象となるオブジェクトタイプのペアは、ピン、ポート、シートエントリの任意の組み合わせです。たとえば、 Output Port が Bidirectional Portに接続されている場合です。
Messagesパネルでの通知
Messages パネルに、次の形式で通知が表示されます。
<NetName> contains <ObjectType1> and <ObjectType2> objects (<Reference>)
各項目の意味は次のとおりです。
- NetName は、競合する可能性のあるオブジェクトが属するネットの名前です。
- ObjectType1 は、問題のある1つ目のオブジェクトのタイプです。
- ObjectType2 は、問題のある2つ目のオブジェクトのタイプです。
-
Reference は、一方または両方のオブジェクトの識別子です(例:
Port PortName、Pin PinName、and Sheet EntrySheetSymbolName-SheetEntryName)。
推奨される解決方法
問題のある接続オブジェクトが実際に接続上の問題を引き起こすかどうかを判断し、問題がある場合は、一方または両方のオブジェクトのI/O仕様を適切に変更します。
注記
- このタイプの違反に実際に使用されるレポートモードは、具体的なオブジェクトタイプ、電気的I/Oタイプ、および Options for Project ダイアログ(Project » Project Options)の 接続マトリクス タブで定義されている対応するレポートレベルによって決まります。
-
Options for Project ダイアログの エラーレポート タブにある Report Mode 設定は、このタイプの違反について Messages に表示される Report Mode 設定には影響しません。パネル。ただし、この設定はデザインスペース内で直接行われるオンライン(リアルタイム)エラーレポートで使用されます。オンラインレポートの設定は、PreferencesダイアログのSchematic – Compilerページで行えます。なお、Connection Matrixで特定のオブジェクトタイプとI/Oタイプの組み合わせに対する個別のチェックが
No Reportに設定されている場合、その組み合わせに対するオンラインエラーレポートは表示されません。
対応するポートがないポート
この違反は、対応するポートがない場合、またはポートが接続されていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
<Port> Port with no matching ports detected at <Location>
各項目の意味:
- Portは、問題のポートの名前です。
- Locationは、問題のポートのX、Y座標です。
推奨される解決方法
プロジェクト内のいずれかのソース回路図ドキュメントに対応するポートを配置するか、必要に応じて問題のポートを接続してください。
注記
-
この種類の違反は、 Project OptionsダイアログのOptionsタブにある Net Identifier Scope オプションが
Flat (Only ports global)またはGlobal (Netlabels and ports global)に設定されている場合にのみ検出されます。
複数の差動ペアで使用されている同一ネット
この違反は、デザイン内の複数の差動ペアオブジェクトで、同じ極性(正または負)の同一ネットが検出された場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Net <NetName> is used in more than one differential pair objects: <ObjectList>
各項目の意味:
-
NetNameは、複数の差動ペアオブジェクトで使用されている正極性または負極性のネットの名前です(例:V_RX1_NまたはV_RX1_P)。 -
ObjectListは、問題のネットが使用されている差動ペアオブジェクトの一覧です。差動ペア名はネット名のルート部分から取得されるため、この一覧の名前はすべて同じになります(例:V_RX1 V_RX1)。
推奨される解決方法
この違反は通常、差動ペアディレクティブが配置されている複数のワイヤオブジェクトに、同じネットラベルが付けられている場合に発生します。問題のネットラベルオブジェクトを見つけ、必要に応じて名前を修正してください。
ペアを構成する正極性と負極性のワイヤには、同じルート名にそれぞれ_Pと_Nの接尾辞を付けたネットラベルを関連付ける必要があります。たとえば、あるペアの2本のワイヤに同じネットラベルV_RX1_Nが付いている場合、正極性ワイヤのネットラベルをV_RX1_Pに変更してください。
重複するポートを含むシート
この違反は、デザイン内の同じ回路図シート上で、同じ名前のポートが2つ検出された場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Sheet contains duplicate ports Port <Identifier> at <Location1> and <Location2>
各項目の意味:
-
Identifierは、問題のポートの名前です。 -
Location1は、そのポートの最初のインスタンスのX、Y座標です。 -
Location2は、そのポートの2番目のインスタンスのX、Y座標です。
推奨される解決方法
重複するポートオブジェクトのうち、どちらに問題があるかを確認し、名前を変更するか、デザインから削除してください。
ネット内の未接続オブジェクト
この違反は、ピン、ポート、またはシートエントリオブジェクトが回路の他の部分に配線されていない場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Unconnected <Object> at <Location>
各項目の意味:
-
Objectは、問題のオブジェクト(ピン、ポート、またはシートエントリ)の種類と名前です。 -
Locationは、ソース回路図シート上のオブジェクトのX、Y座標です。
推奨される解決方法
このエラーを解決するには、以下を検討してください。
- ピン、ポート、またはシートエントリを使用する場合は、回路の他の部分に適切に配線されていることを確認してください。
- ポートまたはシートエントリが不要な場合は、デザインから削除してください。
- 未使用の入力ピンは、適切な電源ラインに接続してください。
- 未使用の入力ピンまたは出力ピンには、No ERCディレクティブを配置してください。
注記
- 未接続のオブジェクトが入力ピンの場合、そのピンが属するネットにフローティング状態の入力ピンが含まれていることを知らせる違反メッセージも表示されます。そのメッセージには、該当するピンの識別子が記載されます。
- この種類の違反に実際に使用されるレポートモードは、オブジェクトの種類、その電気的I/Oタイプ、および Options for Project ダイアログの Connection Matrixタブで定義されている対応するレポートレベルによって決まります(Project » Project Options)。
- Options for Project ダイアログの Error ReportingタブにあるReport Mode設定は、この種類の違反について Messagesパネルに表示されるReport Mode設定には影響しません。ただし、この設定はデザインスペース内で直接行われるオンライン(リアルタイム)エラーレポートで使用されます。オンラインレポートの設定は、PreferencesダイアログのSchematic – Compilerページで行えます。
未接続のワイヤ
この違反は、ワイヤオブジェクトがフローティング状態、つまり回路デザインのどの部分にも電気的に接続されていない状態であると検出された場合に発生します。
Messagesパネルでの通知
Messagesパネルに、次の形式で通知が表示されます。
Unconnected line <Location1> To <Location2>
各項目の意味:
-
Location1は、フローティング状態のワイヤの始点のX、Y座標です。 -
Location2は、フローティング状態のワイヤの終点のX、Y座標です。
推奨される解決方法
問題のワイヤオブジェクトが、必要に応じて回路に接続されていることを確認してください。ワイヤが不要な場合は、デザインから削除してください。ワイヤ(またはその他のオブジェクト)がシートの外にあり、直接選択できない場合は、Edit » Select » Outside Areaコマンドを使用して選択してから削除してください。
その他に関連する違反
重複するプロジェクトファイル
この違反は、Workspaceプロジェクトのフォルダー内で、複数のプロジェクトファイル(.PrjPCB)が見つかった場合に発生します。
通知
Messagesパネルに、次の形式で通知が表示されます。
Duplicate .PrjPcb files found in this project, which can cause design files to display incorrectly in a web browser. To fix this, please remove any extra .PrjPcb files from your project folder.
推奨される解決方法
プロジェクトフォルダーに.PrjPcbファイルが1つだけ含まれるように、余分な .PrjPcbファイルを削除してください。
代替部品を追加できない
この違反は、アクティブな設計プロジェクトで定義されたバリアントのコンポーネントに使用するために選択した代替部品を追加できない場合に発生します。これは、同じ名前で異なるライブラリに存在する部品が、プロジェクトの異なるバリアントで使用されている場合に起こります。選択した代替部品の情報を保存する .PrjPcbVariants ファイルは、同じ名前の部品を複数保存できないため、異なるライブラリにある他のインスタンスへの参照は追加されません。たとえば、配置済みのコンデンサに対して代替部品を選択した、次のような設計プロジェクトのバリアントが定義されている場合を考えます。
-
Variant 1 – ライブラリ
Lib1.SchLibにある代替部品Capを選択。 -
Variant 2 – ライブラリ
Lib2.SchLibにある代替部品Capを選択。
未接続のディレクティブオブジェクト
この違反は、パラメータセットディレクティブ、NoERCディレクティブ、差動ペアディレクティブ、またはプローブオブジェクトが未接続の場合に発生します。
通知
Messages パネルに、次の形式で通知が表示されます。
Floating <Parameter Set directive, NoERC directive, Differential Pair directive, or Probe object> at <Location>,
ここで、
-
Parameter Set directive, NoERC directive, Differential Pair directive, or Probe objectは、設計スペース内にある未接続のオブジェクトです。 -
Locationは、未接続のオブジェクトのX、Y座標です。
推奨される解決方法
未接続のパラメータセットディレクティブ、NoERCディレクティブ、差動ペアディレクティブ、またはプローブオブジェクトを、本来の接続先に接続してください。
プロジェクトバリアント内の不正なリンク
この違反は、アクティブな設計プロジェクトで定義されたバリアントにおいて、マルチパートコンポーネントの Alternate Part としてシングルパートコンポーネントが選択され、元のベース設計のコンポーネントのパートが設計内に複数配置されている場合に発生します。たとえば、8つのサブパートを持つ独立型抵抗ネットワークであるマルチパートコンポーネントR1がベース設計にあるとします。また、そのうち4つのパート(R1A、R1B、R1C、R1D)が配置されているとします。ここで、そのベース設計のバリアントが定義され、元のベース部品の代わりに使用する代替部品が選択されている場合を考えます。選択する部品も、設計で現在使用されている4つのサブパートを問題なく置き換えられるマルチパートコンポーネントである必要があります。しかし、誤ってシングルパートの抵抗コンポーネントを代替部品として選択すると、既存のサブパートR1B、R1C、R1Dを置き換えることができません。そのため、コンパイラはこれを不正なリンクとして報告します。
通知
Messages パネルに、次の形式で通知が表示されます。
Incorrect link between project variant "<VariantName>" and schematic component Component <ComponentPhysicalDesignator> (<ComponentLogicalDesignator>) <BasePartComment>
ここで、
-
VariantNameは、誤った代替コンポーネントが定義されている設計バリアントの名前です。 -
ComponentPhysicalDesignatorは、該当するコンポーネントの物理デジグネータです(そのコンポーネントが配置されている回路図ドキュメントのコンパイル済みタブビューに表示されるデジグネータ)。 -
ComponentLogicalDesignatorは、該当するコンポーネントの論理デジグネータです(そのコンポーネントが配置されている回路図ドキュメントの Editor タブビューに表示されるデジグネータ)。論理デジグネータと物理デジグネータが同じ場合、この項目は表示されません。 -
BasePartCommentは、ベース設計で定義されている、該当するコンポーネントの Comment パラメータの値です。
推奨される解決方法
元のマルチパートコンポーネントのうち1つのパートだけを使用している場合は、配置済みの他のインスタンスを削除して、プロジェクトを再度検証するだけで解決できます。代替部品はシングルパートコンポーネントなので、元のマルチパートコンポーネントで使用している1つのパートを置き換えるには十分です。
ただし、この方法は有効ではあるものの、必ずしも望ましい方法ではありません。根本的な問題の解決というより、応急処置に近いものです。より適切な方法は、該当する設計バリアントで、そのコンポーネントにより適した代替部品を選択することです。以下の手順を実行してください。
-
Projectsパネルで、親プロジェクトの
Variantsフォルダから該当するバリアントを現在のバリアントに設定します。ドキュメントの Compiled タブに切り替え、ベースのマルチパートコンポーネントのパートを右クリックして、Part Actions » Variants を選択します。Variant Managementダイアログが開き、選択したバリアントの only にある問題のコンポーネント only が表示されます。 - Component Variation フィールドを使用して、Edit Component Variationダイアログを開きます。
- Alternate Part オプションを選択したまま、ダイアログ内の他のオプションを使用して、その設計バリアントで使用する、より適切な置換用コンポーネントを参照して選択します。
- OK をクリックしてダイアログを閉じ、設計プロジェクトを再度検証します。不正なリンクの違反は解消され、表示されなくなるはずです(同じ問題のあるコンポーネントが複数ある場合は、前述の手順を繰り返してください)。
オブジェクトがシートの境界内に完全に収まっていない
この違反は、設計オブジェクトが回路図シートの範囲外にある場合に発生します。
通知
Messages パネルに、次の形式で通知が表示されます。
Off sheet <ObjectIdentifier> at <Location>
ここで、
-
ObjectIdentifierは、シートで定義された境界内に現在完全に収まっていないオブジェクトを識別します。識別子は、オブジェクトの種類と名前/デジグネータで構成されます(例:Port <PortName>)。 -
Locationは、オブジェクトの電気的ホットスポットのX、Y座標です。
推奨される解決方法
シート上にオブジェクトを配置または貼り付ける際は、シートの境界の外側には配置/貼り付けできません。この問題は通常、オブジェクトの配置後にシートのサイズや向きを変更した場合に発生します。問題を解決するには、次の方法を検討してください。
- シートの向きを変更します。
- より大きなシートサイズを選択します。
- 問題のオブジェクトをシートの境界内に戻します。
最初の2つの操作は、Propertiesパネルの General タブにある Page Options セクションで実行します(設計スペースでオブジェクトが何も選択されていないときにアクセスできます)。シートサイズの変更が、この問題を解決する最も簡単な方法です。オブジェクトを手動で移動する場合は、問題のオブジェクトを収めるのに十分なスペースを確保するため、回路のレイアウト変更が必要になることがあります。
グリッドから外れたオブジェクト
この違反は、オブジェクトが現在のスナップグリッドに整列していない場合に発生します。
通知
Messages パネルに、次の形式で通知が表示されます。
Off grid <ObjectIdentifier> at <Location>
ここで、
-
ObjectIdentifierは、現在グリッドから外れている特定のオブジェクトを識別します。識別子は、オブジェクトの種類とその名前/デジグネーターで構成されます(例:Pin <PinDesignator>)。 -
Locationは、オブジェクトの電気的ホットスポットのX、Y座標です。
推奨される解決方法
PropertiesパネルのGeneralタブにあるGeneralセクションで、スナップグリッドが要件に応じて定義され、有効になっていることを確認してください(このパネルは、デザインスペースで何もオブジェクトを選択していないときにアクセスできます)。違反のあるオブジェクトは、手動で、または Edit » Align » Align To Grid コマンドを使用してグリッド上に戻すことができます。
パラメーターに関連する違反
同じ名前のパラメーターに異なる型が設定されている
この違反は、同じ名前を持つ2つのパラメーターが同じ設計オブジェクトに割り当てられているものの、それらの型が異なる場合に発生します。
通知
Messagesパネルに、次の形式で通知が表示されます。
Same parameter contains different types <Object> <Types>
各項目の意味は次のとおりです。
-
Objectは、違反のあるパラメーターが関連付けられている特定のオブジェクトです。 -
Typesは、そのパラメーターの異なる型をペアで示します(例:BOOLEANとSTRING)。
推奨される解決方法
通常、同じ名前の複数のパラメーターを1つのオブジェクトに関連付けることはありません。オブジェクトに割り当てられているパラメーターを確認し、誤ったパラメーターや重複するパラメーターを削除してください。
同じ名前のパラメーターに異なる値が設定されている
この違反は、同じ設計オブジェクトに割り当てられた2つのパラメーターが、同じ名前と同じ型を持つものの、値が異なる場合に発生します。
通知
Messagesパネルに、次の形式で通知が表示されます。
Same parameter contains different values <Object> <Values>
各項目の意味は次のとおりです。
-
Objectは、違反のあるパラメーターが関連付けられている特定のオブジェクトです。 -
Valuesは、そのパラメーターの異なる値をペアで示します。
推奨される解決方法
通常、同じ名前の複数のパラメーターを1つのオブジェクトに関連付けることはありません。オブジェクトに割り当てられているパラメーターを確認し、誤ったパラメーターや重複するパラメーターを削除してください。


