マルチシートおよび階層設計
Altium Essentials: Navigating Schematics
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- フラット構造と階層構造のマルチシート設計の違いと、それぞれがどのような場合に適しているかを理解できます。
- マルチシート構成によって、可読性、チームでの共同作業、モジュール性、印刷の利便性が向上する理由を学べます。
- Altium Designerでシートシンボルを使ってサブシートを表し、回路図の構造を構成する方法を確認できます。
回路図が紙に描かれていた頃は、大きな製図台を埋め尽くすほどの大判の用紙1枚に描き、専用の大判コピー機で複製するのが一般的でした。時代は変わり、今では回路図はデスクトップPCで作成され、サーバーに保存され、小型のレーザープリンターで印刷されています。
こうした変化により、単純な設計であっても、複数の回路図シートに分けて表現するほうが、見やすく理解しやすくなります。特に複雑な設計でなくても、複数のシートに分けて整理することには利点があります。
たとえば、設計にさまざまなモジュール要素が含まれている場合があります。これらのモジュールを個別のドキュメントとして管理すれば、複数の設計者が同時にプロジェクトに取り組めます。また、設計を論理的なモジュールに分割すると、設計の可読性も大幅に向上します。これは、製品のライフサイクルの後の段階で回路図を読み解く必要がある人にとって、重要な考慮事項です。もう1つの利点は、設計を複数のシートに分け、各シートの部品数を減らすことで、レーザープリンターなどの小型プリンターで印刷できることです。
設計を複数のシートに分ける場合は、次の2点を決める必要があります。
-
シート間の構造上の関係
-
各シート上の回路を電気的に接続する方法
どのようにするかは、各プロジェクトの規模や種類、設計者自身の好みによって異なります。
フラット設計と階層設計
前述のとおり、設計者は回路図シートをどのように構成し、シート間の接続をどのように確立するかを決める必要があります。ただし、これらは別々に決めることではありません。構造を選ぶ際には、シート間の接続をどのように作成するかも選ぶ必要があります。
マルチシート設計の構成方法には、flatとhierarchicalの2つがあります。
どちらの方法も有効であり、 それぞれに長所と短所があります。フラット設計は短時間で作成できますが、 ほかの人が信号を追跡したり、機能を読み解いたりするのが難しくなります。特に印刷物では、その傾向が顕著です。 階層設計では、接続を作成するための手順が多いため、作図に時間がかかりますが、 その分、ほかの人が機能を理解しやすく、 シートをまたいで信号を追跡しやすい設計になります。階層設計は、設計の再利用においても重要であり、 マルチチャネル設計には欠かせません。
フラット設計
フラット設計は、1枚の大きな回路図シートを複数の小さなシートに切り分けたものと考えることができます。フラット設計では、すべてのシートが同じ階層に存在します。フラット設計の接続は、任意のシートからほかの任意のシートへ直接作成されます。このような接続は、水平接続と呼ばれます。
フラット設計では、トップシートの使用は任意です。トップシートを含める場合は、設計内の各シートに対応するシートシンボルを配置しますが、配線を含めることはできません。フラット設計のシート数に制限はありません。

1枚目の図:トップシートのないフラット設計。2枚目の図:同じ設計にトップシートを追加したもの。トップシートには配線がないことに注目してください。設計内のシートを示しているだけです。
上の2つの図は、どちらもフラット設計を示しています。左側にはトップシートがなく、右側にはトップシートがあります。回路図シートが2~3枚しかない小規模な設計では、トップシートを設けても利点はないと判断するかもしれません。シート数が増えると、トップシート上の論理ブロック(シートシンボル)の配置によって、回路設計の機能を読み手が理解しやすくなります。階層構造がないため、設計内のすべてのシートはProjectsパネルで同じ階層に表示されます。
シートシンボル

配置されたシートシンボル
概要
シートシンボルは、電気設計のプリミティブです。マルチシートの階層設計で、下位シートを表すために使用します。シートシンボルにはシートエントリーシンボルが含まれ、階層設計における親シートと子シート間の信号の接続点となります。これは、フラットシート設計でポートがシート間の接続を提供するのと同様です。
使用方法
シートシンボルを配置できるのは、回路図エディター内のみです。配置コマンドにアクセスするには、次のいずれかの方法を使用します。
- メインメニューから Place » Sheet Symbol を選択します。
-
設計スペース上部の Active Bar にあるグラフィックオブジェクトのドロップダウンから、 Sheet Symbol ボタン(
)をクリックします。( Active Bar ボタンをクリックしたままにすると、関連するほかのコマンドにアクセスできます。一度使用したコマンドは、 Active Barの該当セクションの最上位項目になります。)
- 設計スペース内で右クリックし、コンテキストメニューから Place » Sheet Symbolを選択します。
-
Wiring ツールバーの
をクリックします。
配置
コマンドを起動すると、カーソルが十字に変わり、 シートシンボル配置モードになります。次の操作で配置します。
- クリックするかEnterを押して、シートシンボルの最初の角を固定します。
- カーソルを動かしてシートシンボルのサイズを調整し、クリックするかEnterを押して配置を完了します。
- 引き続きシートシンボルを配置するか、 右クリックするかEscを押して配置モードを終了します。
配置中、シートシンボルがまだカーソルに追従しており、 最初の角を固定する前であれば、 次の操作も実行できます。
-
Tabキーを押すと、Properties パネルのシートシンボルモードにアクセスし、 シートシンボルのプロパティをその場で変更できます。 設計スペースに重ねて表示される一時停止ボタン(
)をクリックすると、配置を再開します。
- Altキーを押したままにすると、 最初に移動した方向に応じて、移動方向を水平方向または垂直方向に制限できます。
- Spacebarを押すとシートシンボルが反時計回りに、Shift+Spacebarを押すと時計回りに回転します。回転は90°刻みです。
- XキーまたはYキーを押すと、シートシンボルをX軸方向またはY軸方向に反転できます。
グラフィカル編集
この編集方法では、デザインスペースに配置されたシートシンボルオブジェクトを直接選択し、サイズ、形状、位置をグラフィカルに変更できます。
シートシンボルオブジェクトを選択すると、編集ハンドルをクリックしてドラッグし、シートシンボルのサイズを変更できます。

選択されたシートシンボル
シートシンボル上の編集ハンドル以外の場所をクリックしてドラッグすると、位置を変更できます。ドラッグ中に、シートシンボルを回転(Spacebar/Shift+Spacebar)または反転(XキーまたはYキーでX軸方向またはY軸方向に反転)できます。
シートシンボルのDesignator およびFile Name テキストフィールドのサイズは、使用するフォントのサイズを変更することによってのみ変更できます(各オブジェクトのPropertiesパネルからアクセスします)。そのため、これらのオブジェクトを選択しても編集ハンドルは表示されません。

シートシンボルの選択されたデジグネータとファイル名
- 破線の枠内をクリックしてドラッグすると、テキストオブジェクトを任意の位置に移動できます。ドラッグ中に、テキストを回転(Spacebar/Shift+Spacebar)または反転(XキーまたはYキーでX軸方向またはY軸方向に反転)できます。
-
オブジェクトのテキストは、次の手順でその場で編集できます。
- デジグネータまたはファイル名のテキストをシングルクリックして選択します。
- もう一度シングルクリックするか、Enterを押して、その場で編集するモードに入ります。2回のシングルクリックがダブルクリック(関連するProperties パネルが開きます)として認識されないように、クリックの間隔を十分に空けてください。
- その場でのテキスト編集を終了するには、Enterを押すか、テキストオブジェクト以外の場所をマウスでクリックします。
非グラフィカル編集
次の非グラフィカル編集方法を使用できます。
Sheet SymbolダイアログまたはPropertiesパネルによる編集
Properties page: シートシンボルのプロパティ
この編集方法では、関連するSheet SymbolダイアログとパネルのPropertiesモードを使用して、シートシンボルオブジェクトのプロパティを変更します。

左:Sheet Symbol ダイアログ、右:PropertiesパネルのSheet Symbolモード
配置後は、次の方法で Sheet Symbolダイアログにアクセスできます。
- 配置されたシートシンボルオブジェクトをダブルクリックします。
- シートシンボルオブジェクト上にカーソルを置いて右クリックし、コンテキストメニューからPropertiesを選択します。
配置中は、Tabキーを押すとPropertiesパネルのSheet Symbol モードにアクセスできます。シートシンボルを配置すると、すべてのオプションが表示されます。
配置後は、次のいずれかの方法でPropertiesパネルのSheet Symbol モードにアクセスできます。
- Propertiesパネルがすでにアクティブな場合は、シートシンボルオブジェクトを選択します。
- シートシンボルオブジェクトを選択した後、デザインスペースの右下にあるPanels ボタンからProperties パネルを選択するか、View » Panels » Propertiesを選択します。
複数のオブジェクトの編集
Propertiesパネルは複数オブジェクトの編集に対応しており、現在選択されているすべてのオブジェクトで共通するプロパティ設定を変更できます。同じ種類のオブジェクトを、手動、類似オブジェクトの検索ダイアログ、またはSCH FilterパネルやSCH Listパネルを使用して複数選択すると、Propertiesパネルでアスタリスク(*)が表示されていないフィールドの値を、選択したすべてのオブジェクトに対して編集できます。
Listパネルによる編集
Panel pages: Listパネル、SCH Filter
List パネルでは、1つ以上のドキュメントのデザインオブジェクトを表形式で表示でき、オブジェクトの属性をすばやく確認、変更できます。適切なフィルタリング(該当するFilter パネル、または類似オブジェクトの検索ダイアログを使用)と組み合わせることで、有効なフィルタの対象となるオブジェクトのみを表示でき、複数のデザインオブジェクトをより正確かつ効率的に指定して編集できます。
シートシンボルの操作
デジグネータとファイル名の書式設定
シートシンボルのデジグネータとファイル名のフィールドは、シートシンボルとは別に書式を設定できます。対応するProperties パネルには、前述の配置後の方法でアクセスできます(シートシンボルを、プロパティを表示または変更する対象のオブジェクトに置き換えてください)。
シートシンボルの右クリックコマンド
配置済みのシートシンボル上で右クリックすると、コンテキストメニューが表示されます。このメニューの Sheet Symbol Actions サブメニューから、対象のシートシンボル(該当する場合は、現在選択されているすべてのシートシンボル)に対して、次のコマンドを使用できます。
-
Open SubSheet "<SheetName.SchDoc>" - シンボルが参照する子シートにアクセスします。子シートがまだ開かれていない場合は開き、メインの設計ウィンドウでアクティブドキュメントにします。
-
Create Sheet From Sheet Symbol - シートシンボルから新しい回路図ドキュメントを作成し、シンボル上の各シートエントリに対応するポートをそのドキュメントに追加します。これにより、トップシート上に作成・配置したシートシンボルに基づいて、マルチシート回路図設計のサブシートを自動的に作成できます。
-
Rename Child Sheet (メインメニューから Design » Rename Child Sheet コマンドを選択してアクセスすることもできます)- シートシンボルが参照する子回路図シートの名前をすばやく変更します。Rename Child Sheet ダイアログが開きます。

Rename Child Sheet ダイアログNew child sheet file name フィールドに回路図シートの新しい名前を指定します。このとき、 .SchDoc 拡張子は必ず残してください。また、次のオプションから、名前変更の方法と操作の適用範囲を指定します。
- Rename child document and update all relevant sheet symbols in the current project – このオプションを有効にすると、子シートの名前が変更され、アクティブなプロジェクト内のソース回路図にある、このシートを参照するすべてのシートシンボルが更新されます。各シートシンボルの File Name は、名前が変更された子シートを反映するように更新されます。
- Rename child document and update all relevant sheet symbols in the current workspace – このオプションを有効にすると、子シートの名前が変更され、開いているすべてのプロジェクトのソース回路図にある、このシートを参照するすべてのシートシンボルが更新されます。各シートシンボルの File Name は、名前が変更された子シートを反映するように更新されます。
- Copy the child document and only update the current sheet symbol – このオプションを有効にすると、元の子シートの名前を変更する前に、そのコピーが作成されます。このオプションでは、現在のシートシンボル(カーソルの下にあるシンボル)のみが更新されます。シートシンボルの File Name フィールドは、コピーされた子シートを参照するように更新されます。
-
Synchronize Sheet Entries and Ports - シートシンボルのシートエントリとサブシートのポートを同期します。ポートとシートエントリの同期ダイアログが開きます。このダイアログを使用して、シートシンボル上のすべてのシートエントリが、参照先の子シート上のポートと、名前およびI/Oタイプの両方で一致していることを確認できます。
-
Flip Sheet Symbol Along X - シートシンボルをX軸方向に反転します。シンボルに関連付けられたシートエントリは、水平方向でシンボルの反対側に移動します。左側にあるものは右側に、右側にあるものは左側に再配置されます。シートエントリの I/O Type は変更されません。

シートシンボルをX軸方向に反転する例 -
Flip Sheet Symbol Along Y - シートシンボルをY軸方向に反転します。シンボルに関連付けられたシートエントリは、垂直方向でシンボルの反対側に移動します。上側にあるものは下側に、下側にあるものは上側に再配置されます。シートエントリの I/O Type は変更されません。

シートシンボルをY軸方向に反転する例 -
Toggle All Sheet Entries IO Type in Sheet Symbol - 該当する場合、シートシンボル内のすべてのシートエントリのI/Oタイプを一括で切り替えます。Edit » Move メインメニューの Toggle All Sheet Entries IO Type In (Selected) Sheet Symbols をクリックするか、Active Bar からも使用できます。
シートエントリのI/Oを切り替えた結果の例
実際の変更内容は、現在のポートI/Oタイプによって次のように異なります。
- Unspecified は Unspecified のままです。
- Output は Input に変更されます。
- Input は Output に変更されます。
- Bidirectionalは Bidirectional のままです。
注記
- 選択したシートシンボルにシートエントリのグループを貼り付けた際に、それらのエントリがシンボルの現在の境界外に配置される場合は、すべてのエントリが収まるようにシンボルのサイズが自動的に変更されます。
-
シートシンボルのインスタンス化を使用すると、同じサブシート上の複数のチャネルを1つのシートシンボルから参照できます。この構文では、シートシンボルの Designator フィールドに Repeat キーワードを使用し、次の形式で記述します。
Repeat(SheetSymbolDesignator, FirstInstance, LastInstance),ここで、
SheetSymbolDesignatorはシートシンボルのベース名で、FirstInstance と LastInstance の組み合わせによって、インスタンス化するチャネル数を定義します。 - 1つのシートシンボルから複数のサブシートを参照できます。File Name フィールドでは、各ファイル名をセミコロンで区切ります。サブシートに配置したオフシートコネクタを効果的に使用することで、設計の一部を複数のシートに分散させながら、それらを1枚の巨大な(フラットな)シートとして扱うことができます。ただし、オフシートコネクタを使用できるのは、同じシートシンボルから参照されるシート間のみです。
-
特殊文字列
SheetSymbolDesignatorを使用できます。この特殊文字列を子回路図シートに配置すると、親回路図シートに配置されている、対応するシートシンボルオブジェクトのデジグネータを表示できます。この特殊文字列は、マルチチャネル設計でも使用できます。特殊文字列が変換された値を表示するには、子回路図シートのコンパイル済みタブを選択します。 - メインメニューから Edit » Move » Reverse Selected Sheet Entries Order コマンドを選択するか、Active Bar上の Reverse Selected Sheet Entries Order コマンドを使用すると、親シートシンボルの一辺に沿って配置されている、選択したシートエントリの順序を逆にできます。このコマンドを有効にするには、シートシンボルの特定の辺で2つ以上のシートエントリを選択する必要があります。同じ親シートシンボルの異なる辺にあるシートエントリや、アクティブな回路図シート上の異なるシートシンボルにあるシートエントリを、同時に並べ替えることもできます。コマンドを実行すると、並べ替えが行われます。並べ替えでは、シートシンボルの特定の辺で選択されたシートエントリのうち、両端にある2つのエントリ間の中点を通る仮想線を軸として、選択されたエントリの位置を反転します。並べ替えても、シートエントリの I/O Type は変更されません。
シートシンボルのプロパティ
回路図エディタのオブジェクトプロパティは、配置されたオブジェクトの外観、内容、動作を指定するための設定項目です。各オブジェクトタイプのプロパティは、次の2つの方法で設定できます。
-
Pre-placement settings – シートシンボルオブジェクトのほとんどのプロパティ、または事前に定義できるプロパティは、Preferencesダイアログの Schematic - Defaultsページで、編集可能なデフォルト設定として用意されています(設計スペースの右上にある
ボタンからアクセスします)。Primitive Listでオブジェクトを選択すると、右側にそのオプションが表示されます。
- Post-placement settings – 設計スペースに配置されたシートシンボルを選択すると、シートシンボルオブジェクトのすべてのプロパティを、Sheet SymbolダイアログおよびPropertiesパネルで編集できます。
一般タブ
位置 (Properties パネルのみ)
-
(X/Y)
- X (最初のフィールド)- 現在の設計スペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も含めてください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も含めてください。
プロパティ
-
Designator - シートシンボルの現在の名前です。このフィールドでは、同じ回路図シートに配置された他のシートシンボルと区別できる、意味のある名前をシートシンボルに付けます。通常、名前は、そのシンボルが表す回路図サブシートの全体的な機能を反映したものにします。
または
を切り替えると、デジグネータの表示/非表示を切り替えられます。
-
File Name - シートシンボルが現在参照している回路図ドキュメントです。
または
を切り替えると、ファイル名の表示/非表示を切り替えられます。
- Bus Text Style - ドロップダウンを使用して、バステキストのスタイルを選択します。選択肢はFull またはPrefixです。
- Width - 編集できます。
- Height - 編集できます。
- Line Style - ドロップダウンを使用して、利用可能な選択肢からデフォルトを選択します。カラーボックスをクリックすると、デフォルトの線の色を選択できるドロップダウンが表示されます。
- Fill Color - チェックを入れると塗りつぶしが有効になります。カラーボックスをクリックすると、デフォルトの塗りつぶし色を選択できるドロップダウンが表示されます。
ソース (Properties パネルのみ)
-
Local / Device / Managed - ファイルのソースです。
-
File Name - シートシンボルが参照する現在の回路図ドキュメントを 表示します。このフィールドによって、シートシンボルと、そのシンボルが表す回路図サブシートが関連付けられます。
をクリックすると、 参照するドキュメントの選択ダイアログが開き、目的のサブシートを選択できます。 このダイアログには、プロジェクト内のすべてのソース回路図シートが一覧表示されます(シンボルが現在配置されているシートを除く)。
-
File Name - シートシンボルが参照する現在の回路図ドキュメントを 表示します。このフィールドによって、シートシンボルと、そのシンボルが表す回路図サブシートが関連付けられます。
シートエントリ (Properties パネルのみ)
-
Grid - シートシンボルに現在定義されているすべてのシートエントリの NameとポートI/Oタイプ を一覧表示します。グリッドにシートエントリがある場合、エントリを選択すると次の追加オプションを使用できます。
- Font - クリックして、シートエントリのフォントスタイルを設定します。
-
Other - クリックしてドロップダウンを開き、追加オプションを変更します。
- Kind - ドロップダウンを使用して、シートエントリの種類を選択します。
- Border Color - クリックして、枠線の色を選択するためのコントロールを表示します。
- 塗りつぶし Color - クリックして、塗りつぶしの色を選択するためのコントロールを表示します。
-
Add - クリックしてシートエントリを追加します。
を使用すると、選択したエントリをテーブルから削除できます。
パラメータタブ
パラメータ
-
Grid - シートシンボルに現在定義されているすべてのパラメータのNameとValueを一覧表示します。グリッドにパラメータがある場合、パラメータを選択すると次の追加オプションを使用できます。
- Font - クリックして、パラメータのフォントスタイルを設定します。
-
Other - クリックしてドロップダウンを開き、追加オプションを変更します。
- Show Parameter Name - 有効にすると、デザインスペースにパラメータ名を表示します。
- Allow Synchronization with Database - 有効にすると、データベースと同期します。このオプションは、コメントを更新できるかどうかを制御します。デフォルトでは、これらのオプションは有効になっており、ソースライブラリ/データベースとの同期が常に許可されます。このオプションを無効にすると、そのコメントを更新処理の対象から除外できます。
- X/Y - 目的のX座標とY座標を入力します。
- Rotation - ドロップダウンを使用して回転角度を選択します。
- Autoposition - チェックすると自動配置が有効になり、コンポーネントを移動または回転しても、テキストは選択した位置に維持されます。
-
Add - クリックしてパラメータを追加します。
を使用すると、選択したエントリをテーブルから削除できます。
シートシンボルのデジグネータ

シートシンボルのデジグネータ
概要
シートシンボルのデジグネータは、電気設計プリミティブに属する非電気的な子オブジェクトです。同じ回路図シートに配置されている他のシートシンボルと区別できるように、シートシンボルに意味のある名前を付けるために使用します。通常、この名前には、シンボルが表す回路図サブシートの全体的な機能を反映させます。
利用と配置
シートシンボルのデジグネータは、親となるコンポーネントパーツオブジェクトを配置したときに自動的に配置されます。 ユーザーが直接配置できる設計オブジェクトではありません。
グラフィカル編集
この編集方法では、デザインスペースでシートシンボルのデジグネータオブジェクトを直接選択し、その位置をグラフィカルに変更できます。シートシンボルのデジグネータのサイズは、プロパティパネルでFont のサイズを変更することによってのみ調整できます。そのため、シートシンボルのデジグネータオブジェクトを選択しても、編集ハンドルは表示されません。

選択されたシートシンボルのデジグネータ
破線の枠内の任意の場所をクリックしてドラッグすると、シートシンボルのデジグネータオブジェクトを目的の位置に移動できます。ドラッグ中にオブジェクトを回転または反転することもできます。
- Tab キーを押すと、プロパティ パネルが開き、シートシンボルのデジグネータのプロパティをその場で変更できます。
- Alt キーを押すと、最初に移動した方向に応じて、移動方向が水平軸または垂直軸に制限されます。
- Spacebar を押すとシートシンボルのデジグネータが反時計回りに回転し、 Shift+Spacebar を押すと時計回りに回転します。回転は90°刻みです。
- X キーまたは Y キーを押すと、シートシンボルのデジグネータをX軸方向またはY軸方向に反転できます。
非グラフィカル編集
次の非グラフィカル編集方法を使用できます。
パラメータダイアログまたはプロパティパネルでの編集
Panel page: シートシンボルのデジグネータのプロパティ
この編集方法では、関連するParameter ダイアログとProperties パネルモードを使用して、シートシンボルのデジグネータオブジェクトのプロパティを変更します。
左側はParameter ダイアログ、右側はPropertiesパネルのParameterモード
配置後、次の方法でParameter ダイアログにアクセスできます。
- 配置済みのシートシンボルのデジグネータオブジェクトをダブルクリックします。
- シートシンボルのデジグネータオブジェクトにカーソルを合わせて右クリックし、コンテキストメニューからPropertiesを選択します。
配置中は、Tabキーを押すと、PropertiesパネルのParameter モードにアクセスできます。シートシンボルのデジグネータを配置すると、すべてのオプションが表示されます。
配置後は、次のいずれかの方法でPropertiesパネルのParameter モードにアクセスできます。
- Propertiesパネルがすでにアクティブな場合は、シートシンボルのデジグネータオブジェクトを選択します。
- シートシンボルのデジグネータオブジェクトを選択した後、設計スペースの右下にあるPanels ボタンからProperties パネルを選択するか、View » Panels » Propertiesを選択します。
複数のオブジェクトの編集
Properties パネルは複数のオブジェクトの編集に対応しており、現在選択されているすべてのオブジェクトで共通するプロパティ設定を変更できます。同じ種類のオブジェクトを、手動、Find Similar Objects ダイアログ、またはFilterパネルやListパネルを使用して複数選択すると、Properties パネル内でアスタリスク(*)として表示されていないフィールドの値を、選択したすべてのオブジェクトに対して編集できます。
Listパネルによる編集
Panel pages: Listパネル、SCH Filter、SCHLIB Filter
List パネルでは、1つ以上のドキュメントの設計オブジェクトを表形式で表示し、オブジェクトの属性をすばやく確認、変更できます。該当するFilter パネルまたはFind Similar Objectsダイアログを使用した適切なフィルタリングと組み合わせることで、アクティブなフィルターの対象となるオブジェクトだけを表示でき、複数の設計オブジェクトをより正確かつ効率的に選択して編集できます。
注意事項
-
テキストフレームは回転させたり、X軸またはY軸に沿って反転させたりできますが、内部のテキストの向きには影響しません。
-
単純な1行のテキスト注釈には、テキスト文字列オブジェクトの使用を検討してください。
-
シートシンボルのインスタンス化を使用すると、1つのシートシンボルから、同じサブシート上の複数のチャネルを参照できます。構文では、シートシンボルのデジグネータフィールドにRepeatキーワードを使用し、次の形式で指定します。
Repeat(SheetSymbolDesignator, FirstInstance, LastInstance)。
Repeatキーワードの使用SheetSymbolDesignatorはシートシンボルのベース名で、FirstInstanceとLastInstanceによって、インスタンス化するチャネル数を定義します。プロジェクトのビルド時、コンパイラは内部コンパイル済みモデルを構築する際に、必要な回数だけチャネルをインスタンス化します。このとき、選択されたアノテーション方式を使用して、各チャネルの各コンポーネントを一意に識別します。チャネルのサブシート自体は複製されません。代わりに、コンパイル後、メイン設計ウィンドウのサブシートドキュメントの下部に、そのシート上の各チャネルに対応する個別のタブが表示されます。
-
SheetSymbolDesignator特殊文字列を使用できます。この特殊文字列を子回路図シートに配置すると、親回路図シートに配置されている関連するシートシンボルオブジェクトのデジグネータを表示できます。この特殊文字列は、マルチチャネル設計でも使用できます。子回路図シートのコンパイル済みタブを選択すると、特殊文字列の変換後の値が表示されます。
シートシンボルのデジグネータのプロパティ
回路図エディターのオブジェクトプロパティは、配置されたオブジェクトの表示スタイル、内容、動作を指定する設定可能なオプションです。各種類のオブジェクトのプロパティ設定は、次の2つの方法で定義します。
-
Pre-placement settings – シートシンボルのデジグネータオブジェクトのほとんどのプロパティ、または事前に定義することが妥当なプロパティは、PreferencesダイアログのSchematic - Defaultsページでデフォルト設定として編集できます(設計スペースの右上にある
ボタンからアクセスします)。Primitive List でオブジェクトを選択すると、右側にそのオプションが表示されます。
-
Post-placement settings – 設計スペースで配置済みのシートシンボルのデジグネータを選択すると、シートシンボルのデジグネータオブジェクトのすべてのプロパティを、Parameter ダイアログとPropertiesパネルで編集できます。
位置 (Properties パネルのみ)
-
(X/Y)
- X (最初のフィールド)- 現在のデザインスペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位を付けてください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位を付けてください。
- Rotation - ドロップダウンから回転角度を選択します。
プロパティ
- Sheet Symbol - このオブジェクトに関連付けられたシートシンボルです。
- Name - 名前を表示します。
-
Value - 実際のデジグネータのテキストを表示します。
または
を使用して、オブジェクトの Value を表示するか非表示にするかを指定します。Autoposition にチェックを入れると、自動配置が有効になります。
- Font - 各コントロールを使用して、フォント、フォントサイズ、色、および太字や下線などの特殊な設定を行います。
- Justification - テキストの配置揃えを選択します。
シートシンボルのファイル名

シートシンボルのファイル名
概要
シートシンボルのファイル名は、電気的な設計プリミティブに属する、電気的特性を持たない子オブジェクトです。シートシンボルと、そのシンボルが表す回路図サブシートを関連付けます。
使用と配置
シートシンボルのファイル名は、親のシートシンボルオブジェクトを配置すると自動的に配置されます。ユーザーが直接配置できる設計オブジェクトではありません。
グラフィカル編集
この編集方法では、デザインスペースでシートシンボルのファイル名オブジェクトを直接選択し、位置をグラフィカルに変更できます。シートシンボルのファイル名のサイズは、Propertiesパネルで Font のサイズを変更することでのみ調整できます。そのため、シートシンボルのファイル名オブジェクトを選択しても、編集ハンドルは表示されません。
破線の枠内の任意の位置をクリックしてドラッグすると、シートシンボルのファイル名オブジェクトを目的の位置に移動できます。ドラッグ中にオブジェクトを回転または反転することもできます。
Spacebar を押すと、ファイル名が回転します。回転は反時計回りに90°刻みで行われます。
非グラフィカル編集
以下の非グラフィカルな編集方法を使用できます。
ParameterダイアログまたはPropertiesパネルによる編集
Panel page: シートシンボルのファイル名のプロパティ
この編集方法では、関連する Parameter ダイアログと Properties パネルモードを使用して、シートシンボルのファイル名オブジェクトのプロパティを変更します。
左は Parameter ダイアログ、右はPropertiesパネルの Parameter モード
配置後は、次の方法で Parameter ダイアログにアクセスできます。
- 配置済みのシートシンボルオブジェクトをダブルクリックします。
- シートシンボルオブジェクトの上にカーソルを置いて右クリックし、コンテキストメニューから Properties を選択します。
配置中は、Tab キーを押すと Properties パネルの Parameter モードにアクセスできます。シートシンボルを配置すると、すべてのオプションが表示されます。
配置後は、次のいずれかの方法で Properties パネルの Parameter モードにアクセスできます。
- Properties パネルがすでにアクティブな場合は、シートシンボルオブジェクトを選択します。
- シートシンボルオブジェクトを選択した後、デザインスペースの右下にある Panels ボタンから Properties パネルを選択するか、View » Panels » Properties を選択します。
複数のオブジェクトの編集
Properties パネルでは複数のオブジェクトを編集でき、現在選択されているすべてのオブジェクトで共通するプロパティ設定を変更できます。同じ種類のオブジェクトを手動で、または Find Similar Objects ダイアログ、Filter パネル、List パネルを使用して複数選択した場合、Properties パネルでアスタリスク(*)が表示されていないフィールドの値は、選択したすべてのオブジェクトに対して編集できます。
Listパネルでの編集
Panel pages: Listパネル、SCH Filter、SCHLIB Filter
List パネルでは、1つまたは複数のドキュメントの設計オブジェクトを表形式で表示し、オブジェクトの属性をすばやく確認、変更できます。該当するFilter パネルまたはFind Similar Objectsダイアログによる適切なフィルタリングと組み合わせることで、有効なフィルターの対象となるオブジェクトのみを表示し、複数の設計オブジェクトをより正確かつ効率的に選択して編集できます。
シートシンボルのファイル名のプロパティ
回路図エディターのオブジェクトプロパティは、配置されたオブジェクトの外観、内容、動作を指定するための設定項目です。各オブジェクトタイプのプロパティ設定は、次の2つの方法で定義します。
-
Pre-placement settings – シートシンボルのファイル名オブジェクトのプロパティの大半、つまり事前に定義できるプロパティは、Preferencesダイアログの Schematic - Defaultsページで、編集可能なデフォルト設定として利用できます(設計スペース右上の
ボタンからアクセス)。Primitive List でオブジェクトを選択すると、右側にそのオプションが表示されます。
- Post-placement settings – 配置済みのシートシンボルのファイル名を設計スペースで選択すると、シートシンボルのファイル名 オブジェクトのすべてのプロパティを、Parameter ダイアログとPropertiesパネルで編集できます。
位置 (Properties パネルのみ)
- Search - このフィールドを使用して、Properties パネル内の目的のテキストを検索します。見つかったテキストはハイライト表示されます。
-
(X/Y)
- X (最初のフィールド)- 現在の設計スペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位も入力してください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位も入力してください。
- Rotation - ドロップダウンを使用して回転角度を選択します。
プロパティ
- Sheet Symbol - このオブジェクトに関連付けられたシートシンボルです。
- Name - 名前を表示します。
-
Value - 実際のファイル名のテキストを表示します。
/
を使用して、オブジェクトの Value を表示するか非表示にするかを指定します。 Autopositionをオンにすると、自動配置が有効になります。
- Font - 各コントロールを使用して、フォント、フォントサイズ、色、および太字や下線などの特殊な設定を行います。
- Justification - テキストの配置揃えを選択します。
階層設計
階層設計とは、設計内のツリー状の構造、つまりシート間の関係を表現した設計です。 この構造は、設計階層内の下位シートを表すシートシンボルで表現します。シンボルは下位のシートを表し、シンボル内のシートエントリは、その下位シート上のポートを表します(またはポートに接続します)。 接続は、これらのシートシンボル内のシートエントリを介して行われます。あるシートのポートから別のシートのポートに直接接続されるわけではありません。
フラット設計と同様に、子シートはシートシンボル内でファイル名を定義することで識別されます。階層設計では、その子シートにも、さらに下位のシートを参照するシートシンボルを含めることができ、これにより階層がもう1段追加されます。下の図は、3階層からなる階層設計を示しています。

階層設計では、ツリーに表示される構造は、シートシンボルによって作成された親子関係によって決まります。
階層設計では、子シート上の信号はポートを介してシートの外に出て、親シート上の対応するシートエントリに接続されます。親シートには、子シートの信号を別のシートシンボル内のシートエントリへ伝える配線が含まれており、信号はそこから2つ目の子シート上の対応するポートへと下ります。以下の画像に示すとおりです。
この親子シート構造は任意の深さまで定義でき、階層設計に含めるシートの数にも制限はありません。
ポート
概要
ポートは、電気設計のプリミティブです。複数のシートを使用する設計(フラット設計と階層設計の両方)で、ある回路図シートと別のシート、またはシートシンボル(対応するシートエントリを介して)との間に電気的な接続を作成するために使用します。ポート名によって接続が定義されます(つまり、回路図シート上のポートは、プロジェクト内の他のシートにある同じ名前のポートまたはシートエントリに接続されます)。
アクセス方法
回路図エディタでは、次の方法でポートを配置できます。
- メインメニューからPlace » Portをクリックします。
-
設計スペース上部にあるActive Barのディレクティブドロップダウンで、ポートボタン(
)をクリックします。(Active Barボタンを長押しすると、関連する他のコマンドにアクセスできます。使用したコマンドは、Active Barの該当セクションの最上部に表示されるようになります。)
- 右クリックして、Place » Portを選択します。
配置
コマンドを実行すると、カーソルが十字に変わり、ポート配置モードになります。次の手順で配置します。
- クリックするかEnterを押して、ポートの左端を固定します。
- カーソルを移動してポートの長さを必要に応じて調整し、クリックするかEnterを押して、ポートの配置を完了します。
- 続けてポートを配置するか、右クリックまたはEscを押して配置モードを終了します。
配置中、ポートがまだカーソルに追従していて、左端が固定されていない状態では、次の操作も行えます。
-
Tabキーを押すと配置が一時停止し、Properties パネルのポートモードにアクセスして、その場でプロパティを変更できます。設計スペースに重ねて表示される一時停止ボタン(
)をクリックすると、配置を再開します。
- Spacebarを押すとポートが反時計回りに、Shift+Spacebarを押すと時計回りに回転します。回転は90°単位です。
- XキーまたはYキーを押すと、ポートがそれぞれX軸またはY軸に沿って反転します。
グラフィカル編集
この編集方法では、設計スペースに配置されたポートオブジェクトを選択し、その長さ、高さ、位置をグラフィカルに変更できます。
ポートオブジェクトを選択すると、編集ハンドルをクリックしてドラッグすることで、ポートのサイズを変更できます。
選択されたポート
ポート上の編集ハンドル以外の場所をクリックしてドラッグすると、位置を変更できます。ドラッグ中に、ポートを回転(Spacebar/Shift+Spacebar)または反転(XキーまたはYキーで、それぞれX軸またはY軸に沿って反転)できます。
ポートオブジェクトの名前は、次の手順でin-place編集できます。
- ポートをシングルクリックして選択します。
- もう一度シングルクリックするか、Enterを押して、その場で編集するモードに入ります。2回のシングルクリックが1回のダブルクリック(Properties パネルが開きます)と認識されないように、クリックの間隔を十分に空けてください。
- その場でのテキスト編集を終了するには、Enterを押すか、ポート以外の場所をマウスでクリックします。
- ポートのサイズは、ポート名の長さと高さに合わせて自動的に調整されます。
非グラフィカル編集
以下の非グラフィカル編集方法を使用できます。
PortダイアログまたはPropertiesパネルによる編集
Properties page: ポートのプロパティ
この編集方法では、関連するPort ダイアログとProperties パネルモードを使用して、ポートオブジェクトのプロパティを変更します。
左側はPort ダイアログ、右側はPropertiesパネルのPortモード
配置後は、次の方法でPort ダイアログにアクセスできます。
- 配置済みのポートオブジェクトをダブルクリックします。
- ポートオブジェクトにカーソルを合わせて右クリックし、コンテキストメニューからPropertiesを選択します。
配置中は、Tabキーを押すと、PropertiesパネルのPort モードにアクセスできます。ポートを配置すると、すべてのオプションが表示されます。
配置後は、次のいずれかの方法でPropertiesパネルのPort モードにアクセスできます。
- Propertiesパネルがすでにアクティブな場合は、ポートオブジェクトを選択します。
- ポートオブジェクトを選択した後、設計スペースの右下にあるPanels ボタンからProperties パネルを選択するか、メインメニューからView » Panels » Propertiesを選択します。
複数オブジェクトの編集
Properties パネルは複数オブジェクトの編集に対応しており、現在選択されているすべてのオブジェクトで共通するプロパティ設定を変更できます。同じ種類のオブジェクトを、手動、Find Similar Objectsダイアログ、またはSCH Filter パネルやSCH List パネルを使用して複数選択すると、Properties パネルでアスタリスク(*)として表示されていないフィールドの値を、選択したすべてのオブジェクトに対して編集できます。
リストパネルによる編集
Panel pages: リストパネル、SCH Filter
List パネルでは、1つ以上のドキュメントの設計オブジェクトを表形式で表示し、オブジェクトの属性をすばやく確認、変更できます。適切なフィルタリング(該当するFilter パネルまたはFind Similar Objectsダイアログを使用)と組み合わせることで、アクティブなフィルターの範囲に含まれるオブジェクトだけを表示でき、複数の設計オブジェクトをより正確かつ効率的に絞り込んで編集できます。
ポートの操作
配置済みのポート上で右クリックすると、コンテキストメニューが表示されます。このメニューのPort Actionsサブメニューから、対象のポート(該当する場合は、現在選択されているすべてのポート)に対して次のコマンドを使用できます。
- Jump to Sheet Entry <PortName> - ポートが配置されているサブシートを参照する親シートシンボル内の、対応するシートエントリにジャンプします。
実際の変更は、現在のI/Oタイプに応じて次のようになります。
- Unspecified はUnspecifiedのままです。
- Output はInputに変わります。
- Input はOutputに変わります。
- Bidirectional はBidirectionalのままです。
- Place Harness Connector of Type <HarnessConnectorType> - ポートに接続するハーネスコネクタを、定義済みの各ハーネスエントリとともに配置します。
- Jump to Port <PortName> on <SheetName> - 指定されたソース回路図ドキュメント上の、同じ名前の別のポートにジャンプします。
注意事項
-
ポートとシートシンボルの関係は、プロジェクトで選択されているNet Identifier Scopeによって決まります。このスコープは、Project Options - Optionsダイアログ(Project » Project Options)のNet Identifier Scopeオプションで定義します。
-
FlatまたはGlobalに設定されている場合、同一または異なる回路図ドキュメント内にある同じ名前のすべてのポートは、電気的に接続されていると見なされます。
-
HierarchicalまたはStrict Hierarchicalに設定されている場合、ポートは対応するシートエントリに対して階層方向にのみ接続されます。同じ名前の他のポートと水平方向には接続されません。
-
-
Properties パネルのI/O Typeオプションでは、ポートの電気的タイプを定義できます。
Input、Output、Bidirectional、Unspecifiedのいずれかを選択します。PreferencesダイアログのSchematic – GeneralページでPort Directionオプションが有効になっている場合、ポートにはI/Oタイプが自動的に表示されます。 -
ポート名を負論理表記(名前の上にバーを表示)にするには、次のいずれかの方法を使用します。
-
名前の各文字の後にバックスラッシュを付けます(例:E\N\A\B\L\E)。
-
PreferencesダイアログのSchematic - Graphical EditingページでSingle '\' Negationオプションを有効にし、名前の先頭にバックスラッシュを1つ付けます(例: \ENABLE)。
-
-
デフォルトでは、ポート名はネット名に使用されません。ポート名をネット名に使用する場合は、Options for ProjectダイアログのOptionsタブでAllow Ports to Name Netsオプションを有効にしてください。このオプションが無効の場合、そのネットにネットラベルや電源オブジェクトが関連付けられていないとき、または階層設計でAllow Sheet Entries to Name Netsオプションが有効になっていないときは、システムが生成したネット名が使用されます。詳しくは、ネットの命名方法を参照してください。
-
ポートは、ポート名の長さや高さに合わせて自動的にサイズが調整されます。自動サイズ調整は、テキストの入力方法に関係なく機能します(PropertiesのPort モードを使用して パネル、または デザインスペースで直接インプレース編集することで変更できます)。
-
ポートをシグナルハーネスに接続すると、ポートはハーネスオブジェクトになります。デフォルトでは、ポートの色はシグナルハーネスと同じ色に変わります。
-
ポートをシグナルハーネスでハーネスコネクタに接続すると、Properties パネルのHarness Typeに、ハーネスコネクタのハーネスタイプが自動的に入力されます。ポートをシグナルハーネスでシートエントリに接続し、そのシートエントリにハーネスタイプが宣言されている場合、ポートはハーネスオブジェクトになり、シグナルハーネスと同じ色に変わります。ポートをハーネスコネクタまたはシートエントリから離すと、ポートの色はデフォルトに戻ります。
-
デフォルトでは、ポートの Name に使用されるフォントは、Properties パネルの Document Options モード(ワークスペースでオブジェクトが選択されていない状態)にある Document Font オプションで設定された、ドキュメント全体のフォントに従います。この設定は、Properties パネルの Font 設定を使用してポートごとに上書きでき、必要に応じてポートのテキスト表示を細かく制御できます。
-
Import Wizardを使用してOrCADデザインをインポートすると、生成される回路図ドキュメントでカスタムポートコネクタがサポートされます。これらのポートは、元のデザインと同じグラフィックスで表示されます。詳細は、 OrCADからのデザインのインポートを参照してください。
-
Import Wizardを使用してxDX Designerデザインをインポートすると、生成される回路図ドキュメントでカスタムポートがサポートされます。これらのポートは、元のデザインと同じグラフィックスで表示されます。詳細は、 xDX DesignerまたはDxDesignerからのデザインのインポートを参照してください。
ポートのプロパティ
回路図エディタのオブジェクトプロパティは、配置したオブジェクトの外観、内容、動作を指定するための設定可能なオプションです。各オブジェクトタイプのプロパティは、次の2つの方法で設定できます。
-
Pre-placement settings – ポートオブジェクトのほとんどのプロパティ、または事前に定義できるプロパティは、Preferencesダイアログ(デザインスペースの右上にある
ボタンからアクセス)の Schematic - Defaultsページで、編集可能なデフォルト設定として用意されています。Primitive List でオブジェクトを選択すると、右側にそのオプションが表示されます。
- Post-placement settings – 配置済みのポートをデザインスペースで選択すると、Port ダイアログおよびPropertiesパネルで、ポートオブジェクトのすべてのプロパティを編集できます。
全般タブ
位置 (Properties パネルのみ)
-
(X/Y)
- X (最初のフィールド)- 現在のデザインスペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置が変わります。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位の値を入力する場合は、単位も含めてください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置が変わります。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトと異なる単位の値を入力する場合は、単位も含めてください。
プロパティ
-
Name - ポートの名前です。
- I/O Type - ポートの電気的特性を定義します。ドロップダウンリストからオプションを選択します。
- Harness Type - ドロップダウンからハーネスのタイプを選択します。
- Cross Ref - このフィールドには、ポートに適用されるクロスリファレンス値が表示されます。
- Width - 編集できます。
- Height - 編集できます。
- Font - コントロールを使用して、目的のフォント、フォントサイズ、色、および太字や斜体などの属性を必要に応じて選択します。
- Alignment - 目的の配置設定をクリックします。
- Border - ドロップダウンを使用して、利用可能な選択肢からデフォルトを選択します。色付きのボックスをクリックすると、デフォルトの色を選択できるドロップダウンが開きます。
- Fill - カラーボックスをクリックすると、デフォルトの色を選択できるドロップダウンが開きます。
全般(ネット)
ポートに割り当てられたネットのプロパティを表示します。必要に応じて更新してください。
パラメータ(ネット)
- Selection buttons - グリッドに表示するオブジェクトをクリックします。
- Add - ドロップダウンを使用して目的のオブジェクトを追加し、値を定義します。
パラメータタブ
パラメータ
この領域を使用して、現在選択されているポートオブジェクトに付加されたパラメータを管理します。
-
Grid - ポートに現在定義されているパラメータのName とValue を一覧表示します。必要に応じてフィールドを直接編集できます。
および
を使用して、パラメータの表示と非表示を切り替えます。ロックアイコンを使用して、選択したパラメータをロックまたはロック解除します。
- Font Settings - クリックすると、フォントを定義するメニューが開きます。
-
Other - クリックしてドロップダウンを開き、追加のオプションを変更します。
- Show Parameter Name - 有効にすると、パラメーター名を表示します。
- Allow Synchronization with Database - 有効にすると、データベースと同期します。
- X/Y - X座標とY座標を入力します。
- Rotation - ドロップダウンを使用して回転角度を選択します。
- Autoposition - チェックすると、自動配置を有効にします。
-
Add - クリックしてパラメーターを追加します。
を使用すると、選択した項目をテーブルから削除できます。
シートエントリ

配置済みのシートエントリ
概要
シートエントリは、シートシンボル内に属する電気設計プリミティブです。シートシンボルの入出力ポートを指定するために、シートシンボル内に配置します。シートエントリは、そのシンボルが表す下位回路図シートに配置されたポートに対応します。
利用方法
回路図エディターでシートエントリを配置するには、次のいずれかの方法を使用します。
- メインメニューから Place » Sheet Entry を選択します。
-
設計スペース上部にある Active Bar のグラフィックオブジェクトのドロップダウンで、Sheet Entry ボタン(
)をクリックします。(Active Bar ボタンを長押しすると、関連する他のコマンドにアクセスできます。使用したコマンドは、Active Bar のそのセクションで最上位の項目になります。)
- 設計スペース内で右クリックし、コンテキストメニューから Place » Sheet Entry を選択します。
-
Wiring ツールバーの
ボタンをクリックします。
配置
コマンドを実行すると、カーソルが十字形に変わり、シートエントリの配置モードになります。次の手順で配置します。
- カーソルに追従するシートエントリを、シート上に配置済みのシートシンボルに重ねます。
- シートシンボルの端に対するシートエントリの位置を調整し、クリックするか Enter を押して、シートエントリを目的の端に固定し、配置を完了します。
- 引き続きシートエントリを配置するか、右クリックするか Esc を押して配置モードを終了します。
グラフィカルな編集
この編集方法では、設計スペース内で配置済みのシートエントリオブジェクトを直接選択し、その位置をグラフィカルに変更できます。
シートエントリの形状を調整するには、Properties パネルで I/O Type を変更する必要があります。そのため、シートエントリオブジェクトを選択しても編集ハンドルは表示されません。

選択したシートエントリ
- クリックしてドラッグし、親シートシンボル内でシートエントリを目的の位置に移動します。
- Ctrl を押しながらシートエントリをクリックしてドラッグすると、現在のシートシンボルから同じシート上の別のシートシンボルに移動できます。シートエントリが元のシートシンボルの境界を越えたら、Ctrl キーを放すことができます。
- シートエントリをクリックしてシートシンボルの境界の外側へドラッグすると、シートエントリの新しい位置に合わせてシートシンボルのサイズが自動的に変更されます。
非グラフィカルな編集
次の非グラフィカルな編集方法を使用できます。
Sheet EntryダイアログまたはPropertiesパネルによる編集
Properties page: シートエントリのプロパティ
この編集方法では、関連する Sheet Entry ダイアログと Properties パネルモードを使用して、シートエントリオブジェクトのプロパティを変更します。

Properties パネルの Sheet Entry モード(1枚目の画像)と Sheet Entry ダイアログ(2枚目の画像)
配置後は、次の方法で Sheet Entry ダイアログにアクセスできます。
- 配置済みのシートエントリオブジェクトをダブルクリックします。
- シートエントリオブジェクトにカーソルを合わせて右クリックし、コンテキストメニューから Properties を選択します。
配置中は、Tab キーを押すと、Properties パネルのSheet Entryモードにアクセスできます。シートエントリを配置すると、すべてのオプションが表示されます。
配置後、次のいずれかの方法で、Propertiesパネルのシートエントリモードにアクセスできます。
- Propertiesパネルがすでにアクティブな場合は、シートエントリオブジェクトを選択します。
- シートエントリオブジェクトを選択した後、デザインスペースの右下にあるPanelsボタンからPropertiesパネルを選択するか、View » Panels » Propertiesを選択します。
複数のオブジェクトの編集
Propertiesパネルでは複数オブジェクトの編集がサポートされており、現在選択されているすべてのオブジェクトで共通するプロパティ設定を変更できます。同じ種類のオブジェクトを、手動、Find Similar Objectsダイアログ、またはFilterパネルやListパネルで複数選択した場合、Propertiesパネルでアスタリスク(*)として表示されていないフィールドの値は、選択したすべてのオブジェクトに対して編集できます。
Listパネルによる編集
Panel pages: Listパネル、SCH Filter
Listパネルでは、1つ以上のドキュメントのデザインオブジェクトを表形式で表示し、オブジェクトの属性をすばやく確認、変更できます。適切なフィルタリング(該当するFilterパネル、またはFind Similar Objectsダイアログを使用)と組み合わせることで、アクティブなフィルターの対象範囲に含まれるオブジェクトのみを表示でき、複数のデザインオブジェクトをより正確かつ効率的に絞り込んで編集できます。
シートエントリの右クリック操作
配置済みのシートエントリを右クリックすると、コンテキストメニューが表示されます。このメニューのSheet Entry Actionsサブメニューから、そのシートエントリ(該当する場合は、現在選択されているすべてのシートエントリ)に対して次のコマンドを実行できます。
-
Toggle Selected Sheet Entries IO Type – このコマンドを使用して、シートエントリのI/Oタイプを切り替えます。メインメニューのEdit » Moveから Toggle Selected Sheet Entries IO Typeをクリックするか、Active Barからも実行できます。
実際の変更内容は、現在のI/Oタイプに応じて次のようになります。
-
UnspecifiedはUnspecifiedのままです。 -
OutputはInputに変わります。 -
InputはOutputに変わります。 -
BidirectionalはBidirectionalのままです。
-
-
Swap Selected Sheet Entries Side – シートエントリを親シートシンボルの反対側に移動します。この入れ替えによってシートエントリのI/Oタイプは変更されません。メインメニューから Edit » Move » Swap Selected Sheet Entries Sideをクリックするか、Active Barからも実行できます。
注意事項
- シートエントリをシグナルハーネスに接続すると、シートエントリはハーネスオブジェクトになります。デフォルトでは、シートエントリの色はシグナルハーネスの色に合わせて変わります。シートエントリに独自の色を指定するか、デフォルトの色を使用するには、PreferencesダイアログのSchematic – Graphical Editingページで Sheet Entries and Ports use Harness Colorオプションを無効にします。
- シートエントリをシグナルハーネスでハーネスコネクタに接続すると、PropertiesパネルのHarness Typeに、ハーネスコネクタのハーネスタイプが自動的に入力されます。シートエントリをシグナルハーネスでポートに接続し、そのポートにHarness Typeが宣言されている場合、シートエントリはハーネスオブジェクトとなり、シグナルハーネスの色に変わります。シートエントリをハーネスコネクタから離したとき、Harness Typeフィールドが空の場合は、シートエントリがデフォルトの色に戻ります。
-
シートエントリ名を反転表記(名前の上にバーを表示)にする必要がある場合は、次のいずれかの方法を使用します。
-
ピン名の各文字の後ろにバックスラッシュを追加します(例:
E\N\A\B\L\E\)。 -
PreferencesダイアログのSchematic – Graphical EditingページでSingle '\' Negationオプションを有効にし、ピン名の先頭にバックスラッシュを1つ追加します(例:
\ENABLE)。
-
ピン名の各文字の後ろにバックスラッシュを追加します(例:
- デフォルトでは、シートエントリ名がネット名として使用されます。この動作は、Options for ProjectダイアログのOptionsタブにあるAllow Sheet Entries to Name Netsオプションで制御されます。このオプションが無効の場合、そのネットに関連付けられたネットラベルや電源オブジェクトがない場合、または階層設計でAllow Ports to Name Netsオプションが有効になっていない場合には、システムが生成したネット名が使用されます。詳細は、ネットの命名方法を参照してください。
-
同じシートシンボルから複数のチャネルをインスタンス化する場合、特定の信号が繰り返され、インスタンス化された各チャネルに個別に送られます。シートエントリでは、名前にRepeatキーワードを使用して信号を繰り返します(例:
Repeat(Headphone))。このシートエントリはバスに配線され、バスを通じて個々の信号がそれぞれ対応するインスタンス化された接続先に送られます。 - シートエントリから子シートの対応するポートにすばやく移動するには、シートエントリオブジェクトをCtrl+Clickします。回路図のPDF出力では、シートエントリをクリックすると、子回路図ページのポートに移動できます。
シートエントリのプロパティ
回路図エディターのオブジェクトプロパティは、配置されたオブジェクトの表示スタイル、内容、動作を指定する設定可能なオプションです。各種類のオブジェクトのプロパティ設定は、次の2つの方法で定義します。
-
Pre-placement settings – シートエントリオブジェクトのほとんどのプロパティ、または事前に定義できるプロパティは、Preferencesダイアログの Schematic – Defaultsページで、編集可能なデフォルト設定として利用できます(デザインスペースの右上にあるボタンからアクセスします)。Primitive Listでオブジェクトを選択すると、右側にそのオプションが表示されます。
-
Post-placement settings – シートエントリオブジェクトのすべてのプロパティは、Propertiesで編集できます。パネル、およびデザインスペースで配置済みのシートエントリを選択したときに表示される Sheet Entry ダイアログ。
プロパティ
-
Name – シートエントリの名前。
- I/O Type – ドロップダウンからシートエントリのI/Oタイプを選択します。
- Harness Type – ドロップダウンからハーネスのタイプを選択します。
-
Cross Ref – このフィールドには、シートエントリに適用されているクロスリファレンス値が表示されます。
または
アイコンを使用して、デザインスペース内のシートエントリのクロスリファレンス値の表示/非表示を切り替えます。
- Font – 各コントロールを使用して、フォント、フォントサイズ、フォントの色を選択し、太字、斜体、下線などの装飾を設定します。
- Kind – ドロップダウンからテキストの種類を選択します。
- Border Color – カラーボックスをクリックすると、枠線の色を選択するためのコントロールが表示されます。
- Fill Color – カラーボックスをクリックすると、枠線の色を選択するためのコントロールが表示されます。
一般(ネット)
オブジェクトに割り当てられているネットのプロパティを表示します。必要に応じて更新してください。
パラメーター(ネット)
- Selection buttons – グリッドに表示するオブジェクトをクリックします。
-
Add – ドロップダウンから目的のオブジェクトを追加し、値を定義します。
クロスリファレンスの追加
プロジェクトにクロスリファレンスを追加すると、プロジェクト内の回路図シート間でネットの接続を簡単にたどることができます。回路図エディターは、クロスリファレンスの自動作成と更新をサポートしています。
Project Options ダイアログの Options タブで、General 領域の Automatic Cross References オプションを有効にし、Cross References 領域のオプションを設定します。アクティブなプロジェクトに固有のクロスリファレンスのスタイルを設定することも、Follow Cross References settings in Preferences オプションを有効にして、Preferences ダイアログの Schematic – General ページにある Port Cross References 領域のオプションを継承することもできます。また、ここでクロスリファレンスを表示するオブジェクト(ポート、オフシートコネクタ、シートエントリ)を選択できます。

Project Options ダイアログの Options タブで、アクティブなプロジェクトの自動クロスリファレンスを設定します。
クロスリファレンスは、回路図上の選択したオブジェクトの横に、設定したスタイルで表示されます。クロスリファレンス値は Properties パネルにも表示され、選択したオブジェクトのクロスリファレンスの表示/非表示を切り替えることができます。

クロスリファレンスは回路図上で確認でき、選択したオブジェクトについては Properties パネルでも確認できます。ここでは、ポートのクロスリファレンスの例を示しています。
クロスリファレンスは、回路図のPDF出力でもサポートされています。オブジェクトに複数の接続先オブジェクトがある場合(たとえば、ポートが親回路図シート上のシートエントリや他のシート上のポートに接続されている場合)、PDF出力内でそのオブジェクトをクリックすると、接続先オブジェクトが存在するシートの一覧が表示されます。一覧の項目を選択すると、対応するページが開きます。接続先オブジェクトが1つだけの場合は、オブジェクトをクリックすると、対応するページがすぐに開きます。

回路図のPDF出力では、ポップアップメニューを使用して、複数の接続先オブジェクトに簡単に移動できます。
マルチシート設計の作成
プロジェクトに2枚目の回路図シートを追加すると、マルチシート設計になります。トップシートのないフラットな設計を作成する場合は、プロジェクトに回路図シートを追加していくだけです(Projects パネルでプロジェクトのエントリを右クリックし、コンテキストメニューから Add New to Project » Schematic コマンドを選択します)。その後、Net Identifier Scope が正しく設定されていることを確認します。
シートシンボルを使用して下位階層のシートを参照する場合は、シートシンボルを配置して手動で編集し、下位階層のシートを正しく参照するように設定できます。または、以下で説明する各種の組み込みコマンドを利用できます。
子シートの参照
下位階層のシートを参照するのは、シートシンボルの Filename プロパティです。このフィールドには、回路図のファイル名のみを入力し、ファイルの保存場所へのパスは含めないでください(保存場所の情報は、実際にはプロジェクトファイルに格納されます)。

Filename プロパティは、このシートシンボルを子回路図シートにリンクします。
複数シート設計のナビゲーション
回路図エディターには、複数シート設計のドキュメント間や、ドキュメント内の関連オブジェクト間をすばやく移動できるツールが用意されています。
Tools » Up/Down Hierarchy コマンドを使用すると、現在のドキュメントから設計階層の1つ上または下の階層へ移動できます。コマンドを実行すると、カーソルが十字に変わり、移動ポイントを選択するよう求められます。シートエントリをクリックすると下位シートの対応するポートが表示され、シートシンボルをクリックすると下位シート全体が表示されます。上位階層へ移動するには、ポートをクリックします。親シートの対応するシートエントリが表示されます。
カーソルの下にあるシートシンボルが参照する子シートを開くには、配置済みのシートシンボル上で右クリックし、コンテキストメニューから Sheet Symbol Actions » Open SubSheet <SchematicDocumentName> コマンドを選択します。コマンドを実行すると、そのシンボルが参照する回路図ドキュメントが開かれ(まだ開かれていない場合)、メイン設計ウィンドウでアクティブなドキュメントになります。
関連するオブジェクトで 自動相互参照 が有効になっている場合は、オブジェクトの右クリックメニューの Port Actions、Sheet Entry Actions、および Off Sheet Actions (フラット設計の場合)サブメニューにある Jump To コマンドを使用して、ポート、シートエントリ、オフシートコネクタ間を移動することもできます。たとえば、Options for Project ダイアログの Options タブで、Automatic Cross References オプションが有効になっており、Ports オプションの設定として Sheet Entry & Ports が選択されている場合、ポート上で右クリックして、コンテキストメニューから必要な Port Actions » Jump to Port <PortName> on <SchematicDocumentName> または Port Actions » Jump to Sheet Entry <PortName> on <SchematicDocumentName> コマンドを選択できます。指定したポートまたはシートエントリを含むドキュメントがアクティブになり、カーソルがそのポートまたはシートエントリ上に配置されます。移動先のドキュメントにある同じ名前のすべてのポート(および接続されている配線)がハイライト表示されます。

Jump to コマンドを使用すると、設計内の任意の場所にある対応するオブジェクトへジャンプできます。
階層の作成
このソフトウェアには、複数のドキュメントからなる階層構造をすばやく効率的に構築するためのコマンドが多数用意されています。使用するコマンドは、設計手法によって異なります。設計手法は、大きくトップダウンとボトムアップに分類できます。これらのコマンドは、シートエントリの追加、新しい回路図シートの作成、ポートの配置など、作業に必要なすべての要素を処理するため、手動で階層を作成するよりも効率的です。
トップダウン方式で階層を構築するには、次のコマンドを使用します。
-
Create Sheet From Sheet Symbol (Design メインメニュー、またはシートシンボルの右クリックメニューにある Sheet Symbol Actions サブメニュー)– このコマンドを使用すると、指定したシートシンボルの下位に新しい回路図シートを作成できます。シンボル上のシートエントリに対応するポートは、新しいドキュメントの左下隅に配置されます。シートシンボルにすべてのシートエントリをまだ追加していなくても問題ありません。後から追加した場合は、以下で説明するように、シートエントリとポートを再同期できます。
ボトムアップ方式で階層を構築するには、次のコマンドを使用します。
-
Create Sheet Symbol From Sheet(Design メインメニュー、または設計スペースの右クリックメニューにある Sheet Actions サブメニュー)– このコマンドを使用すると、指定した回路図シートからシンボルを作成できます。このコマンドを使用するには、まず新しいシートシンボルを配置するシートに切り替えてから、コマンドを実行します。 Choose Document to Place ダイアログが開くので、新しく作成するシートシンボルから参照する回路図ドキュメントを選択します。シートシンボルには、検出された各ポートに対応するシートエントリが含まれます。後からポートやシートエントリを追加または削除した場合は、以下で説明するように再同期できます。
このコマンドを使用して、設計内の回路の配置を再構成できます。
- Edit » Refactor » Move Selected Sub-circuit to Different Sheet - このコマンドを使用すると、選択したコンポーネントと配線をプロジェクト内の別のシートに移動できます。Choose Destination Documentダイアログが開き、プロジェクト内の既存の回路図を選択できます。このコマンドの詳細については、後述します。
設計の再構成
Main article: 設計のリファクタリング
設計プロセスは、必ずしも体系的に進むとは限らず、柔軟に展開していくことがよくあります。設計者は、設計の複数の部分について同時にアイデアを練り、その進展に合わせて各部分を回路図に取り込むことがあります。そのため、最初はきちんと整理され、整然と配置されていた回路図も、次第に過密で整理の行き届かない状態になることがあります。切り取り、コピー、貼り付けによって回路図設計を再構成することはできますが、それが常に最善の方法とは限りません。
なぜ切り取りやコピーを使わないのでしょうか。各コンポーネントには配置時に一意識別子が割り当てられ、この識別子はコンポーネントを切り取り/コピーして貼り付けるたびに自動的にリセットされるためです。このUID管理は、設計内で各UIDが一度だけ使用されるようにするためのものです。UIDは、回路図コンポーネントとPCBコンポーネントを関連付けるキーフィールドです。設計をまだPCBエディタに転送していない場合は、切り取り/コピー/貼り付けでも問題ありませんが、転送済みの場合はリファクタリングツールを使用することをお勧めします。
部分回路を別のシートに移動する
回路の一部を別のシートに移動する最も簡単な方法は、その部分を選択してEdit » Refactor » Move Selected Sub-circuit to Different Sheetコマンドを実行することです。Choose Destination Documentダイアログが開きます。移動先のシートを選択してOKをクリックすると、そのシートが表示され、部分回路がカーソルに追従した状態になり、配置できるようになります。

選択した回路の一部は、Move Selected Subcircuit to Different Sheetコマンドを使用して、プロジェクト内の別のシートに簡単に移動できます。
► 設計のリファクタリングについて詳しく見る。
ポートとシートエントリの同期
設計の再構成の一環としてコンポーネントと配線を移動した場合は、各ポートに対応するシートエントリが存在するように、子シートとそのシートシンボルを再同期する必要がある場合があります。これにはSynchronize Sheet Entries and Portsコマンドを使用します。次のように使用できます。
- A specific Sheet Symbol - シートシンボルを右クリックしてコンテキストメニューを表示し、Sheet Symbol Actions » Synchronize Sheet Entries and Portsコマンドを選択すると、カーソルの下にあるシートシンボルのみを解析します。
- All Sheet Symbols in the design - Design » Synchronize Sheet Entries and Portsコマンドを選択すると、設計全体のすべてのシートシンボルを解析します。ダイアログ下部のOnly Show unmatched sheet symbolsオプションに応じて、設計内の各シートシンボルに対応するタブがダイアログに表示されます。
どちらのコマンドでも、Synchronize Ports to Sheet Entriesダイアログが開きます。ダイアログの右側には照合済みのポート/シートエントリが表示され、左側には未照合のポートとシートエントリが2つの列に表示されます。シートシンボルのすべてのシートエントリが、参照先の子シートにある対応するポートと名前およびI/Oタイプの両方で一致している場合、そのシートシンボルは子シートと「同期している」といいます。

Synchronize Ports to Sheet Entriesダイアログは、シートエントリと子シート上のポートが一致していることを確認するために使用します。タブが2つあることに注目してください。これは、この設計にはシートエントリとポートが一致していないシートシンボルが2つあることを示しています。
Synchronize Ports to Sheet Entriesダイアログのオプションとコントロール
-
Unmatched Sheet Entries - この領域には、シートシンボルに関連付けられている、現在未照合のすべてのシートエントリが一覧表示されます。領域の見出しには、シートシンボルのデジグネータが表示されます。各シートエントリには、名前、I/Oタイプ、ハーネスタイプが表示されます。
- Add Ports - このボタンをクリックすると、この領域で現在選択されている各シートエントリに対して、名前、I/Oタイプ、ハーネスタイプが同じポートが自動的に作成されます。子シートに移動し、ポートがカーソルに追従した状態になり、初期配置できるようになります。クリックするかEnter を押して、ポートを配置します。Synchronize ダイアログが再び表示され、シートエントリとポートの各ペアがダイアログのLinks 領域に自動的に追加されます。
- Delete Sheet Entries - このボタンをクリックすると、現在選択されているシートエントリが削除されます。シートエントリは、この領域から削除されるとともに、親シートシンボルからも削除されます。
-
Unmatched Ports - ダイアログのこの領域には、シートシンボルが参照する回路図シート上の、現在未照合のすべてのポートが一覧表示されます。領域の見出しには、ドキュメント名が表示されます。各ポートには、名前、I/Oタイプ、ハーネスタイプが表示されます。
- Add Sheet Entries - このボタンをクリックすると、この領域で現在選択されている各ポートに対して、名前、I/Oタイプ、ハーネスタイプが同じシートエントリが自動的に作成されます。シートシンボルに移動し、シートエントリがカーソルに追従した状態になり、初期配置できるようになります。クリックするかEnter を押して、シートエントリを配置します。Synchronize ダイアログが再び表示され、シートエントリとポートの各ペアがダイアログのLinks 領域に自動的に追加されます。
- Delete Ports - このボタンをクリックすると、現在選択されているポートが削除されます。ポートは、この領域から削除されるとともに、参照先の子シートからも削除されます。
- Links - ダイアログのこの領域には、現在関連付けられている(照合済みの)すべてのシートエントリとポートのペアが一覧表示されます。各項目には、シートエントリとポートの両方で使用されている名前、I/Oタイプ、ハーネスタイプが表示されます。
ボタン
次のボタンを使用すると、同期処理を手動で制御できます。
-
- このボタンをクリックすると、シートエントリに定義されている名前、I/Oタイプ、ハーネスタイプを使用して、選択したシートエントリ(Unmatched Sheet Entries領域内)を、選択したポートエントリ(Unmatched Ports領域内)にリンクします。これに応じて、ポートの名前、I/Oタイプ、ハーネスタイプが変更されます。
-
- このボタンをクリックすると、ポートに定義されている名前、I/Oタイプ、ハーネスタイプを使用して、選択したポートエントリ(Unmatched Sheet Entries領域内)を、選択したシートエントリ(Unmatched Ports領域内)にリンクします。これに応じて、シートエントリの名前、I/Oタイプ、ハーネスタイプが変更されます。
-
- このボタンをクリックすると、ダイアログのLinks 領域で現在選択されているシートエントリとポートの関連付けを解除します。各オブジェクトは、ダイアログ内のそれぞれの未一致領域に表示されます。
追加コントロール
- Only show unmatched sheet symbols - シートシンボルのシートエントリが、参照先の子シート上のポートとすでに完全に同期している場合、ダイアログにはその旨が表示され、各領域は表示されません。このオプションを無効のままにしておくと、一致しているオブジェクトを確認でき、上記で説明したダイアログのすべてのコントロールを使用できます。
ダイアログの左側に表示される不一致項目については、まず1列目でシートエントリを選択し、次に2列目で対応する正しいポートを選択します。その後、ダイアログ中央の適切なボタンをクリックしていずれかを更新し、両者を同期させます(同期した項目はダイアログ右側のリストに移動します)。
各ボタンの機能は次のとおりです。
-
- シートエントリのプロパティを、選択したポートに適用します。
-
- ポートのプロパティを、選択したシートエントリに適用します。
左側の列で複数のシートエントリを選択した場合、ソフトウェアは各シートエントリを2列目の隣接するポートと同期させます。隣接するポート(またはシートエントリ)がない場合は、新たに作成されます。









