シミュレーションモデルの作成
概略
- メーカーからダウンロードしたファイル、コピーしたテキストベースのモデル、手動で記述したサブサーキットファイルなどを使用して、シミュレーションモデルを作成または入手する方法。
- Altium Designerと接続先のWorkspaceで、Workspaceシミュレーションモデルを作成、保存、リンク、編集する方法。
- モデル名、参照ファイル、モデルレベルのパラメーターなど、シミュレーションモデルを正しく定義するために必要な情報。
Altium Designerの混在信号回路シミュレーターを使用して回路設計をシミュレーションするには、回路内のすべてのコンポーネントがシミュレーション可能な状態である必要があります。つまり、各コンポーネントにシミュレーションモデルがリンクされている必要があります。
モデルの種類と入手方法は、主にコンポーネントによって決まり、ある程度は設計者の好みにも左右されます。多くのデバイスメーカーは、自社製品に対応するシミュレーションモデルを提供しています。通常は、必要なモデルファイルをダウンロードして回路図コンポーネントにリンクするだけです。詳しくは、 設計へのシミュレーションモデルの追加を参照してください。
モデルによっては、一から記述する必要があります。たとえば、階層型サブ回路構文を使用して、必要なサブ回路モデルファイル(*.ckt)を作成します。
新しいシミュレーションモデルの作成
一部のモデルは、メーカーやサプライヤーからダウンロード可能なテキストファイルとして提供されています。モデルの詳細が、ダウンロードファイルではなくブラウザーのページ上にテキストとして掲載されている場合もあります。この場合は、Altium Designerで新しいモデルファイルを作成し、ブラウザーのページから内容をコピーして、新しいモデルファイルに貼り付けることができます。以下に示すように、File » New » Mixed Simulationサブメニューの該当するコマンドを使用します。
その後、モデルファイルの情報をコピーして、モデルエディターに貼り付けることができます。

シミュレーションモデルのテキスト内容の例。
Workspaceシミュレーションモデルの作成
Altium Designerでは、接続されたWorkspaceと連携して、Workspaceシミュレーションモデルを作成および管理できます。作成したWorkspaceシミュレーションモデルは、1つ以上のWorkspaceコンポーネントの作成に使用できます。
単一コンポーネント編集モードのコンポーネントエディターで定義中のコンポーネントにシミュレーションモデルファイルを追加し、そのコンポーネントをWorkspaceに保存すると、Workspaceシミュレーションモデルが自動的に作成されますが、以下で説明するように、Workspace内で直接作成することもできます。
-
Componentsパネルを開き、パネル上部の
ボタンをクリックしてModelsを選択し、モデルを表示できるようにします。
-
Simulationsカテゴリーに移動し、
ボタンのメニューからCreate Componentを選択します。
-
開いたCreate New Itemダイアログで必要な情報を入力し、 Open for editing after creationオプションが有効になっていることを確認して、OKをクリックします。Workspaceシミュレーションモデルが作成され、一時的なSimModelエディターが開き、設計スペースに
.SimModelドキュメントがアクティブドキュメントとして表示されます。このドキュメントの名前は、アイテムとリビジョンに基づき、<Item><Revision>.SimModelという形式になります(例:SIM-001-0001-1.SimModel)。
Workspaceシミュレーションモデルの初期リビジョンを編集する例。一時的なSimModelエディターには、シミュレーションモデルを定義するためのドキュメントが表示されます。 - このドキュメントを使用して、必要に応じてWorkspaceシミュレーションモデルを定義します。詳しくは、 シミュレーションモデルの定義を参照してください。
- Projectsパネル内のシミュレーションモデルのエントリーの右側にある Save to Server コントロールを使用して、モデルをWorkspaceに保存します。Edit Revision ダイアログが表示され、必要に応じて名前や説明を変更したり、リリースノートを追加したりできます。保存後、ドキュメントとエディターは閉じます。
-
ソースとなるシミュレーションモデルの定義を含むドキュメント
*.SimModelは、Workspaceシミュレーションモデルのリビジョンに保存されます。シミュレーションモデルは、ComponentsパネルのSimulationsカテゴリーに表示されます。
Componentsパネルに表示された保存済みのWorkspaceシミュレーションモデルWorkspaceに保存されるデータは、
.SimModelファイル内のモデル定義と、参照されている.mdlファイルまたは.cktファイルで構成されます。ExplorerパネルでPreviewアスペクトビュータブに切り替え、参照先のファイルをクリックすると、その内容をプレビューできます。該当する場合は、モデルレベルのパラメーターも表示されます。
Explorerパネルで保存済みのWorkspaceシミュレーションモデルを参照します。保存されたデータを確認するには、Previewアスペクトビュータブに切り替えます。
保存済みのWorkspaceシミュレーションモデルは、コンポーネントエディターの単一コンポーネント編集モードまたは一括コンポーネント編集モードでコンポーネントを定義する際に、Workspaceコンポーネントにリンクできます。
シミュレーションモデルの定義
SimModelファイルでモデルを定義するために必要な情報は、次のとおりです。
-
Model Name – このフィールドでモデル名を指定します。Workspaceに保存すると、この入力値がシミュレーションモデルアイテムのリビジョンのNameとして使用されます。
MDLファイルを参照する場合、モデル定義の
.MODEL行に記載されている名前を指定する必要があります。次の定義を持つダイオードのモデルを例に説明します。.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )この例のモデル名は
1N4002です。この名前をModel Nameフィールドに入力する必要があります。CKTファイルを参照する場合、モデル定義の
.SUBCKT行に記載されている名前を指定する必要があります。次の定義を持つヒューズのモデルを例に説明します。.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSEこの例のモデル名は
FUSEです。この名前をModel Nameフィールドに入力する必要があります。 -
Model File –
.mdlファイルまたは.cktファイルを使用して定義されたモデルの場合は、Browse ボタンを使用して、利用可能なライブラリから必要なファイルを指定します。 - Description – 用途など、モデルの説明を入力します。Workspaceに保存すると、この入力値がシミュレーションモデルのリビジョンのDescriptionとして使用されます。
- Parameters – モデルのモデルレベルパラメーターです(モデルレベルパラメーターを参照)。
-
Model Preview – 参照先の
.mdlファイルまたは.cktファイルの内容を読み取り専用で表示します。
モデルレベルパラメーター
モデルレベルパラメーターはモデル定義の一部であるため、該当する場合はSimModelファイル内で直接定義できます。ドキュメントのParameters領域には、選択したモデルに適用されるパラメーターが自動的に表示されます。パラメーター値はその場で編集できます。リスト内のパラメーターに対応するParameter Valueフィールドをクリックし、必要な値を直接入力してください。

その場で直接編集して、モデル定義の一部としてパラメーターを定義します。
Workspaceシミュレーションモデルの編集
どの段階でも、任意のWorkspaceシミュレーションモデルに戻って直接編集できます。ComponentsパネルでSimulationsカテゴリーを選択し(このカテゴリーにアクセスするには、パネルの
メニューでModelsオプションを有効にする必要があります)、シミュレーションモデルのエントリを右クリックして、コンテキストメニューから Edit コマンドを選択します。一時エディターが再び開き、Workspaceシミュレーションモデルに含まれるファイル(ソースのシミュレーションモデル定義を含むファイル)が編集可能な状態で表示されます。必要な変更を加え、ドキュメントをWorkspaceシミュレーションモデルの次のリビジョンとして保存します。
SimModelファイルの生成
Tools » Generate SimModel Filesコマンドを使用すると、アクティブな回路図ライブラリドキュメントまたはデータベースライブラリドキュメントからSimModelファイルを生成できます。
コマンドを実行すると、 Generate SimModel Filesダイアログが表示されます。各SimModelファイル(およびそれに含まれるシミュレーションモデル定義)は、アクティブな回路図ライブラリ内の回路図コンポーネントのシミュレーションモデルリンク(またはアクティブなデータベースライブラリ内のコンポーネントレコードのシミュレーション情報)に基づいて作成されます。ダイアログ内の各コントロールを使用して、必要に応じて1つ以上のSimModelファイルの生成を設定します。 デフォルトでは、 Sim Models という名前のサブフォルダーが作成されます。必要に応じて、より適切な名前に変更してください。指定したフォルダーが存在する場合はそのフォルダーが使用され、存在しない場合は新たに作成されます。

Generate SimModel Filesダイアログ
必要に応じてオプションを設定したら、 OKをクリックします。生成処理が実行され、完了すると確認ダイアログに生成されたSimModelファイルの数が表示されます。参照されている .mdl、 .ckt、または .scb ファイルも、SimModelファイルと同じ場所に保存されます。
統合ライブラリから移行する場合は、Altium DesignerでIntLibを開き、ソースライブラリの抽出を選択することで、ソース回路図ライブラリ(SchLib)を取得できます。データベースライブラリからSimModelファイルを生成する場合、対象となるのは現在有効になっているテーブル内のコンポーネントのみです。
SimModelファイルの命名方法は、ソースライブラリの種類によって異なります。
- Schematic Library - 各SimModelファイルには、シミュレーションモデルの名前が使用されます。複数の回路図コンポーネントに同じシミュレーションモデルの実装(同じ名前のシミュレーションモデル)が含まれる場合、その名前を使用したSimModelファイルが1つだけ生成されます。
- Database Library - 各SimModelファイルには、コンポーネントレコードの Sim Model Name フィールドで指定されたシミュレーションモデルの名前が使用されます。有効なテーブル内の複数のコンポーネントレコードに同じシミュレーションモデルの実装( Sim Model Name フィールドの値が同じ)が含まれる場合、その名前を使用したSimModelファイルが1つだけ生成されます。
SPICEモデルウィザード
SPICEに組み込まれている一部のアナログデバイスモデルでは、関連するモデルファイル(*.mdl)を使用して、高度な動作特性をパラメーターで定義できます(半導体抵抗、ダイオード、BJTなど)。このモデルファイルを手作業で作成し、必要な回路図コンポーネントに手動でリンクするのは、非常に手間のかかる作業です。SPICE Model Wizardを使用すると、この作業を簡単に行えます。ウィザードでは、ユーザーが取得したデータに基づいて、このようなデバイスの特性を定義できます。直接入力したパラメーター、または提供されたデータから抽出したパラメーターは、自動的にモデルファイルに書き込まれ、そのファイルが指定した回路図コンポーネントにリンクされます。
SPICE Model Wizardは、さまざまなアナログデバイスのSPICEシミュレーションモデルを作成してリンクするための、便利な半自動化ソリューションです。対象となるのは、SPICEに組み込まれており、モデルファイル(*.mdl)のリンクを必要とするデバイスです。モデルの動作特性は、ウィザードに入力した情報に基づいて定義されます。必要な情報の範囲は、モデルを作成するデバイスの種類によって異なり、モデルパラメーターを入力するだけの場合から、メーカーのデータシートや実際のデバイスの測定から得られたデバイスデータを入力する場合まであります。
以降のセクションでは、ウィザードへのアクセスから検証まで、使用方法について説明します。
ウィザードへのアクセス
ウィザードにアクセスするには、回路図シンボルエディターのメインメニューから Tools » XSpice Model Wizard コマンドを選択します。
の最初のページ。ウィザードの次の2つのページでは、以下を選択できます。
- サポートされているデバイスの種類の一覧から、モデル化するデバイスを選択します。
- 生成されるSPICEモデルを、ライブラリドキュメント内の既存のコンポーネントに追加するか、ウィザードで新規作成してそのドキュメントに追加するコンポーネントに追加するかを選択します。
サポートされているデバイスの種類
ウィザードを使用して、以下のアナログデバイスのSPICEモデルを作成できます。
- ダイオード
- 半導体コンデンサー
- 半導体抵抗
- 電流制御スイッチ
- 電圧制御スイッチ
- バイポーラ接合トランジスター
- 有損失伝送線路
- 一様分布RC伝送線路
モデルの命名
ウィザードの各ページを進める際の最も重要な手順の1つが、作成するモデルに名前を付けることです。実際、名前を入力するまでは、ウィザードのパラメーター定義の段階に進むことはできません。
作成後、この名前はSim ModelダイアログのModel Nameフィールドに表示されます。モデルファイル自体も、この名前を使用して作成されます(<ModelName>.mdl)。ウィザードを使用して新しいライブラリコンポーネントにモデルを追加する場合、モデルに指定した名前がコンポーネントの名前にも使用されます。
モデルに名前を付ける際には、短い説明を入力することもできます。説明には、モデルの機能(例:Semiconductor Resistor)や、値または構成に関するより具体的な情報(例: NPN BJT)を記載できます。
モデル化する特性
モデルに名前を付けたら、モデル化する特性を設定する1つ以上のページに進みます。ウィザードでサポートされているモデルの種類は、次の2つのグループに分類できます。
- 各種モデルパラメーターの値を直接入力する必要があるモデル。詳細については、パラメーターの直接入力によるデバイスモデルの作成のセクションを参照してください。
- 選択したデバイスの特性を定義するパラメーターを抽出するために、データの入力が必要なモデル。入力するデータは、実際のデバイスの直接測定結果、またはメーカーのデータシートから取得します。詳細については、データからのパラメーター抽出によるデバイスモデルの作成のセクションを参照してください。
モデルの生成
必要なデータやパラメーターを定義すると、生成されたモデルがウィザードに表示されます。この内容がMDLファイルに保存されます。
このページでモデルを直接編集できるため、モデルの仕様を細かく制御できます。
モデルの定義が完了したら、Nextをクリックしてウィザードの最後のページに進みます。Finishをクリックすると、モデルを保存できます。Save SPICE Model Fileダイアログで、生成されるMDLファイルの保存先を指定します。デフォルトでは、回路図ライブラリドキュメントと同じディレクトリに保存されます。必要に応じて、この段階でファイル名を変更することもできます。
モデルを新しいコンポーネントに関連付けるよう指定した場合、そのコンポーネントが作成され、ライブラリドキュメントに追加されます。
パラメーターの直接入力によるデバイスモデルの作成
以下のデバイスモデルでは、ウィザードは入力データからパラメーター情報を抽出しません。代わりに、関連するパラメーターの値を直接入力してモデルを作成します。パラメーター値を入力する際には、次の点に注意してください。
- パラメーターの値を指定しない場合、作成されるモデルファイルにそのパラメーターは記載されません。この場合、SPICE内部に保存されているデフォルト値が使用されます。つまり、モデルファイルでパラメーターの値を指定すると、その値がパラメーターのデフォルト値を上書きします。
- ウィザード内でパラメーターの初期値が「-」になっており、そのパラメーターの値を明示的に入力しない場合、計算にはSPICE内部のデフォルト値であるゼロが使用されます。
半導体コンデンサー
このデバイスモデルでは、ウィザードを使用して以下のパラメーターを定義できます。値を入力すると、そのパラメーターが生成されるMDLファイルに書き込まれます。
CJ |
接合底面容量(単位:F/m²)。 |
|
CJSW |
接合側壁容量(単位:F/m)。 |
|
DEFW |
デフォルトのデバイス幅(単位:m)。(デフォルト = 1e-6)。 |
|
NARROW |
サイドエッチングによる幅の減少量(単位:m)。(デフォルト = 0)。 |
半導体抵抗
このデバイスモデルでは、ウィザードを使用して以下のパラメーターを定義できます。値を入力すると、そのパラメーターが生成されるMDLファイルに書き込まれます。
TC1 |
1次温度係数(単位:Ω/˚C)。(デフォルト = 0) |
|
TC2 |
2次温度係数(単位:Ω/˚C²)。(デフォルト = 0) |
|
RSH |
シート抵抗(単位:Ω)。 |
|
DEFW |
デフォルトの幅(単位:m)。(デフォルト = 1e-6) |
|
NARROW |
サイドエッチングによる幅の減少量(単位:m)。(デフォルト = 0) |
|
TNOM |
パラメーターの測定温度(単位:˚C)。値を指定しない場合、Advanced Analyses SettingsダイアログのAdvancedタブでTNOMに割り当てられたデフォルト値が使用されます(デフォルト = 27)。 |
電流制御スイッチ
このデバイスモデルでは、ウィザードを使用して以下のパラメーターを定義できます。値を入力すると、そのパラメーターが生成されるMDLファイルに書き込まれます。
IT |
しきい値電流(単位:A)。(デフォルト = 0) |
|
IH |
ヒステリシス電流(単位:A)。(デフォルト = 0) |
|
RON |
オン抵抗(単位:Ω)。(デフォルト = 1) |
|
ROFF |
オフ抵抗(単位:Ω)。デフォルトでは、1/GMINに設定されます。GMINは、Advanced Analyses SettingsダイアログのAdvancedタブで指定する高度なSPICEパラメーターです。回路内のすべてのデバイスに対する最小コンダクタンス(最大抵抗)を設定します。デフォルト値は1e-12 mhoで、これによりROFFのデフォルト値は1000 GΩになります。 |
電圧制御スイッチ
このデバイスモデルでは、ウィザードを使用して以下のパラメーターを定義できます。値を入力すると、そのパラメーターが生成されるMDLファイルに書き込まれます。
VT |
しきい値電圧(単位:V)。(デフォルト = 0) |
|
VH |
ヒステリシス電圧(単位:V)。(デフォルト = 0) |
|
RON |
オン抵抗(単位:Ω)。(デフォルト = 1) |
|
ROFF |
オフ抵抗(単位:Ω)。デフォルトでは、1/GMINに設定されます。GMINは、Advanced Analyses SettingsダイアログのAdvancedタブで指定する高度なSPICEパラメーターです。回路内のすべてのデバイスに対する最小コンダクタンス(最大抵抗)を設定します。デフォルト値は1e-12 mhoで、これによりROFFのデフォルト値は1000 GΩになります。 |
損失のある伝送線路
このデバイスモデルでは、ウィザードを使用して以下のパラメーターを定義できます。値を入力するか、フラグを設定すると、そのパラメーターが生成されるMDLファイルに書き込まれます。
R |
単位長さあたりの抵抗(単位:Ω/単位長)。(デフォルト = 0) |
|
L |
単位長さあたりのインダクタンス(単位:H/単位長)。(デフォルト = 0) |
|
G |
単位長さあたりのコンダクタンス(単位:mho/単位長)。(デフォルト = 0) |
|
C |
単位長さあたりの静電容量(単位:F/単位長)。(デフォルト = 0) |
|
LEN |
伝送線路の長さ。 |
|
REL |
ブレークポイント制御(任意単位)。(デフォルト = 1) |
|
ABS |
ブレークポイント制御(任意単位)。(デフォルト = 1) |
|
NOSTEPLIMIT |
設定すると、タイムステップを線路の遅延時間未満に制限する処理を解除するフラグ。(デフォルト = 未設定) |
|
NOCONTROL |
設定すると、畳み込み誤差の基準に基づくタイムステップの制限を無効にするフラグ。(デフォルト = 未設定) |
|
LININTERP |
設定すると、遅延信号の計算において、デフォルトの2次補間の代わりに線形補間を使用するフラグ。(デフォルト = 未設定) |
|
MIXEDINTERP |
設定すると、指標に基づいて2次補間が適用可能かどうかを判定し、適用できない場合は線形補間を使用するフラグ。(デフォルト = 未設定) |
|
COMPACTREL |
畳み込みに使用する過去の履歴値の圧縮を制御するための値。デフォルトでは、Advanced Analyses SettingsダイアログのAdvancedタブで定義される相対シミュレーション誤差許容値パラメーター(RELTOL)に指定された値を使用します。 |
|
COMPACTABS |
畳み込みに使用する過去の履歴値の圧縮を制御するための値。デフォルトでは、Advanced Analyses SettingsダイアログのAdvancedタブで定義される電流の絶対誤差許容値パラメーター(ABSTOL)に指定された値を使用します。 |
|
TRUNCNR |
設定すると、タイムステップ制御ルーチンで適切なタイムステップを決定するためにニュートン・ラフソン反復法を使用するフラグ。(デフォルト = 未設定。この場合は、直前のタイムステップを毎回半分にする試行錯誤法が使用されます) |
|
TRUNCDONTCUT |
設定すると、インパルス応答に関連する量の実際の計算で誤差を抑えるためにデフォルトで行われる、タイムステップの短縮を無効にするフラグ。(デフォルト = 未設定) |
均一分布RC伝送線路
このデバイスモデルでは、ウィザードを使用して以下のパラメーターを定義できます。値を入力すると、そのパラメーターが生成されるMDLファイルに書き込まれます。
K |
伝搬定数。(デフォルト = 2) |
|
FMAX |
対象とする最大周波数(単位:Hz)。(デフォルト = 1.0G) |
|
RPERL |
単位長さあたりの抵抗(単位:Ω/m)。(デフォルト = 1000) |
|
CPERL |
単位長さあたりの静電容量(単位:F/m)。(デフォルト = 1.0e-15) |
|
ISPERL |
単位長さあたりの飽和電流(単位:A/m)。(デフォルト = 0) |
|
RSPERL |
単位長さあたりのダイオード抵抗(単位:Ω/m)。(デフォルト = 0) |
データからのパラメータ抽出によって作成されるデバイスモデル
ダイオードおよびBJTデバイスでは、ウィザードが入力データからパラメータ情報を抽出します。モデルファイルに含めるために抽出される具体的なパラメータは、モデル化するダイオードまたはBJTの特性によって異なります。
データの入力方法は特性によって異なります。数値を直接入力する場合もあれば、グラフのデータを入力する場合もあります。いずれの場合も、すべてのデータは、デバイスの実測値、メーカーのデータシート、またはその両方から取得します。
グラフのデータを入力する必要がある場合は、元のグラフから読み取った一連のデータ点を、ウィザードのグリッドに入力します。データがカンマ区切り値形式(*.csv)で保存されている場合は、Import Dataボタンを使用してインポートできます。ウィザードは入力されたデータを使用して、必要なモデルパラメータを抽出します。抽出結果は、ウィザードの後続のページに、抽出されたパラメータ値と、入力データおよび抽出パラメータを使用した計算値の比較グラフとして表示されます。以下の画像は、このようなパラメータ結果の表示例です。

ウィザードで必要なモデルパラメータを抽出できるように、元のデータを入力します。
抽出されたパラメータ値を編集して、ダイオードモデルの精度をさらに高めることができます。比較グラフは、変更を反映して更新されます。
ダイオード
以下の各セクションでは、ダイオードデバイスでモデル化できる各特性について詳しく説明します。各セクションでは、抽出されるパラメータと、その抽出のためにウィザードが必要とする元データについて説明します。
順方向バイアス電流
以下のパラメータは、順方向バイアス領域におけるダイオードの直流電流・電圧特性を記述するために使用されます。
IS |
飽和電流(単位:A)。 |
|
N |
放出係数。 |
|
RS |
オーミック抵抗(単位:Ω)。 |
これらのパラメータを抽出するには、ダイオードの順方向電圧(VF)に対する順方向電流(IF)のグラフが必要です。このグラフは、メーカーのデータシート、または実際のデバイスでの測定によって取得できます。
以下の画像は、データシートから取得したグラフの例と、必要な元データを直接測定して取得するためのテスト回路の例を示しています。

順方向バイアス領域におけるダイオードのI-V特性のグラフと回路の例。
元のグラフから取得した一連のデータ点を、ウィザードに入力します。
逆方向バイアス時の接合容量
以下のパラメータは、逆方向バイアス領域で動作するダイオードの容量を記述するために使用されます。
CJO |
ゼロバイアス接合容量(単位:F)。 |
|
M |
接合傾斜係数。 |
|
VJ |
接合電位(単位:V)。 |
これらのパラメータを抽出するには、ダイオードの逆方向電圧(VR)に対する逆方向バイアス時の容量(Cd)のグラフが必要です。このグラフは、メーカーのデータシート、または実際のデバイスでの測定によって取得できます。
画像は、データシートから取得したグラフの例と、必要な元データを直接測定して取得するためのテスト回路の例を示しています。このテスト回路は、静電容量計がない場合に使用できます。

逆方向バイアス領域におけるダイオード容量のグラフと回路の例。
元のグラフから取得した一連のデータ点を、ウィザードに入力します。
上の画像の回路例は、次の式に基づいています。
I = C * (dv/dt)
この式をCについて解くと、次のようになります。
C = I/(dv/dt)
この回路は、電源V1からランプ電圧を生成します。このランプ電圧の傾きを計算することで、式のdv/dtの部分を求めることができます。測定したダイオード電流をランプ電圧の傾きで割ることで、ダイオードの容量曲線を求めることができます。
逆方向バイアス電流
以下のパラメータは、降伏後のデバイスの逆方向バイアス電流を記述するために使用されます。
BV |
逆方向降伏電圧(単位:V)。 |
|
IBV |
降伏電圧での電流(単位:A)。 |
これらのパラメータを抽出するには、ウィザードに次の2つの値を入力する必要があります。
-
逆方向降伏電圧の値。
-
逆方向降伏点でダイオードを流れる電流の値。
これらの値は、メーカーのデータシート、または実際のデバイスでの測定によって取得できます。通常、データシートにはダイオードの電気的特性(直流特性)が表形式で記載されているため、該当する値を見つけ、記載どおりに入力するだけです。
実際のデバイスから直接測定した場合など、元のデータがグラフで示されている場合は、ダイオードが降伏し始める点でこれら2つの値を読み取る必要があります。以下の画像は、そのようなグラフの例です。

グラフから逆方向降伏点の電流値と電圧値を取得。
グラフ上では負の値として表示されていても、ウィザードの各フィールドには必ず正の値として入力してください。
逆回復特性
以下のパラメータは、ダイオードを順方向バイアスから逆方向バイアスに切り替える際の逆回復時間をモデル化するために使用されます。
TT |
走行時間(単位:秒)。 |
このパラメータを抽出するには、順方向電流と逆方向電流が等しい条件(すなわちIR/IF=1)でのダイオードの逆回復時間(Trr)をウィザードに入力する必要があります。このデータは通常、スイッチングダイオードのメーカーデータシートに、単純な数値データとして記載されています。
以下の画像は、メーカーのデータシートでこの情報がどのように記載されているかを示しています。画像内の該当する値、つまりウィザードに入力する値は4nsです。

ダイオードの逆回復時間の取得。
バイポーラ接合トランジスタ(BJT)
バイポーラ接合トランジスタ(BJT)モデルを作成する際、SPICEモデルウィザードでは、パラメーター情報の抽出元となるデータを選択する必要があります。
- 測定データ – 実デバイスの測定から得られたデータを使用し、DC動作のあらゆる側面を記述する高精度なモデルを作成する場合は、このオプションを選択します。
- メーカーのデータシート – データシートのデータを使用する場合は、このオプションを選択します。一般に、データシートには、BJTデバイスのあらゆる側面をモデル化するために必要な詳細情報は含まれていません。ただし、通常は、順方向能動領域のみで使用するデバイスモデルを作成するのに十分な情報が含まれています。
これら2つのオプションの違いは、主にBJTのDC電流電圧特性をモデル化するパラメーターの抽出方法に影響します。逆バイアス時の接合容量と通過時間については、どちらのオプションでもパラメーターの抽出方法は同じです。
以降のセクションでは、BJTデバイスでモデル化できる各特性について、元データの種類(測定データまたはデータシート)に応じて詳しく説明します。それぞれの場合に抽出されるパラメーターと、それらを抽出するためにウィザードで必要となる元データについて説明します。
測定データを使用してモデル化する特性
実デバイスを直接測定して取得したデータを使用すると、以下の特性をモデル化できます。
-
Forward-Bias Parameters
以下のパラメーターは、順方向バイアス領域におけるBJTのDC電流電圧特性を記述するために使用されます。
IS
輸送飽和電流(単位:A)。
BF
理想最大順方向電流増幅率β。
NF
順方向電流放出係数。
RB
ゼロバイアス時のベース抵抗(単位:Ω)。
RC
コレクター抵抗(単位:Ω)。
RE
エミッター抵抗(単位:Ω)。
IKF
順方向電流増幅率βの高電流域での低下が始まるコーナー電流(単位:A)。
ISE
ベース・エミッター間の漏れ飽和電流(単位:A)。
NE
ベース・エミッター間の漏れ電流放出係数。
VAF
順方向アーリー電圧(単位:V)。
以降のセクションでは、必要な測定データについて詳しく説明します。これらのデータを入力することで、ウィザードが各パラメーターを抽出できるようになります。
-
Base-Emitter Voltage versus Base Current
このデータは、RCパラメーターの初期抽出に使用されます。下図に、ベース電流(IB)に対するベース・エミッター間電圧(VBE)のグラフ例と、データ取得のための測定に使用できるテスト回路例を示します。この回路では、ベースに電流を強制的に流し、開回路状態のベース・エミッター間電圧を測定します。
元のグラフから取得した一連のデータポイントをウィザードに入力します。
-
Collector-Emitter Voltage versus Base Current
このデータは、REパラメーターの初期抽出に使用されます。下図に、ベース電流(IB)に対するコレクター・エミッター間電圧(VCE)のグラフ例と、データ取得のための測定に使用できるテスト回路例を示します。この回路では、ベースに電流を強制的に流し、開回路状態のコレクター・エミッター間電圧を測定します。
元のグラフから取得した一連のデータポイントをウィザードに入力します。
-
Forward Gummel Plot
このデータは、主にIS、BF、NF、RB、IKF、ISE、NEパラメーターの抽出に使用されます。また、RC、RE、VAFパラメーターの最適化にも使用されます。下図に、ガンメルプロットの例と、データ取得のための測定に使用できるテスト回路例を示します。ガンメルプロットは、以下を表します。
-
ベース・エミッター間電圧に対するベース電流(IB対VBE)。
-
ベース・エミッター間電圧に対するコレクター電流(IC対VBE)。
ベース・コレクター間電圧(VBC)は0 Vに保持します。
元のガンメルプロットから取得した一連のデータポイントをウィザードに入力します。IBとICには、対数変換前の値を入力する必要があります。ウィザードが曲線データにLN関数を適用します。
-
-
Collector Current versus Base-Emitter Voltage
このデータは、VAFパラメーターの初期抽出に使用されます。下図に、ベース・エミッター間電圧(VBE)に対するコレクター電流(IC)のグラフ例と、データ取得のための測定に使用できるテスト回路例を示します。この回路を使用して、ベース・コレクター間電圧(VBC)の2つの異なる値に対する、IC対VBEの2本の曲線を生成します。曲線は、電流をできるだけ低くし、VBCを実用上可能な限り0 Vに近づけて測定してください。
各元データ曲線に対応する2つの表に、それぞれ一連のデータポイントをウィザードで入力します。また、それぞれに使用したVBCの値も入力する必要があります。
-
-
Reverse-Bias Parameters
以下のパラメーターは、逆方向バイアス領域におけるBJTのDC電流電圧特性を記述するために使用されます。
IS
輸送飽和電流(単位:A)。
BR
理想最大逆方向電流増幅率β。
NR
逆方向電流放出係数。
RB
ゼロバイアス時のベース抵抗(単位:Ω)。
RC
コレクター抵抗(単位:Ω)。
RE
エミッター抵抗(単位:Ω)。
IKR
逆方向電流増幅率βの高電流域での低下が始まるコーナー電流(単位:A)。
ISC
ベース・コレクター間の漏れ飽和電流(単位:A)。
NC
ベース・コレクター間の漏れ電流放出係数。
VAR
逆方向アーリー電圧(単位:V)。
以降のセクションでは、必要な測定データについて詳しく説明します。これらのデータを入力することで、ウィザードが各パラメーターを抽出できるようになります。
-
Reverse Gummel Plot
このデータは、主にIS、BR、NR、RB、IKR、ISC、NCパラメータの抽出に使用されます。また、RC、RE、VARパラメータの最適化にも使用されます。下図に、ガンメルプロットの例と、データを取得するための測定に使用できるテスト回路の例を示します。ガンメルプロットには、次の特性が示されています。
-
ベース・コレクタ間電圧に対するベース電流(IB対VBC)。
-
ベース・コレクタ間電圧に対するエミッタ電流(IE対VBC)。
ベース・エミッタ間電圧(VBE)は0Vに保持されます。
元のガンメルプロットから取得した一連のデータ点をウィザードに入力します。IBとIEの値は、そのままの値を入力する必要があります。ウィザードが曲線データにLN関数を適用します。
-
-
Emitter Current versus Base-Collector Voltage
このデータは、VARパラメータの初期抽出に使用されます。下図に、ベース・コレクタ間電圧(VBC)に対するエミッタ電流(IE)のグラフの例と、データを取得するための測定に使用できるテスト回路の例を示します。この回路では、ベース・エミッタ間電圧(VBE)の異なる2つの値に対して、IE対VBCの曲線を2本生成します。曲線は、電流をできるだけ低くし、VBEを実用上可能な限り0Vに近づけて測定する必要があります。
元の各データ曲線に対応する2つの表に、一連のデータ点をウィザードで入力します。それぞれの場合に使用したVBEの値も入力する必要があります。
-
メーカーのデータシートのデータを使用してモデル化できる特性
メーカーのデータシートから取得したデータを使用すると、次の特性をモデル化できます。
-
Forward-Bias Parameters
以下のパラメータは、順方向バイアス領域におけるBJTの直流電流・電圧特性を記述するために使用されます。
IS
輸送飽和電流(単位:A)。
BF
理想最大順方向電流増幅率β。
NF
順方向電流放出係数。
RE
エミッタ抵抗(単位:Ω)。
IKF
順方向電流増幅率βの高電流域での低下が始まるコーナー電流(単位:A)。
ISE
B-E間漏れ飽和電流(単位:A)。
NE
B-E間漏れ電流放出係数。
以下のセクションでは、必要なデータについて詳しく説明します。これらのデータを入力することで、ウィザードがこれらのパラメータを抽出できます。
-
Base-Emitter Voltage versus Collector Current
このデータは、IS、NF、RE、IKFパラメータの抽出に使用されます。下図に、データシートから取得した、コレクタ電流(IC)に対するベース・エミッタ間電圧(VBE)のグラフの例を示します。
元のグラフから取得した一連のデータ点をウィザードに入力します。ICの値は、そのままの値を入力する必要があります。ウィザードが曲線データにLN関数を適用します。
曲線の強制β比(β = IC/IB)の値も入力する必要があります。上図のプロット例では、この値はグラフの左上に表示されているため、10を入力します。
-
DC Current Gain versus Collector Current
このデータは、BF、NE、ISE、IKFパラメータの抽出に使用されます。下図に、データシートから取得した、コレクタ電流(IC)に対する直流電流増幅率(hFE)のグラフの例を示します。
元のグラフから取得した一連のデータ点をウィザードに入力します。精度を確保するため、コレクタ電流が低い領域、中程度の領域、高い領域での直流電流増幅率の値を入力してください。
-
-
Forward Early Voltage
以下のパラメータは、ガンメル・プーントランジスタモデルにおけるベース幅変調の影響をモデル化するために使用されます。
VAF
順方向アーリー電圧(単位:V)。
このパラメータを抽出するには、コレクタ電流(IC)に対する出力アドミタンス(hOE)の曲線上の1点を入力する必要があります。下図に、このような曲線の例を示します。
曲線上の任意の値を読み取ります。上図の例では、IC = 1mA、hOE = 30μmhosと読み取れます。
通常、データは表形式で記載されています。下図にその例を示します。

出力アドミタンスの表形式の記載例。図中の対象となる値、つまりウィザードに入力する値は、コレクタ電流が1mA、出力アドミタンスが30μmhosです(通常は最大値を使用します)。
測定データまたはメーカーのデータを使用してモデル化できる特性
メーカーのデータシート、または実際のデバイスを直接測定して取得したデータを使用すると、次の特性をモデル化できます。
-
Base-Emitter Capacitance
以下のパラメータは、ベース・エミッタ接合の逆方向バイアス接合容量を記述するために使用されます。
CJE
B-E間のゼロバイアス空乏層容量(単位:F)。
MJE
B-E接合の指数係数。
VJE
B-E間の内蔵電位(単位:V)。
これらのパラメータを抽出するには、逆方向バイアスを印加したB-E接合の電圧(VBE)に対する接合容量(Cj)の特性グラフが必要です。容量計がない場合は、下図のテスト回路例を使用してデータを取得できます。図には、この回路から得られるグラフの例も示されており、VBEとCjをそれぞれ時間に対してプロットしています。これらのグラフから、同じ時刻におけるVBEとCjの値を簡単に読み取ることができます。
元のグラフから取得した一連のデータ点をウィザードに入力します。
上図の回路例は、次の式に基づいています。
I = C * (dv/dt)この式をCについて解くと、次のようになります。
C = I/(dv/dt)この回路は、電源V1からランプ電圧を生成します。このランプ電圧の傾きを計算することで、式の
dv/dtの部分を求めることができます。測定したダイオード電流をランプ電圧の傾きで割ることで、ダイオードの容量曲線が得られます。上図の2つのグラフと回路の関係は次のとおりです。-
上のグラフ – VBEはV1です。
-
下のグラフ – Cjはq1[ie]/(dV1/dt)です。
-
-
Base-Collector Capacitance
以下のパラメーターは、ベース・コレクター接合の逆バイアス接合容量を表すために使用されます。
CJC
B-C間のゼロバイアス空乏層容量(単位:F)。
MJC
B-C接合の指数係数。
VJC
B-C間の内蔵電位(単位:V)。
これらのパラメーターを抽出するには、逆バイアス時のB-C接合容量(Cj)の電圧(VBC)依存性を示すグラフが必要です。容量計がない場合は、下図のテスト回路例を使用してデータを取得できます。図には、このような回路から得られるグラフの例も示されており、VBCとCjをそれぞれ時間に対してプロットしています。これらのグラフから、同じ時点におけるVBCとCjの値を簡単に読み取ることができます。
元のグラフから取得した一連のデータポイントとして、ウィザードにデータを入力します。
上図の回路例は、次の式に基づいています。
I = C * (dv/dt)この式をCについて解くと、次のようになります。
C = I/(dv/dt)この回路は、電源V1からランプ電圧を生成します。このランプ電圧の傾きを計算することで、式の
dv/dtの部分を求めることができます。測定したダイオード電流をランプ電圧の傾きで割ることで、ダイオードの容量曲線が得られます。上図の2つのグラフと回路の関係は次のとおりです。-
上のグラフ – VBCはV1です。
-
下のグラフ – Cjはq1[ic]/(dV1/dt)です。
-
-
Collector-Substrate Capacitance
以下のパラメーターは、コレクター・基板接合の逆バイアス接合容量を表すために使用されます。
CJS
ゼロバイアス時のコレクター・基板間容量(単位:F)。
MJS
基板接合の指数係数。
VJS
基板接合の内蔵電位(単位:V)。
これらのパラメーターを抽出するには、逆バイアス時のC-S接合容量(Cj)の電圧(VCS)依存性を示すグラフが必要です。容量計がない場合は、下図のテスト回路例を使用して データを取得できます。図には、このような回路から得られるグラフの例も示されており、VCSとCjをそれぞれ時間に対してプロットしています。これらのグラフから、同じ時点におけるVCSとCjの値を簡単に読み取ることができます。
元のグラフから取得した一連のデータポイントとして、ウィザードにデータを入力します。
上図の回路例は、次の式に基づいています。
I = C * (dv/dt)この式をCについて解くと、次のようになります。
C = I/(dv/dt)この回路は、電源V1からランプ電圧を生成します。このランプ電圧の傾きを計算することで、式の
dv/dtの部分を求めることができます。測定したダイオード電流をランプ電圧の傾きで割ることで、ダイオードの容量曲線が得られます。上図 24の2つのグラフと回路の関係は次のとおりです。-
上のグラフ – VCSはV1です。
-
下のグラフ – Cjはq1[is]/(dV1/dt)です。
-
-
Transit Times
以下のパラメーターは、BJTの走行時間を表すために使用されます。
TF
理想順方向走行時間(単位:秒)。
TR
理想逆方向走行時間(単位:秒)。
これらのパラメーターを抽出するには、ウィザードにトランジスターのユニティゲイン周波数(fT)を入力する必要があります。これは、トランジスターの電流利得が1になる周波数です。このデータは通常、メーカーのデータシートに単純な数値データとして記載されています。
下図は、メーカーのデータシートにこの情報がどのように記載されているかを示しています。図中の対象の値、すなわちウィザードに入力する値は100MHzです。

電流利得帯域幅積の表記例。
ウィザードで抽出されないパラメーター
以下のパラメーターは、測定データから抽出することが難しく、通常はメーカーのデータシートにも記載されていません。ウィザードではこれらのパラメーターを抽出せず、生成されるBJTのモデルファイルにも追加しません。MDLファイルには含まれませんが、SPICEはBJTデバイスのシミュレーション時に、これらのパラメーターに固有のデフォルト値を使用します。参照しやすいように、以下にデフォルト値を示します。
IRB |
ベース抵抗が最小値に向かって半分まで低下する電流(単位:A)。(デフォルト = 無限大)。 |
|
RBM |
大電流時の最小ベース抵抗(単位:Ω)。(デフォルト = RB)。 |
|
XTF |
TFのバイアス依存性を表す係数。(デフォルト = 0)。 |
|
VTF |
TFのVBC依存性を表す電圧(単位:V)。(デフォルト = 無限大)。 |
|
ITF |
TFへの影響を表す大電流パラメーター(単位:A)。(デフォルト = 0)。 |
|
PTF |
周波数が1.0/(TF*2PI)Hzのときの過剰位相(単位:度)。(デフォルト = 0)。 |
|
XCJC |
内部ベースノードに接続されるB-C空乏層容量の割合。(デフォルト = 1)。 |
|
XTB |
順方向および逆方向の電流増幅率βの温度指数。(デフォルト = 0)。 |
|
EG |
ISへの温度の影響を表すエネルギーギャップ(単位:eV)。(デフォルト = 1.11)。 |
|
XTI |
ISへの温度の影響を表す温度指数。(デフォルト = 3)。 |
|
KF |
フリッカーノイズ係数。(デフォルト = 0)。 |
|
AF |
フリッカーノイズ指数。(デフォルト = 1)。 |
|
FC |
順方向バイアス時の空乏層容量の計算式に用いる係数。(デフォルト = 0.5)。 |
|
TNOM |
パラメーターの測定温度(˚C)。(このパラメーターのデフォルト値は、Analysis SetupダイアログのSPICE OptionsページでTNOMパラメーターに入力された値と同じです。この設定のデフォルト値は27˚Cです)。 |
もちろん、これらのパラメーターはどれでもMDLファイルに手動で追加し、必要に応じて使用する値を指定できます。














