設計環境への順応

概略

インターフェース、アカウントとWorkspaceへの接続、環境設定、日常的な設計作業の概要を通して、Altium Designerの基本を学びましょう。この記事では、プロジェクトやドキュメントの操作方法、設計スペース内の移動方法、設計オブジェクトの配置と設定の始め方を説明します。基本操作をしっかり身につけて、次の設計を始める準備を整えましょう。

- インターフェースの主要な要素を把握し、コマンド、パネル、環境設定の場所を確認します。
- Altiumアカウントにサインインし、利用可能なAltium 365 Workspaceに接続する方法を学びます。
- プロジェクトの種類を理解し、ドキュメントの作成、オープン、保存、ドキュメント間の移動、および設計オブジェクトの配置に関する基本操作を学びます。
AIでさらに深掘り:

Altium Designerは、フロントエンド設計と回路図入力、ミックスドシグナル回路シミュレーション、物理的なPCB設計など、電子機器開発プロセスのあらゆる側面に対応する、包括的な電子製品開発環境を提供します。

このページでは、次の製品設計をすぐに始められるよう、Altium Designerの基本的な操作方法を説明します。

主なUI要素

Altium Designerでは、他のWindowsアプリケーションやCADツールと共通のUI要素が使用されています。主な要素を以下に示し、その後で説明します。

Design space – アクティブなドキュメントが表示される、アプリケーションウィンドウのメイン領域です。デザインスペースでは、ドキュメントの内容(上の画像に示す回路図ドキュメントなど)を確認したり、編集したりできます。

Panels – アクティブなプロジェクトやドキュメントに関連するさまざまな機能にアクセスできます。パネルには、デザインスペースの右下にあるPanelsボタンのメニューからアクセスできます。

Main menus – 現在のドキュメントの種類に応じた操作コマンドにアクセスできます。使用できるメニューとコマンドは、現在アクティブなドキュメントの種類によって異なります。

Active Bar – アクティブバーは、現在のドキュメントのデザインスペース上部に常に表示され、オブジェクトの配置や選択など、よく使用するコマンドにすばやくアクセスできます。

Quick Access Bar – ドキュメントの保存や、操作の取り消し/やり直しなどの基本操作にアクセスできます。

 

Altium Designer環境のこれらの要素やその他の要素について詳しくは、環境の構成要素を参照してください。

Altiumアカウントへのサインイン

オンデマンドライセンスやAltium 365 Workspaceへの接続など、Altiumのオンデマンドサービスにアクセスするには、Altium DesignerからAltiumアカウントにサインインする必要があります。Altiumアカウントにサインインしていない場合、デザインスペースの右上にある現在のユーザーコントロールはと表示されます。サインインするには、このコントロールをクリックし、表示されるメニューから項目を選択します。

Altium Designer Developでは、Sign Inダイアログが表示され、既定のブラウザーでAltiumアカウントにサインインするためのページが開きます。

Altium Designer AgileまたはAltium Designerでは、ブラウザーを使用してサインインするよう求めるSign Inダイアログが表示されます。ボタンをクリックすると、既定のブラウザーでAltiumアカウントにサインインするためのページが開きます。

 

サインインすると、現在のユーザーコントロールがAltiumのプロフィール画像(例:)に変わります。

利用可能なサインインオプションについて詳しくは、Altiumアカウントへのサインインを参照してください。

Altium 365 Workspaceへの接続

Altiumアカウントにサインインすると、利用可能なAltium 365 Workspace(Altium Develop Workspace、Altium Agile Teams Workspace、またはAltium Agile Enterprise Workspace)に接続して、その機能やデータにアクセスできます。接続するには、デザインスペースの右上にあるアクティブワークスペースコントロールをクリックします(ワークスペースに接続していない場合、このコントロールはと表示されます)。表示されるメニューで、接続するAltium 365 Workspaceの項目をクリックします。コントロールの表示が、接続先のワークスペース名(例:)に変わります。

利用可能な接続オプションについて詳しくは、ワークスペースへのアクセスを参照してください。

環境の設定

Preferencesダイアログでは、Altium Designerのさまざまな機能領域にわたるシステム全体の設定を一元的に行えます。Preferencesダイアログにアクセスするには、デザインスペースの右上にあるアイコンをクリックします。

ダイアログの左側にあるページ項目をクリックすると、そのオプションが右側に表示されます。利便性のため、ページは機能領域ごとのカテゴリ(System、Data Management、Schematicなど)に分類されています。

Altium Designerの環境設定について詳しくは、システム環境設定へのアクセス、定義、および管理を参照してください。

設計プロジェクトとドキュメントの操作

Altium Designerで作成するすべての設計は、プロジェクトから始まります。Altium Designerのプロジェクトは、特定の実装を定義する出力を生成する設計ドキュメントの集合です。プロジェクトファイルには、プロジェクト内の各ドキュメントへのリンクに加えて、エラーチェック設定など、プロジェクト固有のオプションも保存されます。

Altium Designerは、PCB、マルチボード、ハーネスの各種設計プロジェクトに対応しています。以下で、それぞれについて簡単に説明します。

プロジェクト管理操作の大半(作成、開くなど)は、FileメインメニューとProjectsパネルを使用して実行します。

Javascript

新しい設計プロジェクトを作成するには、メインメニューからFile » New » Projectコマンドを選択します。開いたCreate Projectダイアログで、プロジェクトの作成先、プロジェクトの種類、プロジェクト名や保存フォルダーなどのオプションを選択します。Createボタンをクリックすると、新しいプロジェクトのエントリがProjectsパネルに表示されます。

プロジェクトに関連するすべてのデータは、ファイルとも呼ばれるドキュメントに保存されます。プロジェクトに新しいドキュメントを追加するには、Projectsパネルでプロジェクトのエントリを右クリックし、Add New to Projectメニューから必要なドキュメントの種類を選択します。

新しく作成したドキュメントは、初期状態では保存されていません。保存するには、Projectsパネルでドキュメントのエントリの右クリックメニューを使用します。同様に、プロジェクトを変更した場合(新しいドキュメントの追加によって構造を変更した場合など)は、Projectsパネルでプロジェクトのエントリの右クリックメニューを使用して保存します。

既存のプロジェクトを開くには、メインメニューのFile » Open Projectコマンドと、その後に表示されるOpen Projectダイアログを使用します。開いたプロジェクトの構造がProjectsパネルに表示されます。

パネル内のドキュメントのエントリをダブルクリックすると、そのドキュメントがデザインスペースで開きます。

Projectsパネルのプロジェクトおよびドキュメントのエントリの横にあるアイコンは、それらの開いている状態、変更の有無、バージョン管理のステータスを視覚的に示します。

「グラフィカル」な種類のドキュメント(回路図シートやPCBドキュメントなど)で作業する際は、ドキュメントをズームおよびパンして、特定の領域に注目できます。この操作に使用できる基本的なショートカットは次のとおりです。

  • Ctrl+Mouse Wheel または Middle-Click, Hold&Drag:ズームイン/ズームアウト

  • Right-Click, Hold&Drag または Mouse Wheel または Shift+Mouse Wheel:ドキュメントの表示位置を移動

以下の動画では、これらのショートカットの使用方法を紹介しています。

設計オブジェクトの操作

回路図シート、PCB、図面など、どのようなドキュメントでも、作成作業の基本は、オブジェクトを必要な位置に配置し、そのプロパティを設定することです。Altium Designerのほとんどのエディターに共通する、主な配置および編集の操作方法を以下に示します。

  1. オブジェクトを配置するには、メインメニューまたはアクティブバーから、対応する配置コマンドを選択します。たとえば、回路図シートにワイヤーを配置するには、メインメニューからPlace » Wireコマンドを選択するか、アクティブバーの アイコンをクリックします。

  2. 配置コマンドを選択すると配置モードになり、カーソルの下に十字線が表示されます。デザインスペース内でカーソルを配置したい位置に移動し、左クリックしてオブジェクトを配置します。ワイヤーやポリゴンなどの複雑なオブジェクトの場合は、位置の指定とクリックを繰り返して、オブジェクトのすべての頂点を配置する必要があります。

  3. 配置モード中にTabを押すと、Properties パネルが開き、オブジェクトを配置する前にそのプロパティを編集できます。プロパティの設定が完了したら、デザインスペース内の ボタンをクリックして配置モードに戻ります。 

  4. 配置モードを終了するには、右クリックします。

  5. 配置済みオブジェクトのプロパティを編集するには、デザインスペース内でオブジェクトをクリックして選択します。そのプロパティがPropertiesパネルに表示されます。パネルが開いていない場合は、オブジェクトをダブルクリックすると、そのオブジェクトが選択され、パネルが開きます。

以下の動画では、オブジェクトの配置とプロパティの編集の手順を紹介しています。

サンプル

ソフトウェアの特定の機能を使い始める際には、サンプルが役立ちます。サンプルで単一の機能や一連の機能の使い方を確認することで、習得が容易になることもあります。同様に、あらかじめ用意されたライブラリを利用できれば、すぐに使用できるコンポーネントの選択肢が広がります。

初回インストール時に、いくつかのサンプル設計がインストールされます。ソフトウェアを標準のデフォルト設定でインストールした場合、これらはインストール先の \Users\Public\Documents\Altium\AD<Solution/Version>\Examples フォルダーにあります。Workspaceに接続すると、サンプルプロジェクト、コンポーネント、その他の設計コンテンツも利用できます(Workspaceのアクティベーション/インストール時にサンプルデータを含めることを選択した場合)。また、ドメインモデル(シンボル、フットプリント、シミュレーションモデル)を備えたコンポーネントは、Manufacturer Part Searchパネルで検索できます。

Altium Designer 10のリリース時に作成された旧リファレンス設計は、こちらからダウンロードできます。これらには、シミュレーションやスクリプトのサンプルが多数含まれています。ただし、これらは旧バージョンのものであり、更新されていないことに注意してください。

ヘルプの利用

Altium Designerには、追加情報やヘルプを見つけるためのさまざまな方法が用意されています。

  • 任意のオブジェクト、エディター、パネル、メニュー項目、ボタンにカーソルを合わせて F1 を押すと、その項目のドキュメントが開きます。
  • コマンドの実行中に Shift+F1 を押すと、そのコマンドで使用できるショートカットの一覧が表示されます。
  • 特定のトピックについて調べるには、ドキュメントの左側にあるナビゲーションツリーを使用します – 画像を表示。

Altium Designerでは、ソフトウェアでエラーが発生した場合に、クラッシュレポートをAltiumの開発者に送信できます。表示されたエラー/例外ダイアログでSend Reportボタンをクリックし、エラー発生時に行っていた操作の説明を追加してください。情報が多いほど、クラッシュの原因を再現し、対処できる可能性が高まります。

クラッシュが発生しても例外ダイアログが表示されず、ソフトウェアがフリーズしたような状態で応答しなくなった場合は、キーボードショートカットCtrl+Alt+Insertを使用してクラッシュレポートを強制的に表示してください。このダイアログは、Altium Designerのアプリケーションウィンドウの背面に表示される場合があります。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents