Altium Designer Documentation

Design Object Selection in Altium Designer

Created: December 8, 2022 | Updated: December 8, 2022

Parent page: Getting Familiar with the Altium Design Environment

Object selection is one of the most important and frequently used operations when working with the main editors of the Altium Designer environment: schematic editor, PCB editor, Draftsman, etc. A design object must be selected before performing an operation on it, such as:

  • editing object location or size;
  • browsing and changing object properties;
  • performing a clipboard operation (cut/copy) or removal, etc.

Altium Designer provides a number of tools to select a required object or group of objects. Many of them are similar to those that can be found in other Windows applications.

When an object is selected, it is highlighted in the selection color (configure the schematic selection color on the Schematic – Graphical Editing page of the Preferences dialog, and the PCB selection color in the View Configuration panel). If the object can be graphically edited, colored editing handles are displayed when the object is selected.

Selected objects are visually distinguished in the editor's design space. Shown here is the component selected on a schematic sheet. Hover the cursor over the image to see a group of tracks selected in a PCB document.
Selected objects are visually distinguished in the editor's design space. Shown here is the component selected on a schematic sheet. Hover the cursor over the image to see a group of tracks selected in a PCB document.

Simple Selection

In the most basic case, you can select an individual design object by hovering the cursor over it and clicking. Certain design objects, once selected, can then be changed graphically with respect to their size and/or shape. The object will become selected and editing handles will be shown at various editing points around the object. To change the shape and/or size of the object, click & drag an editing handle. The exact nature of the change will depend on the object you are editing.

Click a selected object again or click away from objects to deselect it.

Note that selection with clicking is not cumulative. The selected object deselects when you click on another object. To select multiple objects using clicking, hold the Shift key then click sequentially the objects to be selected or deselected. In other words, the Shift+Click shortcut changes the selection status of the object currently under the cursor without affecting the status of other objects.

  • If you do not want to deselect all design objects by clicking anywhere on the schematic design space, disable the Click Clears Selection option in the Schematic – Graphical Editing page or PCB Editor – General page of the Preferences dialog.
  • If you find that you keep inadvertently selecting certain objects, you can make them harder to select by enabling the Shift Click to Select option in the Schematic – Graphical Editing page or PCB Editor – General page of the Preferences dialog. Click the Primitives button to access the Must Hold Shift To Select dialog or the Shift Click To Select dialog, respectively, from where you can configure which objects require Shift to be held during selection.

    The Must Hold Shift To Select and Shift Click To Select dialogs The Must Hold Shift To Select and Shift Click To Select dialogs
    The Must Hold Shift To Select and Shift Click To Select dialogs

  • Where a group of objects overlap, use the command repeatedly to cycle through the objects, selection-wise, with the object at the front selected first then the object drawn next behind it selected, and so on.

This approach is ideal when the number of objects to be selected is small, or perhaps when there are different kinds of objects to be edited simultaneously.

Selection Rectangle

To select a number of objects located in a specific area of the design document, you can use a selection rectangle. Click and Hold away from objects in the corner of the imaginary rectangle enclosing the objects to be selected and Drag to the opposite corner of this rectangle. Note that the behavior of selection using the selection rectangle depends on the direction of dragging – from Left to Right or from Right to Left.

Select Within or Select Touching?

In Altium Designer, selection can either be objects that are: Within the selection rectangle or touching the selection rectangle. This is controlled by the direction you move the mouse as you draw the selection rectangle:

 Select Within - click and drag a blue rectangle from left to right to select all visible objects that are completely within the selection rectangle.
Select Touching - click and drag a green rectangle from right to left to select all visible objects that touch the selection rectangle.
This behavior of the selection rectangle works when the Use Left/Right Selection option is enabled in the System – General page of the Preferences dialog. When this option is disabled, only a blue rectangle is used independently of the mouse move direction, i.e. only objects that fall completely inside the selection rectangle are selected.

Partial Selection - Selecting a Child Object

Certain objects, including schematic components, sheet symbols, and harness connectors, are parent objects because they contain child text strings that can be edited independently. If a child object is selected but the parent is not, the parent's editing handles are displayed without color, indicating that a child of that object is currently selected, but not the entire object.

Certain editing actions, such as a Move command, will include the child object, while other editing actions, such as a Delete command, will not. To delete a parent object and its children, it must be selected (displaying colored editing handles). These differences are demonstrated in the animation below.

Note how the component selection handles change when a child object is selected or the entire component.
Note how the component selection handles change when a child object is selected or the entire component.

Selection/Deselection Commands

To select/deselect objects you can use the commands of the Edit » Select and Edit » DeSelect sub-menus of the main menus. These selection commands include:

  • Inside Area – select/deselect design objects inside of a user-defined rectangular area.
  • Outside Area – select/deselect design objects outside of a user-defined rectangular area.
  • Lasso Select / Lasso Deselect – select/deselect design objects within a user-defined, free-form 'lasso' area.
  • Touching Rectangle – select/deselect any design objects that are touched by a user-defined rectangle.
  • Touching Line – select/deselect any design objects that are touched by a user-defined line.
  • All (shortcut: Ctrl+A) – select all objects on the current document.
  • Toggle Selection – objects that are currently selected will be deselected. Conversely, objects that are currently unselected will become selected.
The S key pops up the Select menu. The X key pops up the DeSelect menu. Selection commands can also be accessed from the  button menu in the Active Bar.

Selection Memory

Eight selection memories are available in the schematic and PCB editors, which can be used to store and recall the selection state of up to eight sets of objects on the schematic or PCB. Select the objects you want to remember and then store them for quick recall later.

The following selection memory options are available:

  • Store in memory (Ctrl + number 1 to 8) - store the current selection in the design space, into the indicated selection memory location.
  • Add to memory (Shift + number 1 to 8) - add the current selection in the design space, to the objects already stored in the indicated selection memory location.
  • Recall from memory (Alt + number 1 to 8) - select the objects in the design space of the current document, that are currently stored in the indicated selection memory location.
  • Recall and Add from memory (Shift + Alt + number 1 to 8) - select objects in the design space of the current document, that are currently stored in the indicated selection memory location, in addition to any objects already selected.
  • Apply memory as a design space filter (Shift + Ctrl + number 1 to 8) - apply a filter to the current document, essentially using the content of the indicated selection memory location as its scope.

You can also access the selection memories using the Edit » Selection Memory sub-menu.

Alternatively, use the Selection Memory dialog that is opened by pressing Ctrl+Q.

The Selection Memory dialog: in the schematic editor (the first image) and in the PCB editor (the second image) The Selection Memory dialog: in the schematic editor (the first image) and in the PCB editor (the second image)
The Selection Memory dialog: in the schematic editor (the first image) and in the PCB editor (the second image)

Click on an STO button to store a selection or RCL to recall a selection. Click Apply to highlight the related memory contents. Click the Clear button or choose the Edit » Selection Memory » Clear » n command from the main menus to clear the content of the indicated selection memory location (this command will not clear the content of the memory location if the Lock option for that location has been enabled in the Selection Memory dialog).

As well as providing controls for manipulating each of the eight available selection memory locations, the dialog also summarizes the content status of each location. Selection content is summarized in terms of quantity of specific object (if the selection contains objects of a single type) or total number of objects (if the selected objects are of differing types).

The visual result of the applied filtering in the design space is determined by a series of controls defined at the bottom of the Selection Memory dialog:

  • Mask - the filtered objects will appear fully visible in the design space with all other objects becoming dimmed. With masking applied, all objects not under the scope of the filter will be unavailable for selection/editing.
  • Select - the filtered objects will be selected in the design space.
  • Zoom - the filtered objects will be zoomed and centered (where possible) in the design space. The zoom action can be determined by the Zoom Library Components options on the Schematic - Library AutoZoom page of the Preferences dialog.
  • Document Scope (schematic editor only) - choose a document scope for the selection. Options are Current Document and Open Documents.

Any combination of these options can be enabled. For example, you might want to have all filtered objects zoomed, centered and selected in the design space while applying masking to take away the clutter of other design objects.

The Clear Existing option, also in the dialog, enables you to extend an existing filter, essentially refining the filter further by applying a new filter in addition to the existing one. To do this, make sure this option is disabled. If it is enabled (default), the existing filter will be cleared before applying the new one.

You can manually clear an existing (and applied) filter at any time by using the Shift+C keyboard shortcut or by clicking the Clear button in the Selection Memory dialog.

To prevent accidentally overwriting a selection memory, enable the Confirm Selection Memory Clear option in the Schematic – Graphical Editing page or PCB Editor – General page of the Preferences dialog. Selection Memory locations can be locked from being overwritten by checking the Lock checkbox associated with that selection memory.

Notes

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: