物理的なマルチボード アセンブリの作成

Altium Designer は、multi-board assembly と呼ばれるマルチボードアセンブリの作成をサポートしています。マルチボード回路図(*.MbsDoc)でシステムの論理構造を定義した後、空のマルチボードアセンブリドキュメント(*.MbaDoc)へシステム設計を転送することで、物理的なマルチボード設計を作成します。この処理により、マルチボード回路図内の各論理ブロックが参照している物理表現(PCB およびその他のマルチボードアセンブリ)が、マルチボードアセンブリエディターに読み込まれます。このページでは、そのプロセスについて説明します。

マルチボードアセンブリの論理設計段階の詳細については、Capturing the Logical System Design のページを参照してください。

マルチボードプロジェクトと関連するサブプロジェクトは、接続された Workspace に保存でき、Altium 365 Workspace または Enterprise Server Workspace が提供するバージョン管理、共有、管理機能を活用できます。

Altium 365 Workspace にマルチボードプロジェクトを保存および共有する方法については、Workspace Projects のページを参照してください。

新しいマルチボードアセンブリドキュメントを作成するには、次の手順を実行します。

  1. *.MbaDoc をマルチボードプロジェクトに新規追加します。Projects パネルでプロジェクトエントリを右クリックし、コンテキストメニューから Add New to Project » Multi-board Assembly を選択します。

    各マルチボード設計プロジェクトには、マルチボードアセンブリドキュメントを 1 つしか含めることができません。

  2. 新しいマルチボードアセンブリドキュメントを保存します(Projects パネルでそのエントリを右クリックし、コンテキストメニューから Save As を選択)。

  3. システムの論理表現をマルチボード回路図からマルチボードアセンブリドキュメントへ転送します。– 詳細はこちら

  4. 筐体がある場合は、それをアセンブリに読み込みます。– 詳細はこちら

  5. アセンブリ内で各要素を配置します。詳細については、Positioning & Orienting Your Boards のページを参照してください。

  6. メイトを使用してアセンブリ内の要素を接続します。詳細については、Working with Mates のページを参照してください。

マルチボードアセンブリの例。複数の接続された PCB が筐体内に配置されています。
マルチボードアセンブリの例。複数の接続された PCB が筐体内に配置されています。

Opening a Multi-board Assembly Created in Altium Designer 18

Altium Designer 18 で作成されたマルチボードアセンブリは、3D エンジンと改善された機能セットをサポートするために必要なファイル形式変更により、インポートする必要があります。旧形式のマルチボードアセンブリドキュメントを開くと、Legacy document import ダイアログが表示されます。

マルチボードアセンブリエディターで Design » Import コマンドを選択すると、子モジュールを再読み込みする ECO が生成されます。

なお、改善された機能セットと 3D エンジンをサポートするために必要なファイル形式変更により、より新しいバージョンの Altium Designer で保存されたマルチボードアセンブリは、Altium Designer 18 では開くことができません。

Multi-board Assembly エディターでは、マルチボードアセンブリの幾何モデリングに Open CASCADE ライブラリを使用しています。以前のバージョンのソフトウェアで作成された古いマルチボードアセンブリドキュメントを開く場合、作成済みのメイトは削除される点に注意してください(アセンブリ部品の相対位置を維持するか、一列に配置するかを選択できます)。また、開く時点で旧バージョンのバックアップを作成することもできます。

この機能は Open Beta であり、System.MBAEngine.UseOpenCascade オプションを Advanced Settings dialog で有効にすると使用できます。

システム設計をマルチボードアセンブリドキュメントへ転送する

マルチボード設計は、次のいずれかのコマンドを使用して、マルチボード回路図からマルチボードアセンブリドキュメントへ転送されます。

  • Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc マルチボード回路図エディターのメインメニューから実行します。

  • Design » Import Changes From <MultiBoardProjectName>.PrjMbd マルチボードアセンブリエディターのメインメニューから実行します。

これらのコマンドのいずれかを実行すると、ソフトウェアはマルチボード回路図上の各モジュールを調査し、各子プロジェクトに対して選択されている PCB/アセンブリを特定し、それらの各ボードをアセンブリに追加するために必要な変更の一覧を Engineering Change Order ダイアログに表示します。

各 PCB プロジェクトのボードは ECO 修正項目として一覧表示され、ECO を実行するとマルチボード Assembly エディターに読み込まれます。
各 PCB プロジェクトのボードは ECO 修正項目として一覧表示され、ECO を実行するとマルチボード Assembly エディターに読み込まれます。

 ボタンをクリックすると、ボード/アセンブリがマルチボードアセンブリエディターに読み込まれます。各ボード/アセンブリは、子プロジェクト内と同じ向きで設計空間に配置されます。この処理では、各 PCB の完全なデータセットを解析して読み込む必要があるため、多少時間がかかります。

このマルチボードアセンブリ内のボードがマルチボードアセンブリエディターの設計空間に読み込まれ、配置可能な状態になっています。
このマルチボードアセンブリ内のボードがマルチボードアセンブリエディターの設計空間に読み込まれ、配置可能な状態になっています。

  • Preferences ダイアログの Multi-board Assembly – General page にあるオプションを使用すると、子 PCB から自由 3D ボディをインポートするかどうか、および指定した高さ未満の 3D ボディをインポートしないかどうかを設定できます。

  • メインメニューの View » Toggle Units コマンド(または Q ショートカット)を使用して、単位をヤード・ポンド法とメートル法の間で切り替えます。

マルチボードアセンブリへの追加オブジェクトの追加

マルチボード回路図で参照されている PCB に加えて、追加オブジェクトをマルチボードアセンブリに読み込むこともできます。追加オブジェクトは、Design メニュー、または Multi-board Assembly パネル上部にあるボタンを使用して読み込めます。

マルチボードアセンブリ内の各エンティティ、または各アイテムは、part と呼ばれます。

適切なコマンドまたはボタンを使用して、次の操作を行います。

  • Insert PCB Part)– このアセンブリに別の PCB を挿入します。

  • Insert MBA Part)– このアセンブリに別のマルチボードアセンブリを挿入します。

  • Insert STEP Part)– このアセンブリに STEP 形式の機械モデルを挿入します。

  • 部品はマルチボードアセンブリに単一エンティティとして挿入される点に注意してください。たとえば、上半分と下半分から成るケースの STEP モデルを挿入した場合、それらの半分を個別に操作することはできません。このような場合は、各半分を別々にアセンブリへ挿入する必要があります。

  • 挿入されたアセンブリまたは PCB は、マルチボード設計プロジェクト(*.PrjMbd)に not 追加されるため、Projects パネルではそのプロジェクトの子としては表示されません。

アセンブリ部品の更新または編集

部品のロック/ロック解除

部品をロック/ロック解除するには、目的の部品を選択して右クリックし、コンテキストメニューの Lock Selected Part/Unlock Selected Part コマンドを選択して、アセンブリエディターの設計空間における現在位置でその部品(またはメイトされた部品)をロック/ロック解除します。あるいは、Multiboard Assembly パネル内の部品エントリを右クリックし、Locked を選択します。

  • ロックされた部品は編集/移動できません。

  • ロックされた部品には、Multiboard Assembly パネル内で南京錠アイコンが表示されます。

  • ロックされた個別部品にはオブジェクトギズモが表示されません(オブジェクトギズモの詳細については、Positioning & Orienting Your Boards のページを参照してください)。 ロックされた部品は、ソースとして選択された場合(移動するオブジェクト)、メイトできません。部品のメイトの詳細については、Working with Mates のページを参照してください。

部品の更新

アセンブリに追加された部品または 3D ボディが更新された場合、次のいずれかの操作を使用して、その更新内容をマルチボードアセンブリに読み込むことができます。

  • メインメニューから Edit » Update All Parts コマンドを選択するか、設計空間内の任意の場所を右クリックしてコンテキストメニューから Update All Parts コマンド(ショートカット: Shift+Ctrl+U)を選択すると、アクティブなマルチボードアセンブリ内のすべての部品が、対応する子 PCB ドキュメントの最新レイアウト情報で更新されます。

  • 必要な部品を選択し、メインメニューから Edit » Update Selected Part コマンドを選択するか、設計空間内の任意の場所を右クリックしてコンテキストメニューから Update Selected Part コマンド(ショートカット: Ctrl+U)を選択すると、アクティブなマルチボードアセンブリ内の選択した部品が、対応する子 PCB ドキュメントの最新レイアウト情報で更新されます。

  • 必要な 3D ボディを選択し、メインメニューから Edit » Update Selected 3D Body コマンドを選択するか、設計空間内の任意の場所を右クリックしてコンテキストメニューから Update Selected 3D Body コマンドを選択すると、アクティブなマルチボードアセンブリ内の選択した 3D ボディが、対応する子 PCB ドキュメントの最新レイアウト情報で更新されます。

部品の編集

アセンブリまたは PCB の編集セッションは、マルチボードアセンブリエディター内から開始できます。必要な部品を選択し、Edit » Edit Selected Part コマンドを実行するか、設計空間内の任意の場所を右クリックしてコンテキストメニューから Edit Selected Part コマンド(ショートカット: Ctrl+E)を選択します。コマンドを実行すると部品編集モードに入り、選択した PCB がメイン設計ウィンドウ内に収まるように(可能な場合は)ズームおよび中央配置されます。そのボードはフルカラー表示のまま維持され、他のすべてのボードはグレー表示(読み取り専用)になります。

必要に応じて、手動配置および/または整列機能を使用してコンポーネント配置を変更します。編集が完了したら、Finish Part Editing コマンド(Ctrl+E)を使用します。設計空間の表示は、アセンブリ内のすべてのボードが収まる表示に戻り、編集していたボードは選択されたままになります。

変更を適用せずに編集をキャンセルしたい場合は、Cancel Part Editing コマンドを使用します。

マルチボードアセンブリのナビゲーションと管理

マルチボードアセンブリをナビゲーションおよび管理するには、Multiboard Assembly パネルを使用できます。

このパネルには、アセンブリ全体の構造が展開可能なツリー表示で示され、以下が含まれます。

  • 含まれているボード(PCB)およびマルチボードアセンブリ、ならびに各 PCB 内のコンポーネント、レイヤー、ネット

  • 含まれている STEP モデル

  • 含まれているその他のマルチボードアセンブリ

  • アセンブリ内のオブジェクト間で形成されたメイト

マルチボードアセンブリ内の要素のハイライト表示

Multiboard Assembly パネルにはハイライト機能があり、ツリーで選択された部品は設計空間内でハイライト表示されます。ハイライトはアセンブリツリー上位レベルの選択に対して双方向に機能します。たとえば、設計空間で上位レベルのオブジェクトを選択すると、それに応じてパネルエントリの選択状態も変化します。パネルからの選択は、論理的に可能なツリーのすべてのレベルでサポートされます。たとえば、個々のネットを選択すると、そのネットがボード全体でハイライト表示されますが、個々の誘電体レイヤーを選択してもそのレイヤーはハイライト表示されません。パネル内での複数選択には、標準の Windows の Shift+Click または Ctrl+Click ショートカットを使用できます。

設計空間で選択された 3 つのボードは、パネル内でもハイライト表示されます。
設計空間で選択された 3 つのボードは、パネル内でもハイライト表示されます。

パネルからのハイライト表示は、特定の部品を見つけたり、娘基板の下を通る複数ネットの経路を確認したりするのに非常に有効です。

アセンブリ部品の表示/透明度の制御

特定の部品または複数の部品をハイライト表示するだけでなく、パネルを使用して、現在パネルで選択されている部品の表示状態および透明度を制御することもできます。選択した部品を右クリックし、コンテキストメニューから Visible または Transparent を選択します。透明に設定された部品は透けて見えるようになります。Visible オプションが無効になっている部品は非表示になります。

Javascript ID: MBA_Pnl_MultiboardAssembly_PartVisibility

STEP モデルはアセンブリ内で完全に表示されています。

同じモデルを透明にしました。

同じモデルを完全に非表示にしました。

PCB、PCB コンポーネント、または STEP モデルの表示状態は、設計空間内で直接制御することもできます。

  • PCB や STEP モデルなどのオブジェクト全体については、そのオブジェクトを選択し、右クリックしてコンテキストメニューを表示し、Visible オプションを選択してオブジェクトを非表示にします。表示を元に戻すには Multi-board Assembly パネルを使用します。

  • PCB コンポーネントについては、設計空間で PCB を選択し、右クリックして Edit Selected Part を選択します。次に、そのボード上の任意のコンポーネントを右クリックし、コンテキストメニューから Visible または Transparent コマンドを選択します。そのボード上のコンポーネントの表示設定が完了したら、再度そのボードを右クリックし、Finish Editing Part または Cancel Editing Part を選択します。

距離の測定

メインメニューの Tools » Measure Distance コマンド(ショートカット: Ctrl+M)は、マルチボードアセンブリ内の 3D ボディ間の距離を測定するために使用します。コマンドを実行すると、測定モードに入ります。測定は次のように行います。

  1. 最初の 3D オブジェクト、またはそのオブジェクトの特定の面を選択します。カーソルを選択可能な 3D オブジェクト上に移動すると、そのオブジェクトの色が変わります。オブジェクトの特定の面を選択したい場合は、カーソルを移動しながら Ctrl  キーを押したままにします。カーソル下の面がハイライト表示されます。カーソルを目的の位置に合わせたら、クリックしてオブジェクト/面の選択を確定します。

  2. 2 つ目の 3D オブジェクト、またはそのオブジェクトの特定の面を選択します。

  3. ツールは、選択した 2 つのオブジェクト(面)間の最短距離を視覚的に表示します。

  4. 他のオブジェクト/面間の距離測定を続けるか、Esc を押して測定モードを終了します。

  • アクティブな測定セッション中のすべての測定結果は、Messages パネルに表示されます。エントリをダブルクリックすると、設計空間内のその測定箇所へクロスプローブできます。

  • 測定セッションを終了すると、すべての視覚的な測定表示と、Messages パネル内のすべての測定エントリがクリアされます。

  • カーソルを 3D ボディ(またはその面)上に移動すると、その色は View Configuration パネルの System Colors セクションにある Highlight Under Cursor システムカラーで指定された色に変わります。

衝突チェック

2 つのオブジェクトの表面が接触または交差している場合は常に、衝突としてフラグ付けされます。

衝突を確認するには、Tools » Check Collisions (ショートカット: Ctrl+K)を選択します。コマンドを実行すると、ソフトウェアはマルチボードアセンブリに含まれる各種エンティティ間の衝突をチェックします。最初に各ボードと上部/下部のエンクロージャー/ケース部品(STEP 部品)との衝突を確認し、続いてボード同士(PCB 間)の衝突を確認します。

衝突がある場合は、Messages パネルを通じて報告され、問題のあるオブジェクトは Violation システムカラーを使用してハイライト表示されます。衝突に関与しているボード上のどのコンポーネントが原因かを調査するには、Messages パネルの Details 領域を使用します。

必要に応じて、衝突チェック実行後に設計空間でハイライト表示された衝突違反は、Tools » Clear Violations コマンドを選択することでクリアできます。

  • 衝突チェックは、設計空間でのボード/部品の表示状態に関係なく、すべてのボードとエンクロージャー/ケース部品との間で実行されます。

  • メイトされた面は、衝突とは見なされません。

Rigid-Flex のサポート

マルチボードアセンブリエディターは rigid-flex PCB をサポートしています。rigid-flex とは、フレキシブル回路とリジッド回路の両方を組み合わせたプリント回路を指します。マルチボードアセンブリエディターでは、PCB エディターで定義された最終的な折り曲げ状態で PCB が表示されます。

rigid-flex PCB の設計に関する情報は、Designing a Rigid-Flex PCB のページを参照してください。

MCAD へのエクスポート

アセンブリは STEP 3D または Parasolid 形式でエクスポートできます。アセンブリ全体を STEP 3D(*.step または *.stp)でエクスポートするには、メインメニューから File » Export » STEP 3D  を選択します。アセンブリ全体を Parasolid 形式(*.x_t)でエクスポートするには、メインメニューから File » Export » Parasolid を選択します。

MCAD ツールで開いたマルチボードアセンブリの STEP ファイルの例。
MCAD ツールで開いたマルチボードアセンブリの STEP ファイルの例。

マルチボードアセンブリは、Altium Designer と対応する MCAD ツールの間で、Altium MCAD CoDesigner 機能を使用して同期することもできます。

詳細については、Synchronizing a Multi-board Assembly のページを参照してください。

PDF 3D へのエクスポート

マルチボードアセンブリドキュメントは PDF ファイル(*.pdf)にエクスポートすることもできます。これを行うには、メインメニューから File » Export to PDF File コマンドを選択します。

詳細については、Preparing a PDF3D File のページを参照してください。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium DevelopAltium Agile TeamsAltium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Content