回路図で回路の接続性を作成する
Altium Essentials: Creating Hierarchy
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
概略
- 物理的な接続と論理的な接続の違いを学び、回路図でそれぞれがどのような場合に役立つかを理解します。
- ワイヤ、ネットラベル、ポート、電源ポート、バス、シートエントリなど、接続を定義する回路図オブジェクトを確認します。
- Connectivity Insightや関連する選択・ハイライトツールを使って、Altium Designerで接続を確認し、接続先へ移動する方法を理解します。
独自の電子回路を構成するのは、部品と、それらの相互接続です。回路図では、部品のピン同士を接続して設計を論理的に表現します。 プリント基板の設計では、実際の部品を配置し、配線によって同じ接続を実現します。
物理的接続と論理的接続
回路図では、ある部品から別の部品へワイヤーを引くことで接続を作成できます。これを物理的接続と呼びます。
また、それぞれの部品ピンに短いワイヤーとネットラベルを配置することで、ピン同士を接続することもできます。ソフトウェアはこれら2つのネット部分を識別し、接続して1つのネットにします。このような接続を論理的接続と呼びます。
物理的接続では、各ワイヤーをたどりながら回路を確認できますが、ワイヤーが多くなると回路図が密集し、見づらくなることがあります。一方、ネットラベルを使うと配線の量を減らせますが、接続先をすべて見つけるにはシート全体を確認する必要があります。設計者は、両方の方法を組み合わせることも含め、設計に最適な接続方法を自由に選択できます。
ワイヤーを配置して物理的接続を作成するか、ネットラベルを使用して論理的接続を作成します。
回路図シートwithinで論理的接続を作成するだけでなく、回路図シートbetweenの論理的接続を作成するためのオブジェクトもあります。この接続の作成方法は、回路図をフラット設計として構成するか、階層設計として構成するかによって異なります。詳しくは後述します。

シート間の接続に使用できるネット識別子には、いくつかの種類があります。
Connectivity Insight
Altium Designerの Connectivity Insight機能(Design Insight機能の一部)では、プロジェクト内の接続関係を即座に表示できます。ドキュメントツリー形式で表示され、必要に応じて回路図のプレビューも表示できます。ツリー内の要素を選択することで、プロジェクトの接続構造を視覚的かつすばやくたどることができます。
デフォルト設定では、Connectivity Insight機能によって次の内容が表示されます。
- 回路図の接続オブジェクト(ワイヤー、ポートなど)にカーソルを合わせると、関連するネットの接続情報が表示されます。
- オブジェクトに対して Alt+Double-click を使用すると、ツリー形式の接続プレビューマップが表示されます。
さらに、信号ネットに属するオブジェクトにカーソルを合わせて Ctrl+Altを押すことで利用できる機能もあります。これにより、選択可能なツリービューが開きます。ツリー内の目的のシートをクリックすると、そのドキュメントにすばやく移動できます。
この機能は、Preferences ダイアログのSystem - Design Insightページで、Document Tree 項目のMouse Hoverオプションをオン/オフにすることで、有効/無効にできます。
接続の作成に使用するオブジェクト
回路図エディターには、接続の作成に使用する次のオブジェクトが用意されています。これらのオブジェクトを総称してnet identifiersと呼びます。
| ネット識別子 | 機能 |
|---|---|
| バス | Data[0..7]など、複数のネットをまとめるために使用します。ネットには、特定の命名規則に従って連番の名前を付ける必要があります(例:Data0、Data1、…Data7)。この命名によって、Data[0..7]のようにバス名が決まります。 |
| バスエントリー | バスラインの両側から異なる2つのネットを引き出す際に、両者が短絡しないようにするためのグラフィカルな要素です。それ以外の場合には必要ありません。 |
| オフシートコネクター | ある回路図シートから別のシートへネットを接続するために使用します(同一シート内の接続には使用しません)。水平接続(フラット設計)のみに対応しています。オフシートコネクターの機能は、ポートと比べて制限されています。 |
| ネットラベル | 同じ回路図シート上にある同名のネットラベルとの接続を作成するためのネット識別子です。ネット名はネットラベルによって自動的に設定されます。ネットラベルは、部品のピン、ワイヤー、バスに配置できます。ただし、プロジェクトオプションでNet Identifier ScopeがGlobalに設定されていない限り、ネットラベルはシート間では接続されません。 |
| ピン | 部品の物理的なピンを表すために、回路図シンボルエディターで配置します。ピンの一端のみが電気的に有効であり、この端をピンのホットエンドと呼ぶこともあります。 |
| ポート | ある回路図シートから別のシートへネットを接続するために使用します。階層設計では垂直方向、フラット設計では水平方向の接続が可能です(垂直設計と水平設計については後述します)。Project Options ダイアログのオプションタブでAllow Ports to Name Netsオプションが有効になっている場合、ポート名がネット名として使用されます。この場合、ポートは同一の回路図シート内でも接続されますが、同名のネットラベルには接続されません(詳細)。 |
| 電源ポート | 設計構造にかかわらず、回路図プロジェクト全体で同名のすべての電源ポートとの接続を作成します。ネット名は電源ポートによって自動的に設定されます。必要に応じて、このネットを特定の回路図シート内に限定できます (詳細)。 |
| シートエントリー | シートシンボル内に配置し、そのシートシンボルの子シートにある同名のポートとの接続を作成します。Project Options ダイアログのOptionsタブでAllow Sheet Entries to Name Netsオプションが有効になっている場合、シートエントリーがネット名として使用されます。 |
| シグナルハーネス | 任意のネット、バス、および下位階層のシグナルハーネスを組み合わせてまとめるために使用します。 |
| ワイヤー | 回路図上の点と点の間に電気的接続を形成するために使用する、ポリライン状の電気設計プリミティブです。ワイヤーは、物理的な電線に相当します。 |
ネットラベル
ネットラベルは、回路図内の異なるポイントを識別し、電気的に接続します。
概要
回路図上の部品ピン間の電気的な接続は、ピン間にワイヤを配置することで作成できます。これは、ピンがワイヤで physically 接続されるため、物理的接続と呼ばれます。また、ネットラベルなどの適切なネット識別子を使用して、論理的に接続することもできます。ネットラベルは、人が認識しやすいネット識別子となるだけでなく、実際にワイヤを配線せずに回路上のポイントを接続できます。
使用方法
ネットラベルは、回路図エディターでのみ、以下の方法で配置できます。
-
メインメニューから Place » Net Label を選択します。
-
設計スペース上部の Active Bar にあるグラフィックオブジェクトのドロップダウンで、Net Label ボタン(
)をクリックします。(Active Bar ボタンを長押しすると、関連する他のコマンドにアクセスできます。一度使用したコマンドは、Active Bar の該当セクションの最上位に表示されます。)
-
設計スペース内で右クリックし、コンテキストメニューから Place » Net Label を選択します。
-
配線 ツールバーの
ボタンをクリックします。
配置
コマンドを実行すると、カーソルが十字に変わり、ネットラベルがカーソルに追従するネットラベル配置モードに入ります。
-
Tab を押すと、プロパティ パネルの Net Label モードが開き、Net Name フィールドが選択されて編集可能な状態になります。新しいネット名を入力します。
-
ネットラベルの左下隅が、割り当て先のオブジェクトに接するように位置を合わせ、クリックするか Enter を押してネットラベルを配置します。
-
続けてネットラベルを配置するか、右クリックまたは Esc を押して配置モードを終了します。
配置中にネットラベルがまだカーソルに追従しており、その中心点が固定される前には、以下の操作も実行できます。
-
Tab キーを押すと、配置を一時停止し、Properties パネルの ネットラベルモードでプロパティをその場で変更できます。設計スペースに重ねて表示される一時停止ボタン(
)をクリックすると、配置を再開できます。
- X キーまたは Y キーを押すと、ネットラベルをX軸方向またはY軸方向に反転できます。
- Spacebar を押すとネットラベルが反時計回りに回転し、Shift+Spacebar を押すと時計回りに回転します。回転は90°単位です。
配置時の注意事項:
- ネットラベルの電気的なホットスポットは左下隅です。有効な接続を確立するには、この隅がワイヤ、バス、またはシグナルハーネスに must 接している必要があります。
- 配置前にネットラベルの Net プロパティを入力し、その値の末尾が数字の場合、以降に配置するネットラベルでは、この数値が自動的にインクリメントされます。この動作は、Preferences ダイアログの 回路図 – 一般 ページにある Auto-Increment During Placement オプションで設定します。ネットラベルには Primary フィールドのみが適用されます。Secondary フィールドは、ピンなど、複数のフィールドを持つオブジェクトに適用されます。
グラフィカル編集
ネットラベルは、in-place 編集と呼ばれる方法でグラフィカルに編集できます。ネットラベルの文字列をその場で編集するには、1回クリックして選択し、少し間を置いてからもう一度クリックして編集モードに入ります。
![]() |
1回クリックして文字列を選択します。 |
![]() |
少し間を置いてからもう一度クリックし、インプレース編集モードに入ります。 |
![]() |
文字列が選択され、置き換える文字列を入力できる状態になります。 |
編集が完了したら、Enter を押すか、文字列以外の場所をクリックしてインプレース編集モードを終了します。
注記
- ネットラベルは、単一の回路図シート内で論理的な接続を作成します。回路図シート間の接続は作成しません。シート間を接続するには、ポートを使用する必要があります。
-
ネットラベルを否定表記にする(上線を付ける)には、次のいずれかの方法を使用します。
-
ネット名の各文字の後にバックスラッシュを付けます(例:
E\N\A\B\L\E)。 -
Preferences ダイアログの 回路図 - グラフィカル編集 ページで Single '\' Negation オプションを有効にし、ネット名の先頭にバックスラッシュを1つ付けます(例:
\ENABLE)。
-
ネット名の各文字の後にバックスラッシュを付けます(例:
- 個々のネットでバスを構成する場合、ネット名の付け方には特定の要件があります。詳細は、バスのページを参照してください。
-
種類の異なるネット識別子は、同じ名前であっても自動的には接続されません。たとえば、
AGNDという名前のネットラベルは、AGNDという名前の電源ポートには自動的に接続されません。接続するにはワイヤを配置する必要があります。
ネットラベルのプロパティ
位置
-
(X/Y)
- X (最初のフィールド)- 現在の設計スペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も入力してください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も入力してください。
- Rotation - ドロップダウンを使用して回転角度を選択します。
プロパティ
- Net Name - ドロップダウンでネット名を選択するか、名前を直接入力します。
- Font - 必要に応じて、コントロールを使用してフォント、フォントサイズ、色、および太字や斜体などの属性を選択します。
- Justification - 希望する配置に対応する矢印をクリックして文字揃えを選択するか、円をクリックして中央揃えにします。
オフシートコネクタ
オフシートコネクタは、回路図シート間の接続を作成するために使用します。
概要
オフシートコネクタは、電気設計プリミティブの一つです。同じ親シートシンボルの下位にある複数の回路図シートにまたがるネットを接続するために使用します。
利用方法
オフシートコネクタは、回路図エディタでのみ、次の方法で配置できます。
-
メインメニューから Place » Off Sheet Connector を選択します。
-
Active Bar上の Off Sheet Connector コマンド(
)を使用します。
-
設計スペースで右クリックし、コンテキストメニューから Place » Off Sheet Connector を選択します。
配置
コマンドを実行すると、カーソルが十字に変わり、オフシートコネクタがカーソルに追従するオフシートコネクタ配置モードになります。
- Tabを押すと、Net Name が選択され、編集可能な状態でProperties パネルのオフシートコネクタモードが開きます。新しいネット名を入力します。
- オフシートコネクタの電気的ホットスポット(カーソルで保持されている端)が接続先のワイヤに接触するように位置を合わせ、クリックするかEnterを押して配置します。
- 引き続きオフシートコネクタを配置するか、右クリックまたはEscを押して配置モードを終了します。
配置中にオフシートコネクタがカーソルに追従している間は、次の操作も可能です。
-
Tab キーを押すと配置が一時停止し、Properties パネルのOff Sheet Connector モードでプロパティをその場で変更できます。作業領域に重ねて表示される一時停止ボタン(
)をクリックすると、配置を再開します。
- XまたはYキーを押すと、オフシートコネクタがX軸またはY軸方向に反転します。
- Spacebar を押すとオフシートコネクタが反時計回りに、Shift+Spacebar を押すと時計回りに回転します。回転は90°単位です。
グラフィカル編集
オフシートコネクタは、in-place編集と呼ばれる方法でグラフィカルに編集できます。オフシートコネクタの文字列をその場で編集するには、1回クリックして選択し、少し間を置いてからもう一度クリックして編集モードに入ります。
少し間を置いてからもう一度クリックし、インプレース編集モードに入ります。
文字列が選択され、置き換える文字列を入力できる状態になります。
オフシートコネクタは、その場で編集できます。
編集が完了したら、Enterを押すか文字列以外の場所をクリックして、インプレース編集モードを終了します。
注意事項
-
オフシートコネクタや分割されたシートシンボルが役立つ場合もありますが、制限があることに注意してください。これらを使用すると、コンポーネントクラスが自動で正しく作成されないため、PCBで手動で再作成する必要があります。
-
特定のネットを2枚以上のシート間で正しく接続するには、各シートのオフシートコネクタを同じネットに割り当てる必要があります。
-
ポートのクロスリファレンスはオフシートコネクタには適用できないため、可能な限り ポート を使用してください。
オフシートコネクタのプロパティ
位置
-
(X/Y)
- X (最初のフィールド)- 現在の作業領域の原点を基準とする、オブジェクトの基準点の現在のX(水平)座標です。この値を編集すると、オブジェクトのX位置が変わります。値はメートル法またはヤード・ポンド法のどちらでも入力できます。現在のデフォルトと異なる単位で入力する場合は、単位も含めてください。
- Y (2番目のフィールド)- 現在の原点を基準とする、オブジェクトの基準点の現在のY(垂直)座標です。この値を編集すると、オブジェクトのY位置が変わります。値はメートル法またはヤード・ポンド法のどちらでも入力できます。現在のデフォルトと異なる単位で入力する場合は、単位も含めてください。
-
Rotation - ドロップダウンで回転角度を選択します。選択肢は
0 Degrees、90 Degrees、180 Degrees、および270 Degreesです。
プロパティ
-
Net Name - ネット名を入力します。
-
Cross Ref - このフィールドには、オフシートコネクタに適用されているクロスリファレンスの値が表示されます。
-
Style - ドロップダウンで、使用可能な選択肢
LeftまたはRightからデフォルトを選択します。カラーボックスをクリックするとドロップダウンが開き、デフォルトの色を選択できます。
一般(ネット)
オフシートコネクタに割り当てられたネットのプロパティを表示します。必要に応じて更新してください。
パラメータ(ネット)
- Selection buttons - グリッドに表示するオブジェクトをクリックします。
- Add - ドロップダウンを使用して目的のオブジェクトを追加し、値を定義します。
電源ポート
概要
電源ポートは、電気設計のプリミティブです。電源ネットまたはグラウンドネットを定義するための特別な回路図オブジェクトです。電源ポートを使用すると、設計内の任意の場所に電源ネットを簡単に示すことができ、ピンやワイヤに接続できます。同じ名前の電源ネットは、次の2つの場合を除き、設計全体で自動的に接続されます。
-
階層設計(つまり、Net Identifier Scopeが
Hierarchicalに設定された設計、または最上位シートにシートエントリが含まれ、Net Identifier ScopeがAutomaticに設定された設計)で、電源ポートをポートオブジェクトに明示的に配線すると、その電源ネットは配置されたシート内でのみ有効になります – この場合、シートをまたぐネット接続は、ポートとシートエントリの組み合わせの配線によって定義する必要があります(詳細はこちら)。 -
Net Identifier Scopeが
Strict Hierarchicalに設定されている場合。この設定では、すべての電源ネットが各シート内でのみ有効になります。詳細については、ネット識別子のスコープの設定を参照してください。
利用方法
回路図エディタでは、次の方法で電源ポートを配置できます。
-
メインメニューから Place » Power Port をクリックします。
-
Wiringツールバーの
ボタンをクリックすると、VCCネットがあらかじめ割り当てられたバー形状の電源ポートを配置できます。 -
Wiringツールバーの
ボタンをクリックすると、GNDネットがあらかじめ割り当てられた電源グラウンド形状の電源ポートを配置できます。 -
Active Barの電源ポートのドロップダウンからコマンドを選択します。
-
Utilitiesツールバーの
ボタンをクリックすると、さまざまな形状や、ネットがあらかじめ割り当てられた複数の電源ポートなど、各種電源ポートコマンドを含むドロップダウンが表示されます。
-
設計スペースで右クリックし、コンテキストメニューから Place » Power Port を選択します。
配置
コマンドを実行すると、カーソルが十字に変わり、電源ポートの配置モードになります。電源ポートのシンボルがカーソルに追従して表示されます。
- オブジェクトの位置を決め、クリックするかEnterを押して配置します。
- 引き続き電源ポートを配置するか、右クリックまたはEscを押して配置モードを終了します。
配置中に電源ポートがカーソルに追従している間は、次の操作も実行できます。
-
Tab キーを押すと配置が一時停止し、Properties パネルのPower Portモードにアクセスして、その場でプロパティを変更できます。配置を再開するには、設計スペースにオーバーレイ表示される一時停止ボタン(
)をクリックします。
- Alt キーを押すと、最初の移動方向に応じて、移動方向が水平軸または垂直軸に制限されます。
- Spacebar を押すと電源ポートが反時計回りに、 Shift+Spacebar を押すと時計回りに回転します。回転は90°単位です。
- X または Y キーを押すと、電源ポートがX軸またはY軸に沿って反転します。
グラフィカル編集
この編集方法では、配置済みの電源ポートオブジェクトを設計スペースで直接選択し、位置をグラフィカルに変更できます。電源ポートのサイズと形状は固定されています。そのため、電源ポートオブジェクトを選択しても編集ハンドルは表示されません。
- 破線のボックス内の任意の場所をクリックし、ドラッグして電源ポートを目的の位置に移動します。ドラッグ中は、電源ポートを回転(Spacebar/Shift+Spacebar)または反転(XキーまたはYキーでX軸またはY軸に沿って反転)できます。
-
電源ポートオブジェクトに割り当てられたネットは、次の方法でその場で編集できます 。
- 電源ポートをシングルクリックして選択します。
- もう一度シングルクリックする(または Enter を押す)と、インプレース編集モードになります。2回のシングルクリックがダブルクリック(Properties パネルが開きます)として認識されないよう、クリックの間隔を十分に空けてください。
- テキストのインプレース編集を終了するには、Enter を押すか、電源ポート以外の場所をマウスでクリックします。
電源ポートのスタイル
電源ポートには、以下のグラフィカルスタイルを使用できます。Properties パネルでオブジェクトの Style プロパティを編集して設定できます。
|
矢印 |
|
バー |
|
円 |
|
アース |
|
GOST 矢印 |
|
GOST バー |
|
GOST アース |
|
GOST 電源グランド |
|
電源グランド |
|
信号グランド |
|
波形 |
注記
-
電源ポートを反転表記にする(名前の上にバーを付ける)には、次のいずれかの方法を使用します。
-
ネット名の各文字の後にバックスラッシュを追加します(例:
V\C\C\3\)。 -
Preferences ダイアログの Schematic - Graphical Editing ページで Single '\' Negation オプションを有効にし、ネット名の先頭にバックスラッシュを1つ追加します(例:
\VCC3)。
-
-
回路図からPCBドキュメントを更新する際には、電源ポートを含む各ネットに Supply Nets デザインルールを追加することをお勧めします。
電源ポートのプロパティ
位置
-
(X/Y)
- X (1番目のフィールド)- 現在のデザインスペースの原点を基準とした、オブジェクトの基準点の現在のX(水平)座標です。編集すると、オブジェクトのX位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位の値を入力する場合は、単位も指定してください。
- Y (2番目のフィールド)- 現在の原点を基準とした、オブジェクトの基準点の現在のY(垂直)座標です。編集すると、オブジェクトのY位置を変更できます。値はメートル法またはヤード・ポンド法のいずれでも入力できます。現在のデフォルトとは異なる単位の値を入力する場合は、単位も指定してください。
- Rotation - ドロップダウンで回転角度を選択します。
プロパティ
-
Name - 電源ポートの名前です。目のアイコンを使用して、名前の表示/非表示を切り替えます。
-
Style - ドロップダウンで電源オブジェクトのスタイルを選択します。選択内容に応じてプレビュー画像が更新されます。カラーボックスをクリックして色を選択します。
-
Font - コントロールを使用して、必要に応じてフォント、フォントサイズ、色、および太字や斜体などの属性を選択します。
一般(ネット)
電源ポートに割り当てられているネットのプロパティを表示します。必要に応じて更新してください。
パラメーター(ネット)
- Selection buttons - グリッドに表示するオブジェクトをクリックします。
- Add - ドロップダウンで必要なオブジェクトを追加し、値を定義します。
ワイヤ
ワイヤは、回路図内の電気的な接続を作成するために使用します。
概要
ワイヤは、回路図上の点と点の間に電気的な接続を形成するための、ポリライン形状の電気設計プリミティブです。物理的な電線に相当します。
使用方法
ワイヤは回路図エディターでのみ配置でき、以下の方法で配置を開始できます。
- メインメニューから Place » Wire を選択します。
-
デザインスペース上部の Active Bar にあるドロップダウンで、ワイヤボタン(
)をクリックします。(Active Bar ボタンを長押しすると、関連するその他のコマンドにアクセスできます。一度使用したコマンドは、Active Bar の該当セクションの最上位項目になります。)
-
Wiring ツールバーの
ボタンをクリックします。
- デザインスペース内で右クリックし、コンテキストメニューから Place » Wire コマンドを選択します。
- Ctrl+W ショートカットを使用します。
配置
コマンドを実行すると、カーソルが十字に変わり、ワイヤ配置モードになります。次の手順で配置します。
- クリックするか Enter を押して、ワイヤの始点を固定します。
- カーソルを合わせてクリックするか、Enter を押して、ワイヤの形状を定義する一連の頂点を固定します。
- 最後の頂点を配置したら、右クリックするか Esc を押して、ワイヤの配置を完了します。
- 続けてワイヤオブジェクトを配置するか、右クリックまたは Esc を押して配置モードを終了します。
- 最後に配置したワイヤセグメントを削除するには、Backspace キーまたは Delete キーを使用します。
配置モード
ワイヤの配置には、3つの「手動」配置モードがあり、そのうち2つには開始と終了のサブモードがあります。配置モードは、ワイヤを配置する際のコーナーの作成方法と、配置できるワイヤの角度を指定します。配置中は、次の操作が可能です。
-
Shift+Spacebar を押すと、モードが順番に切り替わります。
-
90 Degreeモードまたは45 Degreeモード(真の直交モード)では、Spacebar を押すと、開始と終了のサブモードが切り替わります。 -
配置中は、現在の配置モードがステータスバーに表示されます。ワイヤの配置中は、いつでもモードを変更できます。
-
Any Angle以外のモードでは、カーソルに接続されている線分は look-ahead セグメントです。実際に配置されるセグメントは、この先行表示セグメントの手前にあります。
ガイド付きワイヤ配線
回路図には、オブジェクト間の電気的接続を簡単に定義できる、設定可能な電気的グリッドがあります。ワイヤの配置中に、ワイヤが別の電気オブジェクトの電気的グリッド範囲内に入ると、カーソルがその固定オブジェクトにスナップし、ホットスポット(青い十字)が表示されます。
ホットスポットは、有効な接続を作成できる位置を示し、カーソルを電気的接続点に自動的にスナップさせます。
電気的グリッドは、Document Option モードの Properties パネルにある General タブで定義できます。電気的グリッドは、現在のスナップグリッドより少し小さく設定することをお勧めします。そうしないと、電気オブジェクトをスナップグリッド1つ分の間隔で配置しにくくなる場合があります。
グラフィカル編集
この編集方法では、デザインスペース内で配置済みのワイヤオブジェクトを直接選択し、そのサイズや形状をグラフィカルに変更できます。
ワイヤオブジェクトを選択すると、次の編集ハンドルが使用可能になります。
- A をクリックしてドラッグすると、ワイヤの端点の位置を変更できます。
- B をクリックしてドラッグすると、ワイヤの頂点を移動できます。端点は固定されたままになります。
- ワイヤセグメントをクリックしてドラッグすると、そのセグメントを grab して位置を変更できます。端点とその他の頂点は固定されたままになります。
-
頂点を右クリックして Edit Wire Vertex n コマンドを選択すると、Wire ダイアログが開き、
nth頂点の項目が選択された編集可能な状態になります。必要に応じて、頂点やワイヤのその他のプロパティを編集してください。詳細については、ワイヤのプロパティセクションを参照してください。 - 頂点をクリックしたまま、キーボードの Delete を押すと、その頂点を削除できます。
ドラッグに関する情報
- ドラッグ中は、ホットスポットによって、自動ジャンクションが作成される位置が視覚的に示されます。
- ドラッグが終了すると、不要または冗長な自動ジャンクションが削除されます。
新しい自動ジャンクションの作成位置の表示
影響を受けるワイヤの接続状態によっては、ドラッグ操作により、新しい位置に自動ジャンクションが作成されることがあります。これらの新しいジャンクションが作成される位置を視覚的に示すため、ホットスポットが使用されます。ワイヤとバスのホットスポットの使用を有効にし、その色を設定するには、Preferences ダイアログの Schematic - Compiler ページにある Auto-Junctions 領域を使用します。
選択と削除
ワイヤが選択されている状態でセグメントをクリックすると、そのセグメントを個別に選択できます。このワイヤの「サブ選択」状態は、対応する編集ハンドルが赤色になることで識別できます。
その後、SCH List パネルを使用して、セグメントに対応する頂点を直接編集できます。変更は直ちに回路図に反映されます。
選択したワイヤセグメントは、Delete キーを押して削除することもできます。異なるワイヤにまたがる複数のセグメントを削除できます。それぞれが選択されていることを確認してください(追加する各セグメントで Shift+Click を2回行うと、セグメントの選択対象に追加されます)。自動ジャンクションも考慮されるため、ワイヤのセグメントをそのジャンクションまでの範囲だけ削除できます(削除後、そのジャンクションに接続する他のワイヤセグメントが2本だけになる場合は、ジャンクションも削除されます)。
自動ジャンクション
ワイヤのT字接続は、ジャンクション(コンパイラ生成ジャンクション)によって自動的に接続されます。Preferences ダイアログのSchematic - GeneralページでBreak Wires At Autojunctionsオプションが有効になっている場合、自動ジャンクションが挿入される位置で、既存のワイヤセグメントが2つに分割されます。たとえば、T字接続を作成すると、直交するワイヤセグメントがジャンクションの両側で1つずつ、計2つのセグメントに分割されます。Break Wires At Autojunctionsオプションが無効の場合、ワイヤセグメントはジャンクションで分割されません。
ワイヤのプロパティ
一般(ネット)
ワイヤに割り当てられたネットのプロパティを表示します。
頂点
- Width - ドロップダウンから目的の幅を選択します。カラーボックスをクリックして、オブジェクトの色を選択します。
-
Vertices Grid - オブジェクトに現在定義されているすべての頂点を、以下の項目で一覧表示します。
- Index - 頂点に割り当てられたインデックス(編集不可)。
- X - 頂点のX座標(水平方向)。クリックして編集します。
- Y - 頂点のY座標(垂直方向)。クリックして編集します。
-
Add - クリックして新しい頂点を追加します。新しい頂点は、現在フォーカスされている頂点エントリの下に追加され、初期状態ではそのエントリと同じX、Y座標になります。
をクリックすると、現在選択されている頂点を削除できます。
パラメータ(ネット)
- Selection buttons - グリッドに表示するオブジェクトをクリックします。
- Add - ドロップダウンを使用して目的のオブジェクトを追加し、値を定義します。
コンパイラ生成ジャンクション

回路図コンパイラは、各T字接続にジャンクションを自動的に追加して、電気的接続を確立します。
概要
ジャンクションは、電気設計プリミティブの1つです。回路図シート上で交差するワイヤ(またはバス、シグナルハーネス)を接続するための、小さな円形オブジェクトです。コンパイラ生成ジャンクションは、2本のワイヤ/バス/シグナルハーネスをT字型に接続したとき、またはワイヤ/バス/シグナルハーネスをピン、電源ポート、その他の電気的オブジェクトに直交して接続したときに、自動ジャンクション機能によって自動配置されるジャンクションです。
利用方法
この種類のジャンクションは、回路図エディタの自動ジャンクション機能によって自動的に配置されます。そのため、ユーザーがアクセスして配置できる設計オブジェクトではありません。
配置
コンパイラ生成ジャンクションは、配線中にT字接続が生じるたびに自動的に配置されます。たとえば、2本のワイヤ/バス/シグナルハーネスがT字型に接続する場合や、ワイヤ/バス/シグナルハーネスがコンポーネントのピンの端点、または電源ポートなどの他の電気的オブジェクトと直交する場合です。
編集
コンパイラ生成ジャンクションは、通常の方法(ダイアログ、または回路図シート上のグラフィカルな操作)では編集できません。コンパイラ生成ジャンクションの表示プロパティは、以下の画像に示すように、PreferencesダイアログのSchematic - Compilerページで設定します。コンパイラ生成ジャンクションの表示を無効にしても、そのジャンクション位置での電気的接続は切断されません。
Preferencesダイアログで、コンパイラ生成ジャンクション(自動ジャンクション)の表示オプションを設定します。
新しい自動ジャンクションの作成位置の表示
影響を受ける配線によっては、ドラッグ操作によって新しい位置に自動ジャンクションが作成されることがあります。これらの新しいジャンクションが作成される位置を視覚的に示すために、ホットスポットが使用されます。このホットスポットの使用を有効にし、ワイヤ用とバス用の色を指定する設定も、環境設定で行います。
ドラッグ操作中に予測される自動ジャンクションの表示を制御します。

ドラッグ操作によって作成されると予測される、新しい自動ジャンクションの表示例。
接続変更の視覚的な表示
コンポーネントをドラッグしているときに、誤って少し遠くまで移動したり、意図した経路から外れたりすると、意図しない自動ジャンクションが作成され、回路の接続に致命的な変更が生じる可能性があります。ドラッグ中の接続状態を即座に視覚的に示すために、次の2種類のアイコンが使用されます。
- OK - ドラッグ操作によって回路の接続は変更されません。
- Alert - ドラッグ操作によって回路の接続が変更されます。
ドラッグ中は、該当するアイコンがカーソルの近くに表示されます。

ドラッグ操作によって接続が変更されることを視覚的に警告します。
十字ジャンクションの変換
4方向のジャンクション(ワイヤまたはバスオブジェクトで作成されたもの)を、隣接する2つの3方向ジャンクションにすばやく変換できます。これを行うには、メインメニューからTools » Convert » Convert Cross Junctionsコマンドを選択します。コマンドを実行すると、Junctions Conversionダイアログが表示されます。このダイアログで、変換の対象範囲(現在のドキュメント、プロジェクト内のドキュメント、または開いているすべての回路図ドキュメント)を指定し、対象ドキュメント内の該当するすべての4方向ジャンクションを変換するか、選択したワイヤ/バスに関連するものだけを変換するかを設定します。変換オプションを設定したら、ダイアログのOK をクリックして変換を実行します。

Junctions Conversionダイアログ
Junctions Conversionダイアログのオプション/コントロール
適用範囲
-
Sheet Scope - 次のいずれかのオプションを選択して、更新の適用範囲を指定します。
- Current Document - アクティブな回路図ドキュメントのみを、現在のテンプレートへの変更に合わせて更新します。
- Project Documents - アクティブな回路図ドキュメントと、アクティブなプロジェクト内のその他すべての回路図ドキュメントを、それぞれの現在のテンプレートへの変更に合わせて更新します。 現在閉じている回路図は開かれます。
- Open Documents - アクティブな回路図ドキュメントと、開いているその他すべての回路図ドキュメントを、所属するプロジェクトに関係なく、それぞれの現在のテンプレートへの変更に合わせて更新します。
-
Selection - ドロップダウンを使用して、適用範囲内の対象オブジェクトを選択します。
- Selected Objects - Sheet Scopeで指定したシート内で選択されているオブジェクトのみを対象にします。
- All Objects - Sheet Scopeで指定したシート内のすべてのオブジェクトを対象にします。
オプション
- Miter Size - マイターのサイズを定義する値を入力します。
設計構造が接続性に与える影響
Related page: マルチシート設計と階層設計
設計が1枚の回路図シートに収まらない場合は、複数のシートに分割できます。マルチシート回路図の構成と接続の作成には、2つの異なるモデルがあります。1つは、大きな1枚の回路図シートを複数の小さなシートに分割したものと考えられるフラット設計です。もう1つは、祖父母・親・子のような構造でシートをリンクする階層設計です。
マルチシート設計は、下図のように、子シートを表してそのシートにリンクするシートシンボルを親シートに配置することで実現します。

シートシンボルは下位レベルのシートを表し、そのシートにリンクします。フラット設計では、この構造の深さは1階層のみですが、 階層設計では深さに制限はありません。
フラット設計
Related page: マルチシート設計と階層設計
あるシートから別のシートへ直接接続が作成される設計を、フラット設計と呼びます。この接続は、親シート上のシートシンボルを経由しません。フラット設計では、シートシンボルは単に子シートを表し、参照するだけです。階層がないため、設計内のすべてのシートはProjectsパネル内で同じレベルに表示されます。 以下の2つの画像は、どちらもフラット設計を示しています。
フラット設計は、より簡単に作成できます。フラット設計には、各子シートのシートシンボルを配置した最上位シートを含めることができます。ただし、この最上位シートはシート間接続の作成には使用されないため、必須ではありません。回路図シートが2~3枚しかない小規模な設計では、最上位シートを設ける利点はないと判断するかもしれません。シート数が増えた場合には、最上位シート上の論理ブロック(シートシンボル)の配置によって、回路設計の機能を読み手が理解しやすくなります。

同じ設計を、最上位シートなし(左)と最上位シートあり(右)で示しています。どちらもフラット設計の例です。
フラット設計では、上の画像の拡大部分に示すように、ポート、オフシートコネクタ、電源ポート、ネットラベルを使用してシート間の接続を作成できます。推奨される方法は、各シートwithinの接続にはネットラベルを使用し、シートbetweenの接続にはポートを使用することです。ポートはオフシートコネクタより多くの機能を備えており、ポート相互参照を追加することもできます。この機能は、下図のように、別のシート上の対応するポートを参照するSheetName[GridReference]を各ポートに追加します。
フラット設計のシート数に制限はありません。

各ポートの横にポート相互参照が追加され、対応するポートがあるシートとグリッド参照が示されています。
階層設計
Main page: マルチシート設計と階層設計
シートシンボルから、そのシートシンボルが参照する下位の子シートへとシート間接続が作成される設計を、階層設計と呼びます。 ネットレベルでは、そのシートシンボル内のシートエントリと、子シート上の同名のポートとの間に接続が作成されます。 この接続方式は、作成されるシート間接続が親シートとその子シートの間の上下方向に限られることから、垂直接続とも呼ばれます。

階層設計では、 ネットレベルの接続は、親シート上のシートエントリから、 子シート上の対応するポートへと下方向に作成されます。
階層設計には、 2つの大きな利点があります。
- 1つ目は、回路図シートを論理ブロック(シートシンボル)として構成して示すことで、設計の機能を読み手に伝えられることです。最上位の回路図では、設計を高レベルの機能ブロックの集合として表し、 回路全体における従来の左から右、入力から出力への流れの中での位置を反映するように各ブロックを配置します。 必要に応じて、これらのブロックをさらに小さなブロックに分割することもできます。これにより、部品を配置する最下位レベルの回路図を、部品数の少ない比較的単純な構造にできます。 各シートが比較的単純なため、シートの実寸を小さく抑えることができ、回路図を印刷する際に大きな利点となります。
- もう1つの大きな利点は、階層設計では一般に信号をはるかに追跡しやすいことです。 親シートのシートエントリと子シートの対応するポートを照合するだけで、各シート内の配線に沿って信号を追跡できます。
階層設計の構築には追加の作業が必要です。シートシンボルにはシートエントリが必要であり、 最上位シートでは、シートシンボル間で信号を伝達するための配線を行う必要があります。ソフトウェアには、シートエントリを子シートのポートと同期させるためのツールが用意されています(すべてのシートシンボルにはDesign » Synchronize Sheet Entries and Portsを使用し、個別のシートシンボルには、そのシートシンボルを右クリックして Sheet Symbol Actions » Synchronize Sheet Entries and Portsを選択します)。また、大規模な設計を小さな単位に分割するためのツールも用意されています(Edit » Refactor » Move Selected Subcircuit to Different Sheet)。これらの再構成およびリファクタリングツールの詳細については、 設計のリファクタリングページを参照してください。
階層設計では、階層の深さにも、含める回路図シートの数にも制限はありません。
マルチチャネル設計
Main article: マルチチャネル設計の作成
電子回路設計に同じ回路が繰り返し含まれることは珍しくありません。たとえば、ステレオアンプや 64チャネルのミキシングコンソールなどです。このような設計は、multi-channel designと呼ばれる機能群によって全面的にサポートされています。 マルチチャネル設計では、繰り返す回路を一度だけ作成し、 同じ子回路図を参照する複数のシートシンボルを配置するか、 1つのシートシンボルで参照先の子回路図を必要な回数だけ繰り返すように設定することで、ソフトウェアに回路の繰り返しを指示します。コンパイルされた設計は、 ユーザー定義の命名規則に従い、すべてのコンポーネントと接続を必要な回数だけ繰り返した状態で、 コンピューターのメモリ上に展開されます。

左側では、4つのシートシンボルがすべて同じ子シート(PortIO.SchDoc)を参照しています。 右側では、Repeat キーワードによってInputChannel.SchDocが8回繰り返されています。
作成した論理設計が実際にフラット化されることはなく、 常にマルチチャネル回路図として保持されます。PCBレイアウトに転送すると、物理的なコンポーネントとネットが必要な回数だけ展開され、回路図と基板間での作業で利用できるクロスプローブおよびクロスセレクトツールをすべて使用できます。また、PCBエディターには、1つのチャネルの配置と配線を他のすべてのチャネルに複製するツールがあり、チャネル全体の移動や向きの変更も簡単に行えます。マルチチャネル設計の詳細については、マルチチャネル設計のドキュメントを参照してください。
ソフトウェアは階層構造モデルを使用してメモリ内にチャネルをインスタンス化するため、マルチチャネル設計は階層設計である必要があります。
Net Identifier Scopeの設定
Dialog page: プロジェクトのオプション
ソフトウェアは、Net Identifier Scopeの現在の設定に基づいて、 回路図シート間の接続方法を決定します。Net Identifier Scopeは、Project OptionsダイアログのOptionsタブで設定します(Project » Project Options)。

設計の構造に適したNet Identifier Scopeモードを選択してください。
Global、Flat 、およびHierarchicalの各オプションの動作を以下の図に示します。

3つの主要なモード(Global、Flat、Hierarchical)それぞれで接続がどのように形成されるかを示す簡単な例。
上記の3つのオプションに加えて、Automaticオプションもあります。通常は、Net Identifier Scope をAutomaticに設定しておくことをお勧めします。ソフトウェアは、シートの構造と、ポートおよびシートエントリの有無に基づいて、3つのオプションから最適なものを選択します。
Automaticに設定すると、ソフトウェアは以下の条件に基づいて、 3つの主要なネット識別子モードのうち、どれを使用するかを自動的に選択します。
-
最上位シートにシートエントリがある場合は、
Hierarchicalが使用されます。 -
シートエントリがなく、 ポートがある場合は、
Flatが使用されます。 -
シートエントリもポートもない場合は、
Globalが使用されます。
ネットの命名方法
コンポーネントのピン間にワイヤを配置するたびに、接続が形成されます。設計内のすべてのネットには名前が付けられます。ネットの命名に使用できるネット識別子が配置されていない場合、ソフトウェアはそのネットに含まれるピンの1つに基づいてネット名を付けます。たとえば、 以下の図に示すNetR7_1のようになります。 後でコンポーネントのデジグネータが変更されると、 システムが生成したネット名も変更されます。すべての同期を維持するには、これらの変更を回路図とPCBの間で反映する必要があります。

ネット識別子のないネットには、そのネットに含まれるピンの1つに基づいて、 システムが生成した名前が割り当てられます。
1つのネット上の複数のネット識別子
同一の回路図シート内で、同じネットに異なる名前のネットラベルを複数配置することはできません。このような状態は、検証時に検出され、エラーとして報告されます。ただし、同じネットが複数のシートにまたがっている場合、それぞれのシート上でそのネットに異なるネット識別子を付けることは可能です。
この機能により、次のことが可能になります。
- 階層の各レベルでネット名を変更し、そのシートにおける機能をより適切に表す。
- 子回路図シート上のネット名を変更することなく、そのシートを再利用する。
ネット名を制御するためのオプション
Dialog page: プロジェクトオプション
最終的に、PCB上の各ネットには1つの名前しか付けられません(Net Tieを使用して2つのネットを意図的に接続する場合を除き、1つのPCBネットに2つの名前を付けることはできません)。ソフトウェアは、複数の名前を持つネットを自動的に解決し、プロジェクト内で名前を1つに統一しますが、その名前が想定どおりになるとは限りません。Project OptionsダイアログのOptionsタブのNetlist Optionsセクションには、名前の選択方法を制御するためのオプションが用意されています。各オプションの詳細については、Project Optionsダイアログのページを参照してください。
これらのオプションを設定する際は、Allow Ports to Name NetsおよびHigher Level Names Take Priorityオプションを有効にすることをお勧めします。これらの設定に加えて、各シートの重要なネットにネットラベルを適切に使用することで、シートをまたぐネットを含むすべての重要なネットに名前が付けられ、上位階層の回路図で割り当てた名前が下位階層の回路図でも使用されるようになります。
同じ名前を持つ2つの別々のネット
ネット名に関して発生し得るもう1つの問題は、異なる回路図シート上で、別々のネットに同じネット名が付けられている場合です。これは検証時にDuplicate Netsエラーチェックによって検出されます。この状態のまま設計をPCBに転送することはできません。設計の転送時に、これら2つの別々のネットが1つのPCBネットに統合されてしまいます。
この状況は、Project Options ダイアログのOptionsタブでAppend Sheet Numbers to Local Netsオプションを有効にすることで解決できます。このオプションを有効にすると、以下の図に示すように、すべてのローカルネットの名前にSheetNumberパラメーターの値が付加されます。

ネットラベルInputが複数のシートで使用されているため、Duplicate Netsエラーを防ぐ目的でAppend Sheet Numbers to Local Netオプションを有効にしています。
コンパイル済みシートのタブをクリックすると、その効果を確認できます(右図)。ネット名に「_2」が付加されていることに注目してください。
2つのネットを意図的に接続する
異なる2つのネットを意図的に接続する必要がある場合があります。これは単なる名前の問題ではなく、設計要件として2つのネットを短絡する必要がある場合です。たとえば、アナロググランドとデジタルグランドを、接続箇所を管理したうえで接続する場合が挙げられます。
これは、Net Tieコンポーネントを介して2つのネットを接続することで実現できます。Net Tieコンポーネントは、接続箇所を管理できる短絡にすぎず、基板上のどこでネットを接続するかを決めることができます。回路図上では、Net Tieコンポーネントには2本以上のピンがあり、各ピンを短絡対象のネットのいずれかに接続します。コンポーネントのComponent Typeプロパティは、以下に示すようにNet Tieに設定します。

回路図上で、単一のクロックをFPGAの2つのクロックピンに配線するために使用されているNet Tieコンポーネント。
これらのピンは、回路図上では互いに配線されてnotおらず(回路図上では短絡していません)、PCBフットプリント内で互いに接続されてareいることに注意してください。
PCB側では、フットプリントに回路図シンボルのピンと同じ数のパッドがあり、パッド間は銅箔で接続されています。以下の図の例では、2つの正方形のパッドをトラックで接続することで実現しています。この作業は、PCBライブラリエディターでフットプリント内に対して行います。PCBのComponent TypeプロパティもNet Tieに設定します。
ソフトウェアは、Net Tie PCBコンポーネント内に作成された短絡を自動的に無視するため、DRCエラーは発生しません。

PCB上の同じNet Tieコンポーネント。Net Tieフットプリント内のパッド(選択状態)は、トラックで短絡されています。
Net Tieコンポーネントを使用して異なる2つのネットを接続した場合、各ネットは回路図全体およびPCB上でそれぞれの名前を保持します。
電源ネット
デフォルトの設定では、電源ネットはグローバル、つまり すべての回路図シートで使用するものとみなされます。電源ネットに接続するには、 必要なネット名を指定した電源ポートを配置し、その電源ポートにコンポーネントを配線します。設計がコンパイルされると、各電源ネットに接続されたすべてのピンが、 プロジェクト内のすべてのシートにわたって接続されます。

電源ポートの接続先ネットを決めるのは、シンボルのスタイルではなくネット名です。強調表示されている3つの電源ポートは、すべてGND電源ネットに接続されます。
電源ネットのローカル化 - 全体への適用
前述のとおり、階層設計では、ネット識別子のスコープでStrict Hierarchicalオプションを選択することにより、電源ネットを各回路図シート内にローカル化できます。この方法では、すべてのシートのすべての電源ネットがローカル化されるため、信号ネットと同じ方法で手動で配線して相互に接続する必要があります。相互に配線されていない場合は、 各回路図シートに存在する電源ネットごとにDuplicate Net Nameエラーが発生します。また、ポートを電源ポートに接続できるように、接続マトリクスの設定を調整する必要もあります。

Net Identifier ScopeがStrict Hierarchicalに設定されている場合、 すべての電源ネットを、それぞれが使用されるすべてのシートに配線する必要があります。
ローカル化された電源ネットのシート間接続
階層設計でローカル化された電源ネットは、他のネットと同様に、子シート上のポートから親シート上のシートシンボルのシートエントリへ接続します。ただし、電源ネットの場合、この方法で接続できるのは個別の電源ネットのみであり、バスにまとめられた電源ネット(
)は接続できません。
マルチチャネル設計を作成していて、Repeatステートメントを使用して各チャネルに固有の電源ネットを個別に供給したい場合(下図参照)は、シートエントリとポートの組み合わせを介して各チャネルに渡すネットが1つだけなので、この方法がサポートされます。各シートエントリとポートの組み合わせを介して、親から子へ個別の電源ネットのみを接続する設計であれば、ネットリストは正しく生成されます。
ローカル化された電源ネットは、バスとしてではなく個別のネットとして階層を上下する場合、マルチチャネル設計の各チャネルに分配できます。
電源ネットのローカル化 - 個別の適用
階層設計内の特定の電源ネット (つまり、Net Identifier ScopeがHierarchicalに設定された設計、または最上位シートにシートエントリがあり、 Net Identifier ScopeがAutomaticに設定された設計。詳しくは、ネット識別子のスコープの設定を参照) は、その回路図シート上で電源ポートをポートに配線することによって、特定のシート内にローカル化することもできます。

ここでは、3V3電源ネットがこのシートだけでローカル化されているため、親シート上でも手動で配線する必要があります。GNDネットと5Vネットは、引き続きグローバル電源ネットとして扱われます。
ダイナミックコンパイル
Related page: 設計プロジェクトの検証
2つのピンをワイヤで接続するときは、設計の意図を図面に表しているのであって、実際のネットを作成しているわけではありません。ネットは、プロジェクトがコンパイルされるまで作成されません。コンパイルでは、コンポーネントとその接続方法の詳細に加えて、コンポーネントおよび設計の詳細なパラメーター情報も抽出されます。コンパイルされたプロジェクトのモデルは、統合データモデルと呼ばれます。
設計データモデルは、ユーザーが操作するたびにダイナミックコンパイルによって差分更新され、ダイナミックデータモデル(DDM)と呼ばれるものが作成されます。プロジェクトを手動でコンパイルする必要はなく、すべて自動的に実行されます。ダイナミックコンパイルにより、設計の接続モデルはユーザーが操作するたびに差分更新されます。設計プロジェクトでは、自動コンパイル処理によって次の3つの機能が実行されます。
- 設計階層をインスタンス化します。
- すべての設計シート間のネット接続を確立します。
- 設計の内部ダイナミックデータモデル(DDM)を構築します。
これにより、設計に加えた変更は、 Navigatorおよび プロジェクト パネルに即座に反映されます。
DDMとコンパイラ設定の間で、論理的、電気的、および作図上のエラーをチェックするには、プロジェクトを検証する必要があります。このコマンドは、メインメニューからProject » Validate Project コマンドを選択するか、プロジェクトパネルでプロジェクトのエントリを右クリックし、コンテキストメニューから Validate Projectコマンドを選択して実行します。
コンパイラが検出した違反は、警告やエラーとしてMessagesパネルに一覧表示されます。 コンパイラは、ソースドキュメントの違反をチェックする際に、 Project Optionsダイアログの エラーレポート タブと 接続マトリクス タブで定義されたオプションを使用します(プロジェクトの種類に応じて適用されます)。
ダイナミックデータモデル
このソフトウェアの基本となる要素が、統合データモデル(UDM)です。動的コンパイルが自動的に実行されることで、設計プロセスの中心となる、単一の一貫したモデルが作成されます。モデル内のデータには、回路図エディターやPCBエディターをはじめ、ソフトウェア内のさまざまなエディターやサービスからアクセスし、操作できます。UDMは、設計領域ごとに個別のデータストアを使用するのではなく、コンポーネントやその接続情報など、設計のあらゆる側面に関するすべての情報を格納できる構造になっています。設計プロセスの中心となるこの単一の一貫したモデルは、設計の動的コンパイルによって作成されます。つまり、統合データモデルはプロジェクトを開いた時点から利用でき、追加の手動コンパイルを必要としない、真の動的データモデル(DDM)です。そのため、 ユーザーが操作するたびに、モデルが差分更新(コンパイル)されます。回路図設計内の要素を自由に配置、配線、再配置、名前変更、 追加、 削除できます。
PCB設計のコンパイルプロセスは、回路図エディターおよびPCBエディターの外部のコードによって管理されます。この方式には多くの利点がありますが、最大の利点は、設計の統合データモデルが個々の回路図エディターやPCBエディターの外部に存在することです。UDMには、設計内のすべてのコンポーネントの詳細な情報と、 それらの相互接続に関する情報が含まれています。

ソフトウェアは、回路図とPCBにわたる接続データを管理します。
コンパイルは動的に行われるため、以下の場所や操作では、設計のコンパイルに関して追加の手動操作は必要ありません。
- NavigatorおよびProjectsパネル
- ActiveBOM
- ECOの実行
- クロスプローブ
- ネットの色によるハイライト表示
- ピンスワップ
- コンポーネントの相互参照
では、たとえば設計全体にわたってネットをたどる場合、統合データモデルをどのように操作すればよいでしょうか。その操作にはNavigatorパネルを使用します。
接続の確認
Panel page: Navigatorパネル
設計が大規模で多数のシートにまたがる場合、設計内の接続をたどって確認することが難しくなります。この作業には、Navigatorパネル を利用できます。このパネルでは、コンパイル済みの設計全体を確認できます。
パネルの基本的な使用手順は次のとおりです。
-
パネル上部の
ボタンをクリックしてPreferencesダイアログを開き、必要なHighlight Methodsを有効にして、参照時の動作を設定します。または、下の画像に示すように、パネル内の対象オブジェクトを右クリックし、メニューのオプションを使用してナビゲーションの動作を設定します。
-
パネルのDocuments for領域で参照範囲を設定します。 設計全体を参照するには、
Flattened Hierarchyを選択します。 - リストの Instanceセクションでコンポーネントをクリックすると、そのコンポーネントにジャンプします。コンポーネントを展開すると、ピンを探したり、ピンにジャンプしたりできます。
- Net /Busセクションでネットまたはバスをクリックすると、そのネットまたはバスにジャンプします。
- Altキーを押しながらクリックすると、 回路図とPCBの両方でそのオブジェクトにジャンプします。

Navigatorパネルでコンポーネントまたはネットをクリックすると、そのコンポーネントまたはネットの位置を確認し、設計全体にわたって接続をたどることができます。右クリックすると、表示オプションにアクセスできます。画像にカーソルを合わせると、回路図とPCB上のコンポーネントに同時に移動する様子が表示されます(PCBオブジェクトも対象に含めるには、Altを押しながらNavigatorパネル内をクリックします)。
基板上のコンポーネントへの移動
Navigatorパネルから回路図およびPCB上のコンポーネントの位置を確認する(Altを押した場合)だけでなく、回路図から直接、PCB上のピン、コンポーネント、ネット、バス、ハーネスに移動することもできます。
たとえば、クリックして回路図上のコンポーネントの位置を確認すると、PCB上の同じコンポーネントの位置も確認できます。
これを行うには、次の手順に従います。
- Highlight MethodsのSelectingオプションを有効にし、PreferencesダイアログのSystem - NavigationページにあるCross Select Modeセクションで、必要なオプションも有効にします。
- 回路図エディターとPCBエディターの両方で、クロス選択(Tools » Cross Select Mode)を有効にします。

これらのオプションで、ナビゲーションとクロス選択の動作を設定します。
これで、下の画像に示すように、回路図上でピン、コンポーネント、ネット、バス、ハーネスを選択すると、PCB上でも対応するオブジェクトが選択されます。

回路図上でコンポーネントやネットを選択すると、PCB上でも対応するオブジェクトが選択されます。クロス選択は、PCBから回路図への方向でも機能します。
プロジェクト構造内でのコンポーネントとネットの検索
パネル内の構造をたどって目的のコンポーネントまたはネットを探し、そのオブジェクトをダブルクリックすると、プロジェクトの回路図ドキュメント内にある、そのオブジェクトのインスタンスが表示されます。Preferencesダイアログのシステム - ナビゲーションページにあるオプションを使用して、オブジェクトのハイライト動作(ズーム、淡色表示、選択など)を指定します。
プロジェクト内のオブジェクトへのナビゲーションは、Navigatorパネルでも利用できます。このパネルには、設計オブジェクトとその関連データが詳細な階層構造で表示されます。システム - ナビゲーションの環境設定によって、ProjectパネルとNavigatorパネルの両方でのオブジェクトのハイライト動作が決まります。
接続のハイライト表示
接続のナビゲーションオプションを使用すると、Projectsパネルで選択したオブジェクトの接続関係が表示されます。パネルのオブジェクト階層リストでネットなどの項目をダブルクリックすると、回路図内の相互接続がハイライト表示されます。
プレビュー機能は、PreferencesダイアログのSystem – NavigationページにあるHighlight MethodsセクションのConnectivity Graphオプションで有効にします。選択したオブジェクトに関連付けられた電源オブジェクトの接続も表示するには、追加の Include Power Partsオプションを選択します。
グローバルネットハイライト
Altキーを押しながらワイヤをクリックしてネットを選択すると(Alt+Click)、設計全体にわたるネットの接続を、すべての回路図でハイライト表示できます。そのネットのすべての回路図インスタンスがハイライト表示され、その他のオブジェクトは淡色表示されるため、1回の簡単な操作で、設計内の信号や電源の伝播を視覚的に確認できます。
ネットのハイライトは何もない場所をクリックすると解除され、その動作はPreferencesダイアログのSystem - NavigationページにあるHighlight Methodsの設定によって決まります。Dimmingオプションのチェックを外すと、ネットハイライト機能が無効になることに注意してください。
ネットの色の設定
Main page: ネットへの色の適用
回路図を見やすくし、PCBエディターでネットや配線を扱いやすくするために、回路図のワイヤ、およびPCBのネットや配線に色を適用できます。
下図に示すように、回路図エディターでは、View » Set Net Colorsサブメニューの コマンドを使用して、ネットやバスにハイライト色を適用できます。 これらの色は、Update PCBコマンドでいつでもPCBエディターに転送できます。
PCBエディターでは、Connection Linesのデフォルトの色と表示状態を、PCBのView ConfigurationパネルにあるSystem Colorsセクションで設定します。このデフォルトの色は、ネットの作成時(回路図から設計を初めて転送するとき)に適用されます。このオプションを変更しても、既存の接続線の色は変わらないことに注意してください。
PCBエディターでは、各ネットに適用された色が、PCBパネルのNetsモードに表示されます。下図の右下に示すように、ネット名の横にあるチェックボックスの背景色を確認してください。
未配線のネット(接続線)には常に色が適用されます。配線済みのネットに色を表示するには、PCBパネルでネット名の横にあるチェックボックスをオンにし、PreferencesダイアログのBoard Insight Color Overridesページで表示オプションを設定します。下図では、色のオーバーライドのBase PatternをSolidに、Zoom Out BehaviorをOverride Color Dominatesに設定しています。
回路図に適用したネットの色は、Update PCBコマンドによってPCBに転送されます。基板上での表示方法は、PCBの色のオーバーライド機能を設定して制御します。
PCBネットの色の変更
回路図のワイヤに色を適用してPCBに転送できるとは限りません。そのような場合でも、PCBエディターで接続線や配線に色を適用できます。設計を転送した後でネットの色を変更するには、PCBパネルのNetsモードでネット名をダブルクリックします。個々のネットの色は、Edit Netダイアログで編集できます。
複数のネットの色を変更するには、PCBパネルのNetsモードを使用します。
- Windowsの標準的な複数選択操作(Shift+clickまたはCtrl+click)を使用して、複数のネットクラスまたは複数の個別ネットを選択します。
- 選択したオブジェクトを右クリックし、コンテキストメニューからChange Net Colorコマンドを選択して、選択したネットに新しい色を割り当てます。
- もう一度右クリックしてDisplay Override » Selected Onを選択し、選択したネットの色のオーバーライド機能を有効にします。

接続線の色を変更し、表示のオーバーライド機能を有効にすることで、ネットの視認性を向上できます。























