回路図とPCBの間においてのデザイン変更の管理
概略
- プロジェクトでConstraint ManagerとPCB Rule and Constraints Editorのどちらを使用しているかを確認する方法と、関連設定にアクセスする場所を学びます。
- プロジェクトオプション、比較設定、ECOの生成が、回路図からPCBに反映される変更内容にどのように影響するかを理解します。
- クロスプローブとクロスセレクトを使って、各エディターで対応するオブジェクトを確認し、設計更新時の作業効率を高める方法を紹介します。
Constraint Managerを使用した設計要件の定義
設計制約は、PCB設計で従うべき一連の指示を構成します。クリアランス、配線幅、トポロジーなど、設計のあらゆる側面を網羅します。PCB設計で使用する設計制約の表示、作成、管理には、Constraint Managerを使用します。Constraint Managerは、設計制約を定義するための統一された表形式のスプレッドシートに似た編集インターフェースを提供し、回路図とPCBの両方からアクセスできます。この強力かつ効率的なアプローチにより、組織内で役割の異なるエンジニア間の連携が促進され、より幅広い関係者が共同で設計に必要な制約を定義できるようになります。
Constraint Managerには、回路図エディターまたはPCBエディターのメインメニューからDesign » Constraint Managerコマンドを選択してアクセスできます。Constraint Managerには、さまざまな種類の制約を定義するための複数のビューがあります。Constraint Managerの上部にあるボタンを使用して、次のビューを切り替えます。
-
Clearances – ネットクラス間の電気的クリアランスを定義できるクリアランスマトリックス。
-
Physical – ネット、差動ペア、xNet、およびそれらのクラスの一覧。導体の幅や差動ペアの間隔など、設計の物理的制約を定義できます。
-
Electrical – ネット、xNet、xSignal、およびそれらのクラスの一覧。トポロジーやインピーダンスなど、設計の電気的制約を定義できます。
PCBエディターからConstraint Managerにアクセスすると、追加のAll Rulesビューを使用できます。これは設計制約をルール中心に表示するビューで、PCB設計内のすべてのルールが一覧表示され、クエリに基づいてカスタムルールを作成できます。
変更を設計に反映するには、Constraint Managerで保存を実行する必要があります。これを行うには、Constraint ManagerのメインメニューからFile » Save(回路図からConstraint Managerにアクセスした場合)またはFile » Save to PCB(PCBからConstraint Managerにアクセスした場合)コマンドを使用するか、Ctrl+Sショートカットを使用します。
回路図側からアクセスしたConstraint Managerで定義した制約は、以下で説明する通常のECO(Engineering Change Order:設計変更指示)プロセス中にPCB設計へ転送されます。
PCBへの転送に向けたプロジェクトの設定
Project Optionsダイアログには、回路図設計とPCBレイアウト間で転送するデータを制御するさまざまな設定があります。このダイアログにアクセスするには、Projectsパネルでプロジェクトの項目を右クリックし、コンテキストメニューからProject Optionsコマンドを選択します。
設計を転送する際に同期する内容を設定するには、ダイアログの次のタブを使用します。
|
Class Generation – コンポーネントクラスとネットクラスの生成を設定および制御できます。たとえば、特定の回路図シートに配置されたコンポーネントをコンポーネントクラスにまとめたり、バスにまとめられたネットをネットクラスにまとめたりできます。また、このタブでは、配置された設計ディレクティブから派生するユーザー定義クラスの生成も設定できます。詳細については、回路図とPCBでのクラスの操作を参照してください。 Comparator – ドキュメントの比較時に検出する差異と無視する差異の種類、つまり比較対象となる回路図とPCBのデータを具体的に定義できます。比較の種類ごとにMode列を使用して、 ECO Generation – データ転送時に、どの設計変更(比較機能で検出された差異に基づく変更)に対して設計変更指示(ECO)を生成できるかを定義できます。変更の種類ごとにMode列を使用して、 |
PCBへの設計情報の転送
設計の同期は、回路図エディターとPCBエディターの間で直接実行されます。PCBドキュメントをプロジェクトに追加し、ハードドライブに保存したら、回路図エディターのメインメニューからDesign » Update PCB Document <PCBDocumentName>コマンドを選択して、Engineering Change Orderダイアログを開きます。このダイアログには、現在のプロジェクトオプションに従ってPCBを回路図と一致させるために必要な変更(Engineering Change Order – ECO)の一覧が表示されます。
-
必要に応じて、ダイアログ内の変更項目を有効または無効にできます。
-
Validate Changesボタンをクリックすると、ECOに含めるよう有効にした変更に対して検証チェックが実行されます。検証結果は、ダイアログのStatus 領域にあるCheck 列に表示されます。
-
実行する変更内容を確認し、問題がなければ、 Execute Changes ボタンをクリックしてECOを実行し、その中に含まれる有効な変更を適用します。実行結果は、ダイアログの Status 領域にある Done 列に表示されます。
Execute Changes ボタンをクリックすると、変更がPCBドキュメントに適用され、Engineering Change Orderダイアログを閉じることができます。新規作成したPCBでは、回路図の設計に従って、コンポーネントのフットプリントが基板の外側に配置され、フットプリントのパッド間に接続線が表示されます。
設計を初めてPCBに転送した後も、回路図側で加えた変更は同じ手順でPCBに転送できます。
クロスプローブ
クロスプローブは、現在のエディターでオブジェクトをクリックして、他のエディターでそのオブジェクトを見つける機能です。例えば、回路図エディターの Tools » Cross Probe コマンドを実行した後、回路図上のコンポーネントをクリックすると、PCB上の同じコンポーネントを表示できます。このコマンドは、コンポーネント、バス、ネット、ピン/パッド間のクロスプローブに対応しています。
クロス選択
クロス選択機能は、PCBドキュメントと回路図ドキュメントの間で、対応するオブジェクトを選択するために使用します。つまり、PCBドキュメントでオブジェクトを選択すると、元の回路図ドキュメントでも同じオブジェクトが選択されます。逆の場合も同様です。
クロス選択機能を有効にするには、回路図エディターまたはPCBエディターのメインメニューから Tools » Cross Select Mode コマンドを選択します。 このコマンドで機能のオン/オフを切り替えることができ、メニュー内のコマンドアイコンに現在の状態が表示されます。





